Routing IP: Guía de configuración de OSPF, Cisco IOS Release 12.2SR
OSPF Per-Interface Link-Local Signaling
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 145 KB | Inglés (1 Noviembre 2011) | Comentarios

OSPF Per-Interface Link-Local Signaling

Última actualización: 1 de noviembre de 2011

La función OSPF Per-Interface Link-Local Signaling permite habilitar o inhabilitar selectivamente Link-Local Signaling (LLS) para una interfaz específica con independencia de la configuración global (en el nivel de router) que se haya configurado previamente.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Información sobre OSPF Per-Interface Link-Local Signaling

Ventajas de la Función OSPF Per-Interface Link-Local Signaling

Los LL permiten la extensión de los paquetes OSPF existentes para proporcionar el espacio del bit adicional. El espacio del bit adicional habilita la mayor información por el intercambio de paquetes entre los vecinos OSPF. Estas funciones son utilizadas, por ejemplo, por la característica directa de la conciencia de la expedición OSPF (NSF) que permite al Routers del Customer Premises Equipment (CPE) que es consciente ayudar al Routers con capacidad para NSF a realizar la expedición directa de los paquetes.

Cuando los LL se habilitan en el nivel del router, se habilita automáticamente para todas las interfaces. La característica de la señalización del local de la conexión del por interface OSPF permite que usted habilite o que inhabilite selectivamente los LL para una interfaz específica. Usted puede querer inhabilitar los LL sobre una base del por interface dependiendo de su diseño de red. Por ejemplo, inhabilitar los LL en una interfaz que esté conectada con dispositivo no Cisco que puede ser noncompliant con el RFC 2328 puede prevenir los problemas con la formación de los vecinos del Open Shortest Path First (OSPF) en la red.

Cómo configurar la señalización del local de la conexión del por interface OSPF

Apagar los LL sobre una base del por interface

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. slot /port del tipo de interfaz

4. [secondary] de la máscara del IP address del IP Address

5. ningún broadcast dirigido del IP [access-list-number | access-list-number extendido]

6. clave del md5 del tipo de encripción clave-identificación del message-digest-key OSPF del IP

7. [no | [disable] de los lls OSPF del IP del valor por defecto]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
slot /port del tipo de interfaz


Ejemplo:

Interfaces Ethernet 1/0 de Router(config)#



Ejemplo:

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

 
Paso 4
[secondary] de la máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 10.2.145.20 255.255.255.0

 

Fija una dirección IP primaria o secundaria para una interfaz.

 
Paso 5
ningún broadcast dirigido del IP [access-list-number | access-list-number extendido]


Ejemplo:

Router (config-if) # ningún broadcast dirigido del IP

 

Cae los broadcastes dirigidos destinados para la subred a la cual se asocia esa interfaz, bastante que transmitiendola.

  • La expedición de los broadcastes dirigidos por IP en la interfaz de Ethernet 1/0 se inhabilita.
 
Paso 6
clave del md5 del tipo de encripción clave-identificación del message-digest-key OSPF del IP


Ejemplo:

Router (config-if) # prueba del md5 del message-digest-key 100 OSPF del IP

 

Autenticación del algoritmo de la publicación de mensaje 5 de los permisos OSPF (MD5).

 
Paso 7
[no | [disable] de los lls OSPF del IP del valor por defecto]

Ejemplo:

Router (config-if) # neutralización de los lls OSPF del IP

 

Neutralizaciones LL en una interfaz, sin importar (router llano) la configuración global.

 

Pasos Siguientes

Para verificar que los LL se hayan habilitado o se hayan inhabilitado para una interfaz específica, utilice el comando show ip ospf interface. Vea el “ejemplo: Configurando y verificando sección OSPF del por interface del local de la conexión de la característica de la señalización” por un ejemplo de la información visualizada.

Ejemplos de configuración para la señalización del local de la conexión del por interface OSPF

Señalización del local de la conexión del por interface del ejemplo OSPF

En el siguiente ejemplo, los LL se han habilitado en la interfaz de Ethernet 1/0 y se han inhabilitado en la interfaz de Ethernet 2/0:

interface Ethernet1/0
 ip address 10.2.145.2 255.255.255.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 testing
 ip ospf lls
!
interface Ethernet2/0
 ip address 10.1.145.2 255.255.0.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 testing
!
 ip ospf lls disable
interface Ethernet3/0
 ip address 10.3.145.2 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 log-adjacency-changes detail
 area 0 authentication message-digest
 redistribute connected subnets
 network 10.0.0.0 0.255.255.255 area 1
 network 10.2.3.0 0.0.0.255 area 1

En el siguiente ejemplo, han ingresado al comando show ip ospf interface de verificar que los LL se han habilitado para la interfaz de Ethernet 1/0 y se han inhabilitado para las interfaces Ethernet 2/0:

Router# show ip ospf interface
Ethernet1/0 is up, line protocol is up 
  Internet Address 10.2.145.2/24, Area 1 
  Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 10.2.2.3, Interface address 10.2.145.1
  Backup Designated router (ID) 10.22.222.2, Interface address 10.2.145.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
!   Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 8
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 10.2.2.3  (Designated Router)
  Suppress hello for 0 neighbor(s)
Ethernet2/0 is up, line protocol is up 
  Internet Address 10.1.145.2/16, Area 1 
  Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 10.2.2.3, Interface address 10.1.145.1
  Backup Designated router (ID) 10.22.222.2, Interface address 10.1.145.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
!   Does not support Link-local Signaling (LLS)
Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 11
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 45.2.2.3  (Designated Router)
    Suppress hello for 0 neighbor(s)
Ethernet3/0 is up, line protocol is up 
  Internet Address 10.3.145.2/24, Area 1 
  Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 10.2.2.3, Interface address 10.3.145.1
  Backup Designated router (ID) 10.22.222.2, Interface address 10.3.145.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
!   Supports Link-local Signaling (LLS)
Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 11
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 10.2.2.3  (Designated Router)
  Suppress hello for 0 neighbor(s)

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con la característica de la señalización del local de la conexión del por interface OSPF.

Documentos Relacionados

Tema relacionado

Título del documento

Configurar el OSPF

“Configurando el OSPF”

Configurar la conciencia OSPF NSF

“NSF-OSPF”

Comandos OSPF

Routing IP del Cisco IOS: Referencia del comando ospf

Estándares

Estándares

Título

Ninguno

--

MIB

MIB

Link del MIB

Ninguno

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 2328

Versión 2 OSPF

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre la Función OSPF Per-Interface Link-Local Signaling

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información sobre la Función OSPF Per-Interface Link-Local Signaling

Nombre de la función

Versiones

Información sobre la Función

OSPF Per-Interface Link-Local Signaling

12.0(27)S 12.3(7)T 12.2(25)S 12.2(18)SXE 12.2(27)SBC 12.2(33)SRA

La función OSPF Per-Interface Link-Local Signaling permite habilitar o inhabilitar selectivamente Link-Local Signaling (LLS) para una interfaz específica con independencia de la configuración global (en el nivel de router) que se haya configurado previamente.

El siguiente comando fue introducido o modificado: lls OSPF del IP.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.