Routing IP: Guía de configuración de OSPF, Cisco IOS Release 12.2SR
Supresión de la Dirección de Reenvío OSPF en los LSAs Traducidos de Tipo 5
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 142 KB | Inglés (1 Noviembre 2011) | Comentarios

Supresión de la Dirección de Reenvío OSPF en los LSAs Traducidos de Tipo 5

Última actualización: 1 de noviembre de 2011

La supresión del OSPF Forwarding Address en la característica tipa 5 traducida LSA hace un router del borde del área de la área no exclusiva de rutas internas (NSSA) (ABR) traducir Type-7 los anuncios del estado del link (LSA) a los LSA tipos 5, pero utiliza el direccionamiento 0.0.0.0 para la dirección de reenvío en vez de ése especificada en Type-7 el LSA. Esta característica causa al Routers que se configura para no hacer publicidad de las direcciones de reenvío en la estructura básica para dirigir el tráfico remitido al NSSA que traduce ABR.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Prerrequisitos de OSPF Forwarding Address Suppression in Translated Type-5 LSAs

Este documento supone que usted tiene OSPF configurado en el dispositivo de interconexión de redes; no documenta otros pasos para configurar el OSPF.

Información sobre OSPF Forwarding Address Suppression in Translated Type-5 LSAs

Ventajas de OSPF Forwarding Address Suppression in Translated Type-5 LSAs

La supresión del OSPF Forwarding Address en la característica tipa 5 traducida LSA hace un NSSA ABR traducir Type-7 los LSA a los LSA tipos 5, pero utiliza 0.0.0.0 como la dirección de reenvío en vez de ése especificada en Type-7 el LSA. Esta característica causa al Routers que se configura para no hacer publicidad de las direcciones de reenvío en la estructura básica para dirigir el tráfico remitido al NSSA que traduce ASBR.

Cuándo Suprimir la Dirección de Reenvío OSPF en LSAs de Tipo 5 Traducidos

En la figura abajo, sería ventajoso a los direccionamientos del área de filtro 2 del área 0 minimizar el número de rutas introducidas en la estructura básica (área 0). Sin embargo, usando el rangecommand del área para consolidar y para resumir las rutas en el límite de área--filtración de los direccionamientos del área 2--no trabajará porque los direccionamientos del área 2 incluyen a las direcciones de reenvío para Type-7 los LSA que son generados por el ASBR. Si han filtrado a estas Type-7 direcciones de reenvío LSA fuera del área 0, los routeres de estructura básica no pueden alcanzar los prefijos des divulgación en los LSA tipos 5 traducidos (LSA externo del sistema autónomo).

Figura 1Supresión de la Dirección de Reenvío OSPF en los LSAs Traducidos de Tipo 5


Este problema es solucionado suprimiendo a la dirección de reenvío en el ABR para fijar la dirección de reenvío a 0.0.0.0 en los LSA tipos 5 que fueron traducidos Type-7 de los LSA. Un conjunto de la dirección de reenvío a 0.0.0.0 indica que los paquetes para el destino externo se deben remitir al router para OSPF de la publicidad, en este caso, el NSSA que traduce ABR.

Antes de configurar esta función, tenga en cuenta la siguiente precaución.


Precaución


Configurar esta característica hace al router ser noncompliant con el RFC 1587. Además, podría producirse un ruteo subóptimo, porque podría haber mejores trayectorias para alcanzar la dirección de reenvío del destino. Esta función no se debe configurar sin una planificación apropiada y sin entender antes la topología de red.


Cómo Suprimir la Dirección de Reenvío OSPF en LSAs de Tipo 5 Traducidos

Omisión de OSPF Forwarding Address in Translated Type-5 LSAs


Precaución


Configurar esta característica hace al router ser noncompliant con el RFC 1587. Además, podría producirse un ruteo subóptimo, porque podría haber mejores trayectorias para alcanzar la dirección de reenvío del destino. Esta función no se debe configurar sin una planificación apropiada y sin entender antes la topología de red.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. router ospf process-id

4. el nssa del ID de área del área traduce type7 suprimir-fa

5. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita niveles de privilegio más altos, como el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id


Ejemplo:

OSPF 1 del router de Router(config)#

 

Habilita el ruteo OSPF e ingresa al modo de configuración de router.

  • El argumento process-id identifica el proceso OSPF.
 
Paso 4
el nssa del ID de área del área traduce type7 suprimir-fa


Ejemplo:

El router (config-router) # nssa del área 10 traduce type7 suprimir-fa

 

Configura un área como área no exclusiva de rutas internas (NSSA) y suprime a la dirección de reenvío en Type-7 traducidos los LSA.

 
Paso 5
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Salidas modo de configuración y devoluciones al modo EXEC privilegiado.

 

Ejemplos de Configuración de OSPF Forwarding Address Suppression in Translated Type-5 LSAs

Ejemplo que suprime el OSPF Forwarding Address en los LSA tipos 5 traducidos

Este ejemplo suprime a la dirección de reenvío en los LSA tipos 5 traducidos:

interface ethernet 0
 ip address 10.93.1.1 255.255.255.0
 ip ospf cost 1
!
interface ethernet 1
 ip address 10.94.1.1 255.255.255.0
!
router ospf 1
 network 10.93.0.0 0.0.255.255 area 0.0.0.0
 network 10.94.0.0 0.0.255.255 area 10
 area 10 nssa translate type7 suppress-fa

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Comandos OSPF

Routing IP del Cisco IOS: Referencia del comando ospf

Estándares

Estándares

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Configurar la supresión del OSPF Forwarding Address en la característica tipa 5 traducida LSA hace al router ser noncompliant con el RFC 1587.

La opción OSPF NSSA

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información de la característica para la supresión del OSPF Forwarding Address en los LSA tipos 5 traducidos

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para la supresión del OSPF Forwarding Address en los LSA tipos 5 traducidos

Nombre de la función

Versiones

Información sobre la Función

Supresión de la Dirección de Reenvío OSPF en los LSAs Traducidos de Tipo 5

Cisco IOS XE 3.1.0 SG 12.2(15)T 12.2(18)S 12.2(27)SBC

La supresión del OSPF Forwarding Address en la característica tipa 5 traducida LSA hace un router del borde del área de la área no exclusiva de rutas internas (NSSA) (ABR) para traducir Type-7 los anuncios del estado del link (LSA) a los LSA tipos 5, pero para utilizar el direccionamiento 0.0.0.0 para la dirección de reenvío en vez de ése especificada en Type-7 el LSA. Esta característica causa al Routers que se configura para no hacer publicidad de las direcciones de reenvío en la estructura básica para dirigir el tráfico remitido al NSSA que traduce ABR.

Se introducen o se modifican los siguientes comandos:

  • el nssa del área traduce
  • show ip ospf

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.