Routing IP: Guía de configuración de OSPF, Cisco IOS Release 12.2SR
OSPF Support for Multi-VRF on CE Routers
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 145 KB | Inglés (1 Noviembre 2011) | Comentarios

OSPF Support for Multi-VRF on CE Routers

Última actualización: 1 de noviembre de 2011

La función OSPF Support for Multi-VRF on CE Routers proporciona la capacidad de omitir las verificaciones del borde del proveedor (PE) que son necesarias para evitar los loops cuando el PE está realizando una redistribución recíproca de los paquetes entre los protocolos OSPF y BGP. Cuando el ruteo y reenvío VPN (VRF) se utiliza en un router que no es un PE (es decir, que no ejecuta BGP), las verificaciones se pueden desactivar para permitir que la tabla de ruteo VRF se llene correctamente con rutas a los prefijos IP.

MultiVRF de OSPF permite dividir el router en varios routers virtuales, donde cada router contiene su propio conjunto de interfaces, tabla de ruteo y tabla de reenvío.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Información sobre el Soporte OSPF para Multi-VRF en Routers CE

La función OSPF Support for Multi-VRF on CE Routers proporciona la capacidad de omitir las verificaciones del borde del proveedor (PE) que son necesarias para evitar los loops cuando el PE está realizando una redistribución recíproca de los paquetes entre los protocolos OSPF y BGP. Cuando el ruteo y reenvío VPN (VRF) se utiliza en un router que no es un PE (es decir, que no ejecuta BGP), las verificaciones se pueden desactivar para permitir que la tabla de ruteo VRF se llene correctamente con rutas a los prefijos IP.

MultiVRF de OSPF permite dividir el router en varios routers virtuales, donde cada router contiene su propio conjunto de interfaces, tabla de ruteo y tabla de reenvío. El OSPF MULTI-VRF le da la capacidad de dividir las partes de en segmentos su red y de configurar esos segmentos para realizar las funciones específicas, con todo todavía mantiene la información de ruteo correcta.

Cómo Configurar el Soporte OSPF para Multi-VRF en Routers CE

Configuración de la Capacidad MultiVRF para el Ruteo OSPF

Antes de comenzar

El CEF debe ejecutarse en la red.


PASOS SUMARIOS

1. permiso

2. muestre el [process-id] OSPF del IP

3. configuró terminal

4. [vrf vpn-name] del router ospf process-id

5. capacidad VRF-lite


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita niveles de privilegio más altos, como el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
muestre el [process-id] OSPF del IP


Ejemplo:

OSPF 1 del IP de la demostración del Router>

 

Visualiza el estatus del router. Si la visualización indica que el router está conectado con la estructura básica VPN, usted puede utilizar el comando de VRF-lite de la capacidad de desemparejar al router PE de la estructura básica VPN.

 
Paso 3
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 4
[vrf vpn-name] del router ospf process-id


Ejemplo:

Grc del vrf OSPF 1 del router de Router(config)#

 

Habilita el ruteo OSPF e ingresa al modo de configuración de router.

  • El argumento process-id identifica el proceso OSPF.
  • Utilice la palabra clave vrf y el argumento vpn-name para identificar una VPN.
 
Paso 5
capacidad VRF-lite


Ejemplo:

Capacidad VRF-lite de Router(config)#

 

Aplica la capacidad multi-VRF al proceso OSPF.

 

Verificación de la Configuración de Multi-VRF OSPF

No se asocia a ningunos comandos debug or show específicos a esta característica. Usted puede verificar el éxito de la configuración OSPF MULTI-VRF usando el comando del [process-id] OSPF del IP de la demostración de verificar que el router no esté conectado con la estructura básica VPN.

Esta salida del processcommand OSPF del IP de la demostración indica que el router PE está conectado actualmente con la estructura básica.

Router# show ip ospf 12
 Routing Process "ospf 12" with ID 151.1.1.1 and Domain ID 0.0.0.12
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN Superbackbone
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 0. 0 normal 0 stub 0 nssa
 External flood list length 0

Cuando el proceso OSPF VRF se configura con el comando de VRF-lite de la capacidad bajo comando router ospf , “conectado con el MPLS VPN la línea de Superbackbone” no estará presente en la visualización.

Ejemplos de Configuración de OSPF Support for Multi-VRF on CE Routers

Ejemplo que configura la capacidad Multi-VRF

Este ejemplo muestra OSPF básico una red con un grc nombrado VRF configurado. La capacidad VRF-litecommand se ingresa para suprimir los controles PE.

!
ip cef
ip vrf grc
   rd 1:1
interface Serial2/0
  ip vrf forwarding grc
  ip address 192.168.1.1 255.255.255.252
!
interface Serial3/0
  ip vrf forwarding grc
  ip address 192.168.2.1 255.255.255.252
...
!
router ospf 9000 vrf grc
  log-adjacency-changes
  capability vrf-lite
  redistribute rip metric 1 subnets
  network 192.168.1.0 0.0.0.255 area 0
!
router rip
  address-family ipv4 vrf grc
  redistribute ospf 9000 vrf grc
  network network 192.168.2.0
  no auto-summary
  end
Router# show ip route vrf grc
Routing Table: grc
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
O IA 192.168.192.0/24 [110/138] via 192.168.1.13, 00:06:08, Serial2/0
                      [110/138] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.242.0/24 [110/74] via 192.168.1.13, 00:06:08, Serial2/0
O IA 192.168.193.0/24 [110/148] via 192.168.1.13, 00:06:08, Serial2/0
                      [110/148] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.128.0/24 [110/74] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.129.0/24 [110/84] via 192.168.1.9, 00:06:08, Serial3/0
O IA 192.168.130.0/24 [110/84] via 192.168.1.9, 00:06:08, Serial3/0
     172.16.0.0/24 is subnetted, 2 subnets
O E2    172.16.9.0 [110/5] via 192.168.1.13, 00:06:08, Serial2/0
O E2    172.16.10.0 [110/5] via 192.168.1.13, 00:06:08, Serial2/0
O IA 192.168.131.0/24 [110/94] via 192.168.1.9, 00:06:20, Serial3/0
     192.168.1.0/30 is subnetted, 4 subnets
C       192.168.1.8 is directly connected, Serial3/0
C       192.168.1.12 is directly connected, Serial2/0
O       192.168.1.0 [110/128] via 192.168.1.9, 00:06:20, Serial3/0
O       192.168.1.4 [110/128] via 192.168.1.13, 00:06:20, Serial2/0

Ejemplo que verifica la configuración OSPF MULTI-VRF

Este ejemplo ilustra la visualización de la salida del comando del proceso OSPF del IP de la demostración después de que el OSPF MULTI-VRF se haya configurado en el router.

Router# show ip ospf database external 172.16.0.0 self
            OSPF Router with ID (10.0.0.1) (Process ID 100)
                 Type-5 AS External Link States
   LS age: 175
   Options: (No TOS-capability, DC)
   LS Type: AS External Link
   Link State ID: 172.16.0.0 (External Network Number )
   Advertising Router: 10.0.0.1
   LS Seq Number: 80000001
   Checksum: 0xEA9E
   Length: 36
   Network Mask: /8
         Metric Type: 2 (Larger than any link state path)
         MTID: 0
         Metric: 20
         Forward Address: 0.0.0.0
         External Route Tag: 0

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Configurar el OSPF

Configurar el OSPF

Multiprotocol Label Switching (MPLS)

Soporte MPLS Multi-VRF (VRF Lite)

Estándares

Estándares

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.

--

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información de la característica para el soporte OSPF para el Multi-VRF en el Routers CE

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para el soporte OSPF para el Multi-VRF en el Routers CE

Nombre de la función

Versiones

Información sobre la Función

OSPF Support for Multi-VRF on CE Routers

Cisco IOS XE 3.1.0 SG del 12.0(21)ST 12.0(22)S 12.2(8)B 12.2(13)T 12.2(14)S

El soporte OSPF para el Multi-VRF en la característica del Routers CE proporciona la capacidad para suprimir los controles del borde del proveedor (PE) que son necesarios prevenir los loopes cuando el PE está realizando una redistribución recíproca de los paquetes entre el OSPF y los protocolos BGP. Cuando el VPN Routing and Forwarding (VRF) se utiliza en un router que no sea un PE (es decir, uno que no está ejecutando el BGP), los controles se pueden apagar para tener en cuenta la población correcta de la tabla de ruteo VRF con las rutas a los prefijos IP.

Los siguientes comandos se introducen o se modifican en la característica documentada en este módulo:

  • capacidad VRF-lite

Glosario

Router CE --Router borde del cliente, un router de borde en la red del C, definida como router A.C. que asocia directamente a un router P.

Red del C --Red del cliente (empresa o proveedor de servicio).

Router del C --Router del cliente, un router en la red del C.

LSA --anuncio del estado del vínculo. Paquete de broadcast usado por los protocolos del link-state que contiene la información sobre los vecinos y los costos del trayecto. Los LSA se utilizan por los routers receptores para mantener sus tablas de ruteo.

Router PE --Router de borde del proveedor, un router de borde en la red P, definida como router P que asocia directamente al router A.C.

Red P --Red del núcleo con capacidad para MPLS del proveedor de servicio. El Routers P realiza el MPLS.

Router P --Router del proveedor, un router en la red P.

SPF --trayecto más corto primero. Un algoritmo de ruteo que itera en la longitud de la trayectoria para determinar un Shortest-Path que atraviesa - árbol.

VPN --Red privada virtual. Permite que el tráfico IP se transfiera con seguridad a través de una red TCP/IP pública mediante el cifrado de todo el tráfico de una red a otra.

VRF --VPN Routing and Forwarding.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.