Routing IP: Guía de configuración de OSPF, Cisco IOS Release 12.2SR
Configurar el OSPF
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 342 KB | Inglés (1 Noviembre 2011) | Comentarios

Contenido

Configurar el OSPF

Última actualización: 1 de noviembre de 2011

Este módulo describe cómo configurar el Open Shortest Path First (OSPF). El OSPF es un Interior Gateway Protocol (IGP) desarrollado por el Grupo de trabajo OSPF de la Fuerza de tareas de ingeniería en Internet (IETF) (IETF). El OSPF fue diseñado expreso para las redes IP y soporta conexión en subredes IP y el marcar con etiqueta de la información de ruteo externamente derivada. El OSPF también permite la autenticación de paquete y utiliza el Multicast IP al enviar y recibiendo los paquetes.

Cisco soporta el RFC 1253, Management Information Base de la versión 2 OSPF, agosto de 1991. El OSPF MIB define un IP Routing Protocol que proporcione la Administración relacionada con la información al OSPF y sea soportado por los routeres Cisco.

Para las características del protocolo independiente que trabajan con el OSPF, vea “configurando el módulo de las características IP Routing Protocol-Independent”.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Información sobre el OSPF

Implementación de OSPF de Cisco

La implementación de Cisco se ajusta a las especificaciones de la versión 2 OSPF detalladas en el RFC 2328 de Internet. La lista que sigue delinea las características fundamentales soportadas en la implementación de OSPF de Cisco:

  • Zonas fragmentadas--La definición de las zonas fragmentadas se soporta.
  • Redistribución de ruta--Las rutas aprendidas vía cualquier IP Routing Protocol se pueden redistribuir en cualquier otro IP Routing Protocol. En el nivel del intradomain, el OSPF puede importar las rutas aprendidas vía el Interior Gateway Routing Protocol (IGRP), el Routing Information Protocol (RIP), y el Intermediate System-to-Intermediate System (IS-IS). Las OSPF rutas se pueden también exportar en el IGRP, el RIP, y el IS-IS. En el nivel del interdomain, el OSPF puede importar las rutas aprendidas vía el Exterior Gateway Protocol (EGP) y el Border Gateway Protocol (BGP). Las OSPF rutas se pueden exportar en el BGP y el EGP.
  • Autenticación--La autenticación del sólo texto y del algoritmo condensado de mensaje 5 (MD5) entre los routeres de la vencidad dentro de un área se soporta.
  • Rutear los parámetros de la interfaz--Los parámetros configurables soportados incluyen el coste de la salida de la interfaz, intervalo de retransmisión, interfaz transmiten el retardo, prioridad del router, router “muertos” y intervalos de saludo, y clave de autenticación.
  • Links virtuales--Se soportan los links virtuales.
  • Área no exclusiva de rutas internas (NSSA)--RFC 3101. En las versiones del Cisco IOS Release 15.1(2)S y Posterior, el RFC 3101 substituye el RFC 1587.
  • OSPF sobre el circuito de la demanda--RFC 1793.

Coordinación del router para el OSPF

El OSPF requiere típicamente la coordinación entre muchos routeres internos: Routeres del borde del área (ABR), que son Routers conectado con las áreas múltiples, y Autonomous System Boundary Router (ASBR). Al mínimo, el Routers basado en OSPF o el Access Server puede ser configurado con todos los valores de parámetro predeterminados, ninguna autenticación, y las interfaces asignadas a las áreas. Si usted se prepone personalizar su entorno, usted debe asegurar las configuraciones coordinadas de todo el Routers.

Distribución del Route para el OSPF

Usted puede especificar la redistribución de ruta; vea la tarea “redistribuir la información de ruteo” en los Network Protocol guía de configuración, la parte 1 para la información sobre cómo configurar la redistribución de ruta.

La implementación de OSPF de Cisco permite que usted altere ciertos parámetros interfaz-específicos OSPF, según las necesidades. Le no requieren alterar ninguno de estos parámetros, pero algunos parámetros de la interfaz deben ser constantes a través de todo el Routers en una red conectada. Esos parámetros son controlados por el intervalo de saludo OSPF del IP, el Intervalo muerto OSPF del IP, y los comandos interface configuration de la clave de autenticación OSPF del IP. Por lo tanto, esté seguro que si usted configura ninguno de estos parámetros, las configuraciones para todo el Routers en su red tienen valores compatibles.

El OSPF clasifica diversos media en los tres tipos de red siguientes por abandono:

  • Redes de broadcast (Ethernetes, Token Ring, y FDDI)
  • Redes del acceso múltiple sin broadcast (NBMA) (Switched Multimegabit Data Service (SMDS), Frame Relay, y X.25)
  • Red Point-to-Point ([HDLC] del High-Level Data Link Control y PPP)

Usted puede configurar su red como un broadcast o red NBMA.

El X.25 y el Frame Relay proporcionan una capacidad de broadcast opcional que se pueda configurar en la correspondencia para permitir que el OSPF se ejecute como red de broadcast. Refiera a las descripciones de la correspondencia X.25 y del comando frame-relay map en la publicación de la referencia del comando wide-area networking del Cisco IOS para más detalle.

Tipos de red OSPF

Usted tiene la opción de configurar su tipo de red OSPF según lo transmitido o NBMA, sin importar el tipo de media predeterminado. Usando esta característica, usted puede configurar las redes de broadcast como redes NBMA cuando, por ejemplo, usted tiene el Routers en su red que no soporta el direccionamiento de multidifusión. Usted también puede configurar las redes NBMA (tales como X.25, Frame Relay, y S DS) como redes de broadcast. Esta característica le guarda de la necesidad configurar a los vecinos, según lo descrito en la sección “configurando el OSPF para las redes de Nonbroadcast” más adelante en este módulo.

Configurando las redes NBMA según lo transmitido o el nonbroadcast asume que hay circuitos virtuales (VCs) de cada router a cada router o completamente la red mallada. Esto no es verdad para algunos casos, por ejemplo, debido a los apremios de coste, o cuando usted tiene solamente parcialmente una red mallada. En estos casos, usted puede configurar el tipo de red OSPF como red de punto a multipunto. La encaminamiento entre dos Routers conectado no no directamente pasará a través del router que tiene VCs a ambo Routers. Observe que usted no necesita configurar a los vecinos al usar esta característica.

Una interfaz punto a multipunto OSPF se define como una interfaz punto a punto enumerada que tiene uno o más vecinos. Crea las rutas del host múltiple. Una red de punto a multipunto OSPF tiene las siguientes ventajas comparadas al NBMA y a los red Point-to-Point:

  • La punta a de múltiples puntos es más fácil de configurar porque no requiere ninguna configuración de los comandos neighbor, él consume solamente una subred IP, y no requiere ninguna elección del router designado.
  • Cuesta menos porque no requiere completamente una topología mallada.
  • Es más confiable porque mantiene la Conectividad en caso de error del VC.

En la punta a de múltiples puntos, las redes de broadcast, allí no son ninguna necesidad de especificar a los vecinos. Sin embargo, usted puede especificar a los vecinos con el comando configuration del router vecino, en este caso usted especifica un coste a ese vecino.

Antes de que la palabra clave de la punta a de múltiples puntos fuera agregada al comando configuration del ip ospf network interface, un cierto tráfico de protocolo de la punta a de múltiples puntos OSPF fue tratado como tráfico Multicast. Por lo tanto, el comando configuration del router vecino no era necesario para las interfaces punto a multipunto porque el Multicast tomó el cuidado del tráfico. Hola, actualización, y los mensajes de reconocimiento fueron enviados usando el Multicast. Particularmente, los mensajes Hello Messages del Multicast descubrieron a todos los vecinos dinámicamente.

En cualquier interfaz punto a multipunto (broadcast o no), el Cisco IOS Software asumió que el coste a cada vecino era igual. El coste fue configurado con el comando de la confutación de la interfaz del coste OSPF del IP. En realidad, el ancho de banda para cada vecino es diferente, así que el costo también lo debe ser. Con esta función, puede configurar un costo separado para cada vecino. Esta función se aplica solamente a las interfaces punto a multipunto.

Porque mucho Routers pudo ser asociado a una red OSPF, un router designado se selecciona para la red. Los parámetros de la configuración especial se necesitan en la selección del router designado si la capacidad de broadcast no se configura.

Estos parámetros necesitan solamente ser configurados en esos dispositivos que sean ellos mismos elegibles convertirse en el router designado o el router designado de backup (es decir Routers con un valor de prioridad del router no-cero).

Usted puede especificar los parámetros vecinos siguientes, como sea necesario:

  • Prioridad para un router de la vencidad
  • Intervalo de encuesta de Nonbroadcast

En la punta a de múltiples puntos, las redes del nonbroadcast, utilizan el comando configuration del router vecino de identificar a los vecinos. La asignación de un coste a un vecino es opcional.

Antes del Cisco IOS Release 12.0, algunos clientes utilizaban la punta a de múltiples puntos en los media del nonbroadcast (tales como IP por ATM clásico), así que su Routers no podría descubrir dinámicamente a sus vecinos. Esta característica permite que utilicen al comando configuration del router vecino en las interfaces punto a multipunto.

En cualquier interfaz punto a multipunto (broadcast o no), el Cisco IOS Software asumió que el coste a cada vecino era igual. El coste fue configurado con el comando interface configuration del coste OSPF del IP. En realidad, el ancho de banda para cada vecino es diferente, así que el costo también lo debe ser. Con esta función, puede configurar un costo separado para cada vecino. Esta función se aplica solamente a las interfaces punto a multipunto.

Nuestro software OSPF permite que usted configure varios parámetros del área. Estos parámetros del área, mostrados en la tabla siguiente de la tarea, incluyen la autenticación, la definición de las zonas fragmentadas, y la asignación de los costes específicos a la ruta abreviado predeterminado. La autenticación permite la protección basada en la contraseña contra el acceso no autorizado a un área.

Las zonas fragmentadas son las áreas en las cuales la información sobre las rutas externo no se envía. En lugar, hay una ruta externo predeterminada generada por el ABR, en las zonas fragmentadas para los destinos fuera del sistema autónomo. Para aprovecharse del soporte de las zonas fragmentadas OSPF, el ruteo predeterminado se debe utilizar en las zonas fragmentadas. Para reducir más lejos el número de LSA enviados en las zonas fragmentadas, usted puede configurar la palabra clave del ninguno-resumen del comando configuration del router Stub del área en el ABR de evitar que envíe el anuncio del link de resumen (tipo LSA 3) en las zonas fragmentadas.

La característica OSPF NSSA es descrita por el RFC 3101. En las versiones del Cisco IOS Release 15.1(2)S y Posterior, el RFC 3101 substituye el RFC 1587. El RFC 3101 es compatible con versiones anteriores con el RFC 1587. Para una lista detallada de diferencias entre ellas, vea el apéndice F del RFC 3101. El soporte NSSA primero fue integrado en el Cisco IOS Release 11.2. El OSPF NSSA es una extensión nonproprietary de la característica existente de las zonas fragmentadas OSPF.

El soporte del RFC 3101 aumenta el cálculo externo de la encaminamiento del Autonomous System del tipo 7 y la traducción del tipo 7 LSA en el tipo 5 LSA. Para más información, vea el RFC 3101.

Utilice el NSSA para simplificar la administración si usted es un Proveedor de servicios de Internet (ISP) o un administrador de la red que deben conectar un sitio central que esté utilizando el OSPF a un sitio remoto que esté utilizando un diverso Routing Protocol.

Antes del NSSA, la conexión entre el Router del borde del sitio corporativo y el router remoto no se podría ejecutar como las zonas fragmentadas OSPF porque las rutas para el sitio remoto no se podrían redistribuir en las zonas fragmentadas, y dos Routing Protocol necesarios para ser mantenido. Un protocolo sencillo tal como RIP fue funcionado con y manejó generalmente la redistribución. Con el NSSA, usted puede ampliar el OSPF para cubrir la conexión remota definiendo el área entre el router corporativo y el router remoto como NSSA.

Como con las zonas fragmentadas OSPF, las áreas NSSA no se pueden inyectar con las rutas distribuidas vía el tipo 5 LSA. La redistribución de ruta en una área NSSA es posible solamente con un tipo especial de LSA que se conozca como tipo 7 que pueda existir solamente en una área NSSA. Un NSSA ASBR genera el tipo 7 LSA para poder redistribuir las rutas, y un NSSA ABR traduce el tipo 7 LSA a un tipo 5 LSA, que puede ser inundado en el dominio de ruteo entero OSPF. El resumen y la filtración se soportan durante la traducción.

Las versiones del Cisco IOS Release 15.1(2)S y Posterior soportan el RFC 3101, que permite que usted configure un router ABR NSSA como traductor forzado NSSA LSA. Esto significa que el router ABR NSSA incondicional asumirá el papel del traductor LSA, apropiándose del comportamiento predeterminado, que lo incluiría solamente entre los candidatos que se elegirán como traductor.


Nota


Incluso un traductor forzado no pudo traducir todos los LSA; la traducción depende del contenido de cada LSA.

La figura abajo muestra un diagrama de la red en qué área OSPF 1 se define como las zonas fragmentadas. Las rutas del Enhanced Interior Gateway Routing Protocol (EIGRP) no se pueden propagar en el dominio OSPF porque la redistribución de ruteo no se permite en las zonas fragmentadas. Sin embargo, una vez que la área OSPF 1 se define como NSSA, un NSSA ASBR puede inyectar las rutas EIGRP en el OSPF NSSA creando el tipo 7 LSA.

Figura 1OSPF NSSA


Las rutas redistribuido del router del RIP no serán permitidas en la área OSPF 1 porque el NSSA es una extensión a las zonas fragmentadas. Las características de las zonas fragmentadas todavía existirán, incluyendo la exclusión del tipo 5 LSA.

El resumen de Route es la consolidación de las direcciones anunciadas. Esta característica hace una sola ruta de resumen ser hecha publicidad a otras áreas por un ABR. En el OSPF, un ABR hará publicidad de las redes en una área en otra área. Si los network number en un área se asignan de una manera tales que son contiguos, usted puede configurar el ABR para hacer publicidad de una ruta de resumen que cubra todas las redes individuales dentro del área que caen en el rango especificado.

Cuando las rutas de otros protocolos se redistribuyen en el OSPF (según lo descrito en el módulo las “que configura características IP Routing Protocol-Independent”), cada ruta se hace publicidad individualmente en un externo LSA. Sin embargo, usted puede configurar el Cisco IOS Software para hacer publicidad de una solo ruta para todas las rutas redistribuido que son cubiertas por un direccionamiento y una máscara de red específicada. Haciendo tan las ayudas disminuyen los tamaños de la base de datos de estado de links OSPF.

En el OSPF, todas las áreas se deben conectar con una área de estructura básica. Si hay una rotura en la continuidad de la estructura básica, o la estructura básica se divide útil, usted puede establecer un link virtual. Los dos puntos finales de un link virtual son ABR. El link virtual se debe configurar en ambo Routers. La información de la configuración en cada router consiste en el otro punto final virtual (el otro ABR) y zona que no sea de estructura básica que el dos Routers tiene en el campo común (llamado la área de tránsito). Observe que los links virtuales no se pueden configurar con las zonas fragmentadas.

Usted puede forzar un ASBR para generar una ruta predeterminado en un dominio de ruteo OSPF. Siempre que usted configure específicamente la redistribución de las rutas en un dominio de ruteo OSPF, el router hace automáticamente un ASBR. Sin embargo, el ASBR no genera, en forma predeterminada, una ruta predeterminada dentro del dominio de ruteo OSPF.

Usted puede configurar el OSPF para mirar para arriba los nombres del Domain Naming System (DNS) para el uso en todas las visualizaciones del comando show EXEC OSPF. Usted puede utilizar esta característica a identifica más fácilmente a un router, porque su Router ID o identificación del vecino visualiza al router por nombre bastante que

El OSPF utiliza la dirección IP más grande configurada en las interfaces como su Router ID. Si la interfaz asociada con esta dirección IP alguna vez se reduce, o si se elimina la dirección, el proceso OSPF debe recalcular una nueva ID de router y reenviar toda esta información de ruteo fuera de las interfaces.

Si una interfaz del loop está configurada con una dirección IP, el software IOS de Cisco utilizará esta dirección IP como su ID de router, aún cuando otras interfaces tienen direcciones IP mayores. Porque nunca van las interfaces del loopback abajo, la mayor estabilidad en la tabla de ruteo se alcanza.

OSPF prefiere en forma automática una interfaz de loopback antes que cualquier otro tipo y selecciona la dirección IP más elevada entre las interfaces del loopback. Si no hay interfaces del loopback presentes, la dirección IP más alta del router se elige. Usted no puede decir el OSPF utilizar ninguna interfaz particular.

En las versiones del Cisco IOS Release 10.3 y Posterior, por abandono el OSPF calcula el OSPF métrico para una interfaz según el ancho de banda de la interfaz. Por ejemplo, un link 64-kbps consigue un métrico de 1562, y un link T1 consigue un métrico de 64.

El OSPF métrico se calcula como el valor de referencia-BW dividido por el valor de ancho de banda, con el valor de referencia-BW igual a 108 por abandono, y el valor de ancho de banda determinado por el comando interface configuration del ancho de banda. El cálculo da a FDDI un métrico de 1. Si usted tiene links múltiples con el ancho de banda alto, usted puede ser que quiera especificar un número más grande para distinguir el coste en esos links.

Una distancia administrativa es un grado de la fiabilidad de una fuente de información de ruteo, tal como un router individual o un grupo de Routers. Numéricamente, una distancia administrativa es un número entero a partir de la 0 a 255. Generalmente cuanto más alto es el valor, más bajo es el grado de la confianza. Una distancia administrativa de 255 significa que la fuente de información de ruteo no se puede confiar en absoluto y que debe ser ignorada.

El OSPF utiliza tres diversas distancias administrativas: intra-area, interarea, y externo. Las rutas dentro de un área son intra-area; las rutas a otra área son interarea; y las rutas de otro dominio de ruteo aprendido vía la redistribución son externas. La distancia predeterminada para cada tipo de ruta es 110.

Porque las interfaces a una cara entre dos dispositivos en un Ethernet representan solamente un segmento de red, porque el OSPF usted debe configurar la interfaz de envío para ser una interfaz pasiva. Esta configuración evita que el OSPF envíe los paquetes de saludo para la interfaz de envío. Ambos dispositivos pueden considerarse vía el paquete de saludo generado para la interfaz de recepción.

Usted puede configurar el tiempo de retraso entre cuando el OSPF recibe un cambio de la topología y cuando comienza un primer (SPF) cálculo del trayecto más corto. Usted puede también configurar el tiempo en espera entre dos cálculos consecutivos SPF.

El circuito a pedido OSPF es una mejora al protocolo OSPF que permite la operación eficiente sobre los circuitos a pedido tales como circuitos virtuales conmutados ISDN, X.25 (SVC), y líneas de marcado. Este RFC 1793 de los soportes de característica, OSPF que extiende para soportar los circuitos de la demanda.

Antes de esta característica, los saludos periódicos OSPF y las actualizaciones LSA serían intercambiados entre el Routers que conectó el link a pedido, incluso cuando ningunos cambios ocurrieron en hola o la información LSA.

Con esta característica, se suprime el hellos periódico y el periódico restaura de los LSA no se inunda sobre el circuito de la demanda. Estos paquetes sacan a colación el link solamente cuando se intercambian por primera vez, o cuando un cambio ocurre en la información ellos contiene. Esta operación permite que la capa del link de datos subyacente sea cerrada cuando la topología de red es estable.

Esta característica es útil cuando usted quiere conectar el telecommuters o las sucursales con una estructura básica de OSPF en un sitio central. En este caso, el OSPF para los circuitos a pedido permite las ventajas del OSPF sobre el dominio entero, sin exceso de la conexión cuesta. Periódico restaura hola de las actualizaciones, las actualizaciones LSA, y la otra tara de protocolo se previene de habilitar el circuito a pedido cuando no hay datos “reales” a enviar.

Los protocolos de arriba tales como hellos y los LSA se transfieren sobre el circuito a pedido solamente sobre la configuración inicial y cuando reflejan un cambio en la topología. Esto significa que los cambios críticos a la topología que requieren los nuevos cálculos SPF están enviados para mantener la integridad de la topología de red. Periódico restaura que no incluye los cambios, sin embargo, no se envían a través del link.

La característica de establecimiento del paso del grupo OSPF LSA permite que el router agrupe OSPF LSA y establezca el paso de restauración, checksumming, y de las funciones de envejecimiento. Los resultados de establecimiento del paso del grupo en el uso más eficiente del router.

Los grupos de routers OSPF LSA y establecen el paso de restauración, checksumming, y de las funciones de envejecimiento para evitar los aumentos súbitos en el USO de la CPU y los recursos de red. Esta característica es la más beneficiosa a las redes OSPF grandes.

El establecimiento del paso del grupo OSPF LSA se habilita por abandono. Para los clientes típicos, el intervalo de establecimiento del paso del grupo predeterminado para restaurar, checksumming, y envejecer es apropiado y usted no necesita configurar esta característica.

Comportamiento original LSA

Cada OSPF LSA tiene una edad, que indica si el LSA es todavía válido. Una vez que el LSA alcanza la Edad máxima (1 hora), se desecha. Durante el proceso de desactualización, el router de origen envía un paquete de la restauración cada 30 minutos para restaurar el LSA. Restaure los paquetes se envían para guardar el LSA de la expiración, si ha habido un cambio en la topología de red o no. Checksumming se realiza en todos los LSA cada 10 minutos. El router no pierde de vista los LSA que genera y los LSA recibe del otro Routers. El router restaura los LSA que generó; envejece los LSA que recibió del otro Routers.

Antes de la característica de establecimiento del paso del grupo LSA, el Cisco IOS Software realizaría la restauración en un solo temporizador, y checksumming y el envejecimiento en otro temporizador. En el caso de restaurar, por ejemplo, el software analizaría la base de datos entera cada 30 minutos, restaurando cada LSA que el router generó, no importa cómo es viejo era. La figura abajo ilustra todos los LSA que son restaurados inmediatamente. Este proceso perdió a los recursos de la CPU porque solamente una pequeña porción de la base de datos necesitó ser restaurada. Las bases de datos OSPF grandes (varios miles de LSA) podrían tener millares de LSA con diversas edades. La restauración en un solo temporizador dio lugar a la edad de todos los LSA sincronizadores, que dieron lugar a mucho procesamiento de la CPU inmediatamente. Además, un gran número de LSA podían causar un aumento súbito del tráfico de la red, consumiendo a una gran cantidad de recursos de red en un período corto.

Figura 2OSPF LSA en un solo temporizador sin el establecimiento del paso del grupo


Grupo LSA que establece el paso con los temporizadores múltiples

Configurar cada LSA para tener su propio temporizador evita excesivo procesamiento de la CPU y aumento súbito del tráfico de la red. Para utilizar otra vez el ejemplo de la restauración, cada LSA consigue restaurado cuando es 30 minutos de viejo, independiente de otros LSA. El CPU se utiliza tan solamente cuando sea necesario. Sin embargo, los LSA que son restaurados en frecuente, los intervalos aleatorios requerirían muchos paquetes para el pocos los LSA restaurados que el router debe enviar, que sería uso ineficaz del ancho de banda.

Por lo tanto, el router retrasa el LSA restaura la función para un intervalo del tiempo en vez de realizarlo cuando se alcanzan los temporizadores individuales. Los LSA acumulados constituyen a un grupo, que después se restaura y se envía en un paquete o más. Así, se establecen el paso los paquetes de la restauración, al igual que el checksumming y el envejecimiento. El intervalo de establecimiento del paso es configurable; omite 4 minutos, que se selecciona al azar para evitar más lejos la sincronización.

La figura abajo ilustra el caso de restaura los paquetes. El primer timeline ilustra los temporizadores individuales LSA; el segundo timeline ilustra los temporizadores individuales LSA con el establecimiento del paso del grupo.

Figura 3OSPF LSA en los temporizadores individuales con el establecimiento del paso del grupo


El intervalo de establecimiento del paso del grupo es inverso proporcional al número de LSA que el router está restaurando, de checksumming, y de envejecimiento. Por ejemplo, si usted tiene aproximadamente 10.000 LSA, la disminución del intervalo de establecimiento del paso le beneficiaría. Si usted tiene los LSA muy pequeños de la base de datos (40 a 100), el aumento del intervalo de establecimiento del paso a 10 a 20 minutos pudo beneficiarle levemente.

El valor predeterminado del establecimiento del paso entre los grupos LSA es 240 segundos (4 minutos). El rango es a partir 10 segundos a 1800 segundos (30 minutos).

Por abandono, el OSPF inunda los nuevos LSA sobre todas las interfaces en la misma área, excepto la interfaz en la cual el LSA llega. Una cierta Redundancia es deseable, porque asegura la inundación robusta. Sin embargo, demasiada Redundancia puede perder el ancho de banda y pudo desestabilizar la red debido al link y al USO de la CPU excesivos en ciertas topologías. Un ejemplo sería completamente una topología mallada.

Usted puede bloquear la inundación OSPF de las maneras LSA dos, dependiendo del tipo de red:

  • En el broadcast, el nonbroadcast, y los red Point-to-Point, usted puede bloquear inundar sobre las interfaces OSPF especificadas.
  • En las redes de punto a multipunto, usted puede bloquear la inundación a un vecino especificado.

El crecimiento de Internet ha aumentado la importancia del scalability en los IGP tales como OSPF. Por el diseño, el OSPF requiere los LSA ser restaurado mientras que expiran después de 3600 segundos. Algunas implementaciones han intentado mejorar la inundación reduciendo la frecuencia para restaurar a partir de 30 minutos a cerca de 50 minutos. Esta solución reduce la cantidad de restaura el tráfico pero requiere por lo menos uno restaura antes de que expire el LSA. La solución de la reducción de la inundación de OSPF trabaja reduciendo la restauración e inundar innecesarios de la información ya sabida y sin cambios. Para alcanzar esta reducción, los LSA ahora se inundan con el conjunto de bits más alto. Los LSA ahora se fijan como “no envejecen.”

Los routeres Cisco no soportan el Multicast OSPF (MOSPF) del tipo 6 LSA, y generan los mensajes de Syslog si reciben tales paquetes. Si el router está recibiendo muchos paquetes MOSPF, usted puede ser que quiera configurar al router para ignorar los paquetes y para prevenir así un gran número de mensajes de Syslog.

La implementación de OSPF anterior para enviar los paquetes de actualización necesitó ser más eficiente. Algunos paquetes de actualización conseguían perdidos en caso de que el link fuera lento, un vecino no podrían recibir las actualizaciones rápidamente bastante, o el router estaba fuera de espacio del búfer. Por ejemplo, los paquetes pudieron ser caídos si existió cualquiera de las topologías siguientes:

  • Un router rápido fue conectado con un router más lento sobre un link punto a punto.
  • Durante la inundación, varios vecinos enviaron las actualizaciones a un único router al mismo tiempo.

Los paquetes de actualización OSPF ahora se establecen el paso automáticamente así que no se envían menos de 33 milisegundos de separado. El establecimiento del paso también se agrega en medio vuelve a enviar para aumentar la eficacia y para minimizar las retransmisiones perdidas. También, usted puede visualizar los LSA que esperan para ser enviado una interfaz. La ventaja del establecimiento del paso es que los paquetes de la actualización y de la retransmisión OSPF están enviados más eficientemente. No hay tareas de configuración para esta característica; ocurre automáticamente.

Puede mostrar estadísticas específicas tales como el contenido de las tablas de IP routing, de las memorias caché y de las bases de datos. Se puede utilizar la información proporcionada para determinar la utilización de recursos y solucionar problemas de red. Usted puede también mostrar información sobre el accesibilidad del nodo y descubrir la trayectoria de ruteo que sus paquetes del dispositivo están tomando a través de la red

Cómo configurar el OSPF

Para configurar el OSPF, realice las tareas descritas en las secciones siguientes. Las tareas en la sección OSPF que habilita se requieren; las tareas en las secciones restantes son opcionales, pero se pudieron requerir para su aplicación. Para la información sobre la cantidad máxima de interfaz, vea las restricciones.

Habilitar el OSPF

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. router ospf process-id

4. ID de área basado en wildcard del área del IP Address de red

5. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id


Ejemplo:

OSPF 109 del router de Router(config)#

 

Habilita el OSPF Routing, que coloca al router en el modo de configuración del router.

 
Paso 4
ID de área basado en wildcard del área del IP Address de red


Ejemplo:

Router (config-router) # área 20 de 192.168.129.16 0.0.0.3 de la red

 

Define una interfaz en la cual el OSPF ejecute y defina el ID de área para esa interfaz.

 
Paso 5
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Configurar los parámetros de la interfaz OSPF

Configurar el OSPF sobre diversas redes físicas

Configurar las redes de broadcast de la punta a de múltiples puntos

PASOS SUMARIOS

1. ip ospf network point-to-multipoint

2. salida

3. router ospf process-id

4. número del coste del neighbor ip-address


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
ip ospf network point-to-multipoint
 

Configura una interfaz como punta a de múltiples puntos para el medio de broadcast.

 
Paso 2
salida
 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id
 

Configura un proceso de ruteo OSPF e ingresa en el modo de configuración del router.

 
Paso 4
número del coste del neighbor ip-address
 

Especifica un vecino y le asigna un costo.

Nota    Relance este paso para cada vecino si usted quiere especificar un coste. Si no, los vecinos asumirán el costo de la interfaz, según el comando de configuración de la interfaz ip ospf cost.
 

Configurar el OSPF para las redes de Nonbroadcast

PASOS SUMARIOS

1. ip ospf network point-to-multipoint no-broadcast

2. salida

3. router ospf process-id

4. [cost number] del neighbor ip-address


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
ip ospf network point-to-multipoint no-broadcast
 

Configura una interfaz como punta a de múltiples puntos para los media del nonbroadcast.

 
Paso 2
salida
 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id
 

Configura un proceso de ruteo OSPF e ingresa en el modo de configuración del router.

 
Paso 4
[cost number] del neighbor ip-address
 

Especifica un vecino y le asigna un costo.

Nota    Relance este paso para cada vecino si usted quiere especificar un coste. Si no, los vecinos asumirán el costo de la interfaz, según el comando de configuración de la interfaz ip ospf cost.
 

Configurar los parámetros de la área OSPF

Configurar OSPF NSSA

Configurar una área OSPF NSSA y sus parámetros

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. router ospf process-id

4. redistribuya el [process-id] {level-1 del protocolo | level-1-2 | [autonomous-system-number] level-2} [métrico {valor métrico | transparente}] [metric-type type-value] [coincidencia {interna | externo 1 | [nssa-only] externo del [subnets] del [route-map map-tag] del [tag tag-value] 2}]

5. ID de área basado en wildcard del área del IP Address de red

6. [nssa-only] del [no-summary] del [metric-type] del [default-information-originate [metric] del [no-redistribution] del nssa del ID de área del área]

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id


Ejemplo:

OSPF 10 del router de Router(config)#

 

Habilita el ruteo OSPF e ingresa al modo de configuración de router.

  • El argumento process-id identifica el proceso OSPF. En este ejemplo el número del proceso de ruteo es 10.
 
Paso 4
redistribuya el [process-id] {level-1 del protocolo | level-1-2 | [autonomous-system-number] level-2} [métrico {valor métrico | transparente}] [metric-type type-value] [coincidencia {interna | externo 1 | [nssa-only] externo del [subnets] del [route-map map-tag] del [tag tag-value] 2}]


Ejemplo:

El router (config-router) # redistribuye las subredes del RIP

 

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

  • Las causas del ejemplo RASGAN las subredes que se redistribuirán en el dominio OSPF.
 
Paso 5
ID de área basado en wildcard del área del IP Address de red


Ejemplo:

Router (config-router) # área 1 de 172.19.92.0 0.0.0.255 de la red

 

Define las interfaces en las cuales el OSPF ejecuta y define el ID de área para esas interfaces.

  • El ejemplo define 172.19.92.0/0.0.0.255 interfaces para la área OSPF 1 para el proceso de ruteo de OSPF 10.
 
Paso 6
[nssa-only] del [no-summary] del [metric-type] del [default-information-originate [metric] del [no-redistribution] del nssa del ID de área del área]


Ejemplo:

Router (config-router) # nssa del área 1

 

Configura una área NSSA.

  • En el ejemplo, el área 1 se configura como área NSSA.
 
Paso 7
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Configurar un NSSA ABR como traductor forzado NSSA LSA


Nota


En las versiones del Cisco IOS Release 15.1(2)S y Posterior, la salida de las demostraciones del comando show ip ospf si el NSSA ABR está configurado como traductor forzado, y si el router se está ejecutando como el RFC 3101 o RFC 1587 compatible.
PASOS SUMARIOS

1. permiso

2. configuró terminal

3. router ospf process-id

4. el nssa del ID de área del área traduce type7 siempre

5. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id


Ejemplo:

OSPF 1 del router de Router(config)#

 

Habilita el ruteo OSPF e ingresa al modo de configuración de router.

  • El argumento process-id identifica el proceso OSPF.
 
Paso 4
el nssa del ID de área del área traduce type7 siempre


Ejemplo:

El router (config-router) # nssa del área 10 traduce type7 siempre

 

Configura un router ABR NSSA como traductor forzado NSSA LSA.

Nota    En las versiones del Cisco IOS Release 15.1(2)S y Posterior, el RFC 3101 substituye el RFC 1587, y usted puede utilizar siempre la palabra clave en el comando translate del nssa del área de configurar un router ABR NSSA como traductor forzado NSSA LSA. Este comando trabajará si se inhabilita el RFC 3101 y se está utilizando el RFC 1587.
 
Paso 5
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Inhabilitando la compatibilidad y habilitar del RFC 3101 la compatibilidad del RFC 1587


Nota


En las versiones del Cisco IOS Release 15.1(2)S y Posterior, la salida del comando show ip ospf indicará si el NSSA ABR se configura como el RFC 3101 o RFC 1587 compatible.
PASOS SUMARIOS

1. permiso

2. configuró terminal

3. router ospf process-id

4. rfc1587 compatible

5. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
router ospf process-id


Ejemplo:

OSPF 1 del router de Router(config)#

 

Habilita el ruteo OSPF e ingresa al modo de configuración de router.

  • El argumento process-id identifica el proceso OSPF.
 
Paso 4
rfc1587 compatible


Ejemplo:

Router (config-router) # rfc1587 compatible

 

Cambia el método usado para realizar la selección de Route a la compatibilidad del RFC 1587 y inhabilita el RFC 3101.

 
Paso 5
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Configurar los parámetros OSPF NSSA

Prerrequisitos

Evalúe las consideraciones siguientes antes de que usted implemente esta característica:

  • Usted puede fijar una ruta predeterminado del tipo 7 que se pueda utilizar para alcanzar los destinos externos. Cuando está configurado, el router genera un valor por defecto del tipo 7 en el NSSA o el NSSA ABR.
  • Cada router dentro de la misma área debe estar de acuerdo que el área es NSSA; si no, el Routers no podrá comunicar.

Configurar el resumen de Route entre las áreas OSPF

Configurar el resumen de Route al redistribuir las rutas en el OSPF

Comando

Propósito

summary-address {ip-address mask 
| prefix mask} 
[not-advertise][tag  tag]

Especifica un direccionamiento y se hace publicidad la máscara que cubre las rutas redistribuido, tan solamente una ruta de resumen. Utilice el opcional no-hacen publicidad de la palabra clave para filtrar hacia fuera un conjunto de las rutas.

Establecer los links virtuales

Comando

Propósito

area area-id virtual-link router-id [authentication [message-digest | null]] [hello-interval seconds] [retransmit-interval seconds] [transmit-delay seconds] [dead-interval seconds] [authentication-key key | message-digest-key key-id md5 key] 

Establece un link virtual.

Generación de una ruta predeterminado

Comando

Propósito

default-information originate [always] [metric metric-value] [metric-type type-value] [route-map map-name]

Fuerza el ASBR para generar una ruta predeterminado en el dominio de ruteo OSPF.

Nota    La palabra clave incluye siempre la excepción siguiente cuando se utiliza el Route Map. Cuando se utiliza un Route Map, la creación de la ruta predeterminado por el OSPF no está limitada a la existencia de una ruta predeterminado en la tabla de ruteo.

Configurar las operaciones de búsqueda de los nombres DNS

Comando

Propósito

ip ospf name-lookup

Operaciones de búsqueda del nombre DNS de las configuraciones.

Forzar la opción del Router ID con un Loopback Interface

PASOS SUMARIOS

1. Interface Loopback 0

2. máscara del IP address del IP Address


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
loopback 0 de interfaz
 

Crea un Loopback Interface, que coloca al router en el modo de configuración de la interfaz.

 
Paso 2
máscara del IP address del IP Address
 

Asigna una dirección IP a esta interfaz.

 

Métrica predeterminada que controla

Comando

Propósito

auto-cost reference-bandwidth ref-bw

Distingue los links de ancho de banda altos.

Cambio de las distancias administrativas OSPF

Comando

Propósito

distance  ospf  {intra-area | inter-area | external} dist 

Cambia los valores de distancia OSPF.

Configurar el OSPF en las interfaces de Ethernet a una cara

Comando

Propósito

passive-interface interface-type interface-number

Suprime el envío de los paquetes de saludo a través de la interfaz especificada.

Configurar los temporizadores del cálculo de la ruta

Comando

Propósito

timers spf  spf-delay spf-holdtime 

Temporizadores del cálculo de la ruta de las configuraciones.

Configurar el OSPF sobre los circuitos a pedido

PASOS SUMARIOS

1. router ospf process-id

2. número del tipo de la interfaz

3. ip ospf demand-circuit


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
router ospf process-id
 

Operación de los permisos OSPF.

 
Paso 2
número del tipo de la interfaz
 

Ingresa en el modo de configuración de la interfaz.

 
Paso 3
ip ospf demand-circuit
 

Configuraciones OSPF sobre un circuito a pedido.

 
Pasos Siguientes


Nota


Usted puede evitar que una interfaz valide las peticiones del demand circuit del otro Routers a especificar la palabra clave de la negligencia en el comando ip ospf demand-circuit.

Prerrequisitos

Evalúe las consideraciones siguientes antes de implementar la característica a pedido de los circuitos:

  • Porque los LSA que incluyen los cambios de la topología se inundan sobre un circuito a pedido, recomendamos que usted pone los circuitos de la demanda dentro de las zonas fragmentadas OSPF o dentro de los NSSA para aislar los circuitos de la demanda de tantos cambios de la topología como sea posible.
  • Cada router dentro de las zonas fragmentadas o de un NSSA debe hacer esta característica cargar para aprovecharse de las funciones a pedido del circuito. Si esta característica se despliega dentro de un área regular, el resto de las áreas regulares deben también soportar esta característica antes de que las funciones del circuito de la demanda puedan tomar el efecto porque el LSA externo del tipo 5 se inunda en todas las áreas.
  • Las topologías de red radial que tienen un tipo de interfaz OSPF de la punta a de múltiples puntos (P2MP) en un concentrador no pudieron invertir al modo del circuito del nondemand cuando estaban necesitadas. Usted debe configurar de nuevo simultáneamente el OSPF en todas las interfaces en el segmento P2MP al invertirlas del modo del circuito de la demanda al modo del circuito del nondemand.
  • No implemente esta característica en una topología de red basada en broadcast porque seguirá habiendo los protocolos de arriba (por ejemplo hola y los paquetes LSA) no se pueden suprimir con éxito, que significa el link para arriba.
  • Configurar al router para un circuito a pedido OSPF con una interfaz asincrónica no es una configuración admitida. La configuración admitida es utilizar las interfaces del dialer en los ambos extremos del circuito. Para más información, refiérase a porqué el circuito de la demanda OSPF guarda el sacar a colación del link.

Vecinos de registración que van hacia arriba o hacia abajo

Comando

Propósito

log-adjacency-changes [detail]

Envía el mensaje de Syslog cuando va un vecino OSPF hacia arriba o hacia abajo.

Nota    Configure este comando si usted quiere saber sobre los vecinos OSPF que van hacia arriba o hacia abajo sin girar el comando exec de la adyacencia OSPF del IP del debug. El comando router configuration de los registro-adyacencia-cambios proporciona una vista de alto nivel de la relación de peer con menos salida. Configure el comando detail de los registro-adyacencia-cambios si usted quiere ver los mensajes para cada cambio de estado.

Cambio del intervalo de establecimiento del paso del grupo LSA

Comando

Propósito

timers pacing lsa-group  seconds

Cambia el establecimiento del paso del grupo de los LSA.

Bloqueo de la inundación OSPF LSA

Comando

Propósito

ip ospf database-filter all out

Bloquea la inundación de los paquetes LSA OSPF a la interfaz.

En las redes de punto a multipunto, bloquear la inundación de OSPF LSA, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

neighbor  ip-address  database-filter all out

Bloquea la inundación de los paquetes LSA OSPF al vecino especificado.

Reducción de la inundación LSA

Comando

Propósito

ip ospf flood-reduction

Suprime la inundación innecesaria de los LSA en topologías estables.

Negligencia de los paquetes LSA MOSPF

Comando

Propósito

ignore lsa mospf

Evita que el router genere los mensajes de Syslog cuando recibe los paquetes LSA MOSPF.

Visualizar el establecimiento del paso del paquete de actualización OSPF

Comando

Propósito

show ip ospf flood-list  interface-type interface-number

Visualiza una lista de LSA que esperan para ser inundado sobre una interfaz.

Monitoreando y mantener el OSPF

Comando

Propósito

show ip ospf [process-id]

Visualiza información general sobre los procesos de ruteo de OSPF.

show ip ospf border-routers

Visualiza las entradas de tabla internas del OSPF Routing al ABR y al ASBR.

show ip ospf [process-id 
[area-id]] database

 
				  
show ip ospf [process-id 
[area-id]] database [database-summary]

 
				  
show ip ospf [process-id 
[area-id]] database [router] [self-originate]

 
				  
show ip ospf [process-id 
[area-id]] database [router] [adv-router [ip-address]]

 
				  
show ip ospf [process-id 
[area-id]] database [router] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [network] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [summary] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [asbr-summary] [link-state-id]

 
				  
 show ip ospf [process-id 
[Router# area-id]] database [external] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [nssa-external] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [opaque-link] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [opaque-area] [link-state-id]

 
				  
show ip ospf [process-id 
[area-id]] database [opaque-as] [link-state-id]

Visualiza las listas de relacionado con la información a las bases de datos OSPF.

show ip ospf flood-list interface  type

Visualiza una lista de LSA que esperan para ser inundado sobre una interfaz (observar el paquete OSPF el establecer el paso).

show ip ospf interface [type number]

Muestra información de la interfaz relacionada con OSPF.

 show ip ospf neighbor [interface-name] [neighbor-id] detail

Visualiza información de vecino OSPF interfaz por interfaz.

show ip ospf request-list [neighbor] [interface] [interface-neighbor]

Visualiza una lista de todos los LSA pedidos por un router.

show ip ospf retransmission-list [neighbor] [interface] [interface-neighbor]

Visualiza una lista de todos los LSA que esperan para ser vuelto a enviar.

show ip ospf [process-id] summary-address 

Visualiza una lista de toda la información de la redistribución de la dirección de resumen configurada bajo proceso OSPF.

show ip ospf virtual-links

Información de links virtuales del OSPF relacionado de las visualizaciones.

Para recomenzar un proceso OSPF, utilice el siguiente comando en el modo EXEC:

Comando

Propósito

clear ip ospf [pid] {process  | redistribution | counters [neighbor  [ neighbor - interface]
 
[neighbor-id]]}

Borra la redistribución basada en el proceso de ruteo de OSPF ID. Si la opción del pid no se especifica, se borran todos los procesos OSPF.

Restricciones

En los sistemas con un gran número de interfaces, puede ser posible configurar el OSPF tales que el número de links hizo publicidad en el LSA de router hace el paquete de actualización de estado del link exceder los tamaños de un buffer “enorme” del Cisco IOS. Para resolver este problema, reducir el número de links OSPF o aumentar los tamaños de memoria intermedia de gran tamaño ingresando el comando de los tamaños del gran tamaño de buffers.

Un paquete de actualización de estado del link que contiene un LSA de router tiene típicamente los gastos indirectos fijos de 196 bytes, y los 12 bytes adicionales se requieren para cada descripción del link. Con los tamaños de memoria intermedia de gran tamaño de 18024 bytes puede haber un máximo de 1485 descripciones del link.

Porque los tamaños máximos de un paquete del IP son 65.535 bytes, todavía hay un límite superior en el número de links posibles en un router.

Ejemplos de configuración para el OSPF

Ejemplo: Punta a de múltiples puntos OSPF

En la figura abajo, el router nombrado el identificador de conexión de link de datos de las aplicaciones del router1 (DLCI) 201 a comunicar con el router nombrado router2, DLCI 202 al Router4 Nombrado del router, y DLCI 203 al router nombrado Router 3. aplicaciones DLCI 101 de comunicar con el router1 y DLCI 102 del router2 a comunicar con el router3 del router 3. comunica con el router2 (DLCI 401) y el router1 (DLCI 402). El Router4 comunica con el router1 (DLCI 301). Los ejemplos de configuración siguen la figura.

‘Figura 4’Ejemplo de OSPF Punto a Multipunto


Configuración del Router 1

hostname Router 1
!
interface serial 1
 ip address 10.0.0.2 255.0.0.0
 ip ospf network point-to-multipoint
 encapsulation frame-relay
 frame-relay map ip 10.0.0.1 201 broadcast
 frame-relay map ip 10.0.0.3 202 broadcast
 frame-relay map ip 10.0.0.4 203 broadcast
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0

Configuración del router 2

hostname Router 2
!
interface serial 0
 ip address 10.0.0.1 255.0.0.0
 ip ospf network point-to-multipoint
 encapsulation frame-relay
 frame-relay map ip 10.0.0.2 101 broadcast
 frame-relay map ip 10.0.0.4 102 broadcast
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0

Configuración del router3

hostname Router 3
!
interface serial 3
 ip address 10.0.0.4 255.0.0.0
 ip ospf network point-to-multipoint
 encapsulation frame-relay
 clock rate 1000000
 frame-relay map ip 10.0.0.1 401 broadcast
 frame-relay map ip 10.0.0.2 402 broadcast
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0

Configuración del Router4

hostname Router 4
!
interface serial 2
 ip address 10.0.0.3 255.0.0.0
 ip ospf network point-to-multipoint
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.0.0.2 301 broadcast
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0

Ejemplo: Punta a de múltiples puntos OSPF con el broadcast

El siguiente ejemplo ilustra una red de punto a multipunto con el broadcast:

interface Serial0
 ip address 10.0.1.1 255.255.255.0
 encapsulation frame-relay
 ip ospf cost 100
 ip ospf network point-to-multipoint
 frame-relay map ip 10.0.1.3 202 broadcast
 frame-relay map ip 10.0.1.4 203 broadcast
 frame-relay map ip 10.0.1.5 204 broadcast
 frame-relay local-dlci 200
!
router ospf 1
 network 10.0.1.0 0.0.0.255 area 0
 neighbor 10.0.1.5 cost 5
 neighbor 10.0.1.4 cost 10

El siguiente ejemplo muestra la configuración del vecino en 10.0.1.3:

interface serial 0
 ip address 10.0.1.3 255.255.255.0
 ip ospf network point-to-multipoint
 encapsulation frame-relay
 frame-relay local-dlci 301
 frame-relay map ip 10.0.1.1 300 broadcast
 no shutdown
!
 router ospf 1
 network 10.0.1.0 0.0.0.255 area 0

La salida mostrada para los vecinos en la primera configuración es la siguiente:

Router# show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1           1   FULL/  -        00:01:50    10.0.1.5        Serial0
172.16.1.4           1   FULL/  -        00:01:47    10.0.1.4        Serial0
172.16.1.8           1   FULL/  -        00:01:45    10.0.1.3        Serial0

La información de ruta en la primera configuración es como sigue:

Router# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
Gateway of last resort is not set
C    1.0.0.0/8 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O       10.0.1.3/32 [110/100] via 10.0.1.3, 00:39:08, Serial0
C       10.0.1.0/24 is directly connected, Serial0
O       10.0.1.5/32 [110/5] via 10.0.1.5, 00:39:08, Serial0
O       10.0.1.4/32 [110/10] via 10.0.1.4, 00:39:08, Serial0

Ejemplo: Punta a de múltiples puntos OSPF con Nonbroadcast

El siguiente ejemplo ilustra una red de punto a multipunto con el nonbroadcast:

interface Serial0
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no keepalive
frame-relay local-dlci 200
frame-relay map ip 10.0.1.3 202
frame-relay map ip 10.0.1.4 203
frame-relay map ip 10.0.1.5 204
no shutdown
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.3 cost 5
neighbor 10.0.1.4 cost 10
neighbor 10.0.1.5 cost 15

El siguiente ejemplo es la configuración para el router en el otro lado:

interface Serial9/2
 ip address 10.0.1.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 no ip mroute-cache
 no keepalive
 no fair-queue
 frame-relay local-dlci 301
 frame-relay map ip 10.0.1.1 300
 no shutdown
 !
 router ospf 1
 network 10.0.1.0 0.0.0.255 area 0

La salida mostrada para los vecinos en la primera configuración es la siguiente:

Router# show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1           1   FULL/  -        00:01:52    10.0.1.5        Serial0
172.16.1.4           1   FULL/  -        00:01:52    10.0.1.4        Serial0
172.16.1.8           1   FULL/  -        00:01:52    10.0.1.3        Serial0

Ejemplo: Máscaras de subred de longitud variable

OSPF, Static rutas, y máscaras de subred de longitud variable del soporte IS-IS (VLS). Con los VLSMS, puede utilizar diferentes máscaras para el mismo número de red en distintas interfaces, lo que permite conservar las direcciones IP y optimizar el uso del espacio de direcciones disponible.

En el siguiente ejemplo, una máscara de subred 30-bit se utiliza, saliendo de dos bits de espacio de la dirección reservados para la línea serial direcciones de host. Hay suficiente espacio de la dirección de host para dos puntos finales del host en un link serial Point-to-Point.

interface ethernet 0
 ip address 172.16.10.1 255.255.255.0
! 8 bits of host address space reserved for ethernets
interface serial 0
 ip address 172.16.20.1 255.255.255.252
! 2 bits of address space reserved for serial lines
! Router is configured for OSPF and assigned AS 107
router ospf 107
! Specifies network directly connected to the router
 network 172.16.0.0 0.0.255.255 area 0.0.0.0

Ejemplo: OSPF NSSA

En el siguiente ejemplo, una red Stub OSPF se configura para incluir la área OSPF 0 y la área OSPF 1, usando cinco Routers. La área OSPF 1 se define como NSSA, con el router3 configurado para ser el NSSA ASBR y router2 configurados para ser el NSSA ABR. Lo que sigue es el resultado de la configuración para el cinco Routers.

Router 1

hostname Router1
!
interface Loopback1
 ip address 10.1.0.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
 ip ospf 1 area 0
 no cdp enable
!
interface Serial10/0
 description Router2 interface s11/0
 ip address 192.168.10.1 255.255.255.0
 ip ospf 1 area 1
 serial restart-delay 0
 no cdp enable
!
router ospf 1
 area 1 nssa
!
end

Router 2

hostname Router2
!
!
interface Loopback1
 ip address 10.1.0.2 255.255.255.255
!
interface Serial10/0
 description Router1 interface s11/0
 no ip address
 shutdown
 serial restart-delay 0
 no cdp enable
!
interface Serial11/0
 description Router1 interface s10/0
 ip address 192.168.10.2 255.255.255.0
 ip ospf 1 area 1
 serial restart-delay 0
 no cdp enable
!
interface Serial14/0
 description Router3 interface s13/0
 ip address 192.168.14.2 255.255.255.0
 ip ospf 1 area 1
 serial restart-delay 0
 no cdp enable
!
router ospf 1
 area 1 nssa
!
end

Router 3

hostname Router3
!
interface Loopback1
 ip address 10.1.0.3 255.255.255.255
!
interface Ethernet3/0
 ip address 192.168.3.3 255.255.255.0
 no cdp enable
!
interface Serial13/0
 description Router2 interface s14/0
 ip address 192.168.14.3 255.255.255.0
 ip ospf 1 area 1
 serial restart-delay 0
 no cdp enable
!
router ospf 1
 log-adjacency-changes
 area 1 nssa
 redistribute rip subnets
!
router rip
 version 2
 redistribute ospf 1 metric 15
 network 192.168.3.0
end

Router 4

hostname Router4
!
interface Loopback1
 ip address 10.1.0.4 255.255.255.255
!
interface Ethernet3/0
 ip address 192.168.3.4 255.255.255.0
 no cdp enable
!
interface Ethernet4/1
 ip address 192.168.41.4 255.255.255.0
!
router rip
 version 2
 network 192.168.3.0
 network 192.168.41.0
!
end

Router 5

hostname Router5
!
interface Loopback1
 ip address 10.1.0.5 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.10 255.255.255.0
 ip ospf 1 area 0
 no cdp enable
!
interface Ethernet1/1
 ip address 192.168.11.10 255.255.255.0
 ip ospf 1 area 0
!
router ospf 1
!
end

La figura abajo muestra la red Stub OSPF con la área NSSA 1. Las rutas redistribuido que el Router4 está propagando de las dos redes del RIP serán traducidas al tipo 7 que los LSA por el router2 del router ASBR 3. NSSA, que se configura para ser el NSSA ABR, traducirán el tipo 7 LSA de nuevo al tipo 5 para poderlos inundar con el resto de la red Stub OSPF dentro de la área OSPF 0.

Figura 5Red OSPF NSSA con NSSA ABR y routeres ASBR


Cuando ingresan al comando show ip ospf en el router2, la salida confirma que el área 1 OSFP es una área NSSA:

Router2# show ip ospf
 Routing Process "ospf 1" with ID 10.1.0.2
 Start time: 00:00:01.392, Time elapsed: 12:03:09.480
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 0 normal 0 stub 1 nssa
 Number of areas transit capable is 0
 External flood list length 0
    Area 1
  Number of interfaces in this area is 2
! It is a NSSA area
  Area has no authentication
  SPF algorithm last executed 11:37:58.836 ago
  SPF algorithm executed 3 times
  Area ranges are
  Number of LSA 7. Checksum Sum 0x045598
  Number of opaque link LSA 0. Checksum Sum 0x000000
  Number of DCbitless LSA 0
  Number of indication LSA 0
  Number of DoNotAge LSA 0
  Flood list length 0

Router2# show ip ospf data
            OSPF Router with ID (10.1.0.2) (Process ID 1)
		Router Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum Link count
10.1.0.1        10.1.0.1        1990        0x80000016 0x00CBCB 2
10.1.0.2        10.1.0.2        1753        0x80000016 0x009371 4
10.1.0.3        10.1.0.3        1903        0x80000016 0x004149 2
		Summary Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
192.168.0.0     10.1.0.1        1990        0x80000017 0x00A605
192.168.11.0    10.1.0.1        1990        0x80000015 0x009503
		Type-7 AS External Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.3.0     10.1.0.3        1903        0x80000015 0x00484F 0
192.168.41.0    10.1.0.3        1903        0x80000015 0x00A4CC 0

Ingresar el comando de la información de la base de datos OSPF del IP de la demostración visualiza la información adicional sobre la redistribución entre el tipo 5 y el tipo 7 LSA para las rutas que se han inyectado en la área NSSA y después se han inundado a través de la red OSPF.

Router2# show ip ospf database data
            OSPF Router with ID (10.1.0.2) (Process ID 1)
Area 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        3        0        0       
  Network       0        0        0       
  Summary Net   2        0        0       
  Summary ASBR  0        0        0       
  Type-7 Ext    2        0        0       
     Prefixes redistributed in Type-7  0
  Opaque Link   0        0        0       
  Opaque Area   0        0        0       
  Subtotal      7        0        0       
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router        3        0        0       
  Network       0        0        0       
  Summary Net   2        0        0       
  Summary ASBR  0        0        0       
  Type-7 Ext    2        0        0       
  Opaque Link   0        0        0       
  Opaque Area   0        0        0       
  Type-5 Ext    0        0        0       
      Prefixes redistributed in Type-5  0
  Opaque AS     0        0        0       
  Total         7        0        0       

Ingresar el comando show ip ospf database nssa también visualiza la información detallada para las traducciones del tipo 7 a del tipo 5:

Router2# show ip ospf database nssa
            OSPF Router with ID (10.1.0.2) (Process ID 1)
      Type-7 AS External Link States (Area 1)
  Routing Bit Set on this LSA
  LS age: 1903
  Options: (No TOS-capability, Type 7/5 translation, DC)
  LS Type: AS External Link
  Link State ID: 192.168.3.0 (External Network Number )
  Advertising Router: 10.1.0.3
  LS Seq Number: 80000015
  Checksum: 0x484F
  Length: 36
  Network Mask: /24
  Metric Type: 2 (Larger than any link state path)
  TOS: 0 
  Metric: 20 
  Forward Address: 192.168.14.3
  External Route Tag: 0
  Routing Bit Set on this LSA
  LS age: 1903
! Options: (No TOS-capability, Type 7/5 translation, DC)
  LS Type: AS External Link
  Link State ID: 192.168.41.0 (External Network Number )
  Advertising Router: 10.1.0.3
  LS Seq Number: 80000015
  Checksum: 0xA4CC
  Length: 36
  Network Mask: /24
  Metric Type: 2 (Larger than any link state path)
  TOS: 0 
  Metric: 20 
  Forward Address: 192.168.14.3
  External Route Tag: 0

Router 3

Ingresar el comando show ip ospf en el router3 visualiza la información para confirmar que el router3 está actuando como ASBR y que la área OSPF 1 se ha configurado para ser una área NSSA:

Router3# show ip ospf
 Routing Process "ospf 1" with ID 10.1.0.3
 Start time: 00:00:01.392, Time elapsed: 12:02:34.572
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
!It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
 Router is not originating router-LSAs with maximum metric
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 0 normal 0 stub 1 nssa
 Number of areas transit capable is 0
 External flood list length 0
    Area 1
  Number of interfaces in this area is 1
! It is a NSSA area
  Area has no authentication
  SPF algorithm last executed 11:38:13.368 ago
  SPF algorithm executed 3 times
  Area ranges are
  Number of LSA 7. Checksum Sum 0x050CF7
  Number of opaque link LSA 0. Checksum Sum 0x000000
  Number of DCbitless LSA 0
  Number of indication LSA 0
  Number of DoNotAge LSA 0
  Flood list length 0

Ejemplo: Área OSPF NSSA con el RFC 3101 inhabilitado y Active del RFC 1587

En el siguiente ejemplo, la salida para el OSPF del IP de la demostración y los comandos show ip ospf database nssa es para una área OSPF NSSA donde se inhabilita el RFC 3101, RFC 1587 es activos, y un router ABR NSSA se configura como traductor forzado NSSA LSA. Según lo descrito en “configurar OSPF NSSA”, si se inhabilita el RFC 3101, el traductor forzado NSSA LSA sigue siendo inactivo. La salida de comando demuestra esto.

Router# show ip ospf
Routing Process "ospf 1" with ID 10.0.2.1
Start time: 00:00:25.512, Time elapsed: 00:01:02.200
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Supports NSSA (compatible with RFC 1587)
Event-log enabled, Maximum number of events: 1000, Mode: cyclic
Router is not originating router-LSAs with maximum metric
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 0 normal 0 stub 1 nssa
Number of areas transit capable is 0
External flood list length 0
IETF NSF helper support enabled
Cisco NSF helper support enabled
Reference bandwidth unit is 100 mbps
Area 1
Number of interfaces in this area is 1
It is a NSSA area
Configured to translate Type-7 LSAs, inactive (RFC3101 support
disabled)
Area has no authentication
SPF algorithm last executed 00:00:07.160 ago
SPF algorithm executed 3 times
Area ranges are
Number of LSA 3. Checksum Sum 0x0245F0
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

Los “soportes NSSA (compatibles con la línea RFC el 1587)" en la salida indica que el RFC 1587 es activo o que la área OSPF NSSA es RFC 1587 compatible.

“Configurado para traducir Type-7 los LSA, (soporte del RFC3101 inhabilitado)” línea inactiva indica que la área OSPF NSSA tiene un router ABR configurado para actuar como traductor forzado del tipo 7 LSA, pero está inactiva porque se inhabilita el RFC 3101.

Router2# show ip ospf database nssa
Router Link States (Area 1)
LS age: 28
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 10.0.2.1
Advertising Router: 10.0.2.1
LS Seq Number: 80000004
Checksum: 0x5CA2
Length: 36
Area Border Router
AS Boundary Router
Unconditional NSSA translator
Number of Links: 1
Link connected to: a Stub Network
(Link ID) Network/subnet number: 192.0.2.5
(Link Data) Network Mask: 255.255.255.0
Number of MTID metrics: 0
TOS 0 Metrics: 10

La línea “del traductor incondicional NSSA” indica que el estatus del router ASBR NSSA está como traductor forzado NSSA LSA.

Ejemplo: OSPF Routing y redistribución de ruta

El OSPF requiere típicamente la coordinación entre muchos routeres internos, los ABR, y los ASBR. Como mínimo, los routers basados en OSPF se pueden configurar con todos los valores de parámetro predeterminados, sin autenticación, y con interfaces asignadas a áreas.

A continuación se muestran tres tipos de ejemplos:

  • El primer es una Configuración simple que ilustra OSPF básico los comandos.
  • El segundo ejemplo ilustra una configuración de un router interno, un ABR y los ASBRs dentro de un solo sistema autónomo OSPF, asignado arbitrariamente.
  • El tercer ejemplo ilustra una configuración más compleja y la aplicación de diversas herramientas disponibles para controlar entornos de ruteo basados en OSPF.

Ejemplo: Configuración básica de OSPF

El siguiente ejemplo ilustra una configuración de OSPF simple que habilite el proceso de ruteo de OSPF 9000, asocie la interfaz de Ethernet 0 al área 0.0.0.0, y redistribuya el RIP en el OSPF, y el OSPF en el RIP:

interface ethernet 0
 ip address 10.93.1.1 255.255.255.0
 ip ospf cost 1
!
interface ethernet 1
 ip address 10.94.1.1 255.255.255.0
!
router ospf 9000
 network 10.93.0.0 0.0.255.255 area 0.0.0.0
 redistribute rip metric 1 subnets
!
router rip
 network 10.94.0.0
 redistribute ospf 9000
 default-metric 1 

Ejemplo: OSPF básico configuración para el router interno ABR y ASBR

El siguiente ejemplo ilustra la asignación de cuatro IDs de área a cuatro rangos de direcciones IP. En el ejemplo, se inicializa el proceso de ruteo de OSPF 109, y se definen cuatro áreas OSPF: 10.9.50.0, 2,3, y 0. áreas 10.9.50.0, 2, y 3 rangos de dirección específica de la máscara, y permisos OSPF del área 0 para las cualesquier otras redes.

router ospf 109
 network 192.168.10.0 0.0.0.255 area 10.9.50.0
 network 192.168.20.0 0.0.255.255 area 2
 network 192.168.30.0 0.0.0.255 area 3
 network 192.168.40.0 255.255.255.255 area 0
!
! Interface Ethernet0 is in area 10.9.50.0:
interface ethernet 0
 ip address 192.168.10.5 255.255.255.0
!
! Interface Ethernet1 is in area 2:
interface ethernet 1
 ip address 192.168.20.5 255.255.255.0
!
! Interface Ethernet2 is in area 2:
interface ethernet 2
 ip address 192.168.20.7 255.255.255.0
!
! Interface Ethernet3 is in area 3:
interface ethernet 3
 ip address 192.169.30.5 255.255.255.0
!
! Interface Ethernet4 is in area 0:
interface ethernet 4
 ip address 192.168.40.1 255.255.255.0
!
! Interface Ethernet5 is in area 0:
interface ethernet 5
 ip address 192.168.40.12 255.255.0.0

Evalúan a cada comando router configuration de área de red secuencialmente, así que la orden de estos comandos en la configuración es importante. El Cisco IOS Software evalúa secuencialmente el direccionamiento/los pares basado en wildcard para cada interfaz. Vea el comando network area en el Routing IP del Cisco IOS: Referencia del comando ospf para más información.

Considere el primer comando network area. El ID de área 10.9.50.0 se configura para la interfaz en la cual la subred 192.168.10.0 está situada. Asuma que un emparejamiento está determinado para la interfaz de Ethernet 0 de la interfaz de Ethernet 0. está asociado al área 10.9.50.0 solamente.

Evalúan al segundo comando network area después. Para el área 2, el mismo proceso entonces se aplica a todas las interfaces (excepto la interfaz de Ethernet 0). Asuma que un emparejamiento está determinado para las interfaces Ethernet que 1. OSPF entonces se habilitan para esa interfaz y la interfaz de Ethernet 1 está asociada al área 2.

Este proceso de asociar las interfaces a las áreas OSPF continúa para todos los comandos network area. Observe que el comando network area más reciente de este ejemplo es un caso especial. Con este comando, todas las interfaces disponibles (asociadas no explícitamente a otra área) se asocian al área 0.

Ejemplo: Router interno complejo con el ABR y el ASBR

El siguiente ejemplo delinea una configuración para vario Routers dentro de un solo sistema autónomo OSPF. La figura abajo proporciona una correspondencia de red general que ilustre este ejemplo de configuración.

‘Figura 6’Correlación de la red del sistema autónomo de la muestra OSPF


En esta configuración, configuran a cinco Routers con el OSPF:

  • El router A y el router descubren ambos routeres internos dentro del área 1.
  • El router C es un ABR OSPF. Observe que para el C del router, el área 1 está asignada a E3 y al área 0 está asignada al s0.
  • El router D es un router interno en el área 0 (área de estructura básica). En este caso, ambos comandos de configuración network router especifican la misma área (área 0, o área de estructura básica).
  • El Router E es un OSPF ASBR. Observe que las rutas BGP se redistribuyen en OSPF y que estas rutas se anuncian mediante OSPF.

Nota


Usted no necesita incluir las definiciones de todas las áreas en un sistema autónomo OSPF en la configuración de todo el Routers en el sistema autónomo. Solamente las áreas directamente conectadas deben ser definidas. En el ejemplo que sigue, las rutas en el área 0 son aprendidas por el Routers en el área 1 (router A y router B) cuando el ABR (el router C) inyecta los LSA de resúmenes en el área 1.

El dominio OSPF en el sistema autónomo 109 BGP está conectado con el mundo exterior vía el link BGP al peer externo en la dirección IP 10.0.0.6. Los ejemplos de configuración siguen.

Lo que sigue es la configuración de muestra para la correspondencia de red general mostrada en la figura arriba.

Configuración del router A--Router interno
interface ethernet 1
 ip address 192.168.1.1 255.255.255.0
router ospf 1
 network 192.168.0.0 0.0.255.255 area 1
Configuración del Router B--Router interno
interface ethernet 2
 ip address 192.168.1.2 255.255.255.0
router ospf 202
 network 192.168.0.0 0.0.255.255 area 1
Configuración del Router C--ABR
interface ethernet 3
 ip address 192.168.1.3 255.255.255.0
interface serial 0
 ip address 192.168.2.3 255.255.255.0
router ospf 999
 network 192.168.1.0 0.0.0.255 area 1
 network 192.168.2.0 0.0.0.255 area 0
Configuración del Router D--Router interno
interface ethernet 4
 ip address 10.0.0.4 255.0.0.0
interface serial 1
 ip address 192.168.2.4 255.255.255.0
router ospf 50
 network 192.168.2.0 0.0.0.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
Configuración del router E--ASBR
interface ethernet 5
 ip address 10.0.0.5 255.0.0.0
interface serial 2
 ip address 172.16.1.5 255.255.255.0
router ospf 65001
 network 10.0.0.0 0.255.255.255 area 0
 redistribute bgp 109 metric 1 metric-type 1
router bgp 109
 network 192.168.0.0
 network 10.0.0.0
 neighbor 172.16.1.6 remote-as 110

Ejemplo: Configuración de OSPF compleja para el ABR

La siguiente configuración de ejemplo lleva a cabo varias tareas al configurar un ABR. Estas tareas se pueden dividir en dos categorías generales:

  • Configuración básica de OSPF
  • Redistribución de ruta

Las tareas específicas descritas en esta configuración se detallan brevemente en las descripciones siguientes. La figura abajo ilustra los rangos de dirección de red y las asignaciones de área para las interfaces.

Figura 7Especificaciones de la interfaz y de área para el ejemplo de configuración OSPF


Las tareas de configuración básicas de este ejemplo son las siguientes:

  • Configure los rangos de dirección para las interfaces Ethernet 0 a 3.
  • Habilite OSPF en cada interfaz.
  • Configura una contraseña de autenticación OSPF para cada área y red.
  • Asignar la métrica de estado de link y otras opciones de configuración de la interfaz OSPF.
  • Cree las zonas fragmentadas con el ID de área 36.0.0.0. (La nota que la autenticación y las opciones del stub del comando configuration del router de área se especifican con las entradas de comando separadas del área, pero se puede para combinar en un solo comando de área.)
  • Especifica el área de estructura básica (área 0).

Las tareas de configuración asociadas a la redistribución son las siguientes:

  • Redistribuya el IGRP y el RIP en el OSPF con las diversas opciones fijadas (incluir incluyendo el tipo métrico, métrico, la etiqueta, y la subred).
  • Redistribuya el IGRP y el OSPF en el RIP.

A continuación se muestra un ejemplo de configuración de OSPF:

interface ethernet 0
 ip address 192.42.110.201 255.255.255.0
 ip ospf authentication-key abcdefgh
 ip ospf cost 10
!
interface ethernet 1
 ip address 172.19.251.202 255.255.255.0
 ip ospf authentication-key ijklmnop
 ip ospf cost 20
 ip ospf retransmit-interval 10
 ip ospf transmit-delay 2
 ip ospf priority 4
!
interface ethernet 2
 ip address 172.19.254.2 255.255.255.0
 ip ospf authentication-key abcdefgh
 ip ospf cost 10
!
interface ethernet 3
 ip address 10.56.0.0 255.255.0.0
 ip ospf authentication-key ijklmnop
 ip ospf cost 20
 ip ospf dead-interval 80

En la configuración siguiente el OSPF está en la red 172.16.0.0:

router ospf 201
 network 10.10.0.0 0.255.255.255 area 10.10.0.0
 network 192.42.110.0 0.0.0.255 area 192.42.110.0
 network 172.16.0.0 0.0.255.255 area 0
 area 0 authentication
 area 10.10.0.0 stub
 area 10.10.0.0 authentication
 area 10.10.0.0 default-cost 20
 area 192.42.110.0 authentication
 area 10.10.0.0 range 10.10.0.0 255.0.0.0
 area 192.42.110.0 range 192.42.110.0 255.255.255.0
 area 0 range 172.16.251.0 255.255.255.0
 area 0 range 172.16.254.0 255.255.255.0
 redistribute igrp 200 metric-type 2 metric 1 tag 200 subnets
 redistribute rip metric-type 2 metric 1 tag 200

En la configuración siguiente, el sistema autónomo 200 IGRP está en 192.0.2.1:

router igrp 200
 network 172.31.0.0
!
! RIP for 192.168.110
!
router rip
 network 192.168.110.0
 redistribute igrp 200 metric 1
 redistribute ospf 201 metric 1

Ejemplos: Route map

Los ejemplos de esta sección ilustran el uso de la redistribución, con y sin route maps. Se proporcionan ejemplos para IP y CLNS (ConnectionLess Network Service) Routing Protocols.

El siguiente ejemplo redistribuye todas las OSPF rutas en el IGRP:

router igrp 109
 redistribute ospf 110

El siguiente ejemplo redistribuye las rutas RIP con un conteo de saltos igual a 1 en OSPF. Estas rutas serán redistribuidas en el OSPF pues LSA externo con un métrico de 5, un tipo de métrica de tipo 1, y una etiqueta igual a 1.

router ospf 109
 redistribute rip route-map rip-to-ospf
!
route-map rip-to-ospf permit
 match metric 1
 set metric 5
 set metric-type type1
 set tag 1

El siguiente ejemplo redistribuye rutas aprendidas de OSPF con la etiqueta 7 como una métrica RIP de 15:

router rip
 redistribute ospf 109 route-map 5
!
route-map 5 permit
 match tag 7
 set metric 15

El siguiente ejemplo redistribuye las trayectorias OSPF de intraárea e interárea con routers de siguiente salto en la interfaz serial 0 en el BGP con una métrica INTER_AS de 5:

router bgp 109
 redistribute ospf 109 route-map 10
!
route-map 10 permit
 match route-type internal
 match interface serial 0
 set metric 5

El siguiente ejemplo redistribuye dos tipos de rutas en la tabla de ruteo IS-IS integrada (que soporta tanto IP como CLNS). El primer tipo son rutas IP externas de OSPF con la etiqueta 5; estas rutas se insertan en los paquetes del estado del link del nivel 2 IS-IS (LSP) con un métrico de 5. El segundo tipo son las rutas con prefijo CLNS derivadas de ISO-IGRP que coinciden con la lista de acceso CLSN 2000; estas rutas serán redistribuidas en IS-IS como LSPs de nivel 2 con una métrica de 30.

router isis
 redistribute ospf 109 route-map 2
 redistribute iso-igrp nsfnet route-map 3
!
route-map 2 permit
 match route-type external
 match tag 5
 set metric 5
 set level level-2
!
route-map 3 permit
 match address 2000
 set metric 30

Con la configuración siguiente, las rutas externas OSPF con etiquetas 1, 2, 3 y 5 se redistribuyen en el RIP con la métrica de 1, 1, 5 y 5, respectivamente. Las rutas OSPF con una etiqueta de 4 no se redistribuyen.

router rip
 redistribute ospf 109 route-map 1
!
route-map 1 permit
 match tag 1 2
 set metric 1
!
route-map 1 permit 
 match tag 3
 set metric 5
!
route-map 1 deny
 match tag 4
!
route map 1 permit
 match tag 5
 set metric 5

En la configuración siguiente, una ruta aprendido del RIP para la red 160.89.0.0 y una ruta aprendido ISO-IGRP con el prefijo 49.0001.0002 serán redistribuidas en un nivel 2 LSP IS-IS con un métrico de 5:

router isis
 redistribute rip route-map 1
 redistribute iso-igrp remote route-map 1
!
route-map 1 permit
 match ip address 1
 match clns address 2
 set metric 5
 set level level-2
!
 access-list 1 permit 192.168.0.0 0.0.255.255
 clns filter-set 2 permit 49.0001.0002...

El ejemplo de configuración siguiente ilustra cómo se hace referencia a un route map en el comando de configuración del router default-information. Llaman este tipo de referencia las creaciones predeterminadas condicionales. El OSPF originará la ruta predeterminado (red 0.0.0.0) con un Tipo 2 métrico de 5 si 140.222.0.0 está en la tabla de ruteo.


Nota


Solamente las rutas externas al proceso OSPF se pueden utilizar para seguir, tal como rutas NON-OSPF o OSPF rutas de un proceso OSPF separado.
route-map ospf-default permit
 match ip address 1
 set metric 5
 set metric-type type-2
!
 access-list 1 permit 172.16.0.0 0.0.255.255
!
router ospf 109
 default-information originate route-map ospf-default

Ejemplo: Cambio de la distancia administrativa OSPF

Los cambios de configuración siguientes la distancia externa a 200, haciéndola menos digna de confianza. La figura abajo ilustra el ejemplo.

Figura 8Distancia administrativa OSPF


Configuración del router A

router ospf 1
 redistribute ospf 2 subnet
 distance ospf external 200
!
router ospf 2
 redistribute ospf 1 subnet
 distance ospf external 200

Configuración del Router B

router ospf 1
 redistribute ospf 2 subnet
 distance ospf external 200
!
router ospf 2
 redistribute ospf 1 subnet
 distance ospf external 200

Ejemplo: OSPF sobre el On-Demand Routing

La configuración siguiente permite el OSPF sobre un circuito a pedido, tal y como se muestra en de la figura abajo. Observe que el circuito a pedido está definido en un lado solamente (BRI0 en el router A); no se requiere ser configurado en los ambos lados.

Figura 9OSPF sobre el circuito a pedido


Configuración del router A

username RouterB password 7 060C1A2F47
isdn switch-type basic-5ess
ip routing
!
interface TokenRing0
 ip address 192.168.50.5 255.255.255.0
 no shutdown
!
interface BRI0
 no cdp enable
 description connected PBX 1485
 ip address 192.168.45.30 255.255.255.0
 encapsulation ppp
 ip ospf demand-circuit
 dialer map ip 140.10.10.6 name RouterB broadcast 61484
 dialer-group 1
 ppp authentication chap
 no shutdown
!
router ospf 100
 network 192.168.45.0 0.0.0.255 area 0
 network 192.168.45.50 0.0.0.255 area 0
!
dialer-list 1 protocol ip permit

Configuración del Router B

username RouterA password 7 04511E0804
isdn switch-type basic-5ess
ip routing
!
interface Ethernet0
 ip address 192.168.50.16 255.255.255.0
 no shutdown
!
interface BRI0
 no cdp enable
 description connected PBX 1484
 ip address  192.168.45.17 255.255.255.0
 encapsulation ppp
 dialer map ip 192.168.45.19 name RouterA broadcast 61485
 dialer-group 1
 ppp authentication chap	
 no shutdown
!
router ospf 100
 network 192.168.45.0 0.0.0.255 area 0
 network 192.168.45.50 0.0.0.255 area 0
!
dialer-list 1 protocol ip permit

Ejemplo: Establecimiento del paso del grupo LSA

El siguiente ejemplo cambia el OSPF que establece el paso entre los grupos LSA a 60 segundos:

router ospf
 timers pacing lsa-group 60

Ejemplo: Inundación del bloque LSA

El siguiente ejemplo previene inundar de OSPF LSA para transmitir, nonbroadcast, o interfaz de Ethernet directa accesible 0 de los red Point-to-Point:

interface ethernet 0
 ip ospf database-filter all out

El siguiente ejemplo previene inundar de OSPF LSA a las redes de punto a multipunto al vecino en la dirección IP 10.10.10.45:

router ospf 109
 neighbor 10.10.10.45 database-filter all out

Ejemplo: Ignore los paquetes LSA MOSPF

El siguiente ejemplo configura al router para suprimir el envío de los mensajes de Syslog cuando recibe los paquetes MOSPF:

router ospf 109
 ignore lsa mospf

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Comandos OSPF

Routing IP del Cisco IOS: Referencia del comando ospf

Características del protocolo independiente que trabajan con el OSPF

“Configurando las características IP Routing Protocol-Independent”

Estándares

Estándar

Título

No se soportan los nuevos o modificados estándares, y el soporte para los estándares existentes no se ha modificado.

--

MIB

MIB

Link del MIB

Se soporta el MIB no nuevo o modificado, y el soporte para el MIB existente no se ha modificado.

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 1253

Management Information Base de la versión 2 OSPF, agosto de 1991.

RFC 1587

La opción OSPF NSSA, marzo de 1994

RFC 1793

OSPF que extiende para soportar los circuitos de la demanda, abril de 1995

RFC 2328

Versión 2 OSPF, abril de 1998

RFC 3101

La opción OSPF NSSA, enero de 2003

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información de la característica para configurar el OSPF

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para el OSPF

Nombre de la función

Versiones

Información sobre la Función

OSPF

11.2.1

El OSPF es un IGP desarrollado por el Grupo de trabajo OSPF del IETF. Diseñado expreso para las redes IP, los soportes OSPF conexión en subredes IP y marcar con etiqueta de la información de ruteo externamente derivada. El OSPF también permite la autenticación de paquete y utiliza el Multicast IP al enviar y recibiendo los paquetes.

Reducción de la inundación de OSPF

12.1(2)T

La solución de la reducción de la inundación de OSPF trabaja reduciendo la restauración e inundar innecesarios de la información ya sabida y sin cambios. Esta característica se documenta en la sección siguiente:

OSPF Not-So-Stubby Areas

11.2.1

El OSPF NSSA es una extensión nonproprietary de la característica existente de las zonas fragmentadas OSPF. Esta característica se documenta en las secciones siguientes:

Establecimiento del paso del paquete OSPF

12.0(1)T

Los paquetes de actualización OSPF se establecen el paso automáticamente así que no se envían menos de 33 milisegundos de separado. Esta característica se documenta en la sección siguiente:

Soporte OSPF para el RFC 3101 NSSA

15.1(2)S

15.0(1)SY

15.2(2)T

Esta característica agrega el soporte para la especificación OSPF NSSA descrita por el RFC 3101. El RFC3101 substituyó el RFC 1587 y es compatible con versiones anteriores con el RFC1587.

Se han insertado o modificado los siguientes comandos: el nssa del área traduce, rfc1587 compatible.

OSPF - Neutralización del circuito de la demanda

15.0(1)SY

La palabra clave de la negligencia fue agregada al comando ip ospf demand-circuit, permitiendo usted evite que una interfaz valide las peticiones del demand circuit del otro Routers.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.