Guía de configuración del Server Load Balancing, Cisco IOS Release 12.2SR
Ejemplos de Configuración de IOS SLB
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 841 KB | Inglés (29 Abril 2011) | Comentarios

Contenido

Ejemplos de Configuración de IOS SLB

Última actualización: De abril el 26 de 2011

Esta sección proporciona los ejemplos del mundo real de las Configuraciones de SLB del OIS. Para una descripción completa de los comandos IOS SLB en esta sección, refiera a la referencia de comandos de los Servicios de aplicación IP del Cisco IOS. Para localizar la documentación de otros comandos que aparecen en esta sección, busque en línea usando Cisco.com.

Esta sección incluye los siguientes ejemplos:


Nota


El IP y las direcciones de red en estos ejemplos son genéricos; usted debe substituirlos por las direcciones reales para su red.

Ejemplo cómo configurar una red básica IOS SLB

La figura abajo muestra una red IOS SLB de la muestra con los componentes siguientes:

  • Dos bloques de servidores--uno configurado para permitir el acceso por el público y PUBLIC Nombrado, uno configurado para permitir el acceso limitado y a RESTRICTED Nombrado.
  • Cinco servidores reales configurados como sigue:
    • Tres servidores reales en el bloque de servidores PÚBLICO con los IP Addresses 10.1.1.1, 10.1.1.2, y 10.1.1.3
    • Dos servidores reales en el bloque de servidores restricto con los IP Addresses 10.1.1.20 y 10.1.1.21
  • Dos servidores virtuales--uno configurado para permitir el acceso por el público y el PUBLIC_HTTP nombrado y uno configurado para permitir el acceso limitado y RESTRICTED_HTTP Nombrado.
    • El servidor virtual PUBLIC_HTTP se configura con las conexiones TCP del Equilibrio de carga de la dirección IP 10.0.0.1 en el puerto WWW (80).
    • El servidor virtual RESTRICTED_HTTP se configura con las conexiones TCP del Equilibrio de carga de la dirección IP 10.0.0.2 en el puerto WWW (80) y permite el acceso solamente de los clientes de la red 10.4.4.0 255.255.255.0.
Cuadro 1. red IOS SLB del ejemplo

Las secciones siguientes incluyen los ejemplos de los comandos configuration usados para configurar y para verificar la red IOS SLB mostrada en la figura arriba.

Configuración de la Granja de Servidores

El siguiente ejemplo muestra la configuración para el PÚBLICO del bloque de servidores, asociada a tres servidores reales:

ip slb serverfarm PUBLIC
  real 10.1.1.1
    reassign 2
    faildetect numconns 4 numclients 2
    retry 20
    inservice
    exit
  real 10.1.1.2
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
    exit
  real 10.1.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
    end

El siguiente ejemplo muestra la configuración para el bloque de servidores RESTRINGIDO, asociada a dos servidores reales:

ip slb serverfarm RESTRICTED
  real 10.1.1.20
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
    exit
  real 10.1.1.21
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
    end

Configuración del Servidor Virtual

El siguiente ejemplo muestra la configuración para los servidores virtuales PUBLIC_HTTP y RESTRICTED_HTTP:

ip slb vserver PUBLIC_HTTP
  virtual 10.0.0.1 tcp www
  serverfarm PUBLIC
  idle 120
  delay 5
  inservice
  exit
ip slb vserver RESTRICTED_HTTP
  virtual 10.0.0.2 tcp www
  serverfarm RESTRICTED
  idle 120
  delay 5
  inservice
  end

Configuración Restricta del Cliente

El siguiente ejemplo muestra la configuración para el servidor virtual RESTRICTED_HTTP:

ip slb vserver RESTRICTED_HTTP
  no inservice
  client 10.4.4.0 255.255.255.0
  inservice
  end

Ejemplo cómo configurar una red completa IOS SLB

El siguiente ejemplo proporciona una configuración completa usando muchos de los comandos descritos en este documento de la característica:

ip slb probe PROBE2 http
 request method POST url /probe.cgi?all
 header HeaderName HeaderValue
!
ip slb serverfarm PUBLIC
 nat server
 real 10.1.1.1
  reassign 4
  faildetect numconns 16
  retry 120
  inservice
 real 10.1.1.2
  reassign 4
  faildetect numconns 16
  retry 120
  inservice
probe PROBE2
!
ip slb serverfarm RESTRICTED
 predictor leastconns
 bindid 309
 real 10.1.1.1
  weight 32
  maxconns 1000
  reassign 4
  faildetect numconns 16
  retry 120
  inservice
 real 10.1.1.20
  reassign 4
  faildetect numconns 16
  retry 120
  inservice
 real 10.1.1.21
  reassign 4
  faildetect numconns 16
  retry 120
  inservice
!
ip slb vserver PUBLIC_HTTP
 virtual 10.0.0.1 tcp www
 serverfarm PUBLIC
!
ip slb vserver RESTRICTED_HTTP
 virtual 10.0.0.2 tcp www
 serverfarm RESTRICTED
 no advertise
 sticky 60 group 1
 idle 120
 delay 5
 client 10.4.4.0 255.255.255.0
 synguard 3600000
 inservice

Ejemplos cómo configurar IOS SLB con el Equilibrio de carga de firewall

Esta sección contiene los siguientes ejemplos, ilustrando varias diversas configuraciones del equilibrio de carga de escudo de protección IOS SLB:

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga de firewall básico

La figura abajo muestra una red del equilibrio de carga de escudo de protección IOS SLB de la muestra con los componentes siguientes:

  • Se muestran dos firewalls con las direcciones IP
  • Un dispositivo interno de balanceo de carga del firewall en el lado seguro de los firewalls
  • Un dispositivo externo de balanceo de carga de firewalls en el lado de Internet de los firewalls
  • Un bloque de firewalls denominado FIRE1, que contiene ambos firewalls
Cuadro 2. IOS SLB con los Firewall de la capa 3 en diversas subredes

Cuando usted configura el Equilibrio de carga de firewall IOS SLB, las operaciones de búsqueda de la ruta del uso de los dispositivos del balanceo de carga para reconocer los flujos destinaron para los Firewall. Para habilitar las operaciones de búsqueda de la ruta, usted debe configurar cada dispositivo con la dirección IP de cada Firewall que ruteará los flujos a ese dispositivo.

En los ejemplos siguientes de configuración de granjas de firewall:

  • El dispositivo interno de balanceo de carga del firewall (lado seguro) se configura con las direcciones IP 10.1.3.1 y 10.1.4.1 del firewall.
  • El dispositivo externo de balanceo de carga del firewall (lado de Internet) se configura con las direcciones IP 10.1.1.2 y 10.1.2.2 del firewall.

Dispositivo Interno de Balanceo de Carga de Firewall

El siguiente ejemplo muestra la configuración para la sonda PROBE1 del ping, el sondeo HTTP PROBE2, y la granja FIRE1 del Firewall, asociada a los dos servidores reales para el dispositivo del balanceo de carga en el lado (seguro) interno del Firewall:

!-----Ping probe
ip slb probe PROBE1 ping
!-----IP address of other load-balancing device
  address 10.1.1.1
  faildetect 4
!-----HTTP probe
  ip slb probe PROBE2 http
!-----IP address of other load-balancing device
  address 10.1.2.1
  expect status 401
!-----Firewall farm FIRE1
ip slb firewallfarm FIRE1
!-----First firewall
  real 10.1.4.1
    probe PROBE1
!-----Enable first firewall
    inservice
!-----Second firewall
    real 10.1.3.1
    probe PROBE2
!-----Enable second firewall
    inservice

Dispositivo Externo de Balanceo de Carga de Firewalls

El siguiente ejemplo muestra la configuración para la sonda PROBE1 del ping, el sondeo HTTP PROBE2, y la granja FIRE1 del Firewall, asociada a los dos servidores reales para el dispositivo del balanceo de carga en el lado externo (de Internet) del Firewall:

!-----Ping probe
ip slb probe PROBE1 ping
!-----IP address of other load-balancing device
  address 10.1.4.2
  faildetect 4
!-----HTTP probe
ip slb probe PROBE2 http
!-----IP address of other load-balancing device
  address 10.1.3.2
  expect status 401
!-----Firewall farm FIRE1
ip slb firewallfarm FIRE1
!-----First firewall
  real 10.1.1.2
    probe PROBE1
!-----Enable first firewall
    inservice
!-----Second firewall
  real 10.1.2.2
    probe PROBE2
!-----Enable second firewall
    inservice
    exit
  inservice

Ejemplo cómo configurar IOS SLB con el Server Load Balancing y el Equilibrio de carga de firewall

La figura abajo muestra una red de balanceo de carga IOS SLB de la muestra con el Server Load Balancing y el Equilibrio de carga de firewall que se ejecutan junta, y los componentes siguientes:

  • Dos servidores reales con los IP Addresses como se muestra
  • Un bloque de servidores PUBLIC Nombrado, conteniendo ambos servidores reales
  • Se muestran dos firewalls con las direcciones IP
  • Un bloque de firewalls denominado FIRE1, que contiene ambos firewalls
  • Un dispositivo SLB interno IOS en el lado seguro de los Firewall, realizando el Server Load Balancing y el Equilibrio de carga de firewall
  • Un dispositivo externo de balanceo de carga de firewalls en el lado de Internet de los firewalls
Cuadro 3. IOS SLB con el Server Load Balancing y el Equilibrio de carga de firewall

En los ejemplos siguientes de configuración de granjas de firewall:

  • El dispositivo interno de balanceo de carga del firewall (lado seguro) se configura con las direcciones IP 10.1.3.1 y 10.1.4.1 del firewall.
  • El dispositivo externo de balanceo de carga del firewall (lado de Internet) se configura con las direcciones IP 10.1.1.2 y 10.1.2.2 del firewall.

Servidor interno y dispositivo del equilibrio de carga de escudo de protección

El siguiente ejemplo muestra la configuración para las sondas ABCPROBE y XYZPROBE del ping, la granja FIRE1 del Firewall, y PÚBLICO del bloque de servidores para el dispositivo del balanceo de carga en el lado (seguro) interno de los Firewall:

ip slb probe ABCPROBE ping
  address 10.1.1.1
ip slb probe XYZPROBE ping
  address 10.1.2.1
!
ip slb firewallfarm FIRE1
  real 10.1.4.1
    probe ABCPROBE
    inservice
  real 10.1.3.1
    probe XYZPROBE
    inservice
  inservice
!
ip slb serverfarm PUBLIC
  nat server
  real 10.2.1.1
    inservice
    real 10.2.1.2
    inservice
!
ip slb vserver HTTP1
  virtual 128.1.0.1 tcp www
  serverfarm PUBLIC
  idle 120
  delay 5
  inservice

Dispositivo Externo de Balanceo de Carga de Firewalls

El siguiente ejemplo muestra la configuración para las sondas ABCPROBE del ping y la granja FIRE1 XYZPROBE y del Firewall para el dispositivo del balanceo de carga en el lado externo (de Internet) de los Firewall:

ip slb probe ABCPROBE ping
  address 10.1.4.2
  ip slb probe XYZPROBE ping
  address 10.1.3.2
  ip slb firewallfarm FIRE1
  real 10.1.1.2
    probe ABCPROBE
    inservice
    probe XYZPROBE
    inservice

El ejemplo cómo configurar IOS SLB con el firewall múltiple cultiva

La figura abajo muestra una red de balanceo de carga IOS SLB de la muestra con las granjas del firewall múltiple y los componentes siguientes:

  • Cuatro Firewall con los IP Addresses como se muestra
  • Un dispositivo interno de balanceo de carga del firewall en el lado seguro de los firewalls
  • Un dispositivo externo de balanceo de carga de firewalls en el lado de Internet de los firewalls
  • Una granja ABCFARM Nombrado del Firewall, conteniendo los dos Firewall a la izquierda.
  • Una granja XYZFARM Nombrado del Firewall, conteniendo los dos Firewall a la derecha.
Cuadro 4. IOS SLB con las granjas del firewall múltiple

En los ejemplos siguientes de configuración de granjas de firewall:

  • El dispositivo interno de balanceo de carga del firewall (lado seguro) se configura con las direcciones IP 10.1.3.1 y 10.1.4.1 del firewall.
  • El dispositivo externo de balanceo de carga del firewall (lado de Internet) se configura con las direcciones IP 10.1.1.2 y 10.1.2.2 del firewall.

Dispositivo Interno de Balanceo de Carga de Firewall

El siguiente ejemplo muestra la configuración para las sondas ABCPROBE del ping y las granjas ABCFARM y XYZFARM XYZPROBE y del Firewall para el dispositivo del balanceo de carga en el lado (seguro) interno de los Firewall:

ip slb probe ABCPROBE ping
  address 10.1.2.1
ip slb probe XYZPROBE ping
  address 10.1.1.1
ip slb firewallfarm ABCFARM
  access source 10.1.6.0 255.255.255.0
  inservice
  real 10.1.4.2
    probe ABCPROBE
    inservice
  real 10.1.4.3
    probe ABCPROBE
    inservice
ip slb firewallfarm XYZFARM
  access source 10.1.5.0 255.255.255.0
  inservice
  real 10.1.3.2
    probe XYZPROBE
    inservice
  real 10.1.3.3
    probe XYZPROBE
    inservice

Dispositivo Externo de Balanceo de Carga de Firewalls

El siguiente ejemplo muestra la configuración para las sondas ABCPROBE del ping y las granjas ABCFARM y XYZFARM XYZPROBE y del Firewall para el dispositivo del balanceo de carga en el lado externo (de Internet) de los Firewall:

ip slb probe ABCPROBE ping
  address 10.1.4.1
ip slb probe XYZPROBE ping
  address 10.1.3.1
ip slb firewallfarm ABCFARM
  access destination 10.1.6.0 255.255.255.0
  inservice
  real 10.1.2.2
    probe ABCPROBE
    inservice
  real 10.1.2.3
    probe ABCPROBE
    inservice
ip slb firewallfarm XYZFARM
  access destination 10.1.5.0 255.255.255.0
  inservice
  real 10.1.1.2
    probe XYZPROBE
    inservice
  real 10.1.1.3
    probe XYZPROBE
    inservice

Ejemplo cómo configurar IOS SLB con el  dual del € de Sandwichâ del œ del € del â del Equilibrio de carga de firewall

La figura abajo ilustra una configuración dual básica del  del € del sandwichâ del œ del € del â del Equilibrio de carga de firewall recibida en un dispositivo SLB IOS, incluyendo el Red privada virtual (VPN) que rutea y que remite (VRF) y configuración de la interfaz de acceso. VL105, VL106, VL107 y VL108 son VLANs.


Nota


El cliente y servidor en esta configuración está conectado directamente; en las más instalaciones típicas, las rutas adicionales serían necesitadas dentro y fuera del VRF.
Cuadro 5. IOS SLB con el  dual del € de Sandwichâ del œ del € del â del Equilibrio de carga de firewall

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip vrf client
 rd 0:1
!
ip slb probe P642 ping
 address 10.10.106.42
 interval 120
ip slb probe P643 ping
 address 10.10.106.43
 interval 120
ip slb probe P742 ping
 address 10.10.107.42
 interval 120
ip slb probe P743 ping
 address 10.10.107.43
 interval 120
!
ip slb firewallfarm CLIENT
 access inbound Vlan105
 access outbound Vlan106
 no inservice
!
 real 10.10.106.42
  probe P642
  inservice
 real 10.10.106.43
  probe P643
  inservice
 protocol tcp
  sticky 180 source
 protocol datagram
  sticky 180 source
 predictor hash address port
!
ip slb firewallfarm SERVER
 access inbound Vlan108
 access outbound Vlan107
 inservice
!
 real 10.10.107.42
  probe P742
  inservice
 real 10.10.107.43
  probe P743
  inservice
 protocol tcp
  sticky 180 destination
 protocol datagram
  sticky 180 destination
 predictor hash address port
!
mls flow ip interface-full
!
!*************************************************
!* Switchports, port channels and trunks         *
!* added to vlans 105-108 (left out for brevity) *
!*************************************************
!
interface Vlan105
 ip vrf forwarding client
 ip address 10.10.105.2 255.255.255.0
!
interface Vlan106
 ip vrf forwarding client
 ip address 10.10.106.2 255.255.255.0
!
interface Vlan107
 ip address 10.10.107.2 255.255.255.0
!
interface Vlan108
 ip address 10.10.108.2 255.255.255.0
!
ip route 10.10.105.0 255.255.255.0 10.10.107.42
ip route vrf client 10.10.108.0 255.255.255.0 10.10.106.42

Ejemplos cómo configurar IOS SLB con las sondas

Esta sección contiene los siguientes ejemplos, ilustrando varias diversas configuraciones de sonda IOS SLB:

Ejemplo cómo configurar IOS SLB con el ping y las sondas HTTP

La figura abajo muestra una configuración de muestra con las conexiones del servidor real IOS SLB configuradas como parte de un bloque de servidores, centrándose en usar el ping y las sondas HTTP para monitorear las aplicaciones que son carga balanceada del servidor.

Cuadro 6. ping de la muestra y topología del sondeo HTTP

La topología mostrada en la figura antedicha es un bloque de servidores heterogéneo que mantiene un servidor virtual. Están siguiendo las sentencias de configuración para esta topología, incluyendo una sonda del ping nombrada PROBE1 y un sondeo HTTP nombrado PROBE2:

! Configure ping probe PROBE1, change CLI to IOS SLB probe configuration mode
ip slb probe PROBE1 ping
! Configure probe to receive responses from IP address 13.13.13.13
  address 13.13.13.13
! Configure unacknowledged ping threshold to 16
  faildetect 16
! Configure ping probe timer interval to send every 11 seconds
  interval 11
! Configure HTTP probe PROBE2
  ip slb probe PROBE2 http
! Configure request method as POST, set URL as /probe.cgi?all
  request method post url /probe.cgi?all
! Configure header HeaderName
  header HeaderName HeaderValue
! Configure basic authentication username and password
  credentials Semisweet chips
! Exit to global configuration mode
  exit
! Enter server farm configuration mode for server farm PUBLIC
ip slb serverfarm PUBLIC
! Configure NAT server and real servers on the server farm
  nat server
  real 10.1.1.1
   inservice
  real 10.1.1.2
   inservice
  real 10.1.1.3
   inservice
  real 10.1.1.4
   inservice
  real 10.1.1.5
   inservice
! Configure ping probe on the server farm
  probe PROBE1
! Configure HTTP probe on the server farm
  probe PROBE2
  end

Ejemplo cómo configurar IOS SLB con la sonda ruteada

La figura abajo muestra un datacenter y una Configuración de SLB del OIS típicos. El servidor virtual ACME_VSERVER se configura con dos servidores reales (10.10.10.1 y 10.10.10.2) en el bloque de servidores ACME_FARM. El usuario quisiera que los servidores reales fallaran basado en la salud del servidor de extremo posterior (10.10.10.3). Para lograr esta configuración sin el envío de las revisiones médicas a través de los servidores reales, el usuario define la PARTE, una sonda ruteada del ping a la dirección IP backend del ™ s del € del serverâ.

Cuadro 7. IOS SLB con una sonda ruteada del ping

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb probe BACKEND ping
  address 10.10.10.3 routed
ip slb serverfarm ACME_SFARM
  nat server
  probe BACKEND
  real 10.10.10.1
   inservice
  real 10.10.10.2
   inservice
ip slb vserver ACME_VSERVER
  virtual 10.10.10.10 tcp 80
  serverfarm ACME_SFARM
  inservice	

Ejemplo cómo configurar un switch de la capa 3 con IOS SLB

La figura abajo muestra una configuración de muestra con las conexiones del servidor IOS SLB configuradas como parte de un bloque de servidores.

Cuadro 8. configuración de red para IOS SLB

Tal y como se muestra en del siguiente ejemplo, el ejemplo de topología tiene tres servidores web públicos y dos servidores Web restringidos para los clientes privilegiados en la subred 10.4.4.0. Los servidores web públicos se cargan según su capacidad, con el servidor 10.1.1.2 que tiene la capacidad más baja y que tiene un límite de la conexión impuesto ante él. Los servidores Web restrictos se configuran como miembros del mismo grupo Sticky, de modo que las conexiones de las conexiones HTTP y del Secure Socket Layer (SSL) del mismo cliente utilicen el mismo servidor real.

La configuración de red para proporcionar las funciones previamente descritas IOS SLB sigue:

ip slb probe PROBE2 http
  request method POST url /probe.cgi?all
  header HeaderName HeaderValue
  header Authorization Basic U2VtaXN3ZWV0OmNoaXBz
!
ip slb serverfarm PUBLIC
  nat server
  predictor leastconns
! First real server
  real 10.1.1.1
    reassign 4
    faildetect numconns 16
    retry 120
    inservice
! Second real server
  real 10.1.1.2
    reassign 4
    faildetect numconns 16
    retry 120
    inservice
! Third real server
  real 10.1.1.3
    reassign 4
    faildetect numconns 16
    retry 120
    inservice
! Probe
  probe PROBE2
! Restricted web server farm
ip slb serverfarm RESTRICTED
  predictor leastconns
! First real server
  real 10.1.1.20
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Second real server
  real 10.1.1.21
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
!
! Unrestricted web virtual server
ip slb vserver PUBLIC_HTTP
  virtual 10.0.0.1 tcp www
  serverfarm PUBLIC
  idle 120
  delay 5
  inservice
!
! Restricted HTTP virtual server
ip slb vserver RESTRICTED_HTTP
  virtual 10.0.0.1 tcp www
  serverfarm RESTRICTED
  client 10.4.4.0 255.255.255.0
  sticky 60 group 1
  idle 120
  delay 5
  inservice
!
! Restricted SSL virtual server
ip slb vserver RESTRICTED_SSL
  virtual 10.0.0.1 tcp https
  serverfarm RESTRICTED
  client 10.4.4.0 255.255.255.0
  sticky 60 group 1
  idle 120
  delay 5
  inservice
!
interface GigabitEthernet1/1
  switchport
  switchport access vlan 3
  switchport mode access
  no ip address
!
interface FastEthernet2/1
  switchport
  switchport access vlan 2
  switchport mode access
  no ip address
!
interface FastEthernet2/2
  switchport
  switchport access vlan 2
  switchport mode access
  no ip address
!
interface FastEthernet2/3
  switchport
  switchport access vlan 2
  switchport mode access
  no ip address
!
interface Vlan2
  ip address 10.1.1.100 255.255.255.0
!
interface Vlan3
  ip address 40.40.40.1 255.255.255.0

Ejemplos cómo configurar IOS SLB con el NAT y el NAT estático

Esta sección contiene los siguientes ejemplos, ilustrando varias diversas configuraciones del NAT IOS SLB:

Ejemplo cómo configurar IOS SLB con el NAT

La figura abajo muestra una configuración de muestra con las conexiones del servidor real IOS SLB configuradas como parte de un bloque de servidores, centrándose en la configuración del servidor NAT y de la agrupación de direcciones de los clientes.

Cuadro 9. topología IOS SLB NAT de la muestra

La topología en la figura antedicha tiene cuatro servidores Web, configurados como sigue:

  • Los servidores 1, 2, y 3 son solas aplicaciones de servidor HTTP corrientes que escuchan en el puerto 80.
  • El servidor 4 tiene aplicaciones de servidor HTTP múltiples que escuchan en los puertos 8080, 8081, y 8082.

El server1 y el server2 son la carga balanceada usando el Switch A, que está realizando la traducción de la dirección del servidor.

El Server3 y el servidor 4 son carga balanceada usando el C del switch B y del Switch. Este dos Switches está realizando el servidor y la traducción de la dirección cliente puesto que hay trayectos múltiples entre los clientes y los servidores. Este Switches también debe realizar la traducción del puerto de servidor para los paquetes HTTP a y desde el servidor 4.

Sentencias de configuración del Switch A

ip slb serverfarm FARM1
! Translate server addresses
  nat server
! Server 1 port 80
  real 10.1.1.1
    reassign 2
    faildetect numconns 4 numclients 2
    retry 20
    inservice
! Server 2 port 80
  real 10.2.1.1
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
!
ip slb vserver HTTP1
! Manage HTTP (port 80) requests
  virtual 128.1.0.1 tcp www
  serverfarm FARM1
  idle 120
  delay 5
  inservice

Sentencias de configuración del switch B

ip slb natpool web-clients 128.3.0.1 128.3.0.254
! NAT address pool for clients
ip slb serverfarm FARM2
! Translate server addresses
  nat server
! Translate client addresses
  nat client web-clients
! Server 3 port 80
  real 10.3.1.1
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Server 4 port 8080
  real 10.4.1.1 port 8080
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Server 4 port 8081
  real 10.4.1.1 port 8081
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Server 4 port 8082
  real 10.4.1.1 port 8082
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
!
ip slb vserver HTTP2
! Manage HTTP (port 80) requests
  virtual 128.2.0.1 tcp www
  serverfarm FARM2
  idle 120
  delay 5
  inservice

Sentencias de configuración del C del Switch

ip slb natpool web-clients 128.5.0.1 128.5.0.254
! NAT address pool for clients
ip slb serverfarm FARM2
! Translate server addresses
  nat server
! Translate client addresses
  nat client web-clients 
! Server 3 port 80
  real 10.3.1.1
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Server 4 port 8080
  real 10.4.1.1 port 8080
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Server 4 port 8081
  real 10.4.1.1 port 8081
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
! Server 4 port 8082
  real 10.4.1.1 port 8082
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
!
ip slb vserver HTTP2
! Manage HTTP (port 80) requests
  virtual 128.4.0.1 tcp www
  serverfarm FARM2
  idle 120
  delay 5
  inservice

Ejemplo cómo configurar IOS SLB con el NAT estático

El siguiente ejemplo muestra las sentencias de configuración para los elementos siguientes:

  • Una sonda DNS, PROBE4, configurado para suministrar a la dirección IP 13.13.13.13 del servidor real en respuesta a las peticiones de la resolución del Domain Name.
  • Un bloque de servidores, DNS, que se configura para utilizar el servidor NAT y PROBE4.
  • Un servidor virtual del todo-puerto, 10.11.11.11, asociado al bloque de servidores DNS, que realiza el Server Load Balancing por paquete para las conexiones UDP.
  • Un servidor real, 10.1.1.3, asociado al bloque de servidores DNS, configurado para el NAT estático y el Server Load Balancing por paquete.
ip slb probe PROBE4 dns
 lookup 13.13.13.13
!
ip slb serverfarm DNS
 nat server
 probe PROBE4
 real 10.1.1.3
  inservice
!
ip slb vserver DNS
 virtual 10.11.11.11 UDP 0 service per-packet
 serverfarm DNS
!
ip slb static nat 10.11.11.11 per-packet
 real 10.1.1.3

Ejemplos cómo configurar IOS SLB con la Redundancia

Esta sección contiene los siguientes ejemplos, que ilustran varias configuraciones de IOS SLB distintas con redundancia:

Ejemplos cómo configurar IOS SLB con el respaldo apátrida

Hay varias maneras diferentes en las cuales usted puede configurar el respaldo apátrida IOS SLB. Las diferencias entre las configuraciones dependen de las capacidades de trabajo en red de sus dispositivos del Equilibrio de carga, y de las capacidades de los dispositivos de distribución que dirigen el tráfico del cliente a esos dispositivos del Equilibrio de carga.

  • Si un dispositivo del Equilibrio de carga no es capaz de ambo Layer 2 Switching y VLAN Trunking, usted debe conectar lo y sus servidores reales con un 2 Switch de la capa. Esta configuración se requiere para utilizar el HSRP en los VLA N del lado del servidor.
  • Si un dispositivo de distribución es capaz del Layer 3 Switching, puede utilizar la redistribución de ruta para dirigir los flujos al dispositivo activo del Equilibrio de carga.
  • Si un dispositivo de distribución es capaz del Layer 2 Switching, puede utilizar el HSRP del client cara en el dispositivo del Equilibrio de carga para dirigir los flujos al dispositivo activo del Equilibrio de carga.
  • Mientras que el HSRP ofrece tiempos más rápidos de la Conmutación por falla, el rutear converge rápidamente bastante para la mayoría de las configuraciones. Si usted utiliza el client cara y el HSRP del lado del servidor en los dispositivos del Equilibrio de carga, usted debe utilizar el seguimiento de interfaz y las prioridades del HSRP para sincronizar a los grupos del HSRP del client cara y del lado del servidor.

Esta sección contiene los siguientes ejemplos, ilustrando varias diversas configuraciones de respaldo apátridas IOS SLB:


Nota


El respaldo stateful se omite de estos ejemplos en interés de la simplicidad. Para ver un ejemplo que utilice el respaldo stateful, vea el ejemplo del œ del € del â: Cómo configurar IOS SLB con la sección stateful del  del € de Backupâ.

Ejemplo cómo configurar el Dynamic Routing y el enlace

La figura abajo muestra a IOS SLB de la muestra la configuración de respaldo apátrida con las siguientes características:

  • La dirección IP del servidor real 1 es 10.10.1.3, y la del servidor real 2 es 10.10.1.4, ruteadas a los clientes a través de 10.10.1.100.
  • La dirección IP para el servidor virtual es 10.10.14.1.
  • La dirección IP de la VLAN 1 es 10.10.1.0, con una máscara de subred de 255.255.255.0.
  • La dirección IP de la subred 2 es 10.10.2.0, con una máscara de subred de 255.255.255.0.
  • La dirección IP de la subred 3 es 10.10.3.0, con una máscara de subred de 255.255.255.0.
  • El dispositivo de distribución utiliza el EIGRP para aprender la ruta a 10.10.14.1 con 10.10.2.1 o 10.10.3.1, dependiendo de los cuales el IOS SLB es activo.
Cuadro 10. respaldo apátrida con la capa 3 y el enlace

Sentencias de Configuración de SLB 1
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4 numclients 2
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface Ethernet1
  switchport
  switchport vlan 1
interface Ethernet2
  ip address 10.10.2.1 255.255.255.0
interface vlan 1
  ip address 10.10.1.1 255.255.255.0
  standby ip 10.10.1.100
  standby priority 10 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
router eigrp 666
  redistribute static
  network 10.0.0.0
Instrucciones de Configuración de SLB 2
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface GigabitEthernet1
  no ip address
  switchport
  switchport trunk encapsulation isl
interface Ethernet1
  switchport
  switchport vlan 1
interface Ethernet2
  ip address 10.10.3.1 255.255.255.0
interface vlan 1
  ip address 10.10.1.2 255.255.255.0
  standby ip 10.10.1.100
  standby priority 5 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
router eigrp 666
  redistribute static
  network 10.0.0.0

Ejemplo cómo configurar el Dynamic Routing y ningún enlace

La figura abajo muestra a IOS SLB de la muestra la configuración de respaldo apátrida con las siguientes características:

  • La dirección IP del servidor real 1 es 10.10.1.3, y la del servidor real 2 es 10.10.1.4, ruteadas a los clientes a través de 10.10.1.100.
  • La dirección IP para el servidor virtual es 10.10.14.1.
  • La dirección IP de la subred 2 es 10.10.2.0, con una máscara de subred de 255.255.255.0.
  • La dirección IP de la subred 3 es 10.10.3.0, con una máscara de subred de 255.255.255.0.
  • El dispositivo de distribución utiliza el EIGRP para aprender la ruta a 10.10.14.1 con 10.10.2.2 o 10.10.3.2, dependiendo de los cuales el IOS SLB es activo.
Cuadro 11 respaldo apátrida con la capa 3 y ningún enlace

Sentencias de Configuración de SLB 1
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface Ethernet1
  ip address 10.10.1.1 255.255.255.0
  standby ip 10.10.1.100
  standby priority 10 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
interface Ethernet2
  ip address 10.10.2.1 255.255.255.0
router eigrp 666
  redistribute static
  network 10.0.0.0
Instrucciones de Configuración de SLB 2
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface Ethernet1
  ip address 10.10.1.2 255.255.255.0
  standby ip 10.10.1.100
  standby priority 5 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
interface Ethernet2
  ip address 10.10.3.1 255.255.255.0
router eigrp 666
  redistribute static
  network 10.0.0.0

Ejemplo cómo configurar el Static Routing y el enlace

La figura abajo muestra a IOS SLB de la muestra la configuración de respaldo apátrida con las siguientes características:

  • La dirección IP del servidor real 1 es 10.10.1.3, y la del servidor real 2 es 10.10.1.4, ruteadas a los clientes a través de 10.10.1.100.
  • La dirección IP para el servidor virtual es 10.10.14.1.
  • La dirección IP de la VLAN 1 es 10.10.1.0, con una máscara de subred de 255.255.255.0.
  • La dirección IP de la subred 2 es 10.10.2.0, con una máscara de subred de 255.255.255.0.
  • La dirección IP de la subred 3 es 10.10.3.0, con una máscara de subred de 255.255.255.0.
  • La configuración utiliza enrutamiento estático a la ruta HSRP en el dispositivo de distribución.
Figura 12. Respaldo apátrida con la capa 2 y el enlace

Sentencias de Configuración de SLB 1
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface Ethernet1
  switchport
  switchport vlan 1
interface Ethernet2
  ip address 10.10.2.1 255.255.255.0
  standby ip 10.10.2.100
  standby priority 10 preempt delay sync 20
  standby track vlan1
  standby timers 1 3
interface vlan 1
  ip address 10.10.1.1 255.255.255.0
  standby ip 10.10.1.100
  standby priority 10 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
Instrucciones de Configuración de SLB 2
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface GigabitEthernet1
  no ip address
  switchport
  switchport trunk encapsulation isl
interface Ethernet1
  switchport
  switchport vlan 1
interface Ethernet2
  ip address 10.10.2.2 255.255.255.0
  standby ip 10.10.2.100
  standby priority 5 preempt delay sync 20
  standby track vlan 1
  standby timers 1 3
interface vlan 1
  ip address 10.10.1.2 255.255.255.0
  standby ip 10.10.1.100
  standby priority 5 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
Sentencias de Configuración del Dispositivo de Distribución
interface Ethernet1
  switchport
  switchport distribution vlan 2
interface Ethernet2
  switchport
  switchport distribution vlan 2
interface vlan2
  ip address 10.10.2.3 255.255.255.0
  no shut
ip route 10.10.14.1 255.255.255.255 10.10.2.100

Ejemplo cómo configurar el Static Routing y ningún enlace

La figura abajo muestra a IOS SLB de la muestra la configuración de respaldo apátrida con las siguientes características:

  • La dirección IP del servidor real 1 es 10.10.1.3, y la del servidor real 2 es 10.10.1.4, ruteadas a los clientes a través de 10.10.1.100.
  • La dirección IP para el servidor virtual es 10.10.14.1.
  • La dirección IP de la subred 2 es 10.10.2.0, con una máscara de subred de 255.255.255.0.
  • La dirección IP de la subred 3 es 10.10.3.0, con una máscara de subred de 255.255.255.0.
  • La configuración utiliza enrutamiento estático a la ruta HSRP en el dispositivo de distribución.
Cuadro 13. Respaldo apátrida con la capa 2 y ningún enlace

Sentencias de Configuración de SLB 1
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface Ethernet1
  ip address 10.10.1.1 255.255.255.0
  standby ip 10.10.1.100
  standby priority 10 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
interface Ethernet2
  ip address 10.10.2.1 255.255.255.0
  standby ip 10.10.2.100
  standby priority 10 preempt delay sync 20
  standby track Ethernet1
  standby timers 1 3
Instrucciones de Configuración de SLB 2
ip slb serverfarm SF1
  real 10.10.1.3
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
  real 10.10.1.4
    reassign 2
    faildetect numconns 4
    retry 20
    inservice
ip slb vserver VS1
  virtual 10.10.14.1 tcp www
  serverfarm SF1
  idle 120
  delay 5
  inservice standby SERVER
!
interface Ethernet1
  ip address 10.10.1.2 255.255.255.0
  standby ip 10.10.1.100
  standby priority 5 preempt delay sync 20
  standby name SERVER
  standby track Ethernet2
  standby timers 1 3
!
interface Ethernet2
  ip address 10.10.2.2 255.255.255.0
  standby ip 10.10.2.100
  standby priority 5 preempt delay sync 20
  standby track Ethernet1
  standby timers 1 3
Sentencias de Configuración del Dispositivo de Distribución
interface Ethernet1
  switchport
  switchport distribution vlan 2
interface Ethernet2
  switchport
  switchport distribution vlan 2
interface vlan2
  ip address 10.10.2.3 255.255.255.0
  no shut
ip route 10.10.14.1 255.255.255.255 10.10.2.100

Ejemplo cómo configurar IOS SLB con el respaldo stateful

Esta configuración de muestra se centra en las conexiones del servidor real IOS SLB configuradas como parte de un bloque de servidores, con real y los servidores virtuales sobre las interfaces Fast Ethernet configuradas con las conexiones en espera de reserva stateful.

La figura abajo es un ejemplo de una configuración de respaldo stateful, usando el HSRP en ambos los lados del cliente y servidor para manejar la Conmutación por falla. Los servidores reales rutean los flujos salientes a 10.10.3.100, que es la dirección HSRP en las interfaces del lado del servidor. El cliente (o router de acceso), rutas a la dirección IP virtual (10.10.10.12) con 10.10.2.100, dirección HSRP en el lado del cliente.

Note las interfaces del loopback configuradas en ambos dispositivos para el intercambio de estos mensajes. Cada IOS SLB se debe también dar las rutas duplicado al otro Loopback Address del Switch. Esta configuración permite que los mensajes de la replicación fluyan a pesar de un error de la interfaz.


Nota


Para permitir que el HSRP funcione correctamente, el comando set spantree portfast debe ser configurado en cualquier dispositivo de la capa 2 entre el Switches IOS SLB.
Cuadro 14. Entorno stateful IOS SLB

Sentencias de configuración del Switch SLB1

ip slb serverfarm SF1
  nat server
  real 10.10.3.1
   inservice
  real 10.10.3.2
   inservice
  real 10.10.3.3
   inservice
!
ip slb vserver VS1
  virtual 10.10.10.12 tcp telnet
  serverfarm SF1
  replicate casa 10.10.99.132 10.10.99.99 1024 password PASS
  inservice standby virt
!
interface loopback 1
  ip address 10.10.99.132 255.255.255.255
!
interface FastEthernet1
  ip address 10.10.3.132 255.255.255.0
  no ip redirects
  no ip mroute-cache
  standby priority 5 preempt
  standby name out
  standby ip 10.10.3.100
  standby track FastEthernet2
  standby timers 1 3
interface FastEthernet2
  ip address 10.10.2.132 255.255.255.0
  no ip redirects
  standby priority 5
  standby name virt
  standby ip 10.10.2.100
  standby timers 1 3

Sentencias de configuración del Switch SLB2

ip slb serverfarm SF1
  nat server
  real 10.10.3.1
   inservice
  real 10.10.3.2
   inservice
  real 10.10.3.3
   inservice
!
ip slb vserver VS1
  virtual 10.10.10.12 tcp telnet
  serverfarm SF1
  replicate casa 10.10.99.99 10.10.99.132 1024 password PASS
  inservice standby virt
!
interface loopback 1
  ip address 10.10.99.99 255.255.255.255
!
interface FastEthernet2
  ip address 10.10.2.99 255.255.255.0
  no ip redirects
  no ip route-cache
  no ip mroute-cache
  standby priority 10 preempt delay sync 20
  standby name virt
  standby ip 10.10.2.100
  standby track FastEthernet3
  standby timers 1 3
!
interface FastEthernet3
  ip address 10.10.3.99 255.255.255.0
  no ip redirects
  no ip route-cache
  no ip mroute-cache
  standby priority 10 preempt delay 20
  standby name out
  standby ip 10.10.3.100
  standby track FastEthernet2
  standby timers 1 3

Ejemplo cómo configurar IOS SLB con el respaldo stateful de los Route Processor redundantes

En la figura abajo, el dispositivo SLB IOS incluye dos motores del supervisor configurados para el respaldo stateful. Si el motor del supervisor activo falla, el Supervisor Engine de reserva asume el control con el RPR+ con la información de sincronización IOS SLB poblada ya. El IOS SLB replica la información del estado para el servidor virtual ACME_VSERVER (10.10.10.10) del motor del supervisor activo al respaldo cada 20 segundos. Los servidores reales (10.10.10.1, 10.10.10.2, y 10.10.10.3) se configuran en el bloque de servidores ACME_SFARM.

Cuadro 15. IOS SLB con los Route Processor redundantes

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb replicate slave rate 300
ip slb serverfarm ACME_SFARM
  nat server
  real 10.10.10.1
   inservice
  real 10.10.10.2
   inservice
  real 10.10.10.3
   inservice
ip slb vserver ACME_VSERVER
 virtual 10.10.10.10 tcp 80
 replicate interval 20
 replicate slave
 serverfarm ACME_SFARM
 inservice

Ejemplo cómo configurar IOS SLB con el recurso seguro activo

La figura abajo muestra una red IOS SLB configurada para el recurso seguro activo, con el balanceo de carga de dos dispositivos SLB IOS la misma dirección IP virtual mientras que se sostiene. Si cualquier dispositivo falla, el otro asume el control su carga con la falla de HSRP normal y la redundancia sin estado IOS SLB.

Cuadro 16. Recurso seguro activo IOS SLB

La configuración de red de muestra en la figura antedicha tiene las siguientes características:

  • El SLB 1 equilibra los servidores 1A y 1B y las balanzas 2A y 2B SLB 2.
  • Soportan a una dirección IP virtual (10.10.10.12 para la red) a través de los dos dispositivos SLB IOS.
  • El tráfico del cliente se divide en un router de acceso, enviando los clientes con incluso los IP Addresses a HSRP1 (10.10.5.100) y a los clientes con los IP Addresses impares a HSRP2 (10.10.2.100). El SLB 1 se configura como primario para los clientes con los IP Addresses impares, y el SLB 2 es primario para los clientes con incluso los IP Addresses.
  • Los dispositivos SLB IOS equilibran el tráfico para desunir los conjuntos de los servidores reales. (Si utilizaran al cliente NAT en este ejemplo, esta característica no sería un requisito).
  • Cada conjunto de los servidores reales tiene un default gateway configurado a su dispositivo SLB IOS.
  • La dirección HSRP en el VLA N 105 es 10.10.5.100. La dirección HSRP en el VLA N 102 es 10.10.2.100.

Sentencias de Configuración de SLB 1

ip slb serverfarm EVEN
 nat server
 real 10.10.3.2
  reassign 2
  faildetect numconns 4 numclients 2
  retry 20
  inservice
 real 10.10.3.3
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
!
ip slb serverfarm ODD
 nat server
 real 10.10.3.2
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
 real 10.10.3.3
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
!-----Same EVEN virtual server as in SLB 2
ip slb vserver EVEN
 virtual 10.10.10.12 tcp www
 serverfarm EVEN
 client 0.0.0.0 0.0.0.1
 idle 120
 delay 5
!-----See standby name in Ethernet 3/3 below
 inservice standby STANDBY_EVEN
!-----Same ODD virtual server as in SLB 2
ip slb vserver ODD
 virtual 10.10.10.12 tcp www
 serverfarm ODD
 client 0.0.0.1 0.0.0.1
 idle 120
 delay 5
!-----See standby name in Ethernet 3/2 below
 inservice standby STANDBY_ODD
!
interface Ethernet3/2
 ip address 10.10.5.132 255.255.255.0
 standby priority 20 preempt delay sync 20
!-----See standby name in SLB 2, Ethernet 3/5
 standby name STANDBY_ODD
 standby ip 10.10.5.100
 standby track Ethernet3/3
 standby timers 1 3
!
interface Ethernet3/3
 ip address 10.10.2.132 255.255.255.0
 standby priority 10
!-----See standby name in SLB 2, Ethernet 3/1
 standby name STANDBY_EVEN
 standby ip 10.10.2.100
 standby track Ethernet3/2
 standby timers 1 3

Instrucciones de Configuración de SLB 2

ip slb serverfarm EVEN
 nat server
 real 10.10.3.4
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
 real 10.10.3.5
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
!
ip slb serverfarm ODD
 nat server
 real 10.10.3.4
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
 real 10.10.3.5
  reassign 2
  faildetect numconns 4
  retry 20
  inservice
!-----Same EVEN virtual server as in SLB 1
ip slb vserver EVEN
 virtual 10.10.10.12 tcp www
 serverfarm EVEN
 client 0.0.0.0 0.0.0.1
 idle 120
 delay 5
!-----See standby name in Ethernet 3/1 below
 inservice standby STANDBY_EVEN
!-----Same ODD virtual server as in SLB 1
ip slb vserver ODD
 virtual 10.10.10.12 tcp www
 serverfarm ODD
 client 0.0.0.1 0.0.0.1
 idle 120
 delay 5
!-----See standby name in Ethernet 3/5 below
 inservice standby STANDBY_ODD
!
interface Ethernet3/1
 ip address 10.10.2.128 255.255.255.0
 standby priority 20 preempt delay sync 20
!-----See standby name in SLB 1, Ethernet 3/3
 standby name STANDBY_EVEN
 standby ip 10.10.2.100
 standby track Ethernet3/5
 standby timers 1 3
!
interface Ethernet3/5
 ip address 10.10.5.128 255.255.255.0
 standby priority 10 preempt delay sync 20
!-----See standby name in SLB 1, Ethernet 3/2
 standby name STANDBY_ODD
 standby ip 10.10.5.100
 standby track Ethernet3/1
 standby timers 1 3

Sentencias de configuración del router de acceso

interface Ethernet0/0
 ip address 10.10.5.183 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Ethernet0/1
 ip address 10.10.2.183 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Ethernet0/2
 ip address 10.10.6.183 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 ip policy route-map virts
!
access-list 100 permit ip 0.0.0.1 255.255.255.254 host 10.10.10.12
access-list 101 permit ip 0.0.0.0 255.255.255.254 host 10.10.10.12
route-map virts permit 10
match ip address 100
set ip next-hop 10.10.5.100
!
route-map virts permit 15
match ip address 101
set ip next-hop 10.10.2.100

Ejemplo cómo configurar IOS SLB con la redistribución de las Static rutas

La figura abajo muestra una red IOS SLB configurada para distribuir las Static rutas a una dirección IP virtual del ™ s del € del serverâ. La ruta al direccionamiento se agrega a la tabla de ruteo mientras que los parásitos atmosféricos si usted hace publicidad del direccionamiento cuando usted trae el servidor virtual en el servicio (usando el comando inservice). Vea la descripción del advertisecommand en la referencia de comandos de los Servicios de aplicación IP del Cisco IOS para más detalles sobre los IP Addresses del servidor virtual de la publicidad.

Porque la configuración de ruteo varía del protocolo al protocolo, las configuraciones de muestra para varios diversos Routing Protocol se dan.

Cuadro 17. Redistribución IOS SLB de las Static rutas

Routing Information Protocol (RIP)

Lo que sigue es la configuración de redistribución de la Static ruta del RIP para el Switch IOS SLB mostrado en la figura arriba:

router rip
 redistribute static
 network 10.0.0.0
 network 8.0.0.0

Lo que sigue es la configuración de redistribución de la Static ruta del RIP para el router de acceso que está estando atentas las actualizaciones de ruteo mostradas en la figura arriba:

router rip
 network 10.0.0.0
 network 8.0.0.0

Open Shortest Path First (OSPF)

Lo que sigue es la configuración de redistribución de la Static ruta OSPF para el Switch IOS SLB mostrado en la figura arriba:

router ospf 1
 redistribute static subnets
 network 10.10.6.217 0.0.0.0 area 0
 network 8.8.8.0 0.0.0.255 area 0

Lo que sigue es la configuración de redistribución de la Static ruta OSPF para el router de acceso que está estando atentas las actualizaciones de ruteo mostradas en la figura arriba:

router ospf 1
 network 10.10.6.2 0.0.0.0 area 0
 network 8.8.8.0 0.0.0.255 area 0

Interior Gateway Routing Protocol (IGRP)

Lo que sigue es la configuración de redistribución de la Static ruta IGRP para el Switch IOS SLB mostrado en la figura arriba:

router igrp 1
 redistribute connected
 redistribute static
 network 8.0.0.0
 network 10.0.0.0

Lo que sigue es la configuración de redistribución de la Static ruta IGRP para el router de acceso que está estando atentas las actualizaciones de ruteo mostradas en la figura arriba:

router igrp 1
 network 8.0.0.0
 network 10.0.0.0

Protocolo enhanced interior gateway routing (IGRP mejorado)

Lo que sigue es la configuración de redistribución de la Static ruta del IGRP mejorado para el Switch IOS SLB mostrado en la figura arriba:

router eigrp 666
 redistribute static
 network 10.0.0.0
 network 8.0.0.0

Lo que sigue es la configuración de redistribución de la Static ruta del IGRP mejorado para el router de acceso que está estando atentas las actualizaciones de ruteo mostradas en la figura arriba:

router eigrp 666
 network 10.0.0.0
 network 8.0.0.0

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga WAP y UDP

La figura abajo muestra una red IOS SLB configurada para equilibrar los flujos WAP. En este ejemplo:

  • Los flujos WAP son equilibrados entre los gatewayes WAP 10.10.2.1, 10.10.2.2, y 10.10.2.3.
  • Los clientes conectan con 10.10.1.1, el direccionamiento del servidor virtual IOS SLB.
  • Para una sesión dada, las decisiones de balance de carga cambian si la conexión está desocupada más de largo que el temporizador virtual de la conexión inactiva del ™ s del € del serverâ (3000 segundos en este ejemplo).
Cuadro 18. IOS SLB con el Equilibrio de carga WAP

Hay dos maneras de configurar el Equilibrio de carga IOS SLB para el WAP:

  • A las sesiones del balance de la carga que se ejecutan en el modo orientado a la conexión WSP, defina una sonda WSP y utilice el Equilibrio de carga WAP. El Equilibrio de carga WAP requiere un servidor virtual WAP configurado en uno de los puertos WAP.
  • A las sesiones del balance de la carga que se ejecutan en el WSP sin conexión, el WSP seguro sin conexión, y los modos seguros orientados a la conexión WSP, definen un ping o la sonda WSP y utilizan el Equilibrio de carga estándar UDP con un temporizador de inactividad bajo.

Ejemplo cómo equilibrar los flujos WAP en el puerto 9201 UDP

El siguiente ejemplo muestra la configuración para el dispositivo SLB IOS mostrado en la figura arriba, que equilibra los flujos WAP en el puerto 9201 (WSP/WTP/UDP) UDP:

ip slb probe PROBE3 wsp
  url http://localhost/test.txt
!
ip slb serverfarm WAPFARM
  nat server
  real 10.10.2.1
  inservice
  real 10.10.2.2
  inservice
  real 10.10.2.3
  inservice
  probe PROBE3
!
ip slb vserver VSERVER
  virtual 10.10.1.1 udp 9201
  serverfarm WAPFARM
  idle 3000
  inservice

Ejemplo cómo equilibrar los flujos WAP en el puerto 9203 UDP

El siguiente ejemplo muestra la configuración para el dispositivo SLB IOS mostrado en la figura arriba, que equilibra los flujos WAP en el puerto 9203 (WSP/WTP/WTLS/UDP) UDP:

ip slb probe PROBE1 ping
!
ip slb serverfarm WAPFARM
  nat server
  real 10.10.2.1
  inservice
  real 10.10.2.2
  inservice
  real 10.10.2.3
  inservice
  probe PROBE1
!
ip slb vserver VSERVER
  virtual 10.10.1.1 udp 9203
  serverfarm WAPFARM
  idle 3000
  inservice

Ejemplos cómo configurar IOS SLB con la inyección de la salud de la ruta

Esta sección contiene los siguientes ejemplos, ilustrando varias diversas configuraciones de la inyección de la salud de la ruta IOS SLB:

Ejemplo cómo configurar dos sitios distribuidos con un servidor Web cada uno

La figura abajo muestra una red IOS SLB configurada con la inyección de la salud de la ruta con las siguientes características:

  • Ambos dispositivos de IOS SLB se configuran con la misma dirección IP virtual.
  • Cada dispositivo SLB IOS tiene una granja de servidores que contiene solamente el servidor de red localmente conectado como servidor real.
  • La trayectoria a SLB A tiene el peso más bajo.
Cuadro 19. Dos sitios distribuidos con un servidor Web cada uno

Cuando ambos servidores Web en la figura antedicha son operativos, el router de cliente recibe la ruta del host de ambos dispositivos SLB IOS.

Si el servidor Web A falla, el servidor virtual para la dirección IP virtual en SLB A ingresa al estado fallido y para el hacer publicidad de la ruta del host para la dirección IP virtual. El router de cliente comienza entonces a utilizar la ruta a SLB B.

Cuando el servidor Web A está otra vez disponible, el servidor virtual hace publicidad otra vez de la ruta del host para la dirección IP virtual, y el router de cliente comienza a usar SLB A.

Ejemplo cómo configurar dos sitios distribuidos con dos servidores Web cada uno

La figura abajo muestra una red IOS SLB configurada con la inyección de la salud de la ruta con las siguientes características:

  • Ambos dispositivos de IOS SLB se configuran con la misma dirección IP virtual.
  • Cada dispositivo SLB IOS tiene un bloque de servidores que contiene dos servidores Web localmente asociados como servidores reales.
  • La trayectoria a SLB A tiene el peso más bajo.
Cuadro 20. Dos sitios distribuidos con dos servidores Web cada uno

Cuando todos los servidores Web en la figura antedicha son operativos, el router de cliente recibe la ruta del host de ambos dispositivos SLB IOS.

Si un servidor Web en cualquier bloque de servidores falla, la ruta continúa siendo hecha publicidad por el dispositivo SLB dado IOS.

Si el servidor Web A1 y el a2 del servidor Web fallan, el servidor virtual para la dirección IP virtual en SLB A ingresa al estado fallido y para el hacer publicidad de la ruta del host para la dirección IP virtual. El router de cliente comienza entonces a utilizar la ruta a SLB B.

Cuando el servidor Web A1 o el a2 del servidor Web está otra vez disponible, el servidor virtual hace publicidad otra vez de la ruta del host para la dirección IP virtual, y el router de cliente comienza a usar SLB A.

El ejemplo cómo configurar dos sitios distribuidos con un servidor Web y un IOS SLB del respaldo conmutan cada uno

La figura abajo muestra una red IOS SLB configurada con la inyección de la salud de la ruta con las siguientes características:

  • Ambos dispositivos de IOS SLB se configuran con la misma dirección IP virtual.
  • Cada dispositivo SLB IOS tiene una granja de servidores que contiene solamente el servidor de red localmente conectado como servidor real.
  • Cada sitio tiene un dispositivo SLB primario IOS y un dispositivo SLB IOS del respaldo.
  • La trayectoria a SLB A tiene el peso más bajo.
Cuadro 21. Dos sitios distribuidos con un servidor Web y un IOS SLB del respaldo conmutan cada uno

Cuando ambos servidores Web en la figura antedicha son operativos, el router de cliente recibe la ruta del host del SLB un primario y de SLB B primario.

Si SLB que un primario falla, SLB un respaldo comienza a hacer publicidad de la ruta del host a la dirección IP virtual. Si SLB que un respaldo también falla, el servidor virtual para la dirección IP virtual en el SLB un primario y el SLB un respaldo ingresa al estado fallido y para el hacer publicidad de la ruta del host para la dirección IP virtual. El router de cliente entonces comienza a usar la ruta a SLB B primario (o al respaldo SLB B, si el SLB B primario no está disponible).

Cuando el SLB un primario o el SLB un respaldo está otra vez disponible, el servidor virtual hace publicidad otra vez de la ruta del host para la dirección IP virtual, y el router de cliente comienza a usar el SLB un primario o el SLB un respaldo.

Ejemplos cómo configurar IOS SLB con el Equilibrio de carga GPRS

Esta sección contiene los siguientes ejemplos, que ilustran varias configuraciones de IOS SLB distintas con redundancia:

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga GPRS sin el examen del código de la causa GTP

La figura abajo muestra una configuración típica del balanceo de carga GPRS sin el examen del código de la causa GTP habilitado. En esta configuración:

  • El IOS SLB puede equilibrar los flujos GPRS a través de los GGSN reales múltiples. El  del € del seesâ del œ del € del â SGSN los GGSN reales como un GGSN virtual. Esta configuración aumenta la capacidad de flujo-dirección de los GGSN reales y aumenta la confiabilidad y la Disponibilidad.
  • El direccionamiento de la plantilla virtual del SGSN es 10.111.111.111.
  • El direccionamiento de la plantilla virtual de GGSN1 es 192.168.1.1.
  • El direccionamiento de la plantilla virtual de GGSN2 es 192.168.2.2.
  • El direccionamiento de la plantilla virtual de GGSN3 es 192.168.3.3.
Cuadro 22. IOS SLB con el Equilibrio de carga GPRS

Los siguientes son las sentencias de configuración para la configuración mostrada en la figura arriba:

Para obtener más ejemplos de configuración de GGSN detallados, refiérase a la Guía de Configuración de la Red Inalámbrica Móvil de Cisco IOS.

Instrucciones de Configuración de IOS SLB

hostname GTP_SLB
!
ip domain-name gprs.com
!
ip slb serverfarm GPRS
 real 192.168.1.1
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
 real 192.168.2.2
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
 real 192.168.3.3
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
ip slb vserver FOR_GPRS
 virtual 10.10.10.10 udp 3386 service gtp
 serverfarm GPRS
 inservice
!
ip slb dfp password Password1 0
 agent 10.1.1.201 1111 30 0 10
 agent 10.1.1.202 1111 30 0 10
 agent 10.1.1.203 1111 30 0 10
!
interface FastEthernet1/0
 description TO SERVERFARM GPRS
 ip address 10.1.1.100 255.255.255.0
 no ip redirects
 duplex half
!
interface FastEthernet3/0
 description TO SGSN
 ip address 10.2.1.100 255.255.255.0
 no ip mroute-cache
 duplex half
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
ip route 192.168.1.1 255.255.255.255 10.1.1.201
ip route 192.168.2.2 255.255.255.255 10.1.1.202
ip route 192.168.3.3 255.255.255.255 10.1.1.203

Instrucciones de Configuración de GGSN1

service gprs ggsn
!
hostname GGSN1
!
ip dfp agent gprs
 port 1111
 password Password1 0
 inservice
!
ip domain-name gprs.com
!
interface loopback 1
 description LOOPBACK SAME AS IOS SLB VSERVER ADDRESS
 ip address 10.10.10.10 255.255.255.255
 no ip route-cache
 no ip mroute-cache
!
interface FastEthernet1/0
 description TO SLB
 ip address 10.1.1.201 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 duplex half
!
interface Virtual-Template1
 description GTP VIRTUAL TEMPLATE
 ip address 192.168.1.1 255.255.255.0
 encapsulation gtp
 gprs access-point-list gprs1
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
!
gprs access-point-list gprs1
  access-point 1
   access-point-name gprs.company.com
   access-mode non-transparent
   ip-address-pool dhcp-proxy-client
   dhcp-server 10.100.0.5 10.100.0.6
   dhcp-gateway-address 10.27.3.1
   exit
!
gprs maximum-pdp-context-allowed 45000
gprs qos map canonical-qos
gprs gtp path-echo-interval 0
gprs dfp max-weight 32
gprs slb cef 10.10.10.10

Sentencias de Configuración de GGSN2

service gprs ggsn
!
hostname GGSN2
!
ip dfp agent gprs
 port 1111
 password Password1 0
 inservice
!
ip domain-name gprs.com
!
interface loopback 1
 description LOOPBACK SAME AS IOS SLB VSERVER ADDRESS
 ip address 10.10.10.10 255.255.255.255
 no ip route-cache
 no ip mroute-cache
!
interface FastEthernet1/0
 description TO SLB
 ip address 10.1.1.202 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 duplex half
!
interface Virtual-Template1
 description GTP VIRTUAL TEMPLATE
 ip address 192.168.2.2 255.255.255.0
 encapsulation gtp
 gprs access-point-list gprs1
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
!
gprs access-point-list gprs1
  access-point 1
   access-point-name gprs.company.com
   access-mode non-transparent
   ip-address-pool dhcp-proxy-client
   dhcp-server 10.100.0.5 10.100.0.6
   dhcp-gateway-address 10.27.3.1
   exit
!
gprs maximum-pdp-context-allowed 45000
gprs qos map canonical-qos
gprs gtp path-echo-interval 0
gprs dfp max-weight 32
gprs slb cef 10.10.10.10

Instrucciones de Configuración de GGSN3

service gprs ggsn
!
hostname GGSN3
!
ip dfp agent gprs
 port 1111
 password Password1 0
 inservice
!
ip domain-name gprs.com
!
interface loopback 1
 description LOOPBACK SAME AS IOS SLB VSERVER ADDRESS
 ip address 10.10.10.10 255.255.255.255
 no ip route-cache
 no ip mroute-cache
!
interface FastEthernet1/0
 description TO SLB
 ip address 10.1.1.203 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 duplex half
!
interface Virtual-Template1
 description GTP VIRTUAL TEMPLATE
 ip address 192.168.3.3 255.255.255.0
 encapsulation gtp
 gprs access-point-list gprs1
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
!
gprs access-point-list gprs1
  access-point 1
   access-point-name gprs.company.com
   access-mode non-transparent
   ip-address-pool dhcp-proxy-client
   dhcp-server 10.100.0.5 10.100.0.6
   dhcp-gateway-address 10.27.3.1
   exit
!
gprs maximum-pdp-context-allowed 45000
gprs qos map canonical-qos
gprs gtp path-echo-interval 0
gprs dfp max-weight 32
gprs slb cef 10.10.10.10

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga GPRS y el NAT

El siguiente ejemplo utiliza la misma configuración básica que en el ejemplo del œ del € del â: Cómo configurar IOS SLB con el Equilibrio de carga GPRS sin el examen del código de la causa GTP”, incluyendo la red mostrada en la figura arriba, pero con la adición del NAT:

Para obtener más ejemplos de configuración de GGSN detallados, refiérase a la Guía de Configuración de la Red Inalámbrica Móvil de Cisco IOS.

Instrucciones de Configuración de IOS SLB

hostname GTP_SLB
!
ip domain-name gprs.com
!
ip slb serverfarm GPRS
 nat server
 real 192.168.1.1
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
 real 192.168.2.2
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
 real 192.168.3.3
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
ip slb vserver FOR_GPRS
 virtual 10.10.10.10 udp 3386 service gtp
 serverfarm GPRS
 inservice
!
ip slb dfp password Password1 0
 agent 10.1.1.201 1111 30 0 10
 agent 10.1.1.202 1111 30 0 10
 agent 10.1.1.203 1111 30 0 10
!
interface FastEthernet1/0
 description TO SERVERFARM GPRS
 ip address 10.1.1.100 255.255.255.0
 no ip redirects
 duplex half
!
interface FastEthernet3/0
 description TO SGSN
 ip address 10.2.1.100 255.255.255.0
 no ip mroute-cache
 duplex half
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
ip route 192.168.1.1 255.255.255.255 10.1.1.201
ip route 192.168.2.2 255.255.255.255 10.1.1.202
ip route 192.168.3.3 255.255.255.255 10.1.1.203

Instrucciones de Configuración de GGSN1

service gprs ggsn
!
hostname GGSN1
!
ip dfp agent gprs
 port 1111
 password Password1 0
 inservice
!
ip domain-name gprs.com
!
interface FastEthernet1/0
 description TO SLB
 ip address 10.1.1.201 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 duplex half
!
interface Virtual-Template1
 description GTP VIRTUAL TEMPLATE
 ip address 192.168.1.1 255.255.255.0
 encapsulation gtp
 gprs access-point-list gprs1
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
!
gprs access-point-list gprs1
  access-point 1
   access-point-name gprs.company.com
   access-mode non-transparent
   ip-address-pool dhcp-proxy-client
   dhcp-server 10.100.0.5 10.100.0.6
   dhcp-gateway-address 10.27.3.1
   exit
!
gprs maximum-pdp-context-allowed 45000
gprs qos map canonical-qos
gprs gtp path-echo-interval 0
gprs dfp max-weight 32

Sentencias de Configuración de GGSN2

service gprs ggsn
!
hostname GGSN2
!
ip dfp agent gprs
 port 1111
 password Password1 0
 inservice
!
ip domain-name gprs.com
!
interface FastEthernet1/0
 description TO SLB
 ip address 10.1.1.202 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 duplex half
interface Virtual-Template1
 description GTP VIRTUAL TEMPLATE
 ip address 192.168.2.2 255.255.255.0
 encapsulation gtp
 gprs access-point-list gprs1
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
!
gprs access-point-list gprs1
  access-point 1
   access-point-name gprs.company.com
   access-mode non-transparent
   ip-address-pool dhcp-proxy-client
   dhcp-server 10.100.0.5 10.100.0.6
   dhcp-gateway-address 10.27.3.1
   exit
!
gprs maximum-pdp-context-allowed 45000
gprs qos map canonical-qos
gprs gtp path-echo-interval 0
gprs dfp max-weight 32

Instrucciones de Configuración de GGSN3

service gprs ggsn
!
hostname GGSN3
!
ip dfp agent gprs
 port 1111
 password Password1 0
 inservice
!
ip domain-name gprs.com
!
interface FastEthernet1/0
 description TO SLB
 ip address 10.1.1.203 255.255.255.0
 ip directed-broadcast
 no ip mroute-cache
 duplex half
!
interface Virtual-Template1
 description GTP VIRTUAL TEMPLATE
 ip address 192.168.3.3 255.255.255.0
 encapsulation gtp
 gprs access-point-list gprs1
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
!
gprs access-point-list gprs1
  access-point 1
   access-point-name gprs.company.com
   access-mode non-transparent
   ip-address-pool dhcp-proxy-client
   dhcp-server 10.100.0.5 10.100.0.6
   dhcp-gateway-address 10.27.3.1
   exit
!
gprs maximum-pdp-context-allowed 45000
gprs qos map canonical-qos
gprs gtp path-echo-interval 0
gprs dfp max-weight 32

Ejemplo cómo configurar IOS SLB con el examen del Equilibrio de carga NAT GPRS y del código de la causa GTP

El siguiente ejemplo utiliza la misma configuración básica que en el ejemplo del œ del € del â: Cómo configurar IOS SLB con la sección del  del € del Equilibrio de carga y de NATâ GPRS, incluyendo la red mostrada en la figura arriba, pero con el examen del código de la causa GTP habilitado. En esta configuración:

  • El temporizador de inactividad GSN se fija a 20 segundos.
  • El temporizador de inactividad de la petición GTP se fija a 15 segundos.
  • El servidor virtual valida el contexto PDP crea solamente del suscriptor móvil internacional ID (IMSIs) con mnc 22 mcc 222 del código del portador.

Están siguiendo las sentencias de configuración para la configuración mostrada en la figura arriba, con la adición soporte del examen del código de la causa NAT y GTP:

Para obtener más ejemplos de configuración de GGSN detallados, refiérase a la Guía de Configuración de la Red Inalámbrica Móvil de Cisco IOS.

Instrucciones de Configuración de IOS SLB

hostname GTP_SLB
!
ip domain-name gprs.com
!
ip slb timers gtp gsn 20
!
ip slb serverfarm GPRS
 nat server
 real 192.168.1.1
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
 real 192.168.2.2
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
 real 192.168.3.3
  weight 1
  faildetect numconns 1 numclients 1
  inservice
!
ip slb vserver FOR_GPRS
 virtual 10.10.10.10 udp 0 service gtp-inspect
 idle gtp request 15
 client gtp carrier-code mcc 222 mnc 22
 serverfarm GPRS
 inservice
!
ip slb dfp password Password1 0
 agent 10.1.1.201 1111 30 0 10
 agent 10.1.1.202 1111 30 0 10
 agent 10.1.1.203 1111 30 0 10
!
interface FastEthernet1/0
 description TO SERVERFARM GPRS
 ip address 10.1.1.100 255.255.255.0
 no ip redirects
 duplex half
!
interface FastEthernet3/0
 description TO SGSN
 ip address 10.2.1.100 255.255.255.0
 no ip mroute-cache
 duplex half
!
ip route 10.111.111.111 255.255.255.255 FastEthernet1/0
ip route 192.168.1.1 255.255.255.255 10.1.1.201
ip route 192.168.2.2 255.255.255.255 10.1.1.202
ip route 192.168.3.3 255.255.255.255 10.1.1.203

El ejemplo cómo configurar IOS SLB con el Equilibrio de carga GPRS asocia

El siguiente ejemplo permite a IOS SLB para soportar las granjas del servidor múltiple detrás de un servidor virtual del Equilibrio de carga GPRS, usando los nombres del Punto de acceso (APNs) para seleccionar los bloques de servidores. El bloque de servidores farm6 se configura sin una correspondencia asociada, y por lo tanto actúa como bloque de servidores predeterminado. Si el IOS SLB no puede hacer juego un de los otras correspondencias del bloque de servidores, y se configura un bloque de servidores predeterminado, el IOS SLB envía la petición GPRS al serverfarm predeterminado.

ip slb map 1 gtp
 apn cisco*
ip slb map 4 gtp
 apn abc.microsoft.com
 apn xyz.intel.com
ip slb map 5 gtp
 apn yahoo.com
!
ip slb serverfarm farm1
 real 10.0.0.1
 inservice
 real 10.0.0.2
 inservice
ip slb serverfarm farm2
 real 10.0.0.3
 inservice
 real 10.0.0.4
 inservice
ip slb serverfarm farm3
 real 10.0.0.5
 inservice
 real 10.0.0.6
 inservice
ip slb serverfarm farm4
 real 10.0.0.7
 inservice
 real 10.0.0.8
 inservice
ip slb serverfarm farm5
 real 10.0.0.9
 inservice
 real 10.0.0.10
 inservice
ip slb serverfarm farm6
 real 10.0.0.11
 inservice
!
ip slb map 1 gtp
 apn cisco*
ip slb map 4 gtp
 apn abc.microsoft.com
 apn xyz.intel.com
ip slb map 5 gtp
 apn yahoo.com
!
ip slb vserver GGSN_SERVER
 virtual 10.10.10.10 udp 0 service gtp
 serverfarm farm1 backup farm2 map 1 priority 3
 serverfarm farm4 map 4 priority 1
 serverfarm farm5 map 5 priority 4
 serverfarm farm6
 inservice

Ejemplo cómo configurar IOS SLB con los direccionamientos de la doble pila para el Equilibrio de carga GTP

El siguiente ejemplo permite a IOS SLB para soportar los direccionamientos de la doble pila para el Equilibrio de carga GTP.

ip slb serverfarm SF1
 real 172.16.88.5 
  weight 1
  inservice
!
ip slb serverfarm SF2
 real 172.16.88.6 
  weight 1
  inservice
!
ip slb serverfarm SF3
 real 172.16.88.7 ipv6 2342:2342:2343:FF04:2388:BB03:3329:8612 
  weight 1
  inservice
!
ip slb serverfarm SF4
 real 172.16.88.8 ipv6 2342:2342:2343:FF04:2388:BB03:3423:8912 
  weight 1
  inservice
!
ip slb vserver VS2
 virtual 4.3.2.1 ipv6 2342:2342:2343:FF04:2341:AA03:2323:8912 udp 0 service gtp
 serverfarm sf1 backup sf2 ipv6-primary sf3 ipv6-backup sf4
 idle gtp request 90
 idle gtp imsi 10000000
 sticky gtp imsi group 1
 gtp notification cac 3
 inservice

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga del servidor VPN

La figura abajo muestra una configuración típica del balanceo de carga del servidor VPN. En esta configuración:

  • Los flujos VPN son equilibrados entre los servidores reales 20.20.20.10 y 20.20.20.20.
  • Los clientes conectan con 10.10.1.1, el direccionamiento del servidor virtual IOS SLB.
  • Hay una conexión persistente entre el servidor virtual ESP y el servidor virtual UDP.
  • El intercambio de la clave cifrada ocurre con IKE (ISAKMP; puerto 500).
Cuadro 23. IOS SLB con el Equilibrio de carga del servidor VPN

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb serverfarm VPN
 nat server
 real 20.20.20.10
  inservice
 real 20.20.20.20
  inservice
 failaction purge
!
ip slb vserver ESP
 virtual 10.10.1.1 ESP
 serverfarm VPN
 sticky 3600 group 69
 inservice
!
ip slb vserver UDP
 virtual 10.10.1.1 UDP isakmp
 serverfarm VPN
 sticky 3600 group 69
 inservice

Ejemplos cómo configurar IOS SLB con el Equilibrio de carga RADIUS

Esta sección contiene los siguientes ejemplos, ilustrando varias diversas configuraciones del balanceo de carga IOS SLB RADIUS:

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga RADIUS para una red GPRS

La figura abajo muestra una configuración típica del balanceo de carga IOS SLB RADIUS para una red GPRS. En esta configuración:

  • Las solicitudes de RADIUS tienen la carga balanceada entre los servidores proxy de RADIUS SSG 10.10.10.1 y 10.10.10.2.
  • Los paquetes de datos del usuario final se rutean al dispositivo IOS SLB.
  • Los paquetes de datos del usuario final de la subred de 1.1.1.0 son dirigidos por IOS SLB a SSG1.
  • Los paquetes de datos del usuario final de la subred de 1.1.2.0 son dirigidos por IOS SLB a SSG2.
Cuadro 24. IOS SLB con el Equilibrio de carga RADIUS para una red GPRS

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb route 1.1.0.0 255.255.0.0 framed-ip
!
ip slb serverfarm SSGFARM
 nat server
 real 10.10.10.1
  inservice
 real 10.10.10.2
  inservice
!
ip slb vserver RADIUS_ACCT
 virtual 10.10.10.10 udp 1813 service radius
 serverfarm SSGFARM
 idle radius request 20
 idle radius framed-ip 7200
 sticky radius framed-ip group 1
 inservice
!
ip slb vserver RADIUS_AUTH
 virtual 10.10.10.10 udp 1812 service radius
 serverfarm SSGFARM
 idle radius request 20
 idle radius framed-ip 7200
 sticky radius framed-ip group 1
 inservice

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga RADIUS para una red simple IP CDMA2000

La figura abajo muestra una configuración típica del balanceo de carga IOS SLB RADIUS para una red CDMA2000 con el servicio del IP simple. En esta configuración:

  • La dirección IP del servidor virtual RADIUS para los PDSN es 10.10.10.10.
  • Las solicitudes de RADIUS tienen la carga balanceada entre los servidores proxy de RADIUS SSG 10.10.10.1 y 10.10.10.2.
  • Los paquetes de datos del usuario final se rutean al dispositivo IOS SLB.
  • Los paquetes de datos del usuario final de la red 1.1.0.0 se rutean a los SSGs.
Cuadro 25. IOS SLB con el Equilibrio de carga RADIUS para una red simple IP CDMA2000

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb route 1.1.0.0 255.255.0.0 framed-ip
!
ip slb serverfarm SSGFARM
  nat server
  real 10.10.10.1
    inservice
  real 10.10.10.2
    inservice
!
ip slb vserver RADIUS_SIP
  virtual 10.10.10.10 udp 0 service radius
  serverfarm SSGFARM
  idle radius framed-ip 3600
  sticky radius username
  sticky radius framed-ip
  inservice

Ejemplo cómo configurar IOS SLB con el Equilibrio de carga RADIUS para una red del IP móvil CDMA2000

La figura abajo muestra una configuración típica del balanceo de carga IOS SLB RADIUS para una red CDMA2000 con el servicio del IP móvil. En esta configuración:

  • La dirección IP del servidor virtual RADIUS para los PDSN y el HA es 10.10.10.10.
  • Las solicitudes de RADIUS tienen la carga balanceada entre los servidores proxy de RADIUS SSG 10.10.10.1 y 10.10.10.2.
  • Los paquetes de datos del usuario final se rutean al dispositivo IOS SLB.
  • Los paquetes de datos del usuario final de la red 1.1.0.0 se rutean a los SSGs.
Cuadro 26. IOS SLB con el Equilibrio de carga RADIUS para una red del IP móvil CDMA2000

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb route 1.1.0.0 255.255.0.0 framed-ip
!
ip slb serverfarm SSGFARM
  nat server
  real 10.10.10.1
    inservice
  real 10.10.10.2
    inservice
!
ip slb vserver RADIUS_SIP
  virtual 10.10.10.10 udp 0 service radius
  serverfarm SSGFARM
  idle radius framed-ip 3600
  sticky radius username
  sticky radius framed-ip
  inservice

El ejemplo cómo configurar IOS SLB con el Equilibrio de carga RADIUS para el gateway del servicio múltiple cultiva

El siguiente ejemplo permite a IOS SLB para equilibrar los flujos de paquetes para un conjunto de los suscriptores entre las granjas del servidor de gateway del servicio múltiple (en esta muestra, un bloque de servidores de SSG y un bloque de servidores de CSGs):

ip slb route 1.1.0.0 255.255.0.0 framed-ip
!
ip slb serverfarm SSGFARM
 nat server
 real 10.10.10.1
  inservice
 real 10.10.10.2
  inservice
!
ip slb serverfarm CSGFARM
 nat server
 real 20.20.20.1
  inservice
 real 20.20.20.2
  inservice
!
ip slb vserver SSG_AUTH
 virtual 10.10.10.10 udp 1812 service radius
 serverfarm SSGFARM
 idle radius request 20
 idle radius framed-ip 7200
 sticky radius framed-ip group 1
 access Vlan20 route framed-ip
 inservice
!
ip slb vserver SSG_ACCT
 virtual 10.10.10.10 udp 1813 service radius
 serverfarm SSGFARM
 idle radius request 20
 idle radius framed-ip 7200
 sticky radius framed-ip group 1
 access Vlan20 route framed-ip
 inservice
!
ip slb vserver CSG_ACCT
 virtual 20.20.20.20 udp 1813 service radius
 serverfarm CSGFARM
 idle radius request 25
 idle radius framed-ip 0
 sticky radius framed-ip
 access Vlan30 route framed-ip
 inservice

Ejemplo cómo configurar IOS SLB con el  del € de Sandwichâ del œ del € del â del Equilibrio de carga de firewall del Equilibrio de carga RADIUS

La figura abajo muestra un  del € del sandwichâ del œ del € del â del Equilibrio de carga/del Equilibrio de carga de firewall RADIUS en un dispositivo SLB IOS. En esta configuración de muestra:

  • La dirección IP virtual del Equilibrio de carga RADIUS es 5.5.5.5.
  • La red Framed-IP del suscriptor es 1.0.0.0/255.0.0.0.
  • VL105, VL106, VL107 y VL108 son VLANs.
  • Los pedidos de RADIUS que llegan en el VLA N VL105 se equilibran a 10.10.106.42 y a 10.10.106.43.
  • El tráfico de usuarios stickied basó en las asignaciones de dirección Framed-IP en la subred de 1.0.0.0.
  • El Equilibrio de carga de firewall en el otro lado (10.10.107.42/43) se asegura de que el tráfico del trayecto de retorno al suscriptor esté entregado al gateway correcto.
Cuadro 27. IOS SLB con  del € de Sandwichâ del œ del € del â del Equilibrio de carga/del Equilibrio de carga de firewall RADIUS

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip vrf client
 rd 0:1
!
ip slb probe P742 ping
 address 10.10.107.42
 interval 120
!
ip slb probe P743 ping
 address 10.10.107.43
 interval 120
!
ip slb route 1.0.0.0 255.0.0.0 framed-ip
ip slb route framed-ip deny
!
ip slb firewallfarm SERVER
 access inbound Vlan108
 access outbound Vlan107
 inservice
 real 10.10.107.42
  probe P742
  inservice
 real 10.10.107.43
  probe P743
  inservice
 protocol tcp
  sticky 180 destination
 protocol datagram
  sticky 180 destination
 predictor hash address port
!
ip slb serverfarm SF1
 nat server
 access Vlan106
!
 real 10.10.106.42
  inservice
 real 10.10.106.43
  inservice
!
ip slb vserver VS1
 virtual 5.5.5.5 udp 0 service radius
 serverfarm SF1
 sticky radius framed-ip
 access Vlan105 route framed-ip
 access Vlan105
 inservice
!
mls flow ip interface-full
!
!*************************************************
!* Switchports, port channels and trunks         *
!* added to vlans 105-108 (left out for brevity) *
!*************************************************
!
interface Vlan105
 ip vrf forwarding client
 ip address 10.10.105.2 255.255.255.0
!
interface Vlan106
 ip vrf forwarding client
 ip address 10.10.106.2 255.255.255.0
!
interface Vlan107
 ip address 10.10.107.2 255.255.255.0
!
interface Vlan108
 ip address 10.10.108.2 255.255.255.0
!
ip route 10.10.105.0 255.255.255.0 10.10.107.42
ip route vrf client 10.10.108.0 255.255.255.0 10.10.106.42

El ejemplo cómo configurar IOS SLB con el Equilibrio de carga RADIUS asocia

El siguiente ejemplo permite a IOS SLB para soportar las granjas del servidor múltiple detrás de un servidor virtual del Equilibrio de carga RADIUS, usando la estación de llamada ID RADIUS y los nombres de usuario para seleccionar los bloques de servidores. El bloque de servidores farm3 se configura sin una correspondencia asociada, y por lo tanto actúa como bloque de servidores predeterminado. Si el IOS SLB no puede hacer juego un de los otras correspondencias del bloque de servidores, y se configura un bloque de servidores predeterminado, el IOS SLB envía el pedido de RADIUS al serverfarm predeterminado.

ip slb serverfarm CSGFARM
 predictor route-map rlb-pbr
ip slb serverfarm AAAFARM
 nat server
 real 10.10.10.1
  inservice
 real 10.10.10.2
  inservice
ip slb vserver RADIUS_ACCT
 virtual 10.10.10.10 udp 1813 service radius
 serverfarm CSGFARM
 radius inject acct 1 key 0 cisco
 inservice	
ip slb vserver RADIUS_AUTH
 virtual 10.10.10.10 udp 1812 service radius
 serverfarm AAAFARM
 radius inject auth 1 calling-station-id
 radius inject auth timer 45
 radius inject auth vsa cisco
 inservice
!
interface vlan 100
 ip policy route-map rlb-pbr
!
access-list 1 permit 0.0.0.1 255.255.255.254 
access-list 2 permit 0.0.0.0 255.255.255.254 
!
route-map rlb-pbr permit 10
 match ip address 1
 set ip next-hop 10.10.10.1
!
route-map rlb-pbr permit 20
 match ip address 2
 set ip next-hop 10.10.10.2

El ejemplo cómo configurar IOS SLB con el Equilibrio de carga RADIUS aceleró la expedición plana de los datos

La Configuración de SLB del OIS siguiente tiene las siguientes características:

  • Hay servidor de RADIUS virtual con la dirección IP 10.10.10.10 que maneja los dispositivos del servidor de acceso a la red (NAS).
  • Hay dos gatewayes del paquete con los IP Addresses 10.10.10.1 y 10.10.10.2.
  • El tráfico de RADIUS destinado para el servidor de RADIUS virtual se distribuye entre los gatewayes del paquete, sobre la base de los direccionamientos asociados Framed-IP, según el Route Map rlb-PBR.
  • El bloque de servidores CSGFARM se configura con los IP Address reales que hacen juego los resultados posibles para el Route Map rlb-PBR.
  • El tráfico del usuario final que llega en el VLAN 100 se rutea al Cisco Content Services Gateway correcto (CSG) basado en el Listas de control de acceso (ACL):
    • El ACL 1 envía los IP Addresses que terminan en los números impares al CSGs detrás del gateway 10.10.10.1 del paquete.
    • El ACL 2 envía los IP Addresses que terminan en los números par al CSGs detrás del gateway 10.10.10.2 del paquete.
Cuadro 28. IOS SLB con la expedición acelerada Equilibrio de carga del avión de los datos RADIUS

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb serverfarm CSGFARM
 predictor route-map rlb-pbr
ip slb serverfarm AAAFARM
 nat server
 real 10.10.10.1
  inservice
 real 10.10.10.2
  inservice
!
ip slb vserver RADIUS_ACCT
 virtual 10.10.10.10 udp 1813 service radius
 serverfarm CSGFARM
 radius inject acct 1 key 0 cisco
 inservice	
!
ip slb vserver RADIUS_AUTH
 virtual 10.10.10.10 udp 1812 service radius
 serverfarm AAAFARM
 radius inject auth 1 calling-station-id
 radius inject auth timer 45
 radius inject auth vsa cisco
 inservice
!
interface vlan 100
 ip policy route-map rlb-pbr
!
access-list 1 permit 0.0.0.1 255.255.255.254 
access-list 2 permit 0.0.0.0 255.255.255.254 
!
route-map rlb-pbr permit 10
 match ip address 1
 set ip next-hop 10.10.10.1
!
route-map rlb-pbr permit 20
 match ip address 2
 set ip next-hop 10.10.10.2

Ejemplo cómo configurar IOS SLB con el director del Home Agent

El siguiente ejemplo permite a IOS SLB para equilibrar el IP móvil RRQ entre los agentes caseros múltiples.

Cuadro 29. IOS SLB con el director del Home Agent

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

ip slb serverfarm HA_FARM
 nat server
 real 10.10.10.1
  inservice
 real 10.10.10.2
  inservice
ip slb vserver VIRTUAL_HA
 virtual 10.10.10.10 udp 434 service ipmobile
 serverfarm HA_FARM
 inservice

Ejemplo cómo configurar IOS SLB con las conexiones persistentes

El siguiente ejemplo asigna todas las conexiones HTTP de una subred al mismo servidor real en el PÚBLICO del bloque de servidores:

ip slb vserver http
  serverfarm PUBLIC
  sticky 30 group 1 netmask 255.255.255.248
  virtual 20.20.20.20 tcp 80
  inservice

El siguiente ejemplo agrega las conexiones HTTPS a la configuración antedicha, usando la misma información Sticky pero con un diverso servidor virtual:

ip slb vserver https
  serverfarm PUBLIC
  sticky 30 group 1 netmask 255.255.255.248
  virtual 20.20.20.20 tcp 443
  inservice

Ahora, todo el HTTP y conexiones HTTPS de la subred se asignan al mismo servidor real. Por ejemplo, si un usuario conecta con el HTTP, después un segundo usuario conecta con el HTTPS, ambas conexiones se asigna al mismo servidor real.

Ejemplo cómo configurar IOS SLB con las bases de datos fijas GTP IMSI

El siguiente ejemplo muestra cómo habilitar las bases de datos fijas IOS SLB GTP IMSI:

ip slb serverfarm GGSN_FARM
 failaction gtp purge
 real 10.20.10.1
  weight 1
  faildetect numconns 255 numclients 8
  inservice
!
 real 10.20.10.2
  weight 1
  faildetect numconns 255 numclients 8
  inservice
!
 real 10.20.10.3
  weight 1
  faildetect numconns 255 numclients 8
  inservice
!
ip slb vserver GGSN_SERVER1
 virtual 10.10.10.10 udp 3386 service gtp
 serverfarm GGSN_FARM backup GGSN_FARM
 idle gtp request 90
 idle gtp imsi 10000000
 sticky gtp imsi group 1
 gtp notification cac 3
 inservice
!
ip slb vserver GGSN_SERVER2
 virtual 10.10.10.10 udp 2123 service gtp
 serverfarm GGSN_FARM backup GGSN_FARM
 idle gtp request 90
 idle gtp imsi 10000000
 sticky gtp imsi group 1
 gtp notification cac 3
 inservice

Ejemplo cómo configurar IOS SLB con las bases de datos fijas ASN

Las demostraciones del siguiente ejemplo cómo habilitar las bases de datos fijas IOS SLB ASN:

ip slb entries sticky 15000 800000
ip slb serverfarm ASNLB_FARM
 failaction asn purge 
!
 real 10.20.10.1
  weight 1
  faildetect numconns 255 numclients 8
  inservice
!
 real 10.20.10.2
  weight 1
  faildetect numconns 255 numclients 8
  inservice
!
 real 10.20.10.3
  weight 1
  faildetect numconns 255 numclients 8
  inservice
!
ip slb vserver ASNLB_SERVER
 virtual 10.10.10.10 udp 0 service asn
 serverfarm ASNLB_FARM 
 idle asn request 90
 idle asn msid 100000 
 sticky asn msid group 1
 gw port 63082
 replicate casa 100.100.100.102 100.100.100.101 1024 password hello
 inservice

Ejemplo cómo configurar IOS SLB con caché Web el Equilibrio de carga transparente

En el siguiente ejemplo, el servidor virtual WEBCACHE examina todos los flujos de la red que pasan a través del dispositivo del balanceo de carga y los envía al bloque de servidores WEBCACHE-FARM. El cliente excluye la declaración ignora los flujos que originan de la subred 80.80.7.0, habilitando los servidores reales 80.80.7.188 y 80.80.7.189 para comunicar con Internet según las necesidades.

ip slb serverfarm WEBCACHE-FARM
  real 80.80.7.188
   inservice
  real 80.80.7.189
   inservice
ip slb vserver WEBCACHE
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm WEBCACHE-FARM
  client 80.80.7.0 255.255.255.0 exclude
  inservice

Ejemplo cómo configurar IOS SLB con el agente KAL-AP

En el siguiente ejemplo, configuran al cliente para enviar una interrogación abcd.comto del Domain Name System (DNS) los GS. El selector global de sitio (GS) en el sitio de DUBLÍN recibe las peticiones del cliente. Los GS contestan a la interrogación DNS con la dirección IP virtual de CHICAGO (10.0.0.100) o del NEWYORK (10.0.0.200), sobre la base de la carga señalada por esos servidores virtuales.

Cuadro 30. IOS SLB con el agente KAL-AP

Los siguientes son las declaraciones de Configuración de SLB del OIS para la configuración mostrada en la figura arriba:

GS

shared-keepalive kalap 192.168.1.1 capp-secure enable key kap
shared-keepalive kalap 192.168.2.1 capp-secure enable key kap
!
answer vip 10.0.0.100 name CHICAGO activate
 keepalive type kalap tag 192.168.1.1 chicao.com
answer vip 10.0.0.200 name NEWYORK activate
 keepalive type kalap tag 192.168.2.1 newyork.com
!
answer-group ABCD owner System type vip
answer-add 10.0.0.100 name CHICAGO weight 1 order 0 load-threshold 254 activate
answer-add 10.0.0.200 name NEWYORK weight 1 order 0 load-threshold 254 activate
dns rule ABCDGPRS owner System source-address-list Anywhere domain-list abcd.com query a
 clause 1 vip-group 	method least-loaded ttl 20 count 1 sticky disable

Site-1 IOS SLB - CHICAGO

ip slb capp udp
 peer port 6000 secret 0 kap
!
ip slb serverfarm SF
 kal-ap domain chicago.com
 farm-weight 200
 real 10.10.10.1
  inservice
 real 10.10.10.2
  inservice
!
ip slb vserver chicago
 virtual 10.0.0.100 udp 0
 serverfarm SF
 inservice	
!
ip slb dfp
 agent 10.10.10.1 5000 30 0 10
 agent 10.10.10.2 5000 30 0 10
!
int vlan100
 ip address 192.168.1.1 255.255.255.0

GGSN-1

gprs dfp max-weight 100
gprs maximum-pdp-context-allowed 20000
!
ip dfp agent gprs
 port 5000
 inservice

GGSN-2

gprs dfp max-weight 100
gprs maximum-pdp-context-allowed 20000
!
ip dfp agent gprs
 port 5000
 inservice

Site-2 IOS SLB - NEWYORK

ip slb capp udp
 peer port 6000 
 peer 192.1.1.1 secret 0 test 
 peer 10.100.100.100 port 1234
!
ip slb serverfarm SF
 kal-ap domain newyork.com
 farm-weight 6200
 real 10.20.20.1
  inservice
 real 10.20.20.2
  inservice
 real 10.20.20.3
  inservice
 real 10.20.20.4
  inservice
!
ip slb vserver chicago
 virtual 10.0.0.200 udp 0
 serverfarm SF
 inservice	
!
ip slb dfp
 agent 10.10.10.1 5000 30 0 10
 agent 10.10.10.2 5000 30 0 10
!
int vlan200
 ip address 192.168.2.1 255.255.255.0

GGSN-1

gprs dfp max-weight 100
gprs maximum-pdp-context-allowed 20000
!
ip dfp agent gprs
 port 5000
 inservice

GGSN-2

gprs dfp max-weight 100
gprs maximum-pdp-context-allowed 20000
!
ip dfp agent gprs
 port 5000
 inservice