Routing IP: Guía de configuración BGP, Cisco IOS Release 12.2SR
Borde de la IMAGEN BGP para el IP y el MPLS-VPN
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 289 KB | Inglés (8 Noviembre 2011) | Comentarios

Borde de la IMAGEN BGP para el IP y el MPLS-VPN

Última actualización: De abril el 13 de 2012

El borde de la IMAGEN BGP para la característica IP y MPLS-VPN mejora la convergencia BGP después de un desperfecto de la red. Esta convergencia es aplicable a los errores de la base y del borde y se puede utilizar en el IP y las redes MPLS. El borde de la IMAGEN BGP para la característica IP y MPLS-VPN crea y salva un respaldo/un trayecto alterno en el Routing Information Base (RIB), la Base de información de reenvío (FIB), y el Cisco Express Forwarding de modo que cuando detectan a un error, el respaldo/el trayecto alterno pueda asumir el control inmediatamente, así habilitar la Conmutación por falla rápida.


Nota


En este documento, el borde de la IMAGEN BGP para la característica IP y MPLS-VPN se llama IMAGEN BGP.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la información de la característica para la IMAGEN BGP.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Requisitos previos para la IMAGEN BGP

  • Asegúrese de que el Border Gateway Protocol (BGP) y el IP o la red del Multiprotocol Label Switching (MPLS) sea en servicio con el sitio del cliente conectado con el sitio del proveedor por más de una trayectoria (multihomed).
  • Asegúrese de que el respaldo/el trayecto alterno tenga un salto siguiente único que no sea lo mismo que el salto siguiente del mejor trayecto.
  • Permita al protocolo bidireccional de la detección de la expedición (BFD) para detectar rápidamente las fallas de link directamente de los vecinos conectados.

Restricciones para la IMAGEN BGP

  • Con el trayecto múltiple de BGP, la característica de la convergencia de la Prefijo-independiente BGP (IMAGEN) se soporta ya.
  • En el MPLS VPNs, la característica de la IMAGEN BGP no se soporta con la opción B de los entre sistemas autónomos del MPLS VPN.
  • Los soportes de característica de la IMAGEN BGP prefijan solamente para el IPv4, el IPv6, el VPNv4, y las familias del direccionamiento VPNv6.
  • La característica de la IMAGEN BGP no se puede configurar con las familias del direccionamiento del Multicast o del ruteo virtual y de la expedición L2VPN (VRF).
  • Si el reflector de ruta está solamente en el avión del control, después usted no necesita la IMAGEN BGP, porque la IMAGEN BGP dirige la convergencia plana de los datos.
  • Cuando dos Routers PE hace respaldo/trayecto alterno de cada uno a un router CE, el tráfico pudo colocar si el router CE falla. Ninguno de los dos routers alcanzará el router CE, y el tráfico continuará siendo remitido entre el Routers PE hasta que expire el temporizador del Tiempo para vivir (TTL).
  • La característica de la IMAGEN BGP no soporta la expedición directa con el Stateful Switchover (NSF/SSO). Sin embargo, se soporta ISSU si ambos Route Processor tienen la característica de la IMAGEN BGP configurada.
  • La característica de la IMAGEN BGP soluciona el reenvío de tráfico solamente para un error de la red única en el borde y la base.
  • La característica de la IMAGEN BGP no trabaja con la mejor característica externa BGP. Si usted intenta configurar la característica de la IMAGEN BGP después de configurar la mejor característica externa BGP, usted recibe un error.

Información sobre la IMAGEN BGP

Ventajas del borde de la IMAGEN BGP para la característica IP y MPLS-VPN

  • Una trayectoria adicional para la Conmutación por falla permite una restauración más rápida de la Conectividad si un trayecto principal es inválido o aislado.
  • Reducción de la pérdida de tráfico.
  • Tiempo de convergencia constante de modo que el tiempo de Switching sea lo mismo para todos los prefijos.

Cómo converge el BGP en circunstancias normales

En circunstancias normales, el BGP puede llevar varios segundos algunos minutos para converger después de un cambio de la red. En un nivel elevado, el BGP pasa con el proceso siguiente:

  1. El BGP aprende de los errores con los eventos del Interior Gateway Protocol (IGP) o BFD o los eventos de la interfaz.
  2. El BGP retira las rutas del Routing Information Base (RIB), y el RIB retira las rutas de la Base de información de reenvío (FIB) y de la BOLA distribuida (dFIB). Este proceso borra el trayecto de datos para los prefijos afectados.
  3. El BGP envía retira los mensajes a sus vecinos.
  4. El BGP calcula el mejor trayecto siguiente a los prefijos afectados.
  5. El BGP inserta el mejor trayecto siguiente para los prefijos afectados en el RIB, y el RIB los instala en la BOLA y el dFIB.

Este proceso tarda algunos segundos o algunos minutos para completar, dependiendo del tiempo de espera de la red, del tiempo de convergencia a través de la red, y de la carga local en los dispositivos. El avión de los datos converge solamente después que converge el avión del control.

Cómo la IMAGEN BGP mejora la convergencia

Las funciones de la IMAGEN BGP son alcanzadas por las funciones adicionales en el BGP, el RIB, el Cisco Express Forwarding, y el MPLS.

  • Funciones BGP

Los prefijos de las influencias de la IMAGEN BGP bajo el IPv4 y el VPNv4 se dirigen a las familias. Para esos prefijos, el BGP calcula una trayectoria adicional de la segunda mejor, junto con el mejor trayecto primario. (La trayectoria de la segunda mejor se llama el respaldo/el trayecto alterno.) el BGP instala el mejor y el respaldo/los trayectos alternos para los prefijos afectados en el RIB BGP. El respaldo/el trayecto alterno proporciona un mecanismo del Fast ReRoute para contradecir un desperfecto de la red singular. El BGP también incluye el suplente/el trayecto de backup en su interfaz de programación de aplicaciones (API) al RIB IP.

  • Funciones del RIB

Para la IMAGEN BGP, el RIB instala un trayecto alterno por la ruta si uno está disponible. Con las funciones de la IMAGEN BGP, si el RIB selecciona una ruta BGP que contiene un respaldo/un trayecto alterno, instala el respaldo/el trayecto alterno con el mejor trayecto. El RIB también incluye el trayecto alterno en su API con la BOLA.

  • Funciones del Cisco Express Forwarding

Con la IMAGEN BGP, el Cisco Express Forwarding salva un trayecto alterno por el prefijo. Cuando va el trayecto principal abajo, el Cisco Express Forwarding busca para el respaldo/el trayecto alterno de una manera de la independiente del prefijo. El Cisco Express Forwarding también escucha los eventos BFD para detectar rápidamente las fallas locales.

  • Funciones MPLS

La expedición MPLS es similar al Cisco Express Forwarding, en que salva los trayectos alternos y el Switches al el trayecto alterno si va el trayecto principal abajo.

Cuando se habilita la característica de la IMAGEN BGP, el BGP calcula un respaldo/un trayecto alterno por el prefijo y lo instala en el RIB BGP, el RIB IP, y la BOLA. Esto mejora la convergencia después de un desperfecto de la red. Hay dos errores de los tipos de red que la característica de la IMAGEN BGP detecta:

  • Nodo de la base/falla de link (falla de nodo del [iBGP] del Internal Border Gateway Protocol): Si un nodo/el link PE falla, después detectan al error con la convergencia IGP. El IGP transporta el error a través del RIB a la BOLA.
  • Link/error locales del nodo del vecino inmediato (nodo/falla de link del [eBGP] del Border Gateway Protocol externo): Para detectar un error local del nodo del peer de la falla de link o del salto único del eBGP en menos que un segundo, usted debe habilitar el BFD. El Cisco Express Forwarding busca los eventos BFD para detectar un error de un par del salto único del eBGP.

Convergencia en el avión de los datos

Al detectar un error, el Cisco Express Forwarding detecta el salto siguiente alterno para todos los prefijos afectados por el error. La convergencia del avión de los datos se alcanza en los subseconds dependiendo de si la implementación de la IMAGEN BGP existe en el software o el soporte físico.

Convergencia en el avión del control

Al detectar el error, el BGP aprende sobre el error con la convergencia IGP o los eventos BFD y envía retira los mensajes para los prefijos, recalculando el mejor y el respaldo/los trayectos alternos, y haciendo publicidad del mejor trayecto siguiente a través de la red.

El papel del rerruteo rápido BGP en la característica de la IMAGEN BGP

El Fast ReRoute BGP (FRR) proporciona un mejor trayecto y un respaldo/un trayecto alterno en el BGP, el RIB, y el Cisco Express Forwarding. El BGP FRR proporciona mismo un mecanismo del Fast ReRoute en el RIB y el Cisco Express Forwarding en el salto siguiente del respaldo BGP para alcanzar un destino cuando el mejor trayecto actual no está disponible.

Los precomputes BGP FRR una trayectoria de la segunda mejor en el BGP y dan lo al RIB y el Cisco Express Forwarding como un respaldo/trayecto alterno, y el Cisco Express Forwarding lo programa en el linecards.

Por lo tanto, el BGP FRR configura el mejor trayecto y el respaldo/el trayecto alterno. La característica de la IMAGEN BGP proporciona la capacidad para que el Cisco Express Forwarding conmute rápidamente el tráfico a los otros puertos de egreso si va el salto siguiente actual o el link a este salto siguiente abajo. Esto se ilustra en la figura abajo.

Figura 1Borde y BGP FRR de la IMAGEN BGP


Cómo detectan a un error

El IGP detecta a un error en el par del iBGP (telecontrol); puede tardar algunos segundos para detectar el error. La convergencia puede ocurrir en los subseconds o los segundos, dependiendo de si la IMAGEN está habilitada en el linecards.

Si el error está con directamente los vecinos conectados (eBGP), y si usted utiliza el BFD para detectar cuando ha ido un vecino abajo, la detección sucede dentro de un subsecond y la convergencia puede ocurrir en los subseconds o los segundos, dependiendo de si la IMAGEN está habilitada en el linecards.

Cómo la IMAGEN BGP alcanza la convergencia sub-segunda

La característica de la IMAGEN BGP trabaja en el Cisco Express Forwarding llano, y el Cisco Express Forwarding se puede procesar en ambo linecards del hardware y en el software.

  • Para las Plataformas que soportan el Cisco Express Forwarding que procesa en el linecards, la característica de la IMAGEN BGP puede converger en los subseconds. El Cisco Express Forwarding de los soportes del Cisco 7600 Router y del Cisco 10000 Router que procesa en el linecards y en el software, y puede lograr así la convergencia sub-segunda.
  • Para las Plataformas que no utilizan el Cisco Express Forwarding en el linecards del hardware, el Cisco Express Forwarding se alcanza en el software. La característica de la IMAGEN BGP trabajará con el Cisco Express Forwarding a través del software y alcanzará la convergencia dentro de los segundos. El Cisco Express Forwarding de los soportes del Cisco 7200 Router en el software y puede alcanzar así la convergencia en los segundos bastante que los milisegundos.

Cómo la IMAGEN BGP mejora sobre las funciones del MPLS VPN--BGP Local Convergence

La característica de la IMAGEN BGP es una mejora al MPLS VPN--Característica local de la convergencia BGP, que proporciona un mecanismo de la Conmutación por falla que recalcule el mejor trayecto y instale la nueva trayectoria en la expedición después de una falla de link. La característica mantiene la escritura de la etiqueta local por 5 minutos para asegurar que el tráfico utiliza el respaldo/el trayecto alterno, la pérdida de tráfico así de reducción al mínimo.

La característica de la IMAGEN BGP mejora el tiempo de la ubicación bajo a segundo calculando un respaldo/un trayecto alterno por adelantado. Cuando ocurre una falla de link, el tráfico se envía al respaldo/al trayecto alterno.

Cuando usted configura la característica de la IMAGEN BGP, reemplazará las funciones del MPLS VPN--Característica local de la convergencia BGP. Usted no tiene que quitar los local-prefijos de la protección ordena de la configuración.

Modos de configuración para habilitar la IMAGEN BGP

Porque muchas redes del proveedor de servicios contienen muchos VRF, la característica de la IMAGEN BGP permite que usted configure la característica de la IMAGEN BGP para todos los VRF inmediatamente.

  • El modo de configuración de la familia del direccionamiento del VPNv4 protege todos los VRF.
  • El modo de configuración de la familia del direccionamiento del VRF-IPv4 protege solamente el IPv4 VRF.
  • El modo de configuración del router protege los prefijos en la tabla de Global Routing.

Escenarios de la IMAGEN BGP

Los escenarios siguientes explican cómo usted puede configurar las funciones de la IMAGEN BGP para alcanzar la convergencia rápida:

Link IP PE-CE y protección del nodo en el lado CE (PE duales)

La figura abajo muestra una red que utilice la característica de la IMAGEN BGP. La red incluye los componentes siguientes:

  • las sesiones eBGP existen entre el Routers PE y CE.
  • El tráfico del CE1 utiliza el PE1 para alcanzar la red 192.168.9.0/24 a través del router CE3.
  • El CE1 tiene dos trayectorias:
    • PE1 como el trayecto principal.
    • PE2 como el respaldo/el trayecto alterno.

El CE1 se configura con la característica de la IMAGEN BGP. El BGP computa el PE1 como el mejor trayecto y el PE2 como el respaldo/el trayecto alterno y instala ambas rutas en el RIB y el avión del Cisco Express Forwarding. Cuando va el link del CE1-PE1 abajo, el Cisco Express Forwarding detecta la falla de link y señala el objeto de la expedición al respaldo/al trayecto alterno. El tráfico es rápidamente rerruteado debido a la convergencia rápida local en el Cisco Express Forwarding.

Figura 2Usando la IMAGEN BGP para proteger el PE-CE conecte


Link IP PE-CE y protección del nodo en el lado CE (CE duales y Nodos primarios y de reserva PE dual)

La figura abajo muestra una red que utilice la característica de la IMAGEN BGP en el CE1. La red incluye los componentes siguientes:

  • las sesiones eBGP existen entre el Routers PE y CE.
  • El tráfico del CE1 utiliza el PE1 para alcanzar la red 192.168.9.0/24 a través del router CE3.
  • El CE1 tiene dos trayectorias:
    • PE1 como el trayecto principal.
    • PE2 como el respaldo/el trayecto alterno.
  • Una sesión del iBGP existe entre el Routers CE1 y CE2.

En este ejemplo, el CE1 y el CE2 se configuran con la característica de la IMAGEN BGP. El BGP computa el PE1 como el mejor trayecto y el PE2 como el respaldo/el trayecto alterno y instala ambos las rutas en el RIB y el avión del Cisco Express Forwarding.

No debe haber ninguna directivas fijada en el CE1 y el CE2 para los pares PE1 y PE2 del eBGP. Ambo Routers CE debe señalar a la ruta del eBGP como salto siguiente. En el CE1, el salto siguiente para alcanzar el CE3 está con el PE1, así que el PE1 es el mejor trayecto para alcanzar el CE3. En el CE2, el mejor trayecto para alcanzar el CE3 es PE2. El CE2 se hace publicidad como el salto siguiente al CE1, y el CE1 hace lo mismo al CE2. Como consecuencia, el CE1 tiene dos trayectorias para el prefijo específico y selecciona generalmente la trayectoria directamente conectada del eBGP sobre la trayectoria del iBGP según las reglas de selección del mejor trayecto. Semejantemente, el CE2 tiene dos trayectorias--una trayectoria del eBGP con el PE2 y una trayectoria del iBGP con el CE1-PE1.

Cuando va el link del CE1-PE1 abajo, el Cisco Express Forwarding detecta la falla de link y señala el objeto de la expedición al nodo de reserva/del suplente CE2. El tráfico es rápidamente rerruteado debido a la convergencia rápida local en el Cisco Express Forwarding.

Si va el link del CE1-PE1 o el PE1 abajo y IMAGEN BGP se habilita en el CE1, el BGP recalcula el mejor trayecto, quitando el salto siguiente PE1 del RIB y reinstalando el CE2 como el salto siguiente en el RIB y el Cisco Express Forwarding. El CE1 consigue automáticamente una trayectoria de reserva/del suplente de la reparación en el Cisco Express Forwarding y la pérdida de tráfico durante la expedición ahora está en los subseconds, de tal modo alcanzando la convergencia rápida.

Figura 3Usando la IMAGEN BGP en un CE dual, red dual PE


Link Protection IP MPLS PE-CE para la trayectoria primaria o Respaldo-alterna

El Link Protection IP MPLS PE-CE para la trayectoria primaria o Respaldo-alterna muestra una red que utilice la característica de la IMAGEN BGP en el CE1 y el CE2. La red incluye los componentes siguientes:

  • las sesiones eBGP existen entre el Routers PE y CE.
  • El Routers PE es pares del iBGP del VPNv4 con refleja al Routers en la red MPLS.
  • El tráfico del CE1 utiliza el PE1 para alcanzar la red 192.168.9.0/24 a través del router CE3.
  • El CE3 es dual dirigido con PE3 y PE4.
  • El PE1 tiene dos trayectorias para alcanzar el CE3 del Routers del reflejo:
    • PE3 es el trayecto principal con el salto siguiente pues un direccionamiento PE3.
    • PE4 es el respaldo/el trayecto alterno con el salto siguiente pues un direccionamiento PE4.

En este ejemplo, todo el Routers PE puede ser configurado con la característica de la IMAGEN BGP bajo las familias de direccionamiento del IPv4 o del VPNv4.

Para que la IMAGEN BGP trabaje en el BGP para el Link Protection PE-CE, fije las directivas en PE3 y PE4 para los prefijos recibidos del CE3 de modo que uno del Routers PE actúe como el primario y la otra como el de reserva/el suplente. Generalmente, esto se hace usando la preferencia local y el donante de una mejor preferencia local a PE3. En la nube MPLS, trafique internamente atraviesa PE3 para alcanzar el CE3. Así, el PE1 tiene PE3 como el mejor trayecto y PE4 como la segunda trayectoria.

Cuando va el link del PE3-CE3 abajo, el Cisco Express Forwarding detecta la falla de link, y PE3 recalcula el mejor trayecto, selecciona PE4 como el mejor trayecto, y envía un mensaje del retirar para el prefijo PE3 al Routers del reflejo. Algo del tráfico pasa con el PE3-PE4 hasta que el BGP instale PE4 como la ruta del mejor trayecto en el RIB y el Cisco Express Forwarding. El PE1 recibe el retirar, recalcula el mejor trayecto, selecciona PE4 como el mejor trayecto, y instala las rutas en el RIB y el avión del Cisco Express Forwarding.

Así, con la IMAGEN BGP habilitada en PE3 y PE4, el Cisco Express Forwarding detecta la falla de link y hace la modificación sobre el terreno del objeto de la expedición al nodo de reserva/del suplente PE4 que existe ya en el Cisco Express Forwarding. PE4 sabe que el respaldo/el trayecto alterno localmente está generado y rutea el tráfico al puerto de egreso conectado con el CE3. Se minimiza esta manera, pérdida de tráfico y se alcanza la convergencia rápida.

Protección del nodo IP MPLS PE-CE para la trayectoria primaria o Respaldo-alterna

El cuadro 4 muestra una red que utilice la característica de la IMAGEN BGP en todo el Routers PE en una red MPLS.

‘Figura 4’Habilitar la IMAGEN BGP en todo el Routers PE en la red MPLS


La red incluye los componentes siguientes:

  • las sesiones eBGP existen entre el Routers PE y CE.
  • El Routers PE es pares del iBGP del VPNv4 con refleja al Routers en la red MPLS.
  • El tráfico del CE1 utiliza el PE1 para alcanzar la red 192.168.9.0/24 a través del router CE3.
  • El CE3 es dual dirigido con PE3 y PE4.
  • El PE1 tiene dos trayectorias para alcanzar el CE3 del Routers del reflejo:
    • PE3 es el trayecto principal con el salto siguiente pues un direccionamiento PE3.
    • PE4 es el respaldo/el trayecto alterno con el salto siguiente pues un direccionamiento PE4.

En este ejemplo, configuran a todo el Routers PE con la característica de la IMAGEN BGP bajo las familias de direccionamiento del IPv4 y del VPNv4.

Para que la IMAGEN BGP trabaje en el BGP para la protección del nodo PE-CE, fije las directivas en PE3 y PE4 para los prefijos recibidos del CE3 tales que uno del Routers PE actúa como primario y el otro como el respaldo/suplente. Generalmente, esto se hace usando la preferencia local y el donante de una mejor preferencia local a PE3. En la nube MPLS, trafique internamente atraviesa PE3 para alcanzar el CE3. Así pues, el PE1 tiene PE3 como el mejor trayecto y PE4 como la segunda trayectoria.

Cuando va PE3 abajo, el PE1 sabe sobre el retiro del prefijo del host por los IGP en los subseconds, recalcula el mejor trayecto, selecciona PE4 como el mejor trayecto, y instala las rutas en el RIB y el avión del Cisco Express Forwarding. La convergencia BGP normal sucederá mientras que la IMAGEN BGP está reorientando el tráfico con PE4, y los paquetes no se pierden.

Así, con la IMAGEN BGP habilitada en PE3, el Cisco Express Forwarding detecta la falla de nodo en PE3 y señala el objeto de la expedición al nodo de reserva/del suplente PE4. PE4 sabe que el respaldo/el trayecto alterno localmente está generado y rutea el tráfico al puerto de egreso usando el respaldo/el trayecto alterno. Se minimiza esta manera, pérdida de tráfico.

Ningunas políticas locales fijadas en el Routers PE

El PE1 y el PE2 señalan a las trayectorias del eBGP CE como el salto siguiente sin la política local. Cada uno del Routers PE recibe el otro trayectoria, y el BGP calcula el respaldo/el trayecto alterno y lo instala en el Cisco Express Forwarding, junto con su propia trayectoria del eBGP hacia el CE como el mejor trayecto. La limitación de las soluciones de la protección del link y del nodo MPLS PE-CE es que usted no puede cambiar las políticas de BGP. Deben trabajar sin la necesidad de una trayectoria del mejor-externo.

Políticas locales fijadas en el Routers PE

Siempre que haya una política local en el Routers PE para seleccionar uno del Routers PE como el trayecto principal alcanzar la salida CE, el comando del hacer publicidad-mejor-externo BGP se necesita en el nodo de reserva/del suplente PE3 para propagar las rutas del externo CE con una escritura de la etiqueta de reserva/del suplente en los reflectores de ruta y el Routers del otro extremo PE.

Repetición del Cisco Express Forwarding

La repetición es la capacidad de encontrar la trayectoria que corresponde con más larga siguiente cuando va el trayecto principal abajo.

Cuando la característica de la IMAGEN BGP no está instalada, y si el salto siguiente a un prefijo falla, el Cisco Express Forwarding encuentra la trayectoria siguiente para alcanzar el prefijo recursing con la BOLA para encontrar la trayectoria que corresponde con más larga siguiente al prefijo. Esto es útil si el salto siguiente es saltos múltiples lejos y hay más de una manera de alcanzar el salto siguiente.

Sin embargo, con la característica de la IMAGEN BGP, usted puede querer inhabilitar la repetición del Cisco Express Forwarding por las razones siguientes:

  • La repetición retrasa la convergencia cuando el Cisco Express Forwarding busca todas las entradas de la BOLA.
  • BGP de la IMAGEN del borde precomputes ya un trayecto alterno, así eliminando la necesidad de la repetición del Cisco Express Forwarding.

Cuando se habilitan las funciones de la IMAGEN BGP, la repetición del Cisco Express Forwarding se inhabilita por abandono para dos condiciones:

  • Para los saltos siguientes aprendidos con una máscara de la red de /32 (rutas del host)
  • Para los saltos siguientes que están conectados directamente

Para el resto de los casos, se habilita la repetición del Cisco Express Forwarding.

Como parte de las funciones de la IMAGEN BGP, usted puede publicar el comando host de la repetición BGP de inhabilitar o de habilitar la repetición del Cisco Express Forwarding para las rutas del host BGP.

Para inhabilitar o habilitar la repetición del Cisco Express Forwarding para el BGP conectó directamente los saltos siguientes, usted puede publicar el comando de neutralización-conectar-control.

Cómo configurar la IMAGEN BGP

Configurar la IMAGEN BGP

Porque muchas redes del proveedor de servicios contienen muchos VRF, la característica de la IMAGEN BGP permite que usted configure la característica de la IMAGEN BGP para todos los VRF inmediatamente.

  • El modo de configuración de la familia del direccionamiento del VPNv4 protege todos los VRF.
  • El modo de configuración de la familia del direccionamiento del VRF-IPv4 protege solamente el IPv4 VRF.
  • El modo de configuración del router protege los prefijos en la tabla de Global Routing.

Por un ejemplo de la configuración total que incluya configurar los VRF multiprotocol y muestre la salida para verificar que la característica está habilitada, vea el ejemplo: Configurar la IMAGEN BGP.

Antes de comenzar
  • Si usted está implementando la característica BGP PIC en un MPLS VPN, asegúrese de que la red esté trabajando correctamente antes de configurar la característica BGP PIC. Vea configurar la capa 3 VPN MPLS para más información.
  • Si usted está implementando la característica BGP PIC en un MPLS VPN, configure los VRF multiprotocol, que permiten que usted comparta las directivas de la ruta-blanco (importación y exportación) entre el IPv4 y el IPv6 o que configure las directivas separadas de la ruta-blanco para el IPv4 y el IPv6 VPN. Para la información sobre configurar los VRF multiprotocol, vea el MPLS VPN--VRF CLI para el IPv4 y el IPv6 VPN.
  • Asegúrese de que el router CE sea conectado con la red por por lo menos dos trayectorias.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. autonomous-system-number BGP del router

4.   Siga uno de los siguientes pasos:

  • direccionamiento-familia ipv4 [unicast | vrf-name del vrf]
  • o
  • [unicast] de la direccionamiento-familia vpnv4

5. las adicional-trayectorias BGP instalan

6. neighbor ip-address telecontrol-como el autonomous-system-number

7. el neighbor ip-address activa

8. host de la repetición BGP

9. fail-over del neighbor ip-address [bfd |nombre de asignación del route-map]

10. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
autonomous-system-number BGP del router


Ejemplo:

BGP 40000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
Siga uno de los siguientes pasos:
  • direccionamiento-familia ipv4 [unicast | vrf-name del vrf]
  • o
  • [unicast] de la direccionamiento-familia vpnv4


Ejemplo:

Router (config-router) # unicast de la direccionamiento-familia ipv4



Ejemplo:



Ejemplo:



Ejemplo:

Router (config-router) # direccionamiento-familia vpnv4

 

Especifica familia del direccionamiento del IPv4 o del VPNv4 y ingresa al modo de configuración de la familia del direccionamiento.

  • La palabra clave del unicast especifica familia a la dirección de Unicast del IPv4 o del VPNv4.
  • La palabra clave vrf y el argumento vrf-name especifican el nombre de la instancia de VRF (ruteo y reenvío virtual) que se va a asociar a los comandos subsiguientes del modo de configuración de la familia de direcciones IPv4.
 
Paso 5
las adicional-trayectorias BGP instalan


Ejemplo:

El router (config-router-AF) # las adicional-trayectorias BGP instala

 

Calcula un respaldo/un trayecto alterno y lo instala en el RIB y el Cisco Express Forwarding.

 
Paso 6
neighbor ip-address telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 telecontrol-como 45000

 

Añade la dirección IP del vecino del sistema autónomo especificado a la tabla de vecinos de BGP multiprotocolo IPv4 del router local.

  • De forma predeterminada, los vecinos que se definen mediante el comando neighbor remote-as en modo de configuración del router sólo intercambian los prefijos de dirección unicast IPv4. Para intercambiar otros tipos del prefijo de dirección, los vecinos deben también ser activados usando el comando neighbor activate en el modo de configuración de la familia del direccionamiento para los otros tipos del prefijo.
 
Paso 7
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 activa

 

Permite al vecino intercambiar los prefijos de la familia de direcciones unicast IPv4 con el router local.

 
Paso 8
host de la repetición BGP


Ejemplo:

Router (config-router-AF) # host de la repetición BGP

 

(Opcional) habilita el indicador del recurrente-vía-host para el IPv4, el VPNv4, y las familias del direccionamiento VRF.

  • Cuando se habilita la característica de la IMAGEN BGP, se inhabilita la repetición del Cisco Express Forwarding. Bajo la mayoría de circunstancias, usted no quiere habilitar la repetición cuando se habilita la IMAGEN BGP.
 
Paso 9
fail-over del neighbor ip-address [bfd |nombre de asignación del route-map]


Ejemplo:

Router (config-router-AF) # bfd del fail-over de 192.168.1.1 del vecino

 

Permite al soporte a protocolo BFD para detectar cuando ha salido un vecino, que puede ocurrir dentro de un subsecond.

 
Paso 10
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Ejemplos de configuración para la IMAGEN BGP

Ejemplo: Configurar la IMAGEN BGP

Las demostraciones del siguiente ejemplo cómo configurar la característica de la IMAGEN BGP en el modo de configuración de la familia del direccionamiento del VPNv4, que habilita la característica en todos los VRF. En el siguiente ejemplo, hay dos VRF definido: azul y verde. Todos los VRF, incluyendo ésos en los VRF azules y verdes, son protegidos por el respaldo/los trayectos alternos.

vrf definition test1
 rd 400:1
 route-target export 100:1
 route-target export 200:1
 route-target export 300:1
 route-target export 400:1
 route-target import 100:1
 route-target import 200:1
 route-target import 300:1
 route-target import 400:1
 address-family ipv4
 exit-address-family
 exit
!
interface Ethernet1/0
 vrf forwarding test1
 ip address 10.0.0.1 255.0.0.0
 exit
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 redistribute static
 redistribute connected
 neighbor 10.6.6.6 remote-as 3
 neighbor 10.6.6.6 update-source Loopback0
 neighbor 10.7.7.7 remote-as 3
 neighbor 10.7.7.7 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  bgp additional-paths install
  neighbor 10.6.6.6 activate
  neighbor 10.6.6.6 send-community both
  neighbor 10.7.7.7 activate
  neighbor 10.7.7.7 send-community both
 exit-address-family
 !
 address-family ipv4 vrf blue
  import path selection all
  import path limit 10
  no synchronization
  neighbor 10.11.11.11 remote-as 1
  neighbor 10.11.11.11 activate
 exit-address-family
 !
 address-family ipv4 vrf green
  import path selection all
  import path limit 10
  no synchronization
  neighbor 10.13.13.13 remote-as 1
  neighbor 10.13.13.13 activate
 exit-address-family

La salida siguiente del comando detail del vrf de la demostración muestra que la característica de la IMAGEN BGP está habilitada:

Router# show vrf detail
VRF test1 (VRF Id = 1); default RD 400:1; default VPNID <not set>
  Interfaces:
    Se4/0                   
Address family ipv4 (Table ID = 1 (0x1)):
  Export VPN route-target communities
    RT:100:1                 RT:200:1                 RT:300:1
    RT:400:1                
  Import VPN route-target communities
    RT:100:1                 RT:200:1                 RT:300:1
    RT:400:1                
  No import route-map
  No export route-map
  VRF label distribution protocol: not configured
  VRF label allocation mode: per-prefix
  Prefix protection with additional path enabled
Address family ipv6 not active.

Ejemplo: Visualizar los trayectos alternos de reserva para la IMAGEN BGP

La salida de comando en el siguiente ejemplo muestra que los VRF en los VRF BLUE tienen el respaldo/trayectos alternos:

Router# show ip bgp vpnv4 vrf blue 10.0.0.0
BGP routing table entry for 10:12:12.0.0.0/24, version 88
Paths: (4 available, best #1, table blue)
  Additional-path
  Advertised to update-groups:
     6         
  1, imported path from 12:23:12.0.0.0/24
    10.3.3.3 (metric 21) from 10.6.6.6 (10.6.6.6)
      Origin incomplete, metric 0, localpref 200, valid, internal, best
      Extended Community: RT:12:23
      Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
      mpls labels in/out nolabel/37
  1, imported path from 12:23:12.0.0.0/24
    10.13.13.13 (via green) from 10.13.13.13 (10.0.0.2)
      Origin incomplete, metric 0, localpref 100, valid, external
      Extended Community: RT:12:23 , recursive-via-connected
  1, imported path from 12:23:12.0.0.0/24
    10.3.3.3 (metric 21) from 10.7.7.7 (10.7.7.7)
      Origin incomplete, metric 0, localpref 200, valid, internal
      Extended Community: RT:12:23
      Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
      mpls labels in/out nolabel/37
  1
    10.11.11.11 from 10.11.11.11 (1.0.0.1)
      Origin incomplete, metric 0, localpref 100, valid, external, backup/repair
      Extended Community: RT:11:12 , recursive-via-connected

La salida de comando en el siguiente ejemplo muestra que los VRF en el verde VRF tienen el respaldo/trayectos alternos:

Router# show ip bgp vpnv4 vrf green 12.0.0.0
BGP routing table entry for 12:23:12.0.0.0/24, version 87
Paths: (4 available, best #4, table green)
  Additional-path
  Advertised to update-groups:
     5         
  1, imported path from 11:12:12.0.0.0/24
    10.11.11.11 (via blue) from 10.11.11.11 (1.0.0.1)
      Origin incomplete, metric 0, localpref 100, valid, external
      Extended Community: RT:11:12 , recursive-via-connected
  1
    10.3.3.3 (metric 21) from 10.7.7.7 (10.7.7.7)
      Origin incomplete, metric 0, localpref 200, valid, internal
      Extended Community: RT:12:23
      Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
      mpls labels in/out nolabel/37
  1
    10.13.13.13 from 10.13.13.13 (10.0.0.2)
      Origin incomplete, metric 0, localpref 100, valid, external, backup/repair
      Extended Community: RT:12:23 , recursive-via-connected
  1
    10.3.3.3 (metric 21) from 10.6.6.6 (10.6.6.6)
      Origin incomplete, metric 0, localpref 200, valid, internal, best
      Extended Community: RT:12:23
      Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
      mpls labels in/out nolabel/37

La salida de comando en el siguiente ejemplo muestra las entradas de la tabla de ruteo BGP para el respaldo y los trayectos alternos:

Router# show ip bgp 10.0.0.0 255.255.0.0
BGP routing table entry for 10.0.0.0/16, version 123
Paths: (4 available, best #3, table default)
  Additional-path
  Advertised to update-groups:
     2          3         
  Local
    10.0.101.4 from 10.0.101.4 (10.3.3.3)
      Origin IGP, localpref 100, weight 500, valid, internal
  Local
    10.0.101.3 from 10.0.101.3 (10.4.4.4)
      Origin IGP, localpref 100, weight 200, valid, internal
  Local
    10.0.101.2 from 10.0.101.2 (10.1.1.1)
      Origin IGP, localpref 100, weight 900, valid, internal, best
  Local
    10.0.101.1 from 10.0.101.1 (10.5.5.5)
      Origin IGP, localpref 100, weight 700, valid, internal, backup/repair

La salida de comando en el siguiente ejemplo muestra las entradas del Routing Information Base para el respaldo y los trayectos alternos:

Router# show ip route repair-paths 10.0.0.0 255.255.0.0
Routing entry for 10.0.0.0/16
  Known via "bgp 10", distance 200, metric 0, type internal
  Last update from 10.0.101.2 00:00:56 ago
  Routing Descriptor Blocks:
  * 10.0.101.2, from 10.0.101.2, 00:00:56 ago
      Route metric is 0, traffic share count is 1
      AS Hops 0
      MPLS label: none
    [RPR]10.0.101.1, from 10.0.101.1, 00:00:56 ago
      Route metric is 0, traffic share count is 1
      AS Hops 0
      MPLS label: none

La salida de comando en el siguiente ejemplo muestra el Cisco Express Forwarding/las entradas de bases de información de reenvío para el respaldo y los trayectos alternos:

Router# show ip cef 10.0.0.0 255.255.0.0 detail
10.0.0.0/16, epoch 0, flags rib only nolabel, rib defined all labels
  recursive via 10.0.101.2
    attached to GigabitEthernet0/2
  recursive via 10.0.101.1, repair
    attached to GigabitEthernet0/2

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Comandos bgp: sintaxis de comandos completa, modo de comandos, historial de comandos, valores predeterminados, directrices de uso y ejemplos

Routing IP del Cisco IOS: Referencia del comando bgp

VPNs MPLS Básicas

Configuración de VPNs de Capa 3 MPLS

Una característica de la Conmutación por falla que crea una nueva trayectoria después de un link o de una falla de nodo

MPLS VPN--BGP Local Convergence

Configurar los VRF multiprotocol

MPLS VPN--CLI VRF para VPNs IPv4 y IPv6

Encaminamiento BGP

Mapa de ruta de la característica BGP

Estándares

Estándar

Título

draft-walton-bgp-add-paths-04.txt

Anuncio de los trayectos múltiples en el BGP

MIB

MIB

Link del MIB

Ninguno

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 2547

BGP/MPLS VPN

RFC 1771

Un Border Gateway Protocol 4 (BGP-4)

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información de la característica para la IMAGEN BGP

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para la IMAGEN BGP

Nombre de la función

Versiones

Información sobre la Función

Borde de la IMAGEN BGP para el IP y el MPLS-VPN

12.2(33)SRE

12.2(33)XNE

15.0(1)S

15.2(3)T

El borde de la IMAGEN BGP para la característica IP y MPLS-VPN mejora la convergencia BGP después de un desperfecto de la red. Esta convergencia es aplicable a los errores de la base y del borde y se puede utilizar en el IP y las redes MPLS. El borde de la IMAGEN BGP para la característica IP y MPLS-VPN crea y salva un respaldo/un trayecto alterno en el Routing Information Base (RIB), la Base de información de reenvío (FIB), y el Cisco Express Forwarding de modo que cuando detectan a un error, el respaldo/el trayecto alterno pueda asumir el control inmediatamente, así habilitar la Conmutación por falla rápida.

En 12.2(33)SRE, esta característica fue introducida en el Cisco 7200 y los Cisco 7600 Router.

En 12.2(33)XNE, el soporte fue agregado para el Cisco 10000 Router.

Las secciones siguientes proporcionan información acerca de esta función:

Se han insertado o modificado los siguientes comandos: las adicional-trayectorias BGP instalan, host de la repetición BGP, BGP del IP de la demostración, cef del IP de la demostración, ruta de IP de la demostración, vrf de la demostración.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.