Guía de configuración del IPv6, Cisco IOS Release 12.2SR
Implementar el Tunelización para el IPv6
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 269 KB | Inglés (5 Diciembre 2011) | Comentarios

Contenido

Implementar el Tunelización para el IPv6

Última actualización: De abril el 27 de 2012

Este módulo describe cómo configurar las técnicas de tunelización del recubrimiento usadas por el Cisco IOS Software para soportar la transición de las redes IPv4-only integró las redes IPv4- e IPv6-based. El Tunelización encapsula los paquetes del IPv6 en los paquetes del IPv4 y utiliza la red del IPv4 como mecanismo de la capa de link.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en Cisco.com no se requiere.

Restricciones para implementar el Tunelización para el IPv6

  • En las versiones del Cisco IOS Release 12.0(21)ST y del Cisco IOS Release 12.0(22)S y Anterior, el router de switch Gigabit (GRS) de las Cisco 12000 Series da mismo una prioridad baja al proceso de los paquetes tunneled del IPv6. Por lo tanto, recomendamos fuertemente que usted limita el uso de los túneles del IPv6 en el GSR usando estas versiones a las topologías que sostienen un nivel bajo de tráfico de la red y requieren una cantidad mínima de recursos del Process-Switching.
  • El tráfico del Túnel configurado del IPv6 en el Cisco IOS Release 12.0(23)S se procesa manualmente en el software en el CPU del linecard, en vez en del (RP) del Route Processor en el GSR, dando por resultado el Rendimiento mejorado.

Información sobre implementar el Tunelización para el IPv6

Túneles del recubrimiento para el IPv6

El Tunelización del recubrimiento encapsula los paquetes del IPv6 en los paquetes para entrega del IPv4 a través de una infraestructura del IPv4 (una red del núcleo o Internet (véase la figura abajo). Usando los túneles del recubrimiento, usted puede comunicar con las redes aisladas del IPv6 sin actualizar la infraestructura del IPv4 entre ellas. Los túneles del recubrimiento se pueden configurar entre los Router del borde o entre un Router del borde y un host; sin embargo, ambos puntos finales del túnel deben soportar las pilas del protocolo del IPv4 y del IPv6. El IPv6 soporta los siguientes tipos de mecanismos de tunelización del recubrimiento:

  • Manual
  • Generic Routing Encapsulation (GRE)
  • Compatible con IPv4
  • 6to4
  • Túnel automático de Intrasite que dirige el protocolo (ISATAP)
Figura 1Túneles del recubrimiento



Nota


Los túneles del recubrimiento reducen la Unidad máxima de transmisión (MTU) (MTU) de una interfaz de 20 octetos (si se asume que paquete IPV4 la encabezado básica no contiene los campos opcionales). Una red usando los túneles del recubrimiento es difícil de resolver problemas. Por lo tanto, los túneles cubiertos que conectan las redes aisladas del IPv6 no se deben considerar como arquitectura de red final del IPv6. El uso de los túneles del recubrimiento se debe considerar como técnica de transición hacia una red que soporte las pilas del protocolo del IPv4 y del IPv6 o apenas la pila del protocolo del IPv6.

Utilice la tabla abajo para ayudarle a determinar que el tipo de túnel usted quiera configurar para llevar los paquetes del IPv6 sobre una red del IPv4.

Tabla 1Uso sugerido de los tipos de túnel para llevar los paquetes del IPv6 sobre una red del IPv4

Tipo que hace un túnel

Uso sugerido

Notas de uso

Manual

Túneles Point-to-Point simples que se pueden utilizar dentro de un sitio o entre los sitios

Puede llevar los paquetes del IPv6 solamente.

GRE- y compatible con IPv4

Túneles Point-to-Point simples que se pueden utilizar dentro de un sitio o entre los sitios

Puede llevar el IPv6, el servicio de red sin conexión (CLNS), y muchos otros tipos de paquetes.

Compatible con IPv4

Túneles de la punta a de múltiples puntos

Utiliza:: /96 prefijo. Ahora no recomendamos el usar de este tipo de túnel.

6to4

Los túneles de la punta a de múltiples puntos que se pueden utilizar para conectar aislaron los sitios del IPv6

Direccionamientos del uso de los sitios del prefijo de 2002::/16.

6RD

El servicio del IPv6 se proporciona a los clientes sobre una red del IPv4 usando la encapsulación del IPv6 en el IPv4.

Los prefijos pueden ser del propio bloqueo de dirección SP.

ISATAP

Túneles de la punta a de múltiples puntos que se pueden utilizar para conectar los sistemas dentro de un sitio

Los sitios pueden utilizar a cualquier dirección de Unicast del IPv6.

Discuten los tipos del túnel individual detalladamente en este documento. Recomendamos que usted revisa y entendemos la información sobre el tipo de túnel específico que usted quiere implementar. Cuando usted es familiar con el tipo de túnel que usted necesita, vea la tabla abajo para un resumen de los parámetros de la configuración del túnel que usted puede encontrar útil.

Tabla 2Parámetros de la configuración del túnel haciendo un túnel el tipo

Tipo que hace un túnel

Parámetro de la configuración del túnel

Modo túnel

Origen de túnel

Destino del túnel

Prefijo o direccionamiento de la interfaz

Manual

ipv6ip

Un direccionamiento del IPv4, o una referencia a una interfaz en la cual se configura el IPv4.

Un direccionamiento del IPv4.

Un direccionamiento del IPv6.

GRE/IPv4

IP del gre

Un direccionamiento del IPv4.

Un direccionamiento del IPv6.

Compatible con IPv4

auto-túnel ipv6ip

No requerido. Éstos son todos los tipos del Tunelización de la punta a de múltiples puntos. Calculan a la dirección destino del IPv4, sobre una base por paquete, del destino del IPv6.

No requerido. El direccionamiento de la interfaz se genera como:: tunnel-source/96.

6to4

6to4 ipv6ip

Un direccionamiento del IPv6. El prefijo debe integrar el direccionamiento del IPv4 del origen de túnel

6RD

ipv6ip 6o

Un direccionamiento del IPv6.

ISATAP

isatap ipv6ip

Un prefijo del IPv6 en el formato modificado eui-64. El direccionamiento del IPv6 se genera del prefijo y del direccionamiento del IPv4 del origen de túnel.

Del IPv6 Túneles configurados manualmente

Un Túnel configurado es manualmente equivalente a un enlace permanente entre dos dominios del IPv6 sobre una estructura básica del IPv4. El uso primario está para las conexiones estables que requieren la comunicación segura regular entre dos routeres de borde o entre un sistema extremo y un router de borde, o para la conexión a las redes remotas del IPv6.

Un direccionamiento del IPv6 se configura manualmente en una interfaz del túnel, y los direccionamientos manualmente configurados del IPv4 se asignan al origen de túnel y al destino del túnel. El host o el router en cada extremo de un Túnel configurado debe soportar las pilas del protocolo del IPv4 y del IPv6. Los Túneles configurados se pueden configurar manualmente entre los Router del borde o entre un Router del borde y un host. El Cisco Express Forwarding Switching se puede utilizar para los Túneles configurados del IPv6 manualmente, o el Cisco Express Forwarding Switching puede ser inhabilitado si el process switching es necesario.

Soporte del túnel del IPv4 GRE para el tráfico del IPv6

El tráfico del IPv6 puede ser túneles GRE transportados del IPv4 usando la técnica estándar de la tunelización GRE que se diseña para proporcionar los servicios necesarios implementar cualquier esquema estándar de la encapsulación Point-to-Point. Como en del IPv6 los Túneles configurados manualmente, los túneles GRE son links entre dos puntas, con un túnel diferente para cada link. Los túneles no se atan a un pasajero específico o al Transport Protocol, pero en este caso, lleve el IPv6 como el protocolo pasajero con el GRE como el protocolo de la portadora y IPv4 o el IPv6 como el Transport Protocol.

El uso primario de los túneles GRE está para las conexiones estables que requieren la comunicación segura regular entre dos routeres de borde o entre un router de borde y un sistema extremo. Los routeres de borde y los sistemas extremos deben ser implementaciones de la doble pila.

Soporte GRE sobre el transporte del IPv6

El GRE tiene un campo del protocolo que identifique el protocolo pasajero. Los túneles GRE permiten el Intermediate System-to-Intermediate System (IS-IS) o el IPv6 que se especificarán como protocolo pasajero, que permite que el IS-IS y el tráfico del IPv6 funcionen con encima el mismo túnel. Si el GRE no tuviera un campo del protocolo, sería imposible distinguir si el túnel llevaba los paquetes IS-IS o del IPv6. El campo del protocolo GRE es porqué es deseable que usted hace un túnel el IS-IS y el IPv6 dentro del GRE.

soporte de los túneles del mGRE sobre el IPv6

Para habilitar los proveedores de servicio despliegue el IPv6 en su infraestructura esencial, los túneles de múltiples puntos del Generic Routing Encapsulation (mGRE) sobre el IPv6 se soportan. Los clientes de múltiples puntos dinámicos de la Red privada virtual (DMVPN) pueden ejecutar el IPv4 o el IPv6 en sus redes locales, así que los puntos finales del recubrimiento pueden ser IPv4 o IPv6. Para un punto final del transporte del IPv6, el punto final del recubrimiento puede ser una dirección de red privada del IPv4 o del IPv6. Para la información sobre el DMVPN sobre el IPv6, vea la guía de configuración del IPv6.

El GRE tiene un campo del protocolo que identifique el protocolo pasajero. Los túneles GRE permiten el Intermediate System-to-Intermediate System (IS-IS) o el IPv6 que se especificarán como protocolo pasajero, que permite que el IS-IS y el tráfico del IPv6 funcionen con encima el mismo túnel. Si el GRE no tuviera un campo del protocolo, sería imposible distinguir si el túnel llevaba los paquetes IS-IS o del IPv6. El campo del protocolo GRE es porqué es deseable que usted hace un túnel el IS-IS y el IPv6 dentro del GRE.

Soporte del túnel GRE CLNS para el IPv4 y los paquetes del IPv6

La tunelización GRE de los paquetes del IPv4 y del IPv6 a través de las redes CLNS permite a los túneles de Cisco CLNS (CTunnels) para interoperar con el equipo de interconexión de redes de los otros vendedores. Esta característica proporciona la conformidad con el RFC 3147.

No soportan a los servicios opcionales GRE definidos en los campos del encabezado, tales como sumas de comprobación, las claves, y secuencia. Cualquier paquete recibido pidiendo tales servicios será caído.

Refiera a la guía de configuración del Cisco IOS ISO CLNS para más información sobre esta característica.

Túneles automáticos del 6to4

Un túnel automático del 6to4 permite que los dominios aislados del IPv6 sean conectados sobre una red del IPv4 con las redes remotas del IPv6. La diferencia fundamental entre los túneles automáticos del 6to4 y los Túneles configurados es manualmente que el túnel no es de punto a punto; es punta a de múltiples puntos. En los túneles automáticos del 6to4, no configuran al Routers en pares porque él trata la infraestructura del IPv4 como link virtual del acceso múltiple sin broadcast (NBMA). El direccionamiento del IPv4 integrado en el direccionamiento del IPv6 se utiliza para encontrar el otro extremo del túnel automático.

Un túnel automático del 6to4 se puede configurar en un Router del borde en una red aislada del IPv6, que crea un túnel sobre una base por paquete a un Router del borde en otra red del IPv6 sobre una infraestructura del IPv4. El destino del túnel es determinado por el direccionamiento del IPv4 del Router del borde extraído del direccionamiento del IPv6 que comienza con el prefijo 2002::/16, donde está 2002 el formato: border-router-IPv4-address:: /48. Después del direccionamiento integrado del IPv4 son 16 bits que se pueden utilizar para numerar las redes dentro del sitio. El Router del borde en cada extremo de un túnel del 6to4 debe soportar las pilas del protocolo del IPv4 y del IPv6. los túneles del 6to4 se configuran entre los Router del borde o entre un Router del borde y un host.

El escenario de instrumentación más simple para los túneles del 6to4 es interconectar los sitios múltiples del IPv6, que tiene por lo menos una conexión a una red compartida del IPv4. Esta red del IPv4 podía ser el Internet global o una estructura básica corporativa. El requisito dominante es que cada sitio tiene a global - direccionamiento único del IPv4; el Cisco IOS Software utiliza este direccionamiento para construir el prefijo único del IPv6 6to4/48 a global -. Como con otros mecanismos del túnel, las entradas apropiadas en un Domain Name System (DNS) que asocian entre los nombres de host y los IP Addresses para ambo IPv4 y IPv6 permiten que las aplicaciones elijan el direccionamiento requerido.

Túneles compatibles con IPv4 automáticos del IPv6

Direccionamientos compatibles con IPv4 del IPv6 del uso compatible con IPv4 automático de los túneles. Los direccionamientos compatibles con IPv4 del IPv6 son las direcciones de Unicast del IPv6 que tienen ceros adentro los 96 bits de alto nivel del direccionamiento, y un direccionamiento del IPv4 en los 32 bits de orden inferior. Pueden ser escritos como 0:0:0:0:0:0:A.B.C.D o:: A.B.C.D, donde el “A.B.C.D” representa el direccionamiento integrado del IPv4.

El destino del túnel es determinado automáticamente por el direccionamiento del IPv4 en los 32 bits de orden inferior de los direccionamientos compatibles con IPv4 del IPv6. El host o el router en cada extremo de un túnel compatible con IPv4 debe soportar las pilas del protocolo del IPv4 y del IPv6. Los túneles compatibles con IPv4 se pueden configurar entre los Router del borde o entre un Router del borde y un host. Usando los túneles compatibles con IPv4 es un método sencillo para crear los túneles para el IPv6 sobre el IPv4, pero la técnica no escala para las Redes grandes.

Túneles de la instrumentación rápida del IPv6

Característica de la instrumentación rápida del IPv6 la 6RD) (es una extensión de la característica del 6to4. La 6RD característica permite que un proveedor de servicio proporcione un servicio del IPv6 del unicast a los clientes sobre su red del IPv4 usando la encapsulación del IPv6 en el IPv4.

Las diferencias principales entre las 6RD y el hacer un túnel del 6to4 son como sigue:

  • el 6RD no requiere los direccionamientos tener un prefijo de 2002::/16; por lo tanto, el prefijo puede ser bloqueo de dirección del proveedor del theservice del propio. Esta función permite que el 6RD dominio operativo esté dentro de la red SP. Desde la perspectiva de los sitios del cliente y de Internet general del IPv6 conectado con una red del proveedor de servicios 6RD-enabled, el servicio del IPv6 proporcionado es equivalente al IPv6 nativo.
  • Los 32 bits del destino del IPv4 no necesitan ser llevados adentro el encabezado de carga útil del IPv6. El destino del IPv4 se obtiene de una combinación de bits en el encabezado de carga útil y la información sobre el router. Además, el direccionamiento del IPv4 no está en una ubicación fija en la encabezado del IPv6 mientras que está en el 6to4.

Túneles del ISATAP

El ISATAP es un mecanismo de tunelización automático del recubrimiento que utiliza la red subyacente del IPv4 como capa de link NBMA para el IPv6. El ISATAP se diseña para transportar los paquetes del IPv6 dentro de un sitio donde no está todavía disponible una infraestructura nativa del IPv6; por ejemplo, cuando los hosts escasos del IPv6 se despliegan para probar. Los túneles del ISATAP permiten que los hosts de la doble pila individual del IPv4 o del IPv6 dentro de un sitio comunique con otros tales hosts en el mismo link virtual, creando básicamente una red del IPv6 usando la infraestructura del IPv4.

El router del ISATAP proporciona el soporte estándar de la configuración de red del aviso del router para el sitio del ISATAP. Esta característica permite que los clientes se configuren automáticamente pues harían si fueron conectados con un Ethernet. Puede también ser configurada para proporcionar el sitio de los de la Conectividad. El ISATAP utiliza un formato de dirección bien definido del IPv6 compuesto de cualquier prefijo del IPv6 del unicast (/64), que puede ser local del link, o global (prefijos incluyendo del 6to4), habilitando el IPv6 que rutea localmente o en Internet. El direccionamiento del IPv4 se codifica en los bits del último 32 del direccionamiento del IPv6, habilitando el Tunelización automático IPv6-in-IPv4.

Aunque el mecanismo de tunelización del ISATAP sea similar a otros mecanismos de tunelización automáticos, tales como 6to4 del IPv6 haciendo un túnel, el ISATAP se diseña para transportar los paquetes del IPv6 dentro de un sitio, pero no entre los sitios.

Aunque el mecanismo de tunelización del ISATAP sea similar a otros mecanismos de tunelización automáticos, tales como 6to4 del IPv6 haciendo un túnel, el ISATAP se diseña para transportar los paquetes del IPv6 dentro de un sitio, no entre los sitios.

El ISATAP utiliza a las direcciones de Unicast que incluyen un prefijo 64-bit del IPv6 y un identificador 64-bit de la interfaz. El identificador de la interfaz se crea en el formato modificado EUI-64 en el cual los primeros 32 bits contienen el valor 000:5EFE para indicar que el direccionamiento es un direccionamiento del ISATAP del IPv6. La tabla abajo describe un formato de dirección del ISATAP.

Cuadro 3Formato de dirección del ISATAP del IPv6

64 bits

32 bits

32 bits

Link local o prefijo global del unicast del IPv6

0000:5EFE

Direccionamiento del IPv4 del link del ISATAP

Tal y como se muestra en de la tabla arriba, un direccionamiento del ISATAP consiste en un prefijo del IPv6 y el identificador de la interfaz del ISATAP. Este identificador de la interfaz incluye el direccionamiento del IPv4 del link subyacente del IPv4. El siguiente ejemplo muestra lo que parecería un direccionamiento real del ISATAP si el prefijo es 2001:DB8:1234:5678::/64 y el direccionamiento integrado del IPv4 es 10.173.129.8. En el direccionamiento del ISATAP, el direccionamiento del IPv4 se expresa en el hexadecimal como 0AAD:8108 (por ejemplo, 2001:DB8:1234:5678:0000:5EFE:0AAD:8108).

Protección del sitio a localizar del IPSec del IPv6 usando la interfaz del túnel virtual

La característica del IPSec del IPv6 proporciona la protección crypto del sitio a localizar del IPv6 de todos los tipos de unicast y de tráfico Multicast del IPv6 usando la encapsulación nativa del IPv6 del IPSec. La característica virtual de la interfaz del túnel del IPSec (VTI) proporciona esta función, usando el IKE como el Management Protocol.

Un IPSec VTI apoya al natural tunelización de IPSec e incluye la mayor parte de las propiedades de una interfaz física. El IPSec VTI palía la necesidad de aplicar las correspondencias de criptografía a las interfaces múltiples y proporciona una interfaz enrutable.

El IPSec VTI permite que el Routers del IPv6 trabaje como gatewayes de seguridad, establezca los túneles IPsec entre el otro Routers del gateway de seguridad, y proporcione crypto protección IPSec para el tráfico de la red interna al transmitir a través de Internet público del IPv6.

Para más información sobre VTIs, vea implementar el IPSec en la Seguridad del IPv6.

Cómo implementar el Tunelización para el IPv6

Configurar los túneles manuales del IPv6

Realice esta tarea de configurar los túneles manuales del IPv6.

Antes de comenzar

Con los túneles manualmente configurados del IPv6, un direccionamiento del IPv6 se configura en una interfaz del túnel, y los direccionamientos manualmente configurados del IPv4 se asignan al origen de túnel y al destino del túnel. El host o el router en cada extremo de un Túnel configurado debe soportar las pilas del protocolo del IPv4 y del IPv6.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número de túnel del túnel de la interfaz

4. direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6

5. origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}

6. IP Address de destino del túnel

7. modo túnel ipv6ip


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número de túnel del túnel de la interfaz


Ejemplo:

Interface tunnel 0 de Router(config)#

 

Especifica una interfaz del túnel y un número, y ingresa al modo de configuración de la interfaz.

 
Paso 4
direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6


Ejemplo:

Router (config-if) # direccionamiento 3ffe:b00:c18:1::3/127 del IPv6

 

Especifica la red del IPv6 asignada a la interfaz y habilita el IPv6 que procesa en la interfaz.

 
Paso 5
origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}


Ejemplo:

Router (config-if) # ethernet0 del origen de túnel

 

Especifica el direccionamiento del IPv4 de la fuente o el tipo y el número de interfaz de origen para la interfaz del túnel.

  • Si se especifica una interfaz, la interfaz se debe configurar con un direccionamiento del IPv4.
 
Paso 6
IP Address de destino del túnel


Ejemplo:

Router (config-if) # destino del túnel 192.168.30.1

 

Especifica el direccionamiento o el nombre de host del IPv4 del destino para la interfaz del túnel.

 
Paso 7
modo túnel ipv6ip


Ejemplo:

Router (config-if) # modo túnel ipv6ip

 

Especifica un túnel manual del IPv6.

Nota    El comando del modo túnel ipv6ip especifica el IPv6 como el protocolo pasajero y IPv4 como la encapsulación y Transport Protocol para el túnel manual del IPv6.
 

Configurar los túneles del IPv6 GRE

Realice esta tarea de configurar un túnel GRE en una red del IPv6. Los túneles GRE se pueden configurar para funcionar con encima una capa de red del IPv6 y para transportar los paquetes del IPv6 en los túneles del IPv6 y los paquetes del IPv4 en los túneles del IPv6.

Antes de comenzar

Cuando se configuran los túneles del IPv6 GRE, los direccionamientos del IPv6 se asignan al origen de túnel y al destino del túnel. La interfaz del túnel puede tener direccionamientos del IPv4 o del IPv6 asignados (esto no se muestra en la tarea). El host o el router en cada extremo de un Túnel configurado debe soportar las pilas del protocolo del IPv4 y del IPv6.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número de túnel del túnel de la interfaz

4. direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6

5. origen de túnel {IP address | ipv6-address | interface-type interface-number}

6. destino del túnel {hostname | IP address | ipv6-address}

7. modo túnel {aurp | caimán | dvmrp | eón | gre| gre de múltiples puntos | IPv6 del gre | [decapsulate-any] del ipip | iptalk | IPv6 | mpls | no.


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número de túnel del túnel de la interfaz


Ejemplo:

Interface tunnel 0 de Router(config)#

 

Especifica una interfaz del túnel y un número, y ingresa al modo de configuración de la interfaz.

 
Paso 4
direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6


Ejemplo:

Router (config-if) # direccionamiento 3ffe:b00:c18:1::3/127 del IPv6

 

Especifica la red del IPv6 asignada a la interfaz y habilita el IPv6 que procesa en la interfaz.

 
Paso 5
origen de túnel {IP address | ipv6-address | interface-type interface-number}


Ejemplo:

Router (config-if) # ethernet0 del origen de túnel

 

Especifica el direccionamiento del IPv4 de la fuente o el tipo y el número de interfaz de origen para la interfaz del túnel.

  • Si se especifica una interfaz, la interfaz se debe configurar con un direccionamiento del IPv4.
 
Paso 6
destino del túnel {hostname | IP address | ipv6-address}


Ejemplo:

Router (config-if) # destino del túnel 2001:DB8:1111:2222::1/64

 

Especifica el direccionamiento o el nombre de host del IPv6 del destino para la interfaz del túnel.

 
Paso 7
modo túnel {aurp | caimán | dvmrp | eón | gre| gre de múltiples puntos | IPv6 del gre | [decapsulate-any] del ipip | iptalk | IPv6 | mpls | no.


Ejemplo:

Router (config-if) # IPv6 del gre del modo túnel

 

Especifica un túnel del IPv6 GRE.

Nota    El gre ipv6command del modo túnel especifica el GRE como el Encapsulation Protocol para el túnel.
 

Configurar los túneles automáticos del 6to4

Realice esta tarea de configurar los túneles automáticos del 6to4.

Antes de comenzar

Con los túneles 6to4, el destino del túnel es determinado por el direccionamiento del IPv4 del Router del borde, que se concatena al prefijo 2002::/16 en el formato 2002: border-router-IPv4-address::/48. El Router del borde en cada extremo de un túnel del 6to4 debe soportar las pilas del protocolo del IPv4 y del IPv6.


Nota


La configuración de solamente un túnel compatible con IPv4 y de un túnel del IPv6 del 6to4 se soporta en un router. Si usted elige configurar a ambos tipos de túnel en el mismo router, recomendamos fuertemente que no comparten el mismo origen de túnel.

La razón que un túnel del 6to4 y un túnel compatible con IPv4 no pueden compartir una interfaz es que ambos ellos son vínculos de acceso de la “punta a de múltiples puntos” NBMA y solamente el origen de túnel se puede utilizar para reordenar los paquetes de una secuencia de paquetes multiplexada en una secuencia del solo paquete para una interfaz entrante. Tan cuando un paquete con un Tipo de protocolo del IPv4 de 41 llega en una interfaz, ese paquete se asocia a una interfaz del túnel del IPv6 basada en el direccionamiento del IPv4. Sin embargo, si el túnel 6to4 y el túnel compatible con IPv4 comparten la misma interfaz de origen, el router no puede determinar la interfaz del túnel del IPv6 a la cual debe asignar el paquete entrante.

Los Túneles configurados del IPv6 pueden compartir manualmente la misma interfaz de origen porque un túnel manual es un link “de punto a punto”, y la fuente del IPv4 y el destino del IPv4 del túnel se definen.

>

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número de túnel del túnel de la interfaz

4. direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6

5. origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}

6. 6to4 del modo túnel ipv6ip

7. salida

8. ruta ipv6-prefix del IPv6/número de túnel del túnel de la longitud del prefijo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número de túnel del túnel de la interfaz


Ejemplo:

Interface tunnel 0 de Router(config)#

 

Especifica una interfaz del túnel y un número, y ingresa al modo de configuración de la interfaz.

 
Paso 4
direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6


Ejemplo:

Router (config-if) # direccionamiento 2002:c0a8:6301:1::1/64 del IPv6

 

Especifica el direccionamiento del IPv6 asignado a la interfaz y habilita el IPv6 que procesa en la interfaz.

  • Los 32 bits que siguen el prefijo inicial de 2002::/16 corresponden a un direccionamiento del IPv4 asignado al origen de túnel.
 
Paso 5
origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}


Ejemplo:

Router (config-if) # ethernet0 del origen de túnel

 

Especifica el tipo y el número de interfaz de origen para la interfaz del túnel.

Nota    El tipo de interfaz y el número especificados en el comando tunnel source deben ser configurados con un direccionamiento del IPv4.
 
Paso 6
6to4 del modo túnel ipv6ip


Ejemplo:

Router (config-if) # 6to4 del modo túnel ipv6ip

 

Especifica un túnel del recubrimiento del IPv6 usando un direccionamiento del 6to4.

 
Paso 7
salida


Ejemplo:

Router(config-if)# exit

 

Sale del modo de configuración de interfaz y devuelve el router al modo de configuración global.

 
Paso 8
ruta ipv6-prefix del IPv6/número de túnel del túnel de la longitud del prefijo


Ejemplo:



Ejemplo:

Tunnel0 de la ruta 2002::/16 del IPv6 de Router(config)#

 

Configura una Static ruta para el prefijo 2002::/16 del 6to4 del IPv6 a la interfaz del túnel especificado.

Nota    Al configurar un 6to4 cubrió el túnel, usted debe configurar una Static ruta para el prefijo 2002::/16 del 6to4 del IPv6 a la interfaz del túnel del 6to4.
  • El número de túnel especificado en el comando route del IPv6 debe ser el mismo número de túnel especificado en el tunnelcommand de la interfaz.
 

Configurar los túneles compatibles con IPv4 del IPv6

Realice esta tarea de configurar los túneles compatibles con IPv4 del IPv6.

Antes de comenzar

Con un túnel compatible con IPv4, el destino del túnel es determinado automáticamente por el direccionamiento del IPv4 en los 32 bits de orden inferior de los direccionamientos compatibles con IPv4 del IPv6. El host o el router en cada extremo de un túnel compatible con IPv4 debe soportar las pilas del protocolo del IPv4 y del IPv6.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número de túnel del túnel de la interfaz

4. origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}

5. auto-túnel del modo túnel ipv6ip


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número de túnel del túnel de la interfaz


Ejemplo:

Interface tunnel 0 de Router(config)#

 

Especifica una interfaz del túnel y un número, y ingresa al modo de configuración de la interfaz.

 
Paso 4
origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}


Ejemplo:

Router (config-if) # ethernet0 del origen de túnel

 

Especifica el tipo y el número de interfaz de origen para la interfaz del túnel.

Nota    Configuran al tipo de interfaz y el número especificados en el comando tunnel source con un direccionamiento del IPv4 solamente.
 
Paso 5
auto-túnel del modo túnel ipv6ip


Ejemplo:

Router (config-if) # auto-túnel del modo túnel ipv6ip

 

Especifica un túnel compatible con IPv4 usando un direccionamiento compatible con IPv4 del IPv6.

 

Configurar los 6RD túneles

Realice esta tarea de configurar los 6RD túneles.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número de túnel del túnel de la interfaz

4. origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}

5. modo túnel ipv6ip [6rd | 6to4 | auto-túnel | isatap]

6. haga un túnel el 6o prefijo ipv6-prefix/longitud del prefijo

7. haga un túnel 6o ipv4 {longitud} de la longitud del prefijo {longitud de la sufijo-longitud


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número de túnel del túnel de la interfaz


Ejemplo:

Túnel 1 de la interfaz de Router(config)#

 

Especifica una interfaz del túnel y un número, y ingresa al modo de configuración de la interfaz.

 
Paso 4
origen de túnel {IP address| Número de interfaz del ype de la interfaz-t}


Ejemplo:

Router (config-if) # origen de túnel Ethernet2/0

 

Especifica el tipo y el número de interfaz de origen para la interfaz del túnel.

 
Paso 5
modo túnel ipv6ip [6rd | 6to4 | auto-túnel | isatap]


Ejemplo:

Router (config-if) # modo túnel ipv6ip 6o

 

Configura una interfaz del túnel estática del IPv6.

 
Paso 6
haga un túnel el 6o prefijo ipv6-prefix/longitud del prefijo


Ejemplo:

Router (config-if) # 6o prefijo 2001:B000::/32 del túnel

 

Especifica el prefijo común del IPv6 en túneles del rapid del IPv6 los 6RD.

 
Paso 7
haga un túnel 6o ipv4 {longitud} de la longitud del prefijo {longitud de la sufijo-longitud


Ejemplo:

Router (config-if) # 6o ipv4 sufijo 8 de la longitud del prefijo del túnel 16

 

Especifica la longitud de la longitud del prefijo y del sufijo de la dirección del transporte del IPv4 común a todos los 6RD Router en un dominio.

 

Configurar los túneles del ISATAP

Realice esta tarea de configurar los túneles del ISATAP.

Antes de comenzar

El comando tunnel source usado en la configuración de un túnel del ISATAP debe señalar a una interfaz con un direccionamiento del IPv4 configurado. El direccionamiento y el prefijo (o los prefijos) del IPv6 del ISATAP des divulgación se configuran en cuanto a una interfaz nativa del IPv6. La interfaz del túnel del IPv6 se debe configurar con un direccionamiento modificado EUI-64 porque los bits del último 32 en el identificador de la interfaz se construyen usando el direccionamiento de origen de túnel del IPv4.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número de túnel del túnel de la interfaz

4. direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6

5. ningún ra nd del IPv6 suprime

6. origen de túnel {IP address| interface-type interface-number}

7. isatap del modo túnel ipv6ip


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número de túnel del túnel de la interfaz


Ejemplo:

Túnel 1 de la interfaz de Router(config)#

 

Especifica una interfaz del túnel y un número, y ingresa al modo de configuración de la interfaz.

 
Paso 4
direccionamiento ipv6-prefix/longitud del prefijo [eui-64] del IPv6


Ejemplo:

Router (config-if) # direccionamiento 2001:DB8:6301::/64 eui-64 del IPv6

 

Especifica el direccionamiento del IPv6 asignado a la interfaz y habilita el IPv6 que procesa en la interfaz.

Nota    Refiera a la conectividad básica que configura para el módulo del IPv6 para más información sobre configurar los direccionamientos del IPv6.
 
Paso 5
ningún ra nd del IPv6 suprime


Ejemplo:

El router (config-if) # ningún ra nd del IPv6 suprime

 

El envío de los avisos del router del IPv6 se inhabilita por abandono en las interfaces del túnel. Este comando vuelve a permitir el envío de los avisos del router del IPv6 para permitir la autoconfiguración del cliente.

 
Paso 6
origen de túnel {IP address| interface-type interface-number}


Ejemplo:

Router (config-if) # Ethernetes 1/0/1 del origen de túnel

 

Especifica el tipo y el número de interfaz de origen para la interfaz del túnel.

Nota    El tipo de interfaz y el número especificados en el comando tunnel source deben ser configurados con un direccionamiento del IPv4.
 
Paso 7
isatap del modo túnel ipv6ip


Ejemplo:

Router (config-if) # isatap del modo túnel ipv6ip

 

Especifica un túnel del recubrimiento del IPv6 usando un direccionamiento del ISATAP.

 

Verificar la configuración del túnel y la operación del IPv6

Realice esta tarea de verificar la configuración del túnel y la operación del IPv6.

PASOS SUMARIOS

1. permiso

2. [accounting] del show interfaces tunnel number

3. destino del [protocol] del ping

4. muestre el [address[mask] de la ruta de IP]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
show interfaces tunnel number [contabilidad]


Ejemplo:

Show interfaces tunnel 0 del Router-

 

Información de interfaz del túnel (opcional) de las visualizaciones.

  • Utilice el argumento del número al mostrar información para un túnel especificado.
 
Paso 3
destino del [protocol] del ping


Ejemplo:

Ping 10.0.0.1 del Router-

 

Conectividad de red básica (opcional) de las diagnosis.

 
Paso 4
show ip route [address [mask


Ejemplo:

Ruta de IP 10.0.0.2 de la demostración del Router-

 

(Opcional) Muestra el estado actual de la tabla de ruteo.

Nota    Solamente el sintaxis relevante para esta tarea se muestra.
 

Ejemplos

Salida de muestra para marcar el direccionamiento del punto final remoto del comando ping

Este ejemplo es un ejemplo genérico conveniente para los Túneles configurados del IPv6 manualmente y el IPv6 sobre los túneles GRE del IPv4. En el ejemplo, configuran a dos Routers para ser Puntos finales de un túnel. El router A tiene interfaz de Ethernet 0/0 configurada como interfaz del túnel 0 con un direccionamiento del IPv4 de 10.0.0.1 y un prefijo del IPv6 de 2001:DB8:1111:2222::1/64. El router B tiene interfaz de Ethernet 0/0 configurada como interfaz del túnel 1 con un direccionamiento del IPv4 de 10.0.0.2 y un prefijo del IPv6 de 2001:DB8:1111:2222::2/64. Para verificar que las direcciones de origen y de destino del túnel están configuradas, utilice el comando show interfaces tunnel en el router A.

RouterA# show interfaces tunnel 0
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 10.0.0.1 (Ethernet0/0), destination 10.0.0.2, fastswitch TTL 255
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Tunnel TTL 255
  Checksumming of packets disabled,  fast tunneling enabled
  Last input 00:00:14, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue :0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4 packets input, 352 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     8 packets output, 704 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
Salida de muestra del comando ping

Para marcar que el punto final local es configurado y de trabajo, utilice el comando ping en el router A:

RouterA# ping 2001:DB8:1111:2222::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:1111:2222::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms
Salida de muestra del comando show ip route

Para marcar que una ruta existe al direccionamiento del punto final remoto, utilice el comando show ip route:

RouterA# show ip route 10.0.0.2
Routing entry for 10.0.0.0/24
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Routing Descriptor Blocks:
  * directly connected, via Ethernet0/0
      Route metric is 0, traffic share count is 1
Salida de muestra del comando ping

Para verificar que la dirección del extremo remoto es accesible, utilice el comando ping en el router A.


Nota


El direccionamiento del punto final remoto no puede ser accesible usando el comando ping debido a la filtración, pero el tráfico de túnel puede todavía alcanzar su destino.
RouterA# ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/28 ms

Para verificar que el extremo remoto del túnel IPv6 es accesible, utilice el comando del ping otra vez en el router A. La misma nota sobre el filtrado también se aplica a este ejemplo.

RouterA# ping 1::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/20/20 ms

Estos pasos se pueden relanzar en el otro punto final del túnel.

Ejemplos de configuración para implementar el Tunelización para el IPv6

Ejemplo que configura los túneles manuales del IPv6

El siguiente ejemplo configura un túnel manual del IPv6 entre el router A y el router B. En el ejemplo, la interfaz del túnel 0 para el router A y el router B se configura manualmente con un direccionamiento global del IPv6. Los direccionamientos de origen y destino del túnel se configuran también manualmente.

Configuración del router A

interface ethernet 0
 ip address 192.168.99.1 255.255.255.0
interface tunnel 0
 ipv6 address 3ffe:b00:c18:1::3/127
 tunnel source ethernet 0
 tunnel destination 192.168.30.1
 tunnel mode ipv6ip

Configuración del Router B

interface ethernet 0
 ip address 192.168.30.1 255.255.255.0
interface tunnel 0
 ipv6 address 3ffe:b00:c18:1::2/127
 tunnel source ethernet 0
 tunnel destination 192.168.99.1
 tunnel mode ipv6ip

Ejemplo que configura los túneles GRE

Túnel GRE del ejemplo que ejecuta el tráfico IS-IS y del IPv6

El siguiente ejemplo configura un túnel GRE tráfico IS-IS que se ejecuta y del IPv6 entre el router A y el router B:

Configuración del router A
ipv6 unicast-routing
clns routing
!
interface tunnel 0
 no ip address
 ipv6 address 3ffe:b00:c18:1::3/127
 ipv6 router isis 
 tunnel source Ethernet 0/0
 tunnel destination 2001:DB8:1111:2222::1/64
 tunnel mode gre ipv6
!
interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.0
!
router isis 
 net 49.0000.0000.000a.00
Configuración del Router B
ipv6 unicast-routing
clns routing
!
interface tunnel 0
 no ip address
 ipv6 address 3ffe:b00:c18:1::2/127
 ipv6 router isis 
 tunnel source Ethernet 0/0
 tunnel destination 2001:DB8:1111:2222::2/64
 tunnel mode gre ipv6
!
interface Ethernet0/0
 ip address 10.0.0.2 255.255.255.0
!
router isis 
 net 49.0000.0000.000b.00
 address-family ipv6
 redistribute static
 exit-address-family

Dirección de destino del túnel del ejemplo para el túnel del IPv6

Las demostraciones del siguiente ejemplo cómo configurar a la dirección de destino del túnel para la tunelización GRE de los paquetes del IPv6:

Router(config
)
# interface Tunnel0
Router(config
-if)
# no ip address
Router(config
-if)
# ipv6 router isis 
Router(config
-if)
# tunnel source Ethernet 0/0
Router(config
-if)
# tunnel destination 2001:DB8:1111:2222::1/64
Router(config
-if)
# tunnel mode gre ipv6
Router(config
-if)
# exit
!
Router(config
)
# interface Ethernet0/0
Router(config
-if)
# ip address 10.0.0.1 255.255.255.0
Router(config
-if)
# exit
!
Router(config
)
# ipv6 unicast-routing
Router(config
)
# router isis
 
Router(config
)
# net 49.0000.0000.000a.00

Ejemplo que configura CTunnels en el modo GRE para llevar los paquetes del IPv6 en el CLNS

El siguiente ejemplo configura un GRE CTunnel tráfico IS-IS que se ejecuta y del IPv6 entre el router A y el router B en una red CLNS. El comando del gre del modo del ctunnel permite el hacer un túnel entre Cisco y los dispositivos de interconexión de redes de tercera persona y lleva el tráfico del IPv4 y del IPv6.

El comando del gre del modo del ctunnel proporciona un método de hacer un túnel obediente con el RFC 3147 y debe permitir el hacer un túnel entre el equipo de Cisco y los dispositivos de interconexión de redes de tercera persona.

Router A

ipv6 unicast-routing 
clns routing 
interface ctunnel 102 
 ipv6 address 2001:DB8:1111:2222::1/64
 ctunnel destination 49.0001.2222.2222.2222.00 
 ctunnel mode gre
interface Ethernet0/1 
 clns router isis 
router isis 
 net 49.0001.1111.1111.1111.00 

Router B

ipv6 unicast-routing 
clns routing 
interface ctunnel 201 
 ipv6 address 2001:DB8:1111:2222::2/64 
 ctunnel destination 49.0001.1111.1111.1111.00 
 ctunnel mode gre
interface Ethernet0/1 
 clns router isis 
router isis 
 net 49.0001.2222.2222.2222.00 

Para apagar el modo GRE y restaurar CTunnel a la encapsulación Cisco predeterminada, que rutea solamente entre extremos en equipos Cisco, utilice el comando no ctunnel mode o el comando ctunnel mode cisco. El siguiente ejemplo muestra la misma configuración modificada para transportar solamente el tráfico del IPv4.

Ejemplo que configura los túneles del 6to4

El siguiente ejemplo configura un túnel del 6to4 en un Router del borde en una red aislada del IPv6. El direccionamiento del IPv4 es 192.168.99.1, que traduce al IPv6 el prefijo de 2002:c0a8:6301::/48. El prefijo del IPv6 es subnetted en 2002:c0a8:6301::/64 para la interfaz del túnel: 2002:c0a8:6301:1::/64 para la primera red del IPv6, y 2002:c0a8:6301:2::/64 para la segunda red del IPv6. La Static ruta se asegura de que cualquier otro tráfico para el prefijo 2002::/16 del IPv6 esté dirigido a la interfaz del túnel 0 para el Tunelización automático.

interface Ethernet0
 description IPv4 uplink
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description IPv6 local network 1
 ipv6 address 2002:c0a8:6301:1::1/64 
!
interface Ethernet2
 description IPv6 local network 2
 ipv6 address 2002:c0a8:6301:2::1/64 
!
interface Tunnel0
 description IPv6 uplink
 no ip address
 ipv6 address 2002:c0a8:6301::1/64 
 tunnel source Ethernet 0
 tunnel mode ipv6ip 6to4
!
ipv6 route 2002::/16 tunnel 0

Ejemplo que configura los túneles compatibles con IPv4 del IPv6

El siguiente ejemplo configura un túnel compatible con IPv4 del IPv6 que permita que el Border Gateway Protocol (BGP) se ejecute entre vario Routers sin tener que configurar una malla de los túneles manuales. Cada router tiene un solo túnel compatible con IPv4, y las sesiones de BGP múltiples pueden funcionar con encima cada túnel, uno a cada vecino. La interfaz de Ethernet 0 se utiliza como el origen de túnel. El destino del túnel es determinado automáticamente por el direccionamiento del IPv4 en los 32 bits de orden inferior de un direccionamiento compatible con IPv4 del IPv6. Específicamente, el prefijo 0:0:0:0:0:0 del IPv6 se concatena a un direccionamiento del IPv4 (en el formato 0:0:0:0:0:0:A.B.C.D o:: A.B.C.D) para crear el direccionamiento compatible con IPv4 del IPv6. La interfaz de Ethernet 0 se configura con un direccionamiento global del IPv6 y un direccionamiento del IPv4 (la interfaz soporta las pilas del protocolo del IPv6 y del IPv4).

El Multiprotocol BGP se utiliza en el ejemplo para intercambiar la información de alcance del IPv6 por el par 10.67.0.2. El direccionamiento del IPv4 de la interfaz de Ethernet 0 se utiliza en los 32 bits de orden inferior de un direccionamiento compatible con IPv4 del IPv6 y también se utiliza como el atributo del salto siguiente. Usando un direccionamiento compatible con IPv4 del IPv6 para el vecino BGP permite que transporten a la sesión de BGP del IPv6 automáticamente sobre un túnel compatible con IPv4.

interface tunnel 0
 tunnel source Ethernet 0
 tunnel mode ipv6ip auto-tunnel
interface ethernet 0
 ip address 10.27.0.1 255.255.255.0
 ipv6 address 3000:2222::1/64
router bgp 65000
 no synchronization
 no bgp default ipv4-unicast
neighbor ::10.67.0.2 remote-as 65002
address-family ipv6
 neighbor ::10.67.0.2 activate
 neighbor ::10.67.0.2 next-hop-self
 network 2001:2222:d00d:b10b::/64

Ejemplo que configura los 6RD túneles

El siguiente ejemplo muestra la configuración corriente de un 6RD túnel y la salida correspondiente comando del túnel de la demostración del 6o:

interface Tunnel1 
 ipv6 address 2001:B000:100::1/32 
 tunnel source Ethernet2/1 
 tunnel mode ipv6ip 6rd
 tunnel 6rd prefix 2001:B000::/32
 tunnel 6rd ipv4 prefix-len 16 suffix-len 8 
end
Router# show tunnel 6rd tunnel 1 
Interface Tunnel1: 
  Tunnel Source: 10.1.1.1 
  6RD: Operational, V6 Prefix: 2001:B000::/32 
       V4 Common Prefix Length: 16, Value: 10.1.0.0 
       V4 Common Suffix Length: 8, Value: 0.0.0.1 

Ejemplo que configura los túneles del ISATAP

El siguiente ejemplo muestra el origen de túnel definido en el ethernet0 y el comando tunnel mode usado para configurar el túnel del ISATAP. Los avisos del router se habilitan para permitir la autoconfiguración del cliente.

ipv6 unicast-routing
interface tunnel 1
 tunnel source ethernet 0
 tunnel mode ipv6ip isatap
 ipv6 address 2001:DB8::/64 eui-64
 no ipv6 nd ra suppress
 exit

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

IPSec VTIs

Implementar el IPSec en la Seguridad del IPv6

Lista de la característica admitida del IPv6

“Comienzo aquí: Específicos de la versión de Cisco IOS Software para las características del IPv6,” guía de configuración del IPv6 del Cisco IOS

Túneles CLNS

Guía de configuración del Cisco IOS ISO CLNS

Comandos del IPv6: sintaxis, modo de comando, valores por defecto, Pautas para el uso, y ejemplos del comando complete

Referencia de comandos del IPv6 del Cisco IOS

Estándares

Estándar

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Ninguno

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 2473

Tunelización genérico del paquete en la especificación del IPv6

RFC 2893

Mecanismos de transición para los hosts y el Routers del IPv6

RFC 3056

Conexión de los dominios del IPv6 vía las nubes del IPv4

RFC 4214

Túnel automático del Intra-sitio que dirige el protocolo (ISATAP)

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/support/index.html

Información de la característica para implementar el Tunelización para el IPv6

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Cuadro 4Información de la característica para implementar el Tunelización para el IPv6

Nombre de la función

Versiones

Información sobre la Función

Transferencia CEFv6 para los túneles del 6to4

12.2(28)SB 12.2(25)SG 12.2(33)SRA 12.2(18)SXE 12.2(12)T 12,4 15.0(1)S

El Cisco Express Forwarding Switching se puede utilizar para los Túneles configurados del IPv6 manualmente.

Instrumentación rápida del IPv6 del IPv6 Tunneling--6RD

15.1(3)T

La 6RD característica permite que un proveedor de servicio proporcione un servicio del IPv6 del unicast a los clientes sobre su red del IPv4 usando la encapsulación del IPv6 en el IPv4.

El hacer un túnel del IPv6--Túneles automáticos del 6to4

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA12.2(18)SXE 12.2(2)T 12,3 12.3(2)T 12,4 12.4(2)T 15.0(1)S

Un túnel automático del 6to4 permite que los dominios aislados del IPv6 sean conectados sobre una red del IPv4 con las redes remotas del IPv6.

El hacer un túnel del IPv6--Túneles compatibles con IPv4 automáticos

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(18)SXE 12.2(2)T 12,3 12.3(2)T 12,4 12.4(2)T 15.0(1)S

Direccionamientos compatibles con IPv4 del IPv6 del uso compatible con IPv4 automático de los túneles.

Túneles GRE del IPv6 Tunneling--IPv6 en las redes CLNS

12.2(25)S 12.2(28)SB 12.2(33)SRA 12.3(7)T 12,4 12.4(2)T

La tunelización GRE de los paquetes del IPv4 y del IPv6 a través de las redes CLNS permite a Cisco CTunnels para interoperar con el equipo de interconexión de redes de los otros vendedores.

El hacer un túnel del IPv6--IP sobre los túneles GRE del IPv6

12.2(30)S 12.3(7)T 12,4 12.4(2)T

Los túneles GRE son links entre dos puntas, con un túnel diferente para cada link.

IPv6 Tunneling--IPv4 sobre los túneles del IPv6

12.2(30)S 12.2(33)SRA 12.3(7)T 12,4 12.4(2)T 15.0(1)S

El IPv6 soporta esta característica

IPv6 Tunneling--IPv6 sobre los túneles GRE del IPv4

12.0(22)S1 12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(17a)SX1 12.2(4)T 12,3 12.3(2)T 12,4 12.4(2)T 15.0(1)S

Los túneles GRE son links entre dos puntas, con un túnel diferente para cada link. Los túneles no se atan a un pasajero específico o al Transport Protocol, sino en este caso llevan el IPv6 como el protocolo pasajero con el GRE como el protocolo de la portadora y IPv4 o el IPv6 como el Transport Protocol.

IPv6 Tunneling--IPv6 sobre los túneles del IPv6

12.2(30)S 12.3(7)T 12,4 12.4(2)T

El IPv6 soporta esta característica

IPv6 Tunneling--IPv6 sobre el UTI usando un linecard2 del túnel

12.0(23)S

El IPv6 soporta esta característica.

El hacer un túnel del IPv6--Soporte del túnel del ISATAP

12.2(14)S 12.2(28)SB 12.2(33)SRA12.2(17a)SX112.2(15)T 12,3 12.3(2)T 12,4 12.4(2)T 15.0(1)S

El ISATAP es un mecanismo de tunelización automático del recubrimiento que utiliza la red subyacente del IPv4 como capa de link NBMA para el IPv6.

El hacer un túnel del IPv6--IPv6 manualmente configurado sobre los túneles del IPv4

12.0(23)S3 12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(2)T 12,3 12.3(2)T 12,4 12.4(2)T 15.0(1)S

Un Túnel configurado es manualmente equivalente a un enlace permanente entre dos dominios del IPv6 sobre una estructura básica del IPv4.

túneles del mGRE sobre el IPv6

15.2(1)T

los túneles del mGRE se configuran para habilitar los proveedores de servicio despliegan el IPv6 en su infraestructura esencial.

1 IPv6 sobre los túneles GRE del IPv4 no se soporta en el GSR.
La característica 2 se soporta en el GSR solamente.
3 en el Cisco IOS Release 12.0(23)S, el GSR proporciona el Rendimiento mejorado para los Túneles configurados del IPv6 manualmente procesando el tráfico en el linecard.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

1 IPv6 sobre los túneles GRE del IPv4 no se soporta en el GSR.
La característica 2 se soporta en el GSR solamente.
3 en el Cisco IOS Release 12.0(23)S, el GSR proporciona el Rendimiento mejorado para los Túneles configurados del IPv6 manualmente procesando el tráfico en el linecard.
Cisco Systems, Inc. del © 2012 todos los derechos reservados.