Routing IP: Guía de configuración BGP, Cisco IOS Release 12.2SR
Per-VRF Assignment of BGP Router ID
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 300 KB | Inglés (8 Noviembre 2011) | Comentarios

Per-VRF Assignment of BGP Router ID

Última actualización: De abril el 13 de 2012

La función Per-VRF Assignment of BGP Router ID inserta la capacidad de tener peering de VRF a VRF en un Border Gateway Protocol (BGP) en el mismo router. BGP se ha diseñado para rechazar una sesión consigo mismo debido a la verificación del ID del router. La función de asignación por VRF permite un ID de router separado para cada VRF usando una nueva palabra clave en el comando existente del bgp router-id. El ID de router se puede configurar manualmente para cada VRF o se puede asignar automáticamente globalmente bajo el modo de configuración de la familia de direcciones o para cada VRF.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Prerrequisitos de la Asignación por VRF del ID de Router BGP

Antes de que usted configure esta característica, el Cisco Express Forwarding (CEF) o el CEF distribuido (dCEF) se debe habilitar en la red, y el peering básico BGP se asume para ejecutarse en la red.

Información sobre la Asignación por VRF de ID de router BGP

Id. del router BGP

El identificador del router BGP (ID) es un campo 4-byte que se fija a la dirección IP más alta en el router. Consideran a las direcciones del Loopback Interface antes de que los direccionamientos de la interfaz física porque las interfaces del loopback son más estables que las interfaces físicas. El Id. del router BGP se utiliza en el algoritmo BGP para determinar el mejor trayecto a un destino donde está la preferencia para el router BGP con el Router ID más bajo. Es posible configurar manualmente el Id. del router BGP usando el comando bgp router-id de influenciar el algoritmo del mejor trayecto.

Asignación de ID de Router por VRF

En el Cisco IOS Release 12.2(31)SB2, 12.2(33)SRA, 12.2(33)SXH, 12.4(20)T, y posterior las versiones, soporte para configurar el router separado ID para cada caso el rutear/de la expedición del Red privada virtual (VPN) (VRF) fue introducido. La función Per-VRF Assignment of BGP Router ID inserta la capacidad de tener peering de VRF a VRF en un Border Gateway Protocol (BGP) en el mismo router. BGP se ha diseñado para rechazar una sesión consigo mismo debido a la verificación del ID del router. La función de asignación por VRF permite un ID de router separado para cada VRF usando una nueva palabra clave en el comando existente del bgp router-id. El ID de router se puede configurar manualmente para cada VRF o se puede asignar automáticamente globalmente bajo el modo de configuración de la familia de direcciones o para cada VRF.

Discriminador de Rutas

Un Route Distinguisher (RD) crea la encaminamiento y las tablas de reenvío y especifica el distinguisher de la ruta predeterminado para un VPN. El RD se añade al principio de un prefijo de IPv4 para cambiarlo por un prefijo de VPN-IPv4 globalmente único. Un RD se puede componer de dos maneras: con un número autónomo del sistema y un número arbitrario o con una dirección IP y un número arbitrario.

Puede ingresar un RD en cualquiera de estos formatos:

  • Ingresar un número del sistema autónomo de 16 bits, dos puntos y un número de 32 bits. Por ejemplo:

45000:3

  • Ingrese una dirección IP de 32 bits, dos puntos y un número de 16 bits. Por ejemplo:

192.168.10.15:1

Cómo Configurar Per-VRF Assignment of BGP Router ID

Hay dos formas principales de configurar un Id. del router BGP para cada uno VRF separado. Para configurar un Id. del router BGP por-VRF manualmente, usted debe realizar las primeras tres tareas enumeradas abajo. Para asignar automáticamente un Id. del router BGP a cada VRF, realice la primera tarea y la cuarta tarea.

Configuración de Instancias de VRF

Realice esta tarea de configurar los casos VRF que se utilizarán con las tareas de la asignación por-VRF. En esta tarea, un caso VRF nombrado los vrf_trans se crea. Para hacer el VRF funcional, se crea un Route Distinguisher. Cuando se crea el Route Distinguisher, la encaminamiento y las tablas de reenvío se crean para el caso VRF nombrado los vrf_trans.

Antes de comenzar

Para esta tarea se supone que tiene CEF o dCEF habilitados.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. IP VRF vrf-name

4. Route Distinguisher rd

5. ruta-blanco [importación | ambos] ruta-blanco-extensión-comunidad

6. ruta-blanco [exportación | ambos] ruta-blanco-extensión-comunidad

7. salida

8. Relance el paso 3 al paso 7 para que cada VRF sea definido.


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
IP VRF vrf-name


Ejemplo:

Vrf_trans de Router(config)# IP VRF

 

Define un caso VRF e ingresa en el modo de la configuración de VRF.

 
Paso 4
Route Distinguisher rd


Ejemplo:

Router (config-VRF) # rd 45000:2

 

Crea tablas de ruteo y reenvío para un VRF y especifica el RD predeterminado para una VPN.

  • Utiliza el argumento route-distinguisher para especificar el RD predeterminado para una VPN. Hay dos le formata puede utilizar para especificar un RD. Para más detalles, vea la sección del “Route Distinguisher”.
  • En este ejemplo, el RD utiliza un número del sistema autónomo con el número 2 después de los dos puntos.
 
Paso 5
ruta-blanco [importación | ambos] ruta-blanco-extensión-comunidad


Ejemplo:

Router (config-VRF) # importación 55000:5 de la ruta-blanco

 

Crea a una comunidad ampliada de comando route-target para un VRF.

  • Utilice la palabra clave import para importar la información de ruteo de la comunidad ampliada de VPN de destino.
  • Utilice la palabra clave both para importar información de ruteo desde la comunidad ampliada de la VPN de destino y para exportarla a ella.
  • Utilice el argumento route-target-ext-community para especificar la comunidad ampliada de la VPN.
 
Paso 6
ruta-blanco [exportación | ambos] ruta-blanco-extensión-comunidad


Ejemplo:

Router (config-VRF) # exportación 55000:1 de la ruta-blanco

 

Crea a una comunidad ampliada de comando route-target para un VRF.

  • Utilice la palabra clave export para exportar la información de ruteo a la comunidad ampliada de la VPN de destino.
  • Utilice la palabra clave both para importar información de ruteo desde la comunidad ampliada de la VPN de destino y para exportarla a ella.
  • Utilice el argumento route-target-ext-community para especificar la comunidad ampliada de la VPN.
 
Paso 7
salida


Ejemplo:

Router (config-VRF) # salida

 

Modo y devoluciones de la configuración de VRF de las salidas al modo de configuración global.

 
Paso 8
Relance el paso 3 al paso 7 para que cada VRF sea definido.  

--

 

Asociación de las Instancias VRF con las Interfaces

Realice esta tarea de asociar los casos VRF a las interfaces que se utilizarán con las tareas de la asignación por-VRF. En esta tarea, un caso VRF nombrado los vrf_trans se asocia a una interfaz serial.

Anote los IP Addresses para cualquier interfaz a la cual usted quiera asociar un caso VRF porque el comando ip vrf forwarding quita la dirección IP. El paso 8 permite que usted configure de nuevo la dirección IP.

Antes de comenzar
  • Para esta tarea se supone que tiene CEF o dCEF habilitados.
  • Esta tarea asume que los casos VRF se han configurado en los casos VRF que configuraban.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. [secondary] de la máscara del IP address del IP Address

5. salida

6. número del tipo de la interfaz

7. IP VRF vrf-name de envío [vrf-name2] rio abajo

8. [secondary] de la máscara del IP address del IP Address

9. Relance el paso 5 al paso 8 para que cada VRF sea asociado a una interfaz.

10. extremo

11 muestre IP VRF [descripción | detalle | interfaces | [vrf-name] identificación]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Loopback0 de la interfaz de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

  • En este ejemplo, se configura la interfaz Loopback 0.
 
Paso 4
[secondary] de la máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 172.16.1.1 255.255.255.255

 

Configura una dirección IP.

  • En este ejemplo, se configura la interfaz Loopback con una dirección IP de 172.16.1.1.
 
Paso 5
salida


Ejemplo:

Router(config-if)# exit

 

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

 
Paso 6
número del tipo de la interfaz


Ejemplo:

Interfaz serial2/0 de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

  • En este ejemplo, se configura la interfaz serial 2/0.
 
Paso 7
IP VRF envío del vrf-name [vrf-name2] rio abajo


Ejemplo:

Router (config-if) # IP VRF remitiendo los vrf_trans

 

Asocia un VRF a una interfaz o subinterfaz.

  • En este ejemplo, los vrf_trans nombrados VRF se asocian a la interfaz serial 2/0.
Nota    La ejecución de este comando en una interfaz quita la dirección IP. La dirección IP se debe configurar de nuevo.
 
Paso 8
[secondary] de la máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 192.168.4.1 255.255.255.0

 

Configura una dirección IP.

  • En este ejemplo, la interfaz serial 2/0 se configura con una dirección IP de 192.168.4.1.
 
Paso 9
Repita los pasos del 5 al 8 para cada VRF que se va a asociar a una interfaz.  

--

 
Paso 10
Finalizar


Ejemplo:

Router(config-if)#end

 

Salidas modo de configuración de la interfaz y devoluciones al modo EXEC privilegiado.

 
Paso 11
muestre IP VRF [descripción | detalle | interfaces | [vrf-name] identificación]

Ejemplo:

Show ip vrf interfaces del Router-

 

(Opcional) visualiza el conjunto de los VRF definidos y de las interfaces asociadas.

  • En este ejemplo, la salida de este comando muestra los VRF se han creado que y sus interfaces asociadas.
 

Ejemplos

La demostración s del producto siguiente que dos casos VRF nombraron los vrf_trans y los vrf_users fue configurada en dos interfaces seriales.

Router# show ip vrf interfaces
Interface         IP-Address      VRF                      Protocol
Serial2           192.168.4.1     vrf_trans                up      
Serial3           192.168.5.1     vrf_user                 up 

Configuración Manual de un ID de Router BGP por VRF

Realice esta tarea de configurar manualmente un Id. del router BGP para cada VRF. En esta tarea, se muestran varias configuraciones de la familia del direccionamiento y el Router ID se configura en el modo de la familia del direccionamiento del IPv4 para un caso VRF. El paso 22 le muestra cómo relanzar ciertos pasos para permitir la configuración de más de un VRF en el mismo router.

Antes de comenzar

Esta tarea asume que usted ha creado los casos VRF y los ha asociado previamente a las interfaces. Para más detalles, vea los casos VRF que configuran y los casos de asociación VRF con las interfaces.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. autonomous-system-number BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. log-neighbor-changes BGP

6. vecino {IP address| par-grupo-nombre} telecontrol-como el autonomous-system-number

7. vecino {IP address| interface-type interface-number de la actualización-fuente del par-grupo-nombre}

8. direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}

9. vecino {IP address| el par-grupo-nombre} activa

10. vecino {IP address| enviar-comunidad del par-grupo-nombre } {ambas| estándar| extendido}

11 salida-direccionamiento-familia

12.    direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}

13.    redistribuya conectado

14.    neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number

15.    neighbor ip-address local-como el [no-prepend [replace-as [dual-as] del autonomous-system-number]]

16.    neighbor {ip-address| [ttl] del ebgp-multihop del par-grupo-nombre}

17.    neighbor {ip-address| el par-grupo-nombre} activa

18.    neighbor ip-address allowas-en [number]

19.    ningún automóvil summary

20.    ninguna sincronización

21.    bgp router-id {IP address| auto-asigne}

22.    Repita del paso 11 al paso 21 para configurar otra instancia de VRF.

23.    Finalizar

24.    muestre BGP vpnv4 {todo del IP| Route Distinguisher rd| vrf vrf-name}


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
autonomous-system-number BGP del router


Ejemplo:

BGP 45000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita la familia de direcciones unicast IPv4 para el proceso de ruteo BGP.

Nota    La información de ruteo para la familia de la dirección de Unicast del IPv4 se hace publicidad por abandono para cada sesión de la encaminamiento BGP configurada con el vecino telecontrol-como el comando router configuration a menos que usted no configure el ningún comando configuration del valor por defecto ipv4-unicastrouter BGP antes de configurar el comando neighbor remote-as. Las configuraciones vecinas existentes no se ven afectadas.
 
Paso 5
log-neighbor-changes BGP


Ejemplo:

Router (config-router) # log-neighbor-changes BGP

 

Habilita el registro de reinicios del vecino BGP.

 
Paso 6
neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router) # vecino 192.168.1.1 telecontrol-como 45000

 

Añade la dirección IP o el nombre de grupo de peers del vecino al sistema autónomo especificado a la tabla de vecinos BGP multiprotocolo IPv4 del router local.

  • Si el argumento autonomous-system-number coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino interno.
  • Si el argumento autonomous-system-number no coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino externo.
  • En este ejemplo, el vecino es interno.
 
Paso 7
neighbor {ip-address| interface-type interface-number de la actualización-fuente del par-grupo-nombre}


Ejemplo:

Router (config-router) # loopback0 de la actualización-fuente de 192.168.1.1 del vecino

 

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

  • En este ejemplo, las conexiones TCP de BGP para el vecino especificado se originan con la dirección IP de la interfaz Loopback en lugar de la mejor dirección local.
 
Paso 8
direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}


Ejemplo:

Router (config-router) # direccionamiento-familia vpnv4

 

Ingresa en el modo de configuración de la familia de direcciones para configurar los peers BGP de modo que acepten configuraciones específicas de familia de direcciones.

  • El ejemplo crea una sesión de la familia de direcciones VPNv4.
 
Paso 9
neighbor {ip-address| el par-grupo-nombre} activa


Ejemplo:

El router (config-router-AF) # vecino 172.16.1.1 activa

 

Activa el vecino bajo la familia de direcciones VPNv4.

  • En este ejemplo, se activa el vecino 172.16.1.1.
 
Paso 10
neighbor {ip-address| enviar-comunidad del par-grupo-nombre } {ambas| estándar| extendido}


Ejemplo:

El router (config-router-AF) # enviar-comunidad de 172.16.1.1 del vecino extendió

 

Especifica que se debe enviar un atributo de comunidades a un vecino BGP.

  • En este ejemplo, un atributo de las comunidades ampliadas se envía al vecino en 172.16.1.1.
 
Paso 11
salida-direccionamiento-familia


Ejemplo:

Router (config-router-AF) # salida-direccionamiento-familia

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo de configuración del router.

 
Paso 12
direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}


Ejemplo:

Router (config-router) # vrf_trans del vrf de la direccionamiento-familia ipv4

 

Ingresa en el modo de configuración de la familia de direcciones para configurar los peers BGP de modo que acepten configuraciones específicas de familia de direcciones.

  • El ejemplo especifica que el caso VRF nombrado los vrf_trans debe ser asociado a los comandos configuration subsiguientes de la familia del direccionamiento del IPv4.
 
Paso 13
redistribuya conectado


Ejemplo:

El router (config-router-AF) # redistribuye conectado

 

Redistribuye desde un dominio de ruteo a otro dominio de ruteo.

  • En este ejemplo, se utiliza la palabra clave connected para representar las rutas que se establecen automáticamente cuando se habilita IP en una interfaz.
  • Solamente se muestra la sintaxis aplicable a este paso. Para más detalles, vea el Routing IP del Cisco IOS: Referencia del comando bgp.
 
Paso 14
neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 telecontrol-como 40000

 

Añade la dirección IP o el nombre de grupo de peers del vecino al sistema autónomo especificado a la tabla de vecinos BGP multiprotocolo IPv4 del router local.

  • Si el argumento autonomous-system-number coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino interno.
  • Si el argumento autonomous-system-number no coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino externo.
  • En este ejemplo, el vecino en 192.168.1.1 es un vecino externo.
 
Paso 15
neighbor ip-address local-como el [no-prepend [replace-as [dual-as] del autonomous-system-number]]


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 local-como 50000 ninguno-prepend

 

Personaliza el atributo AS_PATH para las rutas recibidas desde un vecino eBGP.

  • El número del sistema autónomo del proceso de ruteo BGP local se antepone a todas las rutas externas de forma predeterminada.
  • Utilice la palabra clave no-prepend para no anteponer el número del sistema autónomo local a ninguna ruta que se reciba del vecino eBGP.
  • En este ejemplo, las rutas del vecino en 192.168.1.1 no contendrán el número del sistema autónomo local.
 
Paso 16
neighbor {ip-address| [ttl] del ebgp-multihop del par-grupo-nombre}


Ejemplo:

Router (config-router-AF) # ebgp-multihop 2 de 192.168.1.1 del vecino

 

Valida e intenta las conexiones BGP en los peers externos que residen en las redes que no están conectadas directamente.

  • En este ejemplo, se configura BGP para permitir las conexiones a o desde el vecino 192.168.1.1, que reside en una red que no esté conectada directamente.
 
Paso 17
neighbor {ip-address| el par-grupo-nombre} activa


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 activa

 

Activa el vecino bajo la familia de direcciones IPv4.

  • En este ejemplo, se activa el vecino 192.168.1.1.
 
Paso 18
neighbor ip-address allowas-en [number]


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 allowas-en 1

 

Configura los routers del borde del proveedor (PE) para volver a anunciar todos los prefijos que contengan números del sistema autónomos duplicados.

  • En el ejemplo, el router PE con el número del sistema autónomo 45000 se configura para permitir los prefijos del VRF vrf-trans. El router PE vecino con la dirección IP 192.168.1.1 se ha configurado de modo que se envíe un nuevo anuncio a otros routers PE con el mismo número del sistema autónomo.
 
Paso 19
ningún automóvil summary


Ejemplo:

Router (config-router-AF) # ningún automóvil summary

 

Inhabilita el resumen automático y envía la información de ruteo de subprefijo a través de los límites de la red con clase.

 
Paso 20
ninguna sincronización


Ejemplo:

Router (config-router-AF) # ninguna sincronización

 

Habilita Cisco IOS Software para anunciar una ruta de red sin esperar la sincronización con un protocolo de gateway interno (IGP).

 
Paso 21
bgp router-id {IP address| auto-asigne}


Ejemplo:

Router (config-router-AF) # bgp router-id 10.99.1.1

 

Configura un ID de router fijo para el proceso de ruteo de BGP local.

  • En este ejemplo, el Id. del router BGP especificado se asigna para el caso VRF asociado a esta configuración de la familia del direccionamiento del IPv4.
 
Paso 22
Repita del paso 11 al paso 21 para configurar otra instancia de VRF.  

--

 
Paso 23
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 
Paso 24
muestre BGP vpnv4 {todo del IP| Route Distinguisher rd| vrf vrf-name}


Ejemplo:

BGP vpnv4 todo del IP de la demostración del Router-

 

(Opcional) Muestra la información de dirección VPN de la tabla BGP.

  • En este ejemplo, se visualiza la base de datos completa del VPNv4.
Nota    En este ejemplo se utiliza solamente la sintaxis aplicable a esta tarea. Para más detalles, vea la Referencia de Comandos del Multiprotocol Label Switching de Cisco IOS.
 

Ejemplos

La salida de muestra siguiente asume que dos casos VRF nombrados los vrf_trans y vrf_user fueron configurados cada uno con un router separado ID. El ID del router se muestra a continuación del nombre de VRF.

Router# show ip bgp vpnv4 all
BGP table version is 5, local router ID is 172.17.1.99
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf vrf_trans) VRF Router ID 10.99.1.2
*> 192.168.4.0      0.0.0.0                  0         32768 ?
Route Distinguisher: 42:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
*> 192.168.5.0      0.0.0.0                  0         32768 ?

Asignación Automática de un ID de Router BGP por VRF

Realice esta tarea de asignar automáticamente un Id. del router BGP para cada VRF. En esta tarea, un Loopback Interface se asocia a un VRF y configuran al comando bgp router-id en la configuración del router llana de asignar automáticamente un Id. del router BGP a todos los casos VRF. El paso 9 le muestra cómo relanzar ciertos pasos para configurar cada VRF que deba ser asociado a una interfaz. El paso 30 le muestra cómo configurar más de un VRF en el mismo router.

Antes de comenzar

Esta tarea asume que usted ha creado previamente los casos VRF. Para más detalles, vea los casos VRF que configuran.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. [secondary] de la máscara del IP address del IP Address

5. salida

6. número del tipo de la interfaz

7. IP VRF vrf-name de envío [vrf-name2] rio abajo

8. [secondary] de la máscara del IP address del IP Address

9. Relance el paso 5 al paso 8 para que cada VRF sea asociado a una interfaz.

10. salga

11 autonomous-system-number BGP del router

12.    bgp router-id {IP address| el vrf auto-asigna}

13.    ningún valor por defecto ipv4-unicast BGP

14.    log-neighbor-changes BGP

15.    neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number

16.    neighbor {ip-address| interface-type interface-number de la actualización-fuente del par-grupo-nombre}

17.    direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}

18.    neighbor {ip-address| el par-grupo-nombre} activa

19.    neighbor {ip-address| enviar-comunidad del par-grupo-nombre } {ambas| estándar| extendido}

20.    salida-direccionamiento-familia

21.    direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}

22.    redistribuya conectado

23.    neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number

24.    neighbor ip-address local-como el [no-prepend [replace-as [dual-as] del autonomous-system-number]]

25.    neighbor {ip-address| [ttl] del ebgp-multihop del par-grupo-nombre}

26.    neighbor {ip-address| el par-grupo-nombre} activa

27.    neighbor ip-address allowas-en [number]

28.    ningún automóvil summary

29.    ninguna sincronización

30.    Repita del paso 20 al paso 29 para configurar otra instancia de VRF.

31.    Finalizar

32.    muestre BGP vpnv4 {todo del IP| Route Distinguisher rd| vrf vrf-name}


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Loopback0 de la interfaz de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

  • En este ejemplo, se configura la interfaz Loopback 0.
 
Paso 4
[secondary] de la máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 172.16.1.1 255.255.255.255

 

Configura una dirección IP.

  • En este ejemplo, se configura la interfaz Loopback con una dirección IP de 172.16.1.1.
 
Paso 5
salida


Ejemplo:

Router(config-if)# exit

 

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

 
Paso 6
número del tipo de la interfaz


Ejemplo:

Interfaz loopback1 de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

  • En este ejemplo, se configura el Loopback Interface 1.
 
Paso 7
IP VRF envío del vrf-name [vrf-name2] rio abajo


Ejemplo:

Router (config-if) # IP VRF remitiendo los vrf_trans

 

Asocia un VRF a una interfaz o subinterfaz.

  • En este ejemplo, los vrf_trans nombrados VRF se asocian al Loopback Interface 1.
Nota    La ejecución de este comando en una interfaz quita la dirección IP. La dirección IP se debe configurar de nuevo.
 
Paso 8
[secondary] de la máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 10.99.1.1 255.255.255.255

 

Configura una dirección IP.

  • En este ejemplo, el Loopback Interface 1 se configura con una dirección IP de 10.99.1.1.
 
Paso 9
Repita los pasos del 5 al 8 para cada VRF que se va a asociar a una interfaz.  

--

 
Paso 10
salida


Ejemplo:

Router(config-if)# exit

 

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

 
Paso 11
autonomous-system-number BGP del router


Ejemplo:

BGP 45000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 12
bgp router-id {IP address| el vrf auto-asigna}


Ejemplo:

El router (config-router) # vrf del bgp router-id auto-asigna

 

Configura un ID de router fijo para el proceso de ruteo de BGP local.

  • En este ejemplo, un Id. del router BGP se asigna automáticamente para cada caso VRF.
 
Paso 13
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita la familia de direcciones unicast IPv4 para el proceso de ruteo BGP.

Nota    La información de ruteo para la familia de la dirección de Unicast del IPv4 se hace publicidad por abandono para cada sesión de la encaminamiento BGP configurada con el vecino telecontrol-como el comando router configuration a menos que usted no configure el ningún comando configuration del valor por defecto ipv4-unicastrouter BGP antes de configurar el comando neighbor remote-as. Las configuraciones vecinas existentes no se ven afectadas.
 
Paso 14
log-neighbor-changes BGP


Ejemplo:

Router (config-router) # log-neighbor-changes BGP

 

Habilita el registro de reinicios del vecino BGP.

 
Paso 15
neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router) # vecino 192.168.1.1 telecontrol-como 45000

 

Añade la dirección IP o el nombre de grupo de peers del vecino al sistema autónomo especificado a la tabla de vecinos BGP multiprotocolo IPv4 del router local.

  • Si el argumento autonomous-system-number coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino interno.
  • Si el argumento autonomous-system-number no coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino externo.
  • En este ejemplo, el vecino es interno.
 
Paso 16
neighbor {ip-address| interface-type interface-number de la actualización-fuente del par-grupo-nombre}


Ejemplo:

Router (config-router) # loopback0 de la actualización-fuente de 192.168.1.1 del vecino

 

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

  • En este ejemplo, las conexiones TCP de BGP para el vecino especificado se originan con la dirección IP de la interfaz Loopback en lugar de la mejor dirección local.
 
Paso 17
direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}


Ejemplo:

Router (config-router) # direccionamiento-familia vpnv4

 

Ingresa en el modo de configuración de la familia de direcciones para configurar los peers BGP de modo que acepten configuraciones específicas de familia de direcciones.

  • El ejemplo crea una sesión de la familia de direcciones VPNv4.
 
Paso 18
neighbor {ip-address| el par-grupo-nombre} activa


Ejemplo:

El router (config-router-AF) # vecino 172.16.1.1 activa

 

Activa el vecino bajo la familia de direcciones VPNv4.

  • En este ejemplo, se activa el vecino 172.16.1.1.
 
Paso 19
neighbor {ip-address| enviar-comunidad del par-grupo-nombre } {ambas| estándar| extendido}


Ejemplo:

El router (config-router-AF) # enviar-comunidad de 172.16.1.1 del vecino extendió

 

Especifica que se debe enviar un atributo de comunidades a un vecino BGP.

  • En este ejemplo, un atributo de las comunidades ampliadas se envía al vecino en 172.16.1.1.
 
Paso 20
salida-direccionamiento-familia


Ejemplo:

Router (config-router-AF) # salida-direccionamiento-familia

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo de configuración del router.

 
Paso 21
direccionamiento-familia {ipv4 [mdt | Multicast | [vrf vrf-name] del unicast | vrf-name del vrf] | [unicast] vpnv4}


Ejemplo:

Router (config-router) # vrf_trans del vrf de la direccionamiento-familia ipv4

 

Ingresa en el modo de configuración de la familia de direcciones para configurar los peers BGP de modo que acepten configuraciones específicas de familia de direcciones.

  • El ejemplo especifica que el caso VRF nombrado los vrf_trans debe ser asociado a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.
 
Paso 22
redistribuya conectado


Ejemplo:

El router (config-router-AF) # redistribuye conectado

 

Redistribuye desde un dominio de ruteo a otro dominio de ruteo.

  • En este ejemplo, se utiliza la palabra clave connected para representar las rutas que se establecen automáticamente cuando se habilita IP en una interfaz.
  • Solamente se muestra la sintaxis aplicable a este paso. Para más detalles, vea el Routing IP del Cisco IOS: Referencia del comando bgp.
 
Paso 23
neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 telecontrol-como 40000

 

Añade la dirección IP o el nombre de grupo de peers del vecino al sistema autónomo especificado a la tabla de vecinos BGP multiprotocolo IPv4 del router local.

  • Si el argumento autonomous-system-number coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino interno.
  • Si el argumento autonomous-system-number no coincide con el número del sistema autónomo especificado en el comando router bgp, el vecino es un vecino externo.
  • En este ejemplo, el vecino en 192.168.1.1 es un vecino externo.
 
Paso 24
neighbor ip-address local-como el [no-prepend [replace-as [dual-as] del autonomous-system-number]]


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 local-como 50000 ninguno-prepend

 

Personaliza el atributo AS_PATH para las rutas recibidas desde un vecino eBGP.

  • El número del sistema autónomo del proceso de ruteo BGP local se antepone a todas las rutas externas de forma predeterminada.
  • Utilice la palabra clave no-prepend para no anteponer el número del sistema autónomo local a ninguna ruta que se reciba del vecino eBGP.
  • En este ejemplo, las rutas del vecino en 192.168.1.1 no contendrán el número del sistema autónomo local.
 
Paso 25
neighbor {ip-address| [ttl] del ebgp-multihop del par-grupo-nombre}


Ejemplo:

Router (config-router-AF) # ebgp-multihop 2 de 192.168.1.1 del vecino

 

Valida e intenta las conexiones BGP en los peers externos que residen en las redes que no están conectadas directamente.

  • En este ejemplo, se configura BGP para permitir las conexiones a o desde el vecino 192.168.1.1, que reside en una red que no esté conectada directamente.
 
Paso 26
neighbor {ip-address| el par-grupo-nombre} activa


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 activa

 

Activa el vecino bajo la familia de direcciones IPv4.

  • En este ejemplo, se activa el vecino 192.168.1.1.
 
Paso 27
neighbor ip-address allowas-en [number]


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 allowas-en 1

 

Configura los routers del borde del proveedor (PE) para volver a anunciar todos los prefijos que contengan números del sistema autónomos duplicados.

  • En el ejemplo, el router PE con el número del sistema autónomo 45000 se configura para permitir los prefijos del VRF vrf-trans. El router PE vecino con la dirección IP 192.168.1.1 se ha configurado de modo que se envíe un nuevo anuncio a otros routers PE con el mismo número del sistema autónomo.
 
Paso 28
ningún automóvil summary


Ejemplo:

Router (config-router-AF) # ningún automóvil summary

 

Inhabilita el resumen automático y envía la información de ruteo de subprefijo a través de los límites de la red con clase.

 
Paso 29
ninguna sincronización


Ejemplo:

Router (config-router-AF) # ninguna sincronización

 

Habilita Cisco IOS Software para anunciar una ruta de red sin esperar la sincronización con un protocolo de gateway interno (IGP).

 
Paso 30
Repita del paso 20 al paso 29 para configurar otra instancia de VRF.  

--

 
Paso 31
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 
Paso 32
muestre BGP vpnv4 {todo del IP| Route Distinguisher rd| vrf vrf-name}


Ejemplo:

BGP vpnv4 todo del IP de la demostración del Router-

 

(Opcional) Muestra la información de dirección VPN de la tabla BGP.

  • En este ejemplo, se visualiza la base de datos completa del VPNv4.
Nota    En este ejemplo se utiliza solamente la sintaxis aplicable a esta tarea. Para más detalles, vea la Referencia de Comandos del Multiprotocol Label Switching de Cisco IOS.
 

Ejemplos

La salida de muestra siguiente asume que dos casos VRF nombrados los vrf_trans y vrf_user fueron configurados, cada uno con un router separado ID. El ID del router se muestra a continuación del nombre de VRF.

Router# show ip bgp vpnv4 all
BGP table version is 43, local router ID is 172.16.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf vrf_trans) VRF Router ID 10.99.1.2
*> 172.22.0.0       0.0.0.0                  0         32768 ?
r> 172.23.0.0       172.23.1.1               0             0 3 1 ?
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
*> 10.52.1.0/24     172.23.1.1                             0 3 1 ?
*> 10.52.2.1/32     172.23.1.1                             0 3 1 3 i
*> 10.52.3.1/32     172.23.1.1                             0 3 1 3 i
*> 10.99.1.1/32     172.23.1.1               0             0 3 1 ?
*> 10.99.1.2/32     0.0.0.0                  0         32768 ?
Route Distinguisher: 10:1
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
Route Distinguisher: 42:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0       172.22.1.1               0             0 2 1 ?
*> 172.23.0.0       0.0.0.0                  0         32768 ?
*> 10.21.1.1/32     172.22.1.1                             0 2 1 2 i
*>i10.52.1.0/24     192.168.3.1              0    100      0 ?
*>i10.52.2.1/32     192.168.3.1              0    100      0 3 i
*>i10.52.3.1/32     192.168.3.1              0    100      0 3 i
*> 10.99.1.1/32     0.0.0.0                  0         32768 ?
*> 10.99.1.2/32     172.22.1.1               0             0 2 1 ?

Ejemplos de Configuración de Asignación de ID de Router BGP por VRF

Manualmente configurar un Id. del router BGP por los ejemplos VRF

El siguiente ejemplo muestra cómo configurar dos VRF--vrf_trans y vrf_user--con las sesiones entre uno a sobre el mismo router. El Id. del router BGP para cada VRF se configura manualmente bajo las familias separadas del direccionamiento del IPv4. El comando show ip bgp vpnv4 se puede utilizar para verificar que se han configurado los IDs de router para cada VRF. El comienzo de la configuración en el modo de configuración global.

ip vrf vrf_trans
 rd 45000:1
 route-target export 50000:50
 route-target import 40000:1
!
ip vrf vrf_user
 rd 65500:1
 route-target export 65500:1
 route-target import 65500:1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vrf_trans
 ip address 172.22.1.1 255.255.0.0
!
interface Ethernet1/0
 ip vrf forwarding vrf_user
 ip address 172.23.1.1 255.255.0.0
!
router bgp 45000
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.3.1 remote-as 45000
 neighbor 192.168.3.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 192.168.3.1 activate
  neighbor 192.168.3.1 send-community extended
  exit-address-family
 !
 address-family ipv4 vrf vrf_user
  redistribute connected
  neighbor 172.22.1.1 remote-as 40000
  neighbor 172.22.1.1 local-as 50000 no-prepend
  neighbor 172.22.1.1 ebgp-multihop 2
  neighbor 172.22.1.1 activate
  neighbor 172.22.1.1 allowas-in 1
  no auto-summary
  no synchronization
  bgp router-id 10.99.1.1
  exit-address-family
 !
 address-family ipv4 vrf vrf_trans
  redistribute connected
  neighbor 172.23.1.1 remote-as 50000
  neighbor 172.23.1.1 local-as 40000 no-prepend
  neighbor 172.23.1.1 ebgp-multihop 2
  neighbor 172.23.1.1 activate
  neighbor 172.23.1.1 allowas-in 1
  no auto-summary
  no synchronization
  bgp router-id 10.99.1.2
  exit-address-family

Después de la configuración, la salida del comando show ip bgp vpnv4 all muestra el Router ID visualizado al lado del nombre VRF:

Router# show ip bgp vpnv4 all
BGP table version is 43, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 45000:1 (default for vrf vrf_trans) VRF Router ID 10.99.1.2
*> 172.22.0.0       0.0.0.0                  0         32768 ?
r> 172.23.0.0       172.23.1.1               0             0 3 1 ?
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
*> 10.52.1.0/24     172.23.1.1                             0 3 1 ?
*> 10.52.2.1/32     172.23.1.1                             0 3 1 3 i
*> 10.52.3.1/32     172.23.1.1                             0 3 1 3 i
*> 10.99.1.1/32     172.23.1.1               0             0 3 1 ?
*> 10.99.2.2/32     0.0.0.0                  0         32768 ?
Route Distinguisher: 50000:1
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0       172.22.1.1               0             0 2 1 ?
*> 172.23.0.0       0.0.0.0                  0         32768 ?
*> 10.21.1.1/32     172.22.1.1                             0 2 1 2 i
*>i10.52.1.0/24     192.168.3.1              0    100      0 ?
*>i10.52.2.1/32     192.168.3.1              0    100      0 3 i
*>i10.52.3.1/32     192.168.3.1              0    100      0 3 i
*> 10.99.1.1/32     0.0.0.0                  0         32768 ?
*> 10.99.2.2/32     172.22.1.1               0             0 2 1 ?

La salida del comando show ip bgp vpnv4 vrf para un VRF especificado visualiza el Router ID en la encabezado de la salida:

Router# show ip bgp vpnv4 vrf vrf_user
BGP table version is 43, local router ID is 10.99.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0       172.22.1.1               0             0 2 1 ?
*> 172.23.0.0       0.0.0.0                  0         32768 ?
*> 10.21.1.1/32     172.22.1.1                             0 2 1 2 i
*>i10.52.1.0/24     192.168.3.1              0    100      0 ?
*>i10.52.2.1/32     192.168.3.1              0    100      0 3 i
*>i10.52.3.1/32     192.168.3.1              0    100      0 3 i
*> 10.99.1.1/32     0.0.0.0                  0         32768 ?
*> 10.99.2.2/32     172.22.1.1               0             0 2 1 ?

La salida del comando summary del vrf BGP vpnv4 del IP de la demostración para un VRF especificado visualiza el Router ID en la primera línea de la salida:

Router# show ip bgp vpnv4 vrf vrf_user summary
BGP router identifier 10.99.1.1, local AS number 45000
BGP table version is 43, main routing table version 43
8 network entries using 1128 bytes of memory
8 path entries using 544 bytes of memory
16/10 BGP path/bestpath attribute entries using 1856 bytes of memory
6 BGP AS-PATH entries using 144 bytes of memory
3 BGP extended community entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 3744 total bytes of memory
BGP activity 17/0 prefixes, 17/0 paths, scan interval 15 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.22.1.1      4     2      20      21       43    0    0 00:12:33        3

Cuando la trayectoria es originada en el VRF, el Router ID correcto se visualiza en la salida del vrfcommand BGP vpnv4 del IP de la demostración para un VRF y una dirección de red especificados:

Router# show ip bgp vpnv4 vrf vrf_user 172.23.0.0
BGP routing table entry for 65500:1:172.23.0.0/8, version 22
Paths: (1 available, best #1, table vrf_user)
  Advertised to update-groups:
     2          3         
  Local
    0.0.0.0 from 0.0.0.0 (10.99.1.1)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:65500:1

Automáticamente asignación de un Id. del router BGP por los ejemplos VRF

Los tres métodos distintos siguientes de la demostración de los ejemplos de configuración de configurar el BGP para asignar automáticamente un router separado ID a cada caso VRF:

Router ID global automáticamente asignado usando los IP Addresses del Loopback Interface

Las demostraciones del siguiente ejemplo cómo configurar dos VRF--vrf_trans y vrf_user--con las sesiones entre uno a sobre el mismo router. Bajo modo de configuración del router, el BGP global se configura para asignar automáticamente cada VRF que las interfaces del router BGP de un loopback identificación se asocian a los VRF individuales a la fuente una dirección IP para el Router ID. El comando show ip bgp vpnv4 se puede utilizar para verificar que se han configurado los IDs de router para cada VRF.

ip vrf vrf_trans
 rd 45000:1
 route-target export 50000:50
 route-target import 40000:1
!
ip vrf vrf_user
 rd 65500:1
 route-target export 65500:1
 route-target import 65500:1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vrf_user
 ip address 10.99.1.1 255.255.255.255
!
interface Loopback2
 ip vrf forwarding vrf_trans
 ip address 10.99.2.2 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vrf_trans
 ip address 172.22.1.1 255.0.0.0
!
interface Ethernet1/0
 ip vrf forwarding vrf_user
 ip address 172.23.1.1 255.0.0.0
!
router bgp 45000
 bgp router-id vrf auto-assign
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.3.1 remote-as 45000
 neighbor 192.168.3.1 update-source Loopback0
 !
address-family vpnv4
  neighbor 192.168.3.1 activate
  neighbor 192.168.3.1 send-community extended
  exit-address-family
 !
 address-family ipv4 vrf vrf_user
  redistribute connected
  neighbor 172.22.1.1 remote-as 40000
  neighbor 172.22.1.1 local-as 50000 no-prepend
  neighbor 172.22.1.1 ebgp-multihop 2
  neighbor 172.22.1.1 activate
  neighbor 172.22.1.1 allowas-in 1
  no auto-summary
  no synchronization
  exit-address-family
 !
 address-family ipv4 vrf vrf_trans
  redistribute connected
  neighbor 172.23.1.1 remote-as 50000
  neighbor 172.23.1.1 local-as 2 no-prepend
  neighbor 172.23.1.1 ebgp-multihop 2
  neighbor 172.23.1.1 activate
  neighbor 172.23.1.1 allowas-in 1
  no auto-summary
  no synchronization
  exit-address-family

Después de la configuración, la salida del comando show ip bgp vpnv4 all muestra el ID del router al lado del nombre VRF. Tenga en cuenta que el ID del router usado en este ejemplo se origina de las direcciones IP configuradas para la interfaz Loopback 1 y la interfaz Loopback 2. El router ID consiste lo mismo que en manualmente configurar un Id. del router BGP por los ejemplos VRF.

Router# show ip bgp vpnv4 all
BGP table version is 43, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 45000:1 (default for vrf vrf_trans) VRF Router ID 10.99.2.2
*> 172.22.0.0       0.0.0.0                  0         32768 ?
r> 172.23.0.0       172.23.1.1               0             0 3 1 ?
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
*> 10.52.1.0/24     172.23.1.1                             0 3 1 ?
*> 10.52.2.1/32     172.23.1.1                             0 3 1 3 i
*> 10.52.3.1/32     172.23.1.1                             0 3 1 3 i
*> 10.99.1.1/32     172.23.1.1               0             0 3 1 ?
*> 10.99.1.2/32     0.0.0.0                  0         32768 ?
Route Distinguisher: 50000:1
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0       172.22.1.1               0             0 2 1 ?
*> 172.23.0.0       0.0.0.0                  0         32768 ?
*> 10.21.1.1/32     172.22.1.1                             0 2 1 2 i
*>i10.52.1.0/24     192.168.3.1              0    100      0 ?
*>i10.52.2.1/32     192.168.3.1              0    100      0 3 i
*>i10.52.3.1/32     192.168.3.1              0    100      0 3 i
*> 10.99.1.1/32     0.0.0.0                  0         32768 ?
*> 10.99.1.2/32     172.22.1.1               0             0 2 1 ?

Router ID global automáticamente asignado sin el router predeterminado ID

El siguiente ejemplo muestra cómo configurar a un router y asociar un VRF que se asigne automáticamente un Id. del router BGP cuando no se afecta un aparato ningún router predeterminado ID.

ip vrf vpn1
 rd 45000:1
 route-target export 45000:1
 route-target import 45000:1
!
interface Loopback0
 ip vrf forwarding vpn1
 ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vpn1
 ip address 172.22.1.1 255.0.0.0
!
router bgp 45000
 bgp router-id vrf auto-assign
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 !
 address-family ipv4 vrf vpn1
  neighbor 172.22.1.2 remote-as 40000
  neighbor 172.22.1.2 activate
  no auto-summary
  no synchronization
  exit-address-family

Si se asume que configuran a un segundo router para establecer una sesión entre el dos Routers, la salida del comando show ip interface brief muestra solamente las interfaces VRF se configuran que.

Router# show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            172.22.1.1      YES NVRAM  up                    up      
Ethernet1/0            unassigned      YES NVRAM  administratively down down    
Serial2/0              unassigned      YES NVRAM  administratively down down    
Serial3/0              unassigned      YES NVRAM  administratively down down    
Loopback0              10.1.1.1        YES NVRAM  up                    up

El comando show ip vrf puede ser utilizado para verificar que un Router ID está asignado para el VRF:

Router# show ip vrf
Name                             Default RD          Interfaces
  vpn1                             45000:1             Loopback0
                                                       Ethernet0/0
VRF session is established:

Router ID automáticamente asignado Por-VRF

Las demostraciones del siguiente ejemplo cómo configurar dos VRF--vrf_trans y vrf_user--con las sesiones entre uno a sobre el mismo router. Bajo la familia del direccionamiento del IPv4 asociada a un VRF individual, el BGP se configura para asignar automáticamente las interfaces del router BGP de un loopback identificación se asocia a los VRF individuales a la fuente una dirección IP para el Router ID. La salida del comando show ip bgp vpnv4 se puede utilizar para verificar que han configurado al router ID para cada VRF.

ip vrf vrf_trans
 rd 45000:1
 route-target export 50000:50
 route-target import 40000:1
!
ip vrf vrf_user
 rd 65500:1
 route-target export 65500:1
 route-target import 65500:1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vrf_user
 ip address 10.99.1.1 255.255.255.255
!
interface Loopback2
 ip vrf forwarding vrf_trans
 ip address 10.99.2.2 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding vrf_trans
 ip address 172.22.1.1 255.0.0.0
!
interface Ethernet1/0
 ip vrf forwarding vrf_user
 ip address 172.23.1.1 255.0.0.0
!
router bgp 45000
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.3.1 remote-as 45000
 neighbor 192.168.3.1 update-source Loopback0
 !
address-family vpnv4
  neighbor 192.168.3.1 activate
  neighbor 192.168.3.1 send-community extended
  exit-address-family
!
 address-family ipv4 vrf vrf_user
  redistribute connected
  neighbor 172.22.1.1 remote-as 40000
  neighbor 172.22.1.1 local-as 50000 no-prepend
  neighbor 172.22.1.1 ebgp-multihop 2
  neighbor 172.22.1.1 activate
  neighbor 172.22.1.1 allowas-in 1
  no auto-summary
  no synchronization
  bgp router-id auto-assign
  exit-address-family
 !
 address-family ipv4 vrf vrf_trans
  redistribute connected
  neighbor 172.23.1.1 remote-as 50000
  neighbor 172.23.1.1 local-as 40000 no-prepend
  neighbor 172.23.1.1 ebgp-multihop 2
  neighbor 172.23.1.1 activate
  neighbor 172.23.1.1 allowas-in 1
  no auto-summary
  no synchronization
  bgp router-id auto-assign
  exit-address-family

Después de la configuración, la salida del comando show ip bgp vpnv4 all muestra el ID del router al lado del nombre VRF. Tenga en cuenta que el ID del router usado en este ejemplo se origina de las direcciones IP configuradas para la interfaz Loopback 1 y la interfaz Loopback 2.

Router# show ip bgp vpnv4 all
BGP table version is 43, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 45000:1 (default for vrf vrf_trans) VRF Router ID 10.99.2.2
*> 172.22.0.0       0.0.0.0                  0         32768 ?
r> 172.23.0.0       172.23.1.1               0             0 3 1 ?
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
*> 10.52.1.0/24     172.23.1.1                             0 3 1 ?
*> 10.52.2.1/32     172.23.1.1                             0 3 1 3 i
*> 10.52.3.1/32     172.23.1.1                             0 3 1 3 i
*> 10.99.1.1/32     172.23.1.1               0             0 3 1 ?
*> 10.99.1.2/32     0.0.0.0                  0         32768 ?
Route Distinguisher: 50000:1
*>i10.21.1.1/32     192.168.3.1              0    100      0 2 i
Route Distinguisher: 65500:1 (default for vrf vrf_user) VRF Router ID 10.99.1.1
r> 172.22.0.0       172.22.1.1               0             0 2 1 ?
*> 172.23.0.0       0.0.0.0                  0         32768 ?
*> 10.21.1.1/32     172.22.1.1                             0 2 1 2 i
*>i10.52.1.0/24     192.168.3.1              0    100      0 ?
*>i10.52.2.1/32     192.168.3.1              0    100      0 3 i
*>i10.52.3.1/32     192.168.3.1              0    100      0 3 i
*> 10.99.1.1/32     0.0.0.0                  0         32768 ?
*> 10.99.1.2/32     172.22.1.1               0             0 2 1 ?

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con la asignación Por-VRF de la característica del Id. del router BGP.

Documentos Relacionados

Tema relacionado

Título del documento

Comandos bgp: sintaxis de comandos completa, valores predeterminados, modo de comandos, historial de comandos, pautas de uso y ejemplos

Routing IP del Cisco IOS: Referencia del comando bgp

Comandos mpls: sintaxis de comandos completa, valores predeterminados, modo de comandos, historial de comandos, pautas de uso y ejemplos

Referencia de Comandos de Multiprotocol Label Switching de Cisco IOS

Estándares

Estándar

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.

--

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Referencia de Comandos

Los siguientes comandos se introducen o se modifican en la característica o las características documentadas en este módulo. Para la información sobre estos comandos, vea el Routing IP del Cisco IOS: Referencia del comando bgp. Para obtener información sobre todos los comandos de Cisco IOS utilice Command Lookup Tool, disponible en http://tools.cisco.com/Support/CLILookup o la Lista de Comandos Principal de Cisco IOS, Todas las Versiones, que se encuentra en http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html.

  • bgp router-id
  • show ip bgp vpnv4

Información de la Función para Per-VRF Assignment of BGP Router ID

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la Función para Per-VRF Assignment of BGP Router ID

Nombre de la función

Versiones

Información sobre la Función

Per-VRF Assignment of BGP Router ID

12.2(31)SB2 12.2(33)SRA 12.2(33)SXH 12.4(20)T 15.0(1)S

La función Per-VRF Assignment of BGP Router ID inserta la capacidad de tener peering de VRF a VRF en un Border Gateway Protocol (BGP) en el mismo router. BGP se ha diseñado para rechazar una sesión consigo mismo debido a la verificación del ID del router. La función de asignación por VRF permite un ID de router separado para cada VRF usando una nueva palabra clave en el comando existente del bgp router-id. El ID de router se puede configurar manualmente para cada VRF o se puede asignar automáticamente globalmente bajo el modo de configuración de la familia de direcciones o para cada VRF.

Los siguientes comandos fueron introducidos o modificados por esta característica: bgp router-id, BGP vpnv4 del IP de la demostración.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.