Routing IP: Guía de configuración BGP, Cisco IOS Release 12.2SR
Configuración BGP de SoO por Vecino
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 258 KB | Inglés (8 Noviembre 2011) | Comentarios

Contenido

Configuración BGP de SoO por Vecino

Última actualización: De abril el 13 de 2012

El BGP por la característica de configuración de SoO del vecino simplifica la configuración del valor del sitio-de-origen (SoO). En el Cisco IOS Release 12.4(9)T, 12.2(33)SRA, 12.2(31)SB2, y las versiones anteriores, el valor de SoO se configura usando un Route Map entrante que fija el valor de SoO durante el proceso actualización. Por SoO del vecino la configuración presenta a dos comandos new que puedan ser configurados en los submodes bajo modo de configuración del router para fijar el valor de SoO. En el Cisco IOS Release 12.4(24)T, el soporte fue agregado para los números del sistema autónomos 4-byte en el formato del asdot solamente.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en Cisco.com no se requiere.

Prerrequisitos para BGP per Neighbor SoO Configuration

Esta característica asume que una red del Border Gateway Protocol (BGP) está configurada y que el Cisco Express Forwarding está habilitado en su red.

Restricciones de BGP per Neighbor SoO Configuration

Una configuración basada en plantillas de SoO de la directiva del vecino BGP o del par toma la precedencia sobre el valor de SoO configurado en un Route Map entrante.

Información sobre cómo Configurar BGP per Neighbor SoO

Sitio del Atributo de la Comunidad BGP de Origen

La comunidad ampliada del sitio-de-origen (SoO) es un atributo de comunidad extendida de BGP que se utiliza para identificar las rutas que han originado de un sitio para poder prevenir el readvertisement de ese prefijo de nuevo al sitio de la fuente. La comunidad ampliada de SoO identifica únicamente el sitio del cual un router ha aprendido una ruta. El BGP puede utilizar el valor de SoO asociado a una ruta para evitar el rutear de los loopes.

Discriminador de Rutas

Un Route Distinguisher (RD) crea la encaminamiento y las tablas de reenvío y especifica el distinguisher de la ruta predeterminado para un VPN. El RD se añade al principio de un prefijo de IPv4 para cambiarlo por un prefijo de VPN-IPv4 globalmente único. Un RD se puede componer de dos maneras: con un número autónomo del sistema y un número arbitrario o con una dirección IP y un número arbitrario.

Puede ingresar un RD en cualquiera de estos formatos:

  • Ingresar un número del sistema autónomo de 16 bits, dos puntos y un número de 32 bits. Por ejemplo:

45000:3

  • Ingrese una dirección IP de 32 bits, dos puntos y un número de 16 bits. Por ejemplo:

192.168.10.15:1

Soporte BGP para los Números de Sistema Autónomo de 4 Bytes

En el Cisco IOS Release 12.4(24)T, el soporte fue agregado para los números del sistema autónomos 4-byte según lo descrito en el RFC 5396, representación textual de los números de Sistema autónomo (AS). En el Cisco IOS Release 12.4(24)T, la implementación de Cisco de los números del sistema autónomos 4-byte utiliza el asdot notation--1.2 por ejemplo--como el únicos formato de la configuración, coincidencia de la expresión normal, y visualización de la salida, sin el soporte del asplain.

En el Cisco IOS Release 12.2(33)SRE, 12.2(33)XNE, y posterior las versiones, soporte BGP para los números del sistema autónomos 4-octet (4-byte) usando el formato del asplain como el formato predeterminado fue introducido. El formato predeterminado del asplain utiliza los números del valor decimal tales como 65536, pero usted puede configurar los números del sistema autónomos 4-byte en el asplain y el formato del asdot. Si desea cambiar la salida del comando show predeterminado para visualizar los números del sistema autónomo de 4 bytes con el formato asdot, utilice el comando bgp asnotation dot en modo de configuración del router.

Para los ejemplos de configuración que implican los números del sistema autónomos 4-byte, vea la a que configura por el valor de SoO del vecino con un 4-Byte COMO número usando un ejemplo de la plantilla de política del peer BGP o la a que configura por el valor de SoO del vecino usando un comando del vecino BGP y un ejemplo de los números del sistema autónomos 4-Byte.

Para más detalles sobre la implementación de Cisco de los formatos de número del sistema autónomo BGP, vea el “módulo de la descripción de Cisco BGP”.

BGP per Neighbor Site of Origin Configuration

Hay tres maneras de configurar un valor de SoO para un vecino BGP:

  • Plantilla de política del peer BGP--Se crea una plantilla de política del par, y un valor de SoO se configura como parte de la directiva del par. Bajo el VRF IPv4 de la familia de direcciones, se identifica y configura un vecino para heredar la política de peer que contiene el valor de SoO.
  • Comando del vecino BGP--Bajo el IPv4 VRF de la familia del direccionamiento, identifican a un vecino, y un valor de SoO se configura para el vecino.
  • Grupo de peer de BGP--Bajo el IPv4 VRF de la familia del direccionamiento, configuran a un grupo de peer de BGP, un valor de SoO se configura para el grupo de peer, identifican a un vecino, y configuran al vecino como miembro del grupo de peer.

La configuración de los valores de SoO para los vecinos BGP se realiza en un router del borde del proveedor (PE), que es el punto de entrada VPN. Cuando se habilita SoO, PE del router los prefijos adelante al Customer Premises Equipment (CPE) solamente cuando la etiqueta de SoO del prefijo no hacen juego la etiqueta de SoO configurada para el CPE. Por ejemplo, en la figura abajo, una etiqueta de SoO se fija como 65000:1 para el sitio del cliente que incluye al Routers CPE1 y CPE2 con un número del sistema autónomo de 65000. Cuando CPE1 envía los prefijos al PE1, el PE1 marca los prefijos con etiqueta con 65000:1, que es la etiqueta de SoO para CPE1 y CPE2. Cuando el PE1 envía los prefijos marcados con etiqueta al PE2, el PE2 realiza una coincidencia contra la etiqueta de SoO de CPE2. Ninguna prefijos con el valor de la etiqueta de 65000:1 no se envían a CPE2 porque se evita las coincidencias de etiqueta de SoO la etiqueta de SoO de CPE2, y un Routing Loop.

Figura 1Diagrama de la red por el ejemplo de SoO


Ventajas del Sitio de Origen por Vecino de BGP

En las versiones antes del Cisco IOS Release 12.4(11)T, de 12.2(33)SRB, y de 12.2(33)SB, el atributo de la comunidad ampliada de SoO se configura usando un Route Map entrante que fija el valor de SoO durante el proceso actualización. La introducción de dos comandos new configurados en los submodes bajo modo de configuración del router simplifica la configuración del valor de SoO.

Cómo Configurar BGP per Neighbor SoO

Para configurar un valor de SoO para un vecino BGP, usted debe realizar la primera tarea en la lista y la siguiente de las tres tareas siguientes. Las tres tareas más recientes son mutuamente - exclusiva; usted necesita realizar solamente uno de ellas.

Habilitando el Cisco Express Forwarding y configurar los casos VRF

Realice esta tarea en ambos Routers PE en la figura arriba de configurar los casos del ruteo virtual y de la expedición (VRF) que se utilizarán con las tareas de la asignación por-VRF. En esta tarea, se habilita el Cisco Express Forwarding, y un caso VRF nombrado SOO_VRF se crea. Para hacer el VRF funcional, se crea un Route Distinguisher, y el VRF se asocia a una interfaz. Cuando se crea el Route Distinguisher, la encaminamiento y las tablas de reenvío se crean para el caso VRF nombrado SOO_VRF. Después de asociar el VRF a una interfaz, la interfaz se configura con una dirección IP.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. cef del IP

4. IP VRF vrf-name

5. Route Distinguisher rd

6. ruta-blanco {exportación | ambos} ruta-blanco-extensión-comunidad

7. ruta-blanco {importación | ambos} ruta-blanco-extensión-comunidad

8. salida

9. número del tipo de la interfaz

10. IP VRF vrf-name de envío [vrf-name2] rio abajo

11 [secondary] de la máscara del IP address del IP Address

12.    Finalizar

13.    muestre IP VRF [descripción | detalle | interfaces | [output-modifiers] del [vrf-name] identificación]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
ip cef


Ejemplo:

Cef del IP de Router(config)#

 

Cisco Express Forwarding de los permisos en el Route Processor.

 
Paso 4
IP VRF vrf-name


Ejemplo:

Router(config)# IP VRF SOO_VRF

 

Define un caso VRF e ingresa en el modo de la configuración de VRF.

 
Paso 5
Route Distinguisher rd


Ejemplo:

Router (config-VRF) # rd 1:1

 

Crea tablas de ruteo y reenvío para un VRF y especifica el RD predeterminado para una VPN.

  • Utiliza el argumento route-distinguisher para especificar el RD predeterminado para una VPN. Hay dos formatos que usted puede utilizar para especificar un RD:
    • Un número del sistema autónomo de 16 bits, dos puntos, y un número de 32 bits, por ejemplo: 65000:3
    • Una dirección IP de 32 bits, dos puntos, y un número de 16 bits, por ejemplo: 192.168.1.2:51
  • En este ejemplo, el RD utiliza un número del sistema autónomo con el número 1 después de los dos puntos.
 
Paso 6
ruta-blanco {exportación | ambos} ruta-blanco-extensión-comunidad


Ejemplo:

Router (config-VRF) # exportación 1:1 de la ruta-blanco

 

Crea a una comunidad ampliada de comando route-target para un VRF.

  • Utilice la palabra clave export para exportar la información de ruteo a la comunidad ampliada de la VPN de destino.
  • Use la palabra clave both para importar información de ruteo desde la comunidad ampliada de la VPN de destino y para exportarla a ella.
  • Utilice el argumento route-target-ext-community para especificar la comunidad ampliada de la VPN.
Nota    Solamente se muestra la sintaxis aplicable a este paso. Para un diverso uso de este sintaxis, vea el paso 7.
 
Paso 7
ruta-blanco {importación | ambos} ruta-blanco-extensión-comunidad


Ejemplo:

Router (config-VRF) # importación 1:1 de la ruta-blanco

 

Crea a una comunidad ampliada de comando route-target para un VRF.

  • Utilice la palabra clave import para importar la información de ruteo de la comunidad ampliada de VPN de destino.
  • Use la palabra clave both para importar información de ruteo desde la comunidad ampliada de la VPN de destino y para exportarla a ella.
  • Utilice el argumento route-target-ext-community para especificar la comunidad ampliada de la VPN.
 
Paso 8
salida


Ejemplo:

Router (config-VRF) # salida

 

Modo y devoluciones de la configuración de VRF de las salidas al modo de configuración global.

 
Paso 9
número del tipo de la interfaz


Ejemplo:

Gigabitethernet 1/0/0 de la interfaz de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

 
Paso 10
IP VRF envío del vrf-name [vrf-name2] rio abajo


Ejemplo:

Router (config-if) # IP VRF remitiendo SOO_VRF

 

Asocia un VRF a una interfaz o subinterfaz.

  • En este ejemplo, el SOO_VRF nombrado VRF se asocia a la interfaz de Ethernet Gigabite 1/0/0.
Nota    La ejecución de este comando en una interfaz quita la dirección IP, así que la dirección IP debe ser configurada de nuevo.
 
Paso 11
[secondary] de la máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 192.168.1.2 255.255.255.0

 

Configura una dirección IP.

  • En este ejemplo, la interfaz de Ethernet Gigabite 1/0/0 se configura con una dirección IP de 192.168.1.2.
 
Paso 12
Finalizar


Ejemplo:

Router(config-if)#end

 

Salidas modo de configuración de la interfaz y devoluciones al modo EXEC privilegiado.

 
Paso 13
muestre IP VRF [descripción | detalle | interfaces | [output-modifiers] del [vrf-name] identificación]


Ejemplo:

Demostración del Router- IP VRF

 

Visualiza los VRF configurados.

  • Utilice este comando de verificar la configuración de esta tarea.
 

Ejemplos

El producto siguiente del comando show ip vrf visualiza el SOO_VRF nombrado VRF configurado en esta tarea.

Router# show ip vrf
Name                             Default RD            Interfaces
SOO_VRF                                 1:1                GE1/0/0

Configuración de un Valor SoO por Vecino Usando una Plantilla de Política de Peer BGP

Realice esta tarea en el router PE1 en la figura arriba de configurar un valor de SoO para un vecino BGP en el router CPE1 en la figura sobre usar una plantilla de política del par. En esta tarea, se crea una plantilla de política del par, y el valor de SoO se configura para la directiva del par. Bajo el VRF IPv4 de la familia de direcciones, se identifica y configura un vecino para heredar la política de peer que contiene el valor de SoO.

Para un ejemplo de configuración que implica los números del sistema autónomos 4-byte, vea la a que configura por el valor de SoO del vecino con un 4-Byte COMO número usando un ejemplo de la plantilla de política del peer BGP.


Nota


Si un peer BGP hereda de varias plantillas de política del par que especifiquen diversos valores de SoO, el valor de SoO en la plantilla más reciente se aplicó toma la precedencia y se aplica al par. Sin embargo, la configuración directa del valor de SoO en el vecino BGP reemplaza cualquier configuración heredada de la plantilla del valor de SoO.

Plantillas de política del peer BGP

Las plantillas de política de peer se utilizan para configurar los comandos de política de BGP que se configuran para los vecinos que pertenecen a familias de direcciones específicas. Las plantillas de política del par se configuran una vez y después se aplican a muchos vecinos con la aplicación directa de una plantilla de política del par o con la herencia de las plantillas de política del par. La configuración de las plantillas de políticas de peer simplifica la configuración de los comandos de políticas de BGP que se aplican a todos los vecinos dentro de un sistema autónomo.

Las plantillas de política del par soportan la herencia. Una plantilla de política de peer aplicada directamente puede heredar directa o indirectamente las configuraciones de hasta siete plantillas de política de peer. Así pues, se pueden aplicar un total de ocho plantillas de política de peer a un vecino o grupo de vecinos.

La configuración de las plantillas de política de peer simplifica y mejora la flexibilidad de la configuración de BGP. Es posible configurar una vez una política específica y hacer referencia a ella muchas veces. Porque las admite una políticas de un par hasta ocho niveles de herencia, muy específicos y las políticas de BGP muy complejas pueden ser creados.

Para más detalles sobre las plantillas de política del peer BGP, vea “configurando el módulo de una red de BGP básica”.

Antes de comenzar

Para esta tarea se supone que se ha realizado la tarea descrita en la sección "Verificación de CEF y Configuración de Instancias de VRF".


Nota


Un peer BGP no puede heredar de una política de peer o de una plantilla de sesión y configurarse a la vez como miembro de un grupo de peers. Las plantillas BGP y los grupos de peers BGP son mutuamente excluyentes.



PASOS SUMARIOS

1. permiso

2. configuró terminal

3. autonomous-system-number BGP del router

4. directiva-plantilla-nombre de la par-directiva de la plantilla

5. valor de comunidad extendida del soo

6. salida-par-directiva

7. direccionamiento-familia ipv4 [unicast | Multicast| vrf-name del vrf]

8. neighbor ip-address telecontrol-como el autonomous-system-number

9. el neighbor ip-address activa

10. el neighbor ip-address hereda el directiva-plantilla-nombre de la par-directiva

11 extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
autonomous-system-number BGP del router


Ejemplo:

BGP 50000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
directiva-plantilla-nombre de la par-directiva de la plantilla


Ejemplo:

Router (config-router) # par-directiva SOO_POLICY de la plantilla

 

Crea una plantilla de política del par y ingresa al modo de configuración de la plantilla de política.

 
Paso 5
valor de comunidad extendida del soo


Ejemplo:

Router (config-router-ptmp) # soo 65000:1

 

Fija el valor de SoO para una plantilla de política del peer BGP.

  • Utilice el argumento del valor de comunidad extendida para especificar el valor de la comunidad ampliada VPN. El valor toma uno de los formatos siguientes:
    • Un número del sistema autónomo de 16 bits, dos puntos, y un número de 32 bits, por ejemplo: 45000:3
    • Una dirección IP de 32 bits, dos puntos, y un número de 16 bits, por ejemplo: 192.168.10.2:51
  • En este ejemplo, el valor de SoO se fija en 65000:1.
 
Paso 6
salida-par-directiva


Ejemplo:

Router (config-router-pmtp) # salida-par-directiva

 

Modo de configuración y devoluciones de la plantilla de política de las salidas al modo de configuración del router.

 
Paso 7
direccionamiento-familia ipv4 [unicast | Multicast| vrf-name del vrf]


Ejemplo:

Router (config-router) # vrf SOO_VRF de la direccionamiento-familia ipv4

 

Especifica la familia de direcciones de IPv4 e ingresa en el modo de configuración de la familia de direcciones.

  • Utilice la palabra clave unicast para especificar la familia de direcciones unicast IPv4. De forma predeterminada, el router se pone en el modo de configuración para la familia de direcciones unicast IPv4 si no se especifica la palabra clave unicast con el comando address-family ipv4.
  • Utilice la palabra clave multicast para especificar los prefijos de dirección multicast IPv4.
  • Utilice la palabra clave vrf y el argumento vrf-name para especificar el nombre de la instancia de VRF que se debe asociar a los comandos subsiguientes del modo de configuración de la familia de direcciones IPv4.
 
Paso 8
neighbor ip-address telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 telecontrol-como 65000

 

Añade la dirección IP del vecino del sistema autónomo especificado a la tabla de vecinos de BGP multiprotocolo IPv4 del router local.

 
Paso 9
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 activa

 

Permite al vecino intercambiar los prefijos de la familia de direcciones VRF IPv4 con el router local.

 
Paso 10
el neighbor ip-address hereda el directiva-plantilla-nombre de la par-directiva


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 hereda la par-directiva SOO_POLICY

 

Envía una plantilla de política de peer a un vecino para que este vecino pueda heredar la configuración.

  • En este ejemplo, configuran al router para enviar la plantilla de política del par nombrada SOO_POLICY al vecino de 192.168.1.1 para heredar. Si otra plantilla de política del par se hereda indirectamente de SOO_POLICY, la configuración indirectamente heredada también será aplicada. Hasta siete plantillas de política adicionales del par se pueden heredar indirectamente de SOO_POLICY.
 
Paso 11
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Configuración de un Valor de SoO por Vecino Usando un Comando neighbor de BGP

Realice esta tarea en el router PE2 en la figura arriba de configurar un valor de SoO para el vecino BGP en el router CPE2 en la figura sobre usar un comando neighbor. Bajo el IPv4 VRF de la familia del direccionamiento, identifican a un vecino, y un valor de SoO se configura para el vecino.

La configuración directa del valor de SoO en un vecino BGP reemplaza cualquier configuración heredada de la plantilla de política del par del valor de SoO.

Antes de comenzar

Esta tarea asume que la tarea descrita en “verificar el CEF y configurar el VRF cita como ejemplo” la sección se ha realizado con los cambios apropiados a las interfaces y a los IP Addresses.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. autonomous-system-number BGP del router

4. direccionamiento-familia ipv4 [unicast | Multicast| vrf-name del vrf]

5. vecino {IP address| par-grupo-nombre} telecontrol-como el autonomous-system-number

6. el neighbor ip-address activa

7. vecino {IP address| valor de comunidad extendida del soo del par-grupo-nombre}

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
autonomous-system-number BGP del router


Ejemplo:

BGP 50000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
direccionamiento-familia ipv4 [unicast | Multicast| vrf-name del vrf]


Ejemplo:

Router (config-router) # vrf SOO_VRF de la direccionamiento-familia ipv4

 

Especifica la familia de direcciones de IPv4 e ingresa en el modo de configuración de la familia de direcciones.

  • Utilice la palabra clave unicast para especificar la familia de direcciones unicast IPv4. De forma predeterminada, el router se pone en el modo de configuración para la familia de direcciones unicast IPv4 si no se especifica la palabra clave unicast con el comando address-family ipv4.
  • Utilice la palabra clave multicast para especificar los prefijos de dirección multicast IPv4.
  • Utilice la palabra clave vrf y el argumento vrf-name para especificar el nombre de la instancia de VRF que se debe asociar a los comandos subsiguientes del modo de configuración de la familia de direcciones IPv4.
 
Paso 5
neighbor {ip-address| par-grupo-nombre} telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router-AF) # vecino 192.168.2.1 telecontrol-como 65000

 

Añade la dirección IP del vecino del sistema autónomo especificado a la tabla de vecinos de BGP multiprotocolo IPv4 del router local.

 
Paso 6
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 192.168.2.1 activa

 

Permite al vecino intercambiar los prefijos de la familia de direcciones VRF IPv4 con el router local.

  • En este ejemplo, activan al par del BGP externo en 192.168.2.1.
Nota    Si han configurado a un grupo de peer en el paso 5, no utilice este paso porque se activan los grupos de peer de BGP cuando se configura cualquier parámetro. Por ejemplo, se activa un grupo de peer de BGP cuando un valor de SoO se configura usando el comando vecino del soo en el paso 7.
 
Paso 7
neighbor {ip-address| valor de comunidad extendida del soo del par-grupo-nombre}


Ejemplo:

Router (config-router-AF) # soo 65000:1 de 192.168.2.1 del vecino

 

Define el valor de site-of-origin (SoO) para un Vecino o un grupo de peers de BGP.

  • En este ejemplo, configuran al vecino en 192.168.2.1 con un valor de SoO de 65000:1.
 
Paso 8
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Configuración de un Valor SoO por Vecino Usando un Grupo de Peer BGP

Realice esta tarea en el router PE1 en la figura arriba de configurar un valor de SoO para el vecino BGP en el router CPE1 en la figura sobre usar un comando neighbor con un grupo de peer de BGP. Bajo el IPv4 VRF de la familia del direccionamiento, crean a un grupo de peer de BGP y un valor de SoO se configura usando un comando del vecino BGP, e identifican y después se agregan a un vecino como miembro de grupo de peer. Un miembro del grupo de peer de BGP hereda la configuración asociada a un grupo de peer, que en este ejemplo, incluye el valor de SoO.

La configuración directa del valor de SoO en un vecino BGP reemplaza cualquier configuración heredada del grupo de peer del valor de SoO.

Antes de comenzar

Esta tarea asume que la tarea descrita en “habilitar el Cisco Express Forwarding y configurar los casos VRF” se ha realizado.


Nota


Un peer BGP no puede heredar de una política de peer o de una plantilla de sesión y configurarse a la vez como miembro de un grupo de peers. Las plantillas BGP y los grupos de peers BGP son mutuamente excluyentes.



PASOS SUMARIOS

1. permiso

2. configuró terminal

3. autonomous-system-number BGP del router

4. direccionamiento-familia ipv4 [unicast | Multicast| vrf-name del vrf]

5. grupo de peers del par-grupo-nombre del vecino

6. vecino {IP address| valor de comunidad extendida del soo del par-grupo-nombre}

7. neighbor ip-address telecontrol-como el autonomous-system-number

8. el neighbor ip-address activa

9. par-grupo-nombre del grupo de peers del neighbor ip-address

10. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
autonomous-system-number BGP del router


Ejemplo:

BGP 50000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
direccionamiento-familia ipv4 [unicast | Multicast| vrf-name del vrf]


Ejemplo:

Router (config-router) # vrf SOO_VRF de la direccionamiento-familia ipv4

 

Especifica la familia de direcciones de IPv4 e ingresa en el modo de configuración de la familia de direcciones.

  • Utilice la palabra clave unicast para especificar la familia de direcciones unicast IPv4. De forma predeterminada, el router se pone en el modo de configuración para la familia de direcciones unicast IPv4 si no se especifica la palabra clave unicast con el comando address-family ipv4.
  • Utilice la palabra clave multicast para especificar los prefijos de dirección multicast IPv4.
  • Utilice la palabra clave vrf y el argumento vrf-name para especificar el nombre de la instancia de VRF que se debe asociar a los comandos subsiguientes del modo de configuración de la familia de direcciones IPv4.
 
Paso 5
grupo de peers vecino del par-grupo-nombre


Ejemplo:

Router (config-router-AF) # grupo de peers de SOO_group del vecino

 

Crea un grupo de peers de BGP.

 
Paso 6
neighbor {ip-address| valor de comunidad extendida del soo del par-grupo-nombre}


Ejemplo:

Router (config-router-AF) # soo 65000:1 de SOO_group del vecino

 

Define el valor de site-of-origin (SoO) para un Vecino o un grupo de peers de BGP.

  • En este ejemplo, configuran al grupo de peer de BGP, SOO_group, con un valor de SoO de 65000:1.
 
Paso 7
neighbor ip-address telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router-AF) # vecino 192.168.1.1 telecontrol-como 65000

 

Añade la dirección IP del vecino del sistema autónomo especificado a la tabla de vecinos de BGP multiprotocolo IPv4 del router local.

 
Paso 8
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 192.168.1.1 activa

 

Permite al vecino intercambiar los prefijos de la familia de direcciones VRF IPv4 con el router local.

 
Paso 9
par-grupo-nombre del grupo de peers del neighbor ip-address


Ejemplo:

Router (config-router-AF) # grupo de peers SOO_group de 192.168.1.1 del vecino

 

Asigna la dirección IP de un vecino BGP a un grupo de peers.

 
Paso 10
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Ejemplos de Configuración de BGP per Neighbor SoO

Configurar a por el valor de SoO del vecino usando un ejemplo de la plantilla de política del peer BGP

Las demostraciones del siguiente ejemplo cómo crear una plantilla de política del par y configurar un valor de SoO como parte de la directiva del par. Después de habilitar el Cisco Express Forwarding y de configurar un caso VRF nombrado SOO_VRF, se crea una plantilla de política del par y un valor de SoO se configura como parte de la directiva del par. En la familia de direcciones VRF IPv4, se identifica y configura un vecino para que herede la política de peer que contiene el valor de SoO.

ip cef
ip vrf SOO_VRF
 rd 1:1
 route-target export 1:1
 route-target import 1:1
 exit
interface GigabitEthernet 1/0/0
 ip vrf forwarding SOO_VRF
 ip address 192.168.1.2 255.255.255.0
 exit
router bgp 50000
 template peer-policy SOO_POLICY
  soo 65000:1
  exit-peer-policy
 address-family ipv4 vrf SOO_VRF
  neighbor 192.168.1.1 remote-as 65000
  neighbor 192.168.1.1 activate
  neighbor 192.168.1.1 inherit peer-policy SOO_POLICY
  end

Configurar a por el valor de SoO del vecino con un 4-Byte COMO número usando un ejemplo de la plantilla de política del peer BGP

El siguiente ejemplo muestra cómo crear una plantilla de política del par y configurar un valor de SoO usando un número del sistema autónomo 4-byte, 1,2 en el formato del asdot, como parte de la directiva del par. En la familia de direcciones VRF IPv4, se identifica y configura un vecino para que herede la política de peer que contiene el valor de SoO. Este ejemplo requiere el Cisco IOS Release 12.4(24)T, o una versión posterior.

router bgp 1.2
 template peer-policy SOO_POLICY
  soo 1.2:3
  exit-peer-policy
 address-family ipv4 vrf SOO_VRF
  neighbor 192.168.3.2 remote-as 1.14
  neighbor 192.168.3.2 activate
  neighbor 192.168.3.2 inherit peer-policy SOO_POLICY
  end

El siguiente ejemplo muestra cómo crear una plantilla de política del par y configurar un valor de SoO usando un número del sistema autónomo 4-byte, 65538 en el formato del asplain, como parte de la directiva del par. En la familia de direcciones VRF IPv4, se identifica y configura un vecino para que herede la política de peer que contiene el valor de SoO. Este ejemplo requiere el Cisco IOS Release 12.2(33)SRE, 12.2(33)XNE, o una versión posterior.

router bgp 65538
 template peer-policy SOO_POLICY
  soo 65538:3
  exit-peer-policy
 address-family ipv4 vrf SOO_VRF
  neighbor 192.168.3.2 remote-as 65550
  neighbor 192.168.3.2 activate
  neighbor 192.168.3.2 inherit peer-policy SOO_POLICY
  end

Configurar a por el valor de SoO del vecino usando un comando example del vecino BGP

El siguiente ejemplo muestra cómo configurar un valor de SoO para un vecino de BGP. Después de habilitar el Cisco Express Forwarding y de configurar un caso VRF nombrado SOO_VRF, identifican a un vecino bajo el IPv4 VRF de la familia del direccionamiento y un valor de SoO se configura para el vecino.

ip cef
ip vrf SOO_VRF
 rd 1:1
 route-target export 1:1
 route-target import 1:1
 exit
interface GigabitEthernet 1/0/0
 ip vrf forwarding SOO_VRF
 ip address 192.168.2.2 255.255.255.0
 exit
router bgp 50000
 address-family ipv4 vrf SOO_VRF
  neighbor 192.168.2.1 remote-as 65000
  neighbor 192.168.2.1 activate
  neighbor 192.168.2.1 soo 65000:1
  end

Configurando a por el valor de SoO del vecino usando un vecino BGP ordene y el ejemplo de los números del sistema autónomos 4-Byte

El siguiente ejemplo muestra cómo configurar un valor de SoO para un vecino de BGP. En este ejemplo, todos los vecinos BGP, blancos de la ruta, y valores de SoO utilizan los números del sistema autónomos 4-byte en el formato del asplain. Después de marcar se habilita ese CEF, un caso VRF nombrado SOO_VRF se configura con las blancos de la ruta. En una sesión del router BGP identifican a un vecino bajo el IPv4 VRF de la familia del direccionamiento, y un valor de SoO se configura para el vecino. Este ejemplo requiere el Cisco IOS Release 12.4(24)T, o una versión posterior.

show ip cef
ip vrf SOO_VRF
 rd 100:200
 route-target export 1.14:1
 route-target import 1.14:1
 exit
interface Ethernet 1/0
 ip vrf forwarding SOO_VRF
 ip address 192.168.2.2 255.255.255.0
 exit
router bgp 1.2
 address-family ipv4 vrf SOO_VRF
  neighbor 192.168.2.1 remote-as 1.14
  neighbor 192.168.2.1 activate
  neighbor 192.168.2.1 soo 1.14:1
  end

Configurar a por el valor de SoO del vecino usando un ejemplo del grupo de peer de BGP

El siguiente ejemplo muestra cómo configurar un valor de SoO para un grupo de peer de BGP. Después de habilitar el Cisco Express Forwarding y de configurar un caso VRF nombrado SOO_VRF, configuran a un grupo de peer de BGP bajo el IPv4 VRF de la familia del direccionamiento, un valor de SoO se configura para el grupo de peer, identifican a un vecino, y configuran al vecino como miembro del grupo de peer.

ip cef
ip vrf SOO_VRF
 rd 1:1
 route-target export 1:1
 route-target import 1:1
 exit
interface GigabitEthernet 1/0/0
 ip vrf forwarding SOO_VRF
 ip address 192.168.1.2 255.255.255.0
 exit
router bgp 50000
 address-family ipv4 vrf SOO_VRF
  neighbor SOO_GROUP peer-group
  neighbor SOO_GROUP soo 65000:65
  neighbor 192.168.1.1 remote-as 65000
  neighbor 192.168.1.1 activate
  neighbor 192.168.1.1 peer-group SOO_GROUP 
  end

Adonde ir después

  • Para leer una descripción del BGP, proceda “al módulo de la descripción de Cisco BGP”.
  • Para realizar las tareas básicas de la característica BGP, proceda “configurando al módulo de una red de BGP básica”.
  • Para realizar las tareas avanzadas de la característica BGP, proceda a “configurar el BGP avanzado ofrece” el módulo.
  • Para configurar las opciones de sesión de vecino BGP, proceda al módulo "Configuración de las Opciones de Sesión de Vecino BGP" .
  • Para realizar las tareas del Internal BGP, proceda a “configurar el Internal BGP ofrece” el módulo.

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con el soporte BGP para por la característica de configuración de SoO del vecino.

Documentos Relacionados

Tema relacionado

Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Comandos bgp: sintaxis, modo de comando, valores por defecto, comando history, Pautas para el uso, y ejemplos del comando complete

Routing IP del Cisco IOS: Referencia del comando bgp

Comandos del Switching IP: sintaxis, modo de comando, valores por defecto, comando history, Pautas para el uso, y ejemplos del comando complete

Referencia de Comandos de IP Switching de Cisco IOS

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre la Función BGP per Neighbor SoO Configuration

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información sobre la Función BGP per Neighbor SoO Configuration

Nombre de la función

Versiones

Información sobre la Función

Configuración BGP de SoO por Vecino

12.2(33)SB

12.2(33)SRB

12.4(11)T

15.0(1)SY

La función BGP per Neighbor SoO Configuration simplifica la configuración del parámetro de site-of-origin (SoO). En el Cisco IOS Release 12.4(9)T, 12.2(33)SRA, 12.2(31)SB2, y las versiones anteriores, el parámetro de SoO se configura usando un Route Map entrante que fija el valor de SoO durante el proceso actualización. Por la configuración de SoO del vecino presenta a dos comandos new que puedan ser configurados en los submodes bajo modo de configuración del router para fijar el valor de SoO.

Los siguientes comandos fueron introducidos por esta función: soo vecino, soo.

Soporte BGP para ASN de 4 bytes

12.0(32)S12

12.0(32)SY8

12.2(33)SRE

12.2(33)XNE

12.4(24)T

El soporte BGP para la función ASN de 4 bytes introdujo el soporte para números de sistema autónomo de 4 bytes. Debido a la demanda creciente de números del sistema autónomo, en enero de 2009 el IANA comenzará a asignar números del sistema autónomo de 4 bytes en el rango entre 65536 y 4294967295.

En el Cisco IOS Release 12.0(32)SY8, 12.2(33)SRE, y 12.2(33)XNE, la implementación de Cisco del asplain de las aplicaciones de los números del sistema autónomos 4-byte como el formato de visualización predeterminado de la coincidencia y de la salida de la expresión normal para los números del sistema autónomos, pero usted puede configurar los números del sistema autónomos 4-byte en el formato del asplain y el formato del asdot según lo descrito en el RFC 5396. Para cambiar la visualización regular y predeterminada de la coincidencia y de la salida de expresiones de los números del sistema autónomo de 4 bytes al formato asdot, utilice el comando bgp asnotation dot.

En el Cisco IOS Release 12.0(32)S12, y 12.4(24)T, la implementación de Cisco del asdot de las aplicaciones de los números del sistema autónomos 4-byte como el único formato de la configuración, coincidencia de la expresión normal, y visualización de la salida, sin el soporte del asplain.

Los siguientes comandos fueron modificados por esta función: el punto del asnotation BGP, identificador de confederación BGP, confederación BGP mira, BGP claro del IP, nuevo-formato de la BGP-comunidad del IP, extcommunity-lista del IP, fuente-protocolo de la coincidencia, vecino local-como, vecino telecontrol-como, soo vecino, redistribuye (IP), BGP del router, fijó la como-trayectoria, fijó el extcommunity, fijó el origen, el soo, y todos los comandos show ip bgp que visualicen un número del sistema autónomo.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.