Routing IP: Guía de configuración BGP, Cisco IOS Release 12.2SR
BGP Cost Community
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 181 KB | Inglés (8 Noviembre 2011) | Comentarios

BGP Cost Community

Última actualización: De abril el 13 de 2012

La función BGP Cost Community BGP introduce el atributo de la comunidad de costo ampliada. La comunidad de costo es un atributo de comunidad ampliada no transitivo que se pasa a los peers de BGP interno (iBGP) y confederación, pero no a los peers de BGP externo (eBGP). La función de comunidad de costo permite personalizar la preferencia de la ruta local e influir en el proceso de selección de la mejor trayectoria mediante la asignación de valores de costo a rutas específicas.

En el Cisco IOS Release 12.0(27)S, 12.3(8)T, 12.2(25)S, y posterior las versiones, soporte fue introducido para las topologías de red mezcladas del MPLS VPN del EIGRP que contienen el VPN y los links traseros.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en Cisco.com no se requiere.

Prerrequisitos de la Función BGP Cost Community

Este documento asume que el BGP está configurado en su red y que mirando se ha establecido.

Restricciones de la Función BGP Cost Community

  • La característica de la comunidad de costo BGP se puede configurar solamente dentro de un sistema autónomo o de una confederación. La comunidad del coste es una comunidad ampliada NON-transitiva que se pasa al iBGP y la confederación mira solamente y no se pasa a los pares del eBGP.
  • La característica de la comunidad de costo BGP se debe soportar en todo el Routers en el sistema autónomo o la confederación antes de que se configure la filtración de la comunidad del coste. La comunidad del coste debe ser aplicada constantemente en el sistema autónomo o la confederación local para evitar los Routing Loop potencial.
  • Las cláusulas múltiples del conjunto de comunidades del coste se pueden configurar con el comando del coste del extcommunity del conjunto en un bloque o una secuencia de la correspondencia de solo ruta. Sin embargo, cada cláusula del conjunto se debe configurar con un diverso valor ID (0-255) para cada punta de la inserción (POI). El valor ID determina la preferencia cuando el resto de los atributos son iguales. Se prefiere el valor más bajo ID.

Información sobre la Función BGP Cost Community

Descripción General de BGP Cost Community

La comunidad del coste es un atributo NON-transitivo de la comunidad ampliada que se pasa al iBGP y a los pares de la confederación pero no a los pares del eBGP. La configuración de la característica de la comunidad de costo BGP permite que usted personalice el proceso de selección del mejor trayecto BGP para un sistema autónomo o una confederación local.

El atributo de la comunidad del coste es aplicado a las rutas interno configurando el comando del coste del extcommunity del conjunto en un Route Map. La cláusula del conjunto de comunidades del coste se configura con un número de ID de la comunidad del coste (0-255) y el coste número (0-4294967295). El valor numérico del costo determina la preferencia de la trayectoria. La trayectoria con el número más barato de la comunidad se prefiere. Las trayectorias que no se configuran específicamente con el atributo de la comunidad del coste se asignan un valor numérico del costo predeterminado de 2147483647 (el punto mediano entre 0 y 4294967295) y son evaluadas por el proceso de selección del mejor trayecto por consiguiente. En el caso donde dos trayectorias se han configurado con el mismo valor numérico del coste, el proceso de selección de trayecto entonces preferirá la trayectoria con la comunidad más barata ID. El atributo de la comunidad ampliada del coste se propaga a los pares del iBGP cuando el intercambio de la comunidad ampliada se habilita con el comando neighbor send-community.

Los siguientes comandos se pueden utilizar para aplicar el Route Map que se configura con la cláusula del conjunto de comunidades del coste:

  • agregado-direccionamiento
  • el vecino valor por defecto-origina el route-map {en | hacia fuera}
  • route-map vecino
  • route-map de la red
  • redistribuya el route-map

Cómo Influye BGP Cost Community en el Proceso de Selección de la Mejor Trayectoria

El atributo de la comunidad del coste influencia el proceso de selección del mejor trayecto BGP actualmente la inserción (POI). Por abandono, el POI sigue la comparación métrica IGP. Cuando el BGP recibe los trayectos múltiples al mismo destino, utiliza el proceso de selección del mejor trayecto para determinar qué trayectoria es el mejor trayecto. El BGP toma automáticamente la decisión y instala el mejor trayecto en la tabla de ruteo. El POI permite que usted asigne a preferencia a o una trayectoria específica cuando los Trayectos múltiples de igual costo están disponibles. Si el POI es inválido para la selección de mejor trayecto local, el atributo de la comunidad del coste se ignora silenciosamente.

Los trayectos múltiples se pueden configurar con el atributo de la comunidad del coste para el mismo POI. La trayectoria con la comunidad más barata ID se considera primero. Es decir todas las trayectorias de la comunidad del coste para un POI específico se consideran, empezando por el que está con la comunidad más barata. Las trayectorias que no contienen a la comunidad del coste (para el POI y la comunidad ID que son evaluados) se asignan el valor de costo predeterminado de la comunidad (2147483647). Si los Valores comunitarios del coste son iguales, después la comparación de la comunidad del coste procede a la comunidad más baja siguiente ID para este POI.


Nota


Las trayectorias que no se configuran con el atributo de la comunidad del coste son consideradas por el proceso de selección del mejor trayecto tener el valor de costo predeterminado (mitad del valor máximo [4294967295] o 2147483647).

La aplicación del atributo de la comunidad del coste en el POI permite que usted asigne un valor a una trayectoria originada o aprendida por un par en cualquier parte del sistema autónomo o la confederación local. La comunidad del coste puede ser utilizada como “cortacircuítos del lazo” durante el proceso de selección del mejor trayecto. Las instancias múltiples de la comunidad del coste se pueden configurar para los trayectos de igual costos separados dentro del mismo sistema autónomo o de la confederación. Por ejemplo, un Valor comunitario más barato se puede aplicar a una trayectoria específica de la salida en una red con las puntas de salidas múltiples del igual costo, y la trayectoria específica de la salida será preferida por el proceso de selección del mejor trayecto BGP. Vea el escenario descrito en la “influencia de la preferencia de la ruta en una red de la Multi-salida IGP”.

Soporte de Comunidad de Costo para Rutas y Trayectorias Múltiples Agregadas

Los totales de Routes y los multipaths son soportados por la característica de la comunidad de costo BGP. El atributo de la comunidad del coste se puede aplicar a cualquier tipo de ruta. El atributo de la comunidad del coste se pasa al agregado o a la ruta de trayectoria múltiple de las rutas del componente que llevan el atributo de la comunidad del coste. Solamente se pasan los ID únicos, y solamente el coste más alto de cualquier ruta del componente individual será aplicado al agregado sobre una base por-ID. Si las rutas del componente múltiple contienen el mismo ID, el coste configurado más alto se aplica a la ruta. Por ejemplo, las dos rutas del componente siguientes se configuran con el atributo de la comunidad del coste vía un Route Map entrante:

  • 10.0.0.1 (POI=IGP, ID=1, Cost=100)
  • 192.168.0.1 (POI=IGP, ID=1, Cost=200)

Si estas rutas del componente se agregan o se configuran como de trayectoria múltiple, el valor de costo 200 (POI=IGP, ID=1, Cost=200) será hecho publicidad porque es el coste más alto.

Si una o más rutas del componente no llevan el atributo de la comunidad del coste o si las rutas del componente se configuran con diversos ID, después el valor predeterminado (2147483647) será hecho publicidad para el agregado o la ruta de trayectoria múltiple. Por ejemplo, las tres rutas del componente siguientes se configuran con el atributo de la comunidad del coste vía un Route Map entrante. Sin embargo, las rutas del componente se configuran con dos diversos ID.

  • 10.0.0.1 (POI=IGP, ID=1, Cost=100)
  • 172.16.0.1 (POI=IGP, ID=2, Cost=100)
  • 192.168.0.1 (POI=IGP, ID=1, Cost=200)

La sola trayectoria de divulgación incluirá a las comunidades agregadas del coste como sigue:

  • {POI=IGP, ID=1, Cost=2147483647} {POI=IGP, ID=2, Cost=2147483647}

Cómo Influir en la Preferencia de la Ruta en una Red IGP Multisalida

La figura abajo muestra una red del Interior Gateway Protocol (IGP) con dos Autonomous System Boundary Router (ASBR) en el borde. Cada ASBR tiene un trayecto de igual costo a la red 10.8/16.

Figura 1Red de la punta IGP de la Multi-salida


Ambas trayectorias son consideradas ser iguales por el BGP. Si se configura el distribuir la carga de trayectoria múltiple, ambas trayectorias serán instaladas a la tabla de ruteo y utilizadas para cargar el tráfico de la balanza. Si el equilibrio de la carga de trayecto múltiple no se configura, después el BGP seleccionará la trayectoria que fue aprendida primero como el mejor trayecto y instalará esta trayectoria a la tabla de ruteo. Este comportamiento puede no ser deseable bajo algunas condiciones. Por ejemplo, la trayectoria es docta de ISP1 PE2 primero, pero del link entre ISP1 PE2 y ASBR1 es un link de baja velocidad.

La configuración del atributo de la comunidad del coste se puede utilizar para influenciar el proceso de selección del mejor trayecto BGP aplicando un Valor comunitario más barato a la trayectoria aprendida por ASBR2. Por ejemplo, la configuración siguiente se aplica a ASBR2.

route-map ISP2_PE1 permit 10
 set extcommunity cost 1 1
 match ip address 13
!
ip access-list 13 permit 10.8.0.0 0.0.255.255 

El Route Map antedicho aplica un valor numérico de la comunidad del coste de 1 a la ruta de 10.8.0.0. Por abandono, la trayectoria aprendida de ASBR1 será asignada un Valor comunitario del coste de 2147483647. Porque la trayectoria aprendida de ASBR2 tiene Valor comunitario más barato, esta trayectoria será preferida.

BGP Cost Community Support for EIGRP MPLS VPN PE-CE with Backdoor Links

Antes del sitio del EIGRP del soporte de comunidad de costo BGP del origen (SoO) fue introducido, BGP prefirió localmente las rutas originadas sobre las rutas aprendidas de los peeres BGP. El BGP preferirá los links de entrada posterior de una topología EIGRP MPLS VPN si se obtiene primero el link de entrada posterior. (El link de la entrada posterior A, o una ruta, es una conexión que se configura fuera del VPN entre un telecontrol y un sitio principal. Por ejemplo, una línea arrendada PÁLIDA que conecta un sitio remoto con la red corporativa).

El punto de inserción "pre-bestpath" se insertó en la función BGP Cost Community para soportar topologías de red VPN EIGRP mixtas que contienen links de entrada posterior y VPN. Este POI se aplica automáticamente a las trayectorias EIGRP que se redistribuyen en el BGP. La “PRE-mejor trayectoria” POI lleva el tipo de la ruta EIGRP y métrico. Este POI afecta al proceso del cálculo de la mejor trayectoria ya que influye a BGP para que tenga en cuenta este POI antes de cualquier otro paso de comparación. No se requiere configuración. Esta característica se habilita automáticamente para los sitios del EIGRP VPN cuando el Cisco IOS Release 12.0(27)S está instalado a un PE, a un CE, o a un router de la entrada posterior.

Para la información sobre configurar el MPLS VPNs del EIGRP, refiera al soporte del MPLS VPN para el EIGRP entre el documento del borde y de la frontera del cliente del proveedor en el Cisco IOS Release 12.0(27)S.

Para más información sobre el sitio del MPLS VPN PE-CE del EIGRP de la característica del origen (SoO), refiera al sitio del MPLS VPN PE-CE del EIGRP de la documentación sobre característica del origen (SoO) en el Cisco IOS Release 12.0(27)S.

Cómo Configurar la Función BGP Cost Community

Configuración de BGP Cost Community

Para configurar a la comunidad del coste, realice la tarea en esta sección.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. autonomous-system-number BGP del router

4. neighbor ip-address telecontrol-como el autonomous-system-number

5. direccionamiento-familia ipv4 [mdt | Multicast | túnel | [vrf vrf-name] del unicast | vrf-name del vrf] | IPv6 [Multicast | unicast] | [unicast] vpnv4

6. nombre de asignación del route-map del neighbor ip-address {en | hacia fuera}

7. salida

8. nombre de asignación del route-map {permiso | niegue} el [sequence-number]

9. valor de costo determinado comunidad-identificación del [igp] del coste del extcommunity

10. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita niveles de privilegio más altos, como el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
autonomous-system-number BGP del router


Ejemplo:

BGP 50000 del router de Router(config)#

 

Ingresa al modo de configuración del router para crear o configurar un proceso de ruteo BGP.

 
Paso 4
neighbor ip-address telecontrol-como el autonomous-system-number


Ejemplo:

Router (config-router) # vecino 10.0.0.1 telecontrol-como 101

 

Establece el peering con el vecino o el grupo de peers especificado.

 
Paso 5
direccionamiento-familia ipv4 [mdt | Multicast | túnel | [vrf vrf-name] del unicast | vrf-name del vrf] | IPv6 [Multicast | unicast] | [unicast] vpnv4


Ejemplo:

Router (config-router) # direccionamiento-familia ipv4

 

Coloca el router en el modo de configuración de familia de direcciones.

 
Paso 6
nombre de asignación del route-map del neighbor ip-address {en | hacia fuera}


Ejemplo:

Router (config-router) # NOMBRE DE ASIGNACIÓN del route-map de 10.0.0.1 del vecino adentro

 

Aplica un mapa de Route entrante o saliente para el vecino o el grupo de peers especificado.

 
Paso 7
salida


Ejemplo:

Router (config-router) # salida

 

Sale del modo de configuración de routers y entra en el modo de configuración global.

 
Paso 8
nombre de asignación del route-map {permiso | niegue} el [sequence-number]


Ejemplo:

Permiso 10 del NOMBRE DE ASIGNACIÓN del route-map de Router(config)#

 

Ingresa al modo de configuración del Route Map para crear o para configurar un Route Map.

 
Paso 9
fije el valor de costo comunidad-identificación del [igp] del coste del extcommunity


Ejemplo:

El router (config-route-map) # fijó el extcommunity costó 1 100

 

Crea una cláusula del conjunto para aplicar el atributo de la comunidad del coste.

  • Las cláusulas múltiples del conjunto de comunidades del coste se pueden configurar en cada bloque o secuencia del Route Map. Cada cláusula del conjunto de comunidades del coste debe tener un diverso ID (0-255). La cláusula del conjunto de comunidades del coste con el valor de costo más bajo es preferida por el proceso de selección del mejor trayecto cuando el resto de los atributos son iguales.
  • Las trayectorias que no se configuran con el atributo de la comunidad del coste serán asignadas el valor de costo predeterminado, que es mitad del valor máximo (4294967295) o 2147483647.
 
Paso 10
Finalizar


Ejemplo:

Router (config-route-map) # extremo

 

Sale del modo de configuración del route map e ingresa en el modo EXEC privilegiado.

 

Verificación de la Configuración de BGP Cost Community

La configuración de BGP Cost Community se puede verificar localmente o para un vecino específico. Para verificar a la comunidad del coste de la configuración local, utilice el route-map de la demostración o muestre ejecutarse-configcommand. Para verificar que un vecino específico lleve a la comunidad del coste, utilice el comando ip-address BGP del IP de la demostración. La salida de estos comandos visualiza el POI (el IGP es el valor por defecto POI), el ID configurado, y configuró el coste. Para los Valores comunitarios grandes del coste, la salida de estos comandos también mostrará, con + y - los valores, la diferencia entre el coste configurado y el costo predeterminado. Vea “verificar la configuración de la comunidad de costo BGP” para la salida de ejemplo específica.

Consejos de Troubleshooting

El comando bgp bestpath cost-community ignore puede ser utilizado para inhabilitar la evaluación del atributo de la comunidad del coste para ayudar a aislar los problemas y a resolver problemas los problemas que se relacionan con la selección de mejor trayecto BGP.

El comando debug ip bgp updates puede ser utilizado para imprimir los mensajes de la actualización de BGP. El atributo de la comunidad ampliada de la comunidad del coste será visualizado en la salida de este comando cuando está recibido de un vecino. Un mensaje también será visualizado si una comunidad ampliada NON-transitiva si está recibido de un peer externo.

Ejemplos de Configuración de la Función BGP Cost Community

Ejemplo de Configuración de BGP Cost Community

La configuración del siguiente ejemplo muestra la configuración del costcommand del extcommunity del conjunto. El siguiente ejemplo aplica la comunidad ID del coste de 1 y el Valor comunitario del coste de 100 a las rutas que son permitidas por el Route Map. Esta configuración hará el proceso de selección del mejor trayecto preferir esta ruta sobre otros trayectos de igual costos que no fueron permitidos por esta secuencia del Route Map.

Router(config)# router bgp 50000
Router(config-router)# neighbor 10.0.0.1 remote-as 50000
Router(config-router)# neighbor 10.0.0.1 update-source Loopback 0
Router(config-router)# address-family ipv4
Router(config-router-af)# neighbor 10.0.0.1 activate
Router(config-router-af)# neighbor 10.0.0.1 route-map COST1 in 
Router(config-router-af)# neighbor 10.0.0.1 send-community both 
Router(config-router-af)# exit 
Router(config)# route-map COST1 permit 10
Router(config-route-map)# match ip-address 1
Router(config-route-map)# set extcommunity cost 1 100

Ejemplos de Verificación de la Comunidad de Costo BGP

La configuración de BGP Cost Community se puede verificar localmente o para un vecino específico. Para verificar a la comunidad del coste de la configuración local, utilice el route-map de la demostración o muestre ejecutarse-configcommand. Para verificar que un vecino específico lleve a la comunidad del coste, utilice el comando ip-address BGP del IP de la demostración.

La salida de la ruta-mapcommand de la demostración visualizará las ruta-correspondencias localmente configuradas, hace juego, fijó, continúa las cláusulas, y el estatus y la configuración del atributo de la comunidad del coste. La salida de muestra siguiente es similar a la salida que será visualizada:

Router# show route-map
route-map COST1, permit, sequence 10
  Match clauses:
    as-path (as-path filter): 1 
  Set clauses:
    extended community Cost:igp:1:100
  Policy routing matches: 0 packets, 0 bytes
route-map COST1, permit, sequence 20
  Match clauses:
    ip next-hop (access-lists): 2 
  Set clauses:
    extended community Cost:igp:2:200
  Policy routing matches: 0 packets, 0 bytes
route-map COST1, permit, sequence 30
  Match clauses:
    interface FastEthernet0/0 
    extcommunity (extcommunity-list filter):300 
  Set clauses:
    extended community Cost:igp:3:300
  Policy routing matches: 0 packets, 0 bytes

La salida de muestra siguiente muestra las rutas localmente configuradas con los Valores comunitarios grandes del coste:

Router# show route-map 
route-map set-cost, permit, sequence 10
  Match clauses:
  Set clauses:
    extended community RT:1:1 RT:2:2 RT:3:3 RT:4:4 RT:5:5 RT:6:6 RT:7:7
      RT:100:100 RT:200:200 RT:300:300 RT:400:400 RT:500:500 RT:600:600
      RT:700:700 additive
    extended community Cost:igp:1:4294967295 (default+2147483648)
      Cost:igp:2:200 Cost:igp:3:300 Cost:igp:4:400
      Cost:igp:5:2147483648 (default+1) Cost:igp:6:2147484648 (default+1001)
      Cost:igp:7:2147284648 (default-198999)
  Policy routing matches: 0 packets, 0 bytes

La salida del configcommand corriente de la demostración visualizará la coincidencia, fijará, y continuará las cláusulas que se configuran dentro de un route-map. La salida de muestra siguiente se filtra para mostrar solamente el parte pertinente de la configuración corriente:

Router# show running-config | begin route-map
route-map COST1 permit 20
 match ip next-hop 2
 set extcommunity cost igp 2 200
!
route-map COST1 permit 30
 match interface FastEthernet0/0
 match extcommunity 300
 set extcommunity cost igp 3 300
.
.
.

La salida del comando ip-address BGP del IP de la demostración se puede utilizar para verificar si un vecino específico lleva una trayectoria que se configure con el atributo de la comunidad del coste. La información de atributo de la comunidad del coste se visualiza en el campo de la “comunidad ampliada”. Visualizan El POI, a la comunidad ID del coste, y el valor numérico de la comunidad del coste. La salida de muestra siguiente muestra que el vecino 172.16.1.2 lleva una comunidad del coste con un ID de 1 y un coste de 100:

Router# show ip bgp 10.0.0.0
BGP routing table entry for 10.0.0.0/8, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  2 2 2
    172.16.1.2 from 172.16.1.2 (172.16.1.2)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Extended Community: Cost:igp:1:100

Si configuran al vecino especificado con el valor numérico de la comunidad del costo predeterminado o si el valor predeterminado se asigna automáticamente para la evaluación de la comunidad del coste, “valor por defecto” con + y - los valores serán visualizados después del valor numérico de la comunidad del coste en la salida.

Adonde ir después

Para más información sobre el sitio del MPLS VPN PE-CE del EIGRP de la característica del origen (SoO), refiera “sitio del MPLS VPN PE-CE del EIGRP al módulo del origen (SoO)”.

Referencias adicionales

Para relacionado con la información adicional a la característica de la comunidad de costo BGP, refiera a las referencias siguientes:

Documentos Relacionados

Tema relacionado

Título del documento

Selección de mejor trayecto BGP

“Algoritmo de selección del mejor trayecto BGP”

Comandos BGP

Routing IP del Cisco IOS: Referencia del comando bgp

Estándares

Estándares

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para obtener listas de MIB soportadas por la versión de plataforma y laCisco IOS, y descargar módulos MIB, vaya al sitio web de Cisco MIB en Cisco.com en el URL siguiente:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC

Título

draft-retana-bgp-custom-decision-00.txt

Proceso de decisión de la aduana BGP

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Referencia de Comandos

Los siguientes comandos se introducen o se modifican en la característica o las características documentadas en este módulo. Para la información sobre estos comandos, vea el Routing IP del Cisco IOS: Referencia del comando bgp. Para obtener información sobre todos los comandos de Cisco IOS, vaya a la Command Lookup Tool disponible en http://tools.cisco.com/Support/CLILookup o a la Lista de Comandos Principal de Cisco IOS.

  • bgp bestpath la coste-comunidad ignora
  • debug ip bgp updates
  • fije el coste del extcommunity

Información sobre la Función BGP Cost Community

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información sobre la Función BGP Cost Community

Nombre de la función

Versiones

Información sobre la Función

BGP Cost Community

12.0(24)S 12.3(2)T 12.2(18)S 12.2(27)SBC 15.0(1)S

La función BGP Cost Community BGP introduce el atributo de la comunidad de costo ampliada. La comunidad de costo es un atributo de comunidad ampliada no transitivo que se pasa a los peers de BGP interno (iBGP) y confederación, pero no a los peers de BGP externo (eBGP). La función de comunidad de costo permite personalizar la preferencia de la ruta local e influir en el proceso de selección de la mejor trayectoria mediante la asignación de valores de costo a rutas específicas.

Se han insertado o modificado los siguientes comandos: bgp bestpath la coste-comunidad ignora, debug ip bgp updates, y coste del extcommunity del conjunto.

BGP Cost Community Support for EIGRP MPLS VPN PE-CE with Backdoor Links

12.0(27)S 12.3(8)T 12.2(25)S

El BGP preferirá los links de entrada posterior de una topología EIGRP MPLS VPN si se obtiene primero el link de entrada posterior. El punto de inserción "pre-bestpath" se insertó en la función BGP Cost Community para soportar topologías de red VPN EIGRP mixtas que contienen links de entrada posterior y VPN. Este POI se aplica automáticamente a las rutas EIGRP que se redistribuyen en el BGP y el POI influencia el proceso del cálculo del mejor trayecto influenciando el BGP para considerar este POI antes de cualquier otro paso de la comparación. No se requiere configuración. Esta característica se habilita automáticamente para los sitios del EIGRP VPN cuando el Cisco IOS Release 12.0(27)S, 12.3(8)T, 12,2(25)S o versiones posteriores, está instalado a un PE, a un CE, o a un router de la entrada posterior.

No se introdujo ni se modificó ningún comando.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.