Routing IP: Guía de configuración BGP, Cisco IOS Release 12.2SR
Configuración del Soporte BGP Multiprotocolo (MP-BGP) para el CLNS
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 363 KB | Inglés (8 Noviembre 2011) | Comentarios

Contenido

Configuración del Soporte BGP Multiprotocolo (MP-BGP) para el CLNS

Última actualización: De abril el 13 de 2012

Este módulo describe las tareas de configuración de configurar el soporte del Multiprotocol BGP (MP-BGP) para el CLNS, que proporciona la capacidad de escalar las redes del servicio de red sin conexión (CLNS). Las extensiones multiprotocolo del Border Gateway Protocol (BGP) añaden la capacidad de interconectar dominios de ruteo de interconexión de sistema abierto (OSI) separados sin fusionar los dominios de ruteo, proporcionando así la capacidad para construir redes OSI muy grandes.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Restricciones para Configurar el soporte MP-BGP para CLNS

La configuración del soporte MP-BGP para el CLNS no soporta la creación y el uso de las Confederaciones BGP dentro de la red CLNS. Recomendamos el uso de los reflectores de ruta de abordar la aplicación una malla grande del Internal BGP.

Esta característica no soportan a las comunidades ampliadas BGP.

Esta característica no soportan a los comandos bgp siguientes:

  • automóvil summary
  • hacer publicidad-mapa vecino
  • distribuir-lista vecina
  • reconfiguración suave vecina
  • unsuppress-mapa vecino

Información sobre la Configuración del Soporte de MP-BGP para CLNS

Información de ruteo de la familia del direccionamiento

Por abandono, los comandos entered bajo comando router bgp se aplican a la familia del direccionamiento del IPv4. Éste continuará siendo el caso a menos que usted no ingrese el ningún comando bgp default ipv4-unicast pues el primer comando bajo comando router bgp. Se configura el comando no bgp default ipv4-unicast en el router para inhabilitar el comportamiento predeterminado del proceso de ruteo BGP al intercambiar la información de direcciones IPv4 con los routers vecinos de BGP.

Funciones de Diseño del Soporte MP-BGP para CLNS

La configuración del soporte MP-BGP para el CLNS permite que el BGP sea utilizado como Routing Protocol del interdomain en las redes que utilizan el CLNS como el protocolo de capa de red. Esta característica fue desarrollada para solucionar un problema de ampliación con un Data Communications Network (DCN) donde un gran número de elementos de redes se manejan remotamente. Para más información sobre los problemas DCN y cómo implementar esta característica en una topología DCN, vea la topología de red DCN.”

El BGP, como Exterior Gateway Protocol, fue diseñado para manejar el volumen de información de ruteo generado por Internet. Los administradores de la red pueden controlar la información de BGP Routing porque vecino BGP que las relaciones (peering) se configuran manualmente y las actualizaciones de ruteo utilizan los broadcasts ampliados. Algunos Routing Protocol interiores tales como Intermediate System-to-Intermediate System (IS-IS), en cambio, utilizan una forma de técnica automática de la detección de vecino y de actualizaciones transmitidas a intervalos regulares.

El CLNS utiliza los direccionamientos del punto de acceso al servicio de red (NSAP) para identificar todos sus elementos de redes. Usando el soporte de la direccionamiento-familia BGP, los prefijos del NSAP Address se pueden transportar usando el BGP. En el CLNS, los prefijos BGP se insertan en la tabla del prefijo del nivel 2 CLNS. Estas funciones permiten que el BGP sea utilizado como Routing Protocol del interdomain entre los dominios de ruteo separados CLNS.

Implementar el BGP en el Routers en el borde de cada red interna significa que los protocolos interiores existentes no necesitan ser cambiados, interrupción de reducción al mínimo en la red.

Topología de Red CLNS BGP Genérica

La figura abajo muestra una red genérica BGP CLNS que contiene a nueve Routers que se agrupe en cuatro sistemas autónomos diferentes (en la terminología BGP) o los dominios de ruteo (en la terminología OSI). Para evitar la confusión, utilizaremos la terminología BGP de los sistemas autónomos porque cada sistema autónomo se numera y por lo tanto se identifica más fácilmente en el diagrama y en la discusión de la configuración.

Figura 1Componentes en una red genérica BGP CLNS


Dentro de cada sistema autónomo, el IS-IS se utiliza como el Routing Protocol del intradomain. Entre los sistemas autónomos, el BGP y sus Extensiones multiprotocol se utilizan como el Routing Protocol del interdomain. Cada router está ejecutando un BGP o el proceso de ruteo IS-IS del nivel 2. Para facilitar esta característica, los routeres BGP también están ejecutando un proceso IS-IS del nivel 2. Aunque los links no se muestren en la figura, cada router del nivel 2 IS-IS está conectado con el Routers del nivel múltiple 1 IS-IS que, a su vez, está conectado con las redes múltiples CLNS.

Cada sistema autónomo en este ejemplo se configura para demostrar las diversas características BGP y cómo estas características trabajan con el CLNS para proporcionar una solución scalable de la encaminamiento del interdomain. En la figura arriba, el sistema autónomo AS65101 tiene un router de un solo nivel de 2 IS-IS, r1, y está conectado con apenas otro sistema autónomo, AS65202. La Conectividad al resto de la red es proporcionada por el r2, y una ruta predeterminado se genera para que el r1 envíe al r2 todos los paquetes con los NSAP Address del destino fuera de AS65101.

En AS65202 hay dos Routers, r2 y R3, ambos con diversos vecinos del BGP externo (eBGP). El r2 del Routers y el R3 se configuran para ejecutar el Internal BGP (iBGP) sobre la conexión interna entre ellos.

AS65303 muestra cómo el uso de los grupos de peer de BGP y del Route Reflection puede minimizar la necesidad de las conexiones TCP entre el Routers. Menos conexiones entre el Routers simplifican el diseño de red y la cantidad de tráfico en la red.

AS65404 muestra cómo utilizar la redistribución para comunicar la información sobre el alcance de la red a un router del nivel 2 IS-IS que no esté ejecutando el BGP.

Las tareas de configuración y los ejemplos se basan en el diseño de red genérico mostrado en la figura arriba. Las configuraciones para todo el Routers en la figura antedicha se enumeran adentro.

Topología de red DCN

El soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS puede beneficiar a un DCN que maneja un gran número de anillos SONET remotos. SONET es utilizado típicamente por las compañías de telecomunicaciones para enviar los datos sobre las redes fibroópticas.

La figura abajo muestra algunos componentes de una red DCN. Para ser constante con la terminología BGP, la figura contiene las escrituras de la etiqueta para indicar tres sistemas autónomos en vez de los dominios de ruteo. Los elementos de redes--señalado por el NE en la figura 2--of un anillo SONET es manejado por los protocolos OSI tales como transferencia de archivos, acceso, y la Administración (FTAM) y el Protocolo de información de gestión común (CMIP). FTAM y el CMIP ejecutado sobre el protocolo de capa de red CLNS, así que significa que el Routers que proporciona a la Conectividad debe funcionar con un protocolo del OSI Routing.

Figura 2Componentes en una red DCN


El IS-IS es un Link-State Protocol usado en este ejemplo para rutear el CLNS. Cada nodo de la encaminamiento (dispositivo de interconexión de redes) se llama un sistema intermedio (ES). La red se divide en las áreas definidas como colección de Nodos de la encaminamiento. La encaminamiento dentro de un área se refiere como encaminamiento del nivel 1. La encaminamiento entre las áreas implica la encaminamiento del nivel 2. Definen al Routers que conecta un nivel 1 área a un nivel 2 áreas como 1-2 Router llanos. Un elemento de redes que conecta con los 2 Router llanos que proporcionan una trayectoria a la base DCN es representado por un elemento de red de gateway--GNE en el cuadro 2. La topología de red aquí es un link punto a punto entre cada router del elemento de redes. En este ejemplo, llaman un router del nivel 1 IS-IS un router NE.

Seleccionaron a routeres Cisco más pequeños tales como las Cisco 2600 Series ejecutarse como los 1-2 Router llanos porque el espacio del estante en la oficina de un proveedor de servicio es muy costoso. Un Cisco 2600 Series Router ha limitado la potencia de procesamiento si está actuando como el 1 Router llano para diverso nivel cuatro o cinco 1 área. El número de nivel 1 área bajo esta configuración se limita a cerca de 200. La red entera del nivel 2 también es limitada por la velocidad del 2 Router llano más lento.

Para proporcionar la Conectividad entre el Routers NE, se utiliza el señalización dentro de la banda. El señalización dentro de la banda se lleva adentro la trama de la jerarquía digital SONET/Synchronous (SDH) en el Data Communications Channel (DCC). El DCC es un canal 192-KB, que es mismo cantidades limitadas de ancho de banda para el tráfico de administración. Debido al ancho de banda limitado de la señalización entre los elementos de redes y las cantidades limitadas de potencia de procesamiento y la memoria en el Routers NE que ejecuta el IS-IS, la cada área se restringe a un número máximo de 30 a los 40 Router. Por término medio, cada anillo SONET consiste en 10 a 15 elementos de redes.

Con un máximo de 200 áreas que contienen 10 a 15 elementos de redes por el área, el número total de Routers del elemento de redes en un solo sistema autónomo debe ser menos que 3000. Los proveedores de servicio están mirando para implementar sobre 10.000 elementos de redes mientras que sus redes crecen, pero el número potencial de elementos de redes en un área es limitado. La Solución actual es analizar el DCN en varios sistemas autónomos más pequeños y conectarlos usando las Static rutas o el Interior Gateway Routing Protocol (IGRP) ISO. El ISO IGRP es un protocolo de propietario que puede limitar la opción de implementación futura del equipo. El Static Routing no escala porque el crecimiento en la red puede exceder la capacidad de un administrador de la red de mantener las Static rutas. El BGP se ha mostrado para escalar sobre a 100.000 rutas.

Para implementar el soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS en este ejemplo, configuración BGP para ejecutarse en cada router en la base network--AS64800 DCN en la figura información de ruteo del intercambio 2--to entre todos los sistemas autónomos. En los sistemas autónomos AS64600 y AS64700, solamente los 2 Router llanos ejecutarán el BGP. El BGP utiliza el TCP para comunicar con los routeres vecinos de BGP-discurso, así que significa que una red direccionado por IP y una red NSAP-dirigida se deben configurar para cubrir a todo el Routers del nivel 2 IS-IS en los sistemas autónomos AS64600 y AS64700 y todo el Routers en la red del núcleo DCN.

Si se asume eso cada sistema autónomo--por ejemplo, AS64600 y AS64700 en la figura 2--remains los mismos tamaños con hasta 3000 Nodos, podemos demostrar cómo las redes grandes DCN se pueden soportar con esta característica. Cada sistema autónomo hace publicidad de un prefijo de dirección al sistema autónomo de la base. Cada prefijo de dirección puede tener dos trayectorias asociadas a él para proporcionar la Redundancia porque hay dos links entre cada sistema autónomo y el sistema autónomo de la base. El BGP se ha mostrado para soportar 100.000 rutas, así que el sistema autónomo de la base puede soportar muchos otros sistemas autónomos directamente enlazados porque cada sistema autónomo genera solamente algunas rutas. Podemos asumir que el sistema autónomo de la base puede soportar cerca de 2000 sistemas autónomos directamente enlazados. Con diseño de hub y spoke donde cada sistema autónomo se enlaza directamente al sistema autónomo de la base, y no actuando como sistema autónomo del transitar, el sistema autónomo de la base puede generar una ruta predeterminado a cada sistema autónomo enlazado. Usando las rutas predeterminado, los 2 Router llanos en los sistemas autónomos enlazados procesan solamente los muy poco de información de ruteo adicional. Multiplicar los 2000 sistemas autónomos enlazados por los 3000 Nodos dentro de cada sistema autónomo podía permitir hasta 6 millones de elementos de redes.

Beneficios del Soporte MP-BGP para CLNS

El soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS agrega la capacidad de interconectar los dominios separados del OSI Routing sin la combinación de los dominios de ruteo, que proporciona la capacidad para construir las redes muy grandes OSI. Las ventajas de usar esta característica no se confinan a las redes DCN, y se pueden implementar para ayudar a escalar cualquier red usando los protocolos del OSI Routing con el CLNS.

Cómo Configurar MP-BGP Support for CLNS

En esta sección se presentan los siguientes procedimientos. Puede no ser necesario pasar con cada procedimiento para su red determinada. Usted debe realizar los pasos en los procedimientos requeridos, pero el resto de los procedimientos se hacen como sea necesario para su red.

Configurando y activando a un vecino BGP para soportar el CLNS

Para configurar y activar un proceso de ruteo y a un vecino BGP asociado (par) BGP para soportar el CLNS, realice los pasos en este procedimiento.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. vecino {IP address | par-grupo-nombre} telecontrol-como el como-número

6. [unicast] del nsap de la direccionamiento-familia

7. el neighbor ip-address activa

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65101 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router.

  • El argumento del como-número identifica el sistema autónomo en el cual el router reside. Los valores válidos son a partir la 0 a 65535. Los números privados del sistema autónomo que se pueden utilizar en redes internas van del 64512 al 65535.
 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 5
neighbor {ip-address | par-grupo-nombre} telecontrol-como el como-número


Ejemplo:

Router (config-router) # vecino 10.1.2.2 telecontrol-como 64202

 

Añade una dirección IP o el nombre de grupo de peers del vecino BGP al sistema autónomo especificado en la tabla de vecinos BGP del router local.

 
Paso 6
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica la familia de direcciones NSAP e ingresa en el modo de configuración de la familia de direcciones.

  • La palabra clave opcional unicast especifica los prefijos de dirección unicast NSAP. Por abandono, colocan al router en el modo de configuración para la familia del NSAP Address del unicast si la palabra clave del unicast no se especifica con el comando nsap de la direccionamiento-familia.
 
Paso 7
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 10.1.2.2 activa

 

Permite al vecino BGP intercambiar prefijos de la familia de direcciones NSAP con el router local.

Nota    Si usted ha configurado a un grupo de peer como vecino BGP, usted no utiliza este comando porque los grupos de peer se activan automáticamente cuando se configura cualquier parámetro del grupo de peer.
 
Paso 8
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Configurar un proceso de ruteo IS-IS

Cuando se configura un proceso de ruteo IS-IS integrado, el primer caso del proceso de ruteo IS-IS configurado es por abandono un router del nivel 1-2 (intra-area y interarea). Todos los procesos de ruteo IS-IS subsiguientes de una red en la que se ejecuta CLNSP se configuran como Nivel 1. Todos los procesos de ruteo IS-IS subsiguientes de una red en la que se ejecuta IP se configuran como Nivel-1-2. Para utilizar el soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS, configure un proceso de ruteo del nivel 2.

Para configurar un proceso de ruteo IS-IS y asignarlo como proceso Level-2-only, realice los pasos en este procedimiento.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. área-etiqueta ISIS del router

4. título de entidad de la red neto

5. ser-tipo [level-1 | level-1-2 | level-2-only]

6. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
área-etiqueta ISIS del router


Ejemplo:

ISIS osi-as-101 del router de Router(config)#

 

Configura un proceso de ruteo IS-IS e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

  • El argumento de la área-etiqueta es un nombre significativo para un proceso de ruteo. Debe ser único entre todos los procesos de ruteo IP y CLNS para un router dado.
 
Paso 4
título de entidad de la red neto


Ejemplo:

Router (config-router) # red 49.0101.1111.1111.1111.1111.00

 

Configura un título de entidad de red (NET) para el proceso de ruteo. Si está configurando un IS-IS multiárea, debe especificar un NET para cada proceso de ruteo.

 
Paso 5
ser-tipo [level-1 | level-1-2 | level-2-only]


Ejemplo:

Router (config-router) # ser-tipo level-1

 

Configura al router para actuar como router del nivel 1 (intra-area), como un 1 Router llano y router del nivel 2 (interarea), o como router del interarea solamente.

  • En configuraciones IS-IS del multiarea, el primer caso del proceso de ruteo IS-IS configurado es por abandono un router del nivel 1-2 (intra-area y interarea). Todos los procesos de ruteo IS-IS subsiguientes de una red en la que se ejecuta CLNSP se configuran como Nivel 1. Todos los procesos de ruteo IS-IS subsiguientes de una red en la que se ejecuta IP se configuran como Nivel-1-2.
 
Paso 6
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Configurando las interfaces que conectan con los vecinos BGP

Cuando un router que ejecuta el IS-IS está conectado directamente con un vecino eBGP, la interfaz entre los dos vecinos eBGP se activa usando el comando clns enable, que permite que los paquetes CLNS sean remitidos a través de la interfaz. El comando clns enable activa el protocolo del sistema a sistema intermedio de extremo (ES-IS) para buscar para los sistemas vecinos OSI.


Nota


El IS-IS que se ejecuta a través de la misma interfaz que está conectada con un vecino eBGP puede llevar a los resultados no deseables si los dos dominios del OSI Routing se combinan en un solo dominio.

Cuando se encuentra un sistema vecino OSI, los controles BGP que es también un vecino eBGP configuraron para la familia del NSAP Address. Si ambas las se cumplen condiciones precedentes, el BGP crea una ruta especial del vecino BGP en la tabla de ruteo del prefijo del nivel 2 CLNS. La ruta especial del vecino BGP se redistribuye automáticamente adentro a las actualizaciones de ruteo del nivel 2 de modo que el resto del Routers del nivel 2 IS-IS en el dominio de ruteo local OSI sepa alcanzar a este vecino eBGP.

Para configurar las interfaces que se están utilizando para conectar con los vecinos eBGP, realice los pasos en este procedimiento. Estas interfaces serán conectadas normalmente directamente con su vecino eBGP.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. máscara del IP address del IP Address

5. permiso del clns

6. ningún apague

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Serial 2/0 de la interfaz de Router(config)#

 

Especifica el tipo de interfaz y el número y ingresa al modo de configuración de la interfaz.

 
Paso 4
máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 10.1.2.2 255.255.255.0

 

Configura la interfaz con una dirección IP.

 
Paso 5
permiso del clns


Ejemplo:

Router (config-if) # permiso del clns

 

Especifica que los paquetes CLNS se pueden remitir a través de esta interfaz. El protocolo ES-IS se activa y comienza a buscar para los sistemas adyacentes OSI.

 
Paso 6
ningún apague


Ejemplo:

El router (config-if) # ningún apaga

 

Activa la interfaz.

 
Paso 7
Finalizar


Ejemplo:

Router(config-if)#end

 

Salidas modo de configuración de la interfaz y devoluciones al modo EXEC privilegiado.

 

Configurando las interfaces conectadas con el dominio de ruteo local OSI

Para configurar las interfaces que están conectadas con el dominio de ruteo local OSI, realice los pasos en este procedimiento.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. máscara del IP address del IP Address

5. área-etiqueta ISIS del router del clns

6. área-etiqueta ISIS del router del IP

7. ningún apague

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interfaces Ethernet 0/1 de Router(config)#

 

Especifica el tipo de interfaz y el número y ingresa al modo de configuración de la interfaz.

 
Paso 4
máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 10.2.3.1 255.255.255.0

 

Configura la interfaz con una dirección IP.

Nota    Se requiere este paso solamente cuando las necesidades de la interfaz de comunicar con un vecino iBGP.
 
Paso 5
área-etiqueta ISIS del router del clns


Ejemplo:

Router (config-if) # ISIS osi-as-202 del router del clns

 

Especifica que la interfaz está ruteando activamente el IS-IS cuando el Network Protocol es ISO CLNS e identifica el área asociada a este proceso de ruteo.

 
Paso 6
área-etiqueta ISIS del router del IP


Ejemplo:

Router (config-if) # ISIS osi-as-202 del router del IP

 

Especifica que la interfaz está ruteando activamente el IS-IS cuando el Network Protocol es IP e identifica el área asociada a este proceso de ruteo.

Nota    Se requiere este paso solamente cuando las necesidades de la interfaz de comunicar con un vecino iBGP, y el IGP es IS-IS.
 
Paso 7
ningún apague


Ejemplo:

El router (config-if) # ningún apaga

 

Activa la interfaz.

 
Paso 8
Finalizar


Ejemplo:

Router(config-if)#end

 

Salidas modo de configuración de la interfaz y devoluciones al modo EXEC privilegiado.

 

Publicidad de los prefijos del establecimiento de una red

La publicidad del prefijo del NSAP Address fuerza los prefijos a ser agregada a la tabla de BGP Routing. Para configurar el anuncio de los prefijos del establecimiento de una red, realice los pasos en este procedimiento.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. vecino {IP address | par-grupo-nombre} telecontrol-como el como-número

6. [unicast] del nsap de la direccionamiento-familia

7. [route-map map-tag] del NSAP-prefijo de la red

8. el neighbor ip-address activa

9. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65101 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 5
neighbor {ip-address | par-grupo-nombre} telecontrol-como el como-número


Ejemplo:

Router (config-router) # vecino 10.1.2.2 telecontrol-como 64202

 

Añade una dirección IP o el nombre de grupo de peers del vecino BGP al sistema autónomo especificado en la tabla de vecinos BGP del router local.

 
Paso 6
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica la familia de direcciones NSAP e ingresa en el modo de configuración de la familia de direcciones.

  • La palabra clave opcional unicast especifica los prefijos de dirección unicast NSAP. Por abandono, colocan al router en el modo de configuración de la familia del NSAP Address del unicast si la palabra clave del unicast no se especifica con el comando nsap de la direccionamiento-familia.
 
Paso 7
[route-map map-tag] del NSAP-prefijo de la red


Ejemplo:

Router (config-router-AF) # red 49.0101.1111.1111.1111.1111.00

 

Hace publicidad de un solo prefijo del dominio de ruteo local OSI y lo ingresa en la tabla de BGP Routing.

Nota    Es posible hacer publicidad de un solo prefijo, en este caso este prefijo podría ser el prefijo único del NSAP Address del dominio de ruteo local OSI. Alternativamente, los prefijos más largos múltiples, cada cubierta a la pequeña porción del dominio de ruteo OSI, se pueden utilizar para hacer publicidad selectivamente de diversas áreas.
  • La publicidad de los prefijos del NSAP Address puede ser controlada usando la palabra clave opcional del route-map. Si no se especifica ningún Route Map, se redistribuyen todos los prefijos del NSAP Address.
 
Paso 8
el neighbor ip-address activa


Ejemplo:

El vecino 10.1.2.2 del router (config-router-AF) activa

 

Especifica que la información de ruteo NSAP será enviada al vecino BGP especificado.

Nota    Vea la descripción del comando neighbor en los documentos enumerados en las “referencias adicionales” para más detalles en el uso de este comando.
 
Paso 9
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Redistribución de las rutas del BGP en el IS-IS

La redistribución de ruta se debe acercar con cautela. No recomendamos el inyectar del Conjunto completo de las rutas BGP en el IS-IS porque el tráfico excesivo de la encaminamiento será agregado al IS-IS. Los route maps se pueden utilizar para controlar qué rutas dinámicas se redistribuyen.

Para configurar la redistribución de ruta del BGP en el IS-IS, realice los pasos en este procedimiento.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. área-etiqueta ISIS del router

4. título de entidad de la red neto

5. redistribuya el [route-map map-tag] del [route-type] del como-número del protocolo

6. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
área-etiqueta ISIS del router


Ejemplo:

ISIS osi-as-404 del router de Router(config)#

 

Configura un proceso de ruteo IS-IS e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

Nota    Usted no puede redistribuir las rutas BGP en un proceso de ruteo IS-IS del nivel 1-only.
 
Paso 4
título de entidad de la red neto


Ejemplo:

Router (config-router) # red 49.0404.7777.7777.7777.7777.00

 

Configura un título de entidad de red (NET) para el proceso de ruteo. Si está configurando un IS-IS multiárea, debe especificar un NET para cada proceso de ruteo.

 
Paso 5
redistribuya el [route-map map-tag] del [route-type] del como-número del protocolo


Ejemplo:

El router (config-router) # redistribuye el clns BGP 65404

 

Redistribuye las rutas del prefijo NSAP del BGP en la tabla de ruteo del nivel 2 CLNS asociada al proceso de ruteo IS-IS cuando el argumento del protocolo se fija al bgpand que el argumento del route tipo se fija al clns.

  • El argumento del como-número se define como el número del sistema autónomo del proceso de ruteo BGP que se redistribuirá en el CLNS.
  • Es posible controlar la redistribución de las rutas mediante el uso de la palabra clave opcional route-map. Si no se especifica ningún Route Map, se redistribuyen todas las rutas BGP.
 
Paso 6
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Redistribución de las rutas del IS-IS en el BGP

La redistribución de ruta debe ser acercada con cautela porque la información de la ruta redistribuido se salva en las tablas de ruteo. Las tablas de ruteo grandes pueden hacer el proceso de ruteo más lento. Los route maps se pueden utilizar para controlar qué rutas dinámicas se redistribuyen.

Para configurar la redistribución de ruta del IS-IS en el BGP, realice los pasos en este procedimiento.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. [unicast] del nsap de la direccionamiento-familia

6. redistribuya el [route-map map-tag] del [route-type] del [process-id] del protocolo

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65202 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 5
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica la familia de direcciones NSAP e ingresa en el modo de configuración de la familia de direcciones.

 
Paso 6
redistribuya el [route-map map-tag] del [route-type] del [process-id] del protocolo


Ejemplo:

El router (config-router-AF) # redistribuye las interno-rutas-solamente del route-map del clns ISIS osi-as-202

 

Redistribuye las rutas de la tabla de ruteo del nivel 2 CLNS asociada al proceso de ruteo IS-IS en el BGP mientras que los prefijos NSAP cuando el argumento del protocolo se fija al isisand el argumento del route tipo se fijan al clns.

  • El argumento proceso-identificación se define como el nombre del área para que el proceso de ruteo IS-IS relevante sea redistribuido.
  • Es posible controlar la redistribución de las rutas mediante el uso de la palabra clave opcional route-map. Si no se especifica ningún Route Map, se redistribuyen todas las rutas del nivel 2.
 
Paso 7
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Configuración de Grupos de Peers BGP y Reflectores de Ruta

Los grupos de peer de BGP reducen el número de comandos configuration aplicando un comando del vecino BGP a los varios vecinos. Usando un grupo de peer de BGP con un router local configurado como reflector de la ruta BGP permite la información de BGP Routing recibida a partir de un miembro del grupo que se replicará al resto de los miembros del grupo. Sin un grupo de peer, cada Route Reflector Client debe ser especificado por la dirección IP.

Para crear a un grupo de peer de BGP y utilizar al grupo como cliente del reflector de la ruta BGP, realice los pasos en este procedimiento. Esto es una tarea optativa y se utiliza con los vecinos del Internal BGP. En esta tarea, algo del sintaxis BGP se muestra con el argumento del par-grupo-nombre solamente y configuran a solamente un vecino como miembro del grupo de peer. Relance el paso 9 para configurar a otros vecinos BGP como miembros del grupo de peer.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. grupo de peers del par-grupo-nombre del vecino

6. par-grupo-nombre del vecino telecontrol-como el como-número

7. [unicast] del nsap de la direccionamiento-familia

8. ruta-reflector-cliente del par-grupo-nombre del vecino

9. grupo de peers del grupo de peers del neighbor ip-address

10. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65303 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 5
grupo de peers vecino del par-grupo-nombre


Ejemplo:

Router (config-router) # grupo de peers de los iBGP-pares del vecino

 

Crea un grupo de peers de BGP.

 
Paso 6
par-grupo-nombre vecino telecontrol-como el como-número


Ejemplo:

Router (config-router) # iBGP-pares vecinos telecontrol-como 65303

 

Agrega el nombre de grupo de peer del vecino BGP en el sistema autónomo especificado a la tabla del vecino BGP del router local.

 
Paso 7
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica la familia de direcciones NSAP e ingresa en el modo de configuración de la familia de direcciones.

 
Paso 8
ruta-reflector-cliente vecino del par-grupo-nombre


Ejemplo:

Router (config-router-AF) # ruta-reflector-cliente de los iBGP-pares del vecino

 

Configura al router como reflector de la ruta BGP y configura al grupo de peer especificado como su cliente.

 
Paso 9
grupo de peers del grupo de peers del neighbor ip-address


Ejemplo:

Router (config-router-AF) # iBGP-pares del grupo de peers de 10.4.5.4 del vecino

 

Asigna un vecino BGP a un grupo de peers BGP.

 
Paso 10
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Rutas entrantes de filtración basadas en los prefijos NSAP

Realice esta tarea de filtrar las rutas BGP entrantes basadas en los prefijos NSAP. La lista de prefijo vecina en el comando se configura en el modo de configuración de la familia del direccionamiento para filtrar las rutas entrantes.

Antes de comenzar

Usted debe especificar un conjunto de filtros CLNS o una expresión de filtro CLNS antes de configurar el comando neighbor. Vea las descripciones para el filtro-expr y los comandos clns filter-set del clns para más información.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. [unicast] del nsap de la direccionamiento-familia

6. vecino {IP address| peer-group-name} prefix-list {clns-filter-expr-name| clns-filtro-conjunto-nombre} adentro

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65200 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 5
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica a la familia del direccionamiento y ingresa al modo de configuración de la familia del direccionamiento.

 
Paso 6
neighbor {ip-address| peer-group-name} prefix-list {clns-filter-expr-name| clns-filtro-conjunto-nombre} adentro


Ejemplo:

Router (config-router-AF) # ABC de la lista de prefijo de 10.23.4.1 del vecino adentro

 

Especifica un conjunto de filtros CLNS o la expresión de filtro CLNS que se utilizarán para filtrar las rutas BGP entrantes.

  • El argumento clns-filter-expr-name se define con el comando de configuración clns filter-expr .
  • El argumento clns-filter-set-name se define con el comando de configuración clns filter-set.
 
Paso 7
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Actualizaciones de BGP salientes de filtración basadas en los prefijos NSAP

Realice esta tarea de filtrar las actualizaciones de BGP salientes basadas en los prefijos NSAP, utilice el comando out vecino de la lista de prefijo en el modo de configuración de la familia del direccionamiento. Esta tarea se configura en el router 7 en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”). En esta tarea se crea un filtro de CLNS con dos entradas para negar los prefijos NSAP que comiencen por 49.0404 y para permitir los demás prefijos NSAP que comiencen por 49. Se crea un grupo de peers BGP y se aplica el filtro a las actualizaciones de BGP de salida para el vecino que es miembro del grupo de peers.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. plantilla del [deny] del nombre del clns filter-set

4. plantilla del [permit] del nombre del clns filter-set

5. como-número BGP del router

6. ningún valor por defecto ipv4-unicast BGP

7. grupo de peers del par-grupo-nombre del vecino

8. vecino {IP address | par-grupo-nombre} telecontrol-como el como-número

9. [unicast] del nsap de la direccionamiento-familia

10. vecino {IP address | peer-group-name} prefix-list {clns-filter-expr-name | clns-filtro-conjunto-nombre} hacia fuera

11 grupo de peers del grupo de peers del neighbor ip-address

12.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
plantilla del [deny] del nombre del clns filter-set


Ejemplo:

El clns filter-set routes0404 de Router(config)# niega 49,0404…

 

Define una coincidencia del prefijo NSAP para una condición de la negación para el uso en las expresiones de filtro CLNS.

  • En este ejemplo, se vuelve una acción de la negación si un direccionamiento comienza con 49,0404.
 
Paso 4
plantilla del [permit] del nombre del clns filter-set


Ejemplo:

Permiso 49 del clns filter-set routes0404 de Router(config)#…

 

Define una coincidencia del prefijo NSAP para una condición de permiso para el uso en las expresiones de filtro CLNS.

  • En este ejemplo, se vuelve una acción del permiso si un direccionamiento comienza con 49.
Nota    Aunque el ejemplo del permiso en este paso permita todos los NSAP Address que comienzan con 49, la condición de la coincidencia en el paso 3 se procesa primero así que los NSAP Address que comienzan con 49,0404 todavía se niegan.
 
Paso 5
como-número BGP del router


Ejemplo:

BGP 65404 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 6
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 7
grupo de peers vecino del par-grupo-nombre


Ejemplo:

Router (config-router) # grupo de peers de los eBGP-pares del vecino

 

Crea un grupo de peers de BGP.

  • En este ejemplo, crean al grupo de peer de BGP nombrado los eBGP-pares.
 
Paso 8
neighbor {ip-address | par-grupo-nombre} telecontrol-como el como-número


Ejemplo:

Router (config-router) # eBGP-pares vecinos telecontrol-como 65303

 

Añade una dirección IP o el nombre de grupo de peers del vecino BGP al sistema autónomo especificado en la tabla de vecinos BGP del router local.

  • En este ejemplo, agregan al grupo de peer nombrado los eBGP-pares a la tabla del vecino BGP.
 
Paso 9
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica la familia de direcciones NSAP e ingresa en el modo de configuración de la familia de direcciones.

 
Paso 10
neighbor {ip-address | peer-group-name} prefix-list {clns-filter-expr-name | clns-filtro-conjunto-nombre} hacia fuera


Ejemplo:

Router (config-router-AF) # lista de prefijo routes0404 de los eBGP-pares del vecino hacia fuera

 

Especifica un conjunto de filtros CLNS o la expresión de filtro CLNS que se utilizarán para filtrar las actualizaciones de BGP salientes.

  • El argumento clns-filter-expr-name se define con el comando de configuración clns filter-expr .
  • El argumento clns-filter-set-name se define con el comando de configuración clns filter-set.
  • En este ejemplo, el conjunto de filtros nombrado routes0404 fue creado en Step3 y el paso 4.
 
Paso 11
grupo de peers del grupo de peers del neighbor ip-address


Ejemplo:

Router (config-router-AF) # eBGP-pares del grupo de peers de 10.6.7.8 del vecino

 

Asigna un vecino BGP a un grupo de peers BGP.

 
Paso 12
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Originar las rutas predeterminado para un dominio de ruteo vecino

Para crear una ruta del valor por defecto CLNS que señale al router local en nombre de un dominio de ruteo vecino OSI, realice los pasos en este procedimiento. Esto es una tarea optativa y se utiliza normalmente solamente con los vecinos del BGP externo.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. [unicast] del nsap de la direccionamiento-familia

6. vecino {IP address | el par-grupo-nombre} valor por defecto-origina el [route-map map-tag]

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 64803 del router de Router(config)#

 

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita el comportamiento predeterminado del proceso de ruteo BGP intercambiando información de direccionamiento IPv4 con los routers vecinos BGP.

 
Paso 5
[unicast] del nsap de la direccionamiento-familia


Ejemplo:

Router (config-router) # nsap de la direccionamiento-familia

 

Especifica la familia de direcciones NSAP e ingresa en el modo de configuración de la familia de direcciones.

 
Paso 6
neighbor {ip-address | el par-grupo-nombre} valor por defecto-origina el [route-map map-tag]


Ejemplo:

El router (config-router-AF) # vecino 172.16.2.3 valor por defecto-origina

 

Genera una ruta del valor por defecto CLNS que señale al router local y que sea hecha publicidad al dominio de ruteo vecino OSI.

 
Paso 7
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones y vuelve al modo EXEC privilegiado.

 

Verificar el soporte MP-BGP para el CLNS

Para verificar la configuración, utilice el comando exec de los ejecutar-config de la demostración. La salida de muestra está situada en el soporte MP-BGP que implementa por el ejemplo CLNS. Para verificar que el soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS esté funcionando, realice los pasos siguientes.

PASOS SUMARIOS

1. muestre a los vecinos del clns

2. muestre la ruta del clns

3. muestre el resumen del unicast del nsap BGP

4. Ingrese el comando del unicast del nsap BGP de la demostración de visualizar todas las rutas del prefijo NSAP que el router local ha descubierto. En el siguiente ejemplo de la salida del r2 del router, mostrado en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”), se muestra una sola ruta válido para prefijar 49,0101. Dos rutas válido--marcado por a *--se muestran para el prefijo 49,0404. La segunda ruta se marca con una secuencia del *>i, representando la mejor ruta a este prefijo.


PASOS DETALLADOS
Paso 1   muestra los vecinos del clns

Utilice este comando de confirmar que el router local ha formado todas las adyacencias necesarias IS-IS con el otro Routers del nivel 2 IS-IS en el dominio de ruteo local OSI. Si el router local tiene algunos pares directamente conectados del BGP externo, la salida de este comando mostrará que han descubierto a los vecinos externos, bajo la forma de adyacencias ES-IS.

En el siguiente ejemplo, la salida se visualiza para el r2 del router, mostrado en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”). El r2 tiene tres vecinos CLNS. El r1 y el R4 son vecinos ES-IS porque estos Nodos están en los sistemas autónomos diferentes del r2. El R3 es un vecino IS-IS porque está en el mismo sistema autónomo como r2. Observe que el ID del sistema es substituido por los nombres de host CLNS (r1, r3, y r4) que se definen al inicio de cada archivo de configuración. Especificar el nombre de host CLNS significa que usted no necesita recordar qué ID del sistema corresponde a qué nombre de host.



Ejemplo:
 
Router# show clns neighbors
Tag osi-as-202:
System Id      Interface   SNPA                State  Holdtime  Type Protocol
r1             Se2/0       *HDLC*              Up     274       IS   ES-IS
r3             Et0/1       0002.16de.8481      Up     9         L2   IS-IS
r4             Se2/2       *HDLC*              Up     275       IS   ES-IS
Paso 2   muestre la ruta del clns

Utilice este comando de confirmar que el router local ha calculado las rutas a otras áreas en el dominio de ruteo local OSI. En el siguiente ejemplo de la salida del r2 del router, mostrado en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”), la entrada de la tabla de ruteo--i 49.0202.3333 [110/10] vía R3--shows que el r2 del router sabe sobre otras áreas locales IS-IS dentro del dominio de ruteo local OSI.



Ejemplo:
 
Router# show clns route
Codes: C - connected, S - static, d - DecnetIV
       I - ISO-IGRP,  i - IS-IS,  e - ES-IS
       B - BGP,       b - eBGP-neighbor
C  49.0202.2222 [2/0], Local IS-IS Area
C  49.0202.2222.2222.2222.2222.00 [1/0], Local IS-IS NET
b  49.0101.1111.1111.1111.1111.00 [15/10]
      via r1, Serial2/0
i  49.0202.3333 [110/10]
      via r3, Ethernet0/1
b  49.0303.4444.4444.4444.4444.00 [15/10]
      via r4, Serial2/2
B  49.0101 [20/1]
      via r1, Serial2/0
B  49.0303 [20/1]
      via r4, Serial2/2
B  49.0404 [200/1]
      via r9
i  49.0404.9999.9999.9999.9999.00 [110/10]
      via r3, Ethernet0/1
Paso 3   muestre el resumen del unicast del nsap BGP

Utilice este comando de verificar que la conexión TCP a un vecino particular es activa. En la salida de siguiente ejemplo, busque la fila apropiada basada en la dirección IP del vecino. Si es la entrada de la columna del estado/de PfxRcd un número, incluyendo cero, la conexión TCP para ese vecino es activo.



Ejemplo:
 
Router# show bgp nsap unicast summary
BGP router identifier 10.1.57.11, local AS number 65202
BGP table version is 6, main routing table version 6
5 network entries and 8 paths using 1141 bytes of memory
6 BGP path attribute entries using 360 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 5/0 prefixes, 8/0 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.2.1        4 65101      34      34        6    0    0 00:29:11        1
10.2.3.3        4 65202      35      36        6    0    0 00:29:16        3
Paso 4   Ingrese el comando del unicast del nsap BGP de la demostración de visualizar todas las rutas del prefijo NSAP que el router local ha descubierto. En el siguiente ejemplo de la salida del r2 del router, mostrado en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”), se muestra una sola ruta válido para prefijar 49,0101. Dos rutas válido--marcado por a *--se muestran para el prefijo 49,0404. La segunda ruta se marca con una secuencia del *>i, representando la mejor ruta a este prefijo.

Ejemplo:
 
Router# show bgp nsap unicast
BGP table version is 3, local router ID is 192.168.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 49.0101          49.0101.1111.1111.1111.1111.00
                                                           0 65101 i
* i49.0202.2222     49.0202.3333.3333.3333.3333.00
                                                  100      0 ?
*>                  49.0202.2222.2222.2222.2222.00
                                                       32768 ?
* i49.0202.3333     49.0202.3333.3333.3333.3333.00
                                                  100      0 ?
*>                  49.0202.2222.2222.2222.2222.00
                                                       32768 ?
*> 49.0303          49.0303.4444.4444.4444.4444.00
                                                           0 65303 i
*  49.0404          49.0303.4444.4444.4444.4444.00
                                                           0 65303 65404 i
*>i                 49.0404.9999.9999.9999.9999.00
                                                  100      0 65404 i

Localización de averías del soporte MP-BGP para el CLNS

La salida de diagnóstico del permiso de los unicastcommands del nsap BGP del debug referente a los diversos eventos referentes a la operación de los paquetes CLNS en el Routing Protocol BGP que se visualizará en una consola. Estos comandos se piensan solamente para los propósitos de Troubleshooting porque el volumen de salida generado por el software cuando se utilizan puede dar lugar a la degradación grave del rendimiento en el router. Vea la referencia del comando Debug del Cisco IOS para más información sobre usar estos comandos debug.

Para resolver problemas los problemas con la configuración del soporte MP-BGP para el CLNS y minimizar el impacto de los debugcommands usados en este procedimiento, realice los pasos siguientes.

PASOS SUMARIOS

1. Asocie una consola directamente a un router que funciona con la versión de Cisco IOS Software que incluye el soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS.

2. ninguna consola de registro

3.    Utilice Telnet para acceder un puerto de router.

4. permiso

5. monitor terminal

6. unicast del nsap BGP del debug [dirección de vecino | humedecimiento | Keepalives | actualizaciones]

7. ningún monitor terminal

8. ningún unicast del nsap BGP del debug [dirección de vecino | humedecimiento | Keepalives | actualizaciones]

9. consola de registro


PASOS DETALLADOS
Paso 1   Asocie una consola directamente a un router que funciona con la versión de Cisco IOS Software que incluye el soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS.
Nota    Este procedimiento minimizará la carga en el router creado por los comandos del unicast del nsap BGP del debug porque el puerto de la consola generará no más las interrupciones del procesador del carácter-por-carácter. Si no se puede conectar directamente con una consola, se puede ejecutar este procedimiento a través de un servidor terminal. Si usted debe romper la conexión Telnet, sin embargo, usted no puede poder volver a conectar porque el router puede no poder responder debido a la carga del procesador de generar la salida del unicast del nsap BGP del debug.
Paso 2   ninguna consola de registro

Este comando inhabilita todo el registro a la terminal de la consola.

Paso 3   Utilice Telnet para acceder un puerto de router.
Paso 4   permiso

Ingrese este comando de acceder al modo EXEC privilegiado.

Paso 5   monitor terminal

Este comando habilita la apertura de sesión del Terminal virtual.

Paso 6   unicast del nsap BGP del debug [dirección de vecino | humedecimiento | Keepalives | actualizaciones]

Ingrese solamente los unicastcommands específicos del nsap BGP del debug para aislar la salida a cierto subcomponente y para minimizar la carga en el procesador. Use argumentos y palabras clave apropiados para generar una información de debug más detallada sobre los subcomponentes especificados.

Paso 7   ningún monitor terminal

Este comando inhabilita la apertura de sesión del Terminal virtual.

Paso 8   ningún unicast del nsap BGP del debug [dirección de vecino | humedecimiento | Keepalives | actualizaciones]

Ingrese el específico ningún unicastcommand del nsap BGP del debug cuando le acaban.

Paso 9   consola de registro

Este comando vuelve a permitir el registro a la consola.


Ejemplos de Configuración del Soporte de MP-BGP para CLNS

Esta sección proporciona los ejemplos de configuración para hacer juego las tareas de configuración identificadas en la sección anterior. Para proporcionar una descripción de todas las configuraciones del router en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”), más configuraciones detalladas para cada router se agregan en el extremo de esta sección.

Configurando y activando a un vecino BGP para soportar el ejemplo CLNS

En el siguiente ejemplo, el r1 del router, mostrado en la figura abajo, en el sistema autónomo AS65101 se configura para ejecutar el BGP y se activa para soportar el CLNS. El r1 del router es el único router del nivel 2 IS-IS en el sistema autónomo AS65101, y tiene solamente una conexión a otro sistema autónomo vía el r2 del router en AS65202. Se configura el comando no bgp default ipv4-unicast en el router para inhabilitar el comportamiento predeterminado del proceso de ruteo BGP al intercambiar la información de direcciones IPv4 con los routers vecinos de BGP. Después de que habiliten al modo de configuración de la familia del NSAP Address con el comando nsap de la direccionamiento-familia, configuran al router para hacer publicidad del prefijo NSAP de 49,0101 a sus vecinos BGP y para enviar la información de ruteo NSAP al vecino BGP en 10.1.2.2.

router bgp 65101
 no bgp default ipv4-unicast
 address-family nsap
  network 49.0101...
  neighbor 10.1.2.2 activate
  exit-address-family

Configurar un ejemplo del proceso de ruteo IS-IS

En el siguiente ejemplo, el r1 del router, mostrado adentro él figura abajo, se configura para ejecutar un proceso IS-IS:

router isis osi-as-101
 net 49.0101.1111.1111.1111.1111.00

Se utiliza el nivel predeterminado del proceso de ruteo IS-IS.

Configurar el ejemplo de las interfaces

En el siguiente ejemplo, dos de las interfaces del r2 del router, mostradas en la figura abajo, en el sistema autónomo AS65202 se configuran para ejecutar el CLNS. La interfaz de Ethernet 0/1 está conectada con el dominio de ruteo local OSI y configurada para ejecutar el IS-IS cuando el Network Protocol es CLNS usando el comando clns router isis. La interfaz serial 2/0 con el IP Address local de 10.1.2.2 está conectada con un vecino eBGP y configurada para ejecutar el CLNS a través del comando clns enable:

interface serial 2/0
 ip address 10.1.2.2 255.255.255.0
 clns enable
 no shutdown
!
interface ethernet 0/1
 ip address 10.2.3.1 255.255.255.0
 clns router isis osi-as-202
 no shutdown

Haciendo publicidad del establecimiento de una red prefija el ejemplo

En el siguiente ejemplo, el r1 del router, mostrado en la figura abajo, se configura para hacer publicidad del prefijo NSAP de 49,0101 al otro Routers. El prefijo NSAP único al sistema autónomo AS65101 se hace publicidad para permitir que los otros sistemas autónomos descubran la existencia del sistema autónomo AS65101 en la red:

router bgp 65101
 no bgp default ipv4-unicast
 neighbor 10.1.2.2 remote-as 64202
 address-family nsap
  network 49.0101...
  neighbor 10.1.2.2 activate

Redistribución de las rutas del BGP en el ejemplo IS-IS

En el siguiente ejemplo, configuran al Routers R7 y R9, mostrados en la figura abajo, en el sistema autónomo AS65404 para redistribuir las rutas BGP en el proceso de ruteo IS-IS llamado osi-as-404. La redistribución de las rutas BGP permite que el router del nivel 2 IS-IS, R8, haga publicidad de las rutas a los destinos fuera del sistema autónomo AS65404. Sin un Route Map que es especificado, se redistribuyen todas las rutas BGP.

Router R7

router isis osi-as-404
 net 49.0404.7777.7777.7777.7777.00
 redistribute bgp 65404 clns

Router R9

router isis osi-as-404
 net 49.0404.9999.9999.9999.9999.00
 redistribute bgp 65404 clns

Redistribución de las rutas del IS-IS en el ejemplo de BGP

En el siguiente ejemplo, el r2 del router, mostrado en la figura abajo, en el sistema autónomo AS65202 se configura para redistribuir las rutas del nivel 2 CLNS NSAP en el BGP. Un Route Map se utiliza para permitir que solamente las rutas dentro del sistema autónomo local sean redistribuidas en el BGP. Sin un Route Map que es especificado, cada ruta NSAP de la tabla del prefijo del nivel 2 CLNS se redistribuye. Se configura el comando no bgp default ipv4-unicast en el router para inhabilitar el comportamiento predeterminado del proceso de ruteo BGP al intercambiar la información de direcciones IPv4 con los routers vecinos de BGP.

clns filter-set internal-routes permit 49.0202...
!
route-map internal-routes-only permit 10
 match clns address internal-routes
!
router isis osi-as-202
 net 49.0202.2222.2222.2222.2222.00
!
router bgp 65202
 no bgp default ipv4-unicast
 address-family nsap
 redistribute isis osi-as-202 clns route-map internal-routes-only

Configurar el BGP Peer Groups y el ejemplo de los reflectores de ruta

El router R5, mostrado en la figura arriba (en la sección “de la topología de red genérica BGP CLNS”), tiene solamente los vecinos iBGP y ejecuta el IS-IS en ambas interfaces. Para reducir el número de comandos configuration, la configuración R5 como miembro de un grupo de peer de BGP llamó a los iBGP-pares. El grupo de peer es activado automáticamente bajo comando nsap de la direccionamiento-familia configurando al grupo de peer como Route Reflector Client permitiendo que intercambie la información de ruteo NSAP entre los miembros del grupo. Configuran al grupo de peer de BGP también como un cliente del reflector de la ruta BGP para reducir la necesidad de cada routers iBGP de ser conectado el uno al otro.

En el siguiente ejemplo, configuran al router R5 en el sistema autónomo AS65303 como miembro de un grupo de peer de BGP y de un cliente del reflector de la ruta BGP.

router bgp 65303
 no bgp default ipv4-unicast
 neighbor ibgp-peers peer-group
 neighbor ibgp-peers remote-as 65303
 address-family nsap
  neighbor ibgp-peers route-reflector-client
  neighbor 10.4.5.4 peer-group ibgp-peers
  neighbor 10.5.6.6 peer-group ibgp-peers
  exit-address-family

La filtración de las rutas entrantes basadas en el NSAP prefija el ejemplo

En el siguiente ejemplo, el r1 del router, mostrado en la figura abajo, en el sistema autónomo AS65101 se configura para filtrar las rutas entrantes especificadas por la lista de prefijos del valor por defecto-prefijo-solamente.

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router isis osi-as-101
 net 49.0101.1111.1111.1111.1111.00
!
router bgp 65101
 no bgp default ipv4-unicast
 neighbor 10.1.2.2 remote-as 64202
 address-family nsap
  network 49.0101.1111.1111.1111.1111.00
  neighbor 10.1.2.2 activate
  neighbor 10.1.2.2 prefix-list default-prefix-only in

La filtración de las actualizaciones de BGP salientes basadas en el NSAP prefija el ejemplo

En el siguiente ejemplo, las actualizaciones de BGP salientes se filtran sobre la base de los prefijos NSAP. Este ejemplo se configura en el router 7 en la figura abajo. En esta tarea se crea un filtro de CLNS con dos entradas para negar los prefijos NSAP que comiencen por 49.0404 y para permitir los demás prefijos NSAP que comiencen por 49. Se crea un grupo de peers BGP y se aplica el filtro a las actualizaciones de BGP de salida para el vecino que es miembro del grupo de peers.

clns filter-set routes0404 deny 49.0404...
clns filter-set routes0404 permit 49...
!
router bgp 65404
 no bgp default ipv4-unicast
 neighbor ebgp-peers remote-as 65303
 address-family nsap
   neighbor ebgp-peers prefix-list routes0404 out
   neighbor 10.6.7.8 peer-group ebgp-peers

Originar un ejemplo de filtración de la ruta predeterminado y de la ruta de salida

En la figura abajo, el sistema autónomo AS65101 está conectado con solamente otro sistema autónomo, AS65202. El r2 del router en AS65202 proporciona la Conectividad al resto de la red para el sistema autónomo AS65101 enviando una ruta predeterminado al r1. Cualquier paquete de los 1 Router llanos dentro del sistema autónomo AS65101 con los NSAP Address del destino fuera de la red del nivel local 1 se envía al r1, el 2 Router llano más cercano. R1 del router adelante los paquetes al r2 del router usando la ruta predeterminado.

En el siguiente ejemplo, el r2 del router, mostrado en la figura abajo, en el sistema autónomo AS65202 se configura para generar una ruta predeterminado para el r1 del router en el sistema autónomo AS65101, y un filtro saliente se crea para enviar solamente la información de direccionamiento de la ruta predeterminado NSAP en los mensajes de la actualización de BGP al r1 del router.

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router bgp 65202
 no bgp default ipv4-unicast
 neighbor 10.1.2.1 remote-as 64101
 address-family nsap
  network 49.0202...
  neighbor 10.1.2.1 activate
  neighbor 10.1.2.1 default-originate
  neighbor 10.1.2.1 prefix-list default-prefix-only out

Implementar el soporte MP-BGP por el ejemplo CLNS

La figura abajo muestra una red genérica BGP CLNS que contiene a nueve Routers que se agrupe en cuatro sistemas autónomos diferentes (en la terminología BGP) o los dominios de ruteo (en la terminología OSI). Esta sección contiene las configuraciones completas para todo el Routers mostrado en la figura abajo.

Figura 3Componentes en una red genérica BGP CLNS


Si usted necesita más detalles sobre los comandos usados en los siguientes ejemplos, vea las tareas de configuración anterior en este documento y los documentos enumerados en las referencias adicionales.

Sistema autónomo AS65101

Router 1
clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router isis osi-as-101
 net 49.0101.1111.1111.1111.1111.00
!
router bgp 65101
 no bgp default ipv4-unicast
 neighbor 10.1.2.2 remote-as 65202
 address-family nsap
  neighbor 10.1.2.2 activate
  neighbor 10.1.2.2 prefix-list default-prefix-only in
  network 49.0101...
  exit-address-family
!
interface serial 2/0
 ip address 10.1.2.1 255.255.255.0
 clns enable
 no shutdown

Sistema autónomo AS65202

Router 2
clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
clns filter-set internal-routes permit 49.0202...
!
route-map internal-routes-only permit 10
  match clns address internal-routes
!
router isis osi-as-202
  net 49.0202.2222.2222.2222.2222.00
!
router bgp 65202
  no bgp default ipv4-unicast
  neighbor 10.1.2.1 remote-as 65101
  neighbor 10.2.3.3 remote-as 65202
  neighbor 10.2.4.4 remote-as 65303
  address-family nsap
    neighbor 10.1.2.1 activate
    neighbor 10.2.3.3 activate
    neighbor 10.2.4.4 activate
    redistribute isis osi-as-202 clns route-map internal-routes-only
    neighbor 10.1.2.1 default-originate
    neighbor 10.1.2.1 prefix-list default-prefix-only out
    exit-address-family
!
interface ethernet 0/1
  ip address 10.2.3.2 255.255.255.0
  clns router isis osi-as-202
  no shutdown
!
interface serial 2/0
  ip address 10.1.2.2 255.255.255.0
  clns enable
  no shutdown
!
interface serial 2/2
  ip address 10.2.4.2 255.255.255.0
  clns enable
  no shutdown
Router 3
clns filter-set internal-routes permit 49.0202...
!
route-map internal-routes-only permit 10
  match clns address internal-routes
!
router isis osi-as-202
 net 49.0202.3333.3333.3333.3333.00
!
router bgp 65202
 no bgp default ipv4-unicast
 neighbor 10.2.3.2 remote-as 65202
 neighbor 10.3.9.9 remote-as 65404
 address-family nsap
  neighbor 10.2.3.2 activate
  neighbor 10.3.9.9 activate
  redistribute isis osi-as-202 clns route-map internal-routes-only
  exit-address-family
!
interface ethernet 0/1
 ip address 10.2.3.3 255.255.255.0
 clns router isis osi-as-202
 no shutdown
!
interface serial 2/2
 ip address 10.3.9.3 255.255.255.0
 clns enable
 no shutdown

Sistema autónomo AS65303

Router 4
router isis osi-as-303
 net 49.0303.4444.4444.4444.4444.00
!
router bgp 65303
 no bgp default ipv4-unicast
 neighbor 10.2.4.2 remote-as 65202
 neighbor 10.4.5.5 remote-as 65303
 address-family nsap
  no synchronization
  neighbor 10.2.4.2 activate
  neighbor 10.4.5.5 activate
  network 49.0303...
  exit-address-family
!
interface ethernet 0/2
 ip address 10.4.5.4 255.255.255.0
 clns router isis osi-as-303
 no shutdown
!
interface serial 2/3
 ip address 10.2.4.4 255.255.255.0
 clns enable
 no shutdown
Router 5
router isis osi-as-303
 net 49.0303.5555.5555.5555.5555.00
!
router bgp 65303
 no bgp default ipv4-unicast
 neighbor ibgp-peers peer-group
 neighbor ibgp-peers remote-as 65303
 address-family nsap
  no synchronization
  neighbor ibgp-peers route-reflector-client
  neighbor 10.4.5.4 peer-group ibgp-peers
  neighbor 10.5.6.6 peer-group ibgp-peers
  exit-address-family
!
interface ethernet 0/2
 ip address 10.4.5.5 255.255.255.0
 clns router isis osi-as-303
 no shutdown
!
interface ethernet 0/3
 ip address 10.5.6.5 255.255.255.0
 clns router isis osi-as-303
 no shutdown
Router 6
router isis osi-as-303
 net 49.0303.6666.6666.6666.6666.00
!
router bgp 65303
 no bgp default ipv4-unicast
 neighbor 10.5.6.5 remote-as 65303
 neighbor 10.6.7.7 remote-as 65404
 address-family nsap
  no synchronization
  neighbor 10.5.6.5 activate
  neighbor 10.6.7.7 activate
  network 49.0303...
!
interface ethernet 0/3
 ip address 10.5.6.6 255.255.255.0
 clns router isis osi-as-303
 no shutdown
!
interface serial 2/2
 ip address 10.6.7.6 255.255.255.0
 clns enable
 no shutdown

Sistema autónomo AS65404

Router 7
clns filter-set external-routes deny 49.0404...
clns filter-set external-routes permit 49...
!
route-map noexport permit 10
  match clns address external-routes
  set community noexport
!
router isis osi-as-404
 net 49.0404.7777.7777.7777.7777.00
 redistribute bgp 404 clns
!
router bgp 65404
 no bgp default ipv4-unicast
 neighbor 10.6.7.6 remote-as 65303
 neighbor 10.8.9.9 remote-as 65404
 address-family nsap
  neighbor 10.6.7.6 activate
  neighbor 10.8.9.9 activate
  neighbor 10.8.9.9 send-community
  neighbor 10.8.9.9 route-map noexport out
  network 49.0404...
!
interface ethernet 1/0
 ip address 10.7.8.7 255.255.255.0
 clns router isis osi-as-404
 ip router isis osi-as-404
 no shutdown
!
interface serial 2/3
 ip address 10.6.7.7 255.255.255.0
 clns enable
 no shutdown
Router 8
router isis osi-as-404
 net 49.0404.8888.8888.8888.8888.00
!
interface ethernet 1/0
 ip address 10.7.8.8 255.255.255.0
 clns router isis osi-as-404
 ip router isis osi-as-404
 no shutdown
!
interface ethernet 1/1
 ip address 10.8.9.8 255.255.255.0
 clns router isis osi-as-404
 ip router isis osi-as-404
 no shutdown
Router 9
clns filter-set external-routes deny 49.0404...
clns filter-set external-routes permit 49...
!
route-map noexport permit 10
  match clns address external-routes
  set community noexport
!
router isis osi-as-404
 net 49.0404.9999.9999.9999.9999.00
 redistribute bgp 404 clns
!
router bgp 65404
 no bgp default ipv4-unicast
 neighbor 10.3.9.3 remote-as 65202
 neighbor 10.7.8.7 remote-as 65404
 address-family nsap
  network 49.0404...
  neighbor 10.3.9.3 activate
  neighbor 10.7.8.7 activate
  neighbor 10.7.8.7 send-community
  neighbor 10.7.8.7 route-map noexport out
!
interface serial 2/3
 ip address 10.3.9.9 255.255.255.0
 clns enable
 no shutdown
!
interface ethernet 1/1
 ip address 10.8.9.9 255.255.255.0
 clns router isis osi-as-404
 ip router isis osi-as-404
 no shutdown

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con el soporte del Multiprotocol BGP (MP-BGP) para la característica CLNS.

Documentos Relacionados

Tema relacionado

Título del documento

Comandos BGP

Routing IP del Cisco IOS: Referencia del comando bgp

Comandos clns

Referencia de Comandos ISO CLNS de Cisco IOS

Estándares

Estándar

Título

ISO/IEC 8473

ISO CLNP: Protocolo de red sin conexión (ISO-IP). Protocolo para proporcionar el servicio de red sin conexión-MODE.

ISO/IEC 9542

Sistema extremo al protocolo del sistema intermedio (ESIS). Sistema extremo al protocolo del intercambio de ruteo del sistema intermedio para el uso conjuntamente con el protocolo para proporcionar el servicio de red sin conexión-MODE (ISO 8473).

ISO/IEC 10589

IS-IS, Intermediate System-to-Intermediate System. Exchange Protocol de la información de ruteo del intradomain del Intermediate System to Intermediate System para el uso conjuntamente con el protocolo para proporcionar el servicio de red sin conexión-MODE (ISO 8473).

MIB

MIB

Link del MIB

Ninguno.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 1700

Números Asignados

RFC 1771

Un Border Gateway Protocol 4 (BGP-4)

RFC 1997

Atributo de las comunidades BGP

RFC 2042

Registro de los nuevos tipos del atributo BGP

RFC 2439

Humedecimiento del flap de la ruta BGP

RFC 2842

Anuncio de Capacidades con BGP-4

RFC 2858

Extensiones Multiprotocolo para BGP-4

RFC 2918

Capacidad de Actualización de Ruta para BGP-4

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com. Si dispone de un contrato de servicios válido pero no tiene asignados un ID de usuario ni una contraseña, puede registrarse en Cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre Funciones para Configurar el Soporte MP-BGP para el CLNS

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para el soporte MP-BGP para el CLNS

Nombre de la función

Versiones

Información sobre la Función

Multiprotocol BGP (MP-BGP) Support for CLNS

12.2(8)T 12.2(33)SRB

La función Multiprotocol BGP (MP-BGP) Support for CLNS proporciona la capacidad de escalar redes CLNS (Connectionless Network Service). Las extensiones multiprotocolo del Border Gateway Protocol (BGP) añaden la capacidad de interconectar dominios de ruteo de interconexión de sistema abierto (OSI) separados sin fusionar los dominios de ruteo, proporcionando así la capacidad para construir redes OSI muy grandes.

En la versión 12.2(8)T, esta característica fue introducida en las Plataformas siguientes:

  • Cisco 2600 Series
  • Cisco 3600 Series
  • Cisco 7100 Series
  • Cisco 7200 Series
  • Cisco 7500 Series
  • Cisco uBR7200 series

En la versión 12.2(33)SRB, esta característica fue introducida en las Cisco 7600 Series.

Los siguientes comandos fueron introducidos o modificados por esta característica: el nsap de la direccionamiento-familia, nsap claro BGP, nsap claro BGP que humedece, externo claro del nsap BGP, flap-statistics claro del nsap BGP, grupo de peers claro del nsap BGP, nsap BGP del debug, nsap BGP del debug que humedece, las actualizaciones del nsap BGP del debug, lista de prefijo vecina, red (BGP y Multiprotocol BGP), redistribuye (BGP a ISO ISIS), redistribuye (ISO ISIS al BGP), muestra el nsap BGP, muestra a la comunidad del nsap BGP, muestra la comunidad-lista del nsap BGP, muestra la trayectoria que ya no sirve del nsap BGP, muestra la lista de filtros del nsap BGP, muestra el flap-statistics del nsap BGP, muestra el nsap BGP contrario-como, muestra a los vecinos del nsap BGP, muestra las trayectorias del nsap BGP, muestra el cita-regexp del nsap BGP, muestra el nsap BGP regexp, resumen del nsap BGP de la demostración.

Glosario

familia del direccionamiento --Un grupo de Network Protocol que comparten un formato común de la dirección de red. El RFC 1700 definen a las familias del direccionamiento.

COMO --sistema autónomo. Un término IP para describir un dominio de ruteo que tiene su propio política de ruteo independiente y es administrado por una sola autoridad. Equivalente al término “dominio de ruteo OSI.”

BGP --Protocolo Protocolo de la puerta de enlace marginal (BGP). Interdomain Routing Protocol que intercambia información de alcance con otros sistemas BGP.

CLNS --Servicio de red sin conexión. Un protocolo de capa de red OSI.

CMIP --Protocolo de información de gestión común. En el OSI, un Network Management Protocol creado y estandardizado por el ISO para el monitoreo y control de las redes heterogéneas.

DCC --Data Communications Channel.

DCN --Data Communications Network.

ES-IS --Sistema a sistema intermedio del extremo. Protocolo OSI que define cómo los sistemas extremos (hosts) se anuncian a los sistemas intermedios (Routers).

FTAM --Transferencia de archivos, acceso, y Administración. En el OSI, un Application Layer Protocol desarrolló para el intercambio y la Administración del archivo de red entre los tipos diversos de ordenadores.

IGP --Protocolo Interior Gateway Protocols. Protocolo de Internet que se usa para intercambiar información de ruteo dentro de un sistema autónomo.

IGRP --Protocolo interior gateway routing. Un protocolo propietario de Cisco, desarrollado para abordar los problemas se asoció a la encaminamiento en las redes grandes, heterogéneas.

ES --sistema intermedio. Rutear el nodo en una red OSI.

IS-IS --Intermediate System-to-Intermediate System. Protocolo del ruteo jerárquico del link-state OSI basado el la fase V del DECNet que rutea, donde el Routers intercambia la información de ruteo basada en un solo métrico, para determinar la topología de red.

ISO --International Organization for Standardization. Organización internacional que es responsable de una amplia gama de estándares, incluyendo ésos relevantes al establecimiento de una red. El ISO desarrolló el modelo de referencia del interconexión de sistema abierto (OSI), un modelo de referencia popular del establecimiento de una red.

NSAP Address --direccionamiento del punto de acceso al servicio de red. El formato de dirección de red usado por las redes OSI.

OSI --Interconexión de sistema abierto. Programa internacional de la normalización creado por el ISO y el ITU-T para desarrollar los estándares para la red de datos que facilitan la Interoperabilidad multivendor del equipo.

dominio de ruteo --El término OSI que es equivalente al sistema autónomo para el BGP.

SDH --Jerarquía digital sincrónica. Estándar que define un conjunto de los estándares de la tarifa y del formato que se envían usando las señales ópticas sobre la fibra.

SONET --Red óptica sincrónica. La especificación de alta velocidad de la red sincrónica diseñó ejecutarse en la fibra óptica.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.