Guía de configuración del IPv6, Cisco IOS Release 12.2SR
Implementar el IPv6 sobre el MPLS
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 320 KB | Inglés (27 Abril 2012) | Comentarios

Implementar el IPv6 sobre el MPLS

Última actualización: De abril el 27 de 2012

El Multiprotocol Label Switching (MPLS) es desplegado por muchos proveedores de servicio en sus redes del IPv4. Los proveedores de servicio quieren introducir los Servicios IPv6 a sus clientes, pero los cambios a su infraestructura existente del IPv4 pueden ser costosos y el coste-beneficio para los muy poco de tráfico del IPv6 no tiene sentido económico. Varios escenarios de la integración se han desarrollado para leverage una infraestructura MPLS existente del IPv4 y para agregar los Servicios IPv6 sin requerir ningunos cambios a la estructura básica de red. Este documento describe cómo implementar el IPv6 sobre el MPLS.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Requisitos previos para implementar el IPv6 sobre el MPLS

  • Este módulo asume que usted es familiar con el IPv4. Refiera a las publicaciones referidas a los requisitos previos para implementar el IPv6 sobre la sección MPLS para la configuración y la información sobre referencias de comandos del IPv4.
  • Antes del IPv6 el router de borde del proveedor sobre la característica MPLS (6PE) se puede implementar, MPLS debe ejecutarse sobre la red del IPv4 de la base. Si utilizan a los routeres Cisco, el Cisco Express Forwarding o el Distributed Cisco Express Forwarding se debe habilitar para los protocolos del IPv4 y del IPv6. Este módulo asume que usted es familiar con el MPLS.

Información sobre implementar el IPv6 sobre el MPLS

Ventajas del IPv6 que despliega sobre las estructuras básicas MPLS

El IPv6 sobre las estructuras básicas MPLS permite a los dominios aislados del IPv6 para comunicar con uno a sobre una red del núcleo del IPv4 MPLS. Esta implementación requiere solamente algunas actualizaciones de la infraestructura de la estructura básica y ninguna reconfiguración de los routeres del núcleo porque el envío se basa en las escrituras de la etiqueta bastante que el encabezado IP sí mismo, proporcionando a una estrategia muy rentable para el despliegue del IPv6.

Además, los servicios inherentes del Red privada virtual (VPN) y de la Ingeniería de tráfico MPLS (MPLS-TE) disponibles dentro de un entorno MPLS permiten que las redes del IPv6 sean combinadas en el IPv4 VPN o las extranets sobre una infraestructura que soporta el IPv4 VPN y MPLS-TE.

IPv6 sobre un transporte del circuito sobre el MPLS

Usando cualquier circuito el transporte para el IPv6 que despliega sobre las redes MPLS no tiene ningún impacto en la operación o la infraestructura del MPLS, y no requiere ningún cambio de configuración a la base o a los routeres de borde del proveedor. La comunicación entre los dominios remotos del IPv6 funciona con los protocolos nativos del IPv6 sobre un link dedicado, donde están completamente transparentes los mecanismos subyacentes al IPv6. El tráfico del IPv6 es tunneled usando el cualquier transporte sobre MPLS (MPLS/AToM) o la característica del Ethernet por MPLS (EoMPLS) con el Routers conectado a través de una atmósfera OC-3 o interfaz de Ethernet, respectivamente.

La figura abajo muestra la configuración para el IPv6 sobre cualquier transporte del circuito sobre el MPLS.

Figura 1IPv6 sobre un transporte del circuito sobre el MPLS


IPv6 usando los túneles en el Routers de la frontera del cliente

Usando los túneles en la frontera del cliente (CE) el Routers es la manera más simple de desplegar el IPv6 sobre las redes MPLS sin el impacto en la operación o la infraestructura del MPLS, y ningunos cambios de configuración a la base o a los routeres de borde del proveedor. La comunicación entre los dominios remotos del IPv6 utiliza los mecanismos de tunelización estándar y requiere al Routers CE ser configurada para funcionar con las pilas del protocolo duales del IPv4 y del IPv6. La figura abajo muestra la configuración usando los túneles en el Routers CE.

Figura 2IPv6 usando los túneles en el Routers CE


Refiera a implementar el Tunelización para el IPv6 para información sobre configuración manualmente de los Túneles configurados, de los túneles automáticos, y de los túneles 6to4.

Las limitaciones en usar los túneles implican configurar manual de una malla de los túneles en el Routers CE, creando los problemas de ampliación para las Redes grandes.

IPv6 en los routeres de borde del proveedor (6PE)

La implementación de Cisco del router de borde del proveedor del IPv6 sobre el MPLS se llama 6PE, y permite a los sitios del IPv6 para comunicar con uno a sobre una red del núcleo del IPv4 MPLS usando las trayectorias conmutadas de etiquetas MPLS (LSP). Esta característica confía en las Extensiones multiprotocol del Border Gateway Protocol (BGP) en la configuración de red del IPv4 en el router del borde del proveedor (PE) para intercambiar la información de alcance del IPv6 además de una escritura de la etiqueta MPLS para que cada prefijo de dirección del IPv6 sea hecho publicidad. Los routeres de borde se configuran para ser IPv4 que se ejecuta y IPv6 del stack dual, y utilizan el direccionamiento asociado IPv4 del IPv6 para el intercambio del accesibilidad del prefijo del IPv6.

Una jerarquía de las escrituras de la etiqueta se impone ante el router de ingreso 6PE para mantener el tráfico del IPv6 transparente a todos los routeres del núcleo. La escritura de la etiqueta superior proporciona la Conectividad dentro de la red del núcleo del IPv4 MPLS y la escritura de la etiqueta es distribuida por el (TDP) del Protocolo de distribución de etiquetas (LDP), del Tag Distribution Protocol, o el Resource Reservation Protocol (RSVP). El TDP y el LDP se pueden utilizar para la distribución de etiqueta, pero RSVP se utiliza solamente en el contexto del intercambio de la escritura de la etiqueta MPLS-TE. La etiqueta inferior, asignada automáticamente al IPv6 el prefijo del destino, es distribuida por el Multiprotocol BGP y utilizada en cada router Egress 6PE para el envío del IPv6.

En la figura debajo de los 6PE Router se configuran como Routers dual del stack capaz de rutear el tráfico del IPv4 y del IPv6. Configuran a cada 6PE Router para ejecutar el LDP, el TDP, o RSVP (si se configura la ingeniería de tráfico) para atar las escrituras de la etiqueta del IPv4. Los 6PE Router utilizan el Multiprotocol BGP para intercambiar la información de alcance por los otros dispositivos 6PE dentro del dominio MPLS, y para distribuir las escrituras de la etiqueta globales del IPv6 entre ellas. Todo el 6PE y routeres del núcleo--El Routers P en la figura 3--within el dominio MPLS comparte un Interior Gateway Protocol (IGP) del IPv4 del campo común tal como Open Shortest Path First (OSPF) o Intermediate System-to-Intermediate System (IS-IS) integrado.

Figura 3Topología del 6PE Router


Las interfaces en los 6PE Router que conectan con el router CE se pueden configurar para remitir el tráfico del IPv6, el tráfico del IPv4, o ambos tipos de tráfico dependiendo de los requisitos del cliente. Los 6PE Router hacen publicidad de la información de alcance del IPv6 aprendida de sus pares 6PE sobre la nube MPLS. Los proveedores de servicio pueden delegar un prefijo del IPv6 de sus prefijos registradoes del IPv6 sobre la infraestructura 6PE; si no, no hay impacto en el router CE.

El Routers P en la base de la red no es consciente que él está conmutando los paquetes del IPv6. Los routeres del núcleo se configuran para soportar MPLS y el mismo IPv4 IGP que el Routers PE para establecer el accesibilidad interno dentro de la nube MPLS. De los routeres del núcleo uso LDP, TDP, o RSVP también para las escrituras de la etiqueta obligatorias del IPv4. Implementar la característica de Cisco 6PE no tiene ningún impacto en los dispositivos del núcleo MPLS.

Dentro de la red MPLS, el tráfico del IPv6 se remite usando el Label sSwitching, haciendo el tráfico del IPv6 transparente a la base de la red MPLS. Ningún IPv6 sobre los túneles del IPv4 o acoda 2 métodos de encapsulación se requiere.

6PE de trayectoria múltiple

Interno y BGP externo de trayectoria múltiple para el IPv6 permite que el router del IPv6 cargue el equilibrio entre varias trayectorias (por ejemplo, el mismo sistema autónomo vecino o sistema subautonomous, o el mismo métrico) para alcanzar su destino. El Internal BGP multiprotocol de las aplicaciones de trayectoria múltiple de la característica 6PE (MP-iBGP) para distribuir las rutas del IPv6 sobre la red del núcleo del IPv4 MPLS y para sujetar una escritura de la etiqueta MPLS a cada ruta.

Cuando el MP-iBGP de trayectoria múltiple se habilita en el 6PE Router, todas las trayectorias etiquetadas están instaladas en la tabla de reenvío con la información MPLS (pila de etiquetas) cuando la información MPLS está disponible. Estas funciones permiten a 6PE para realizar el Equilibrio de carga.

Cómo implementar el IPv6 sobre el MPLS

IPv6 que despliega sobre un transporte del circuito sobre el MPLS

Para desplegar el IPv6 sobre un transporte del circuito sobre el MPLS, el Routers del IPv6 debe ser configurado para la Conectividad del IPv6. Refiera a implementar la dirección y la conectividad básica del IPv6 para los detalles en la configuración básica del IPv6. La configuración del router MPLS requiere la configuración del átomo o la configuración de EoMPLS.

IPv6 que despliega en los routeres de borde del proveedor (6PE)

Especificar la interfaz de la dirección de origen en un 6PE Router

Dos tareas de configuración usando la red mostrada en la figura abajo se requieren en el 6PE1 Router para habilitar la característica 6PE.

La frontera del cliente router--CE1 en la figura abajo--se configura para remitir su tráfico del IPv6 al 6PE1 Router. Asumen para ejecutar el MPLS, un Label Distribution Protocol, un IPv4 IGP, y Cisco Express Forwarding o Distributed Cisco Express Forwarding, y no requiere al router P1 en la base de la red ninguna nueva configuración habilitar la característica 6PE.

‘Figura 4’ejemplo de configuración 6PE


Antes de comenzar
  • Los 6PE Router--los 6PE1 y 6PE2 Router en la figura abajo--deben ser los miembros de la red del IPv4 de la base. Las interfaces del 6PE Router asociadas a la red del núcleo deben ejecutar el MPLS, el mismo Label Distribution Protocol, y el mismo IPv4 IGP, como en la red del núcleo.
  • Los 6PE Router deben también ser configurados para ser stack dual para ejecutar el IPv4 y el IPv6.

Nota



Nota


A partir del Cisco IOS Release 12.2(22)S, las restricciones siguientes no aplican al Cisco IOS 12.2S las versiones.

Las restricciones siguientes se aplican al implementar el router de borde del proveedor del IPv6 sobre la característica MPLS (6PE):

  • El Routers de la base MPLS está soportando el MPLS y el IPv4 solamente, así que él no puede remitir o crear ninguna mensajes del Internet Control Message Protocol (ICMP) del IPv6.
  • La capacidad del Equilibrio de carga no es proporcionada por Cisco 6PE entre una trayectoria MPLS y una trayectoria del IPv6. Si ambos están disponibles, la trayectoria MPLS se prefiere siempre. El Equilibrio de carga entre dos trayectorias MPLS es posible.
  • El trayecto múltiple de BGP no se soporta para las rutas de Cisco 6PE. Si dos peeres BGP hacen publicidad del mismo prefijo con un igual costo, Cisco 6PE utilizará la ruta más reciente para cruzar la base MPLS.
  • la característica 6PE no se soporta sobre los túneles con excepción de los túneles RSVP-TE.
>

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Unicast Routing del IPv6

4. cef del IPv6

5. número del tipo de la interfaz

6. direccionamiento ipv6-address/longitud del prefijo del IPv6 | sub-bits /longitud del prefijo del prefijo-nombre


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
Unicast Routing del IPv6


Ejemplo:

Unicast Routing del IPv6 de Router(config)#

 

Habilita la expedición de los datagramas del unicast del IPv6.

 
Paso 4
cef del IPv6


Ejemplo:

Cef del IPv6 de Router(config)#

 

Cisco Express Forwarding del IPv6 de los permisos.

 
Paso 5
número del tipo de la interfaz


Ejemplo:

Serial0/0 de la interfaz de Router(config)#

 

Especifica un tipo y número de interfaz e ingresa en el modo de configuración de interfaz.

  • En el contexto de esta característica, la interfaz que se configurará es la interfaz que comunica con el router CE.
 
Paso 6
direccionamiento ipv6-address/longitud del prefijo del IPv6 | sub-bits /longitud del prefijo del prefijo-nombre


Ejemplo:

Router (config-if) # direccionamiento 2001:DB8:FFFF::2/64 del IPv6

 

Configura un direccionamiento del IPv6 basado en un prefijo general del IPv6 y el IPv6 del permiso que procesa en una interfaz.

 

Atando y haciendo publicidad de la escritura de la etiqueta 6PE para hacer publicidad de los prefijos

Realice esta tarea de habilitar el atascamiento y la publicidad de las escrituras de la etiqueta del agregado al hacer publicidad de los prefijos del IPv6 a un vecino BGP especificado.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. ningún valor por defecto ipv4-unicast BGP

5. vecino {IP address | ipv6-address | par-grupo-nombre} telecontrol-como el como-número

6. neighbor ip-address | ipv6-address | interface-type interface-number de la actualización-fuente del par-grupo-nombre}

7. [unicast] del IPv6 de la direccionamiento-familia

8. vecino {IP address | par-grupo-nombre| ipv6-address} activan

9. vecino {IP address | enviar-escritura de la etiqueta ipv6-address}


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
ningún valor por defecto ipv4-unicast BGP


Ejemplo:

Router (config-router) # ningún valor por defecto ipv4-unicast BGP

 

Inhabilita a la familia de la dirección de Unicast del IPv4 para el proceso de ruteo BGP especificado en el paso anterior.

Nota    La información de ruteo para la familia de la dirección de Unicast del IPv4 se hace publicidad por abandono para cada sesión de la encaminamiento BGP configurada con el comando neighbor remote-as a menos que usted no configure el ningún valor por defecto ipv4-unicastcommand BGP antes de configurar el comando neighbor remote-as.
 
Paso 5
neighbor {ip-address | ipv6-address | par-grupo-nombre} telecontrol-como el como-número


Ejemplo:

Router (config-router) # vecino 192.168.99.70 telecontrol-como 65000

 

Agrega la dirección IP del vecino en el sistema autónomo especificado a la tabla del vecino BGP del router local.

 
Paso 6
neighbor ip-address | ipv6-address | interface-type interface-number de la actualización-fuente del par-grupo-nombre}


Ejemplo:

Router (config-router) # loopback0 de la actualización-fuente de 192.168.99.70 del vecino

 

Especifica la interfaz cuyo direccionamiento del IPv4 debe ser utilizado como la dirección de origen para el peering.

  • En el contexto de esta tarea, la interfaz debe tener un direccionamiento del IPv4 con una máscara de 32 bits configurada. El uso de un Loopback Interface se recomienda. Este direccionamiento es utilizado para determinar el salto siguiente del IPv6 por el par 6PE.
 
Paso 7
[unicast] del IPv6 de la direccionamiento-familia


Ejemplo:

Router (config-router) # IPv6 de la direccionamiento-familia

 

Especifica a la familia del direccionamiento del IPv6 y ingresa al modo de configuración de la familia del direccionamiento.

  • La palabra clave del unicast especifica a la familia de la dirección de Unicast del IPv6. Por abandono, colocan al router en el modo de configuración para la familia de la dirección de Unicast del IPv6 si la palabra clave del unicast no se especifica con el comando address-family ipv6.
 
Paso 8
neighbor {ip-address | par-grupo-nombre| ipv6-address} activan


Ejemplo:

El router (config-router-AF) # vecino 192.168.99.70 activa

 

Permite al vecino para intercambiar los prefijos para la familia del direccionamiento del IPv6 por el router local.

 
Paso 9
neighbor {ip-address | enviar-escritura de la etiqueta ipv6-address}


Ejemplo:

Router (config-router-AF) # enviar-escritura de la etiqueta de 192.168.99.70 del vecino

 

Hace publicidad de la capacidad del router para enviar las escrituras de la etiqueta MPLS con las rutas BGP.

  • En el modo de configuración de la familia del direccionamiento del IPv6 este comando habilita el atascamiento y el anuncio de las escrituras de la etiqueta del agregado al hacer publicidad de los prefijos del IPv6 en el BGP.
 

Configurar la carga a compartir de la ruta múltiple iBGP

Realice esta tarea de configurar la carga a compartir de la ruta múltiple iBGP y de controlar el número máximo de rutas paralelas del iBGP que se puedan instalar en una tabla de ruteo.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. número-de-trayectorias del ibgp de las máximo-trayectorias


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 65000 del router de Router(config)#

 

Ingresa el modo de configuración del router para el proceso de ruteo especificado.

 
Paso 4
número-de-trayectorias del ibgp de las máximo-trayectorias


Ejemplo:

Router (config-router) # ibgp 3 de las máximo-trayectorias

 

Controla el número máximo de rutas paralelas del iBGP que se puedan instalar en una tabla de ruteo.

 

Verificar la configuración 6PE y la operación

Cuando 6PE se está ejecutando, los componentes siguientes pueden ser monitoreados:

  • Multiprotocol BGP
  • MPLS
  • Cisco Express Forwarding para el IPv6
  • Tabla de ruteo del IPv6
PASOS SUMARIOS

1. show bgp ipv6 {unicast | Multicast} [longer-prefixes] [ipv6-prefix/de la longitud del prefijo] [escrituras de la etiqueta

2. show bgp ipv6 {unicast | vecinos [ipv6-address] [recibir-rutas del Multicast} | rutas | flap-statistics | rutas anunciadas | expresión normal de las trayectorias | rutas que ya no sirven

3. muestre la tabla de reenvío de los mpls [red {máscara| longitud}| [- label] de la escritura de la etiqueta de las escrituras de la etiqueta | interfaz de la interfaz| direccionamiento del nexthop| [vrf vrf-name] del [tunnel-id] del túnel LSP] [detail]

4. muestre el cef [ipv6-prefix/longitud del prefijo del IPv6] | [interface-type interface-number] [prefijos más largos | similar-prefijos | detalle | interno | plataforma | epoch | fuente]]

5. show ipv6 route [ipv6-address | ipv6-prefix/longitud del prefijo | protocolo | interface-type interface-number


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
show bgp ipv6 {unicast | Multicast} [longer-prefixes] [ipv6-prefix/de la longitud del prefijo] [escrituras de la etiqueta


Ejemplo:

Unicast 2001:DB8:DDDD::/48 del show bgp ipv6 del Router>

 

Entradas (opcionales) de las visualizaciones en la tabla de BGP Routing del IPv6.

  • En este ejemplo, la información sobre la ruta del IPv6 para el prefijo 2001:DB8:DDDD::/48 se visualiza.
 
Paso 2
show bgp ipv6 {unicast | vecinos [ipv6-address] [recibir-rutas del Multicast} | rutas | flap-statistics | rutas anunciadas | expresión normal de las trayectorias | rutas que ya no sirven


Ejemplo:

Unicast 192.168.99.70 de los vecinos del show bgp ipv6 del Router>

 

Información (opcional) de las visualizaciones sobre las conexiones BGP del IPv6 a los vecinos.

  • En este ejemplo, la información incluyendo la capacidad de la escritura de la etiqueta del IPv6 se visualiza para el peer BGP en 192.168.99.70.
 
Paso 3
muestre la tabla de reenvío de los mpls [red {máscara| longitud}| [- label] de la escritura de la etiqueta de las escrituras de la etiqueta | interfaz de la interfaz| direccionamiento del nexthop| [vrf vrf-name] del [tunnel-id] del túnel LSP] [detail]


Ejemplo:

Tabla de reenvío de los mpls de la demostración del Router>

 

(Opcional) visualiza el contenido de la Base de información de reenvío (FIB) MPLS.

  • En este ejemplo, la información que conecta la escritura de la etiqueta MPLS a los prefijos del IPv6 se visualiza donde las escrituras de la etiqueta se muestran tan global y el prefijo se muestra como el IPv6.
 
Paso 4
muestre el cef [ipv6-prefix/longitud del prefijo del IPv6] | [interface-type interface-number] [prefijos más largos | similar-prefijos | detalle | interno | plataforma | epoch | fuente]]


Ejemplo:

Cef 2001:DB8:DDDD::/64 del IPv6 de la demostración del Router>

 

Las visualizaciones (opcionales) MIENTEN las entradas basadas en la información de dirección del IPv6.

  • En este ejemplo, la información de la escritura de la etiqueta de la tabla del Cisco Express Forwarding para el prefijo 2001:DB8:DDDD::/64 se visualiza.
 
Paso 5
show ipv6 route [ipv6-address | ipv6-prefix/longitud del prefijo | protocolo | interface-type interface-number


Ejemplo:

Show ipv6 route del Router>

 

(Opcional) visualiza el contenido actual de la tabla de ruteo del IPv6.

 

Ejemplos de Salida

Salida de muestra del comando show bgp ipv6

Este ejemplo muestra la información de la salida sobre una ruta del IPv6 usando el BGP ipv6command de la demostración con un prefijo del IPv6:

Router# show bgp ipv6 2001:DB8:DDDD::/48
BGP routing table entry for 2001:DB8:DDDD::/48, version 15
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    ::FFFF:192.168.99.70 (metric 20) from 192.168.99.70 (192.168.99.70)
      Origin IGP, localpref 100, valid, internal, best
Salida de muestra del comando neighbors del show bgp ipv6

Este ejemplo muestra la información de la salida sobre un peer BGP, incluyendo capacidad de la escritura de la etiqueta "IPv6”, usando el neighborscommand del show bgp ipv6 con una dirección IP:

Router# show bgp ipv6 neighbors 192.168.99.70
BGP neighbor is 192.168.99.70, remote AS 65000, internal link
  BGP version 4, remote router ID 192.168.99.70
  BGP state = Established, up for 00:05:17
  Last read 00:00:09, hold time is 0, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received
    Address family IPv6 Unicast: advertised and received
    ipv6 MPLS Label capability: advertised and received
  Received 54 messages, 0 notifications, 0 in queue
  Sent 55 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 5 seconds
 For address family: IPv6 Unicast
  BGP table version 21880, neighbor version 21880
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  77 accepted prefixes consume 4928 bytes 
  Prefix advertised 4303, suppressed 0, withdrawn 1328
  Number of NLRIs in the update sent: max 1, min 0
Salida de muestra del comando show mpls forwarding-table

Este ejemplo muestra la información de la salida que conecta la escritura de la etiqueta MPLS a los prefijos usando la expedición-tablecommand de los mpls de la demostración. Si se configura la característica 6PE, se agregan las escrituras de la etiqueta porque hay varios prefijos para una escritura de la etiqueta local, y la columna del prefijo contiene el "IPv6" en vez de un prefijo de la blanco.

Router# show mpls forwarding-table
Local Outgoing      Prefix            Bytes tag Outgoing       Next Hop       
tag   tag or VC     or Tunnel Id      switched  interface                     
16    Aggregate     IPv6              0             
17    Aggregate     IPv6              0                 
18    Aggregate     IPv6              0                 
19    Pop tag       192.168.99.64/30  0         Se0/0         point2point    
20    Pop tag       192.168.99.70/32  0         Se0/0         point2point      
21    Pop tag       192.168.99.200/32 0         Se0/0         point2point    
22    Aggregate     IPv6              5424    
23    Aggregate     IPv6              3576 
24    Aggregate     IPv6              2600
Salida de muestra del comando show bgp ipv6

Este ejemplo muestra la información de la salida sobre el top de la escritura de la etiqueta del stack con la información de Label Switching usando el BGP ipv6command de la demostración con la palabra clave de las escrituras de la etiqueta:

Router# show bgp ipv6 labels
Network              Next Hop               In tag/Out tag
2001:DB8:DDDD::/64  ::FFFF:192.168.99.70   notag/20
Salida de muestra del comando cef del IPv6 de la demostración

Este ejemplo muestra la información de la salida sobre las escrituras de la etiqueta de la tabla del Cisco Express Forwarding usando el cefcommand del IPv6 de la demostración con un prefijo del IPv6:

Router# show ipv6 cef 2001:DB8:DDDD::/64
2001:DB8:DDDD::/64
      nexthop ::FFFF:192.168.99.70
      fast tag rewrite with Se0/0, point2point, tags imposed {19 20}
Salida de muestra del comando show ipv6 route

Este ejemplo muestra la información de la salida de la tabla de ruteo del IPv6 usando el routecommand del IPv6 de la demostración. La salida muestra la interfaz virtual del IPv6 MPLS como la interfaz de salida de las rutas del IPv6 remitidas a través de la nube MPLS. En este ejemplo usando el Routers en la figura arriba, la salida es del 6PE1 Router.

El 6PE2 Router ha hecho publicidad del prefijo del IPv6 de 2001:DB8:dddd::/48 configurado para el router CE2 y la dirección del salto siguiente es el direccionamiento compatible con IPv4 del IPv6:: ffff:192.168.99.70, donde está el direccionamiento 192.168.99.70 del IPv4 del 6PE2 Router.

Router# show ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
B 2001:DB8:DDDD::/64 [200/0]
  via ::FFFF:192.168.99.70, IPv6-mpls
B 2001:DB8:DDDD::/64 [200/0]
  via ::FFFF:192.168.99.70, IPv6-mpls
L 2001:DB8:FFFF::1/128 [0/0]
  via ::, Ethernet0/0
C 2001:DB8:FFFF::/64 [0/0]
  via ::, Ethernet0/0
S 2001:DB8:FFFF::/48 [1/0]
  via 2001:DB8:B00:FFFF::2, Ethernet0/0

Ejemplos de configuración para el IPv6 sobre el MPLS

Los siguientes ejemplos muestran los ejemplos de configuración 6PE para tres del Routers mostrado en la figura arriba y usado en especificar la interfaz de la dirección de origen en un 6PE Router y un atascamiento y la publicidad la escritura de la etiqueta 6PE para hacer publicidad de las secciones de los prefijos.

Ejemplo Router borde del cliente

Este ejemplo muestra a eso la interfaz serial 0/0 de la frontera del cliente router--CE1 en la figura arriba--está conectado con el proveedor de servicio y asignado un direccionamiento del IPv6. Se habilita el IPv6 y una Static ruta predeterminada está instalada usando el direccionamiento del IPv6 de la interfaz serial 0/0 del 6PE1 Router.

ip cef
!
ipv6 unicast-routing
!
interface Serial 0/0
 description to_6PE1_router
 no ip address
 ipv6 address 2001:DB8:FFFF::2/64
!
ipv6 route ::/0 Serial 0/0 FE80::210:XXXX:FEE1:1001

Router de borde del proveedor del ejemplo

El 6PE Router--Router 6PE1 en la figura arriba--se configura para el tráfico del IPv4 y del IPv6. La interfaz de Ethernet 0/0 se configura con un direccionamiento del IPv4 y está conectada con un router en la base de la red--router P1 en la figura arriba. Las configuraciones integradas IS-IS y TDP en este router son similares al router P1.

El router 6PE1 intercambia la información de ruteo del IPv6 por otro 6PE Router--Router 6PE2 en la figura arriba-- usando el Internal BGP (iBGP) establecido sobre una conexión del IPv4 de modo que todos los comandos neighbor utilicen el direccionamiento del IPv4 del 6PE2 Router. Todos los peeres BGP están dentro del sistema autónomo 65000, así que la sincronización con el IGP se apaga para el IPv4. En el modo de configuración de la familia del direccionamiento del IPv6, la sincronización se inhabilita por abandono.

El IPv6 y el Cisco Express Forwarding para el IPv6 se habilitan, activan al vecino 6PE2, y la vinculación de etiquetas y el anuncio del agregado se habilita para los prefijos del IPv6 usando el comando vecino de la enviar-escritura de la etiqueta. Las rutas conectadas y estáticas del IPV6 se redistribuyen usando el BGP. Si los paquetes del IPv6 se generan en el router local, el direccionamiento del IPv6 para el proceso MPLS será el direccionamiento del Loopback Interface 0.

Este ejemplo muestra que la interfaz serial 0/0 conecta con el cliente y el prefijo del IPv6 delegado al cliente es 2001:DB8:ffff::/48, que se determina del prefijo del IPv6 del proveedor de servicio. Una Static ruta se configura para rutear los paquetes del IPv6 entre la ruta 6PE y el router CE.

ip cef
ipv6 cef
ipv6 unicast-routing
!
mpls ipv6 source-interface Loopback0
tag-switching tdp router-id Loopback0
!
interface Loopback0
 ip address 192.168.99.5 255.255.255.255
 ipv6 address 2001:DB8:1000:1::1/64
!
interface Ethernet0/0
 description to_P_router
 ip address 192.168.99.1 255.255.255.252
 ip router isis 
 tag-switching ip
!
interface Serial0/0
 description to_CE_router
 no ip address
 ipv6 address 2001:DB8:FFFF::1/64
!
router isis 
 passive-interface Loopback0
 net 49.0001.1921.6809.9005.00
!
router bgp 65000
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.99.70 remote-as 65000
 neighbor 192.168.99.70 description to_6PE2
 neighbor 192.168.99.70 update-source Loopback0
 !
 address-family ipv6
 neighbor 192.168.99.70 activate
 neighbor 192.168.99.70 send-label
 network 2001:DB8:FFFF::/48
 exit-address-family
!
ipv6 route 2001:DB8:FFFF::/48 Ethernet0/0 2001:DB8:FFFF::2

Router del núcleo del ejemplo

Este ejemplo muestra a eso el router en la base de la red--Router P en la figura arriba--está ejecutando el MPLS, el IS-IS, y el IPv4 solamente. Las interfaces de Ethernet se configuran con el direccionamiento del IPv4 y están conectadas con los 6PE Router. El IS-IS es el IGP para esta red y el P1 y los 6PE Router están en los mismos área IS-IS 49,0001. El TDP y el Tag Switching se habilitan en ambas las interfaces de Ethernet. El Cisco Express Forwarding se habilita en el modo de configuración global.

ip cef
!
tag-switching tdp router-id Loopback0
!
interface Loopback0
 ip address 192.168.99.200 255.255.255.255
!
interface Ethernet0/0
 description to_6PE1
 ip address 192.168.99.2 255.255.255.252
 ip router isis 
 tag-switching ip
!
interface Ethernet0/1
 description to_6PE2
 ip address 192.168.99.66 255.255.255.252
 ip router isis 
 tag-switching ip
router isis 
 passive-interface Loopback0
 net 49.0001.1921.6809.9200.00

Adonde ir después

Si usted quiere personalizar más lejos su red MPLS, refiera a la guía de configuración del Switching IP del Cisco IOS.

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

IPv6 usando los túneles en el Routers CE

“Implementando el Tunelización para la guía de configuración del IPv6 del Cisco IOS del IPv6,"

Lista de la característica admitida del IPv6

“Comienzo aquí: Específicos de la versión de Cisco IOS Software para las características del IPv6,” guía de configuración del IPv6 del Cisco IOS

Comandos del IPv6: sintaxis, modo de comando, valores por defecto, Pautas para el uso, y ejemplos del comando complete

Referencia de comandos del IPv6 del Cisco IOS

Tareas de la configuración de MPLS

“Descripción del Multiprotocol Label Switching,” guía de configuración del Multiprotocol Label Switching del Cisco IOS

Comandos mpls: sintaxis, modo de comando, valores por defecto, Pautas para el uso, y ejemplos del comando complete

Referencia de Comandos de Multiprotocol Label Switching de Cisco IOS

Estándares

Estándares

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Ninguno

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.

--

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/support/index.html

Información de la característica para implementar el IPv6 sobre el MPLS

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para implementar el IPv6 sobre el MPLS

Nombre de la función

Versiones

Información sobre la Función

IPv6 sobre un transporte del circuito sobre el MPLS

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(15)T 12,3 12.3(2)T 12,4 12.4(2)T

En esta característica, la comunicación entre los dominios remotos del IPv6 funciona con los protocolos nativos del IPv6 sobre un link dedicado, donde están completamente transparentes los mecanismos subyacentes al IPv6.

IPv6 usando los túneles sobre el Routers de la frontera del cliente

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(15)T 12,3 12.3(2)T 12,4 12.4(2)T

Usando los túneles en el Routers CE está la manera más simple de desplegar el IPv6 sobre las redes MPLS sin el impacto en la operación o la infraestructura del MPLS.

El conmutar del IPv6--Router de borde del proveedor sobre MPLS (6PE)

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(15)T 12,3 12.3(2)T 12,4 12.4(2)T

La implementación de Cisco del router de borde del proveedor del IPv6 sobre el MPLS permite a los sitios del IPv6 para comunicar con uno a sobre una red del núcleo del IPv4 MPLS usando MPLS LSP.

6PE de trayectoria múltiple

12.2(25)S 12.2(28)SB 12.2(33)SRA 12.4(6)T

El Internal BGP multiprotocol de las aplicaciones de trayectoria múltiple de la característica 6PE (MP-iBGP) para distribuir las rutas del IPv6 sobre la red del núcleo del IPv4 MPLS y para sujetar una escritura de la etiqueta MPLS a cada ruta.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.