Routing IP: Guía de configuración BGP, Cisco IOS Release 12.2SR
Configuración de las Funciones del BGP Interno
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 341 KB | Inglés (8 Noviembre 2011) | Comentarios

Contenido

Configuración de las Funciones del BGP Interno

Última actualización: De abril el 13 de 2012

Este módulo describe cómo configurar las características del (BGP) del Internal Border Gateway Protocol. El Internal BGP (iBGP) refiere al Border Gateway Protocol (BGP) corriente en los dispositivos de interconexión de redes dentro de un sistema autónomo. El BGP es un Routing Protocol del interdomain diseñado para proporcionar el Loop-Free Routing entre los dominios de ruteo separados (sistemas autónomos) que contienen los políticas de ruteo independientes. Muchas compañías ahora tienen redes internas grandes y hay muchos problemas implicados en el escalamiento de los Routing Protocol internos existentes para hacer juego las demandas de tráfico cada vez mayores mientras que mantiene la eficacia de la red.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Información sobre las características del Internal BGP

Confederación del dominio de ruteo BGP

Una manera de reducir la malla del Internal BGP (iBGP) es dividir un sistema autónomo en los sistemas subautonomous múltiples y agruparlos en una sola confederación. Al mundo exterior, la confederación parece un solo sistema autónomo. Cada sistema autónomo se enreda completamente dentro de sí mismo, y tiene algunas conexiones a otros sistemas autónomos en la misma confederación. Aunque los pares en los sistemas autónomos diferentes tienen sesiones del BGP externo (eBGP), intercambian la información de ruteo como si fueran pares del iBGP. Específicamente, se preserva el salto siguiente, el atributo de Multi_Exit_Discriminator (MED), y la información de preferencia local. Esta característica le permite para conservar un solo Interior Gateway Protocol (IGP) para todos los sistemas autónomos.

Para configurar una Confederación BGP, usted debe especificar un identificador de confederación. Al mundo exterior, el grupo de sistemas autónomos parecerá un solo sistema autónomo con el identificador de confederación como el número del sistema autónomo.

Reflector de la ruta BGP

El BGP requiere que todos los interlocutores iBGP estén enredados completamente. Sin embargo, este requisito no escala bien cuando hay muchos interlocutores iBGP. En vez de configurar una confederación, otra manera de reducir la malla del iBGP es configurar un reflector de ruta.

La figura abajo ilustra una configuración de iBGP simple con tres interlocutores iBGP (Routers A, B, y C). Sin los reflectores de ruta, cuando el router A recibe una ruta de un vecino externo, debe hacer publicidad de ella al Routers B y a C. Routers B y el C no hace readvertise la ruta aprendida iBGP a otros interlocutores iBGP porque el Routers no pasa encendido las rutas aprendió de los vecinos internos a otros vecinos internos, así previniendo un Routing Information Loop.

Figura 1Tres interlocutores iBGP completamente enredados


Con los reflectores de ruta, todos los interlocutores iBGP no necesitan ser enredados completamente porque hay un método para pasar las rutas aprendido a los vecinos. En este modelo, configuran a un par del iBGP para ser un reflector de ruta responsable de pasar las rutas aprendidas iBGP a un conjunto de los vecinos iBGP. En la figura abajo, configuran al router B como reflector de ruta. Cuando el reflector de ruta recibe las rutas des divulgación del router A, hace publicidad de ellas al C del router, y vice versa. Este esquema elimina la necesidad de la sesión del iBGP entre el Routers A y el C.

Figura 2Modelo simple BGP con un reflector de ruta


Dividen a los peeres internos del reflector de ruta en dos grupos: pares del cliente y el resto de Routers en el sistema autónomo (peeres no cliente). Un reflector de ruta refleja las rutas entre estos dos grupos. El reflector de ruta y sus pares del cliente forman un cluster. Los peeres no cliente deben ser enredados completamente con uno a, pero los pares del cliente no necesitan ser enredados completamente. Los clientes en el cluster no comunican con los interlocutores iBGP fuera de su cluster.

La figura abajo ilustra un esquema más complejo del reflector de ruta. El router A es el reflector de ruta en un cluster con el Routers B, C, y enredan a D. Routers E, F, y G completamente, Routers del nonclient.

Figura 3Un modelo más complejo del reflector de la ruta BGP


Cuando el reflector de ruta recibe una ruta anunciada, dependiendo del vecino, toma medidas siguientes:

  • Una ruta de un altavoz del BGP externo se hace publicidad a todos los clientes y peeres no cliente.
  • Una ruta de un peer no cliente se hace publicidad a todos los clientes.
  • Una ruta de un cliente se hace publicidad a todos los clientes y peeres no cliente. Por lo tanto, los clientes no necesitan ser enredados completamente.

Junto con los BGP de conversaciones que reconoce el reflector de la ruta, es posible tener BGP de conversaciones que no entiendan el concepto de reflectores de ruta. Pueden ser miembros del cliente o de los grupos no clientes permitiendo un fácil y migración gradual del viejo modelo BGP al modelo del reflector de ruta. Inicialmente, usted podría crear un solo cluster con un reflector de ruta y algunos clientes. El resto de interlocutores iBGP podrían ser peeres no cliente al reflector de ruta y entonces más clusteres se podrían crear gradualmente.

Un sistema autónomo puede tener reflectores de ruta múltiples. Un reflector de ruta trata otros reflectores de ruta apenas como otros interlocutores iBGP. Un reflector de ruta se puede configurar para tener otros reflectores de ruta en un Grupo de clientes o un grupo no cliente. En una Configuración simple, la estructura básica se podía dividir en muchos clusteres. Cada reflector de ruta sería configurado con otros reflectores de ruta como peeres no cliente (así, todos los reflectores de ruta serán enredados completamente). Configuran a los clientes para mantener las sesiones del iBGP con solamente el reflector de ruta en su cluster.

Un cluster de los clientes tendrá generalmente un reflector de la solo ruta. En ese caso, el cluster es identificado por el Router ID del reflector de ruta. Para aumentar la Redundancia y evitar un solo punto de falla, un cluster pudo tener más de un reflector de ruta. En este caso, todos los reflectores de ruta en el cluster se deben configurar con 4-byte el cluster ID de modo que un reflector de ruta pueda reconocer las actualizaciones de los reflectores de ruta en el mismo cluster. Todos los reflectores de ruta que sirven un cluster deben ser enredados completamente y todos deben tener los conjuntos idénticos de cliente y de los peeres no cliente.

Mecanismos del reflector de ruta a evitar rutear los loopes

Mientras que se reflejan las rutas aprendidas iBGP, la información de ruteo puede colocar. El modelo del reflector de ruta tiene los mecanismos siguientes a evitar rutear los loopes:

  • El ID del originador es un atributo BGP opcional, nontransitive. Es un atributo 4-byte creado por un reflector de ruta. El atributo lleva el Router ID del terminal original de la ruta en el sistema autónomo local. Por lo tanto, si un misconfiguration hace la información de ruteo volver al terminal original, se ignora la información.
  • la Cluster-lista es un atributo BGP opcional, nontransitive. Es una secuencia del cluster ID que la ruta ha pasado. Cuando un reflector de ruta refleja una ruta de sus clientes a los peeres no cliente, y vice versa, añade el clúster local al final del fichero ID a la lista del cluster. Si la lista del cluster está vacía, se crea una nueva lista del cluster. Usando este atributo, un reflector de ruta puede identificar si la información de ruteo es circuito hecho atrás al mismo cluster debido al misconfiguration. Si el ID de clúster local se encuentra en la lista de clústeres, se ignora el anuncio.
  • El uso de las cláusulas del conjunto en los mapas de ruta de salida puede modificar los atributos y crear posiblemente los loopes de la encaminamiento. Para evitar este comportamiento, la mayoría de las cláusulas del conjunto de los mapas de ruta de salida se ignoran para las rutas reflejadas a los pares del iBGP. La única cláusula del conjunto de un mapa de ruta de salida que se actúe sobre es la cláusula del Next-Hop del IP del conjunto.

Mapa de ruta de salida BGP en el reflector de ruta para fijar el salto siguiente IP para el par del iBGP

El mapa de ruta de salida BGP en el reflector de ruta para fijar la característica del salto siguiente IP permite que un reflector de ruta modifique el atributo del salto siguiente para una ruta reflejada.

El uso de las cláusulas del conjunto en los mapas de ruta de salida puede modificar los atributos y crear posiblemente los loopes de la encaminamiento. Para evitar este comportamiento, la mayoría de las cláusulas del conjunto de los mapas de ruta de salida se ignoran para las rutas reflejadas a los pares del iBGP. La única cláusula del conjunto de un mapa de ruta de salida en un reflector de ruta (RR) que se actúe sobre es la cláusula del Next-Hop del IP del conjunto. La cláusula del Next-Hop del IP del conjunto se aplica a las rutas reflejadas.

Configurar un RR con un mapa de ruta de salida permite que un administrador de la red modifique el atributo del salto siguiente para una ruta reflejada. Configurando un Route Map con la cláusula del Next-Hop del IP del conjunto, el administrador pone el RR en el trayecto de reenvío, y puede configurar la carga a compartir de la ruta múltiple iBGP para alcanzar el Equilibrio de carga. Es decir, el RR puede distribuir los paquetes de salida entre los puntos de egreso múltiples. Vea “configurando el módulo de la carga a compartir de la ruta múltiple iBGP”.


Precaución


Incorrectamente la determinación de los atributos BGP para las rutas reflejadas puede causar el ruteo inconsistente, ruteando los loopes, o una pérdida de conectividad. La determinación de los atributos BGP para las rutas reflejadas se debe intentar solamente por alguien que tiene una buena comprensión de las implicaciones del diseño.


Soporte del autodetección BGP VPL en el reflector de ruta

En el Cisco IOS Release 12.2(33)SRE, el soporte del autodetección BGP VPL en el reflector de ruta fue introducido. En el Routers de las Cisco 7600 y Cisco 7200 Series, el reflector de la ruta BGP fue aumentado para poder reflejar los prefijos BGP VPL sin tener VPL configurados explícitamente en el reflector de ruta. El reflector de ruta refleja los prefijos VPL al otro Routers del borde del proveedor (PE) de modo que los PE no necesiten tener una interconexión total de las sesiones de BGP. El administrador de la red configura solamente a la familia del direccionamiento BGP VPL en el reflector de ruta.

Por un ejemplo de una configuración del reflector de ruta que pueda reflejar los prefijos VPL, vea el ejemplo: Soporte del autodetección BGP VPL en el reflector de ruta. Para más información sobre el autodetección VPL, vea el autodetección VPL: El BGP basó el capítulo en la guía de configuración de MPLS del Cisco IOS.

Dampening de la Ruta de BGP

El dampening de ruta es una función de BGP diseñada para minimizar la propagación de las rutas inestables a través de una conexión entre redes. Una ruta se considera inestable cuando su disponibilidad varía repetidamente.

Por ejemplo, considere una red con tres sistemas autónomos BGP: sistema autónomo 1, sistema autónomo 2 y sistema autónomo 3. Suponga que la ruta a la red A en el sistema autónomo 1 es inestable (deja de estar disponible). Cuando no se disponga de dampening de rutas, el vecino eBGP del sistema autónomo 1 al sistema autónomo 2 envía un mensaje de retirada al sistema autónomo 2. El router de borde del sistema autónomo 2, a su vez, propaga el mensaje del retirada al sistema autónomo 3. Cuando vuelve a aparecer la ruta a la red A, el sistema autónomo 1 envía un mensaje de anuncio al sistema autónomo 2, que lo envía al sistema autónomo 3. Si la ruta de la red A deja de estar disponible repetidamente para volver a estar disponible después, se envían numerosos mensajes de retirada y de anuncio. Esto es un problema en una red interna conectada a Internet porque una inestabilidad de ruta en la estructura básica de Internet generalmente afecta a muchas rutas.


Nota


No se aplica ninguna pena a un peer BGP reajustado cuando se habilita la amortiguación de Routes. Aunque el restablecimiento retira la ruta, no se aplica ninguna penalización en este caso, incluso si el dampening de la inestabilidad de la ruta está habilitado.

La amortiguación de Routes minimiza la inestabilidad de ruta

La función de dampening de rutas minimiza el problema de la inestabilidad como sigue. Suponga otra vez que la ruta a la red A es inestable. El router del sistema autónomo 2 (donde se ha habilitado el dampening de rutas) asigna a la red A una penalización de 1000 y la desplaza al estado de historial. El router del sistema autónomo 2 continúa anunciando el estado de la ruta a los vecinos. Las sanciones son acumulativas. Cuando la ruta es inestable con tanta frecuencia que la penalización excede de un límite de supresión configurable, el router deja de anunciar la ruta a la red A, sin importar cuántas veces sea inestable. De esta forma, se amortigua la ruta.

La penalización impuesta a la red A se aplaza hasta que se alcanza el límite de reutilización, tras el cual la ruta se anuncia de nuevo. A la mitad del límite de reutilización, la información de dampening de la ruta de la red A se remueve.

Términos de humedecimiento de la ruta BGP

Los términos siguientes se utilizan para describir el dampening de la ruta:

  • Flap--Una ruta cuya Disponibilidad alterna en varias ocasiones.
  • Estado del historial--Después de que una ruta agite una vez, él se asigna una pena y puesto en el estado del historial, significar al router no tiene el mejor trayecto, sobre la base de la información histórica.
  • Pena--Cada vez que una ruta agita, el router configurado para la amortiguación de Routes en otro sistema autónomo asigna a ruta una pena de 1000. Las sanciones son acumulativas. La penalización de la ruta se almacena en la tabla de ruteo BGP hasta que la penalización exceda el límite de supresión. En este punto, el estado de la ruta cambia del historial a damp.
  • Estado húmedo--En este estado, la ruta ha agitado tan a menudo que el router no hará publicidad de esta ruta a los vecinos BGP.
  • Suprima el límite--Se suprime una ruta cuando su pena excede este límite. El valor predeterminado es 2000.
  • Semivida--La ruta se ha asignado una vez una pena, la pena es disminuida por la mitad después del período de semivida (que es 15 minutos por abandono). El proceso de reducción de la sanción ocurre cada 5 segundos.
  • Límite de la reutilización--Mientras que la pena para una ruta inestable disminuye y baja debajo de este límite de la reutilización, la ruta es unsuppressed. Es decir, la ruta se vuelve a añadir a la tabla BGP y se vuelve a utilizar para reenviar. El límite predeterminado de reutilización es 750. El proceso de reactivación de las rutas se produce en incrementos de 10 segundos. Cada 10 segundos, el router detecta qué rutas no se han omitido y las anuncia.
  • El máximo suprime el límite--Este valor es la cantidad máxima de tiempo que una ruta puede ser suprimida. El valor predeterminado es cuatro veces el valor de tiempo de mitad de vida.

Las rutas externas de un sistema autónomo aprendido a través de iBGP no se amortiguan. Esta política evita que los peers iBGP tengan una penalización superior para las rutas externas al sistema autónomo.

Cómo Configurar Funciones BGP Internas

Configurar una confederación del dominio de ruteo

Para configurar una Confederación BGP, usted debe especificar un identificador de confederación. Al mundo exterior, el grupo de sistemas autónomos parecerá un solo sistema autónomo con el identificador de confederación como el número del sistema autónomo. Para configurar un identificador de la Confederación BGP, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# bgp confederation identifier  as-number

Configura una Confederación BGP.

Para tratar a los vecinos de otros sistemas autónomos dentro de la confederación como pares especiales del eBGP, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# bgp confederation peers  as-number [as-number]

Especifica los sistemas autónomos que pertenecen a la confederación.

Para que una manera alternativa reduzca la malla del iBGP, vea “configurar un reflector de ruta.”

Configurar un reflector de ruta

Para configurar un reflector de ruta y a sus clientes, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# neighbor {ip-address | peer-group-name} route-reflector-client

Configura el router local como un reflector de la ruta BGP y el vecino especificado como cliente.

Si el cluster tiene más de un reflector de ruta, configure el cluster ID usando el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# bgp cluster-id  cluster-id 

Configura la identificación del cluster

Utilice el comando show ip bgp de visualizar el ID del originador y los atributos de la cluster-lista.

Por abandono, no requieren a los clientes de un reflector de ruta ser enredados completamente y las rutas de un cliente se reflejan a otros clientes. Sin embargo, si enredan a los clientes completamente, el reflector de ruta no necesita reflejar las rutas a los clientes.

Para inhabilitar el Route Reflection del cliente-a-cliente, no utilice el ningún comando bgp client-to-client reflection en el modo de configuración del router:

Comando

Propósito

Router(config-router)# no bgp client-to-client reflection

Inhabilita el Route Reflection del cliente-a-cliente.

Configurar un reflector de ruta usando un Route Map para fijar el salto siguiente para el par del iBGP

Realice esta tarea en un RR de fijar un salto siguiente para un par del iBGP. Una razón para realizar esta tarea es cuando usted quiere hacer el RR el salto siguiente para las rutas, de modo que usted pueda configurar la carga a compartir del iBGP. Cree un Route Map que fija el salto siguiente para ser el direccionamiento RR, que será hecho publicidad a los clientes RR. El Route Map se aplica solamente a las rutas de salida del router a quien el Route Map es aplicado.


Precaución


Incorrectamente la determinación de los atributos BGP para las rutas reflejadas puede causar el ruteo inconsistente, ruteando los loopes, o una pérdida de conectividad. La determinación de los atributos BGP para las rutas reflejadas se debe intentar solamente por alguien que tiene una buena comprensión de las implicaciones del diseño.



Nota


No utilice el comando neighbor next-hop-self de modificar el atributo del salto siguiente para un RR. Usando el comando neighbor next-hop-self en el RR modificará los atributos del salto siguiente solamente para las rutas NON-reflejadas y no las rutas previstas que se están reflejando de los clientes RR. Para modificar el atributo del salto siguiente al reflejar una ruta, utilice un mapa de ruta de salida.

Esta tarea configura el RR (router 2) en el escenario ilustrado en la figura abajo. En este caso, el router1 es el par del iBGP cuyo se está fijando el salto siguiente de las rutas. Sin un Route Map, las rutas de salida del router1 irían al Next Hop Router 3. En lugar, la determinación del salto siguiente al direccionamiento RR hará las rutas del router1 ir al RR, y permite así que el RR realice el Equilibrio de carga entre el Routers 3, 4, y 5.

‘Figura 4’Reflector de ruta usando un Route Map para fijar el salto siguiente para un par del iBGP


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Map Tag del route-map

4. IP Address de Next Hop determinado del IP

5. salida

6. como-número BGP del router

7. direccionamiento-familia ipv4

8. número del ibgp de las máximo-trayectorias

9. neighbor ip-address telecontrol-como el como-número

10. el neighbor ip-address activa

11 ruta-reflector-cliente del neighbor ip-address

12.    nombre de asignación del route-map del neighbor ip-address hacia fuera

13.    Relance los pasos 12 a 14 para los otros clientes RR.

14.    Finalizar

15.    muestre a los vecinos BGP del IP


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
Map Tag del route-map


Ejemplo:

Route-map RR-hacia fuera de Router(config)#

 

Ingresa al modo de configuración del Route Map para configurar un Route Map.

  • El Route Map se crea para fijar el salto siguiente para el Route Reflector Client.
 
Paso 4
fije el IP Address de Next Hop del IP


Ejemplo:

El router (config-route-map) # fijó el Next-Hop 10.2.0.1 del IP

 

Especifica eso para las rutas se hacen publicidad que donde está aplicado este Route Map, el atributo del salto siguiente se fijan a este direccionamiento del IPv4.

  • Para esta tarea, queremos fijar el salto siguiente para ser el direccionamiento del RR.
 
Paso 5
salida


Ejemplo:

Router (config-route-map) # salida

 

Da salida al modo de configuración del route-map y ingresa al modo de configuración global.

 
Paso 6
como-número BGP del router


Ejemplo:

BGP 100 del router de Router(config)#

 

Ingresa en el modo de configuración de router y crea un proceso de ruteo BGP.

 
Paso 7
direccionamiento-familia ipv4


Ejemplo:

Router (config-router-AF) # direccionamiento-familia ipv4

 

Ingresa en el modo de configuración de la familia de direcciones para configurar los peers BGP de modo que acepten configuraciones específicas de familia de direcciones.

 
Paso 8
número del ibgp de las máximo-trayectorias


Ejemplo:

Router (config-router) # ibgp 5 de las máximo-trayectorias

 

Controla el número máximo de rutas paralelas del iBGP que se puedan instalar en la tabla de ruteo.

 
Paso 9
neighbor ip-address telecontrol-como el como-número


Ejemplo:

Router (config-router-AF) # vecino 10.1.0.1 telecontrol-como 100

 

Agrega una entrada a la tabla del vecino BGP.

 
Paso 10
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 10.1.0.1 activa

 

Habilita el intercambio de información con el par.

 
Paso 11
ruta-reflector-cliente del neighbor ip-address


Ejemplo:

Router (config-router-AF) # ruta-reflector-cliente de 10.1.0.1 del vecino

 

Configura el router local como reflector de la ruta BGP, y configura al vecino especificado como Route Reflector Client.

 
Paso 12
nombre de asignación del route-map del neighbor ip-address hacia fuera


Ejemplo:

Router (config-router-AF) # route-map RR-hacia fuera de 10.1.0.1 del vecino hacia fuera

 

Aplica el Route Map a las rutas salientes de este vecino.

  • Refiérase al Route Map que usted creó en el paso 3.
 
Paso 13
Relance los pasos 12 a 14 para los otros clientes RR.  

Usted no aplicará un Route Map a los otros clientes RR.

 
Paso 14
Finalizar


Ejemplo:

Router (config-router-AF) # extremo

 

Sale del modo de configuración de la familia de direcciones e ingresa en el modo EXEC privilegiado.

 
Paso 15
muestre a los vecinos BGP del IP


Ejemplo:

Vecinos BGP del IP de la demostración del Router-

 

Información (opcional) de las visualizaciones sobre los vecinos BGP, incluyendo su estatus como clientes RR, e información sobre el Route Map configurado.

 

Ajuste de los temporizadores BGP

El BGP utiliza a ciertos temporizadores para controlar las actividades periódicas tales como el envío de los mensajes de keepalive y del intervalo después de que no reciba un mensaje de keepalive después de lo cual el Cisco IOS Software declare a los muertos de un par. Por abandono, el temporizador KEEPALIVE es 60 segundos, y el temporizador del tiempo en espera es 180 segundos. Usted puede ajustar estos temporizadores. Cuando se comienza una conexión, el BGP negociará el tiempo en espera con el vecino. El más pequeño del dos tiempo en espera será elegido. El temporizador KEEPALIVE entonces se fija basado en el tiempo en espera negociado y el tiempo configurado del keepalive.

Para ajustar los temporizadores BGP para que haya todos los vecinos, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# timers bgp  keepalive holdtime

Ajusta los temporizadores BGP según todos los vecinos.

Para ajustar los temporizadores del keepalive y del tiempo en espera BGP para que haya un vecino específico, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# neighbor [ip-address | peer-group-name] timers  keepalive holdtime 

Fija los temporizadores del keepalive y del tiempo en espera (en los segundos) para el par o el grupo de peer especificado.


Nota


Los temporizadores configurados para una invalidación específica del vecino o del grupo de peer que los temporizadores configuraron para todos los vecinos BGP que usaban el comando router configuration BGP de los temporizadores.

Para borrar los temporizadores para un vecino BGP o un grupo de peer, no utilice la ninguna forma del comando timers vecino.

Configurar al router para considerar un MED que falta como trayectoria peor

Para configurar al router para considerar una trayectoria con un atributo que falta MED como la trayectoria peor, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# bgp bestpath med missing-as-worst

Configura al router para considerar un MED que falta como teniendo un valor del infinito, haciendo la trayectoria sin un valor de MED el menos trayecto deseable.

Configurar al router para considerar el MED para elegir una trayectoria de los trayectos del sistema de Subautonomous

Para configurar al router para considerar el valor de MED en elegir una trayectoria, utilice el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# bgp bestpath med confed

Configura al router para considerar el MED en elegir una trayectoria entre de ésas des divulgación por diversos sistemas subautonomous dentro de una confederación.

La comparación entre los MED se hace solamente si no hay sistemas autónomos externos en la trayectoria (un sistema autónomo externo es un sistema autónomo que no está dentro de la confederación). Si hay un sistema autónomo externo en la trayectoria, después el externo MED se pasa transparente con la confederación, y la comparación no se hace.

El siguiente ejemplo compara la ruta A con estas trayectorias:

path= 65000 65004, med=2
path= 65001 65004, med=3
path= 65002 65004, med=4
path= 65003 1, med=1

En este caso, la trayectoria 1 sería elegida si bgp bestpath el configurationcommand confed MED del router se habilita. La cuarta trayectoria tiene un MED más bajo, pero no está implicada en la comparación MED porque hay un sistema autónomo externo está en esta trayectoria.

Configurar al router para utilizar el MED para elegir una trayectoria en una confederación

Para configurar al router para utilizar el MED para elegir el mejor trayecto entre de las trayectorias hizo publicidad por un solo sistema subautonomous dentro de una confederación, utiliza el siguiente comando en el modo de configuración del router:

Comando

Propósito

Router(config-router)# bgp deterministic med

Configura al router para comparar la variable MED al elegir entre las rutas des divulgación por diversos pares en el mismo sistema autónomo.


Nota


Si habilitan al comando router configuration del always-compare-med BGP, todas las trayectorias son completamente comparables, incluyendo ésas de otros sistemas autónomos en la confederación, incluso si habilitan al comando bgp deterministic med también.

Habilitar el humedecimiento de la ruta BGP

Para habilitar la ruta BGP que humedece, utilice el siguiente comando en la familia o el modo de configuración del router del direccionamiento:

Comando

Propósito

Router(config-router)# bgp dampening

Humedecimiento de la ruta BGP de los permisos.

Para cambiar los valores predeterminados de los diversos factores de humedecimiento, utilice el siguiente comando en la familia o el modo de configuración del router del direccionamiento:

Comando

Propósito

Router(config-router)# bgp dampening  half-life reuse suppress max-suppress [route-map  map-name]

Cambia los valores predeterminados de los factores de la amortiguación de Routes.

Monitoreo y Mantenimiento del Dampening de la Ruta de BGP

Usted puede monitorear las aletas de todas las trayectorias que están agitando. Las estadísticas se eliminarán cuando se reactive la ruta y se mantenga estable durante al menos la mitad de su vida útil. Para visualizar las estadísticas del flap, utilice los siguientes comandos según las necesidades:

Comando

Propósito

Router# show ip bgp flap-statistics

Estadísticas del flap de las visualizaciones BGP para todas las trayectorias.

Router# show ip bgp flap-statistics regexp  regexp

Estadísticas del flap de las visualizaciones BGP para todas las trayectorias que hacen juego la expresión normal.

Router# show ip bgp flap-statistics filter-list access- list

Estadísticas del flap de las visualizaciones BGP para todas las trayectorias que pasan el filtro.

Router# show ip bgp flap-statistics  ip-address mask

Estadísticas del flap de las visualizaciones BGP para una sola entrada.

Router# show ip bgp flap-statistics  ip-address mask longer-prefix

Estadísticas del flap de las visualizaciones BGP para más entradas específicas.

Para borrar las estadísticas del flap BGP (así haciéndolo menos probablemente que la ruta será humedecida), utilice los siguientes comandos según las necesidades:

Comando

Propósito

Router# clear ip bgp flap-statistics 

Estadísticas del flap de los claros BGP para todas las rutas.

Router# clear ip bgp flap-statistics regexp regexp

Estadísticas del flap de los claros BGP para todas las trayectorias que hacen juego la expresión normal.

Router# clear ip bgp flap-statistics filter-list  list

Estadísticas del flap de los claros BGP para todas las trayectorias que pasan el filtro.

Router# clear ip bgp flap-statistics  ip-address mask

Estadísticas del flap de los claros BGP para una sola entrada.

Router# clear ip bgp  ip-address  flap-statistics

Estadísticas del flap de los claros BGP para todas las trayectorias de un vecino.


Nota


Las estadísticas del flap para una ruta también se borran cuando reajustan a un peer BGP. Aunque la restauración retire la ruta, no hay en este caso aplicado pena, incluso si se habilita el Route Flap Dampening.

Que sigue habiendo una ruta se humedece una vez, usted puede visualizar la información de amortiguación de la ruta BGP, incluyendo el tiempo antes de que las rutas humedecidas sean unsuppressed. Para visualizar la información, utilice el siguiente comando:

Comando

Propósito

Router# show ip bgp dampened-paths

Visualiza las rutas humedecidas, incluyendo el tiempo que permanece antes de que sean unsuppressed.

Usted puede borrar la información de amortiguación y los unsuppress de la ruta BGP cualquier ruta suprimida usando el siguiente comando:

Comando

Propósito

Router# clear ip bgp dampening [ip-address network-mask]

Información y unsuppresses de la amortiguación de Routes de los claros las rutas suprimidas.

Ejemplos de Configuración de la Función Internal BGP

Configuraciones de la Confederación BGP del ejemplo con el Route Maps

Esta sección contiene un ejemplo del uso de una configuración de la Confederación BGP que incluya las comunidades BGP y los mapa del ruta. Por más ejemplos de cómo configurar una Confederación BGP, vea la Confederación BGP de los ejemplos de la sección en este capítulo.

Este ejemplo muestra cómo los atributos de la comunidad BGP se utilizan con una configuración de la Confederación BGP a las rutas de filtro.

En este ejemplo, el Route Map nombrado conjunto-comunidad se aplica a las actualizaciones salientes al vecino 172.16.232.50 y local-como el atributo de la comunidad se utiliza para filtrar las rutas. Las rutas que pasan la lista de acceso 1 tienen el valor de atributo de la comunidad especial local-como. Las rutas restantes se anuncian normalmente. Este valor de la comunidad especial previene automáticamente el anuncio de esas rutas por los BGP de conversaciones fuera del sistema autónomo 200.

router bgp 65000
 network 10.0.1.0 route-map set-community
 bgp confederation identifier 200
 bgp confederation peers 65001
 neighbor 172.16.232.50 remote-as 100
 neighbor 172.16.233.2 remote-as 65001
!
route-map set-community permit 10
 match ip address 1
 set community local-as
!

Confederación BGP de los ejemplos

Lo que sigue es una configuración de muestra que muestra a varios pares en una confederación. La confederación consiste en tres sistemas autónomos internos con los números del sistema autónomos 6001, 6002, y 6003. A los BGP de conversaciones fuera de la confederación, la confederación parece un sistema autónomo normal con el número del sistema autónomo 500 (especificado vía el comando router configuration del identificador de confederación BGP).

En un BGP de conversación en el sistema autónomo 6001, el comando router configuration de los pares de la confederación BGP marca a los pares de los sistemas autónomos 6002 y 6003 como pares especiales del eBGP. Por lo tanto mira 172.16.232.55 y 172.16.232.56 conseguirá la preferencia local, el salto siguiente, y el MED sin modificar en las actualizaciones. El router en 10.16.69.1 es interlocutores eBGP normales y las actualizaciones recibidas por ellos de este par serán apenas como una actualización normal del eBGP de un par en el sistema autónomo 6001.

router bgp 6001
 bgp confederation identifier 500
 bgp confederation peers 6002 6003
 neighbor 172.16.232.55 remote-as 6002
 neighbor 172.16.232.56 remote-as 6003
 neighbor 10.16.69.1 remote-as 777

En un BGP de conversación en el sistema autónomo 6002, configuran a los pares de los sistemas autónomos 6001 y 6003 como pares especiales del eBGP. 10.70.70.1 es un par normal del iBGP y 10.99.99.2 es un par normal del eBGP del sistema autónomo 700.

router bgp 6002
 bgp confederation identifier 500
 bgp confederation peers 6001 6003
 neighbor 10.70.70.1 remote-as 6002
 neighbor 172.16.232.57 remote-as 6001
 neighbor 172.16.232.56 remote-as 6003
 neighbor 10.99.99.2 remote-as 700

En un BGP de conversación en el sistema autónomo 6003, configuran a los pares de los sistemas autónomos 6001 y 6002 como pares especiales del eBGP. 10.200.200.200 es un par normal del eBGP del sistema autónomo 701.

router bgp 6003
 bgp confederation identifier 500
 bgp confederation peers 6001 6002
 neighbor 172.16.232.57 remote-as 6001
 neighbor 172.16.232.55 remote-as 6002
 neighbor 10.200.200.200 remote-as 701

Lo que sigue es una parte de la configuración del BGP de conversación 10.200.200.205 del sistema autónomo 701 en el mismo ejemplo. Configuran al vecino 172.16.232.56 como interlocutores eBGP normales del sistema autónomo 500. La división interna del sistema autónomo en los sistemas autónomos múltiples no se sabe a los pares externos a la confederación.

router bgp 701
 neighbor 172.16.232.56 remote-as 500
 neighbor 10.200.200.205 remote-as 701

Reflector de ruta del ejemplo usando un Route Map para fijar el salto siguiente para el par del iBGP

El siguiente ejemplo se basa en la figura arriba. El router2 es el reflector de ruta para los clientes: El Routers 1, 3, 4, y 5. router1 están conectados con el router3, solamente usted no quisiera que el router1 remitiera el tráfico destinado al AS200 para utilizar el router3 como el salto siguiente (y por lo tanto utilizar el link directo con el router 3); usted quiere dirigir el tráfico al RR, que puede cargar la parte entre el Routers 3, 4, y 5.

Este ejemplo configura el RR, router2. Un Route Map nombrado RR-hacia fuera se aplica al router1; el Route Map fija el salto siguiente para ser el RR en 10.2.0.1. Cuando el router1 ve que el salto siguiente es el direccionamiento RR, router1 adelante las rutas al RR. Cuando el RR recibe los paquetes, cargará automáticamente la parte entre las trayectorias del iBGP. Un máximo de cinco trayectorias del iBGP se permite.

Router 2

route-map rr-out
 set ip next-hop 10.2.0.1 
!
interface gigabitethernet 0/0
 ip address 10.2.0.1 255.255.0.0
router bgp 100
 address-family ipv4 unicast
 maximum-paths ibgp 5
 neighbor 10.1.0.1 remote-as 100
 neighbor 10.1.0.1 activate
 neighbor 10.1.0.1 route-reflector-client
 neighbor 10.1.0.1 route-map rr-out out
!
 neighbor 10.3.0.1 remote-as 100
 neighbor 10.3.0.1 activate
 neighbor 10.3.0.1 route-reflector-client
!
 neighbor 10.4.0.1 remote-as 100
 neighbor 10.4.0.1 activate
 neighbor 10.4.0.1 route-reflector-client
!
 neighbor 10.5.0.1 remote-as 100
 neighbor 10.5.0.1 activate
 neighbor 10.5.0.1 route-reflector-client
end

Soporte del autodetección del ejemplo BGP VPL en el reflector de ruta

En el siguiente ejemplo, un host nombrado PE-RR (que indica el reflector de ruta del borde del proveedor) se configura como reflector de ruta capaz de reflejar los prefijos VPL. Los vpls de la direccionamiento-familia l2vpn configura a la familia del direccionamiento VPL abajo.

hostname PE-RR
!
router bgp 1
 bgp router-id 1.1.1.3
 no bgp default route-target filter
 bgp log-neighbor-changes
neighbor iBGP_PEERS peer-group
neighbor iBGP_PEERS remote-as 1
neighbor iBGP_PEERS update-source Loopback1  
neighbor 1.1.1.1 peer-group iBGP_PEERS  
neighbor 1.1.1.2 peer-group iBGP_PEERS  
!
address-family l2vpn vpls
  neighbor iBGP_PEERS send-community extended
  neighbor iBGP_PEERS route-reflector-client
  neighbor 1.1.1.1 peer-group iBGP_PEERS
  neighbor 1.1.1.2 peer-group iBGP_PEERS  
exit-address-family 
!

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con configurar las características del Internal BGP.

Documentos Relacionados

Tema relacionado

Título del documento

Comandos BGP

Routing IP del Cisco IOS: Referencia del comando bgp

Descripción general de BGP

Módulo "Descripción General de Cisco BGP"

Tareas básicas de la configuración BGP

Módulo "Configuración de una Red BGP Básica"

carga a compartir de la ruta múltiple iBGP

“módulo de la carga a compartir de la ruta múltiple iBGP”

Conexión con un proveedor de servicio

“Conectando con un proveedor de servicio que usa módulo del BGP externo”

Configurando las características que se aplican IP múltiple a los Routing Protocol

Routing IP del Cisco IOS: Guía de configuración del protocolo independiente

Estándares

Estándar

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 1772

Aplicación de Border Gateway Protocol en Internet

RFC 1773

Experiencia con el Protocolo BGP

RFC 1774

Análisis del Protocolo BGP-4

RFC 1930

Pautas para la Creación, Selección y Registro de un Autonomous System (AS)

RFC 2519

Un Marco para la Agregación de Rutas Entre Dominios

RFC 2858

Extensiones Multiprotocolo para BGP-4

RFC 2918

Capacidad de Actualización de Ruta para BGP-4

RFC 3392

Anuncio de Capacidades con BGP-4

RFC 4271

Un Border Gateway Protocol 4 (BGP-4)

RFC 4893

Soporte BGP para el Espacio de Números AS de Cuatro Octetos

RFC 5396

Representación Textual de los Números del Sistema autónomo (AS)

RFC 5398

Reserva de Números de Sistema autónomo (AS) para Uso en Documentación

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre Funciones para Configurar Funciones de BGP Interno

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información sobre Funciones para Configurar Funciones de BGP Interno

Nombre de la función

Versiones

Información de la Configuración de la Función

Configurar las características del Internal BGP

10,3

12.0(32)S12

12.0(7)T

12.2(33)SRA

12.2(33)SXH

Todas las características contenidas en este módulo se consideran ser características de la herencia y trabajarán en todas las imágenes de la versión de los trenes.

Los siguientes comandos fueron introducidos o modificados por estas características:

  • always-compare-med BGP
  • bgp bestpath MED confed
  • bgp bestpath MED que falta-como-más malo
  • reflexión del cliente-a-cliente BGP
  • cluster-identificación BGP
  • identificador de confederación BGP
  • pares de la confederación BGP
  • humedecimiento BGP
  • bgp deterministic med
  • borre el humedecimiento BGP del IP
  • borre el flap-statistics BGP del IP
  • ruta-reflector-cliente vecino
  • temporizadores vecinos
  • muestre el BGP del IP
  • muestre la trayectoria que ya no sirve BGP del IP
  • show ip bgp flap-statistics
  • BGP de los temporizadores

Mapa de ruta de salida BGP en el reflector de ruta para fijar el salto siguiente IP

12.0(22)S

12.0(16)ST

12,2

12.2(14)S

15.0(1)S

El mapa de ruta de salida BGP en el reflector de ruta para fijar la característica del salto siguiente IP permite que un reflector de ruta modifique el atributo del salto siguiente para una ruta reflejada.

Soporte del autodetección BGP VPL en el reflector de ruta

12.2(33)SRE

Esta característica fue introducida en el Routers de las Cisco 7600 y Cisco 7200 Series.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.