Routing IP: Guía de configuración ISIS, Cisco IOS Release 12.2SR
Reducción del Tiempo de Cálculo de Trayectorias Alternativas en las Redes IS-IS
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 318 KB | Inglés (30 Enero 2012) | Comentarios

Contenido

Reducción del Tiempo de Cálculo de Trayectorias Alternativas en las Redes IS-IS

Última actualización: De enero el 27 de 2012

Las tareas en este módulo explican cómo ajustar el IS-IS y al Routers del permiso a responden más rápidamente a los cambios de la topología y a los desperfectos de la red cuando reciben las actualizaciones de ruteo que hacen publicidad de los cambios de la topología.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Prerrequisitos para Reducir Tiempos de Cálculo de Trayectoria Alternativa en Redes IS-IS

Usted debe ser familiar con los conceptos descritos en “descripción el módulo de la convergencia rápida IS-IS”.

Información sobre la Reducción de los Tiempos de Cálculo de Trayectorias Alternativas en Redes IS-IS

El IS-IS utiliza el algoritmo SPF de Dijkstra para computar el Árbol de ruta más corto (SPT). Durante el cálculo del SPT se detecta la trayectoria más corta para cada nodo. El árbol de topología se utiliza para rellenar la tabla de ruteo con rutas a redes IP. Cuando ocurren los cambios, se recalcula el SPT entero. En muchos casos, el SPT completo no necesitó ser recalculado porque la mayor parte del árbol no se ha modificado. El SPF incremental permite que el sistema recalcule solamente la parte de afectada del árbol. Recalcular solamente una porción del árbol bastante que el árbol entero da lugar a una convergencia más rápida IS-IS y guarda a los recursos de la CPU.

El SPF ampliado computa solamente los pasos necesarios para aplicar los cambios en el diagrama de la topología de red. Ese proceso requiere que el sistema guarde más información sobre la topología para aplicar los cambios ampliados. También, más proceso se debe hacer en cada nodo para el cual el sistema reciba un nuevo LSP. Sin embargo, el SPF ampliado reduce típicamente la demanda en el CPU.

Redistribución de ruta

Se permite al Routers redistribuir los prefijos externos, o las rutas, que son doctas de cualquier otro Routing Protocol, configuración estática, o interfaz conectada. Las rutas redistribuido se permiten en un 1 Router llano o un 2 Router llano. Cuando las rutas del nivel 2 se inyectan como rutas del nivel 1, esto se llama Route Leaking.

IS-IS Caching of Redistributed Routes

Empezando por el Cisco IOS Release 12.0(27)S, y posterior las versiones, IS-IS ocultan las rutas que se redistribuyen de otros Routing Protocol o de otro nivel IS-IS en un caché local de la redistribución que sea mantenido por el IS-IS. El almacenamiento en memoria caché ocurre automáticamente y no requiere ninguna configuración. El almacenamiento en memoria caché de las rutas redistribuidas mejora el tiempo de convergencia de IS-IS cuando las rutas se redistribuyen en IS-IS. El almacenamiento en memoria caché de IS-IS de las rutas redistribuidas aumenta el rendimiento de la generación de LSPs, lo que mejora de forma significativa la escalabilidad de la red.

Prioridad de la Actualización de los Prefijos IP en RIB para Reducir el Tiempo de Cálculo de Trayectorias Alternativas

La época necesaria para que el Routing Information Base IS-IS (RIB) o la tabla de ruteo se ponga al día depende del número de prefijos cambiados o de rutas IS-IS que deban ser actualizados. Usted puede marcar los prefijos importantes IP con etiqueta IS-IS y configurar al router para dar la prioridad a los prefijos marcados con etiqueta para poner al día los prefijos prioritarios primero en el RIB. Por ejemplo, los Loopback Address para el Routers en un entorno del MPLS VPN se consideran los prefijos prioritarios.

IS-IS Priority-Driven IP Prefix RIB Installation

En una red donde el Routers ejecuta protocolo IS-IS, la convergencia es alcanzada distribuyendo una vista coherente de la topología a todo el Routers en la red. Cuando un evento de red causa un cambio de la topología, varios pasos deben ocurrir para que la convergencia ocurra. El router que detecta inicialmente el cambio de la topología (por ejemplo, un cambio de estado de la interfaz) debe informar al otro Routers el cambio de la topología inundando la información de ruteo actualizada (bajo la forma de link-state PDU) al otro Routers. Todo el Routers, incluyendo el router que detectó el cambio de la topología, debe utilizar la información de topología actualizada para recalcular los trayectos más cortos (funcionados con un SPF), proporcionando a la salida actualizada del cálculo SPF al RIB del router, que hará eventual la información de ruteo actualizada ser utilizado para remitir los paquetes. Hasta que todo el Routers haya realizado estos pasos básicos, algunos destinos pueden ser temporalmente inalcanzables. La convergencia más rápida beneficia al rendimiento de la red minimizando el período de tiempo durante el cual información de topología añeja--la información de ruteo anterior que obsoleted por la información de ruteo actualizada--se utiliza para remitir los paquetes.

Después de realizar un SPF, el IS-IS debe instalar las rutas actualizadas en el RIB. Si el número de prefijos des divulgación por el IS-IS es grande, el tiempo entre la instalación del primer prefijo y el prefijo más reciente es significativo. La instalación a base de prioridad del RIB del prefijo IP permite un subconjunto de los prefijos des divulgación por el IS-IS que se señalará como tener una prioridad más alta. Las actualizaciones a las trayectorias a estos prefijos serán instaladas antes de que las actualizaciones a los prefijos que no tienen esta designación. Esto reduce el tiempo de convergencia para los prefijos importantes y los resultados IP IS-IS en más rápidamente la puesta al día para las rutas que son dependientes en estos prefijos. Esto a su vez acorta el tiempo durante el cual la información que ha expirado se utiliza para remitir los paquetes a estos destinos.

Los prefijos se caracterizan como teniendo uno de tres niveles de importancia:

  1. Prefijos prioritarios--los prefijos que se han marcado con etiqueta con una etiqueta señalaron para la convergencia rápida.
  2. Prefijos de la Prioridad media--cualquier prefijos de /32 que no se hayan señalado como prefijos prioritarios.
  3. Prefijos de la prioridad baja--el resto de los prefijos.

Cuando el IS-IS pone al día el RIB, los prefijos se ponen al día en la orden basada en el nivel asociado de importancia.

Cuando usted asigna una etiqueta prioritaria a algunos prefijos IP IS-IS, esos prefijos con la prioridad más alta se ponen al día en las tablas de ruteo antes de los prefijos con la prioridad baja. En algunas redes, los prefijos prioritarios serán los Loopback Address del borde del proveedor (PE). El tiempo de convergencia se reduce para los prefijos importantes y los resultados IP IS-IS en el tiempo de convergencia reducido para los procesos actualización que ocurren en el RIB global y el Cisco Express Forwarding (CEF).

Etiquetado de Rutas IS-IS para Controlar su Redistribución

Usted puede controlar la redistribución de las rutas IS-IS marcándolas con etiqueta. El término “Route Leaking” refiere a la distribución que controla con marcar con etiqueta de las rutas.

Cómo Pueden los Resúmenes de Rutas Aumentar la Escalabilidad de las Redes IS-IS

El resumen es un factor clave que afecta al scalability de un Routing Protocol. El resumen reduce el número de actualizaciones de ruteo que se inunden a través de las áreas o de los dominios de ruteo. Especialmente para el multi-área IS-IS, un buen esquema de direccionamiento puede optimizar el resumen no permitiendo una base de datos excesivamente grande del nivel 2 que se pueble innecesariamente con las actualizaciones que han venido del nivel 1 área.

Un router puede resumir los prefijos en la redistribución si los prefijos han venido de los prefijos internos, de la redistribución local, o de la redistribución llana del 1 Router. Las rutas que han sido el nivel escapado 2 al nivel 1 y las rutas que se hacen publicidad en el nivel 2 del nivel 1 pueden también ser resumidas.

Beneficios de las Etiquetas de Ruta IS-IS

  • El soporte IS-IS para la característica de las etiquetas de la ruta permite que usted marque los IP Addresses con etiqueta de una interfaz y que utilice la etiqueta para aplicar la directiva administrativa con un Route Map.
  • Usted puede marcar las rutas IS-IS con etiqueta para controlar su redistribución. Usted puede configurar un Route Map para fijar una etiqueta para un prefijo IP IS-IS (ruta) y/o para hacer juego en la etiqueta (quizás en un diverso router) para redistribuir las rutas IS-IS. Aunque la etiqueta y los comandos set tag del emparejamiento existieran para otros protocolos antes de esta característica, no fueron implementados para el IS-IS, así que no hicieron nada cuando estaban especificados en una red IS-IS hasta ahora.
  • Usted puede marcar una ruta de resumen con etiqueta y después utilizar un Route Map para hacer juego la etiqueta y para fijar uno o más atributos para la ruta.

Características de la Etiqueta de Ruta IS-IS

Un número de Tag de la ruta IS-IS puede ser hasta 4 bytes de largo. El valor de la etiqueta se fija en un TLV secundario 1 para el tipo 135 TLV (Type Length Value). Para más información sobre el tipo 135 TLV, vea que el documento del Intermediate System-to-Intermediate System (IS-IS) TLV referido “relacionó a la sección de los documentos”.

Solamente una etiqueta se puede fijar a una ruta de IP IS-IS (prefijo). La etiqueta se envía en el link-state PDU (LSP) que hace publicidad de la ruta. La determinación de una etiqueta a una ruta sola no hace nada para su red. Usted puede utilizar la etiqueta de la ruta en el área o los límites del nivel 1/Level 2 correspondiendo con en la etiqueta y después aplicando las directivas administrativas tales como redistribución, resumen de Route, o Route Leaking.

Configurar una etiqueta para una interfaz (con el comando tag ISIS) acciona la generación de nuevos LSP del router porque la etiqueta es nueva información para los PDU.

Agotamiento de Rutas IS-IS Basada en una Etiqueta de Ruta

Usted puede marcar las rutas IS-IS con etiqueta para configurar Route Leaking (redistribución). Puesto que solamente se redistribuyen las rutas apropiadas--o escapado--los resultados son escalabilidad de la red y una convergencia más rápida para la actualización del router. Si usted configura Route Leaking y usted quiere hacer juego en una etiqueta, utilice un Route Map (no una lista de la distribución). Para más información sobre Route Leaking, vea el documento IS-IS Route Leaking referido al IS-IS Route Leaking basado en una sección de la etiqueta de la ruta.

Hay dos pasos generales a usar las etiquetas de la ruta IS-IS: marcando las rutas con etiqueta y refiriéndose a la etiqueta a los valores establecidos para las rutas y/o redistribuya las rutas.

Hay tres maneras de marcar las rutas IS-IS con etiqueta: marque las rutas con etiqueta para las redes conectadas directamente con una interfaz, fije una etiqueta en un Route Map, o marque una ruta de resumen con etiqueta. Los tres métodos se describen en esta sección. El método que marca con etiqueta es independiente de cómo usted utiliza la etiqueta.

Después de que usted marque las rutas con etiqueta, usted puede utilizar la etiqueta a los valores establecidos (tales como un métrico, o salto siguiente, y así sucesivamente) y/o redistribuir las rutas. Usted puede ser que marque las rutas con etiqueta en un router, pero se refiere a la etiqueta en el otro Routers, dependiendo de lo que usted quiere alcanzar. Por ejemplo, usted podría marcar la interfaz con etiqueta en el router A con una etiqueta, hacer juego la etiqueta en el router B a los valores establecidos, y redistribuir las rutas en el C del router basado en los valores usando un Route Map.

Limitación del Número de Rutas que se Redistribuyen en IS-IS

Si alguien inyecta equivocadamente un gran número de rutas de IP en el IS-IS, quizás redistribuyendo el Border Gateway Protocol (BGP) en el IS-IS, la red puede ser inundada seriamente. Este posible problema se previene limitando el número de rutas redistribuidas. Usted puede cualquier configuración IS-IS parar el permitir que de las rutas sean redistribuidas una vez que se ha alcanzado su valor configurado máximo o configurar el software para generar una advertencia de sistema que el número de prefijos redistribuidos ha alcanzado una vez el valor máximo. Antes de configurar las tareas en esta sección, usted debe ser familiar con el concepto siguiente.

Estado completo LSP

En algunos casos cuando un límite no se pone en el número de rutas redistribuido, el LSP puede llegar a ser lleno y las rutas pueden ser caídas. Un usuario puede especificar cuál rutea debe ser suprimido en ese evento para manejar la consecuencia de un estado completo LSP de una manera agraciada y fiable.

La redistribución es generalmente la causa del estado completo LSP. Por abandono, las rutas externo redistribuidas en el IS-IS se suprimen si ocurre el estado completo LSP. El IS-IS puede tener 255 fragmentos para un LSP en un nivel. Cuando no hay espacio dejado en los fragmentos uces de los, se genera un mensaje de error LSPFULL.

Una vez que se resuelve el problema que causó a LSP el estado completo, un usuario puede borrar el estado LSPFULL.

Esta sección contiene los siguientes procedimientos, que son mutuamente excluyentes. Es decir, usted no puede limitar los prefijos redistribuidos y también elegir ser advertido solamente.

Simplificación del Proceso de Actualización de la Tabla de Ruteo Excluyendo Prefijos de IP conectados desde Anuncios LSP

Para acelerar la convergencia IS-IS, el número de prefijos IP llevó adentro los LSP necesita ser limitado. El configurar interconecta como innumerable limitaría los prefijos. Sin embargo, por las razones de la Administración de redes, usted puede ser que quiera tener interfaces numeradas y también querer evitar la publicidad de los direccionamientos de la interfaz en el IS-IS. Hay dos métodos alternativos para evitar la superpoblación de las tablas de ruteo y de tal modo para reducir el tiempo de convergencia IS-IS. Para elegir el método que trabajará mejor para su red, usted debe hacer familiar con los conceptos siguientes.

Método a escala reducida para reducir el tiempo de convergencia IS-IS

Usted puede configurar explícitamente una interfaz IS-IS para no hacer publicidad de su red del IP a los vecinos (usando ningún ISIS haga publicidad-prefixcommand). Este método es posible para una pequeña red; no escala bien. Si usted tiene docenas o los centenares de Routers en su red, con posiblemente diez por tantas interfaces físicas implicadas, sería difícil agregar este comando a la configuración de cada router.

Método en grande para reducir el tiempo de convergencia IS-IS

Una manera más fácil de reducir la convergencia IS-IS es configurar el caso IS-IS en un router para hacer publicidad solamente de las interfaces pasivas (usando el comando hacer publicidad-pasivo-solamente). Este comando confía en el hecho de que al habilitar el IS-IS en un Loopback Interface, usted configura generalmente el loopback como voz pasiva (evitar el mandar del hola innecesario PDU con él porque no hay ocasión de encontrar a un vecino detrás de ella). Así, si usted quiere hacer publicidad solamente del loopback y si se ha configurado ya como voz pasiva, configurar el comando hacer publicidad-pasivo-solamente por el caso IS-IS prevendría la superpoblación de las tablas de ruteo.

Ventaja de excluir los prefijos IP de las redes conectadas en los anuncios LSP

Si usted elige prevenir la publicidad de los redes secundarios de la interfaz IS-IS o hacer publicidad solamente de los prefijos IS-IS que pertenecen a las interfaces pasivas (del loopback), usted reducirá el tiempo de convergencia IS-IS. Los mecanismos IS-IS para excluir los prefijos conectados IP de la característica de los anuncios LSP se recomiendan en todo caso donde se requiere la convergencia rápida.

Cómo Reducir los Tiempos de Cálculo de Trayectorias Alternativas en las Redes IS-IS

Configuración de SPF Incremental

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. área-etiqueta ISIS del router

4. ispf [level-1 | nivel 2 | level-1-2][seconds]

5. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
área-etiqueta ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

Habilita IS-IS como protocolo de ruteo IP y asigna una etiqueta a un proceso, si es necesario.

  • Ingresa en el modo de configuración del router.
 
Paso 4
ispf [level-1 | nivel 2 | level-1-2][seconds]


Ejemplo:

Router (config-router) # ispf level-1-2 60

 

Habilita el SPF incremental.

  • El argumento de los segundos representa el número de segundos después de configurar este comando que el SPF ampliado está activado. El valor puede estar en el rango a partir de la 1 a 600. El valor predeterminado es 120 segundos. El argumento de los segundos se aplica solamente cuando usted ha habilitado el IS-IS.
 
Paso 5
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Vuelve al modo EXEC privilegiado.

 

Asignación de una etiqueta prioritaria a un prefijo IP IS-IS

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. [area-tag] ISIS del router del IP

5. etiqueta-valor de la etiqueta ISIS

6. salida

7. [area-tag] ISIS del router

8. etiqueta-valor de la etiqueta de la alta prioridad de la ruta de IP

9. extremo

10. muestre el RIB ISIS [IP address | IP-direccionamiento-máscara]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interface ethernet 0 de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

 
Paso 4
[area-tag] ISIS del router del IP


Ejemplo:

Router (config-if) # ISIS tag13 del router del IP

 

Los permisos IS-IS como IP Routing Protocol, y asignan una etiqueta a un proceso, si procede.

Nota    Si el argumento de la área-etiqueta no se especifica, se asume una etiqueta nula y el proceso se refiere con una etiqueta nula. Este nombre debe ser único entre todo el IP o procesos del router del servicio de red sin conexión (CLNS) para un router dado.
 
Paso 5
etiqueta-valor de la etiqueta ISIS


Ejemplo:

Router (config-if) # etiqueta 17 ISIS

 

Fija una etiqueta en la dirección IP configurada para una interfaz cuando este prefijo IP se pone en un IS-IS LSP.

  • El argumento del etiqueta-valor requiere un interger en un rango a partir de la 1 a 4294967295 y sirve como etiqueta en una ruta IS-IS.
 
Paso 6
salida


Ejemplo:

Router(config-if)# exit

 

Vuelve al modo de configuración global.

 
Paso 7
[area-tag] ISIS del router


Ejemplo:

Márketing ISIS del router de Router(config)#

 

Habilita el protocolo de ruteo IS-IS y especifica un proceso IS-IS. Ingresa en el modo de configuración del router.

Nota    Si el argumento de la área-etiqueta no se especifica, se asume una etiqueta nula y el proceso se refiere con una etiqueta nula. Este nombre debe ser único entre todos los procesos del router IP o CLNS para un router dado.
 
Paso 8
etiqueta-valor de la etiqueta de la alta prioridad de la ruta de IP


Ejemplo:

Router (config-router) # etiqueta 17 de la alta prioridad de la ruta de IP

 

Asigna un prioritario a los prefijos asociados al valor especificado de la etiqueta.

  • Asigna un prioritario a los prefijos IP IS-IS con una etiqueta específica de la ruta en un rango a partir de la 1 a 4294967295 que usted especifique para el argumento del etiqueta-valor.
 
Paso 9
Finalizar


Ejemplo:

Router (config-router) # extremo

 

(Opcional) guarda los comandos configuration al archivo de configuración corriente y las devoluciones al modo EXEC privilegiado.

 
Paso 10
muestre el RIB ISIS [IP address | IP-direccionamiento-máscara]


Ejemplo:

RIB 255.255.255.0 ISIS de la demostración del Router-

 

Visualiza las trayectorias para una ruta específica en versión IP el RIB local de 4 IS-IS.

  • El IS-IS mantiene las bases de datos locales para toda la información de ruteo IS-IS. Estas bases de datos locales se refieren como el RIB local IS-IS. Contienen los atributos adicionales que no se mantienen en la tabla de ruteo del IP global. El acceso al contenido del RIB local se utiliza para soportar el comando del RIB ISIS de la demostración, que se utiliza aquí para verificar rutear relacionado con la información a la característica a base de prioridad de la instalación del RIB del prefijo IP.
 

Consejos de Troubleshooting

Usted puede ingresar el comando local del RIB ISIS del debug de verificar si los prefijos IP que son hechos publicidad por el link-state PDU (LSP) IS-IS se están poniendo al día correctamente en el RIB local IS-IS.

Marcando las rutas con etiqueta para las redes conectadas directamente con una interfaz

Antes de comenzar
  • Porque la etiqueta de la ruta IS-IS será utilizada en un Route Map, usted debe entender cómo configurar un Route Map.
  • Para utilizar la etiqueta de la ruta, usted debe configurar el comando metric-style wide. (El narrowcommand del métrico-estilo se configura por abandono). El valor de la etiqueta se fija en el TLV secundario 1 para el tipo 135 TLV (Type Length Value).
  • Usted debe entender la tarea para la cual usted está utilizando la etiqueta de la ruta, tal como redistribución de ruta, resumen de Route, o Route Leaking.

Antes de que usted marque cualquier ruta IS-IS con etiqueta, usted necesita decidir sobre el siguiente:

  1. Su meta a los valores establecidos para las rutas o redistribuye las rutas (o ambas).
  2. Donde en su red usted quiere marcar las rutas con etiqueta.
  3. Donde a su red usted quiere referirse a las etiquetas.
  4. Qué método que marca con etiqueta usted utilizará, que determina que encargan en esta sección para realizarse.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. máscara del IP address del IP Address

5. máscara del IP address del IP Address secundaria

6. etiqueta-valor de la etiqueta ISIS

7. extremo

8. muestre la base de datos ISIS prolija

9. muestre el [longer-prefixes] del [ip-address [mask] de la ruta de IP | [process-id] del protocolo | lista [access-list-number | acceso-lista-nombre]]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interface ethernet 0 de Router(config)#

 

Configura una interfaz.

 
Paso 4
máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 10.1.1.1 255.255.255.0

 

Define una dirección IP primaria para una interfaz.

  • En este ejemplo, la red 10.1.1.0 será marcada con etiqueta.
 
Paso 5
máscara del IP address del IP Address secundaria


Ejemplo:

Router (config-if) # dirección IP 10.2.2.1 255.255.255.0 secundario

 

(Opcional) fija una driección IP secundaria para una interfaz.

  • En este ejemplo, la red 10.2.2.0 será marcada con etiqueta.
 
Paso 6
etiqueta-valor de la etiqueta ISIS


Ejemplo:

Router (config-if) # etiqueta 120 ISIS

 

Fija una etiqueta en los IP Addresses configurados bajo esta interfaz cuando esos prefijos IP se ponen en un IS-IS LSP.

  • La etiqueta debe ser un número entero.
 
Paso 7
Finalizar


Ejemplo:

Router(config-if)#end

 

(Opcional) Sale del modo de configuración y vuelve al modo EXEC privilegiado.

 
Paso 8
muestre la base de datos ISIS prolija


Ejemplo:

Base de datos ISIS de la demostración del Router- prolija

 

(Opcional) Muestra detalles sobre la base de datos de estado de links de IS-IS, incluida la etiqueta de ruta.

  • Realice este paso si quiere verificar la etiqueta.
 
Paso 9
muestre el [longer-prefixes] del [ip-address [mask] de la ruta de IP | [process-id] del protocolo | lista [access-list-number | acceso-lista-nombre]]


Ejemplo:

Ruta de IP 10.1.1.1 255.255.255.0 de la demostración del Router-

 

(Opcional) Muestra el estado actual de la tabla de ruteo.

  • Realice este paso si quiere verificar la etiqueta.
 

Pasos Siguientes

La aplicación de la etiqueta no hace nada de valor para su red hasta que la utilice referenciándola en un route map, ya sea para definir valores, para redistribuir rutas, o para hacer ambas cosas. Proceda a la sección, “usando la etiqueta a los valores establecidos y o redistribuya las rutas.”

Marcar las rutas con etiqueta usando un Route Map

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Map Tag del route-map [permiso | niegue] el [sequence-number]

4. […tag-value] del etiqueta-valor de la etiqueta de la coincidencia

5.    Utilice un comando match adicional para cada criterio de la coincidencia que usted quiere.

6. etiqueta-valor de la etiqueta del conjunto

7. Fije otro valor, dependiendo de qué más usted quiere hacer con las rutas marcadas con etiqueta.

8. Relance el paso 7 para cada valor que usted quiera fijar.

9. Relance los pasos 3 a 8 para cada declaración del route-map que usted quiera.

10. extremo

11 muestre la base de datos ISIS prolija

12.    muestre el [longer-prefixes] del [ip-address [mask] de la ruta de IP | [process-id] del protocolo | [list access-list-number | [access-list-name]]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
Map Tag del route-map [permiso | niegue] el [sequence-number]


Ejemplo:

Permiso 15 del estático-color del route-map de Router(config)#

 

Define las condiciones para redistribuir las rutas de un protocolo de ruteo a otro o de un nivel IS-IS a otro.

  • Este comando hace al router ingresar al modo de configuración del route-map.
 
Paso 4
[…tag-value] del etiqueta-valor de la etiqueta de la coincidencia


Ejemplo:

Router (config-route-map) # etiqueta 15 de la coincidencia

 

(Opcional) hace juego las rutas marcadas con etiqueta con los números de Tag especificados.

  • Si usted está fijando una etiqueta por primera vez, usted no puede hacer juego en la etiqueta; este paso es una opción si usted es etiquetas de cambio.
 
Paso 5
Utilice un comando match adicional para cada criterio de la coincidencia que usted quiere.  

(Opcional) vea los comandos match apropiados en el Routing IP del Cisco IOS: Referencia de comandos del protocolo independiente

  • Relance este paso para cada criterio de la coincidencia usted que quiere.
 
Paso 6
fije el etiqueta-valor de la etiqueta


Ejemplo:

El router (config-route-map) # fijó la etiqueta 10

 

Especifica el número de Tag para fijar.

 
Paso 7
Fije otro valor, dependiendo de qué más usted quiere hacer con las rutas marcadas con etiqueta.  

(Opcional) vea los comandos set siguientes en el Routing IP del Cisco IOS: Referencia de comandos del protocolo independiente

  • set level
  • set metric
  • set metric-type
 
Paso 8
Relance el paso 7 para cada valor que usted quiera fijar.  

(Opcional)

 
Paso 9
Relance los pasos 3 a 8 para cada declaración del route-map que usted quiera.  

(Opcional)

 
Paso 10
Finalizar


Ejemplo:

Router (config-route-map) # extremo

 

(Opcional) Sale del modo de configuración y vuelve al modo EXEC privilegiado.

 
Paso 11
muestre la base de datos ISIS prolija


Ejemplo:

Base de datos ISIS de la demostración del Router- prolija

 

(Opcional) Muestra detalles sobre la base de datos de estado de links de IS-IS, incluida la etiqueta de ruta.

  • Realice este paso si quiere verificar la etiqueta.
 
Paso 12
muestre el [longer-prefixes] del [ip-address [mask] de la ruta de IP | [process-id] del protocolo | [list access-list-number | [access-list-name]]


Ejemplo:

Ruta de IP 10.1.1.1 255.255.255.0 de la demostración del Router-

 

(Opcional) Muestra el estado actual de la tabla de ruteo.

  • Realice este paso si quiere verificar la etiqueta.
 

Pasos Siguientes

La aplicación de la etiqueta no hace nada de valor para su red hasta que la utilice referenciándola en un route map, ya sea para definir valores, para redistribuir rutas, o para hacer ambas cosas. Proceda a usar la etiqueta a los valores establecidos y o redistribuya las rutas.

Marcar a una dirección de resumen con etiqueta

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. [area-tag] ISIS del router

4. métrico-estilo ancho

5. máscara de dirección {level-1 del resumen-direccionamiento | level-1-2 | [tag tag-value] level-2} [metric metric-value]

6. extremo

7. muestre la base de datos ISIS prolija

8. muestre el [longer-prefixes] del [ip-address [mask] de la ruta de IP | [process-id] del protocolo | [list access-list-number | [access-list-name]]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
[area-tag] ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

Habilita IS-IS como protocolo de ruteo IP y asigna una etiqueta a un proceso, si es necesario.

  • Ingresa en el modo de configuración del router.
 
Paso 4
métrico-estilo de par en par


Ejemplo:

Router (config-router) # métrico-estilo de par en par

 

Configura un router que ejecuta IS-IS para que genere y acepte el objeto TLV (Tipo, longitud y valor) 135 para las direcciones IP.

 
Paso 5
máscara de dirección {level-1 del resumen-direccionamiento | level-1-2 | [tag tag-value] level-2} [metric metric-value]


Ejemplo:

Router (config-router) # etiqueta 12345 321 métricos de 192.168.0.0 255.255.0.0 del resumen-direccionamiento

 

Crea direcciones añadidas para IS-IS.

Nota    Si se resume una ruta marcada con etiqueta y la etiqueta no se configura explícitamente en el comando summary-address, después se pierde la etiqueta.
 
Paso 6
Finalizar


Ejemplo:

Router (config-router) # extremo

 

(Opcional) Sale del modo de configuración y vuelve al modo EXEC privilegiado.

 
Paso 7
muestre la base de datos ISIS prolija


Ejemplo:

Base de datos ISIS de la demostración del Router- prolija

 

(Opcional) Muestra detalles sobre la base de datos de estado de links de IS-IS, incluida la etiqueta de ruta.

  • Realice este paso si quiere verificar la etiqueta.
 
Paso 8
muestre el [longer-prefixes] del [ip-address [mask] de la ruta de IP | [process-id] del protocolo | [list access-list-number | [access-list-name]]


Ejemplo:

Ruta de IP 10.1.1.1 255.255.255.0 de la demostración del Router-

 

(Opcional) Muestra el estado actual de la tabla de ruteo.

  • Realice este paso si quiere verificar la etiqueta.
 

Pasos Siguientes

La aplicación de la etiqueta no hace nada de valor para su red hasta que usted utilice la etiqueta refiriéndose a ella a un Route Map a los valores establecidos. Es inverosímil que usted redistribuirá las rutas de resumen. Vaya a la sección "Uso de la Etiqueta para Definir Valores y/o Redistribuir Rutas".

Usando la etiqueta a los valores establecidos y o redistribuya las rutas

Antes de comenzar

Usted debe haber aplicado ya una etiqueta en la interfaz, en un Route Map, o en una ruta de resumen. Vea las rutas IS-IS que marcan con etiqueta para controlar su redistribución.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Map Tag del route-map [permiso | niegue] el [sequence-number]

4. etiqueta-valor de la etiqueta de la coincidencia

5. Especifique un comando match para cada criterio de la coincidencia que usted quiere.

6. Fije un valor, dependiendo de lo que usted quiere hacer con las rutas marcadas con etiqueta.

7. Relance el paso 6 para cada valor que usted quiera fijar.

8. Relance los pasos 3 a 7 para cada declaración del route-map que usted quiera.

9. salga

10. ISIS del router

11 métrico-estilo ancho

12.    redistribuya el [process-id] [level-1| level-1-2 del protocolo | [route-map map-tag] level-2] [metric metric-value] [metric-type type-value]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
Map Tag del route-map [permiso | niegue] el [sequence-number]


Ejemplo:

Permiso 15 del estático-color del route-map de Router(config)#

 

Define las condiciones para redistribuir las rutas de un protocolo de ruteo a otro o de un nivel IS-IS a otro.

  • Este comando le hace ingresar al modo de configuración del route-map.
 
Paso 4
etiqueta-valor de la etiqueta de la coincidencia


Ejemplo:

Router (config-route-map) # etiqueta 120 de la coincidencia

 

(Opcional) aplica los comandos set subsiguientes a las rutas que las rutas de la coincidencia marcaron con etiqueta con este número de Tag.

 
Paso 5
Especifique un comando match para cada criterio de la coincidencia que usted quiere.  

(Opcional) refiérase a los comandos match apropiados al Routing IP del Cisco IOS: Referencia de comandos del protocolo independiente.

 
Paso 6
Fije un valor, dependiendo de lo que usted quiere hacer con las rutas marcadas con etiqueta.  

(Opcional) vea los comandos set siguientes en el Routing IP del Cisco IOS: Referencia de comandos del protocolo independiente.

  • set level
  • set metric
  • set metric-type
 
Paso 7
Relance el paso 6 para cada valor que usted quiera fijar.  

(Opcional)

 
Paso 8
Relance los pasos 3 a 7 para cada declaración del route-map que usted quiera.  

(Opcional)

 
Paso 9
salida


Ejemplo:

Router (config-route-map) # salida

 

Devoluciones (opcionales) al modo de configuración global.

 
Paso 10
ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

(Opcional) habilita el Routing Protocol IS-IS y especifica un proceso IS-IS.

 
Paso 11
métrico-estilo de par en par


Ejemplo:

Router (config-router) # métrico-estilo de par en par

 

Configura un router que ejecuta IS-IS para que genere y acepte el objeto TLV (Tipo, longitud y valor) 135 para las direcciones IP.

 
Paso 12
redistribuya el [process-id] [level-1| level-1-2 del protocolo | [route-map map-tag] level-2] [metric metric-value] [metric-type type-value]


Ejemplo:

El router (config-router) # redistribuye IP estático el estático-color métrico del route-map 2

 

(Opcional) redistribuye las rutas a partir de un dominio de ruteo en otro dominio de ruteo.

 

Limitación del Número de Rutas IS-IS Redistribuidas

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. [area-tag] ISIS del router

4. redistribuya el [as-number] del protocolo [process-id]{level-1| level-1-2| level-2} [metric metric-value] [metric-type type-value] [coincidencia {interna| [route-map map-tag] externo externo del etiqueta-valor 1| 2}][tag]

5. redistribuya el [percentage] máximo del máximo-prefijo [advertencia-solamente | retírese]

6. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
[area-tag] ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

Habilita IS-IS como protocolo de ruteo IP y asigna una etiqueta a un proceso, si es necesario.

  • Ingresa en el modo de configuración del router.
 
Paso 4
redistribuya el [as-number] del protocolo [process-id]{level-1| level-1-2| level-2} [metric metric-value] [metric-type type-value] [coincidencia {interna| [route-map map-tag] externo externo del etiqueta-valor 1| 2}][tag]


Ejemplo:

El router (config-router) # redistribuye el eigrp 10 level-1

 

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

 
Paso 5
redistribuya el [percentage] máximo del máximo-prefijo [advertencia-solamente | retírese]


Ejemplo:

El router (config-router) # redistribuye el máximo-prefijo 1000 80

 

Fija un número máximo de prefijos IP que se permitan ser redistribuidos en el IS-IS.

  • No hay un valor predeterminado para el argumento maximum.
  • El valor predeterminado de percentage es el 75 por ciento.
  • Si se especifica la palabra clave del retirar y el número máximo de prefijos se excede, el IS-IS reconstruye los fragmentos de la unidad de datos del Link-State Protocol (PDU) sin IP externa los prefijos. Es decir, los prefijos redistribuidos se quitan de los PDU.
Nota    Si palabra clave warning-only (Sólo advertencia) tenido configurado en este comando, ningún límite sería aplicado; un mensaje de advertencia se registra simplemente.
 
Paso 6
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router.

 

Solicitud de una Advertencia sobre el Número de Prefijos Redistribuidos en IS-IS

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. [area- tag] ISIS del router

4. redistribuya el [as-number] del protocolo [process-id]{level-1| level-1-2| level-2} [metric metric-value] [metric-type type-value] [coincidencia {interna| [route-map map-tag] externo externo del etiqueta-valor 1| 2}][tag]

5. redistribuya el [percentage] máximo del máximo-prefijo [advertencia-solamente | retírese]

6. el LSP-FULL suprime {[interlevel] del [external] | ningunos}

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
[area- tag] ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

Habilita IS-IS como protocolo de ruteo IP y asigna una etiqueta a un proceso, si es necesario.

  • Ingresa en el modo de configuración del router.
 
Paso 4
redistribuya el [as-number] del protocolo [process-id]{level-1| level-1-2| level-2} [metric metric-value] [metric-type type-value] [coincidencia {interna| [route-map map-tag] externo externo del etiqueta-valor 1| 2}][tag]


Ejemplo:

El router (config-router) # redistribuye el eigrp 10 level-1

 

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

 
Paso 5
redistribuya el [percentage] máximo del máximo-prefijo [advertencia-solamente | retírese]


Ejemplo:

El router (config-router) # redistribuye la advertencia-solamente 80 del máximo-prefijo 1000

 

Hace un mensaje de advertencia ser registrado cuando el número máximo de prefijos IP se ha redistribuido en el IS-IS.

  • Porque palabra clave warning-only (Sólo advertencia) es incluido, no se impone ningún límite ante el número de prefijos redistribuidos en el IS-IS.
  • No hay un valor predeterminado para el argumento maximum.
  • El valor predeterminado de percentage es el 75 por ciento.
  • En este ejemplo de configuración, se generan dos advertencias: uno en el 80 por ciento de 1000 (800 prefijos redistribuidos) y otro en 1000 prefijos redistribuidos.
 
Paso 6
el LSP-FULL suprime {[interlevel] del [external] | ningunos}


Ejemplo:

El router (config-router) # LSP-FULL suprime el interlevel externo

 

Controles (opcionales) que las rutas se suprimen cuando se convierte el link-state PDU por completo.

 
Paso 7
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router.

 

Excepto los prefijos conectados IP en una pequeña escala

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. netmask del IP address del IP Address

5. ningún broadcast dirigido del IP

6. [area- tag] ISIS del router del IP

7. ningún hacer publicidad-prefijo ISIS

8. salida

9. Relance los pasos 3 a 8 para cada interfaz en la cual usted no quiera hacer publicidad de los prefijos IP.

10. [area- tag] ISIS del router

11 título de entidad de la red neto

12.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interface ethernet 0 de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

 
Paso 4
netmask del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 192.168.20.1 255.255.255.0

 

Define una dirección IP primaria para una interfaz.

  • La máscara de red se puede indicar como una dirección de punto decimal de 4 partes o como un prefijo. Este ejemplo utiliza un número decimal con puntos de cuatro partes.
 
Paso 5
no ip directed-broadcast


Ejemplo:

Router (config-if) # ningún broadcast dirigido del IP

 

(Opcional) Inhabilita la traducción de un broadcast dirigido a broadcasts físicos.

 
Paso 6
[area- tag] ISIS del router del IP


Ejemplo:

Router (config-if) # ISIS del router del IP

 

Configura un proceso de ruteo IS-IS para IP en una interfaz y asocia un designador de área al proceso de ruteo.

 
Paso 7
ningún hacer publicidad-prefijo ISIS


Ejemplo:

Router (config-if) # ningún hacer publicidad-prefijo ISIS

 

Previene la publicidad de los prefijos IP de las redes conectadas en los anuncios LSP por la interfaz IS-IS.

 
Paso 8
salida


Ejemplo:

Router(config-if)# exit

 

Vuelve al modo de configuración global.

 
Paso 9
Relance los pasos 3 a 8 para cada interfaz en la cual usted no quiera hacer publicidad de los prefijos IP. 

(Opcional)

 
Paso 10
[area- tag] ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

Habilita IS-IS como protocolo de ruteo IP y asigna una etiqueta a un proceso, si es necesario.

  • Ingresa en el modo de configuración del router.
 
Paso 11
título de entidad de la red neto


Ejemplo:

Router (config-router) # red 47.0004.004d.0001.0001.0c11.1111.00

 

Configura un título de entidad de la red IS-IS (RED) para el proceso de ruteo.

 
Paso 12
Finalizar


Ejemplo:

Router (config-router) # extremo

 

(Opcional) Guarda los comandos de configuración en el archivo de configuración en ejecución, sale del modo de configuración y vuelve al modo EXEC privilegiado.

 

Excepto los prefijos conectados IP a gran escala

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del Interface Loopback

4. netmask del IP address del IP Address

5. ningún broadcast dirigido del IP

6. salida

7. número del tipo de la interfaz

8. netmask del IP address del IP Address

9. ningún broadcast dirigido del IP

10. [area- tag] ISIS del router del IP

11 salida

12.    [area- tag] ISIS del router

13.    de la pasivo-interfaz número de tipo [default]

14.    título de entidad de la red neto

15.    hacer publicidad-pasivo-solamente

16.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del Interface Loopback


Ejemplo:

Interface Loopback 0 de Router(config)#

 

Configura una interfaz Loopback e ingresa en el modo de configuración de la interfaz.

 
Paso 4
netmask del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 192.168.10.1 255.255.255.255

 

Define una dirección IP primaria para una interfaz.

  • La máscara de red se puede indicar como una dirección de punto decimal de 4 partes o como un prefijo. Este ejemplo utiliza un número decimal con puntos de cuatro partes.
 
Paso 5
no ip directed-broadcast


Ejemplo:

Router (config-if) # ningún broadcast dirigido del IP

 

(Opcional) Inhabilita la traducción de un broadcast dirigido a broadcasts físicos.

 
Paso 6
salida


Ejemplo:

Router(config-if)# exit

 

Vuelve al modo de configuración global.

 
Paso 7
número del tipo de la interfaz


Ejemplo:

Interface ethernet 0 de Router(config)#

 

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

 
Paso 8
netmask del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 192.168.20.1 255.255.255.0

 

Define una dirección IP primaria para una interfaz.

  • La máscara de red se puede indicar como una dirección de punto decimal de 4 partes o como un prefijo. Este ejemplo utiliza un número decimal con puntos de cuatro partes.
 
Paso 9
no ip directed-broadcast


Ejemplo:

Router (config-if) # ningún broadcast dirigido del IP

 

(Opcional) Inhabilita la traducción de un broadcast dirigido a broadcasts físicos.

 
Paso 10
[area- tag] ISIS del router del IP


Ejemplo:

Router (config-if) # ISIS del router del IP

 

Configura un proceso de ruteo IS-IS para IP en una interfaz y asocia un designador de área al proceso de ruteo.

 
Paso 11
salida


Ejemplo:

Router(config-if)# exit

 

Vuelve al modo de configuración global.

 
Paso 12
[area- tag] ISIS del router


Ejemplo:

ISIS del router de Router(config)#

 

Habilita IS-IS como protocolo de ruteo IP y asigna una etiqueta a un proceso, si es necesario.

  • Ingresa en el modo de configuración del router.
 
Paso 13
de la pasivo-interfaz número de tipo [default]


Ejemplo:

Router (config-router) # loopback0 de la pasivo-interfaz

 

Neutralizaciones que envían las actualizaciones de ruteo en una interfaz.

 
Paso 14
título de entidad de la red neto


Ejemplo:

Router (config-router) # red 47.0004.004d.0001.0001.0c11.1111.00

 

Configura una RED IS-IS para el proceso de ruteo.

 
Paso 15
hacer publicidad-pasivo-solamente


Ejemplo:

Router (config-router) # hacer publicidad-pasivo-solamente

 

Configura el IS-IS para hacer publicidad solamente de los prefijos que pertenecen a las interfaces pasivas.

 
Paso 16
Finalizar


Ejemplo:

Router (config-router) # extremo

 

(Opcional) Guarda los comandos de configuración en el archivo de configuración en ejecución, sale del modo de configuración y vuelve al modo EXEC privilegiado.

 

Monitoreo del Tiempo de Convergencia de Red IS-IS

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. delimitador de la visualización ISIS [vuelva la cuenta | cuenta de carácter]

4. salida

5. muestre el [lspid] de la base de datos [level-1] [level-2] [l1] [l2] ISIS [detail]

6. muestre las rutas del [area-tag] ISIS

7. muestre el [area-tag] [ipv6 ISIS | *] SPF-registro

8. muestre la topología del [process-tag] ISIS


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
delimitador de la visualización ISIS [vuelva la cuenta | cuenta de carácter]


Ejemplo:

Vuelta 2 del delimitador de la visualización ISIS de Router(config)#

 

Facilita la lectura de la salida de las visualizaciones multiárea especificando el delimitador que se debe utilizar para separar las visualizaciones de información.

 
Paso 4
salida


Ejemplo:

Salida de Router(config)#

 

Vuelve al modo EXEC privilegiado.

 
Paso 5
muestre el [lspid] de la base de datos [level-1] [level-2] [l1] [l2] ISIS [detail]


Ejemplo:

Detalle de base de datos ISIS de la demostración del Router-

 

Muestra la base de datos de estado de link IS-IS.

 
Paso 6
muestre las rutas del [area-tag] ISIS


Ejemplo:

Rutas del financetag ISIS de la demostración del Router-

 

Muestra la tabla de reenvío de nivel 1 de IS-IS para las rutas aprendidas de IS-IS.

 
Paso 7
muestre el [area-tag] [ipv6 ISIS | *] SPF-registro


Ejemplo:

SPF-registro ISIS de la demostración del Router-

 

Muestra con cuánta frecuencia y por qué el router ha ejecutado un cálculo de SPF completo.

 
Paso 8
muestre la topología del [process-tag] ISIS


Ejemplo:

Topología del financetag ISIS de la demostración del Router-

 

Visualiza una lista de todos los routers conectados en todas las áreas.

  • Si se especifica una etiqueta de proceso, la salida se limita al proceso de ruteo especificado. Cuando se especifica "null" para la etiqueta de proceso, la salida se visualiza solamente para el proceso del router que no tenga ninguna etiqueta especificada. Si no se especifica una etiqueta de proceso, se muestra la salida para todos los procesos.
 

Ejemplos

La salida de muestra siguiente del comando show isis spf-log visualiza la información importante siguiente:

  • A que hora se han ejecutado los SPF
  • Tiempo transcurrido total para el cómputo SPT, la actualización LRIB, y la actualización del RIB y de la BOLA
  • Número de Nodos en el gráfico
  • Número de activadores que causaron el cálculo SPF
  • Información con respecto qué accionó el cálculo SPF

Router# show isis spf-log

 
		
   Level 1 SPF log

 
		
  When   Duration  Nodes  Count     Last trigger LSP   Triggers
00:15:46    3124     40      1          milles.00-00  TLVCODE
00:15:24    3216     41      5          milles.00-00  TLVCODE NEWLSP
00:15:19    3096     41      1          deurze.00-00  TLVCODE
00:14:54    3004     41      2          milles.00-00  ATTACHFLAG LSPHEADER
00:14:49    3384     41      1          milles.00-01  TLVCODE
00:14:23    2932     41      3          milles.00-00  TLVCODE
00:05:18    3140     41      1                        PERIODIC
00:03:54    3144     41      1          milles.01-00  TLVCODE
00:03:49    2908     41      1          milles.01-00  TLVCODE
00:03:28    3148     41      3           bakel.00-00  TLVCODE TLVCONTENT
00:03:15    3054     41      1          milles.00-00  TLVCODE
00:02:53    2958     41      1          mortel.00-00  TLVCODE

Ejemplos de Configuración para Reducir los Tiempos de Cálculo de Trayectorias Alternativas en Redes IS-IS

Ejemplo que asigna un valor prioritario de la etiqueta a un prefijo IP IS-IS

El siguiente ejemplo utiliza el comando priority high de la ruta de IP de asignar un valor de la etiqueta de 200 al prefijo IP IS-IS:

interface Ethernet 0
 ip router isis
 isis tag 200
!
router isis
 ip route priority high tag 200

Ejemplo que marca las rutas con etiqueta para las redes conectadas directamente con una interfaz y que las redistribuye

En este ejemplo, dos interfaces se marcan con etiqueta con diversos valores de la etiqueta. Por abandono, estos dos IP Addresses habrían sido puestos en la base de datos del nivel 1 y del nivel 2 IS-IS. Sin embargo, usando el comando redistribute con un Route Map de hacer juego la etiqueta 110, solamente ponen a la dirección IP 172.16.10.5 255.255.255.0 en la base de datos del nivel 2.

interface ethernet 1/0
 ip address 192.168.129.1 255.255.255.0
 ip router isis
 isis tag 120
interface ethernet 1/1
 ip address 172.16.10.5 255.255.255.0
 ip router isis
 isis tag 110
router isis
 net 49.0001.0001.0001.0001.00
 redistribute isis ip level-1 into level-2 route-map match-tag
route-map match-tag permit 10
 match tag 110

Ejemplo que redistribuye las rutas IS-IS usando un Route Map

En un escenario usando las etiquetas de la ruta, usted puede ser que configure algunos comandos en un router y otros comandos en otro router. Por ejemplo, usted puede ser que tenga un Route Map que las coincidencias en una etiqueta y fijan una diversa etiqueta en un router en el borde de una red, y en diverso Routers usted puede ser que configure la redistribución de las rutas basadas en una etiqueta en un diverso Route Map.

Figura 1Ejemplo de redistribuir las rutas IS-IS usando un Route Map


La figura antedicha ilustra un nivel plano 2 área IS-IS. En el borde izquierdo son las Static rutas del router A para alcanzar algunos prefijos IP. El router A redistribuye las Static rutas en el IS-IS. El router B ejecuta el BGP y redistribuye las rutas IS-IS en el BGP y después utiliza la etiqueta para aplicar diversa directiva administrativa basada en diversos valores de la etiqueta.

Router A

router isis
 net 49.0000.0000.0001.00
 metric-style wide
 redistribute static ip route-map set-tag
!
route-map set-tag permit 5
 set tag 10

Router B

router bgp 100
 redistribute isis level-2 route-map tag-policy
route-map tag-policy permit 20
 match tag 10
 set metric 1000

Ejemplo que marca a una dirección de resumen con etiqueta y que aplica un Route Map

La figura abajo ilustra la 1 área de dos niveles y un nivel 2 áreas entre ellos. El router A y el router B son routeres de borde del nivel 1/Level 2 en el nivel 2 áreas. En el router de borde A, configuran a una dirección de resumen para reducir el número de IP Addresses puesto en las bases de datos IS-IS del nivel 2. También, un valor de la etiqueta de 100 se fija a la dirección de resumen.

En el router B, la dirección de resumen se escapa en el nivel 1 área, y la directiva administrativa es aplicada basada en el valor de la etiqueta.

Figura 2Etiqueta en una dirección de resumen


Router A

router isis
 net 49.0001.0001.0001.00
 metric-style wide
 summary-address 10.0.0.0 255.0.0.0 tag 100

Router B

router isis
 net 49.0002.0002.0002.0002.0
 metric-style wide
 redistribute isis ip level-2 into level-1 route-map match-tag
route-map match-tag permit 10
 match tag 100

Ejemplo que filtra y que redistribuye las rutas IS-IS usando una lista de acceso y un Route Map

En este ejemplo, el primeros redistribuyen el comando ip ISIS controlan la redistribución de las rutas del nivel 1 en el nivel 2. Solamente las rutas con la etiqueta de 90 y cuyo no sea prefijo IP 192.168.130.5/24 sean redistribuidas del nivel 1 en el nivel 2.

El segundo redistribuye el comando ip ISIS controla Route Leaking del nivel 2 en el dominio del nivel 1. Solamente las rutas marcadas con etiqueta con 60 o 50 serán redistribuidas del nivel 2 en el nivel 1.

interface ethernet 1
 ip address 192.168.130.5 255.255.255.0
 ip router isis
 isis tag 60
!
interface ethernet 2
 ip address 192.168.130.15 255.255.255.0
 ip router isis
 isis tag 90
!
interface ethernet 3
 ip address 192.168.130.25 5 255.255.255.0
 ip router isis
 isis tag 50
!
router isis
 net 49.0001.0001.0001.0001.00
 metric-style wide
 redistribute isis ip level-1 into level-2 route-map redist1-2
 redistribute isis ip level-2 into level-1 route-map leak2-1
!
access-list 102 deny ip host 192.168.130.5 host 255.255.255.255
access-list 102 permit ip any any
!
route-map leak2-1 permit 10
 match tag 60
!
route-map leak2-1 permit 20
 match tag 50
!
route-map redist1-2 permit 10
 match ip address 102
 match tag 90

Límite del ejemplo IS-IS en el número de rutas redistribuido

Este ejemplo muestra cómo fijar un máximo de 1200 prefijos que se puedan redistribuir en el IS-IS. Cuando el número de prefijos redistribuidos alcanza el 80 por ciento de 1200 (960 prefijos), se registra un mensaje de advertencia. Cuando se redistribuyen 1200 prefijos, el IS-IS reconstruye los fragmentos LSP sin los prefijos externos y ninguna redistribución ocurre.

router isis 1
 redistribute maximum-prefix 1200 80 withdraw

Ejemplo que pide una advertencia sobre el número de rutas redistribuido

Este ejemplo muestra cómo permitir que dos mensajes de advertencia sean registrados. Se genera el primer mensaje si el número de prefijos redistribuidos alcanza el 85 por ciento de 600 (510 prefijos), y se genera el segundo mensaje si el número de los alcances redistribuidos 600 de los prefijos. Sin embargo, el número de prefijos redistribuidos no es limitado. Si ocurre el estado LSPFULL, los prefijos externos serán suprimidos.

router isis 1
 redistribute maximum-prefix 600 85 warning-only
 lsp-full suppress external

Ejemplo excepto los prefijos conectados IP en una pequeña escala

El siguiente ejemplo no utiliza el ningún comando del hacer publicidad-prefijo ISIS en la interfaz de Ethernet 0. Solamente la dirección IP del Loopback Interface 0 se hace publicidad.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet 0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 no isis advertise-prefix
.
.
.
router isis 
 passive-interface loopback 0
 net 47.0004.004d.0001.0001.0c11.1111.00
 log-adjacency-changes
!

Ejemplo excepto los prefijos conectados IP a gran escala

El siguiente ejemplo utiliza el comando hacer publicidad-pasivo-solamente, que se aplica al caso entero IS-IS, de tal modo evitando que el IS-IS haga publicidad de la red del IP de la interfaz de Ethernet 0. Solamente la dirección IP del Loopback Interface 0 se hace publicidad.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
.
.
.
router isis 
 passive-interface Loopback0
 net 47.0004.004d.0001.0001.0c11.1111.00
 advertise-passive-only
 log-adjacency-changes
!

Adonde ir después

Para configurar las funciones que mejoran el tiempo de convergencia de la red IS-IS, realice las tareas opcionales de uno o varios de los módulos siguientes:

  • “Descripción de la convergencia rápida IS-IS”
  • "Reducción de los Tiempos de Detección de Fallas en Redes IS-IS"
  • "Reducción de los Tiempos de Notificación de Fallas de Links y Cambios de Topología en las Redes IS-IS"

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Descripción del Type Length Value IS-IS (TLV) y de su uso.

Sistemas a sistema intermedio intermedios (IS-IS) TLV

Comandos de IS-IS: sintaxis, modo de comando, valores por defecto, comando history, Pautas para el uso, y ejemplos del comando complete

Routing IP del Cisco IOS: Referencia de comandos ISIS

IS-IS Route Leaking

IS-IS Route Leaking

Descripción general de la información conceptual sobre Cisco IS-IS con links a todos los módulos IS-IS individuales

Módulo "Descripción General de Integrated IS-IS Routing Protocol"

RFC

RFC

Título

Se soportan los RFC no nuevos o modificados, y el soporte para los RFC existentes no se ha modificado.

--

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre Funciones para Reducir los Tiempos de Cálculo de Trayectorias Alternativas en las Redes IS-IS

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información sobre Funciones para Reducir los Tiempos de Cálculo de Trayectorias Alternativas en las Redes IS-IS

Nombre de la función

Versiones

Información sobre la Función

IS-IS Caching of Redistributed Routes

Cisco IOS XE 3.1.0 SG 12.0(27)S 12.2(25)S 12.3(7)T

El almacenamiento en memoria inmediata IS-IS de la característica de las rutas redistribuido mejora el tiempo de convergencia del Intermediate System-to-Intermediate System (IS-IS) en que las rutas se están redistribuyendo en el IS-IS. Este documento inserta nuevos comandos para monitorear y mantener las rutas redistribuidas IS-IS.

IS-IS Incremental SPF

Cisco IOS XE 3.1.0 SG 12.0(24)S 12.2(18)S 12.3(2)T

El IS-IS integrado se puede configurar para que use un algoritmo SPF incremental para calcular las rutas con la trayectoria más corta primero. El SPF incremental es más eficiente que el algoritmo SPF completo, por lo que permite que IS-IS converja más rápido en una nueva topología de ruteo como reacción a un evento de red.

IS-IS Limit on Number of Redistributed Routes

Cisco IOS XE 3.1.0 SG 12.0(25)S 12.2(18)S 12.3(4)T

La función IS-IS Limit on Number of Redistributed Routes fija un número máximo de prefijos definido por el usuario que se pueden redistribuir en IS-IS de otros protocolos u otros procesos IS-IS. Tal límite puede ayudar a evitar que al router inunde demasiadas rutas redistribuido.

Mecanismos IS-IS para Excluir Prefijos IP Conectados de Anuncios LSP

Cisco IOS XE 3.1.0 SG 12.0(22)S 12.2(18)S 12.3(2)T

Este documento describe dos mecanismos integrados del Intermediate System-to-Intermediate System (IS-IS) para excluir los prefijos IP de las redes conectadas de los anuncios del link-state PDU (LSP), de tal modo reduciendo el tiempo de convergencia IS-IS.

IS-IS Support for Priority-Driven IP Prefix RIB Installation

Cisco IOS XE 3.1.0 SG 12.0(26)S 12.2(18)SXE 12.2(25)S 12.3(4)T

El soporte IS-IS para la característica a base de prioridad de la instalación del RIB del prefijo permite que los clientes señalen un subconjunto de prefijos IP des divulgación por el IS-IS para más rápidamente procesar y la instalación en la tabla de Global Routing como una manera de alcanzar una convergencia más rápida. Por ejemplo, es posible que sea necesario procesar primero las direcciones de gateway de voz sobre IP (VoIP) para ayudar a que el tráfico de VoIP se actualice más rápido que otros tipos de paquetes.

Soporte IS-IS para Etiquetas de Rutas

Cisco IOS XE 3.1.0 SG 12.2(18)S 12.2(27)SBC 12.3(2)T

La función IS-IS Support for Route Tags proporciona la capacidad para etiquetar prefijos de ruta IS-IS y utilizar estas etiquetas en un route map para controlar la redistribución de ruta o el agotamiento de ruta IS-IS.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.