Routing IP: Guía de configuración EIGRP, Cisco IOS Release 12.2SR
EIGRP Support for Route Map Filtering
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 166 KB | Inglés (28 Abril 2011) | Comentarios

Contenido

EIGRP Support for Route Map Filtering

Última actualización: De abril el 21 de 2011

El soporte del EIGRP para la función de filtrado del Route Map permite al Enhanced Interior Gateway Routing Protocol (EIGRP) para interoperar con otros protocolos para leverage la funcionalidad de ruteo adicional filtrando el tráfico entrante y saliente basado en las opciones complejas del Route Map. Se introduce varia opción de filtro extendida de proporcionar las opciones Eigrp-específicas de la coincidencia.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Información Sobre el Soporte de EIGRP para Filtrado de Route Map

Soporte de EIGRP para Route Map

El soporte del EIGRP para la filtración del Route Map permite al EIGRP para interoperar con otros protocolos filtrando el tráfico entrante y saliente basado en las opciones del Route Map. Las opciones Eigrp-específicas adicionales de la coincidencia están disponibles permitir la flexibilidad en las operaciones de la red EIGRP del ajuste fino.

El EIGRP soporta el Route Map que filtra la capacidad que existe para otros Routing Protocol a las rutas de filtro que son redistribuidas en su protocolo. Para más detalles sobre la comprensión y configurar de los mapa del ruta, vea la sección del Policy Routing que habilita del módulo IP Routing Protocol-Independent de las características que configura del Routing IP del Cisco IOS: Guía de configuración del protocolo independiente.

Las opciones de la coincidencia permiten que el EIGRP filtre el Routes interno y externo basado en los protocolos de la fuente, para hacer juego un métrico contra un rango, y para hacer juego en un protocolo externo métrico.

El EIGRP se puede configurar al filtrar tráfico usando un Route Map y la redistribución o el comando distribute-list. Usando un Route Map con el comando redistribute permite las rutas que se redistribuyen de la tabla de ruteo que se filtrará con un Route Map antes de ser admitida en una tabla de topología EIGRP. Las rutas de las cuales se reciben dinámicamente, o hicieron publicidad a, los pares del EIGRP pueden ser filtradas agregando una opción del Route Map al comando distribute-list.

Un Route Map se puede configurar con la redistribución y los comandos distribute-list en el mismo proceso de ruteo. Cuando un Route Map se utiliza con un comando distribute-list que se configure para entrante o el filtrado de salida, los paquetes de Routes de los cuales sea docto o hecho publicidad al EIGRP los pares se pueden procesar con el Route Map para proporcionar un mejor control de la selección de Route durante el proceso del intercambio de ruta. La redistribución sirve como mecanismo importar las rutas en la tabla de topología EIGRP de una tabla de ruteo. Un Route Map configurado con el comando redistribute agrega la flexibilidad a la capacidad de la redistribución y los resultados en una selección más específica de la ruta redistribuido.

El uso de los mapa del ruta al filtrar tráfico es lo mismo para ambas configuraciones del Autonomous System y las configuraciones Nombradas. Vea el módulo del EIGRP que configura para más información sobre el sistema autónomo y las configuraciones Nombradas.

Las demandas para que el EIGRP interopere con los otros protocolos y flexibilidad en la operación de la red del ajuste fino necesitan la capacidad al filtrar tráfico usando un Route Map.

Cómo Configurar el Soporte de EIGRP para el Filtrado del Route Map

Determinación de las etiquetas del EIGRP usando un Route Map para las configuraciones del sistema autónomo

Realice esta tarea de fijar las etiquetas del EIGRP para las configuraciones del sistema autónomo usando un Route Map. La Métrica EIGRP usada para filtrar se configura dentro de un Route Map. La primera cláusula de la coincidencia define las rutas EIGRP que contienen un protocolo externo métrico entre 400 y 600 inclusivos; la segunda cláusula de la coincidencia define las rutas EIGRP externas que hacen juego un protocolo de la fuente de BGP y del sistema autónomo 45000. Cuando las dos cláusulas de la coincidencia son verdades, un valor de la etiqueta del Routing Protocol del destino se fija a 5. Este Route Map se puede utilizar con el comando distribute-list; vea el ejemplo el fijar de las etiquetas del EIGRP usando una configuración del sistema autónomo del Route Map para un ejemplo de configuración.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Map Tag del route-map [permiso | niegue] el [sequence-number]

4. coincidencia métrica {valor métrico| [+- deviation-number] externo del valor métrico}

5. [autonomous-system-number] del fuente-protocolo del fuente-protocolo de la coincidencia

6. etiqueta-valor de la etiqueta del conjunto

7. salida

8. como-número del eigrp del router

9. IP Address de red

10. Map Tag del route-map de la distribuir-lista adentro


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1 permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2 configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3 Map Tag del route-map [permiso | niegue] el [sequence-number]


Ejemplo:

Métrico-rango del route-map de Router(config)#

 

Ingresa al modo de configuración del route-map.

 
Paso 4 coincidencia métrica {valor métrico| [+- deviation-number] externo del valor métrico}


Ejemplo:

Router (config-route-map) # externo métrico 500 de la coincidencia + - 100

 

Especifica una cláusula de la coincidencia que filtre las actualizaciones entrantes que hacen juego un interno o un protocolo externo métrico.

  • valor métrico --Protocolo interno métrico, que puede ser una cinco-parte del EIGRP métrica. El rango es a partir la 1 a 4294967295.
  • externo --Protocolo externo métrico. El rango es a partir la 1 a 4294967295.
  • + - número de desviación --(Opcional) representa una desviación estándar. La desviación puede ser cualquier número. No existe configuración predeterminada.
Nota    Cuando usted especifica una desviación métrica con + y - las palabras claves, el router harán juego cualquier métrico que las caídas inclusivo en ese rango.
Nota    El protocolo externo métrico no es lo mismo que el EIGRP asignado la ruta métrica, que es una figura computada de los componentes métricos vectorizados del EIGRP (retardo, ancho de banda, confiabilidad, carga, y MTU).
 
Paso 5 [autonomous-system-number] del fuente-protocolo del fuente-protocolo de la coincidencia


Ejemplo:

Router (config-route-map) # BGP 45000 del fuente-protocolo de la coincidencia

 

Especifica una cláusula de la coincidencia que haga juego las rutas externo de las fuentes que hacen juego el protocolo de la fuente.

  • fuente-protocolo --Protocolo a hacer juego. Las palabras claves válidas son BGP, conectado, eigrp, ISIS, OSPF, RIP, y parásitos atmosféricos. No existe configuración predeterminada.
  • autonomous-system-number --Número del sistema autónomo (opcional). El argumento del autonomous-system-number es no corresponde a la haber conectado, a los parásitos atmosféricos, y a las palabras claves del RIP. El rango es a partir la 1 a 65535. No existe configuración predeterminada.
 
Paso 6 fije el etiqueta-valor de la etiqueta


Ejemplo:

El router (config-route-map) # fijó la etiqueta 5

 

Fija un valor de la etiqueta en la ruta en el Routing Protocol del destino cuando todos los criterios de concordancia de un Route Map se cumplen.

 
Paso 7 salida


Ejemplo:

Router (config-route-map) # salida

 

Sale del modo de configuración de route map y vuelve al modo de configuración global.

 
Paso 8 como-número del eigrp del router


Ejemplo:

Eigrp 1 del router de Router(config)#

 

Configura el proceso de EIGRP Routing y ingresa al modo de configuración del router.

 
Paso 9 IP Address de red


Ejemplo:

Router (config-router) # red 172.16.0.0

 

Especifica una red para el proceso de EIGRP Routing.

 
Paso 10 Map Tag del route-map de la distribuir-lista adentro


Ejemplo:

Router (config-router) # métrico-rango del route-map de la distribuir-lista adentro

 

Filtra las redes recibidas en las actualizaciones.

 

Determinación de las etiquetas del EIGRP usando un Route Map para Configurations Nombrada

Realice esta tarea de fijar las etiquetas del EIGRP para las configuraciones Nombradas usando un Route Map. La Métrica EIGRP usada para filtrar se configura dentro de un Route Map. La primera cláusula de la coincidencia define las rutas EIGRP que contienen un protocolo externo métrico entre 400 y 600 inclusivos; la segunda cláusula de la coincidencia define las rutas EIGRP externas que hacen juego un protocolo de la fuente de BGP y del sistema autónomo 45000. Cuando las dos cláusulas de la coincidencia son verdades, un valor de la etiqueta del Routing Protocol del destino se fija a 5. Este Route Map se puede utilizar con el comando distribute-list, ve el ejemplo el fijar de las etiquetas del EIGRP usando un Route Map nombrado Configuration para un ejemplo de configuración.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Map Tag del route-map [permiso | niegue] el [sequence-number]

4. confiabilidad métrica determinada del retardo del ancho de banda que carga el MTU

5. ruta-fuente del IP de la coincidencia {access-list-number| acceso-lista-nombre} [… access-list-number | … acceso-lista-nombre]

6. coincidencia métrica {valor métrico| [+- deviation-number] externo del valor métrico}

7. [autonomous-system-number] del fuente-protocolo del fuente-protocolo de la coincidencia

8. etiqueta-valor de la etiqueta del conjunto

9. salida

10. virtual-caso-nombre del eigrp del router

11.   Siga uno de los siguientes pasos:

  • autonomous-system-number del Autonomous System del [vrf vrf-name] del [unicast] del [multicast] de la direccionamiento-familia ipv4
  • autonomous-system-number del Autonomous System del [vrf vrf-name] del [unicast] del IPv6 de la direccionamiento-familia

12.    [wildcard-mask] del IP Address de red

13.    AF-interfaz {valor por defecto | interface-type interface-number}

14.    eigrp del siguiente-salto-uno mismo

15.    salida-AF-interfaz

16.    topología {base | número del tid del topología-nombre}

17.    Map Tag del route-map de la distribuir-lista adentro


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1 permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2 configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3 Map Tag del route-map [permiso | niegue] el [sequence-number]


Ejemplo:

Métrico-rango del route-map de Router(config)#

 

Ingresa al modo de configuración del route-map.

 
Paso 4 fije la confiabilidad métrica del retardo del ancho de banda que carga el MTU


Ejemplo:

El router (config-route-map) # fijó 10000 10 255 1 1500 métricos

 

(Opcional) fija el valor métrico para el EIGRP en un Route Map.

 
Paso 5 ruta-fuente del IP de la coincidencia {access-list-number| acceso-lista-nombre} [… access-list-number | … acceso-lista-nombre]


Ejemplo:

Router (config-route-map) # ruta-fuente 5 80 del IP de la coincidencia

 

Redistribuye las rutas que han sido hechas publicidad por el Routers y el Access Server en el direccionamiento especificado por las Listas de acceso.

 
Paso 6 coincidencia métrica {valor métrico| [+- deviation-number] externo del valor métrico}


Ejemplo:

Router (config-route-map) # externo métrico 500 de la coincidencia + - 100

 

Especifica una cláusula de la coincidencia que incluya las rutas EIGRP que hacen juego un interno o un protocolo externo métrico.

  • valor métrico --Protocolo interno métrico, que puede ser una cinco-parte del EIGRP métrica. El rango es a partir la 1 a 4294967295.
  • externo --Protocolo externo métrico. El rango es a partir la 1 a 4294967295.
  • + - número de desviación --(Opcional) representa una desviación estándar. La desviación puede ser cualquier número. No existe configuración predeterminada.
Nota    Cuando usted especifica una desviación métrica con + y - las palabras claves, el router harán juego cualquier métrico que las caídas inclusivo en ese rango.
Nota    El protocolo externo métrico no es lo mismo que el EIGRP asignado la ruta métrica, que es una figura computada de los componentes métricos vectorizados del EIGRP (retardo, ancho de banda, confiabilidad, carga, y MTU).
 
Paso 7 [autonomous-system-number] del fuente-protocolo del fuente-protocolo de la coincidencia


Ejemplo:

Router (config-route-map) # BGP 45000 del fuente-protocolo de la coincidencia

 

Especifica una cláusula de la coincidencia que incluya las rutas EIGRP externas que hacen juego un protocolo de la fuente.

  • fuente-protocolo --Protocolo a hacer juego. Las palabras claves válidas son BGP, conectado, eigrp, ISIS, OSPF, RIP, y parásitos atmosféricos. No existe configuración predeterminada.
  • autonomous-system-number --Número del sistema autónomo (opcional). El argumento del autonomous-system-number es no corresponde a la haber conectado, a los parásitos atmosféricos, y a las palabras claves del RIP. El rango es a partir la 1 a 65535. No existe configuración predeterminada.
 
Paso 8 fije el etiqueta-valor de la etiqueta


Ejemplo:

El router (config-route-map) # fijó la etiqueta 5

 

Fija un valor de la etiqueta en la ruta en el Routing Protocol del destino cuando todos los criterios de concordancia de un Route Map se cumplen.

 
Paso 9 salida


Ejemplo:

Router (config-route-map) # salida

 

Sale del modo de configuración de route map y vuelve al modo de configuración global.

 
Paso 10 virtual-caso-nombre del eigrp del router


Ejemplo:

Eigrp virtual-name1 del router de Router(config)#

 

Configura el proceso de EIGRP Routing y ingresa al modo de configuración del router.

 
Paso 11Siga uno de los siguientes pasos:
  • autonomous-system-number del Autonomous System del [vrf vrf-name] del [unicast] del [multicast] de la direccionamiento-familia ipv4
  • autonomous-system-number del Autonomous System del [vrf vrf-name] del [unicast] del IPv6 de la direccionamiento-familia


Ejemplo:

Router (config-router) # Autonomous System 45000 de la direccionamiento-familia ipv4

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar un IPv4 o el IPv6 del EIGRP que rutea el caso.

 
Paso 12 [wildcard-mask] del IP Address de red


Ejemplo:

Router (config-router-AF) # red 172.16.0.0

 

Especifica una red para el proceso de EIGRP Routing.

 
Paso 13 AF-interfaz {valor por defecto | interface-type interface-number}


Ejemplo:

Router (config-router-AF) # valor por defecto de la AF-interfaz

 

Ingresa al modo de configuración de la interfaz de la familia del direccionamiento para configurar los comandos eigrp interfaz-específicos.

 
Paso 14 eigrp del siguiente-salto-uno mismo


Ejemplo:

Router (config-router-AF-interfaz) # eigrp del siguiente-salto-uno mismo

 

EIGRP de los permisos para hacer publicidad de las rutas con el direccionamiento local de la interfaz de salida como el salto siguiente.

 
Paso 15 salida-AF-interfaz


Ejemplo:

Router (config-router-AF-interfaz) # salida-AF-interfaz

 

Da salida al modo de configuración de la interfaz de la direccionamiento-familia.

 
Paso 16 topología {base | número del tid del topología-nombre}


Ejemplo:

Router (config-router-AF) # base de la topología

 

Configura un proceso EIGRP para rutear el tráfico IP bajo caso especificado de la topología y ingresa el modo de las configuraciones de topología de la familia del direccionamiento.

 
Paso 17 Map Tag del route-map de la distribuir-lista adentro


Ejemplo:

Router (config-router-AF-topología) # métrico-rango del route-map de la distribuir-lista adentro

 

Filtra las redes recibidas en las actualizaciones.

 

Ejemplos de Configuración de EIGRP Support for Route Map Filtering

Ejemplo que fija las etiquetas del EIGRP usando una configuración del sistema autónomo del Route Map

El siguiente ejemplo muestra cómo configurar un Route Map para hacer juego una ruta métrica del protocolo EIGRP externo con una desviación permisible de 100, un protocolo de la fuente del BGP, y un sistema autónomo 45000. Cuando las dos cláusulas de la coincidencia son verdades, el valor de la etiqueta del Routing Protocol del destino se fija a 5. El Route Map se utiliza para distribuir los paquetes entrantes para un proceso EIGRP.

Router(config)# route-map metric-range
Router(config-route-map)# match metric external 500 +- 100
Router(config-route-map)# match source-protocol bgp 45000
Router(config-route-map)# set tag 5
Router(config-route-map)# exit
Router(config)# router eigrp 1
Router(config-router)# network 172.16.0.0
Router(config-router)# distribute-list route-map metric_range in

El siguiente ejemplo muestra cómo configurar un Route Map para hacer juego las rutas EIGRP con un métrico de 110, de 200, o de un rango inclusivo de 700 a 800. Cuando la cláusula de la coincidencia es verdad, el valor de la etiqueta del Routing Protocol del destino se fija a 10. El Route Map se utiliza para redistribuir los paquetes EIGRP.

Router(config)# route-map metric-eigrp
Router(config-route-map)# match metric 110 200 750 +- 50
Router(config-route-map)# set tag 10
Router(config-route-map)# exit
Router(config)# router eigrp 1
Router(config-router)# network 172.21.1.0/24
Router(config-router)# redistribute eigrp route-map metric-eigrp

Ejemplo que fija las etiquetas del EIGRP usando un Route Map Configuration Nombrada

El siguiente ejemplo muestra cómo configurar un Route Map para hacer juego una ruta métrica del protocolo EIGRP externo con una desviación permisible de 100, un protocolo de la fuente del BGP, y un sistema autónomo 45000. Cuando las dos cláusulas de la coincidencia son verdades, el valor de la etiqueta del Routing Protocol del destino se fija a 5. El Route Map se utiliza para distribuir los paquetes entrantes para un proceso EIGRP.

Router(config)# route-map metric_range
Router(config-route-map)# match metric external 500 +- 100
Router(config-route-map)# match source-protocol bgp 45000
Router(config-route-map)# set tag 5
Router(config-route-map)# exit
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 45000
Router(config-router-af)# network 172.21.1.0/24
Router(config-router-af)# topology base
Router(config-router-af-topology)# distribute-list route-map metric_range in

El siguiente ejemplo muestra cómo configurar un Route Map para hacer juego las rutas EIGRP con un métrico de 110, de 200, o de un rango inclusivo de 700 a 800. Cuando la cláusula de la coincidencia es verdad, el valor de la etiqueta del Routing Protocol del destino se fija a 10. El Route Map se utiliza para redistribuir los paquetes EIGRP.

Router(config)# route-map metric_eigrp
Router(config-route-map)# match metric 110 200 750 +- 50
Router(config-route-map)# set tag 10
Router(config-route-map)# exit
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 45000
Router(config-router-af)# network 172.21.1.0/24
Router(config-router-af)# topology base
Router(config-router-af-topology)# distribute-list route-map metric-range in

AdditionalReferences

Documentos Relacionados

Tema relacionado

Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Descripción y configuración del EIGRP

La sección del EIGRP que configura del Routing IP del Cisco IOS: Guía de configuración EIGRP

Comandos eigrp incluyendo el sintaxis, las Pautas para el uso, y los ejemplos

Routing IP del Cisco IOS: Referencia del comando eigrp

Estándares

Estándar

Título

Ninguno

--

MIB

MIB

Link del MIB

Ninguno

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Ninguno

--

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información de la Función para el Soporte EIGRP para el Filtrado de Route Map

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Información de la característica del cuadro 1 para el soporte del EIGRP para la filtración del Route Map

Nombre de la función

Versiones

Información sobre la Función

EIGRP Support for Route Map Filtering

12.2(33)SRA 12.2(33)SRE 12.2(33)SXH 12.2(33)XNE 12.3(8)T el 15.0(1)M 15.0(1)S

El soporte del EIGRP para la función de filtrado del Route Map permite al EIGRP para interoperar con otros protocolos filtrando el tráfico entrante y saliente basado en las opciones complejas del Route Map. Se introduce varia opción de filtro extendida de proporcionar las opciones Eigrp-específicas de la coincidencia.

Los siguientes comandos fueron introducidos o modificados por esta característica: haga juego métrico (IP), haga juego el fuente-protocolo, muestre la topología EIGRP del IP.

En el Cisco IOS Release 15.0(1)M, 12.2(33)SRE, y 12.2(33)XNE el siguiente comando fue introducido o modificado para esta característica: muestre la topología de la direccionamiento-familia del eigrp

Cisco y el logotipo de Cisco son marcas registradas del Cisco Systems, Inc. y/o de sus afiliados en los E.E.U.U. y otros países. Un anuncio de las marcas registradas de Cisco se puede encontrar en www.cisco.com/go/trademarks. Las marcas registradas del otro vendedor mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1005R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.