Guía de la agregación y de configuración de DSL del acceso por banda ancha, Cisco IOS Release 12.2SR
NAS-Port-ID Format C Enhancement
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 150 KB | Inglés (2 Diciembre 2011) | Comentarios

NAS-Port-ID Format C Enhancement

Última actualización: 1 de diciembre de 2011

La función NAS-Port-ID Format C Enhancement inserta el comando nas-port-id format c para la configuración del grupo de acceso por banda ancha (grupo BBA). Este comando define un formato específico de codificación de la identificación de línea de acceso del suscriptor a banda ancha (NAS-Port-ID). Cuando se configura este comando, se sobrescribe el valor original de la etiqueta NAS-Port-ID. Si no hay Cadena válida disponible para el ID remoto o la etiqueta del circuit id como parte de la opción 82 del Protocolo de configuración dinámica de host (DHCP), una cadena predeterminada de 0/0/0/0/0/0 se añade al final del fichero a la etiqueta del nas-port-id.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en Cisco.com no se requiere.

Requisitos previos para la mejora del C del formato del nas-port-id

Se crea la etiqueta del nas-port-id.

Restricciones de la Función NAS-Port-ID Format C Enhancement

La característica de la mejora del C del formato del nas-port-id se soporta en la plataforma de las Cisco 10000 Series donde se soporta la funcionalidad de servidor del PPP over Ethernet (PPPoE).

Esta característica no se soporta en el PPP over ATM.

Información sobre la Función NAS-Port-ID Format C Enhancement

Formato de codificación para NAS-Port-ID Format C

La característica de la mejora del C del formato del nas-port-id proporciona el formato siguiente de la codificación de la identificación de línea de acceso del suscriptor a banda ancha (nas-port-id):

{ATM/eth/trunk} NAS_slot/NAS_subslot/NAS_port: XPI: XCI {circuit id/cadena del ID remoto/del valor por defecto}

  • Para la atmósfera, XPI es el identificador de trayecto virtual (VPI) y XCI es el identificador de circuito virtual (VCI).
  • Para los Ethernetes, XPI es VLAN-etiqueta externa, XCI es VLAN-etiqueta interna.
  • Requisitos para XPI: XCI para los Ethernetes es como sigue:
    • Para el 802.1Q que hace un túnel (QinQ), el formato debe ser VLAN-etiqueta externa: VLAN-etiqueta interna. (Antes de la versión 12.2(31)SB2, Cisco IOS Software soporta la VLAN-etiqueta interna: VLAN-etiqueta externa).
    • Para el solo VLA N de la etiqueta, XPI debe ser 4096.
  • La etiqueta del circuit id (si presente) se debe añadir al final del fichero a esta cadena cuando utilizan al comando c del formato del nas-port-id. El formato para la etiqueta del circuit id o del ID remoto es como sigue:

AccessNodeIdentifier/ANI_rack/ANI_frame/ANI_slot/ANI_subslot/ANI_port [: ANI_XPI.ANI_XCI]

  • El Digital Subscriber Line Access Multiplexer (DSLAM) debe añadir esta información al Remote Access Server de banda ancha (SUJETADORES), y los SUJETADORES al final del fichero transparente lo entrega. Si la etiqueta del circuit id o del ID remoto no está presente en la opción DHCP 82, una cadena de 0/0/0/0/0/0 se debe añadir al final del fichero a la etiqueta del nas-port-id.

Los siguientes ejemplos ilustran este formato:

  • Nas-port-id = ATM 31/31/7:255.65535 name001/0/31/63/31/127

En este ejemplo, el tipo de interfaz del suscriptor del equipo de los SUJETADORES es una interfaz ATM, el número de slot de los SUJETADORES es 31, el número del subslot de los SUJETADORES es 31, el número del puerto de los SUJETADORES es 7, el VPI es 255, y el VCI es 65535. La cadena name001/0/31/63/31/127 es la etiqueta del circuit id o del ID remoto.

  • Nas-port-id = eth 31/31/7:1234.2345 0/0/0/0/0/0

En este ejemplo, el tipo de interfaz del suscriptor del equipo de los SUJETADORES es una interfaz de Ethernet, el número de slot de los SUJETADORES es 31, el número del subslot de los SUJETADORES es 31, el número del puerto de los SUJETADORES es 7, la VLAN-etiqueta externa es 1234, y la VLAN-etiqueta interna es 2345. La cadena 0/0/0/0/0/0 es el valor predeterminado.

  • Nas-port-id = eth 31/31/7:4096.2345 0/0/0/0/0/0

En este ejemplo, el tipo de interfaz del suscriptor del equipo de los SUJETADORES es una interfaz de Ethernet, el número de slot de los SUJETADORES es 31, el número del subslot de los SUJETADORES es 31, el número del puerto de los SUJETADORES es 7, y el VLAN ID es 2345. La cadena 0/0/0/0/0/0 es el valor predeterminado.

Cómo Configurar la Función NAS-Port-ID Format C Enhancement

Configuración de la Función NAS-Port-ID Format C Enhancement Feature

Para sobregrabar el valor original del nas-port-id marque y defina al suscriptor a banda ancha con etiqueta específico que el formato de la codificación de la identificación de línea de acceso (nas-port-id) realiza la tarea siguiente.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. nombre del grupo del pppoe del BBA-grupo

4. plantilla-número de la virtual-plantilla

5. formato c del nas-port-id

6. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
nombre del grupo del pppoe del BBA-grupo


Ejemplo:

Pppoe-grupo del pppoe del BBA-grupo de Router(config)#

 

Ingresa el modo de la configuración de grupo BBA y define un perfil del pppoe.

 
Paso 4
plantilla-número de la virtual-plantilla


Ejemplo:

Router (config-BBA-grupo) # virtual-template 1

 

Configura un perfil PPPoE con una plantilla virtual que se utilizará para reproducir las interfaces de acceso virtual.

  • El argumento del plantilla-número es un número de identificación de la plantilla virtual que será utilizada para reproducir las interfaces de acceso virtual.
 
Paso 5
formato c del nas-port-id


Ejemplo:

Router (config-BBA-grupo) # formato c del nas-port-id

 

Especifica un formato para la codificación de la identificación de línea de acceso del suscriptor a banda ancha.

Nota    La designación del formato c se diseña específicamente como sigue:

NAS_PORT_ID=atm 31/31/7:255.65535 name001/0/31/63/31/127

 
Paso 6
Finalizar


Ejemplo:

Router (config-BBA-grupo) # extremo



Ejemplo:

 

Sale el modo y las devoluciones de la configuración actual al modo EXEC privilegiado.

 

Ejemplos de configuración para la mejora de NAS-Port-ID Format C

Para habilitar la característica de la mejora del C del formato del nas-port-id, usted debe configurar el lado del concentrador de acceso y el lado del cliente en su red. :

Configurar el PPPoE sobre los Ethernetes por el ejemplo lateral del lado y del cliente del concentrador de acceso

Lo que sigue es una configuración de muestra para el lado del concentrador de acceso de un PPPoE sobre la configuración de Ethernet:

bba-group pppoe bba-pppoeoe
 virtual-template 1
 nas-port-id format c
!
interface Loopback0
 ip address 209.165.200.234 255.255.255.224
!
interface Virtual-Template1
 ip unnumbered Loopback0
no peer default ip address
 ppp authentication chap
!
interface FastEthernet0/0
 description PPPoEoE
 pppoe enable group bba-pppoeoe
!

A continuación se ofrece un ejemplo de configuración para el lado de cliente:

bba-group pppoe bbag-pppoeoe
 virtual-template 1
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp chap hostname xyz
 ppp chap password 0 lab
!
interface Loopback0
 ip address 209.165.200.243 255.255.255.224
!
interface FastEthernet1/1
 no ip address
 pppoe enable group bbag-pppoeoe
!

Configurar el PPPoE sobre el AAL5SNAP atmósfera por el ejemplo lateral del lado y del cliente del concentrador de acceso

Lo que sigue es una configuración de muestra para el lado del concentrador de acceso de un PPPoE sobre una configuración (RÁPIDA) del Subnetwork Access Protocol ATM/AAL5:

bba-group pppoe bba-pppoeoa
 virtual-template 2
 nas-port-id format c
!
interface Loopback1
 ip address 209.165.200.245 255.255.255.224
!
interface Virtual-Template2
 ip unnumbered Loopback1
no peer default ip address
 ppp authentication chap
!
interface ATM2/0.1 multipoint
 description PPPoEoA
 pvc 1/100
  encapsulation aal5snap
  protocol pppoe group bba-pppoeoa
 !

A continuación se ofrece un ejemplo de configuración para el lado de cliente:

bba-group pppoe bbag-pppoeoa
 virtual-template 2
!
interface Virtual-Template2
 ip unnumbered Loopback1
 ppp chap hostname abc
 ppp chap password 0 lab
!
interface Loopback1
 ip address 209.165.200.247 255.255.255.224
!
interface ATM6/0.1 multipoint
 pvc 1/100
 encapsulation aal5snap
 protocol pppoe group bbag-pppoeoa
 !

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con la característica de la mejora del C del formato del nas-port-id.

Documentos Relacionados

Tema relacionado

Título del documento

Documentación de la referencia de comandos para los comandos usados en este documento

Agregación del acceso por banda ancha del Cisco IOS y referencia de comandos DSL

Estándares

Estándar

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.

--

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre la Función NAS-Port-ID Format C Enhancement

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para la característica de la mejora del C del formato del nas-port-id

Nombre de la función

Versiones

Información sobre la Función

NAS-Port-ID Format C Enhancement

12.2(31)SB2

el 15.0(1)M

Esta plataforma de las Cisco 10000 Series de los soportes de característica.

El ccommand del formato del nas-port-id define un formato específico de la codificación de la identificación de línea de acceso del suscriptor a banda ancha (nas-port-id). Cuando se configura este comando, se sobrescribe el valor original de la etiqueta NAS-Port-ID. Si no hay Cadena válida disponible para la etiqueta del ID remoto o del circuit id como parte de la opción 82 del Protocolo de configuración dinámica de host (DHCP), una cadena predeterminada de 0/0/0/0/0/0 se añade al final del fichero a la etiqueta del nas-port-id.

Se han insertado o modificado los siguientes comandos: formato c del nas-port-id

Glosario

AAA --autenticación, autorización y contabilidad.

ATM --Asynchronous Transfer Mode.

SUJETADORES --Remote Access Server de banda ancha.

CLI --interfaz de la línea de comandos.

DHCP --Protocolo DHCP.

DSLAM --Digital Subscriber Line Access Multiplexer.

HA --Alta disponibilidad.

NAS --servidor de acceso a la red.

PPP --Point-to-Point Protocol

PPPoA --Protocolo Point-to-Point sobre la atmósfera.

PPPoE --Protocolo Point-to-Point sobre los Ethernetes.

QinQ --El hacer un túnel del IEEE 802.1Q.

RADIUS --Remote Authentication Dial-In User Service (RFC 2865).

SNAP --Subnetwork Access Protocol.

VCI --identificador de circuito virtual.

VLAN --Virtual Local-Area Network.

VPI --identificador de trayecto virtual.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.