Cisco IOS Release 12.2SR de la guía de configuración de los Servicios de aplicación IP
Configuración del Seguimiento de Objeto Mejorado
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 323 KB | Inglés (27 Junio 2011) | Comentarios

Contenido

Configuración del Seguimiento de Objeto Mejorado

Última actualización: De julio el 13 de 2011

Antes de la introducción de la característica aumentada del Rastreo de objetos, el Hot Standby Router Protocol (HSRP) tenía un mecanismo de seguimiento simple que permitió que usted siguiera el estado del Line Protocol de la interfaz solamente. Si el estado del Line Protocol de la interfaz estuviese inactivo, la prioridad de HRSP del router se reduciría, lo que permitiría que pasase a estar activo otro router de HSRP con una prioridad mayor.

La característica aumentada del Rastreo de objetos separa el mecanismo de seguimiento del HSRP y crea un proceso de seguimiento independiente separado que se pueda utilizar por otros procesos y el HSRP del Cisco IOS. Esta función permite el seguimiento de otros objetos además del estado del protocolo de línea de la interfaz.

Un proceso del cliente tal como HSRP, Virtual Router Redundancy Protocol (VRRP), o protocolo del Equilibrio de carga del gateway (GLBP), se puede registrar su interés en el seguimiento de los objetos y después notificar cuando el estado seguido de los cambios del objeto.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en Cisco.com no se requiere.

Restricciones para el Rastreo de objetos aumentado

El Rastreo de objetos aumentado no es el Stateful Switchover (SSO) - enterado y no se puede utilizar con el Hot Standby Routing Protocol (HSRP), el Virtual Router Redundancy Protocol (VRRP), o el protocolo del Equilibrio de carga del gateway (GLBP) en el modo SSO.

Información sobre el Rastreo de objetos aumentado

Diseño de Función del Seguimiento de Objetos Mejorado

La característica aumentada del Rastreo de objetos proporciona la separación completa entre los objetos que se seguirán y Paso a seguir por un cliente cuando un objeto seguido cambia. Así, varios clientes tales como HSRP, VRRP, o GLPB pueden registrar su interés con el proceso de seguimiento, siguen el mismo objeto, y cada tome diversas medidas cuando el objeto cambia.

Cada objeto seguido es identificado por un número único que se especifique en el CLI de seguimiento. Los procesos del cliente utilizan este número para realizar el seguimiento de un objeto específico.

El proceso de seguimiento interroga periódicamente a los objetos sometidos a seguimiento y anota cualquier cambio del valor. Los cambios en el objeto de seguimiento se comunican a los procesos cliente interesados, inmediatamente o después de una demora especificada. Los valores del objeto se notifican como activo o inactivo.

Usted puede configurar una combinación de objetos seguidos en una lista y un método flexible para combinar los objetos usando la lógica boleana. Estas funciones incluyen las capacidades siguientes:

  • El “ del € del â del “ del € de Thresholdâ la lista seguida se puede configurar para utilizar una ponderación o un umbral de porcentaje para medir el estado de la lista. Cada objeto en una lista seguida se puede asignar una ponderación del umbral. El estado de la lista seguida se determina por si se ha resuelto el umbral.
  • El “ boleano “y” del functionâ del € del “ del â del € cuando una lista seguida se ha asignado un boleano “y” la función, cada objeto definido dentro de un subconjunto debe estar en un estado ascendente de modo que el objeto seguido pueda convertirse para arriba.
  • El “ boleano “o” del functionâ del € del “ del â del € cuando la lista seguida se ha asignado un boleano “o” la función, por lo menos un objeto definido dentro de un subconjunto debe estar en un estado ascendente de modo que el objeto seguido pueda convertirse para arriba.

A partir del Cisco IOS Release 15.1(3)T, de 15.1(1)S y de 12.2(50)SY un máximo de 1000 objetos puede ser seguido. Aunque 1000 objetos seguidos puedan ser configurados, cada objeto seguido utiliza a los recursos de la CPU. La cantidad de recursos de la CPU disponibles en un router depende de las variables tales como carga de tráfico y cómo otros protocolos se configuran y se ejecutan. La capacidad de utilizar 1000 objetos seguidos depende del CPU disponible. La prueba se debe conducir en el sitio para asegurarse de que el servicio trabaja bajo condiciones de tráfico específicas del sitio.

Seguimiento del estado de la interfaz

Un objeto del Routing IP se considera encima de cuando existen los criterios siguientes:

  • Se habilita el Routing IP y active en la interfaz.
  • El estado del Line Protocol de la interfaz está para arriba.
  • Se sabe la dirección IP de la interfaz. La dirección IP se configura o se recibe con la negociación del Protocolo de configuración dinámica de host (DHCP) o del IP Control Protocol (IPCP).

El Routing IP de la interfaz irá abajo de cuando existe uno de los criterios siguientes:

  • El Routing IP se inhabilita global.
  • El estado del Line Protocol de la interfaz está abajo.
  • La dirección IP de la interfaz es desconocida. La dirección IP no se configura ni se recibe con el DHCP o la negociación IPCP.

El seguimiento del estado de ruteo de IP de una interfaz usando el comando del track interface ip routing puede ser más útil en algunas situaciones que si solamente se realiza el seguimiento del estado de protocolo de línea usando el comando track interface line-protocol, especialmente en las interfaces para las que se negocian las direcciones IP. Por ejemplo, en una interfaz serial que utiliza el PPP, el Line Protocol podría estar para arriba ([LCP] del Link Control Protocol negociado con éxito), pero el IP podría estar abajo (negociación IPCP fallada).

El comando ip routing de la interfaz de la pista soporta el seguimiento de una interfaz con una dirección IP adquirida con los métodos siguientes uces de los:

  • Configuración de IP Address convencional
  • PPP/IPCP
  • DHCP
  • Interfaz sin numerar

Usted puede configurar el Rastreo de objetos aumentado para considerar el temporizador del portador-retardo al seguir el estado del Routing IP de una interfaz usando el comando carrier-delay en el seguimiento del modo de configuración.

Métrica escalada de la ruta

El comando ip route de la pista habilita el seguimiento de una ruta en la tabla de ruteo. Si una ruta existe en la tabla, el valor métrico se convierte en un número. Para proporcionar una interfaz común a seguir a los clientes, normalice los valores métricos de la ruta al rango a partir de la 0 a 255, donde 0 está conectado y 255 es inaccesibles. La métrica escalada puede ser seguida fijando los umbrales. Arriba y abajo de la notificación del estado ocurre cuando se cruzan los umbrales. El valor de resultado se compara contra los valores de umbral para determinar el estado de seguimiento como sigue:

  • El estado es para arriba si es el métrico escalada para esa ruta inferior o igual el umbral ascendente.
  • El estado es abajo si es el métrico escalada para esa ruta mayor o igual abajo el umbral.

El seguimiento utiliza un valor configurable de la resolución del por-protocolo para convertir el métrico real al métrico escalada. La tabla abajo muestra los valores predeterminados usados para la conversión. Usted puede utilizar el comando de la resolución de la pista de cambiar los valores predeterminados métricos de la resolución.

Tabla 1Conversión métrica

Tipo 1 de la ruta

Resolución métrica

Estática

10

Enhanced Interior Gateway Routing Protocol (EIGRP)

2560

Open Shortest Path First (OSPF)

1

Intermediate System-to-Intermediate System (IS-IS)

10

1 RIP se escala directamente al rango a partir de la 0 a 255 porque su métrico máximo es menos de 255.

Por ejemplo, un cambio en 10 en los resultados métricos IS-IS en un cambio de 1 en el métrico escalada. Se diseñan las resoluciones predeterminadas de modo que aproximadamente un link 2-Mbps en la trayectoria dé un métrico escalada de 255.

El escalamiento de los rangos métricos muy grandes del EIGRP y del IS-IS al a0 al rango 255 es un compromiso. Las resoluciones predeterminadas harán el métrico escalada exceder el límite máximo con un link 2-Mb/s. Sin embargo, este escalamiento permite una distinción entre una ruta que consiste en tres links Fast Ethernet y una ruta que consiste en cuatro links Fast Ethernet.

Seguimiento de la operación IP SLA

El Rastreo de objetos de las operaciones llanas de los acuerdos del servicio del IP (SLA) permite el seguir de los clientes para seguir la salida de los objetos IP SLA y para utilizar la información proporcionada para accionar una acción.

El IP SLA del Cisco IOS es una herramienta de la medición del rendimiento de la red y de diagnósticos que utiliza la supervisión activa. La supervisión activa es la generación de tráfico de una manera confiable y fiable para medir el rendimiento de la red. El Cisco IOS Software utiliza IP SLA para recoger la métrica en tiempo real tal como tiempo de respuesta, Disponibilidad de recursos de red, rendimiento de la aplicación, jitter (varianza del retardo de entre paquetes), tiempo de conexión, producción, y pérdida del paquete.

Estas métricas se pueden utilizar para localizar averías, porque el análisis dinámico antes de que ocurran los problemas, y para diseñar las topologías de red.

Cada operación IP SLA mantiene un valor de código de retorno de la operación. Este código de retorno es interpretado por el proceso de seguimiento. El código de retorno puede volver OK, OverThreshold, y varios otros códigos de retorno. Se utilizan diversas operaciones pueden tener diversos valores de código de retorno, valoran tan solamente el campo común a todos los tipos de operación.

Dos aspectos de una operación IP SLA pueden ser seguidos: estado y accesibilidad. La diferencia entre estos aspectos es la aceptación del código de retorno de OverThreshold. La tabla abajo muestra el estado y los aspectos del accesibilidad de las operaciones IP SLA que pueden ser seguidas.

Tabla 2Comparación de las operaciones del estado y del accesibilidad

Seguimiento

Código de retorno

Estado de la pista

Estado

OK

(el resto de los códigos de retorno)

En funcionamiento

Down (inactivo)

Alcance

AUTORIZACIÓN u OverThreshold

(el resto de los códigos de retorno)

En funcionamiento

Down (inactivo)

Seguimiento Mejorado de Objetos y Embedded Event Manager

El Rastreo de objetos aumentado (EOT) ahora se integra con el administrador del evento integrado (EEM) para permitir EEM señale sobre el cambio de estado de un objeto seguido y permita que el EOT siga los objetos EEM. Un tipo nuevo de seguir el objeto--un objeto del stub--se crea. El objeto del stub se puede modificar por un proceso externo a través de una interfaz de programación de aplicaciones definida (API). Vea el documento de descripción general integrado del administrador del evento en la guía de configuración de la administración de Cisco IOSNetwork para más información sobre cómo el EOT trabaja con EEM.

Soporte de EOT para Demora de Portadora

La función EOT Support for Carrier Delay permite al Seguimiento de Objetos Mejorado (EOT) considerar el temporizador de demora de la portadora cuando se realiza el seguimiento del estado de una interfaz.

Si un link falla, por abandono hay un dos-segundo temporizador que debe expirar antes de una interfaz y las rutas asociadas se declaran como estando abajo. Si un link va abajo y viene salvaguardia antes de que expire el temporizador del retraso del portador, filtran al estado inactivo con eficacia, y el resto del software en el Switch no es consciente que ocurrió un evento de la conexión abajo. Usted puede configurar el portador-retardo que los segundos ordenan en el modo de configuración de la interfaz para extender el temporizador hasta 60 segundos.

Cuando el EOT se configura en una interfaz, el seguimiento puede detectar la interfaz está abajo antes de que haya expirado un temporizador configurado del portador-retardo. Esto es porque las miradas EOT en la interfaz estado y no considera el temporizador del retraso del portador. Utilice el comando carrier-delay en el seguimiento del modo de configuración para habilitar el seguimiento para considerar el temporizador del portador-retardo configurado en una interfaz.

Seguimiento de Objetos Mejorado para las Aplicaciones de Mobile IP

El soporte aumentado del Rastreo de objetos para la característica del IP móvil permite al EOT para monitorear la presencia de tráfico del Home Agent, del Packet Data Serving Node (PDSN), o del Gateway GPRS Support Node (GGSN) en un router para las aplicaciones de la Tecnología inalámbrica móvil.

Cuando un par redundante de los agentes caseros que ejecutan el HSRP entre ellos pierde la Conectividad, ambos Nodos del HSRP llegan a ser activos. Una vez que la Conectividad se restablece entre los dos Nodos, una manera agraciada es necesaria restablecer los estados apropiados del HSRP sin los atascamientos del Home Agent que pierden. Durante la época de ninguna Conectividad, uno de los Nodos continuará procesando el tráfico del Home Agent, GGSN, o PDSN mientras que el otro no. El nodo que continúa procesando el tráfico necesita seguir siendo Conectividad activa se restablece una vez. Para asegurarse de que siga habiendo el nodo activo en el estado activo, la prioridad del miembro del grupo del HSRP que no procesa tráfico del Home Agent se reduce. La reducción de la prioridad del nodo que no está procesando el tráfico del Home Agent se asegura de que este nodo se convertirá en el recurso seguro después de que se restablezca la Conectividad. Cuando se restablece la Conectividad, la sincronización de estado normal del Home Agent conseguirá todos los atascamientos nuevamente dentro del nodo inactivo y, dependiendo de la configuración de la apropiación, puede cambiar otra vez. Esta sincronización de estado se asegura de que no se pierda ningunos atascamientos del IP móvil, GGSN, o PDSN.

Para más información sobre configurar los servicios del IP móvil, vea las guías de configuración del Cisco IOS siguientes:

  • Guía de configuración del Home Agent de la Tecnología inalámbrica móvil del Cisco IOS
  • Guía de configuración del Gateway GPRS Support Node de la Tecnología inalámbrica móvil del Cisco IOS
  • Guía de configuración del Packet Data Serving Node de la Tecnología inalámbrica móvil del Cisco IOS
  • Guía de configuración de IP Mobility de Cisco IOS

Ventajas de Enhanced Object Tracking

  • Aumenta la Disponibilidad y la velocidad de la recuperación de una red.
  • Disminuye el número de interrupciones de la red y de su duración.
  • Procesos del cliente de los permisos tales como VRRP y GLBP para seguir los objetos individualmente o como lista de objetos. Antes de la introducción de estas funciones, el proceso de seguimiento fue integrado dentro del HSRP.

Cómo configurar aumentó el Rastreo de objetos

Seguimiento del Estado de Protocolo de Línea de una Interfaz

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. interfaz del temporizador de la pista {segundos | milisegundos milisegundo}

4. Line Protocol del número del tipo de la interfaz del objeto-número de la pista

5. portador-retardo

6. retardo {encima del [down [seconds] de los segundos | del [up seconds] segundos abajo]}

7. extremo

8. muestre el objeto-número de la pista


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
interfaz del temporizador de la pista {segundos | milisegundos milisegundo}


Ejemplo:

Interfaz 5 del temporizador de la pista de Router(config)#

 

(Opcional) Especifica el intervalo en el cual el proceso de seguimiento sondea el objeto de seguimiento.

  • El intervalo predeterminado durante el cual el proceso de seguimiento sondea los objetos de la interfaz es 1 segundo.
Nota    Todas las frecuencias de consultas se pueden configurar abajo a 500 milisegundos, reemplazando el intervalo del mínimo 1-second configurado usando la palabra clave milisegundo y los milisegundos de argumento.
 
Paso 4
Line Protocol del número del tipo de la interfaz del objeto-número de la pista


Ejemplo:

Line Protocol de las interfaces Ethernet 0/1 de la pista 3 de Router(config)#

 

Sigue el estado del Line Protocol de una interfaz y ingresa el seguimiento del modo de configuración.

 
Paso 5
portador-retardo


Ejemplo:

Router (config-pista) # portador-retardo

 

(Opcional) Habilita el EOT para considerar el temporizador de demora del portador al realizar el seguimiento del estado de una interfaz.

 
Paso 6
retardo {encima del [down [seconds] de los segundos | del [up seconds] segundos abajo]}


Ejemplo:

Router (config-pista) # retardo encima de 30

 

(Opcional) Especifica un período de tiempo (en segundos) para demorar la comunicación de los cambios de estado de un objeto seguido.

 
Paso 7
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Sale al modo EXEC privilegiado.

 
Paso 8
muestre el objeto-número de la pista


Ejemplo:

Pista 3 de la demostración del Router-

 

(Opcional) Muestra información de seguimiento.

  • Utilice este comando para verificar la configuración.
 

Ejemplo:

El siguiente ejemplo muestra el estado del Line Protocol en una interfaz cuando se sigue:

Router# show track 3

Track 3
   Interface Ethernet0/1 line-protocol
   Line protocol is Up
     1 change, last change 00:00:05
   Tracked by:
     HSRP Ethernet0/3 1

Seguimiento del Estado de IP Routing de una Interfaz

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. interfaz del temporizador de la pista {segundos | milisegundos milisegundo}

4. Routing IP del número del tipo de la interfaz del objeto-número de la pista

5. portador-retardo

6. retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}

7. extremo

8. muestre el objeto-número de la pista


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
interfaz del temporizador de la pista {segundos | milisegundos milisegundo}


Ejemplo:

Interfaz 5 del temporizador de la pista de Router(config)#

 

(Opcional) Especifica el intervalo en el cual el proceso de seguimiento sondea el objeto de seguimiento.

  • El intervalo predeterminado durante el cual el proceso de seguimiento sondea los objetos de la interfaz es 1 segundo.
Nota    Todas las frecuencias de consultas se pueden configurar abajo a 500 milisegundos, reemplazando el intervalo del mínimo 1-second configurado usando la palabra clave milisegundo y los milisegundos de argumento.
 
Paso 4
Routing IP del número del tipo de la interfaz del objeto-número de la pista


Ejemplo:

Routing IP de las interfaces Ethernet 0/1 de la pista 1 de Router(config)#

 

Sigue el estado del Routing IP de una interfaz y ingresa el seguimiento del modo de configuración.

  • El seguimiento de la ruta de IP sigue una ruta de IP en la tabla de ruteo y la capacidad de una interfaz de rutear los paquetes IP.
 
Paso 5
portador-retardo


Ejemplo:

Router (config-pista) # portador-retardo

 

(Opcional) Habilita el EOT para considerar el temporizador de demora del portador al realizar el seguimiento del estado de una interfaz.

 
Paso 6
retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 30

 

(Opcional) Especifica un período de tiempo (en segundos) para demorar la comunicación de los cambios de estado de un objeto seguido.

 
Paso 7
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Vuelve al modo EXEC privilegiado.

 
Paso 8
muestre el objeto-número de la pista


Ejemplo:

Pista 1 de la demostración del Router-

 

Visualiza la información de seguimiento.

  • Utilice este comando para verificar la configuración.
 

Ejemplo:

El siguiente ejemplo muestra el estado del Routing IP en una interfaz cuando se sigue:

Router# show track 1

Track 1
   Interface Ethernet0/1 ip routing
   IP routing is Up
     1 change, last change 00:01:08
   Tracked by:
     HSRP Ethernet0/3 1

Seguimiento del Alcance de una Ruta IP

Realice esta tarea de seguir el accesibilidad de una ruta de IP. Un objeto seguido se considera encima de cuando una entrada de la tabla de ruteo existe para la ruta y la ruta es accesible.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. ruta de IP del temporizador de la pista {segundos | milisegundos milisegundo}

4. accesibilidad del IP address/de la longitud del prefijo de la ruta de IP del objeto-número de la pista

5. retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}

6. IP VRF vrf-name

7. extremo

8. muestre el objeto-número de la pista


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
ruta de IP del temporizador de la pista {segundos | milisegundos milisegundo}


Ejemplo:

Ruta de IP 20 del temporizador de la pista de Router(config)#

 

(Opcional) Especifica el intervalo en el cual el proceso de seguimiento sondea el objeto de seguimiento.

  • El intervalo predeterminado durante el cual el proceso de seguimiento sondea los objetos de ruta IP es de 15 segundos.
Nota    Todas las frecuencias de consultas se pueden configurar abajo a 500 milisegundos, reemplazando el intervalo del mínimo 1-second configurado usando la palabra clave milisegundo y los milisegundos de argumento.
 
Paso 4
accesibilidad del IP address/de la longitud del prefijo de la ruta de IP del objeto-número de la pista


Ejemplo:

Accesibilidad de la ruta de IP 10.16.0.0/16 de la pista 4 de Router(config)#

 

Sigue el accesibilidad de una ruta de IP y ingresa el seguimiento del modo de configuración.

 
Paso 5
retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 30

 

(Opcional) Especifica un período de tiempo (en segundos) para demorar la comunicación de los cambios de estado de un objeto seguido.

 
Paso 6
IP VRF vrf-name


Ejemplo:

Router (config-pista) # IP VRF VRF2

 

(Opcional) configura una tabla del VPN Routing and Forwarding (VRF).

 
Paso 7
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Vuelve al modo EXEC privilegiado.

 
Paso 8
muestre el objeto-número de la pista


Ejemplo:

Pista 4 de la demostración del Router-

 

(Opcional) Muestra información de seguimiento.

  • Utilice este comando para verificar la configuración.
 

Ejemplo:

El siguiente ejemplo muestra el estado del accesibilidad de una ruta de IP cuando se sigue:

Router# show track 4

Track 4
   IP route 10.16.0.0 255.255.0.0 reachability
   Reachability is Up (RIP)
     1 change, last change 00:02:04
   First-hop interface is Ethernet0/1
   Tracked by:
     HSRP Ethernet0/3 1

Seguimiento del Umbral de las Métricas de la Ruta IP

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. ruta de IP del temporizador de la pista {segundos | milisegundos milisegundo}

4. ruta de IP de la resolución de la pista {eigrp | ISIS | OSPF | resolución-valor de los parásitos atmosféricos}

5. siga el IP address de la ruta de IP del objeto-número/el umbral métrico de la longitud del prefijo

6. retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}

7. IP VRF vrf-name

8. umbral métrico {encima del [down number] del número | abajo [up number] del número}

9. extremo

10. muestre el objeto-número de la pista


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
ruta de IP del temporizador de la pista {segundos | milisegundos milisegundo}


Ejemplo:

Ruta de IP 20 del temporizador de la pista de Router(config)#

 

(Opcional) Especifica el intervalo en el cual el proceso de seguimiento sondea el objeto de seguimiento.

  • El intervalo predeterminado durante el cual el proceso de seguimiento sondea los objetos de ruta IP es de 15 segundos.
Nota    Todas las frecuencias de consultas se pueden configurar abajo a 500 milisegundos, reemplazando el intervalo del mínimo 1-second configurado usando la palabra clave milisegundo y los milisegundos de argumento.
 
Paso 4
ruta de IP de la resolución de la pista {eigrp | ISIS | OSPF | resolución-valor de los parásitos atmosféricos}


Ejemplo:

Eigrp 300 de la ruta de IP de la resolución de la pista de Router(config)#

 

(Opcional) especifica los parámetros de la resolución para un objeto seguido.

  • Utilice este comando de cambiar los valores métricos predeterminados de la resolución.
 
Paso 5
siga el IP address de la ruta de IP del objeto-número/el umbral métrico de la longitud del prefijo


Ejemplo:

Umbral métrico de la ruta de IP 10.16.0.0/16 de la pista 6 de Router(config)#

 

Sigue el valor métrico escalado de una ruta de IP para determinar si está sobre o debajo de un umbral y ingresa el seguimiento del modo de configuración.

  • El valor por defecto abajo valora es 255, que compara a una ruta inaccesible.
  • El valor por defecto encima del valor es 254.
 
Paso 6
retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 30

 

(Opcional) Especifica un período de tiempo (en segundos) para demorar la comunicación de los cambios de estado de un objeto seguido.

 
Paso 7
IP VRF vrf-name


Ejemplo:

Router (config-pista) # IP VRF VRF1

 

(Opcional) configura una tabla VRF.

 
Paso 8
umbral métrico {encima del [down number] del número | abajo [up number] del número}


Ejemplo:

Router (config-pista) # umbral para arriba 254 abajo 255 métricos

 

(Opcional) fija un umbral métrico con excepción del valor predeterminado.

 
Paso 9
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Sale al modo EXEC privilegiado.

 
Paso 10
muestre el objeto-número de la pista


Ejemplo:

Pista 6 de la demostración del Router-

 

(Opcional) Muestra información de seguimiento.

  • Utilice este comando para verificar la configuración.
 

Ejemplo:

El siguiente ejemplo muestra el umbral métrico de una ruta de IP cuando se sigue:

Router# show track 6

Track 6
   IP route 10.16.0.0 255.255.0.0 metric threshold
   Metric threshold is Up (RIP/6/102)
     1 change, last change 00:00:08
   Metric threshold down 255 up 254
   First-hop interface is Ethernet0/1
   Tracked by:
     HSRP Ethernet0/3 1

Seguimiento del Estado de una Operación de SLAs de IP

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. estado del operación-número del sla del IP del objeto-número de la pista

4. retardo {encima de los segundos [abajo segundos | del [up seconds] segundos abajo}

5. extremo

6. muestre el objeto-número de la pista


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
estado del operación-número del sla del IP del objeto-número de la pista


Ejemplo:

Estado del sla 4 del IP de la pista 2 de Router(config)#

 

Sigue el estado de un objeto IP SLA y ingresa el seguimiento del modo de configuración.

Eficaz con el Cisco IOS Release 12.4(20)T, 12.2(33)SXI1, y 12.2(33)SRE el comando del sla del IP de la pista substituyó al comando rtr de la pista.  
Paso 4
retardo {encima de los segundos [abajo segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 60 abajo 30

 

(Opcional) Especifica un período de tiempo (en segundos) para demorar la comunicación de los cambios de estado de un objeto seguido.

 
Paso 5
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Sale al modo EXEC privilegiado.

 
Paso 6
muestre el objeto-número de la pista


Ejemplo:

Pista 2 de la demostración del Router-

 

(Opcional) Muestra información de seguimiento.

  • Utilice este comando para verificar la configuración.
 

Ejemplo:

El siguiente ejemplo muestra el estado del seguimiento IP SLA:

Router# show track 2

Track 2
   IP SLA 1 state
   State is Down
     1 change, last change 00:00:47
   Latest operation return code: over threshold
   Latest RTT (millisecs) 4
   Tracked by:
     HSRP Ethernet0/1 3

Seguimiento del Alcance de un Host IP de SLAs IP

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. accesibilidad del operación-número del sla del IP del objeto-número de la pista

4. retardo {encima del [down seconds] de los segundos | downseconds del [up seconds]}

5. extremo

6. muestre el objeto-número de la pista


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
accesibilidad del operación-número del sla del IP del objeto-número de la pista


Ejemplo:

Accesibilidad del sla 4 del IP de la pista 2 de Router(config)#

 

Sigue el accesibilidad de un host IP IP SLA y ingresa el seguimiento del modo de configuración.

Nota    Eficaz con el Cisco IOS Release 12.4(20)T, 12.2(33)SXI1, y 12.2(33)SRE, el comando del sla del IP de la pista substituyó al comando rtr de la pista.
 
Paso 4
retardo {encima del [down seconds] de los segundos | downseconds del [up seconds]}


Ejemplo:

Router (config-pista) # retardo encima de 30 abajo 10

 

(Opcional) Especifica un período de tiempo (en segundos) para demorar la comunicación de los cambios de estado de un objeto seguido.

 
Paso 5
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Sale al modo EXEC privilegiado.

 
Paso 6
muestre el objeto-número de la pista


Ejemplo:

Pista 3 de la demostración del Router-

 

(Opcional) Muestra información de seguimiento.

  • Utilice este comando para verificar la configuración.
 

Ejemplo:

El siguiente ejemplo muestra si la ruta es accesible:

Router# show track 3

Track 3
   IP SLA 1 reachability
   Reachability is Up
     1 change, last change 00:00:47
   Latest operation return code: over threshold
   Latest RTT (millisecs) 4
   Tracked by:
     HSRP Ethernet0/1 3

Configuración de una Lista Seguida y una Expresión Booleana

Realice esta tarea de configurar una lista seguida de objetos y de una expresión boleana para determinar el estado de la lista. Una lista de seguimiento contiene uno o varios objetos. La expresión boleana habilita dos tipos de cálculos usando los operadores del  del € del orâ del œ del € del  o del â del € del andâ del œ del € del â. Por ejemplo, cuando usted configura el seguimiento para dos interfaces usando el operador del  del € del andâ del œ del € del â para arriba significa que ambas interfaces están para arriba, y abajo significa que cualquier interfaz está abajo.

Usted puede configurar un estado seguido de la lista que se medirá usando una ponderación o un umbral de porcentaje. Vea configurar una lista y una ponderación seguidas del umbral para seccionar y configurar una sección seguida de la lista y del porcentaje del umbral.

Antes de comenzar

Un objeto debe existir para poder ser añadido a una lista seguida.


Nota


Especifican para uno o más objetos y niega al operador del  del € del notâ del œ del € del â el estado del objeto.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. lista del pista-número de la pista boleana {y | o}

4. [not] del objeto-número del objeto

5. retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}

6. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
lista del pista-número de la pista boleana {y | o}


Ejemplo:

Lista de la pista 100 de Router(config)# boleana y

 

Configura un objeto de lista seguida e ingresa en el modo de configuración del seguimiento.

 
Paso 4
[not] del objeto-número del objeto


Ejemplo:

Router (config-pista) # objeto 3 no

 
Especifica el objeto que se seguirá.
  • el argumento del Theobject-número tiene un intervalo válido a partir de la 1 a 500. No existe configuración predeterminada. No la palabra clave opcional niega el estado del objeto.

Nota    El ejemplo significa que cuando el objeto 3 está para arriba, la lista seguida detecta el objeto 3 como abajo.
 
Paso 5
retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 3

 

(Opcional) Especifica una demora del seguimiento en segundos entre los estados activado y desactivado.

 
Paso 6
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Vuelve al modo EXEC privilegiado.

 

Configuración de una Lista de Seguimiento y de un Peso del Umbral

Realice esta tarea de configurar una lista de objetos seguidos, de especificar que la ponderación esté utilizada como el umbral, y de configurar una ponderación para cada uno de los objetos en la lista de objetos seguidos. Una lista de seguimiento contiene uno o varios objetos. El Rastreo de objetos aumentado utiliza una ponderación del umbral para determinar el estado de cada objeto comparando la ponderación total de todos los objetos que estén para arriba contra una ponderación del umbral para cada objeto.

Usted puede también configurar un estado seguido de la lista que se medirá usando un cálculo o un porcentaje del umbral boleano. Vea configurar una sección de la lista seguida y de la expresión boleana y configurar una sección seguida de la lista y del porcentaje del umbral.

Antes de comenzar

Un objeto debe existir para poder ser añadido a una lista seguida.


Nota


Usted no puede utilizar al operador boleano del  del € del notâ del œ del € del â en una ponderación o una lista del umbral de porcentaje.



PASOS SUMARIOS

1. permiso

2. configuró terminal

3. ponderación del umbral de la lista del pista-número de la pista

4. [weight weight-number] del objeto-número del objeto

5. ponderación del umbral {encima del número abajo numere | encima del número | abajo número}

6. retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
ponderación del umbral de la lista del pista-número de la pista


Ejemplo:

Ponderación del umbral de la lista de la pista 100 de Router(config)#

 

Configura un objeto de lista seguida e ingresa en el modo de configuración del seguimiento. Las palabras clave son las siguientes:

  • el ” del € del â del umbral especifica que el estado de la lista seguida está basado en un umbral.
  • el ” del € del â de la ponderación especifica que el umbral está basado en una ponderación especificada.
 
Paso 4
[weight weight-number] del objeto-número del objeto


Ejemplo:

Router (config-pista) # ponderación 30 del objeto 3

 

Especifica el objeto que se seguirá. El argumento object-number tiene un rango válido entre 1 y 500. No existe configuración predeterminada. La palabra clave opcional de la ponderación especifica una ponderación del umbral para cada objeto.

 
Paso 5
ponderación del umbral {encima del número abajo numere | encima del número | abajo número}


Ejemplo:

Router (config-pista) # ponderación del umbral encima de 30

 

Especifica la ponderación del umbral.

  • encima del intervalo válido del ” del € del â del número es a partir la 1 a 255.
  • abajo el rango del ” del € del numberâ depende de lo que usted selecciona para la palabra clave ascendente. Por ejemplo, si usted configura 25 para arriba, usted verá un rango a partir de la 0 a 24 para abajo.
 
Paso 6
retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 3

 

(Opcional) Especifica una demora del seguimiento en segundos entre los estados activado y desactivado.

 
Paso 7
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Vuelve al modo EXEC privilegiado.

 

Configuración de una Lista de Seguimiento y de un Porcentaje de Umbral

Realice esta tarea de configurar una lista seguida de objetos, de especificar que un porcentaje será utilizado como el umbral, y de especificar un porcentaje para cada objeto en la lista. Una lista de seguimiento contiene uno o varios objetos. El Rastreo de objetos aumentado utiliza el porcentaje del umbral para determinar el estado de la lista comparando el porcentaje asignado de cada objeto a la lista.

Usted puede también configurar un estado seguido de la lista que se medirá usando una ponderación boleana del cálculo o del umbral. Vea configurar una sección de la lista seguida y de la expresión boleana y configurar una sección seguida de la lista y de la ponderación del umbral.


Nota


Usted no puede utilizar al operador boleano del  del € del notâ del œ del € del â en una ponderación o una lista del umbral de porcentaje.


Antes de comenzar

Un objeto debe existir para poder ser añadido a una lista seguida.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. porcentaje del umbral de la lista del pista-número de la pista

4. objeto-número del objeto

5. porcentaje del umbral {encima del [down number] del número | abajo [up number] del número}

6. retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
porcentaje del umbral de la lista del pista-número de la pista


Ejemplo:

Porcentaje del umbral de la lista de la pista 100 de Router(config)#

 

Configura un objeto de lista seguida e ingresa en el modo de configuración del seguimiento. Las palabras clave son las siguientes:

  • el ” del € del â del umbral especifica que el estado de la lista seguida está basado en un umbral.
  • el ” del € del â del porcentaje especifica que el umbral está basado en un porcentaje.
 
Paso 4
objeto-número del objeto


Ejemplo:

Router (config-pista) # objeto 3

 

Especifica el objeto que se seguirá.

  • El argumento object-number tiene un rango válido entre 1 y 500. No existe configuración predeterminada.
 
Paso 5
porcentaje del umbral {encima del [down number] del número | abajo [up number] del número}


Ejemplo:

Router (config-pista) # porcentaje del umbral encima de 30

 

Especifica el porcentaje del umbral.

  • encima del intervalo válido del ” del € del numberâ es a partir la 1 a 100.
  • abajo el rango del ” del € del â del número depende de lo que usted ha seleccionado para la palabra clave ascendente. Por ejemplo, si usted especifica 25 como para arriba, un rango a partir del 26 a 100 se visualiza para abajo la palabra clave.
 
Paso 6
retardo {encima del [down seconds] de los segundos | del [up seconds] segundos abajo}


Ejemplo:

Router (config-pista) # retardo encima de 3

 

(Opcional) Especifica una demora del seguimiento en segundos entre los estados activado y desactivado.

 
Paso 7
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Vuelve al modo EXEC privilegiado.

 

Configurar los valores por defecto de la lista de la pista

Realice esta tarea de configurar un valor de retraso predeterminado para una lista seguida, un objeto predeterminado, y los parámetros predeterminados del umbral para una lista seguida.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. pista-número de la pista

4. valor por defecto {retardo | objeto-número del objeto | porcentaje del umbral}

5. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
pista-número de la pista


Ejemplo:

Pista 3 de Router(config)#

 

Enters que sigue al modo de configuración.

 
Paso 4
valor por defecto {retardo | objeto-número del objeto | porcentaje del umbral}


Ejemplo:

Router (config-pista) # retardo del valor por defecto

 

Especifica un valor de retraso predeterminado para una lista seguida, un objeto predeterminado, y los parámetros predeterminados del umbral para una lista seguida.

  • el ” del € del â del retardo invierte al retardo predeterminado.
  • el ” del € del objeto-numberâ del objeto especifica un objeto predeterminado para la lista de la pista. El intervalo válido es a partir la 1 a 1000.
  • el ” del € del percentageâ del umbral especifica un porcentaje del umbral predeterminado.
 
Paso 5
Finalizar


Ejemplo:

Router (config-pista) # extremo

 

Vuelve al modo EXEC privilegiado.

 

Configuración del Seguimiento para las Aplicaciones de Mobile IP

Realice esta tarea de configurar una lista seguida de objetos applicationes del IP móvil.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. Home Agent de la aplicación del pista-número de la pista

4. salida

5. pdsn de la aplicación del pista-número de la pista

6. salida

7. ggsn de la aplicación del pista-número de la pista

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
Home Agent de la aplicación del pista-número de la pista


Ejemplo:

Home Agent de la aplicación de la pista 100 de Router(config)#

 

(Opcional) sigue la presencia de tráfico del Home Agent en un router y ingresa el seguimiento del modo de configuración.

 
Paso 4
salida


Ejemplo:

Router (config-pista) # salida

 

Vuelve al modo de configuración global.

 
Paso 5
pdsn de la aplicación del pista-número de la pista


Ejemplo:

Pdsn de la aplicación de la pista 100 de Router(config)#

 

(Opcional) sigue la presencia de tráfico del Packet Data Serving Node (PDSN) en un router que sigue al modo de configuración.

 
Paso 6
salida


Ejemplo:

Router (config-pista) # salida

 

Vuelve al modo de configuración global.

 
Paso 7
ggsn de la aplicación del pista-número de la pista


Ejemplo:

Ggsn de la aplicación de la pista 100 de Router(config)#

 

(Opcional) sigue la presencia de tráfico del Gateway GPRS Support Node (GGSN) en un router que sigue al modo de configuración.

 
Paso 8
Finalizar


Ejemplo:

Router(config)# end

 

Vuelve al modo EXEC privilegiado.

 

Ejemplos de Configuración de Enhanced Object Tracking

Ejemplo: Line Protocol de la interfaz

En el siguiente ejemplo, el proceso de seguimiento se configura para seguir el estado del Line Protocol de la interfaz 1/0/0 del gigabitethernet. El HSRP en la interfaz 0/0/0 del gigabitethernet entonces se registra con el proceso de seguimiento que se informará cualquier cambio al estado del Line Protocol de la interfaz 1/0/0 del gigabitethernet. Si va el Line Protocol en la interfaz 1/0/0 del gigabitethernet abajo, la prioridad del grupo del HSRP es reducida por 10.

Configuración del router A

Router(config)# track 100 interface GigabitEthernet1/0/0 line-protocol
!
Router(config)# interface GigabitEthernet0/0/0
Router(config-if)# ip address 10.1.0.21 255.255.0.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.0.1
Router(config-if)# standby 1 priority 110
Router(config-if)# standby 1 track 100 decrement 10

Configuración del Router B

Router(config)# track 100 interface GigabitEthernet1/0/0 line-protocol
!
Router(config)# interface GigabitEthernet0/0/0
Router(config-if)# ip address 10.1.0.22 255.255.0.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.0.1
Router(config-if)# standby 1 priority 105
Router(config-if)# standby 1 track 100 decrement 10

Ejemplo: Routing IP de la interfaz

En el siguiente ejemplo, el proceso de seguimiento se configura para seguir la capacidad del Routing IP de la interfaz 1/0/0 del gigabitethernet. El HSRP en la interfaz 0/0/0 del gigabitethernet entonces se registra con el proceso de seguimiento que se informará cualquier cambio al estado del Routing IP de la interfaz 1/0/0 del gigabitethernet. Si va el estado del Routing IP en la interfaz 1/0/0 del gigabitethernet abajo, la prioridad del grupo del HSRP es reducida por 10.

Si las dos interfaces seriales están operativas, el router A será el router activo de HSRP porque tiene la prioridad más alta. Sin embargo, si el IP en la interfaz 1/0/0 del gigabitethernet en el router A falla, la prioridad del grupo del HSRP será reducida y el router B asumirá el control como el router activo, así manteniendo un servicio del gateway virtual predeterminado a los hosts en la subred de 10.1.0.0.

Vea la figura abajo para una topología de ejemplo.

Figura 1Topología para el soporte de IP Routing


Configuración del router A

Router(config)# track 100 interface GigabitEthernet1/0/0 ip routing
!
Router(config)# interface GigabitEthernet0/0/0
Router(config-if)# ip address 10.1.0.21 255.255.0.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.0.1
Router(config-if)# standby 1 priority 110
Router(config-if)# standby 1 track 100 decrement 10

Configuración del Router B

Router(config)# track 100 interface GigabitEthernet1/0/0 ip routing
!
Router(config)# interface GigabitEthernet0/0/0
Router(config-if)# ip address 10.1.0.22 255.255.0.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.0.1
Router(config-if)# standby 1 priority 105
Router(config-if)# standby 1 track 100 decrement 10

Ejemplo: Accesibilidad de la ruta de IP

En el siguiente ejemplo, el proceso de seguimiento se configura para seguir el accesibilidad de la ruta de IP 10.2.2.0/24:

Configuración del router A

Router(config)# track 100 ip route 10.2.2.0/24 reachability 
!
Router(config)# interface GigabitEthernet0/0/0 
Router(config-if)# ip address 10.1.1.21 255.255.255.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.1.1 
Router(config-if)# standby 1 priority 110 
Router(config-if)# standby 1 track 100 decrement 10 

Configuración del Router B

Router(config)# track 100 ip route 10.2.2.0/24 reachability
!
Router(config)# interface GigabitEthernet0/0/0 
Router(config-if)# ip address 10.1.1.22 255.255.255.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.1.1 
Router(config-if)# standby 1 priority 105
Router(config-if)# standby 1 track 100 decrement 10

Ejemplo: Umbral de la ruta de IP métrico

En el siguiente ejemplo, el proceso de seguimiento se configura para seguir el umbral métrico de la ruta de IP 10.2.2.0/24:

Configuración del router A

Router(config)# track 100 ip route 10.2.2.0/24 metric threshold
! 
Router(config)# interface GigabitEthernet0/0/0 
Router(config-if)# ip address 10.1.1.21 255.255.255.0
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.1.1 
Router(config-if)# standby 1 priority 110 
Router(config-if)# standby 1 track 100 decrement 10 

Configuración del Router B

Router(config)# track 100 ip route 10.2.2.0/24 metric threshold
! 
Router(config)# interface GigabitEthernet0/0/0 
Router(config-if)# ip address 10.1.1.22 255.255.255.0 
Router(config-if)# standby 1 preempt
Router(config-if)# standby 1 ip 10.1.1.1 
Router(config-if)# standby 1 priority 105 
Router(config-if)# standby 1 track 100 decrement 10

Ejemplo: Seguimiento del host IP IP SLA

Las demostraciones del siguiente ejemplo cómo configurar el host IP que sigue para la operación 1 IP SLA en las versiones del Cisco IOS antes del Cisco IOS Release 12.4(20)T, de 12.2(33)SXI1, y de 12.2(33)SRE:

Router(config)# ip sla 1
Router(config-ip-sla)# icmp-echo 10.51.12.4
Router(config-ip-sla-echo)# timeout 1000
Router(config-ip-sla-echo)# threshold 2
Router(config-ip-sla-echo)# frequency 3
Router(config-ip-sla-echo)# request-data-size 1400
Router(config-ip-sla-echo)# exit
Router(config)# ip sla schedule 1 start-time now life forever
Router(config-ip-sla)# track 2 rtr 1 state
Router(config-ip-sla)# exit
Router(config)# track 3 rtr 1 reachability
Router(config-track)# exit
Router(config)# interface ethernet0/1
Router(config-if)# ip address 10.21.0.4 255.255.0.0
Router(config-if)# no shutdown
Router(config-if)# standby 3 ip 10.21.0.10
Router(config-if)# standby 3 priority 120
Router(config-if)# standby 3 preempt
Router(config-if)# standby 3 track 2 decrement 10
Router(config-if)# standby 3 track 3 decrement 10

Las demostraciones del siguiente ejemplo cómo configurar el host IP que sigue para la operación 1 IP SLA en el Cisco IOS Release 12.4(20)T, 12.2(33)SXI1, 12.2(33)SRE, y posterior versiones:

Router(config)# ip sla 1
Router(config-ip-sla)# icmp-echo 10.51.12.4
Router(config-ip-sla-echo)# threshold 2
Router(config-ip-sla-echo)# timeout 1000
Router(config-ip-sla-echo)# frequency 3
Router(config-ip-sla-echo)# request-data-size 1400
Router(config-ip-sla-echo)# exit
Router(config)# ip sla schedule 1 start-time now life forever
Router(config)# track 2 ip sla 1 state
Router(config-track)# exit
Router(config)# track 3 ip sla 1 reachability
Router(config-track)# exit
Router(config)# interface ethernet0/1
Router(config-if)# ip address 10.21.0.4 255.255.0.0
Router(config-if)# no shutdown
Router(config-if)# standby 3 ip 10.21.0.10
Router(config-if)# standby 3 priority 120
Router(config-if)# standby 3 preempt
Router(config-if)# standby 3 track 2 decrement 10
Router(config-if)# standby 3 track 3 decrement 10

Ejemplo: Expresión boleana para una lista seguida

En el siguiente ejemplo, un objeto de la lista de la pista se configura para seguir dos interfaces del gigabitethernet cuando ambas interfaces son ascendentes y cuando cualquier interfaz está abajo:

Router(config)# track 1 interface GigabitEthernet2/0/0 line-protocol
Router(config)# track 2 interface GigabitEthernet2/1/0 line-protocol
Router(config-track)# exit
Router(config)# track 100 list boolean and
Router(config-track)# object 1
Router(config-track)# object 2

En el siguiente ejemplo, un objeto de la lista de la pista se configura para seguir dos interfaces del gigabitethernet cuando cualquier interfaz es ascendente y cuando ambas interfaces están abajo:

Router(config)# track 1 interface GigabitEthernet2/0/0 line-protocol
Router(config)# track 2 interface GigabitEthernet2/1/0 line-protocol
Router(config-track)# exit
Router(config)# track 101 list boolean or
Router(config-track)# object 1
Router(config-track)# object 2

El ejemplo de configuración siguiente muestra que la lista seguida 4 tiene dos objetos y un estado de objeto está negado (si la lista está para arriba, la lista detecta que el objeto 2 está abajo):

Router(config)# track 4 list boolean and
Router(config-track)# object 1
Router(config-track)# object 2 not

Ejemplo: Ponderación del umbral para una lista seguida

En el siguiente ejemplo, tres interfaces de GigabitEtherent en la lista seguida 100 se configuran con una ponderación del umbral de 20 por cada uno. Abajo el umbral se configura a 0 y el umbral ascendente se configura a 40:

Router(config)# track 1 interface GigabitEthernet2/0/0 line-protocol
Router(config)# track 2 interface GigabitEthernet2/1/0 line-protocol
Router(config)# track 3 interface GigabitEthernet2/2/0 line-protocol
Router(config-track)# exit
Router(config)# track 100 list threshold weight
Router(config-track)# object 1 weight 20
Router(config-track)# object 2 weight 20
Router(config-track)# object 3 weight 20
Router(config-track)# threshold weight  up 40 down 0

En el ejemplo anterior el objeto de la pista-lista va abajo de solamente cuando van las tres interfaces seriales abajo, y sube otra vez solamente cuando por lo menos dos interfaces están para arriba (porque 20 + 20 el >= 40). La ventaja de esta configuración es que evita que suba el objeto de la pista-lista si dos interfaces están abajo y la tercera interfaz está agitando.

El ejemplo de configuración siguiente muestra que si el objeto 1 y el objeto 2 están abajo, después la lista 4 de la pista está para arriba, porque el objeto 3 satisface el valor de umbral ascendente de 30 ascendentes. Pero, si el objeto 3 está abajo, ambos objetos 1 y 2 necesite estar para arriba para satisfacer la ponderación del umbral.

Router(config)# track 4 list threshold weight
Router(config-track)# object 1 weight 15
Router(config-track)# object 2 weight 20
Router(config-track)# object 3 weight 30
Router(config-track)# threshold weight up 30 down 10

Esta configuración puede serle útil si usted hace dos pequeñas conexiones de ancho de banda (representar por la conexión de ancho de banda grande del objeto 1 y 2) y una (representada por el objeto 3). También el valor del plumón 10 significa que una vez que el objeto seguido está para arriba, no irá abajo hasta que el valor de umbral sea más bajo o igual a 10, que en este ejemplo significa que todas las conexiones están abajo.

Ejemplo: Porcentaje del umbral para una lista seguida

En el siguiente ejemplo, cuatro interfaces del gigabitethernet en la lista 100 de la pista se configuran para un porcentaje del umbral ascendente de 75. La lista de la pista está para arriba cuando el 75 por ciento de las interfaces está arriba y abajo de cuando el más poco de 75 por ciento de las interfaces está para arriba.

Router(config)# track 1 interface GigabitEthernet2/0/0 line-protocol
Router(config)# track 2 interface GigabitEthernet2/1/0 line-protocol
Router(config)# track 3 interface GigabitEthernet2/2/0 line-protocol
Router(config)# track 4 interface GigabitEthernet2/3/0 line-protocol
Router(config-track)# exit
Router(config)# track 100 list threshold percentage
Router(config-track)# object 1
Router(config-track)# object 2
Router(config-track)# object 3
Router(config-track)# object 4
Router(config-track)# threshold percentage up 75

Seguimiento de la aplicación del IP móvil del ejemplo

El siguiente ejemplo muestra cómo configurar el EOT para seguir el tráfico del IP móvil, GGSN, y PDSN en un router:

Router(config)# track 1 application home-agent
Router(config-track)# exit
Router(config)# track 2 application ggsn
Router(config-track)# exit
Router(config)# track 3 application pdsn

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Embedded Event Manager

Descripción General de Embedded Event Manager

Conceptos y tareas de configuración del HSRP

Configuración de HSRP

Conceptos y tareas de configuración GLBP

Configurar GLBP

Comandos IP SLA

Referencia de Comandos de IP SLAs de Cisco IOS

Conceptos y tareas de configuración VRRP

Configurar el VRRP

Comandos GLBP, del HSRP, y VRRP

Referencia de Comandos de IP Application Services de Cisco IOS

Estándares

Estándares

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

” del € del â

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.

” del € del â

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información sobre la Función Enhanced Object Tracking

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Cuadro 3Información sobre la Función Enhanced Object Tracking

Nombre de la función

Versiones

Información de la Configuración de la Función

Enhanced Tracking Support

Cisco IOS XE 3.1.0SG 12.2(15)T 12.2(25)S 12.2(28)SB 12.2(33)SRA 12.2(33)SXH

La función Enhanced Tracking Support separa el mecanismo de seguimiento del HSRP y crea un proceso de seguimiento autónomo separado que pueden utilizar otros procesos de Cisco IOS así como el HSRP. Esta función permite el seguimiento de otros objetos además del estado del protocolo de línea de la interfaz.

Los siguientes comandos fueron introducidos o modificados por esta característica: haga el debug de la pista, retrase el seguir, IP VRF, de la pista de la demostración, pista espera, umbral métrico, interfaz de la pista, ruta de IP de la pista, temporizador de la pista.

FHRP--Integración aumentada del Rastreo de objetos con el administrador del evento integrado

12.2(33)SRB 12.2(33)SXI 12.4(2)T

El EOT ahora se integra con el EEM para permitir que éste informe sobre un cambio de estado de un objeto y para permitir que el EOT realice un seguimiento de los objetos del EEM.

Los siguientes comandos fueron introducidos o modificados por esta característica: pista de la acción leída, conjunto de la pista de la acción, valor por defecto-estado, recurso del evento, evento rf, pista del evento, pista de la demostración, stub de la pista.

FHRP--Rastreo de objetos aumentado de las operaciones IP SLA

Cisco IOS XE 3.1.0SG 12.2(25)S 12.2(27)SBC 12.2(33)SRA 12.2(33)SXH 12.3(4)T 15.0(1)S

Esta característica permite a los primeros protocolos de la redundancia de salto (FHRPs) y a otro los clientes aumentados del Rastreo de objetos (EOT) para seguir la salida de los objetos IP SLA y para utilizar la información proporcionada para accionar una acción.

El siguiente comando fue introducido por esta característica: rtr de la pista.

FHRP--Soporte aumentado del Rastreo de objetos para el IP móvil

12.4(11)T

El FHRP--El soporte aumentado del Rastreo de objetos para la característica del IP móvil proporciona los nuevos objetos de seguimiento necesarios por las aplicaciones de la Tecnología inalámbrica móvil para seguir la presencia de tráfico del Home Agent, GGSN, o PDSN en un router.

El siguiente comando fue introducido por esta característica: aplicación de la pista.

FHRP--Deprecación EOT de la palabra clave del rtr

12.2(33)SRE 12.2(33)SXI1 12.4(20)T

Esta característica substituye el comando rtr de la pista por el comando del sla del IP de la pista.

El siguiente comando fue introducido por esta característica: sla del IP de la pista.

FHRP--Lista del Rastreo de objetos

Cisco IOS XE 3.1.0SG 12.2(30)S 12.2(31)SB2 12.2(33)SRA 12.2(33)SXH 12.3(8)T 15.0(1)S

Esta función mejora las capacidades de seguimiento para permitir la configuración de una combinación de objetos de seguimiento en una lista y un método flexible para combinar objetos con lógica booleana.

Los siguientes comandos fueron introducidos o modificados por esta característica: muestre la pista, porcentaje del umbral, ponderación del umbral, lista de la pista, resolución de la pista.

Soporte de EOT para Demora de Portadora

12.4(9)T

La función EOT Support for Carrier Delay permite al Seguimiento de Objetos Mejorado (EOT) considerar el temporizador de demora de la portadora cuando se realiza el seguimiento del estado de una interfaz.

Los siguientes comandos fueron introducidos o modificados por esta característica: portador-retardo (seguimiento), pista de la demostración.

Glosario

Protocolo DHCP del ” del € de DHCPâ. El DHCP es un protocolo que entrega los IP Addresses y la información de la configuración a los clientes de red.

Gateway GPRS Support Node del ” del € de GGSNâ. Un gateway inalámbrico que permite que los usuarios móviles del teléfono celular accedan la Red de datos públicos (PDN) o las redes de IP privado especificadas. La función GGSN se implementa en los routeres Cisco.

Protocolo del Equilibrio de carga del gateway del ” del € de GLBPâ. Proporciona el respaldo automático del router para los hosts IP que se configuran con un solo default gateway en un IEEE 802,3 LAN. Varios routers de primer salto de la LAN se combinan para ofrecer un solo router IP de primer salto virtual al tiempo que se comparte la carga de reenvío de paquetes IP. El otro Routers en el LAN puede actuar como Routers redundante (GLBP) que haga activo si los routeres de reenvío existentes uces de los fallan.

General Packet Radio Service del ” del € de GPRSâ. Una tecnología de comunicaciones por teléfono móvil 2.5G que permite a los proveedores de servicio de la Tecnología inalámbrica móvil para ofrecer a sus suscriptores móviles con los servicios de datos del paquete basado sobre las redes GSM.

Sistema global del ” del € del networkâ GS para la red de las comunicaciones por teléfono móvil. Una tecnología celular digital que se utiliza por todo el mundo, predominante en Europa y Asia. El GS es el estándar principal del ™ s del € del worldâ en las comunicaciones de red inalámbrica digitales.

El ” casero del € de Agentâ un Home Agent es un router en la red doméstica del nodo móvil (manganeso) que mantiene una asociación entre la dirección IP casera del manganeso y su cuidado-del direccionamiento, que es la ubicación actual del manganeso en una red no nativa o visitada. El HA reorienta los paquetes haciéndolos un túnel al manganeso mientras que está lejos de la red doméstica.

Protocolo del router de la espera en caliente del ” del € de HSRPâ. Proporciona la gran disponibilidad de red y los cambios de la topología de red transparentes. El HSRP crea un grupo de routers de la espera en caliente con un router del lead que mantenga todos los paquetes enviados al direccionamiento de la espera en caliente. Al otro Routers en el grupo monitorea al router del lead, y si falla, uno de estos routeres en espera hereda la posición del lead y el grupo de dirección de la espera en caliente.

IP Control Protocol del ” del € de IPCPâ. El protocolo utilizado para establecer y configurar IP sobre PPP.

Link Control Protocol del ” del € de LCPâ. El protocolo usado para establecer, para configurar, y para probar las conexiones de link de datos para uso del PPP.

Packet Data Serving Node del ” del € de PDSNâ. Cisco PDSN es un cumple con las normas, el gateway inalámbrico que habilita los servicios de datos del paquete en un entorno del acceso del múltiplex de la división de códigos (CDMA). Actuando como gateway de acceso, Cisco PDSN proporciona el acceso simple IP y del IP móvil, el soporte del agente extranjero, y el transporte del paquete para el Redes Privadas Virtuales (VPN).

Protocolo Point-to-Point del ” del € de PPPâ. Proporciona conexiones de router a router y de host a red a través de circuitos síncronos y asíncronos. En la mayoría de los casos, PPP se utiliza para el acceso de marcado telefónico a Internet. Sus funciones incluyen la notificación de la dirección, autenticación vía CHAP o PAP, soporte para varios protocolos y monitoreo de links.

Caso del VPN Routing and Forwarding del ” del € de VRFâ. Un VRF consta de una tabla de IP Routing, una tabla de reenvío derivada, un conjunto de interfaces que utiliza la tabla de reenvío y un conjunto de reglas y protocolos de ruteo que determina qué incluye la tabla de reenvío. Un VRF incluye generalmente la información de ruteo que define un sitio del cliente VPN que se asocie a un router de borde del proveedor.

Protocolo Virtual Router Redundancy del ” del € de VRRPâ. Elimina el solo punto de falla inherente en el entorno ruteado del estático predeterminado. El VRRP especifica un protocolo de elección que asigne dinámicamente la responsabilidad de un router virtual a uno del Routers VRRP en un LAN. Llaman el router VRRP que controla los IP Addresses asociados a un router virtual el master, y adelante los paquetes enviados a estos IP Addresses. El proceso de elección proporciona la Conmutación por falla dinámica en la responsabilidad de la expedición si el master llega a ser inasequible. Los IP Address de router virtual uces de los en un LAN se pueden entonces utilizar como el router de primer salto predeterminado por los host extremos.

Cisco y el logotipo de Cisco son marcas registradas del Cisco Systems, Inc. y/o de sus afiliados en los E.E.U.U. y otros países. Un anuncio de las marcas registradas de Cisco se puede encontrar en www.cisco.com/go/trademarks. Las marcas registradas del otro vendedor mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1005R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

1 RIP se escala directamente al rango a partir de la 0 a 255 porque su métrico máximo es menos de 255.