Guía de configuración del Asynchronous Transfer Mode, Cisco IOS Release 12.2SR
Configuración de LAN Emulation
18 Febrero 2013 - Traducción Automática | Otras Versiones: PDFpdf 374 KB | Inglés (6 Diciembre 2011) | Comentarios

Contenido

Configuración de LAN Emulation

Última actualización: Mayo 22, 2012

Este capítulo describe cómo configurar el LAN Emulation (LANE) en las plataformas siguientes que están conectadas con una nube del switch ATM o del Switch:

  • Procesador de interfaz ATM (AIP) en los Cisco 7500 Series Router
  • Adaptador de puerto ATM en las Cisco 7200 Series y los Cisco 7500 Series Router
  • Módulo del procesador de red (NPM) en el Cisco4500 y los Cisco 4700 Router

Nota


Empezando por el Cisco IOS Release 11.3, soportan a los comandos all soportados en los Cisco 7500 Series Router también en las Cisco 7000 Series.

Para obtener una descripción completa de los comandos de este capítulo, refiérase a la Referencia de Comandos de Servicios de Cisco IOS Switching. Para encontrar documentación de otros comandos que aparecen en este capítulo, utilice el índice principal de referencia de comandos, o busque en línea.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

LANE en la atmósfera

El LANE emula a un IEEE 802,3 Ethernet o el Token Ring LANE IEEE802.5 usando la tecnología ATM. El LANE proporciona una interfaz del servicio para los protocolos de capa de red que sea idéntica a las capas MAC existentes. No se requiere ningunos cambios a los protocolos de la capa superiores y a las aplicaciones existentes. Con el LANE, los paquetes de la Ethernet y del Token Ring se encapsulan en las células ATM apropiadas y se envían a través de la red ATM. Cuando los paquetes alcanzan el otro lado de la red ATM, deencapsulated. El LANE esencialmente interliga el tráfico de LAN a través de los switches ATM.

Ventajas del LANE

La atmósfera es una célula-transferencia y tecnología de la multiplexación diseñada para combinar las ventajas del Switching de circuito (el retraso de la transmisión constante y garantizó la capacidad) con las del packet switching (flexibilidad y eficacia para el tráfico intermitente).

El LANE permite que los usuarios de la Ethernet y del Token Ring LANE de la herencia se aprovechen de las ventajas atmósfera sin el soporte físico o el software de modificación de la estación final. La atmósfera utiliza el servicio orientado a la conexión con la señalización de punto a punto o el multicast que señala entre el dispositivo de origen y de destino. Sin embargo, los LAN utilizan el Servicio sin conexión. Los mensajes se transmiten a todos los dispositivos en la red. Con el LANE, los routers y los switches emulan al Servicio sin conexión de un LAN para los endstations.

Usando el LANE, usted puede escalar sus redes a tamaños más grandes mientras que preserva su inversión en tecnología LAN.

Componentes de LANE

Un solo LAN emulada (ELAN) consiste en las entidades siguientes: Un LECS, un BUS, un LES, y clientes LANE.

  • Servidor de configuración LANE--Un servidor que asigna a los clientes individuales a los LAN emulados determinados dirigiéndolos al LES para el ELAN. El (LECs) del servidor de configuración LANE mantiene una base de datos de la atmósfera del cliente LANE y del servidor o de las direcciones MAC y de sus LAN emulados. Un LECS puede servir los LAN emulados múltiples.
  • Broadcast y servidor desconocidos LANE--Un servidor de multidifusión que inunda el tráfico del destino desconocido y adelante multicast y tráfico de broadcast a los clientes dentro de un ELAN. Un broadcast y servidor desconocidos (BUS) existe por el ELAN.
  • Servidor lane--Un servidor que proporciona un recurso del registro para que los clientes se unan al ELAN. Hay un servidor lane (LES) por el ELAN. El protocolo lan emulation address resolution de las manijas LES (LE ARP) pide y mantiene una lista de direcciones MAC del Destino del LAN. Para el LANE de Token Ring, el LES también mantiene una lista de descriptores de Route que se utilice para soportar el (SRB) del Source-Route Bridging sobre el ELAN. Utilizan a los descriptores de Route para determinar el ATM Address del salto siguiente en el (RIF) del campo routing information.
  • Cliente LANE--Una entidad en un punto final, tal como un router, que realiza el reenvío de datos, el address resolution, y otras funciones de control para un solo punto final en un solo ELAN. El (LEC) del cliente LANE proporciona el servicio LAN estándar a cualquier capa superior que interconecte con él. Un router puede tener los clientes LANE residentes múltiples, cada uno que conecta con diversos LAN emulados. El cliente LANE registra su MAC y ATM Address con el LES.

Las entidades ELAN coexisten en uno o más routeres Cisco. En los routeres Cisco, el LES y el BUS se combinan en una sola entidad.

Otros componentes de LANE incluyen los switches ATM--cualquier switch ATM que soporte la interfaz de administración local interina (ILMI) y la señalización. Los LAN emulados múltiples pueden coexistir en una sola red ATM.

Redundancia del servidor simple

El LANE confía en tres servidores: el LECS, el LES, y el BUS. Si de estos servidores falla, el ELAN no puede funcionar completamente.

Cisco ha desarrollado un mecanismo de la tolerancia de fallas conocido como redundancia del servidor simple que elimina estos solos puntos de falla. Aunque este esquema sea propio, no se ha hecho ninguna nueva adición de protocolos a los subsistemas LANE.

La redundancia del servidor simple utiliza los LECS múltiples y transmitir-y-desconocido múltiple y menos. Usted puede configurar los servidores como servidores de backup, que llegarán a ser activos si un servidor principal falla. Los niveles de prioridad para los servidores determinan que los servidores tienen precedencia.

Refiera “configurando a la sección de la operación tolerante a fallas” para los detalles y las notas sobre el protocolo simple server redundancy (SSRP).

Consideraciones sobre la Implementación de LANE

Soporte de la red

En esta versión, Cisco soporta las características siguientes del establecimiento de una red:

  • LAN emulado a Ethernet
    • Encaminamiento a partir de un ELAN a otro vía el IP, el IPX, o el AppleTalk
    • Bridging entre los LAN emulados y entre los LAN emulados y otros LAN
    • DECnet, Vine Banyan, y protocolos ruteados XNS
  • LAN emulados del token ring
    • IP Routing (conmutado rápido) entre los LAN emulados y entre un Token Ring ELAN y una herencia LAN
    • IPX Routing entre los LAN emulados y entre un Token Ring ELAN y una herencia LAN
    • Cuadripolo y multiport SRB (conmutado rápido) entre los LAN emulados y entre los LAN emulados y un Token Ring
    • IP y IPX multiring
    • SRB, Source-Route Translational Bridging (SR/TLB), y Source-Route Transparent Bridging (SRT)
    • El AppleTalk para (IOS) TR-LANE e incluye la encaminamiento rápidamente conmutada de Appletalk.
    • El DECnet, los Vine Banyan, y los protocolos XNS no se soportan

La implementación de Cisco del LAN Emulation sobre la terminología existente de 802,5 aplicaciones y de la opción de configuración para los Token Rings, incluyendo el SRB. Para más información sobre configurar el SRB, vea el capítulo el “configurar del Source-Route Bridging” en el Cisco IOS que interliga y la guía de configuración del IBM Networking. El Transparent Bridging y la interconexión de redes peer-to-peer avanzada (APPN) no se soportan ahora.

  • Hot Standby Router Protocol (HSRP)

Para la información sobre configurar el APPN sobre el LANE Ethernet, refiera “configurando al capítulo APPN” en el Cisco IOS que interliga y la guía de configuración del IBM Networking.

Soporte de Hardware

Esta versión del LANE se soporta en las plataformas siguientes:

  • Cisco 4500-M, Cisco 4700-M
  • Cisco 7200 Series
  • Cisco 7500 Series

Nota


Empezando por el Cisco IOS Release 11.3, soportan a los comandos all soportados en los Cisco 7500 Series Router también en los Cisco 7000 Series Router equipados del RSP7000. El Token Ring LAN Emulation en los Cisco 7000 Series Router requiere la actualización RSP7000. La actualización RSP7000 requiere un mínimo del 24 MB DRAM y de memoria flash del 8 MB.

El router debe contener un procesador de interfaz ATM (AIP), el adaptador de puerto ATM, o un módulo NP-1A procesador de red ATM (NPM). Estos módulos proporcionan interfaz de red de ATM para los routers. Las interfaces de la red residen en los procesadores de la interfaz modular, que proporcionan una conexión directa entre el bus ampliado Cisco de alta velocidad (CxBus) y las redes externas. El número máximo de AIP, de adaptadores de puerto ATM, o de NPM que los soportes para router dependen del ancho de banda configurado. El ancho de banda total con todos los AIP, adaptadores de puerto ATM, o NPM en el sistema se debe limitar al duplex del 200 Mbps por completo ---dos transmisores asíncronos transparentes/interfaces receptor (taxis), un Synchronous Optical Network (SONET) y un E3, o un SONET y un SONET ligeramente usado.

Esta característica también requiere uno de los switches siguientes:

  • Cisco lightstream 1010 (recomendado)
  • Cisco Lightstream 100
  • Cualquier switch ATM con el soporte UNI 3.0/3.1 y del ILMI para comunicar el direccionamiento LECS

TR-LANE requiere el Cisco IOS Release 3.1(2) o después el Switch del Lightstream 100 y el Cisco IOS Release 11.1(8) o después el LightStream1010.

Para una descripción completa de los routers, los switches, y las interfaces, refieren a su documentación sobre hardware.

Dirección

En un LAN, los paquetes alocución por la dirección de capa MAC del destino y de las estaciones de origen. Para proporcionar las funciones similares para el LANE, la dirección de la Capa MAC debe ser soportada. Cada cliente LANE debe tener una dirección MAC. Además, cada componente de LANE (servidor, cliente, BUS, y LECS) debe tener un ATM Address que sea diferente del del resto de componentes.

Todos los clientes LANE en la misma interfaz tienen lo mismo, asignado automáticamente la dirección MAC. Esa dirección MAC también se utiliza como la parte del identificador del sistema extremo (ESI) el ATM Address, como se explica en la siguiente sección. Aunque los MAC Address del cliente no sean únicos, todos los ATM Address son únicos.

ATM Address LANE

Un ATM Address LANE tiene el mismo sintaxis que un NSAP, pero no es un direccionamiento del nivel de red. Consiste en el siguiente:

  • Un prefijo 13-byte que incluye los campos siguientes definió por el foro ATM:
    • Campo AFI (identificador de autoridad y de formato) (1 byte)
    • Campo DCC (Código del país de los datos) o ICD (designador de códigos internacionales) (2 bytes)
    • Campo de DFI (identificador de formato de la parte específica del dominio) (1 byte)
    • Campo de las autoridades administrativas (3 bytes)
    • Campo reservado (2 bytes)
    • Campo del dominio de ruteo (2 bytes)
    • Campo de área (2 bytes)
  • Un identificador del sistema extremo 6-byte (ESI)
  • Un campo del selector 1-byte

Método automáticamente de asignar los ATM Address

Proporcionamos el método estándar siguiente de construir y de asignar la atmósfera y las direcciones MAC para el uso en la base de datos LECS. Un pool de las direcciones MAC se asigna a cada interfaz ATM en el router. En los Cisco 7200 Series Router, los Cisco 7500 Series Router, los Cisco 4500 Router, y los Cisco 4700 Router, el pool contienen ocho direcciones MAC. Para construir los ATM Address, las asignaciones siguientes se hacen a los componentes de LANE:

  • Los campos de prefijo son lo mismo para todos los componentes de LANE en el router; el prefijo indica la identidad del Switch. El valor del prefijo se debe configurar en el Switch.
  • El valor de campo ESI asignado a cada cliente en la interfaz es el primer del pool de las direcciones MAC asignadas a la interfaz.
  • El valor de campo ESI asignado a cada servidor en la interfaz es el segundo del pool de las direcciones MAC.
  • El valor de campo ESI asignado al servicio transmitir-y-desconocido r en la interfaz es el tercero del pool de las direcciones MAC.
  • El valor de campo ESI asignado al servidor de configuración es el cuarto del pool de las direcciones MAC.
  • El valor de campo del selector se fija al número de la subinterfaz del componente de LANE--a excepción del LECS, que tiene un valor de campo del selector de 0.

Porque los componentes de LANE se definen en las subinterfaces diferentes de una interfaz ATM, el valor del campo del selector en un ATM Address es diferente para cada componente. El resultado es un ATM Address único para cada componente de LANE, incluso dentro del mismo router. Para más información sobre la asignación de los componentes a las subinterfaces, vea las “reglas para asignar los componentes a las interfaces y subinterfaz” para seccionar más adelante en este capítulo.

Por ejemplo, si las direcciones MAC asignadas a una interfaz son 0800.200C.1000 con 0800.200C.1007, la parte de ESI los ATM Address se asigna a los componentes de LANE como sigue:

  • Cualquier cliente consigue el ESI 0800.200c.1000.
  • Cualquier servidor consigue el ESI 0800.200c.1001.
  • El BUS consigue el ESI 0800.200c.1002.
  • El LECS consigue el ESI 0800.200c.1003.

Refiera el “Token Ring múltiple ELAN con al ejemplo sin restricción de la calidad de miembro” y el “Token Ring múltiple ELAN con a las secciones del ejemplo restricto de la calidad de miembro” por los ejemplos usando los valores de la dirección MAC como valores de campo ESI en los ATM Address y por los ejemplos usando los números de la subinterfaz como valores de campo del selector en los ATM Address.

Usando las plantillas del ATM Address

Las plantillas del ATM Address se pueden utilizar en muchos comandos lane que asignen los ATM Address a los componentes de LANE (así reemplazando los ATM Address automáticamente asignados) o que conecten los ATM Address del cliente a los LAN emulados. El uso de las plantillas puede simplificar grandemente el uso de estos comandos. El sintaxis de las plantillas de dirección, el uso de las plantillas de dirección, y el uso de los caracteres comodín dentro de una plantilla de dirección para el LANE son muy similares a ésos para las plantillas de dirección de ISO CLNS.


Nota


Los ATM Address E.164-format no soportan el uso de las plantillas del ATM Address LANE.

Las plantillas del ATM Address LANE pueden utilizar dos tipos de comodines: un asterisco (*) para hacer juego cualquier solo carácter, y puntos de suspensión (...) para hacer juego cualquier número de caracteres principales o que se arrastran.

En el LANE, una plantilla del prefijo hace juego explícitamente a los comodines del prefijo pero de las aplicaciones para los campos ESI y del selector. Una plantilla ESI hace juego explícitamente el campo ESI pero a los comodines de las aplicaciones para el prefijo y el selector. La tabla abajo indica cómo los valores de los dígitos sin especificar se determinan cuando plantilla de dirección ATM se utiliza:

Tabla 1Valores de los dígitos sin especificar en las plantillas del ATM Address

Dígitos sin especificar adentro

El valor es

Prefijo (primeros 13 bytes)

Obtenido del switch ATM vía la interfaz de administración local interina (ILMI)

ESI (después 6 bytes)

Llenado de la dirección MAC1 del slot más

  • cliente 0--LANE
  • 1--LES
  • BUS 2--LANE
  • 3--LECS

Campo del selector (último 1 byte)

Número de la subinterfaz, en el rango 0 a 255.

1 el más bajo del pool de las direcciones MAC asignadas a la interfaz ATM más un valor que indica el componente de LANE. Para los Cisco 7200 Series Router, los Cisco 7500 Series Router, los Cisco 4500 Router, y los Cisco 4700 Router, el pool tienen ocho direcciones MAC.

Reglas para Asignar los Componentes a las Interfaces y Subinterfaces

Las reglas siguientes se aplican a asignar los componentes de LANE a la interfaz ATM principal y sus subinterfaces en un router dado:

  • El LECS se ejecuta siempre en la interfaz principal.

La asignación de cualquier otro componente a la interfaz principal es idéntica a asignar ese componente a las 0 subinterfaces.

  • El servidor y el cliente del mismo ELAN se pueden configurar en la misma subinterfaz en un router.
  • Los clientes de dos diversos LAN emulados no pueden ser configurados en la misma subinterfaz en un router.
  • Los servidores de dos diversos LAN emulados no se pueden configurar en la misma subinterfaz en un router.

Lista de tareas de configuración LANE

Antes de que usted comience a configurar el LANE, usted debe decidir si usted quiere configurar uno o los LAN emulados múltiples. Si usted configura los LAN emulados múltiples, usted debe también decidir donde localizarán los servidores y a los clientes, y si restringir a los clientes que pueden pertenecer a cada ELAN. Los LAN emulados interligados se configuran apenas como cualquier otro LAN, en términos de comandos y salidas. Una vez que usted ha tomado esas decisiones básicas, usted puede proceder a configurar el LANE.

Una vez que se configura el LANE, usted puede configurar el multiprotocolo sobre ATM (MPOA). Para que el MPOA trabaje con el LANE, un cliente LANE debe tener un ELAN ID a trabajar correctamente, un cliente LANE debe tener un ELAN ID. Configurar a un cliente LANE para el MPOA y dar un ELAN ID realizan las tareas descritas en la sección siguiente:

Aunque las secciones descritas contengan la información sobre configurar la tolerancia de fallas SSRP, refiera a la sección tolerante a fallas de la operación que configura para información detallada sobre los requisitos y las consideraciones de instrumentación.

Una vez que se configura el LANE, usted puede monitorear y mantener los componentes en los routeres participantes completando las tareas descritas en la supervisión y manteniendo la sección de los componentes de LANE.

Para los ejemplos de configuración, vea “la sección de los ejemplos de configuración LANE” en el final de este capítulo.

Creación de un Plano y una Hoja de Trabajo LANE

Elabore un plan y una hoja de trabajo para su propio escenario LANE, mostrando la siguiente información y dejando el espacio para observar el ATM Address de cada uno de los componentes de LANE en cada subinterfaz de cada router participante:

  • El router y la interfaz donde el LECS será localizado.
  • El router, la interfaz, y la subinterfaz donde el LES y el BUS para cada ELAN serán localizados. Puede haber servidores múltiples para cada ELAN para la operación incidente-tolerante.
  • Los routers, las interfaces, y las subinterfaces donde localizarán a los clientes para cada ELAN.
  • El nombre del valor por defecto ELAN (opcional).
  • Los nombres de los LAN emulados que tendrán calidad de miembro sin restricción.
  • Los nombres de los LAN emulados que habrán restringido la calidad de miembro.

Los tres elementos más recientes de esta lista son muy importantes; determinan cómo usted configura cada ELAN en la base de datos LECS.

Configuración del Prefijo en el Switch

Antes de que usted configure los componentes de LANE en cualquier Cisco 7200 Series Router, Cisco 7500 Series Router, Cisco 4500 Router, o Cisco 4700 Router, usted debe configurar el Cisco ATM Switch con el prefijo del ATM Address que se utilizará por todos los componentes de LANE en la nube del Switch. En el switch Cisco, el prefijo del ATM Address se llama los prefijos identificación del nodo debe ser 26 dígitos largos. Si usted proporciona más poco de 26 dígitos, los ceros se agregan a la derecha del valor especificado para llenarlo a 26 dígitos.

En los switches, usted puede visualizar el prefijo actual usando el comando exec de la red de la demostración.


Nota


Si usted no salva el valor configurado permanentemente, será perdido cuando el Switch se reajusta o se acciona apagado.

Para fijar el prefijo del ATM Address en el Cisco lightstream 1010 o en el 100 Switch del Cisco Lightstream, siga los siguientes pasos:

PASOS SUMARIOS

1. ATM-direccionamiento de Router(config)# {ATM-direccionamiento | prefijo}

2. Salida de Router(config)#

3. Sistema de la copia del Router-: running-config nvram: startup-config

4. El router (config-route-map) # fijó el prefijo de la máscara del localnameip-direccionamiento

5. Router (config-route-map) # salvaguardia


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
ATM-direccionamiento de Router(config)# {ATM-direccionamiento | prefijo} 

(Switch del Cisco lightstream 1010) fija el nodo local ID (el prefijo del ATM Address).

 
Paso 2
Salida de Router(config)# 

(Modo de configuración global de las salidas del Switch del Cisco lightstream 1010).

 
Paso 3
Sistema de la copia del Router-: running-config nvram: startup-config 

(Switch del Cisco lightstream 1010) guarda los valores de configuración permanentemente.

 
Paso 4
El router (config-route-map) # fijó el prefijo de la máscara del localnameip-direccionamiento 

(Cisco Lightstream 100) fija el nodo local ID (prefijo del ATM Address).

 
Paso 5
Router (config-route-map) # salvaguardia 

(Cisco Lightstream 100) guarda los valores de configuración permanentemente.

 

Configuración de PVCs de Señalización e ILMI

Usted debe configurar el circuito virtual permanente (PVC) de señalización y el PVC que comunicarán con el ILMI en la interfaz ATM principal de cualquier router que participe en el LANE.

Complete esta tarea solamente una vez para una interfaz importante. Usted no necesita relanzar esta tarea en la misma interfaz aunque usted puede ser que configure menos y a los clientes en varias de sus subinterfaces.

Para configurar estos PVC, utilice los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1.   

2. Router (config-if) # qsaal del vci del vpi del pvcvcd ATM

3. Router (config-if) # ilmi del vci del vpi del pvcvcd ATM


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1



Ejemplo:

Router (config-if) # slot /0 de la interfaz ATM



Ejemplo:

Router (config-if) # slot/puerto-ADAPTER /0 de la interfaz ATM



Ejemplo:

Router (config-if) # número de la interfaz ATM

 

Especifica la interfaz ATM principal y ingresa al modo de configuración de la interfaz:

  • En el AIP para Cisco 7500 Series Routers; en el adaptador de puerto ATM para los Cisco 7200 Series Router.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
 
Paso 2
Router (config-if) # qsaal del vci del vpi del pvcvcd ATM 

Configura PVC de señalización que configura y derriba los circuitos virtuales conmutados (SVC); el vpi y los valores VCI se fijan generalmente a 0 y a 5, respectivamente.

 
Paso 3
Router (config-if) # ilmi del vci del vpi del pvcvcd ATM 

Configura un PVC para comunicar con el ILMI; el vpi y los valores VCI se fijan generalmente a 0 y a 16, respectivamente.

 

Visualización de las Direcciones de LANE Predeterminadas

Usted puede visualizar los direccionamientos del lane predeterminada para hacer la configuración más fácil. Complete esta tarea para cada router que participe en el LANE. Este comando visualiza a las direcciones predeterminadas para todas las interfaces ATM presentes en el router. Anote los direccionamientos visualizados en su hoja de trabajo.

Para visualizar los direccionamientos del valor por defecto LANE, utilice el siguiente comando en el modo EXEC:

Comando

Propósito

Router# show lane default-atm-addresses

Visualiza los direccionamientos del lane predeterminada.

Ingresar el ATM Address LECS en el switch Cisco

Usted debe ingresar el ATM Address LECS en el Cisco Lightstream 100 o el switch ATM del Cisco lightstream 1010 y salvarlo permanentemente para no perder el valor cuando el Switch se reajusta o se acciona apagado.

Usted debe especificar el ATM Address completo 40-digit. Utilice los direccionamientos en su hoja de trabajo que usted obtuvo de la tarea anterior.

Si usted está configurando SSRP o el protocolo fast simple server redundancy (FSSRP), ingrese los direccionamientos múltiples LECS en los switches ATM del extremo. Los switches se utilizan como las ubicaciones centrales para la lista de direccionamientos LECS. Los componentes de LANE conectados con los switches obtienen la lista global de direccionamientos LECS de los switches.

Ingresar los ATM Address en el switch LightStream 1010 de ATM

En el switch ATM del Cisco lightstream 1010, el direccionamiento LECS se puede especificar para un puerto o para el Switch entero.

Para ingresar los direccionamientos LECS en el switch ATM del Cisco lightstream 1010 para el Switch entero, utilice los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1. [sequence -] 2 del lecs-direccionamiento-defaultlecsaddress de Router(config)# ATM

2. Salida de Router(config)#

3. Sistema de la copia del Router-: running-config nvram: startup-config


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
[sequence -] 2 del lecs-direccionamiento-defaultlecsaddress de Router(config)# ATM 

Especifica el ATM Address LECS para el Switch entero. Si está configurando SSRP, incluya las direcciones ATM de todos los LECSs.

 
Paso 2
Salida de Router(config)# 

Sale del modo de configuración global.

 
Paso 3
Sistema de la copia del Router-: running-config nvram: startup-config 

Guarda el valor de configuración permanentemente.

 
2 refiera a la referencia de comandos del switch LightStream 1010 de ATM para más información sobre este comando.

Ingresar los ATM Address en el switch LightStream 1010 de ATM por el puerto

Para ingresar los direccionamientos LECS en el switch ATM del Cisco lightstream 1010 por el puerto, utilice los siguientes comandos que comienzan en el modo de configuración de la interfaz:

PASOS SUMARIOS

1. Router (config-if) # [sequence -] 3 de los lecs-addresslecsaddress ATM

2. Router (config-if) # Ctrl-z

3. Sistema de la copia del Router-: running-config nvram: startup-config


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
Router (config-if) # [sequence -] 3 de los lecs-addresslecsaddress ATM 

Especifica el ATM Address LECS para un puerto. Si está configurando SSRP, incluya las direcciones ATM de todos los LECSs.

 
Paso 2
Router (config-if) # Ctrl-z 

Sale del modo de configuración de interfaz.

 
Paso 3
Sistema de la copia del Router-: running-config nvram: startup-config 

Guarda el valor de configuración permanentemente.

 
3 refiera a la referencia de comandos del switch LightStream 1010 de ATM para más información sobre este comando.

Ingreso de Direcciones ATM en el Cisco LightStream 100 ATM Switch

Para ingresar el ATM Address LECS en el switch ATM del Cisco Lightstream 100 y salvarlo permanentemente, utilice los siguientes comandos en el modo EXEC privilegiado:

PASOS SUMARIOS

1. El Router- fijó el ATM-direccionamiento del índice del configserver

2. Salvaguardia del Router-


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
El Router- fijó el ATM-direccionamiento del índice del configserver 

Especifica el ATM Address LECS. Si usted está configurando el SSRP, relance este comando para cada direccionamiento LECS. El valor del índice determina la prioridad. La prioridad más alta es el 0. Puede haber un máximo de 4 LECS.

 
Paso 2
Salvaguardia del Router- 

Guarda el valor de configuración permanentemente.

 

Configurar las bases de datos LECS

La base de datos LECS contiene la información sobre cada ELAN, incluyendo los ATM Address del menos.

Usted puede especificar un ELAN predeterminado en la base de datos. El LECS asignará a cualquier cliente que no pida un ELAN específico al valor por defecto ELAN.

Los LAN emulados están restringidos o sin restricción. El LECS asignará a un cliente a un ELAN sin restricción si el cliente especifica ese ELAN determinado en su configuración. Sin embargo, el LECS asignará solamente a un cliente a un ELAN restricto si especifican al cliente en la base de datos del LECS como perteneciendo a ese ELAN. El valor por defecto ELAN debe tener calidad de miembro sin restricción.

Si usted está configurando la tolerancia de fallas, usted puede tener cualquier número de servidores por el ELAN. La prioridad es determinada por la orden de la entrada; la primera entrada tiene la prioridad más alta, a menos que usted la reemplace con la opción de índice.

Configuración de la Base de Datos Únicamente para la ELAN Predeterminada

Cuando usted configura a un router como el LECS para un ELAN predeterminado, usted proporciona un nombre para la base de datos, el ATM Address del LES para el ELAN, y un nombre predeterminado para el ELAN. Además, usted indica que el ATM Address LECS debe ser computado automáticamente.

Cuando usted configura una base de datos con solamente un ELAN sin restricción predeterminado, usted no tiene que especificar donde localizan a los clientes LANE. Es decir, cuando usted configura la base de datos LECS para un solo valor por defecto ELAN, usted no tiene que proporcionar ninguna entradas de la base de datos que conecten los ATM Address de cualquier cliente al nombre de ELAN. Asignarán todos los clientes al valor por defecto ELAN.

Usted puede tener cualquier número de servidores por el ELAN por tolerancia de fallas. La prioridad es determinada por la orden de la entrada. La primera entrada tiene la prioridad más alta a menos que usted la reemplace con la opción de índice.

Si usted está configurando solamente un valor por defecto ELAN, el valor del nombre de ELAN en los pasos 2 y 3 es lo mismo que el nombre de ELAN predeterminado usted proporciona en el paso 4.

Para configurar la operación tolerante a fallas, vea la sección “Configuración de la Operación Tolerante a Fallas” más adelante en este capítulo.

Para configurar el LECS para el valor por defecto ELAN, utilice los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1. Databasedatabase-nombre del carril de Router(config)#

2. Router (LANE-config-DAT) # [index number] del nameelan-nameserver-ATM-addressatm-direccionamiento

3. Router (LANE-config-DAT) # nameelan-namelocal-seg-idsegment-número

4. Router (LANE-config-DAT) # valor por defecto-nameelan-nombre

5. Router (LANE-config-DAT) # salida


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
Databasedatabase-nombre del carril de Router(config)# 

Crea una base de datos con nombre para el LECS.

 
Paso 2
Router (LANE-config-DAT) # [index number] del nameelan-nameserver-ATM-addressatm-direccionamiento  

En las bases de datos de la configuración, ata el nombre del ELAN al ATM Address del LES.

Si usted está configurando el SSRP, relance este paso para cada servidor adicional para el mismo ELAN. El índice determina la prioridad. La prioridad más alta es el 0.

 
Paso 3
Router (LANE-config-DAT) # nameelan-namelocal-seg-idsegment-número 

Si usted está configurando un Token Ring ELAN, asigna un número de segmento al Token Ring LANE emulado en las bases de datos de la configuración.

 
Paso 4
Router (LANE-config-DAT) # valor por defecto-nameelan-nombre 

En las bases de datos de la configuración, proporciona un nombre predeterminado para el ELAN.

 
Paso 5
Router (LANE-config-DAT) # salida 

Sale del modo de configuración de base de datos y vuelve al modo de configuración global.

 

Configuración de la Base de Datos para LAN Emuladas sin Restricción de Miembros

Cuando usted configura una base de datos para los LAN emulados sin restricción, usted crea las entradas de la base de datos que conectan el nombre de cada ELAN al ATM Address de su servidor.

Sin embargo, usted puede elegir no especificar donde localizan a los clientes LANE. Es decir, cuando usted configura la base de datos LECS, usted no tiene que proporcionar ninguna entradas de la base de datos que conecten los ATM Address o las direcciones MAC de cualquier cliente al nombre de ELAN. El LECS asignará a los clientes a los LAN emulados especificados en las configuraciones de cliente.

Para configurar la operación tolerante a fallas, vea la sección “Configuración de la Operación Tolerante a Fallas” más adelante en este capítulo.

Para configurar a un router como el LECS para los LAN emulados múltiples con la calidad de miembro sin restricción, utilice los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1. Databasedatabase-nombre del carril de Router(config)#

2. Router (LANE-config-DAT) # [index number] nameelan-name1server-atm-addressatm-address

3. Router (LANE-config-DAT) # [index number] nameelan-name2server-atm-addressatm-address

4. Router (LANE-config-DAT) # nameelan - name1local-seg-idsegment-number

5. Router (LANE-config-DAT) # nameelan - name2local-seg-idsegment-number

6. Router (LANE-config-DAT) # default-nameelan-name1

7. Router (LANE-config-DAT) # salida


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
Databasedatabase-nombre del carril de Router(config)# 

Crea una base de datos con nombre para el LECS.

 
Paso 2
Router (LANE-config-DAT) # [index number] nameelan-name1server-atm-addressatm-address 

En las bases de datos de la configuración, vincula el nombre de la primera ELAN a la dirección ATM del LES para esa ELAN.

Si configura SSRP, repita este paso con el mismo nombre de ELAN pero con diferentes direcciones ATM de servidor por cada servidor adicional de la misma ELAN. El índice determina la prioridad. La prioridad más alta es el 0.

 
Paso 3
Router (LANE-config-DAT) # [index number] nameelan-name2server-atm-addressatm-address 

En las bases de datos de configuración, vincula el nombre de la segunda ELAN a la dirección ATM del LES.

Si configura SSRP, repita este paso con el mismo nombre de ELAN pero con diferentes direcciones ATM de servidor por cada servidor adicional de la misma ELAN. El índice determina la prioridad. La prioridad más alta es el 0.

Relance este paso, proporcionando a un diversos nombre de ELAN y ATM Address para cada ELAN adicional en esta nube del Switch.

 
Paso 4
Router (LANE-config-DAT) # nameelan - name1local-seg-idsegment-number 

Para una ELAN Token Ring, asigna un número de segmento a la primera LAN Token Ring emulada de la base de datos de configuración.

 
Paso 5
Router (LANE-config-DAT) # nameelan - name2local-seg-idsegment-number 

Para los LAN emulados del Token Ring, asigna un número de segmento al segundo Token Ring LANE emulado en las bases de datos de la configuración.

Repita este paso, proporcionando un nombre de ELAN y un número de segmento distintos para cada ELAN puenteada de ruta de origen adicional en esta nube del switch.

 
Paso 6
Router (LANE-config-DAT) # default-nameelan-name1 

(Opcional) especifica un valor por defecto ELAN para los clientes LANE limitados no explícitamente a un ELAN.

 
Paso 7
Router (LANE-config-DAT) # salida 

Sale del modo de configuración de base de datos y vuelve al modo de configuración global.

 

Configuración de la Base de Datos para las LANs de Miembros Restringidos

Cuando usted configura la base de datos para los LAN emulados de la restricto-calidad de miembro, usted crea las entradas de la base de datos que conectan el nombre de cada ELAN al ATM Address de su servidor.

Sin embargo, usted debe también especificar donde localizan a los clientes LANE. Es decir, para cada restricto-calidad de miembro ELAN, usted proporciona una entrada de la base de datos que conecte explícitamente el ATM Address o la dirección MAC de cada cliente de ese ELAN al nombre de ese ELAN.

Las entradas de la base de datos del cliente especifican se permite a qué clientes unirse al ELAN. Cuando los pedidos de cliente de unirse a un ELAN, el LECS consultan su base de datos y entonces asigna al cliente al ELAN especificado en la base de datos LECS.

Cuando los clientes para la misma restricto-calidad de miembro ELAN están situados en los routeres múltiples, el ATM Address o la dirección MAC de cada cliente se debe conectar explícitamente al nombre del ELAN. Como consecuencia, usted debe configurar tantas entradas del cliente (en los pasos 6 y 7, en el siguiente procedimiento) pues usted tiene los clientes para los LAN emulados en todos los routers. Cada cliente tendrá un diverso ATM Address en las entradas de la base de datos.

Para configurar la operación tolerante a fallas, vea la sección “Configuración de la Operación Tolerante a Fallas” más adelante en este capítulo.

Para configurar el LECS para los LAN emulados con la calidad de miembro restricta, utilice los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1. Databasedatabase-nombre del carril de Router(config)#

2. Router (LANE-config-DAT) # [index number] restricto nameelan-name1server-atm-addressatm-address

3. Router (LANE-config-DAT) # [index number] restricto nameelan-name2server-atm-addressatm-address

4. Router (LANE-config-DAT) # nameelan - name1local-seg-idsegment-number

5. Router (LANE-config-DAT) # nameelan - name2local-seg-idsegment-number

6. Router (LANE-config-DAT) # client-atm-addressatm-address-templatenameelan-name1

7. Router (LANE-config-DAT) # client-atm-addressatm-address-templatenameelan-name2

8. Router (LANE-config-DAT) # salida


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
Databasedatabase-nombre del carril de Router(config)# 

Crea una base de datos con nombre para el LECS.

 
Paso 2
El router (LANE-config-DAT) # nameelan-name1server-atm-addressatm-address restringió el [index number]  

En las bases de datos de la configuración, vincula el nombre de la primera ELAN a la dirección ATM del LES para esa ELAN.

Si configura SSRP, repita este paso con el mismo nombre de ELAN pero con diferentes direcciones ATM de servidor por cada servidor adicional de la misma ELAN. El índice determina la prioridad. La prioridad más alta es el 0.

 
Paso 3
El router (LANE-config-DAT) # nameelan-name2server-atm-addressatm-address restringió el [index number] 

En las bases de datos de configuración, vincula el nombre de la segunda ELAN a la dirección ATM del LES.

Si configura SSRP, repita este paso con el mismo nombre de ELAN pero con diferentes direcciones ATM de servidor por cada servidor adicional de la misma ELAN. El índice determina la prioridad. La prioridad más alta es el 0.

Relance este paso, proporcionando a un nombre diferente y a un diverso ATM Address, para cada ELAN adicional.

 
Paso 4
Router (LANE-config-DAT) # nameelan - name1local-seg-idsegment-number 

Para una ELAN Token Ring, asigna un número de segmento a la primera LAN Token Ring emulada de la base de datos de configuración.

 
Paso 5
Router (LANE-config-DAT) # nameelan - name2local-seg-idsegment-number 

Si usted está configurando los LAN emulados del Token Ring, asigna un número de segmento al segundo Token Ring LANE emulado en las bases de datos de la configuración.

Repita este paso, proporcionando un nombre de ELAN y un número de segmento distintos para cada ELAN puenteada de ruta de origen adicional en esta nube del switch.

 
Paso 6
Router (LANE-config-DAT) # client-atm-addressatm-address-templatenameelan-name1 

Agrega una entrada de la base de datos que asocia el ATM Address de un cliente específico a la primera restricto-calidad de miembro ELAN.

Relance este paso para cada uno de los clientes de la primera restricto-calidad de miembro ELAN.

 
Paso 7
Router (LANE-config-DAT) # client-atm-addressatm-address-templatenameelan-name2 

Agrega una entrada de la base de datos que asocia el ATM Address de un cliente específico a la segunda restricto-calidad de miembro ELAN.

Relance este paso para cada uno de los clientes de la segunda restricto-calidad de miembro ELAN.

Relance este paso, proporcionando a un nombre diferente y a una diversa lista de ATM Address del cliente, para cada ELAN adicional.

 
Paso 8
Router (LANE-config-DAT) # salida 

Sale del modo de configuración de base de datos y vuelve al modo de configuración global.

 

Habilitación del LECS

Una vez que usted ha creado la base de datos, usted puede habilitar el LECS en la interfaz ATM y el router seleccionados usando los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1.   

2. Router (config-if) # databasedatabase-nombre del lane config

3.   Siga uno de los siguientes pasos:

  • Router (config-if) # lane config auto-config-atm-address
  • Router (config-if) # lane config auto-config-atm-address
  • Router (config-if) # lane config fixed-config-atm-address router (config-if) # lane config fixed-config-atm-address

4. salida

5. Ctrl-z

6. sistema de la copia: running-config nvram: startup-config


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1



Ejemplo:

Interfaz ATM slot/0[.subinterface-number de Router(config)#



Ejemplo:

Slot/port-adapter/0[.subinterface-number de la interfaz ATM de Router(config)#]



Ejemplo:

[.subinterface-number] del número de la interfaz ATM de Router(config)#

 

Si usted no está configurando actualmente la interfaz, especifica la interfaz ATM principal donde se localiza el LECS.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
 
Paso 2
Router (config-if) # databasedatabase-nombre del lane config 

Conecte el nombre de la base de datos LECS a la interfaz principal especificada, y habilite el LECS.

 
Paso 3
Siga uno de los siguientes pasos:
  • Router (config-if) # lane config auto-config-atm-address
  • Router (config-if) # lane config auto-config-atm-address
  • Router (config-if) # lane config fixed-config-atm-address router (config-if) # lane config fixed-config-atm-address


Ejemplo:

Router (config-if) # Config-atm-address del lane config plantilla de dirección ATM

 

Especifica cómo el ATM Address LECS será computado. Usted puede optar elegir uno de los escenarios siguientes:

El LECS participará en el SSRP y el direccionamiento es computado por el método automático.

El LECS participará en el SSRP, y el direccionamiento es computado por el método automático. Si el LECS es el master, el direccionamiento fijo también se utiliza.

El LECS no participará en el SSRP, el LECS es el master, y solamente utilizan a la dirección conocida.

El LECS participará en el SSRP y el direccionamiento se computa usando un explícito, el ATM Address 20-byte.

 
Paso 4
salida
 

Sale del modo de configuración de interfaz.

 
Paso 5
Ctrl-z
 

Devoluciones al modo EXEC.

 
Paso 6
sistema de la copia: running-config nvram: startup-config
 

Guarda la configuración.

 

Configuración de LESs y Clientes

Para cada router que participe en el LANE, configure los servidores y a los clientes necesarios para cada ELAN; después visualice y registre los ATM Address del servidor y del cliente. Esté seguro de no perder de vista la interfaz del router donde el LECS será localizado eventual.

Usted puede configurar los servidores para más de un ELAN en las subinterfaces diferentes o en la misma interfaz de un router, o usted puede colocar los servidores en diversos routers.

Cuando usted configura un servidor y un BUS en un router, usted puede combinarlos con un cliente en la misma subinterfaz, un cliente en una subinterfaz diferente, o ningún cliente en absoluto en el router.

Donde usted pone a los clientes es importante porque cualquier router con los clientes para los LAN emulados múltiples puede rutear las tramas entre esos LAN emulados.

Dependiendo de donde localizan a sus clientes y servidor, realice una de las tareas siguientes para cada subinterfaz LANE.

Configurar el servidor y el BUS y el cliente

Si el ELAN en el paso 3 se piensa para tener restrictedmembership, considere cuidadosamente si usted quiere especificar su nombre aquí. Usted especificará el nombre en la base de datos LECS cuando se configura. Sin embargo, si usted conecta al cliente a un ELAN en este paso, y con un cierto error no hace juego la entrada de la base de datos que conecta al cliente a un ELAN, no se permitirá a este cliente unirse a este ELAN o cualquier otro.

Si usted decide incluir el nombre del ELAN conectado al cliente en el paso 3 y posterior quiere asociar a ese cliente a un diverso ELAN, realice el cambio en la base de datos LECS antes de que usted realice el cambio para el cliente en esta subinterfaz.

Cada ELAN es una subred independiente. En el paso 4 aseegurese que asignan los clientes del mismo ELAN a las direcciones de protocolo en el mismo red secundario y que asignan los clientes de diversos LAN emulados a las direcciones de protocolo en diversos redes secundarios.

Para configurar el servidor, el BUS, y (opcionalmente) los clientes para un ELAN, utilizan los siguientes comandos que comienzan en el modo de configuración global:

PASOS SUMARIOS

1. Slot /0 .subinterface-number de la interfaz ATM de Router(config)#

2. Router (config-if) # bus de servidor LANE {Ethernet| nombre de ELAN del token ring}

3. Router (config-if) # cliente LANE {Ethernet| [elan-id id] del [elan-name] del token ring}

4. Router (config-if) # máscara del IP address

5. Router (config-if) # Ctrl-z

6. Sistema de la copia del Router-: running-config nvram: startup-config


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
Slot /0 .subinterface-number de la interfaz ATM de Router(config)#

Ejemplo:

Slot/puerto-ADAPTER /0 .subinterface-number de la interfaz ATM de Router(config)#



Ejemplo:

Número de la interfaz ATM de Router(config)#. subinterfaz-número

 

Especifica la subinterfaz para la ELAN en este router.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
 
Paso 2
Router (config-if) # bus de servidor LANE {Ethernet| nombre de ELAN del token ring}  

Habilita un LES y un BUS LANE para el ELAN.

 
Paso 3
Router (config-if) # cliente LANE {Ethernet| [elan-id id] del [elan-name] del token ring}  

(Opcional) habilita a un cliente LANE para el ELAN.

Para participar en el MPOA, configura el LES y un BUS LANE para el ELAN con la identificación ELAN

 
Paso 4
Router (config-if) # máscara del IP address  

Proporciona a una dirección de protocolo para el cliente.

  • El comando o los comandos dependen del Routing Protocol utilizado. Si utiliza IPX o AppleTalk, vea el capítulo de protocolo correspondiente (IPX o AppleTalk) en la Guía de Configuración de AppleTalk y Novell IPX de Cisco IOS para conocer los comandos que puede utilizar.
 
Paso 5
Router (config-if) # Ctrl-z  

Devoluciones al modo EXEC.

 
Paso 6
Sistema de la copia del Router-: running-config nvram: startup-config  

Guarda la configuración.

 

Configuración solamente de un Cliente en una Subinterfaz

En cualquier router dado, usted puede configurar un cliente para un ELAN o a los clientes múltiples para los LAN emulados múltiples. Usted puede configurar a un cliente para un ELAN dado en cualquier router que usted elija participar en ese ELAN. Cualquier router con los clientes para los LAN emulados múltiples puede los paquetes de Routes entre esos LAN emulados.

Usted debe primero configurar la señalización y el ILMI PVC en la interfaz ATM principal, según lo descrito anterior en el “configurar de la señalización y de la sección del ILMI PVC”, antes de que usted configure al cliente.

Cada ELAN es una subred independiente. En el paso 2, aseegurese que asignan los clientes del mismo ELAN a las direcciones de protocolo en el mismo red secundario y que asignan los clientes de diversos LAN emulados a las direcciones de protocolo en diversos redes secundarios.

Para configurar solamente a un cliente para los LAN emulados, utilizan los siguientes comandos que comienzan en el modo de configuración de la interfaz:

PASOS SUMARIOS

1. Slot /0 de la interfaz ATM de Router(config)#. subinterfaz-número

2. Router (config-if) # máscara del IP address

3. Router (config-if) # cliente LANE {Ethernet| [elan-name] del token ring}

4. Router (config-if) # Ctrl-z

5. Sistema de la copia del Router-: running-config nvram: startup-config


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
Slot /0 de la interfaz ATM de Router(config)#. subinterfaz-número

Ejemplo:

Slot/puerto-ADAPTER /0 de la interfaz ATM de Router(config)#. subinterfaz-número



Ejemplo:

Número de la interfaz ATM de Router(config)#. subinterfaz-número

 

Especifica la subinterfaz para la ELAN en este router.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
 
Paso 2
Router (config-if) # máscara del IP address  

Proporciona a una dirección de protocolo para el cliente en esta subinterfaz.

  • El comando o los comandos dependen del Routing Protocol utilizado. Si utiliza IPX o AppleTalk, vea el capítulo de protocolo correspondiente (IPX o AppleTalk) en la Guía de Configuración de AppleTalk y Novell IPX de Cisco IOS para conocer los comandos que puede utilizar.
 
Paso 3
Router (config-if) # cliente LANE {Ethernet| [elan-name] del token ring}  

Habilita a un cliente LANE para el ELAN.

 
Paso 4
Router (config-if) # Ctrl-z  

Devoluciones al modo EXEC.

 
Paso 5
Sistema de la copia del Router-: running-config nvram: startup-config  

Guarda la configuración.

 

Inhabilitar el proceso RASANTE de los LAN Emulation Clients

Inhabilite el proceso LE_FLUSH y haga la transición de usar el BUS a usar una vía directa de datos Conexión de canal virtual (VCC). Inhabilitar el proceso LE_FLUSH se recomienda para prevenir las caídas de paquetes iniciales durante el establecimiento de VC directo LANE. Con el proceso LE_FLUSH inhabilitado, el (LECs) de los LAN Emulation Clients en el nodo no enviará una petición rasante y utilizará directamente un VCC directo de datos para la Transferencia de datos.


Nota


Inhabilitar el proceso LE_FLUSH afecta a todos los LEC en un dispositivo de interconexión de redes de Cisco.

Para guardar los LEC de enviar los mensajes LE_FLUSH al telecontrol LEC, utilice el siguiente comando en el modo de configuración de la interfaz:

Comando

Propósito

Router(config-if)# no lane client flush

Inhabilita el mecanismo rasante de un LEC.

Configuración de Clientes LANE para MPOA

Para el multiprotocolo sobre ATM (MPOA) a trabajar correctamente, un cliente LANE debe tener un ELAN ID para todos los ELAN representados por el cliente LANE.


Precaución


Si un ELAN ID es suministrado por los comandos both, aseegurese que el ELAN ID hace juego en ambos.


Para más información sobre configurar el MPOA Client, refiera “configurando al capítulo al cliente del multiprotocolo sobre ATM”.

Para configurar un ELAN ID, utilice uno de los siguientes comandos en el modo de configuración de las bases de datos LANe o en el modo de configuración de la interfaz al comenzar encima del LES para ese ELAN:

Comando

Propósito

Router(lane-config-dat)# name elan-name
 elan-id id

Configura el ELAN ID en la base de datos del (LECs) del servidor del LAN Emulation Client para participar en el MPOA.

Router(lane-config-dat)# lane server-bus {ethernet | tokenring} elan-name
 [elan-id id
]

Configura el LES y un BUS LANE para el ELAN (ELAN).

Para participar en el MPOA, configure el LES y un BUS LANE para el ELAN con la identificación ELAN

Configurar la operación tolerante a fallas

La característica simple de la redundancia del servidor LANE crea la tolerancia de fallas usando los protocolos estándar y los mecanismos LANE. Si un error ocurre en el LECS o en el LES/BUS, el ELAN puede continuar actuando usando los servicios de un respaldo LES. Este protocolo se llama el SSRP.

Esta sección describe cómo configurar la redundancia del servidor simple por tolerancia de fallas en un ELAN.


Nota


Esta redundancia del servidor no supera otras puntas del error más allá de los puertos de router: La redundancia adicional en el lado LAN o en la nube del switch ATM no es una parte de la característica simple de la redundancia del servidor LANE.

Requisitos simples de la redundancia del servidor

Por la replicación o tolerancia de fallas simple del servicio LANe a trabajar, el switch ATM debe soportar los direccionamientos múltiples LES. Este mecanismo se especifica en el estándar LANE. El LE servers establece y mantiene un circuito de control estándar que permita a la redundancia del servidor para actuar.

La redundancia del servidor simple LANE se soporta en el Cisco IOS Release 11.2 y Posterior. Más viejos archivos de configuración LANE continúan trabajando con este nuevo software.

Esta función de redundancia trabaja solamente con Cisco LECS y las combinaciones LES/BUS. Los clientes LANE de tercera persona pueden ser utilizados con el SSRP, pero los servidores de configuración, LE servers, y el BUS de tercera persona no soportan el SSRP.

Para que redundancia del servidor trabaje correctamente:

  • Todos los switches ATM deben tener listas idénticas de los direccionamientos globales LECS, en la orden idéntica de la prioridad.
  • Los LECS de funcionamiento deben utilizar exactamente la base de datos de la misma configuración. Cargue los datos de la Tabla de configuración usando el sistema RCP tftp de la copia}: comando running-config. Este método minimiza los errores y habilita la base de datos que se mantendrá centralmente en un lugar.

El protocolo LANE no especifica donde las entidades unas de los del servidor ELAN deben ser localizadas, pero con el fin de la confiabilidad y del funcionamiento, Cisco implementa estos componentes del servidor en sus routers.

Requisitos simples rápidos de la redundancia del servidor

El protocolo fast simple server replication (FSSRP) diferencia de LANE SSRP en que todo el LE configurado servers de un ELAN es siempre activo. los clientes LANE FSSRP-habilitados tienen circuitos virtuales (VCs) establecidos a un máximo de cuatro LE servers y broadcastes y servidor desconocidos (BUSs) al mismo tiempo. Si va un solo LES abajo, del cliente LANE los switches rápidamente encima al LES y el BUS siguientes dando por resultado ninguna pérdida de los datos o de la entrada de tabla del LE-ARP y señalización no extraña.

Debido al aumento en las conexiones del cliente LAN a todo el LE servers en un ELAN, el FSSRP aumenta el número de VCs en su red. En a por las bases del cliente, hasta 12 VCs adicional serán agregados. Éstos incluyen el control dirigido adicional, el control distribuye, el multicast envía y multicast VCs delantero (mide el tiempo de los 3 LE adicional servers y BUSs), que suma 12 VCs adicional.

Los usuarios deben tomar el cuidado para calcular independientemente de si el número de VCs existente en su red se puede mantener con las conexiones adicionales del VC al LE secundario servers y a BUSs.

Un cliente LANE puede conectar con hasta solamente 4 LE servers y el en un momento de BUSs.

Servidores de la configuración redundante

Para habilitar los LECS redundantes, ingrese los direccionamientos múltiples LECS en los switches ATM del extremo. Los componentes de LANE pueden obtener la lista de direccionamientos LECS de los switches ATM a través de la interfaz de administración local interina (ILMI).

Refiera “ingresando el ATM Address LECS en a la sección del switch Cisco” para más detalles.

Servidores redundantes y BUSs

El LECS gira la redundancia server/BUS ajustando su base de datos para acomodar los ATM Address del servidor múltiple para un ELAN determinado. Los servidores adicionales sirven como servidores de backup para ese ELAN.

Para activar la característica, usted agrega una entrada para la lista jerárquica de servidores que soporten el ELAN dado. Todas las modificaciones de la base de datos para el ELAN deben ser idénticas en todos los LECS.

Refiera “configurando a la sección de las bases de datos LECS” para más detalles.

Consideraciones de Implementación

Lo que sigue es una lista de restricciones de la implementación LANE:

  • El LightStream1010 puede manejar hasta 16 direccionamientos LECS. El Lightstream 100 permite un máximo de 4 direccionamientos LECS.
  • No hay límite en el número de LE servers que se puede definir por el ELAN.
  • Cuando ocurre un intercambio LECS, no hay clientes previamente unidos afectados.
  • Cuando ocurren los cambios LES/BUS, pérdida momentánea de los clientes hasta que todos se transfieran al nuevo LES/BUS.
  • Los LECS suben como los masters hasta que un LECS de alto nivel les diga de otra manera. Esto es automático y no puede ser cambiada.
  • Si viene una prioridad más alta LES en línea, topa el LES actual apagado en el mismo ELAN. Por lo tanto, puede haber algún cambio de clientes a partir de un LES a otro después de un powerup, dependiendo de la orden del LE servers que sube. El cambio debe establecer después de que suba la prioridad más alta más reciente LES.
  • Si ninguno del LE especificado servers es ascendente o conectado con el master LECS y más de un LES se define para un ELAN, un pedido de configuración para ese ELAN específico es rechazado por el LECS.
  • Los cambios realizados a la lista de direccionamientos LECS en los switches ATM pueden tomar hasta un minuto para propagar a través de la red. Los cambios realizados a las bases de datos de la configuración con respecto a los direccionamientos LES toman el efecto casi inmediatamente.
  • Si ningunos de los LECS señalados son operativos o accesibles, se utiliza el direccionamiento bien conocido definido por forum atmósfera LECS.
  • Usted puede reemplazar el direccionamiento LECS en cualquier subinterfaz, usando los siguientes comandos:
    • auto-config-ATM-direccionamiento del carril
    • reparar-config-ATM-direccionamiento del carril
    • lane config-atm-address

Precaución


Cuando una invalidación como esto se realiza, la operación incidente-tolerante no puede ser garantizada. Para evitar afectar a la operación incidente-tolerante, no reemplace ningún LECS, LES o direcciones del bus.


  • Si ocurre un error subyacente de la red ATM, puede haber master múltiple LECS y LE activo múltiple servers para el mismo ELAN. Esta situación crea una red “dividida”. Los clientes continúan actuando normalmente, pero la transmisión entre diversas divisiones de la red no es posible. Cuando se repara la quiebre de la red, el sistema se recupera.
  • Cuando el LECS es ya en servicio, y usted utiliza la configuración del commandto del lane config reparar-config-ATM-addressinterface el direccionamiento bien conocido LECS, sea consciente de los escenarios siguientes:
    • Si usted configura el LECS con solamente la dirección conocida, el LECS no participará en el SSRP, actúa como master “independiente”, y escucha solamente en el direccionamiento bien conocido LECS. Este escenario es ideal si usted quiere un LECS “independiente” que no participe en el SSRP, y usted quisiera escuchar solamente la dirección conocida.
    • Si solamente asignan la dirección conocida ya, y usted asigna por lo menos otro direccionamiento al LECS, (asignan las direcciones adicionales usando el comando interface del lane config auto-config-atm-address y/o el comando del lane config config-ATM-addressinterface) el LECS participará en el SSRP y actuará como el master o el esclavo basado en las reglas habituales SSRP. Este escenario es ideal si usted como el LECS participara en el SSRP, y usted quisiera hacer que escucha el master LECS en la dirección conocida.
    • Si el LECS está participando en el SSRP, tiene más de un direccionamiento (uno de los cuales es la dirección conocida), y todos los direccionamientos pero quitan a la dirección conocida, el LECS se declarará el master y parará el participar en el SSRP totalmente.
    • Si el LECS está actuando como esclavo SSRP, y tiene la dirección conocida configurada, no escuchará en la dirección conocida a menos que sienta bien al master.
    • Si usted quisiera que el LECS asumiera a la dirección conocida solamente cuando siente bien al master, configure el LECS con la dirección conocida y por lo menos otra direccionamiento.

Cambios SSRP para reducir el flap de la red

El SSRP fue diseñado originalmente de modo que cuando un LES más alto vino en la línea, todos los LEC en ese ELAN movieran de un tirón encima al LES más alto. Esto causó las interrupciones innecesarias en las Redes grandes. Ahora el SSRP se diseña para eliminar el cambio innecesario. Si el LES actual es sano, el cambio puede ser eliminado cambiando el comportamiento SSRP de modo que el ELAN no mueva de un tirón encima a otro LES. Obviamente, si actualmente - el LES activo va abajo, todos los LEC entonces será conmutado encima al primer LES más alto disponible de la lista. Éste ahora es el comportamiento predeterminado.

Si los ELAN ahora se configuran de la nueva manera, un intercambio LECS puede o no puede causar un flap de la red dependiendo de cómo cada LES ahora vuelve a conectar rápidamente al nuevo master LECS. Si el active viejo LES conecta primero, el flap no ocurrirá. Sin embargo, si otro LES conecta el primer (puesto que ahora los criterios son que el primer LES conectado está asumido el master LES, bastante que el más alto), después la red todavía agitará.

Para los clientes que quisieran específicamente mantener el viejo comportamiento SSRP, pueden utilizar el nuevo comando de configuración de la base de datos del preemptLANE del nombre de ELAN del nombre LECS. Este comando forzará el viejo comportamiento a ser mantenido. Esta característica se puede habilitar/inhabilitar en a por la base individual ELAN de las bases de datos LECS. En el más viejo esquema (apropíese), el intercambio LES causó el flap de la red.

Para habilitar la red agite y fije el ELAN se apropian para un LES, utilizan el siguiente comando en el modo de configuración de las bases de datos LANe:

Comando

Propósito

Router(lane-config-dat)# name elan-name preempt

Fija el derecho preferente de compra ELAN LES.

Monitoreando y manteniendo los componentes de LANE

Después de configurar los componentes de LANE en una interfaz o ninguna de sus subinterfaces, en una subinterfaz especificada, o en un ELAN, usted puede visualizar su estatus. Para mostrar la información LANE, utilice los siguientes comandos en el modo EXEC:

Comando

Propósito

Router# show lane [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief] 
                
                  

                Router# show lane [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
] [brief]


              
Router# show lane [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Visualiza la información global y por-virtual de la conexión de canal LANE para todos los componentes de LANE y LAN emulados configurados en una interfaz o ninguna de sus subinterfaces.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
Router# show lane bus [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief]
                
                  

                Router# show lane bus [interface atm slot/port-adapter/ 0 [.subinterface-number
] | name elan-name
] [brief]
                
                  

                Router# show lane bus [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Visualiza la información global y por-VCC LANE para el BUS configurado en cualquier subinterfaz o ELAN.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
Router# show lane client [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief 
Router# show lane client [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
] [brief]
                
                  

                Router# show lane client [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Visualiza la información global y por-VCC LANE para todos los clientes LANE configurados en cualquier subinterfaz o ELAN.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
Router# show lane config [interface atm slot/0]
                
                  

                Router# show lane config [interface atm slot/port-adapter/0]
                
                  

                Router# show lane config [interface atm number
]

Visualiza la información global y por-VCC LANE para el LECS configurado en cualquier interfaz.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
Router# show lane database [database-name
]

Visualiza la base de datos LECS.

Router# show lane default-atm-addresses [interface atm slot/0.subinterface-number
]
                
                  

                Router# show lane default-atm-addresses [interface atm slot/port-adapter/0.subinterface-number
]
                
                  

                Router# show lane default-atm-addresses [interface atm number.subinterface-number
]

Visualiza el ATM Address automáticamente asignado de cada componente de LANE en un router o en una interfaz especificada o una subinterfaz.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
Router# show lane le-arp [interface atm slot/0[.subinterface-number
] | name elan-name
]
                
                  

                Router# show lane le-arp [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
]


              
Router# show lane le-arp [interface atm number
[.subinterface-number
] | name elan-name
]

Visualice la tabla ARP LANE del cliente LANE configurado en la subinterfaz o el ELAN especificada.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.
Router# show lane server [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief
Router# show lane server [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
] [brief]


              
Router# show lane server [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Visualice la información global y por-VCC LANE para el LES configurado en una subinterfaz o un ELAN especificada.

  • En el AIP para Cisco 7500 Series Routers; En el adaptador de puerto ATM para Cisco 7200 Series Routers.
  • En el adaptador de puerto ATM para Cisco 7500 Series Routers.
  • En el NPM para los Cisco 4500 y Cisco 4700 Routers.

Ejemplos de configuración LANE

Todos los ejemplos utilizan el método de asignación automático del ATM Address descrito en “método automáticamente de asignar la sección de los ATM Address” anterior en este capítulo. Estos ejemplos muestran las configuraciones LANE, no el proceso de determinar los ATM Address y de ingresarlos.

Solo ejemplo de la Ethernet ELAN

El siguiente ejemplo configura a cuatro Cisco 7500 Series Router para una Ethernet ELAN. El router1 contiene el LECS, el servidor, el BUS, y a un cliente. Los routeres restantes cada uno contienen a un cliente para el ELAN. Este ejemplo acepta todas las configuraciones predeterminadas que se proporcionan. Por ejemplo, no fija explícitamente los ATM Address para los diversos componentes de LANE que se colocan en el router. En esta LAN la pertenencia no está restringida.

Configuración del Router 1

lane database example1
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 default-name eng
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example1
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus ethernet eng
 lane client ethernet 

Configuración del router 2

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.1
 ip address 172.16.0.3 255.255.255.0
 lane client ethernet

Configuración del router3

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 2/0.1
 ip address 172.16.0.4 255.255.255.0
 lane client ethernet

Configuración del Router4

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.3
 ip address 172.16.0.5 255.255.255.0
 lane client ethernet

Sola Ethernet ELAN con un backup LECS y el ejemplo LES

Este ejemplo configura a cuatro Cisco 7500 Series Router para un ELAN con la tolerancia de fallas. El router1 contiene el LECS, el servidor, el BUS, y a un cliente. El router2 contiene el backup LECS y el respaldo LES para este ELAN y otro cliente. Los routers 3 y 4 contienen a los clientes solamente. Este ejemplo acepta todas las configuraciones predeterminadas que se proporcionan. Por ejemplo, no fija explícitamente los ATM Address para los diversos componentes de LANE colocados en el router. En esta LAN la pertenencia no está restringida.

Configuración del Router 1

lane database example1
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name eng server-atm-address 39.000001415555121101020304.0612.200c 2001.01
 default-name eng
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example1
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus ethernet eng
 lane client ethernet 

Configuración del router 2

lane database example1_backup
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name eng server-atm-address 39.000001415555121101020304.0612.200c 2001.01 (backup LES)
 default-name eng
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database example1_backup
interface atm 1/0.1
 ip address 172.16.0.3 255.255.255.0
 lane server-bus ethernet eng
 lane client ethernet

Configuración del router3

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 2/0.1
 ip address 172.16.0.4 255.255.255.0
 lane client ethernet

Configuración del Router4

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.3
 ip address 172.16.0.5 255.255.255.0
 lane client ethernet

Ejemplo de ELANs Token Ring Múltiples con Afiliación Sin Restricción

El siguiente ejemplo configura a cuatro Cisco 7500 Series Router para tres LAN emulados para dirigir, fabricar, y comercializar, tal y como se muestra en de la figura abajo. Este ejemplo no restringe la pertenencia en las LANs emuladas.

Figura 1LAN emulados múltiples


En este ejemplo, el router1 tiene los componentes de LANE siguientes:

  • El LECS (hay un LECS para este grupo de LAN emulados)
  • El LES y el BUS para el ELAN para fabricar (hombre)
  • El LES y el BUS para el ELAN para dirigir (inglés)
  • Un cliente LANE para ELAN para fabricación (man)
  • Un cliente LANE para la ELAN de ingeniería (eng)

El router2 tiene los componentes de LANE siguientes:

  • Un cliente LANE para ELAN para fabricación (man)
  • Un cliente LANE para la ELAN de ingeniería (eng)

El router3 tiene los componentes de LANE siguientes:

  • Un cliente LANE para ELAN para fabricación (man)
  • Un cliente LANE para la ELAN para Comercializar (mkt)

El Router4 tiene los componentes de LANE siguientes:

  • El LES y el BUS para el ELAN para comercializar (mkt)
  • Un cliente LANE para ELAN para fabricación (man)
  • Un cliente LANE para la ELAN para Comercializar (mkt)

Con el propósito de este ejemplo, asignan los cuatro routers los prefijos del ATM Address y los Identificadores del sistema final (ESI) tal y como se muestra en de la tabla abajo (la parte de ESI el ATM Address se deriva de la primera dirección MAC del AIP mostrado en el ejemplo).

Tabla 2Prefijos atmósfera por el ejemplo TR-LANE

Router

Prefijo del ATM Address

Base ESI

Router 1

39,000001415555121101020304

0800.200c.1000

Router 2

39,000001415555121101020304

0800.200c.2000

Router 3

39,000001415555121101020304

0800.200c.3000

Router 4

39,000001415555121101020304

0800.200c.4000

Configuración del Router 1

El router 1 tiene el LECS y su base de datos, el servidor y el BUS para la ELAN de Fabricación, el servidor y el BUS para la ELAN de Ingeniería, un cliente para Fabricación y un cliente para Ingeniería. El Router 1 se configura tal y como se muestra en este ejemplo:

!The following lines name and configure the configuration server's database.
lane database example2
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.02
 name eng local-seg-id 1000
 name man server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name man local-seg-id 2000
 name mkt server-atm-address 39.000001415555121101020304.0800.200c.4001.01
 name mkt local-seg-id 3000
 default-name man
!
! The following lines bring up the configuration server and associate
! it with a database name.
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example2
!
! The following lines configure the "man" server, broadcast-and-unknown server,
! and the client on atm subinterface 1/0.1. The client is assigned to the default
! emulated lan.
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus tokenring man
 lane client tokenring man
!
! The following lines configure the "eng" server, broadcast-and-unknown server,
! and the client on atm subinterface 1/0.2. The client is assigned to the 
! engineering emulated lan. Each emulated LAN is a different subnetwork, so the "eng"
! client has an IP address on a different subnetwork than the "man" client.
interface atm 1/0.2
 ip address 172.16.1.1 255.255.255.0
 lane server-bus tokenring eng
 lane client tokenring eng

Configuración del router 2

El router 2 se configura para un cliente de la ELAN de fabricación y un cliente de la ELAN de ingeniería. Dado que el nombre de ELAN predeterminado es man, el primer cliente está vinculado a ese nombre de ELAN de manera predeterminada. El router 2 se configura del siguiente modo:

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.1
 ip address 172.16.0.2 255.255.255.0
 lane client tokenring
interface atm 1/0.2
 ip address 172.16.1.2 255.255.255.0
 lane client tokenring eng

Configuración del router3

El Router 3 se configura para un cliente de la ELAN de fabricación y un cliente de la ELAN de marketing. Dado que el nombre de ELAN predeterminado es man, el primer cliente está vinculado a ese nombre de ELAN de manera predeterminada. El router3 se configura como se muestra aquí:

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 2/0.1
 ip address 172.16.0.3 255.255.255.0
 lane client tokenring
interface atm 2/0.2
 ip address 172.16.2.3 255.255.255.0
 lane client tokenring mkt

Configuración del Router4

El router 4 tiene el servidor y el BUS para la ELAN de marketing, un cliente para marketing y un cliente para fabricación. Porque el nombre de ELAN predeterminado es hombre, conectan al segundo cliente a ese nombre de ELAN por abandono. El router 4 se configura como se muestra a continuación:

interface atm 3/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 3/0.1
 ip address 172.16.2.4 255.255.255.0
 lane server-bus tokenring mkt
 lane client tokenring mkt
interface atm 3/0.2
 ip address 172.16.0.4 255.255.255.0
 lane client tokenring

Ejemplo de ELANs Token Ring Múltiples con Miembros con Restricción

El siguiente ejemplo, mostrado en la figura abajo, configura a un Cisco 7500 Series Router para tres LAN emulados para dirigir, fabricar, y comercializar.

Los mismos componentes se asignan a los cuatro routers como en el ejemplo anterior. Los prefijos del ATM Address y las direcciones MAC son también lo mismo que en el ejemplo anterior.

Sin embargo, este ejemplo restringe la calidad de miembro para los LAN emulados de la ingeniería y del márketing. La base de datos LECS tiene entradas explícitas que atan los ATM Address de los clientes LANE a especificado, nombrados los LAN emulados. En estos casos, la información de los pedidos de cliente del LECS sobre qué ELAN debe unirse a; el LECS marca su base de datos y contesta al cliente. Puesto que la fabricación ELAN está sin restricción, se permite a cualquier cliente no en la base de datos LECS unirse a la.

Figura 2LAN emulados múltiples con la calidad de miembro restricta


Configuración del Router 1

El router 1 tiene el LECS y su base de datos, el servidor y el BUS para la ELAN de Fabricación, el servidor y el BUS para la ELAN de Ingeniería, un cliente para Fabricación y un cliente para Ingeniería. También tiene entradas de la base de datos explícitas que atan los ATM Address de los clientes LANE a especificado, nombrados los LAN emulados. El router1 se configura como se muestra aquí:

! The following lines name and configure the configuration server's database.
lane database example3
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.02 restricted
 name eng local-seg-id 1000
 name man server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name man local-seg-id 2000
 name mkt server-atm-address 39.000001415555121101020304.0800.200c.4001.01 restricted
 name mkt local-seg-id 3000
! 
 ! The following lines add database entries binding specified client ATM 
 ! addresses to emulated LANs. In each case, the Selector byte corresponds
 ! to the subinterface number on the specified router. 
 ! The next command binds the client on Router 1's subinterface 2 to the eng ELAN.
 client-atm-address 39.0000014155551211.0800.200c.1000.02 name eng
 ! The next command binds the client on Router 2's subinterface 2 to the eng ELAN.
 client-atm-address 39.0000014155551211.0800.200c.2000.02 name eng
 ! The next command binds the client on Router 3's subinterface 2 to the mkt ELAN.
 client-atm-address 39.0000014155551211.0800.200c.3000.02 name mkt
 ! The next command binds the client on Router 4's subinterface 1 to the mkt ELAN.
 client-atm-address 39.0000014155551211.0800.200c.4000.01 name mkt
 default-name man
!
! The following lines bring up the configuration server and associate
! it with a database name.
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example3
!
! The following lines configure the "man" server/broadcast-and-unknown server,
! and the client on atm subinterface 1/0.1. The client is assigned to the default
! emulated lan.
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus tokenring man
 lane client tokenring
!
! The following lines configure the "eng" server/broadcast-and-unknown server
! and the client on atm subinterface 1/0.2. The configuration server assigns the 
! client to the engineering emulated lan. 
interface atm 1/0.2
 ip address 172.16.1.1 255.255.255.0
 lane server-bus tokenring eng
 lane client tokenring eng

Configuración del router 2

El router 2 se configura para un cliente de la ELAN de fabricación y un cliente de la ELAN de ingeniería. Dado que el nombre de ELAN predeterminado es man, el primer cliente está vinculado a ese nombre de ELAN de manera predeterminada. El router2 se configura tal y como se muestra en de este ejemplo:

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
! This client is not in the configuration server's database, so it will be 
! linked to the "man" ELAN by default.
interface atm 1/0.1
 ip address 172.16.0.2 255.255.255.0
 lane client tokenring
! A client for the following interface is entered in the configuration 
! server's database as linked to the "eng" ELAN.
interface atm 1/0.2
 ip address 172.16.1.2 255.255.255.0
 lane client tokenring eng

Configuración del router3

El Router 3 se configura para un cliente de la ELAN de fabricación y un cliente de la ELAN de marketing. Dado que el nombre de ELAN predeterminado es man, el primer cliente está vinculado a ese nombre de ELAN de manera predeterminada. Enumeran al segundo cliente en la base de datos según lo conectado al mkt ELAN. El router3 se configura tal y como se muestra en de este ejemplo:

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
! The first client is not entered in the database, so it is linked to the
! "man" ELAN by default.
interface atm 2/0.1
 ip address 172.16.0.3 255.255.255.0
 lane client tokenring man
! The second client is explicitly entered in the configuration server's 
! database as linked to the "mkt" ELAN.
interface atm 2/0.2
 ip address 172.16.2.3 255.255.255.0
 lane client tokenring mkt

Configuración del Router4

El router 4 tiene el servidor y el BUS para la ELAN de marketing, un cliente para marketing y un cliente para fabricación. Enumeran al primer cliente en la base de datos según lo conectado a los LAN emulados del mkt. No enumeran en la base de datos, sino se conectan al segundo cliente al nombre de ELAN del hombre por abandono. El router 4 se configura como se muestra a continuación:

interface atm 3/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
! The first client is explicitly entered in the configuration server's 
! database as linked to the "mkt" ELAN.
interface atm 3/0.1
 ip address 172.16.2.4 255.255.255.0
 lane server-bus tokenring mkt
 lane client tokenring mkt
! The following client is not entered in the database, so it is linked to the 
! "man" ELAN by default. 
interface atm 3/0.2
 ip address 172.16.0.4 255.255.255.0
 lane client tokenring

Ejemplo de TR-LANE con SRB de 2 puertos

El siguiente ejemplo configura a dos Cisco 7500 Series Router para un Token Ring LANE emulado usando el SRB, tal y como se muestra en de la figura abajo. Este ejemplo no restringe la pertenencia en las LANs emuladas.

Figura 32-Port SRB TR-LANE


Configuración del Router 1

El router 1 contiene el LECS, el servidor y el BUS, además de un cliente. El Router 1 se configura tal y como se muestra en este ejemplo:

hostname Router1
!
! The following lines configure the database cisco_eng.
lane database cisco_eng
 name elan1 server-atm-address 39.020304050607080910111213.00000CA05B41.01
 name elan1 local-seg-id 2048
 default-name elan1
!
interface Ethernet0/0
 ip address 10.6.10.4 255.255.255.0
!
! The following lines configure a configuration server using the cisco_eng database on
! the interface. No IP address is needed since we are using source-route bridging.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database cisco_eng
!
! The following lines configure the server-bus and the client on the subinterface and
! specify source-route bridging information.
interface ATM2/0.1 multipoint
 lane server-bus tokenring elan1
 lane client tokenring elan1
 source-bridge 2048 1 1
 source-bridge spanning
!
! The following lines configure source-route bridging on the Token Ring interface.
interface TokenRing3/0/0
 no ip address
 ring-speed 16
 source-bridge 1 1 2048
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Configuración del router 2

El router 2 sólo contiene un cliente para la ELAN. El router2 se configura como se muestra aquí:

hostname Router2
!
interface Ethernet0/0
 ip address 10.6.10.5 255.255.255.0
!
! The following lines configure source-route bridging on the Token Ring interface.
interface TokenRing1/0
 no ip address
 ring-speed 16
 source-bridge 2 2 2048
 source-bridge spanning
!
! The following lines set up the signalling and ILMI PVCs.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines set up a client on the subinterface and configure
! source-route bridging.
interface ATM2/0.1 multipoint
 ip address 1.1.1.2 255.0.0.0
 lane client tokenring elan1
 source-bridge 2048 2 2
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Ejemplo de TR-LANE con SRB Multipuerto

El siguiente ejemplo configura a dos Cisco 7500 Series Router para un Token Ring LANE emulado usando el SRB, tal y como se muestra en de la figura abajo. Puesto que cada router conecta con tres timbres (los dos Token Rings y el ELAN “timbre”), un Anillo virtual se debe configurar en el router. Este ejemplo no restringe la pertenencia en las LANs emuladas.

‘Figura 4’Token Ring ELAN del Multiport SRB


Configuración del Router 1

El router 1 contiene el LECS, el servidor y el BUS, además de un cliente. El Router 1 se configura tal y como se muestra en este ejemplo:

hostname Router1
!
! The following lines configure the database with the information about the
! elan1 emulated Token Ring LAN.
lane database cisco_eng
 name elan1 server-atm-address 39.020304050607080910111213.00000CA05B41.01
 name elan1 local-seg-id 2048
 default-name elan1
!
! The following line configures virtual ring 256 on the router.
source-bridge ring-group 256
!
interface Ethernet0/0
 ip address 10.6.10.4 255.255.255.0
!
! The following lines configure the configuration server to use the cisco_eng database.
! The Signalling and ILMI PVCs are also configured.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database cisco_eng
!
! The following lines configure the server and broadcast-and-unknown server and a client
! on the interface. The lines also specify source-route bridging information.
interface ATM2/0.1 multipoint
 lane server-bus tokenring elan1
 lane client tokenring elan1
 source-bridge 2048 5 256
 source-bridge spanning
!
! The following lines configure the Token Ring interfaces.
interface TokenRing3/0
 no ip address
 ring-speed 16
 source-bridge 1 1 256
 source-bridge spanning
interface TokenRing3/1
 no ip address
 ring-speed 16
 source-bridge 2 2 256
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Configuración del router 2

El router 2 sólo contiene un cliente para la ELAN. El router 2 se configura del siguiente modo:

hostname Router2
!
! The following line configures virtual ring 512 on the router.
source-bridge ring-group 512
!
interface Ethernet0/0
 ip address 10.6.10.5 255.255.255.0
!
! The following lines configure the Token Ring interfaces.
interface TokenRing1/0
 no ip address
 ring-speed 16
 source-bridge 3 3 512
 source-bridge spanning
interface TokenRing1/1
 no ip address
 ring-speed 16
 source-bridge 4 4 512
 source-bridge spanning
!
! The following lines configure the signalling and ILMI PVCs.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines configure the client. Source-route bridging is also configured.
interface ATM2/0.1 multipoint
 ip address 1.1.1.2 255.0.0.0
 lane client tokenring elan1
 source-bridge 2048 6 512
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Token Ring y ejemplo de los LAN emulados de la Ethernet

Este ejemplo, mostrado en la figura abajo, configura la encaminamiento entre un Token Ring ELAN (trelan) y una Ethernet ELAN (ethelan) en la misma interfaz ATM. El router1 contiene el LECS, un LES y un BUS para cada ELAN, y un cliente para cada ELAN. El router2 contiene a un cliente para trelan (Token Ring); El router 3 contiene un cliente para ethelan (Ethernet).

Figura 5Encaminamiento entre el Token Ring y los LAN emulados de la Ethernet


Configuración del Router 1

El router1 contiene el LECS, un LES y un BUS para cada ELAN, y un cliente para cada ELAN. El Router 1 se configura tal y como se muestra en este ejemplo:

hostname router1
!
! The following lines name and configures the configuration server's database.
! The server addresses for trelan and ethelan and the ELAN ring number for
! trelan are entered into the database. The default ELAN is trelan.
lane database cisco_eng
 name trelan server-atm-address 39.020304050607080910111213.00000CA05B41.01
 name trelan local-seg-id 2048
 name ethelan server-atm-address 39.020304050607080910111213.00000CA05B41.02
 default-name trelan
!
! The following lines enable the configuration server and associate it
! with the cisco_eng database.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database cisco_eng
!
! The following lines configure the tokenring LES/BUS and LEC for trelan
! on subinterface atm2/0.1 and assign an IP address to the subinterface. 
interface ATM2/0.1 multipoint
 ip address 10.1.1.1 255.255.255.0
 lane server-bus tokenring trelan
 lane client tokenring trelan
!
! The following lines configure the Ethernet LES/BUS and LEC for ethelan 
! on subinterface atm2/0.2 and assign an IP address to the subinterface. 
interface ATM2/0.2 multipoint
 ip address 20.2.2.1 255.255.255.0
 lane server-bus ethernet ethelan
 lane client ethernet ethelan
!
! The following lines configure the IGRP routing protocol to enable routing 
! between ELANS.
router igrp 1 
 network 10.0.0.0
 network 20.0.0.0

Configuración del router 2

El router2 contiene a un cliente para trelan (Token Ring). El router 2 se configura del siguiente modo:

hostname router2
!
! The following lines set up the signalling and ILMI PVCs for the interface.
interface ATM2/0
 no ip address
 no keepalive
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines configure a Token Ring LEC on atm2/0.1 and assign
! an IP address to the subinterface.
interface ATM2/0.1 multipoint
 ip address 10.1.1.2 255.255.255.0
 lane client tokenring trelan
!
! The following lines configure the IGRP routing protocol to enable routing 
! between ELANS.
router igrp 1
 network 10.0.0.0
 network 20.0.0.0

Configuración del router3

El router 3 contiene un cliente para ethelan (Ethernet). Se configura el router3 como sigue:

hostname router3
!
! The following lines set up the signalling and ILMI PVCs for the interface.
interface ATM2/0
 no ip address
 no ip mroute-cache
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines configure an Ethernet LEC on atm2/0.1 and assign
! an IP address to the subinterface.
interface ATM2/0.1 multipoint
 ip address 20.2.2.2 255.255.255.0
 lane client ethernet ethelan
!
! The following lines configure the IGRP routing protocol to enable routing 
! between ELANS.
router igrp 1
 network 10.0.0.0
 network 20.0.0.0

Ejemplo de Disabling LANE Flush Process

El siguiente ejemplo muestra una configuración corriente y el proceso LE_FLUSH inhabilitados para todos los LEC:

more system:running-config
Building configuration... 
Current configuration :496 bytes 
! 
! Last configuration change at 11:36:21 UTC Thu Dec 20 2001 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname donner_b 
!
no lane client flush 
! 
interface ATM0 
 atm preferred phy A 
 atm pvc 1 0 5 qsaal 
 atm pvc 2 0 16 ilmi 
 no atm ilmi-keepalive 
! 
interface ATM0.1 multipoint 
 lane config-atm-address 47.009181000000001007385101.0050A2FEBC43.00 
 lane client ethernet 100 elan1 
! 
line con 0 
line vty 0 4 
 no login 
! 
end 

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2012 todos los derechos reservados.