IP : Protocolo de router de reserva activa (HSRP)

Opción de la pista en el ejemplo de configuración HSRPv2

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar un Hot Standby Router Protocol (HSRP) espera para que el grupo del IPv6 (HSRPv2) siga un objeto y cambie la prioridad HSRP en base del estado de objeto.

Cada objeto seguido tiene un número único que se especifique en el comando line interface(cli) de seguimiento. HSRPv2 utiliza este número para seguir un objeto específico. El proceso de seguimiento sondea el objeto seguido para los cambios del valor y envía periódicamente cualquier cambio (como hacia arriba o hacia abajo valores) a HSRPv2, o inmediatamente o después de que un retardo especificado. Este documento utiliza el comando interface de la pista para configurar una interfaz que se seguirá.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

Componentes Utilizados

Las configuraciones en este documento se basan en el router de las Cisco7200 Series que funciona con el Software Release 15.0(1) del ½ del ¿Â de Cisco IOSïÂ.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener información sobre las convenciones sobre documentos.

Configurar

El r2 y el Routers R3 están conectados con el r1 vía una interfaz serial. Las interfaces Fast Ethernet del r2 y del R3 se configuran con el IPv6 del HSRP de una manera tal que el r2 actúe como el router activo y el R3 actúe como el router en espera. En el r2 del router, el proceso de seguimiento se configura para seguir el estado del Line Protocol de la interfaz de la interfaz serial 1/0: En caso de que vaya la interfaz serial S1/0 del r2 abajo, el router R3 cambia su estado de espera al Active.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113553-to-hsrpv2-config-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Configuración del r1 del router
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Serial1/0
 no ip address
 ipv6 address 2010:10:10:10::1/64
 serial restart-delay 0
!
!
interface Serial1/1
 no ip address
 ipv6 address 2011:11:11:11::1/64
 serial restart-delay 0
 !
end

Configuración del r2 del router
!
version 15.0
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
track 1 interface Serial1/0 line-protocol

!--- Tracking process 1 is configured in the router
!--- to track state of the interface line protocol
!--- of serial interface 1/0

!
interface Serial1/0
 no ip address
 ipv6 address 2010:10:10:10::2/64
 serial restart-delay 0
!
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::10/64
 standby version 2
 standby 10 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.

 standby 10 preempt delay minimum 45

!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than all the other
!--- HSRP-configured routers. Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 45 seconds.

 standby 10 track 1 decrement 10

!--- Configures HSRP to track an object and change the Hot Standby
!--- priority on the basis of the state of the object.



!--- In this example,the HSRP tracks the interface s1/0 mentioned
!--- in the track process 1.


!--- Decrement value specified the amount by which the Hot Standby 
!--- priority for the router is decremented (or incremented) when the tracked object 
!--- goes down (or comes back up). The range is from 1 to 255. The default is 10. 

!
end

Configuración del router R3
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::2/64
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::11/64
 standby version 2
 standby 10 ipv6 autoconfig
 standby 10 priority 95
 standby 10 preempt delay minimum 45
!
end

Verificación

Utilice el comando show standby en el r2 y al Routers R3 para verificar la configuración.

R2 del router
R2#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Active
    5 state changes, last state change 00:26:03
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.872 secs
  Preemption enabled, delay min 45 secs
  Active router is local
  Standby router is FE80::C802:AFF:FE10:38, priority 95 (expires in 8.048 sec)
  Priority 100 (default 100)
    Track object 1 state Up decrement 10
  Group name is "hsrp-Fa2/0-10" (default)

Router R3
R3#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Standby
    4 state changes, last state change 00:26:25
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.176 secs
  Preemption enabled, delay min 45 secs
  Active router is FE80::C801:14FF:FEF4:38, priority 100 (expires in 9.888 sec)
    MAC address is ca01.14f4.0038
  Standby router is local
  Priority 95 (configured 95)
  Group name is "hsrp-Fa2/0-10" (default)

Para visualizar la información de seguimiento, utilice el comando show track en el r2 del router.

R2 del router
R2#show track 1
Track 1
  Interface Serial1/0 line-protocol
  Line protocol is Up
    3 changes, last change 00:28:39
  Tracked by:
    HSRP FastEthernet2/0 10

!--- Displays the information about the objects that 
!--- are tracked by tracking process 1.

R2#show track int brief
Track   Object                           Parameter        Value Last Change
1       interface   Serial1/0            line-protocol    Up    00:31:19

!--- Displays the information about the tracked interface.

En caso de que vaya el router activo (r2 en este ejemplo) abajo, el router en espera cambia su estado inmediatamente al Active tal y como se muestra en de esta tabla:

Cuando el router activo (el r2) va abajo de…
R2 del router
R2(config)#interface s1/0
R2(config-if)#shut
R2(config-if)#
*May 21 20:56:54.223: %TRACKING-5-STATE: 1 interface Se1/0 line-protocol Up->Down
R2(config-if)#
*May 21 20:56:56.203: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down
*May 21 20:56:57.203: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R2(config-if)#
*May 21 20:57:43.087: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Active -> Speak
R2(config-if)#
*May 21 20:57:54.479: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Speak -> Standby


!--- When the interface goes down, the active router changes 
!--- its state to Standby.

Router R3
R3#
*May 21 20:56:53.419: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Standby-> Active


!--- The standby router is now the active router.
 

R3#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Active
    5 state changes, last state change 00:02:32
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.080 secs
  Preemption enabled, delay min 45 secs
  Active router is local
  Standby router is FE80::C801:14FF:FEF4:38, priority 90 (expires in 9.664 sec)
  Priority 95 (configured 95)
  Group name is "hsrp-Fa2/0-10" (default)

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 113553