IP : Protocolo de puerta de enlace fronteriza (BGP)

Ejemplo de configuración del BGP Prefix-Based Outbound Route Filtering del IPv6

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra usando el IPv6 que le ayude a configurar el BGP Prefix-Based Outbound Route Filtering. Esta característica utiliza el filtro de la ruta de salida BGP (ORF) envía y recibe las capacidades que minimizan el número de actualizaciones de BGP enviadas entre el Routers del par. La configuración de esta característica puede ayudar en la filtración hacia fuera de las actualizaciones de ruteo indeseadas en la fuente.

prerrequisitos

Requisitos

Aseegurese que usted cumple estos requisitos antes de que usted intente esta configuración:

  • Tenga una comprensión del Routing Protocol BGP y de su operación

  • Tenga una comprensión del esquema de direccionamiento del IPv6

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Las configuraciones en este documento se basan en el Cisco 7200 Series Router con el Software Release 15.0(1) del½ del¿Â del Cisco IOSïÂ.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En este ejemplo, el r1 del router es hacer publicidad-prefijo configurado basado ORF envía las capacidades al r2 del router. En el router del otro extremo el r2 se configura para hacer publicidad del ORF basado en prefijo recibe las capacidades al r1 del router. Antes de que la característica del BGP Prefix-Based Outbound Route Filtering se pueda habilitar para enviar o para recibir los avisos basados en prefijo ORF, las sesiones de peer BGP deben ser en servicio y las capacidades BGP ORF se deben habilitar en cada router participante antes de un router.

Este documento utiliza el comando del prefijo-filtro orf del vecino para habilitar la capacidad de la lista de prefijos ORF en el router. Este comando fue introducido en el Cisco IOS Software Release 12.0(11)ST.

Nota: Utilice la herramienta de búsqueda de comandos (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113504-ipv6-bgp-outbound-prefixfilter-01.gif

Configuraciones de Ejemplo

En este documento, se utilizan estas configuraciones:

R1 del router
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback1
 no ip address
 ipv6 address 1111::1/128
!
!
interface Loopback2
 no ip address
 ipv6 address 2222::1/128
! 
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::1/64
 serial restart-delay 0
!
!
router bgp 6501
 no synchronization
 no bgp default ipv4-unicast
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 capability orf prefix-list send
  neighbor 2011:11:11:11::2 prefix-list FILTER_IPv6 in
 exit-address-family
!
!
ipv6 prefix-list FILTER_IPv6 seq 10 permit 1111::1/128
ipv6 prefix-list FILTER_IPv6 seq 20 permit 2222::1/128
!
!
end

R2 del router
!
hostname R2
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
 !
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::2/64
 serial restart-delay 0
!
!
router bgp 6502
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::1 remote-as 6501
 neighbor 2011:11:11:11::1 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6

  network 1010::1/128
  network 2020::1/128
  neighbor 2011:11:11:11::1 activate
  neighbor 2011:11:11:11::1 capability orf prefix-list receive
  neighbor 2011:11:11:11::1 prefix-list R2_list in
 exit-address-family
!
ipv6 prefix-list R2_list seq 10 permit 1010::1/128
ipv6 prefix-list R2_list seq 20 permit 2020::1/128
!
end

Escenario 1: Rutas de filtro basadas en la lista de prefijo con las expresiones

En este escenario, un Loopback Address 1000::1/45 se configura en el r1 bajo el Interface Loopback 0. Una lista de prefijo se crea para permitir cualquier ruta que sea mayor que la longitud del prefijo:: /64.

Nota: El r2 de la configuración del router sigue siendo lo mismo que previamente como se muestra dado y del r1 los cambios de configuración aquí. Los IP Addresses en este Routers siguen siendo lo mismo.

R1 del router

!--- Output omitted.
 
!
interface Loopback0
 no ip address
 ipv6 address 1000::1/45
 !

!--- Output omitted.

  router bgp 6501
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  network 1000::1/45
  network 1111::1/128
  network 2222::1/128
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 prefix-list IPV6-LONG in

!--- Applies the prefix-list and filters 
!--- the incoming updates from the neighbor 2011:11:11:11::2.

 exit-address-family
!
ipv6 prefix-list IPV6-LONG description Match any prefix longer than /64
ipv6 prefix-list IPV6-LONG seq 1 permit ::/0 ge 64

!--- seq 1 permit ::/0 ge 64 permits anything
!--- that is ge /64 subnet mask.

!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Utilizan a estos comandos show de verificar la configuración:

Verifique el BGP Prefix-Based Outbound Route Filtering del IPv6 configurado en el modo de envío

En el r1 del router:

show running-config | pida el BGP
router bgp 6501
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 capability orf prefix-list send

!--- Indicates that the neighbor 2011:11:11:11::2 
!--- is configured with the prefix-based 
!--- ORF feature in send mode.

vecinos del unicast del show bgp ipv6
R1#show bgp ipv6 unicast neighbors 2011:11:11:11::2
BGP neighbor is 2011:11:11:11::2,  remote AS 6502, external link
  BGP version 4, remote router ID 2.2.2.2
  Session state = Established, up for 01:30:36
  Last read 00:00:44, last write 00:00:42, hold time is 180, keepalive interval is 60 seconds 
 BGP multisession with 2 sessions (2 established), first up for 01:31:26
  Neighbor sessions:
    2 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new) on session 1, 2
    Four-octets ASN Capability: advertised and received on session 1, 2
    Address family IPv4 Unicast: advertised and received
    Address family IPv6 Unicast: advertised and received

!--- Output omitted.

 For address family: IPv6 Unicast
  Session: 2011:11:11:11::2 session 2
  BGP table version 1, neighbor version 1/0
  Output queue size : 0
  Index 2
  session 2 member
  2 update-group member
  AF-dependant capabilities:
    Outbound Route Filter (ORF) type (128) Prefix-list:

!--- Shows that the neighbor 2011:11:11:11::2 
!--- is configured with the prefix-based 
!--- ORF feature in send mode.

      Send-mode: advertised
      Receive-mode: received
  Outbound Route Filter (ORF): sent;
  Incoming update prefix filter list is FILTER_IPv6
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          4
    Prefixes Total:                 0          0
    Implicit Withdraw:              1          0
    Explicit Withdraw:              1          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    
  
!--- Output omitted.

Verifique el BGP Prefix-Based Outbound Route Filtering del IPv6 configurado adentro reciben el modo

En el r2 del router:

show running-config | pida el BGP
router bgp 6502
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::1 remote-as 6501
 neighbor 2011:11:11:11::1 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  network 1010::1/128
  network 2020::1/128
  neighbor 2011:11:11:11::1 activate
  neighbor 2011:11:11:11::1 capability orf prefix-list receive

!--- Indicates that the neighbor 2011:11:11:11::1 
!--- is configured with the prefix-based 
!--- ORF feature in receive mode.

vecinos del unicast del show bgp ipv6
R2#show bgp ipv6 unicast nei 2011:11:11:11::1
BGP neighbor is 2011:11:11:11::1,  remote AS 6501, external link
  BGP version 4, remote router ID 1.1.1.1
  Session state = Established, up for 01:47:11
  Last read 00:00:44, last write 00:00:32, hold time is 180, keepalive interval is 60 seconds  
multisession with 2 sessions (2 established), first up for 01:48:02
  Neighbor sessions:
    2 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new) on session 1, 2
    Four-octets ASN Capability: advertised and received on session 1, 2
    Address family IPv4 Unicast: advertised and received
    Address family IPv6 Unicast: advertised and received
    Multisession Capability: advertised and received
 
!--- Output omitted.


 For address family: IPv6 Unicast
  Session: 2011:11:11:11::1 session 2
  BGP table version 3, neighbor version 3/0
  Output queue size : 0
  Index 3
  session 2 member
  3 update-group member
  AF-dependant capabilities:
    Outbound Route Filter (ORF) type (128) Prefix-list:

!--- Shows that the neighbor 2011:11:11:11::1 
!--- is configured with the prefix-based 
!--- ORF feature in receive mode.

      Send-mode: received
      Receive-mode: advertised
  Outbound Route Filter (ORF): received (2 entries)
Incoming update prefix filter list is R2_list
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          5
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              2          0
    

!--- Output omitted.
 

Verifique el escenario 1: Rutas de filtro basadas en la lista de prefijo con las expresiones

Publique el comando bgp de la show ipv6 route en el r1 del router para visualizar el contenido actual de la tabla de BGP Routing del IPv6.

BGP de la show ipv6 route
En el r1 del router:
R1#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   1010::1/128 [20/0]
     via 2011:11:11:11::2
B   2020::1/128 [20/0]
     via 2011:11:11:11::2

!--- In this ouput, 1000::1/45 is not 
!--- displayed because the network is lesser 
!--- than ::/64 prefix and its filtered. 

Utilice el mostrar información del comando de la lista de prefijo del IPv6 de la demostración para sobre las entradas de una lista de prefijos del IPv6 o de lista de prefijos del IPv6.

muestre la lista de prefijo del IPv6
En el r1 del router:
 
R1#show ipv6 prefix-list detail

Prefix-list with the last deletion/insertion: IPV6-LONG
ipv6 prefix-list IPV6-LONG:
   Description: Match any prefix longer than /64
   count: 1, range entries: 1, sequences: 1 - 1, refcount: 3
   seq 1 permit ::/0 ge 64 (hit count: 14, refcount: 1)

R1#show ipv6 prefix-list summary

Prefix-list with the last deletion/insertion: IPV6-LONG
ipv6 prefix-list IPV6-LONG:
   Description: Match any prefix longer than /64
   count: 1, range entries: 1, sequences: 1 - 1, refcount: 3

R1#show ipv6 prefix-list  IPV6-LONG

ipv6 prefix-list IPV6-LONG: 1 entries
   seq 1 permit ::/0 ge 64


Información Relacionada


Document ID: 113504