Switches : Switches Cisco Nexus de la serie 7000

Del nexo del 7000 Series Switch ejemplo de configuración ERSPAN

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar una sesión remota encapsulada del analizador de puertos del switch (ERSPAN) en un Nexus 7000 Series Switch que monitorea el tráfico entre los puertos Ethernet en dos Nexus 7000 Series Switches diferentes.

prerrequisitos

Requisitos

Aseegurese que usted cumple estos requisitos antes de que usted intente esta configuración:

  • Tenga conocimiento básico de la configuración en los 7000 Series Switch del nexo

  • Tenga conocimiento básico de ERSPAN

Componentes Utilizados

La información en este documento se basa en el 7018 Series Switch del nexo en la versión del Software Cisco NX-OS 5.1(3).

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Antecedentes

Sobre ERSPAN

  • ERSPAN habilita la supervisión remota de los switches múltiples a través de su red.

  • ERSPAN transporta el tráfico duplicado de los puertos de origen de diverso Switches al puerto destino, en donde el analizador de red ha conectado.

  • El tráfico se encapsula en el switch de origen y se transfiere al switch de destino, donde está decapsulated y después enviado el paquete al puerto destino.

  • ERSPAN consiste en ERSPAN una sesión de la fuente, el Generic Routing Encapsulation (GRE) del routable ERSPAN - tráfico encapsulado, y ERSPAN una sesión del destino.

  • Usted puede configurar ERSPAN las sesiones de la fuente y las sesiones del destino sobre diverso Switches por separado.

  • ERSPAN no hace monitorean ninguna paquetes que sean generados por el supervisor, sin importar su fuente.

ERSPAN fuentes

  • Las interfaces de las cuales el tráfico puede ser monitoreado se llaman ERSPAN las fuentes.

  • Usted puede monitorear todos los paquetes para el puerto de origen se recibe que (ingreso), transmitido (salida), o bidireccional (ambos).

  • ERSPAN las fuentes incluyen los puertos de origen, los VLA N de la fuente, o la fuente VSAN. Cuando un VLA N se especifica como ERSPAN fuente, todas las interfaces soportadas en el VLA N son ERSPAN fuentes.

ERSPAN destinos

  • Los puertos destino reciben el tráfico copiado ERSPAN de las fuentes.

  • El puerto destino es un puerto que fue conectado con el dispositivo tal como dispositivo de SwitchProbe o la otra sonda o dispositivo de seguridad del Monitoreo remoto (RMON) que pueden recibir y analizan los paquetes copiados del puerto solo o de la fuente múltiple.

  • Los puertos destino no participan en ninguna instancia del árbol de expansión o ninguna protocolos de la capa 3.

Configurar

Este ejemplo de configuración utiliza un puerto de origen en el 7000 Series Switch 1 del nexo y un puerto destino en otro 7000 Switch del nexo, en donde el analizador de red ha conectado. Hay un link Ethernet entre ambos el Switches, tal y como se muestra en del diagrama.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113480-erspan-nexus-7k-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

7000 Switch 1 del nexo
switch_1#configure terminal


!--- Configures an ERSPAN source session.

switch_1(config)#monitor session 48 type erspan-source

!--- Configure the sources and traffic direction.

switch_1(config-erspan-src)#source interface Ethernet2/10 both

!--- Configure the destination IP address in the ERSPAN session.

switch_1(config-erspan-src)#destination ip 10.11.11.3

!--- Configure the ERSPAN ID.

switch_1(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_1(config-erspan-src)#vrf default

!--- Enable the ERSPAN source session (by default the session is 
!--- in shutdown state).

switch_1(config-erspan-src)#no shut
switch_1(config-erspan-src)#exit


!--- Configure the ERSPAN global origin IP address.

switch_1(config)#monitor erspan origin ip-address 10.254.254.21 global



!--- Configure the IP address for loopback interface, which is used
!--- as source of the ERSPAN traffic.

switch_1(config)#interface loopback1
switch_1(config-if)#ip address 10.254.254.21/32
switch_1(config-if)#exit

switch_1(config)#interface Ethernet1/1
switch_1(config-if)#switchport
switch_1(config-if)#switchport mode trunk
switch_1(config-if)#no shutdown
switch_1(config-if)#exit

switch_1(config)#feature interface-vlan
switch_1(config)#interface Vlan 11
switch_1(config-if)#ip address 10.11.11.2/29
switch_1(config-if)#no ip redirects
switch_1(config-if)#no shutdown
switch_1(config-if)#exit


!--- Save the configurations in the device.

switch_1(config)#copy running-config startup-config
Switch_1(config)#exit

7000 Switch 2 del nexo
switch_2#configure terminal


!--- Configures an ERSPAN destination session.

switch_2(config)#monitor session 47 type erspan-destination

!--- Configures the source IP address.

switch_2(config-erspan-src)#source ip 10.11.11.3

!--- Configures a destination for copied source packets.

switch_2(config-erspan-src)#destination interface Ethernet2/34

!--- Configure the ERSPAN ID.

switch_2(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_2(config-erspan-src)#vrf default

!--- Enable the ERSPAN destination session (by default the session is 
!--- in shutdown state).

switch_2(config-erspan-src)#no shut
switch_2(config-erspan-src)#exit

switch_2(config)#interface Ethernet2/34
switch_2(config-if)#switchport monitor
switch_2(config-if)#exit

switch_2(config)#feature interface-vlan
switch_2(config)#interface Vlan 11
switch_2(config-if)#ip address 10.11.11.3/29
switch_2(config-if)#no ip redirects
switch_2(config-if)#no shutdown
switch_2(config-if)#exit

switch_2(config)#interface Ethernet1/2
switch_2(config-if)#switchport
switch_2(config-if)#switchport mode trunk
switch_2(config-if)#no shutdown
switch_2(config-if)#exit


!--- Save the configurations in the device.

switch_2(config)#copy running-config startup-config
Switch_2(config)#exit

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Éstos son algunos ERSPAN de los Comandos de verificación:

  • Utilice el comando show monitor para visualizar el estatus ERSPAN de las sesiones:

    switch_1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    4        up           The session is up
  • Utilice el comando del [session session_number] de la sesión de monitoreo de la demostración para visualizar ERSPAN la configuración de la sesión:

    switch_1# show monitor session 48
       session 48
    ---------------
    type              : erspan-source
    state             : up
    erspan-id         : 902
    vrf-name          : default
    acl-name          : acl-name not specified
    ip-ttl            : 255
    ip-dscp           : 0
    destination-ip    : 10.11.11.3
    origin-ip         : 10.254.254.21 (global)
    source intf       :
        rx            : Eth2/10
        tx            : Eth2/10
        both          : Eth2/10
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
  • Utilice el comando all de la sesión de monitoreo de la demostración para visualizar todos ERSPAN configuración de las sesiones en el dispositivo.

  • Utilice el comando monitor de los ejecutar-config de la demostración para visualizar la configuración del funcionamiento ERSPAN:

    switch_1# show running-config monitor
    
    !Command: show running-config monitor
    !Time: Thu Apr 19 10:15:33 2012
    
    version 5.1(3)
    monitor session 48 type erspan-source
      erspan-id 902
      vrf default
      destination ip 10.11.11.3
      source interface Ethernet2/10 both
      no shut
    
    monitor erspan origin ip-address 10.254.254.21 global
  • Utilice el comando monitor de los lanzamiento-config de la demostración para visualizar ERSPAN la configuración de inicio.


Información Relacionada


Document ID: 113480