IP : IP versión 6 (IPv6)

Redistribuya las rutas OSPFv3 en el ejemplo de la configuración BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo de redistribuir las rutas abiertas del trayecto más corto primero versión 3 (OSPFv3) adentro al Multiprotocol BGP para el IPv6. OSPFv3 se amplía en la versión 2 OSPF para proporcionar el soporte para el IPv6 que rutea los prefijos y los direccionamientos más de gran tamaño del IPv6. Multiprotocol BGP es un BGP mejorado que transporta información de enrutamiento para diversas familias de direcciones del protocolo de capa de red, como la familia de direcciones de IPv6 y para rutas de IP Multicast.

prerrequisitos

prerrequisitos

Aseegurese que usted cumple estos requisitos antes de que usted intente esta configuración:

Versiones de hardware y de software

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Las configuraciones en este documento se basan en el Cisco 3700 Series Router con el Software Release 12.4 (15)T1 del½ del¿Â del Cisco IOSïÂ.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En este ejemplo, el r2 del Routers y el R3 están conectados a través de una interfaz serial y configurados con el Multiprotocol BGP. El r2 del Routers y el R3 comunican con su r1 de los routeres locales y R4 usando OSPFv3. Los Loopback Address se crean en el Routers para generar las redes. El r2 del Routers y el R3, que ejecutan el BGP y OSPFv3, utilizan el comando redistribute para redistribuir las rutas OSPFv3 adentro al BGP. Configuran a todo el Routers con los direccionamientos del IPv6.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113453-redis-ospfv3-bgp-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

R1 del router
!
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback0
 no ip address
 ipv6 address 2222::1/128
 ipv6 ospf 1 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::1/64
 ipv6 ospf 1 area 0

!--- Associates the Interface Fa0/0 to area 0.

!
ipv6 router ospf 1
 router-id 1.1.1.1

!--- Router R1 uses 1.1.1.1 as router ID.

 log-adjacency-changes
!
end

R2 del router
!
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2010::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 2011::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 5050:55:55:55::55/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring "no bgp default ipv4-unicast" only 
!--- IPv4 will be advertised.

 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 65000
 neighbor 3030:1:1:1::11 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::11 activate
  network 5050:55:55:55::55/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2

!--- This redistributes all OSPF routes into BGP.

  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
!
end

Router R3
!
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1111::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 1112::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 6060:66:66:66::66/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 65000
 neighbor 3030:1:1:1::10 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::10 activate
  network 6060:66:66:66::66/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2
  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
end

Router R4
!
version 12.4
!
hostname R4
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3333::1/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::1/64
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
!
end

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Utilizan a estos comandos show de verificar la configuración:

Verifique la configuración OSPFv3

Para verificar que OSPFv3 esté configurado correctamente, utilice el comando ospf de la show ipv6 route en el r1 del Routers y el R4.

OSPF de la show ipv6 route
En el r1 del router
 
R1#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  2010::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
OI  2011::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
En el router R4
 
R4#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  1111::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0
OI  1112::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0

Verifique la configuración BGP

Para verificar si las rutas OSPFv3 estén redistribuidas adentro al BGP, utilice el comando bgp de la show ipv6 route en el r2 del Routers y el R3.

BGP de la show ipv6 route
En el r2 del router
R2#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1111::1/128 [200/0]
     via 3030:1:1:1::11
B   1112::1/128 [200/0]
     via 3030:1:1:1::11
B   2020:1:1:1::/64 [200/0]
     via 3030:1:1:1::11
B   3333::1/128 [200/10]
     via 3030:1:1:1::11

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   6060:66:66:66::66/128 [200/0]
     via 3030:1:1:1::11
En el router R3
R3#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:1:1:1::/64 [200/0]
     via 3030:1:1:1::10
B   2010::1/128 [200/0]
     via 3030:1:1:1::10
B   2011::1/128 [200/0]
     via 3030:1:1:1::10
B   2222::1/128 [200/10]
     via 3030:1:1:1::10

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   5050:55:55:55::55/128 [200/0]
     via 3030:1:1:1::10


Información Relacionada


Document ID: 113453