IP : Protocolo de puerta de enlace fronteriza (BGP)

Ejemplo de configuración del reflector de la ruta BGP del IPv6

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra usando el IPv6 que le ayude a entender la característica del reflector de ruta (RR) en el Border Gateway Protocol (BGP). De forma predeterminada, las rutas recibidas de un peer iBGP no se envían a otro peer iBGP a menos que se forme una configuración de interconexión total entre todos los routers BGP dentro de un AS. Esto da lugar a problemas de ampliación. El uso de reflectores de ruta BGP conduce a niveles mucho más altos de escalabilidad.

Configurar el reflector de ruta permite que un router haga publicidad o refleje de las rutas aprendidas iBGP a otros interlocutores iBGP. El router reputa un reflector de ruta cuando está configurado con el comando neighbor route-reflector-client y los vecinos en quienes el comando señala son los clientes de ese RR.

prerrequisitos

Requisitos

Aseegurese que usted cumple estos requisitos antes de que usted intente esta configuración:

  • Tenga una comprensión del Routing Protocol BGP y de su operación

  • Tenga una comprensión del esquema de direccionamiento del IPv6

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Las configuraciones en este documento se basan en el Cisco 3700 Series Router con el Software Release 12.4 (15)T1 del � del Cisco IOS.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En este ejemplo, configuran al router A pues el RR y el Routers RRClient1 y RRClient2 son los clientes del router A. Configuran a todo el Routers para estar en el AS100, aunque el Routers no tenga configuración de la interconexión total. En lugar, utiliza la característica BGP RR para comunicar con uno a.

Nota: Utilice la herramienta de búsqueda de comandos (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113419-ipv6-bgp-rr-01.gif

Configuraciones de Ejemplo

En este documento, se utilizan estas configuraciones:

router A
hostname Router-A
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2011:11:11:11::11/128
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2011:12:12:12::1/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2011:13:13:13::1/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:22:22:22::22 remote-as 100
 neighbor 2011:22:22:22::22 update-source Loopback0
 neighbor 2011:33:33:33::33 remote-as 100
 neighbor 2011:33:33:33::33 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:22:22:22::22 activate
  neighbor 2011:22:22:22::22 route-reflector-client

!--- Configures the router RRClient1
as route reflector client!


  neighbor 2011:33:33:33::33 activate
  neighbor 2011:33:33:33::33 route-reflector-client

!--- Configures the router RRClient2
as route reflector client!

 exit-address-family
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 1.1.1.1

!--- Router ID of the route reflector router A!

 log-adjacency-changes
!
end

RRClient1
hostname RR-Client1
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2011:22:22:22::22/128
 ipv6 ospf 10 area 0
!
interface Loopback10
 no ip address
 ipv6 address 1010:10:10:10::10/128
!
interface Serial0/0
 no ip address
 ipv6 address 2011:12:12:12::2/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 2.2.2.2

!--- Router ID of the RRClient1

 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::11 remote-as 100
 neighbor 2011:11:11:11::11 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:11:11:11::11 activate
  network 1010:10:10:10::10/128
 exit-address-family
!
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
!
end

RRClient2
hostname RR-Client2
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
!
interface Loopback0
 no ip address
 ipv6 address 2011:33:33:33::33/128
 ipv6 ospf 10 area 0
!
interface Loopback20
 no ip address
 ipv6 address 2020:20:20:20::20/128
!
interface Serial0/0
 no ip address
 ipv6 address 2011:13:13:13::2/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 3.3.3.3

!--- Router ID of the RRClient2

 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::11 remote-as 100
 neighbor 2011:11:11:11::11 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:11:11:11::11 activate
  network 2020:20:20:20::20/128
 exit-address-family
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Utilizan a estos comandos show de verificar la configuración:

En los clientes RR:

BGP de la show ipv6 route
En RRClient1
 
RRClient1#sh ipv6 route bgp
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2020:20:20:20::20/128 [200/0]
     via 2011:33:33:33::33

!--- The iBGP route from RRClient2 is reflected


RRClient1#ping 2011:33:33:33::33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2011:33:33:33::33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/32 ms

!--- Ping to the RRClient2 from RRClient1 is successful

En RRClient2
 
RRCLlient2#sh ipv6 route bgp
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:10:10:10::10/128 [200/0]
     via 2011:22:22:22::22

!--- The iBGP route from RRClient1 is reflected

RRCLlient2#ping 1010:10:10:10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1010:10:10:10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/50/76 ms

!--- Ping to the RRClient1 from RRClient2 is successful

En el router A:

prefijo del IPv6 del unicast del show bgp ipv6
RouterA#sh bgp ipv6 unicast 1010:10:10:10::10/128
BGP routing table entry for 1010:10:10:10::10/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
        1
  Local, (Received from a RR-client)

!--- Indicates that the route was received from a route-reflector
 client router RRClient1

    2011:22:22:22::22 (metric 64) from 2011:22:22:22::22 (2.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, internal, best
RouterA#show bgp ipv6 unicast 2020:20:20:20::20/128
BGP routing table entry for 2020:20:20:20::20/128, version 2
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
        1
  Local, (Received from a RR-client)

!--- Indicates that the route was received from a route-reflector
client router RRClient2

    2011:33:33:33::33 (metric 64) from 2011:33:33:33::33 (3.3.3.3)
      Origin IGP, metric 0, localpref 100, valid, internal, best

En los clientes RR:

Siempre que se refleje un IBGP Route (es decir, propagado a otro iBGP el par), el router que implementa el reflector de ruta (en nuestro caso, el router A) añade 2 atributos al final del fichero NON-transitivos:

  • ID del originador:

    Esto es un atributo BGP opcional NON-transitivo. El IBGP Route reflejado tendrá el Router ID del par del iBGP de quien la ruta se ha recibido como su ID del originador. En nuestro ejemplo, la ruta 2020:20:20:20::20/128 que es del RRClient 2 es reflejada por el router A (RR), a RRClient1. Como consecuencia, esta ruta tendrá el Router ID del RRClient2 (Router ID: 3.3.3.3) como su ID del originador.

  • CLUSTER-ID:

    Esto es un atributo BGP opcional NON-transitivo. El IBGP Route reflejado tendrá el Router ID del RR como su Cluster-ID, si el valor cluster-identificación no se configura. En nuestro ejemplo, la ruta 2020:20:20:20::20/128 no tiene la cluster-identificación configurada y por lo tanto el Router ID (Router ID: 1.1.1.1) del router A (RR) será el Cluster-ID.

unicast ipv6-prefix del show bgp ipv6
En RRClient1
 
show bgp ipv6 unicast 2020:20:20:20::20/128
BGP routing table entry for 2020:20:20:20::20/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    2011:33:33:33::33 (metric 128) from 2011:11:11:11::11 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 3.3.3.3, Cluster list: 1.1.1.1

!--- Originator ID 3.3.3.3 is the router id of the RRClient2 from
which the route is received!


!--- Similarly, Cluster ID 1.1.1.1 is the router ID of the
router reflector Router A!

En RRClient2
 
show bgp ipv6 unicast 1010:10:10:10::10/128
BGP routing table entry for 1010:10:10:10::10/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    2011:22:22:22::22 (metric 128) from 2011:11:11:11::11 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 2.2.2.2, Cluster list: 1.1.1.1

!--- Originator ID 2.2.2.2 is the router ID of the RRClient1 from 
which the route is received!


!--- Similarly, Cluster ID 1.1.1.1 is the router ID of the
router reflector Router A!

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113419