IP : IP versión 6 (IPv6)

Implemente las Static rutas para el ejemplo de configuración del IPv6

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar las Static rutas para el IPv6. Las Static rutas son rutas manualmente configuradas que define el trayecto explícito entre dos dispositivos. En el caso del cambio de la topología en una red, las Static rutas no se ponen al día automáticamente como la del los protocolos dinámicos y deben ser configuradas de nuevo manualmente. Las Static rutas son útiles para redes más pequeñas que tiene solamente una trayectoria a las redes externas.

La desventaja principal del uso de las Static rutas es la falta de configuración automática en caso de los cambios de la topología. Las Static rutas también se implementan para proporcionar la Seguridad para los tipos determinados de tráficos a otras redes que necesiten más control. Las limitaciones que se consideran en el uso de las Static rutas son la falta de Redundancia y en redes más grandes que la reconfiguración manual de las rutas puede convertirse en un consumo de recursos gasto administrativo grande.

Utilice el comando route del IPv6 para configurar el Static Routing. Observe que antes de que usted configure al router con una ruta estática del IPv6, usted debe habilitar la expedición de los paquetes del IPv6 con el comando del Unicast Routing del IPv6 en el modo de configuración global.

prerrequisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimiento del Static Routing del IPv4

  • Conocimiento del esquema de direccionamiento del IPv6

Componentes Utilizados

La información en este documento se basa en el Cisco 3700 Series Router en el Software Release 12.4 (15)T 13 del½ del¿Â del Cisco IOSïÂ.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Aquí está un link a un vídeo, disponible en la comunidad del soporte de Ciscoleavingcisco.com , que demuestra cómo configurar las Static rutas para la red del IPv6 en el Routers del Cisco IOS:

Configuración de las Static rutas para el IPv6 en el Cisco IOS leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-02.gif

R1 del router
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::1/126
!
ip forward-protocol nd
!
ipv6 route 2001::/126 2000::2
ipv6 route 2020::1/128 2000::2
ipv6 route 3030::1/128 2000::2

!--- Static routes are configured in router R1, 
!--- to reach the networks in router R2 and R3.
!--- This is done when you specify 
!--- the next-hop address, which in this case is
!--- 2000::2 from which the output interface 
!--- is automatically derived.


!
end

R2 del router
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::2/126
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::1/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2000::1
ipv6 route 3030::1/128 2001::2

!--- Static routes are configured to reach
!--- routers R1 and R3 loopback address when you 
!--- specify the corresponding interface address.

!
end

Router R3
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback3
 no ip address
 ipv6 address 3030::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::2/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2001::1
ipv6 route 2000::/126 2001::1
ipv6 route 2020::1/128 2001::1

!--- For router 3, to reach R1 and R2, 
!--- static routes are configured when you 
!--- mention 2001::1 as the next-hop address.

!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Utilice el comando static de la show ipv6 route para visualizar el contenido de la tabla de ruteo del IPv6, y la salida es demostración abajo:

parásitos atmosféricos de la show ipv6 route
En el r1 del router
R1#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   2001::/126 [1/0]
     via 2000::2
S   2020::1/128 [1/0]
     via 2000::2
S   3030::1/128 [1/0]
     via 2000::2

!--- Displays the static routes learnt by router R1 through 2000::2.

En el router R3
R3#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   1010::1/128 [1/0]
     via 2001::1
S   2000::/126 [1/0]
     via 2001::1
S   2020::1/128 [1/0]
     via 2001::1

!--- Displays the static routes learnt by router R3 through 2001::1.

El r1 del router tiene las rutas al r2 del router y el R3, por lo tanto, r1 del router debe poder hacer ping el Loopback Address y al router R3 del router R2'. Utilice el comando ping para verificar lo mismo.

En el r1 del router
Hacer ping el Loopback Address del router R2'
R1#ping 2020::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2020::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/36/104 ms

!--- Router R1 is successfully able to ping 
!--- router R2's loopback address.

Hacer ping al router R3
R1#ping 2001::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/40/116 ms

R1#ping 3030::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3030::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/84 ms

!--- Similarly R1 is also able to reach R3,
!--- for example, ping to R3's interface address
!--- and loopback address from router R1 is successful.

Nota: El router R3 puede también alcanzar semejantemente el direccionamiento 2000::1 del Routers R1 Fa0/0 y su Loopback Address 1010::1.

Utilice el comando static del IPv6 de la demostración para visualizar el contenido actual de la tabla de ruteo y utilizar el sintaxis del detalle para visualizar más información útil, que se discute en este ejemplo:

muestre los parásitos atmosféricos del IPv6
En el r1 del router
R1#show ipv6 static
IPv6 Static routes
Code: * - installed in RIB
* 2001::/126 via nexthop 2000::2, distance 1
* 2020::1/128 via nexthop 2000::2, distance 1
* 3030::1/128 via nexthop 2000::2, distance 1

!--- Displays the routes that are installed in 
!--- the IPv6 Routing Information Base(RIB) marked with *!

Cuando se especifica la palabra clave del detalle, se visualiza la información adicional. Esto es una muestra de la salida:

muestre el detalle de los parásitos atmosféricos del IPv6
En el r2 del router
R2#show ipv6 static detail
IPv6 Static routes
Code: * - installed in RIB
* 1010::1/128 via nexthop 2000::1, distance 1
     Resolves to 1 paths (max depth 1)

!--- Displays the output path set, and maximum 
!--- resolution depth, which in this case is 1.

     via FastEthernet0/0
* 3030::1/128 via nexthop 2001::2, distance 1
     Resolves to 1 paths (max depth 1)
     via FastEthernet0/1

!--- Displays that the route is received through 
!--- the next-hop 2000::1 through interface fa0/0.

Nota: En caso de las rutas inválidas, se visualiza esta información:

  • Para las rutas recurrentes inválidas, la razón por la que la ruta es inválida.

  • Para inválido dirija o completamente las rutas especificado, la razón por la que la ruta es inválida.


Información Relacionada


Document ID: 113361