IP : Routing IP

Redistribuya las redes conectadas en el OSPF con la palabra clave de subred

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (29 Noviembre 2011) | Comentarios


Contenido


Introducción

Este documento describe el comportamiento de la redistribución de los Routeconectad en el Open Shortest Path First (OSPF). Hay dos comportamientos que dependen encendido si la palabra clave de subred está dada o no cuando usted redistribuye las redes conectadas. En el general, cuando se utiliza el comando redistribute para redistribuir routers dentro de un dominio OSPF, el router se convierte automáticamente en un ASBR (Autonomous System Boundary Router). Por abandono cuando las rutas de los protocolos se redistribuyen adentro al OSPF con la palabra clave conectada, estas rutas se convierten en tan externas redistribuido al COMO y solamente se redistribuyen las rutas que no son subnetted. En usted incluya la palabra clave de las subredes, el OSPF redistribuye las rutas, que son subnetted. El proceso utiliza 20 como el valor por defecto métrico. Esto sucede cuando no es métrico es especificada por el uso de la palabra clave del tipo métrico.

Prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimiento IP general de rutear

  • Conocimiento de los conceptos y de los términos del OSPF Routing Protocol

Componentes Utilizados

Las configuraciones en este documento se basan en el Cisco 3700 Series Router en el software 12,4 (15)T 13 de la versión de software de Cisco IOS®.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

El r1, el r2 y el R3 del Routers están conectados a través de la interfaz serial el uno al otro y configurados con la dirección IP. Hay algunos Loopback Address creados en el r1 y el R3 para generar las redes. El EIGRP se ejecuta en el r1 y el r2 del Routers mientras que el R3 comunica al r1 usando el OSPF. El r2 del router, que ejecuta el EIGRP y el OSPF, utiliza el comando redistribute para redistribuir las rutas EIGRP adentro al OSPF.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/113339/ospf_connected_net-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

R1 del router
version 12.4
!
hostname R1
!
ip cef
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.240
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.240
!
interface Loopback2
 ip address 30.30.30.30 255.255.255.240
!
interface Serial0/0
 ip address 172.16.10.1 255.255.248.0
 clock rate 2000000
!
router eigrp 100
 network 10.10.10.0 0.0.0.15
 network 20.20.20.16 0.0.0.15
 network 30.30.30.16 0.0.0.15
 network 172.16.8.0 0.0.7.255
 no auto-summary

!--- Auto-summary is disabled so that 
!--- the networks are summarized with subnets.

!
end

R2 del router
version 12.4
!
hostname R2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 172.16.10.2 255.255.248.0
 clock rate 2000000
!
interface Serial0/1
 ip address 172.16.64.1 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 1.0.0.0
 network 3.0.0.0
 network 172.16.8.0 0.0.7.255
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 
 redistribute connected
 network 2.2.2.2 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Router R3
version 12.4
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 11.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 12.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 13.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 172.16.64.2 255.255.255.0
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 11.1.1.1 0.0.0.0 area 0
 network 12.1.1.1 0.0.0.0 area 0
 network 13.1.1.1 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Verificación

Verifique la redistribución de las redes conectadas en el OSPF

Utilize esta sección para confirmar que su configuración funcione correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Utilice el comando show ip route ospf para verificar al router que el R3 receoved las rutas redistribuido.

muestre el OSPF de la ruta de IP
Cuando los Routeconectad se redistribuyen con la redistribución conectada en el r2 del router: En el router R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0

!--- Only the classful routes are shown without actual subnets.

Cuando está redistribuido con la especificación de la palabra clave de las subredes en las subredes conectadas de la redistribución en el r2 del router: En el router R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0
R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- When routes are redistributed in to OSPF, 
!--- OSPF uses 20 as the default metric if 
!--- the metric-type keyword is not mentioned
!--- and the routes are redistributed as External Type 2(E2) routes.

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:36:58, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 172.16.64.1, 00:00:02, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.8.0/21 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- On specifying the keyword subnets, 
!--- the routes are reflected along with the subnets.



!--- Only the classful routes are shown without actual subnets.

Verifique la redistribución de las rutas EIGRP en el OSPF

Cuando las rutas EIGRP se redistribuyen adentro al OSPF con el <process del eigrp de la redistribución identificación > comando, las rutas se redistribuyen como rutas E2 con el valor por defecto métrico de 20 cuando no se especifica ninguna palabra clave del tipo métrico.

muestre el OSPF de la ruta de IP
Cuando el EIGRP se redistribuye con el comando 100 del eigrp de la redistribución en el r2 del router: En el router R3
R3#show ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:03:16, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:00:09, Serial0/0

!--- Only classful networks are redistributed by default.

Cuando usted especifica la palabra clave de subred en el comando subnets del eigrp 100 de la redistribución en el r2 del router: En el router R3
R3#sh ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:09:26, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     20.0.0.0/28 is subnetted, 1 subnets
O E2    20.20.20.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     10.0.0.0/28 is subnetted, 1 subnets
O E2    10.10.10.0 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     30.0.0.0/28 is subnetted, 1 subnets
O E2    30.30.30.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0

!--- On specifying the keyword subnets, 
!--- the subnetted routes are reflected along
!--- with their subnet mask.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113339