IP : Traducción de direcciones de red (NAT)

NAT-PT estático para el ejemplo de configuración del IPv6

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (23 Abril 2015) | Comentarios


Contenido


Introducción

La traducción de dirección de red - La traducción de puerto (NAT-PT) es un IPv6 al mecanismo de la traducción del IPv4, que permite que los dispositivos IPv6-only comuniquen con los dispositivos IPv4-only y vice versa. El NAT-PT se diseña para ser desplegado para permitir la comunicación directa entre las redes IPv6-only y las redes IPv4-only transparente que utilizan un solo direccionamiento V4.

Este documento explica cómo implementar el NAT-PT estático que utiliza un ejemplo de configuración donde los nodos de red del IPv6 comunican con los nodos de red del IPv4 que utilizan asociar del IPv6 del direccionamiento del IPv4 configurado en el router del NAT-PT.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimientos básicos de los conceptos y de las operaciones NAT.

  • Conocimientos básicos del esquema de direccionamiento del IPv6

  • Conocimientos básicos del Static Routing del IPv6

Nota: El NAT-PT ha sido juzgado desaprobado por el IETF debido a su acoplamiento apretado con el Domain Name System (DNS) y sus limitaciones generales en la traducción, y ha demostrado como tecnología ser demasiado compleja mantener los servicios de translación scalable. Con la deprecación del NAT-PT y la transición cada vez mayor del IPv6 entre los usuarios ha llevado a la introducción de NAT64. Refiera a estos documentos para más información sobre NAT64:

Componentes Utilizados

Las configuraciones en este documento se basan en el Cisco 3700 Series Router en el Software Release 12.4 (15)T 13 del � del Cisco IOS.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En este ejemplo, tres r1, r2 y R3 del Routers están conectados a través de una interfaz serial donde el r1 actúa como router del NAT-PT, que conecta con el r2 del router usando el direccionamiento del IPv4 y con el R3 usando el direccionamiento del IPv6.

Nota: El NAT-PT no se soporta en el Cisco Express Forwarding (CEF) y tiene que ser inhabilitado.

Nota: Utilice la herramienta de búsqueda de comandos (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Este ejemplo utiliza esta configuración de la red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/network-address-translation-nat/113275-nat-ptv6-01.gif

Configuraciones

Este ejemplo utiliza este la configuración:

Configuración del r1
hostname R1
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.30.10 255.255.255.0
 duplex auto
 speed auto
 ipv6 nat
!
interface Serial0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::9/64
 ipv6 enable
!
ipv6 route ::/0 2001:DB8:3002::10
ipv6 nat v4v6 source 192.168.30.9 2000::960B:202

!--- Translates the ipv4 add of R2 fa0/0 to ipv6 address.
          
ipv6 nat v6v4 source 3001:11:0:1::1 150.11.3.1

!--- Translates the ipv6 add of loop0 of R3 to ipv4 address.
              
ipv6 nat prefix 2000::/96

!--- The destination prefixes that matches 2000::/96 
!--- are translated by NAT-PT.
                            
!
end

Configuración del r2
hostname R2
!
interface Serial0/0
 ip address 192.168.30.9 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.10
!

!
end

Configuración R3
hostname R3
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3001:11:0:1::1/64
!
interface Serial0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::10/64
!
ipv6 route ::/0 2001:DB8:3002::9
!

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

En el router R3

Ahora cualquier paquete del direccionamiento del IPv6 del loopback0 del R3 debe poder alcanzar el direccionamiento del IPv4 fa0/0 del r2 usando el direccionamiento 2000::960B:202 del IPv6 como se muestra aquí:

Ping
R3#ping 2000::960b:202 sou lo 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000::960B:202, timeout is 2 seconds:
Packet sent with a source address of 3001:11:0:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/124 ms

!--- This shows that the router R3 is able to reach 
!--- the router R2 through lo address 3001:11:0:1::1.

En el r2 del router

Ping
R2#ping 150.11.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.11.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/68/120 ms

!--- The successful ping response shows that the router R2
!--- is able to reach the IPv6 network.

En el r1 del router

muestre a IPv6 las traducciones nacionales

muestre a IPv6 las traducciones nacionales
R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

!--- This command displays the active NAT-PT translations in the router.

haga el debug de detallado nacional del IPv6

haga el debug de detallado nacional del IPv6
R1#debug ipv6 nat detailed
R1#
*Mar  1 09:12:41.877: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (0.0.0.0 -> ::)
                 ref_count = 1, usecount = 0, flags = 513,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (0.0.0.0 -> ::)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 257,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: IPv6->IPv4:
                 src (3001:11:0:1::1 -> 150.11.3.1)
                 dst (2000::960B:202 -> 192.168.30.9)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: icmp src (3001:11:0:1::1) -> (150.11.3.1), 
                 dst (2000::960B:202) -> (192.168.30.9)
*Mar  1 09:12:41.965: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.965: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0,


!--- This command displays detailed information about NAT-PT events.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113275