IP : Routing IP

Ejemplo de configuración del IPv6 del EIGRP

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (26 Septiembre 2011) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar EIGRP (Enhanced Interior Gateway Routing Protocol) para IPv6. El EIGRP es una versión mejorada del IGRP desarrollado por Cisco. Es un protocolo del vector de distancia mejorado que confía en el Diffused Update Algorithm (DUAL) para calcular el trayecto más corto a un destino dentro de una red. El EIGRP para el IPv6 trabaja igual que el IPv4 del EIGRP donde pueden ser configurados y ser manejados por separado.

Prerrequisitos

  • Conocimientos básicos de EIGRPv4

  • Conocimientos básicos de la dirección del IPv6

Restricciones

Configurar el EIGRP para el IPv6 tiene algunas restricciones; son mencionadas abajo:

  • Las interfaces se pueden configurar directamente con el EIGRP para el IPv6, sin el uso de un direccionamiento global del IPv6. No hay declaración de la red en el EIGRP para el IPv6.

  • El Router ID necesita ser configurado para un caso del protocolo EIGRPv6 antes de que pueda ejecutarse.

  • El EIGRP para el IPv6 tiene una característica del apagar. Asegúrese de que el proceso de ruteo esté en “ningún” modo cerrado a comenzar a funcionar con el protocolo.

Componentes Utilizados

Las configuraciones en este documento se basan en el Cisco 3700 Series Router en el Cisco IOS Software Release 12.4 (15)T 13.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En este ejemplo, configuran a dos Routers (r1 y r2) con el direccionamiento del IPv6. Los Loopback Address se asignan en ambo Routers, y se configuran para estar en EIGRP1. El EIGRPv6 se habilita por el nivel de la interfaz usando este comando: como-número del eigrp del IPv6

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Este ejemplo utiliza esta configuración de la red:

/image/gif/paws/113267/eigrp-ipv6-01.gif

Configuraciones

Este ejemplo utiliza este la configuración:

Configuración del r1
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1010:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2020:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3030:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::1 link-local
 ipv6 address 2010:AB8::1/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 2.2.2.2
 no shutdown
!
end

Configuración del r2
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::2 link-local
 ipv6 address 2010:AB8::2/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 1.1.1.1
 no shutdown
!
end

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Comandos show

El comando neighbors del eigrp del IPv6 de la demostración visualiza a los vecinos descubiertos por el EIGRPv6.

Muestre a los vecinos del eigrp del IPv6
R1 del router
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             13 15:17:58   44   264  0  12
    FE80::2

!--- Shows the link local address of router R2. 

R2 del router
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             14 16:32:05   30   300  0  12
    FE80::1

!--- Shows the link local address of router R1. 

El comando eigrp de la show ipv6 route muestra el contenido de la tabla de ruteo del IPv6 que incluye las rutas específicas al EIGRP.

eigrp de la show ipv6 route
R1 del router
R1#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   2000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   3000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0

!--- This command shows IPv6-specific EIGRP routes.

R2 del router
R2#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1010:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   2020:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   3030:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0

El eigrp del IPv6 de la demostración interconecta el comando visualiza la información sobre las interfaces que se configuran para el EIGRP.

muestre las interfaces del eigrp del IPv6
R1 del router
R1#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        44       0/15         199           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

!--- This command determines which interface EIGRP is active.

R2 del router
R2#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        30       0/15         135           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113267