IP : Servicios de aplicación IP

Ejemplo de la configuración HSRP del IPv6

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (31 Octubre 2011) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar el Hot Standby Routing Protocol (HSRP) para el IPv6. El HSRP se utiliza dentro de un grupo de Routers para seleccionar un router activo y un router en espera. En un grupo de interfaces del router, el router activo es el router de la opción para los paquetes de ruteo; el router en espera es el router que asume el control cuando el router activo falla o cuando se cumplen las condiciones de la precolocación. El HSRP se diseña para proporcionar solamente un primer salto virtual para los hosts del IPv6.

Un grupo del IPv6 del HSRP tiene una dirección MAC virtual que se derive del número de grupo del HSRP y de una dirección local del link virtual del IPv6 es decir, por abandono, derivada del HSRP Virtual MAC Address. Los avisos del router periódicos (RA) se envían para la dirección local del link virtual del IPv6 del HSRP cuando el grupo del HSRP es activo. Estos RA paran después de que se envíe un RA final cuando el grupo deja el estado activo.

El HSRP utiliza un mecanismo de prioridad para determinar que el router configurado del HSRP sea ser el router activo predeterminado. Para configurar a un router como el router activo, usted debe asignarle una prioridad que sea más alta que la prioridad del resto del Routers HSRP-configurado. La prioridad predeterminada es 100; por lo tanto, si usted configura a apenas un router para tener una prioridad más alta, ese router será el router activo predeterminado. La versión 2 de HSRP utiliza la nueva dirección de IP Multicast 224.0.0.102 para enviar paquetes hello en lugar de la dirección de multicast 224.0.0.2, que se utiliza en la versión 1.

Prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimiento de configurar el HSRP; refiera a configurar el HSRP para más información.

  • Conocimientos básicos de implementar la dirección y la conectividad básica del IPv6; refiera a implementar la dirección y la conectividad básica del IPv6 para más información.

  • La versión 2 del HSRP se debe habilitar en una interfaz antes de que el IPv6 del HSRP pueda ser configurado.

  • El Unicast Routing del IPv6 se debe habilitar en el dispositivo para que el IPv6 del HSRP sea configurado

Componentes Utilizados

Las configuraciones en este documento se basan en el Cisco 3700 Series Router en el software 12,4 (15)T 13 de la versión de Cisco IOS Software.

Nota: Verifique la información sobre la licencia para los comandos del IPv6.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener información sobre las convenciones sobre documentos.

Configurar

El r1 y el r2 del Routers están conectados con el R3 vía una interfaz serial. Las interfaces Fast Ethernet del r1 y del r2 se configuran con el IPv6 del HSRP de una manera tal que el r1 actúe como el router activo y el r2 actúe como el router en espera. En caso de que vaya la interfaz serial S0/0 del r1 abajo, el router del r2 cambia su estado de espera al Active.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/113216/ipv6-hsrp-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Aquí está un link a un vídeo (disponible en la comunidad del soporte de Ciscoleavingcisco.com ) que demuestre cómo configurar el HSRP para el IPv6 en el Routers del Cisco IOS:

Configurar el HSRP para el IPv6 leavingcisco.com

ipv6-hsrp-02.gif

Configuración del r1 del router
R1#show run
Building configuration...
!
hostname R1
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1010/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.


 standby 1 priority 120


!--- R1 is configured as the active router.
!--- This is done by assigning a priority value 
!--- (in this case 120) to the router's Fa0/0 interface.
!--- The default priority value is 100.


 standby 1 preempt delay minimum 30


!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than 
!--- all the other HSRP-configured routers. 
!---- Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 30 seconds.


 standby 1 track Serial0/0 90


!--- Indicates that HSRP tracks serial0/0.
!--- The interface priority is configured (in this case 90) which 
!--- indicates that if the tracked interface goes down the router 
!--- priority value is to be decremented by 90. 
!--- Default decrement value is 10.

!
interface Serial0/0
 no ip address
 ipv6 enable
 ipv6 address 2010:AB8:2001::1010/64
 clock rate 2000000
!
end

Configuración del r2 del router
R2#show run
Building configuration...
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0

!--- R2 is configured as a standby router
!--- with a default priority value of 100.

 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2010::1020/64
 ipv6 enable
 clock rate 2000000
!
end

Configuración del router R3
R3#show run
Building configuration...
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2001::1011/64
 ipv6 enable
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2010:AB8:2010::1021/64
 clock rate 2000000
!
end

Verificación

Utilice el comando show standby en el Routers del r1 y del r2 para verificar la configuración.

R1 del router
R1#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active 
!--- R1 router is in Active state.

    4 state changes, last state change 02:51:30
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.480 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C010:21FF:FE78:0, priority 100 (expires in 7.036 sec)
  Priority 120 (configured 120)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

R2 del router
R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Standby
!--- R2 router is in Standby state.

    4 state changes, last state change 02:51:43
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.900 secs
  Preemption enabled, delay min 30 secs
  Active router is FE80::C00F:21FF:FE78:0, priority 120 (expires in 9.928 sec)
    MAC address is c20f.2178.0000
  Standby router is local
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

En caso de que vaya el router activo (r1 en este ejemplo) abajo, el router en espera cambia su estado inmediatamente al Active tal y como se muestra en de esta tabla:

Cuando el router activo (el r1) va abajo de…
R1 del router
R1(config)#interface s0/0
R1(config-if)#shut
R1(config-if)#exit
*Mar  1 00:01:34.879: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
      administratively down
*Mar  1 00:01:35.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, 
      changed state to down
R1#
*Mar  1 00:04:06.691: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  1 00:04:36.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Speak
R1#
*Mar  1 00:04:46.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

!--- When the interface goes down, the active router changes its state to Standby.

R2 del router
*Mar  1 00:04:35.631: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby ->Active


!--- The standby router is now the active router.
 

R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:10:39
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.532 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C00F:21FF:FE78:0, priority 30 (expires in 7.524 sec)
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113216