IP : Open Shortest Path First (OSPF)

Ejemplo de configuración del link virtual OSPFv3

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona un ejemplo en configurar los links virtuales en el trayecto más corto abierto primero versión 3 (OSPFv3). OSPFv3 se amplía en la versión 2 OSPF para proporcionar el soporte para el IPv6 que rutea los prefijos y el más de gran tamaño de los direccionamientos del IPv6.

Para cada link virtual, un datablock principal de la información sobre seguridad se crea para el link virtual. Porque un socket seguro se debe abrir en cada interfaz, habrá un datablock correspondiente de la información sobre seguridad para cada interfaz en la área de tránsito. El estado seguro del socket se mantiene el datablock de la información sobre seguridad de la interfaz. El campo de estado en el datablock principal de la información sobre seguridad refleja el estatus de todo el asegura los socketes abiertos para el link virtual. Si todo el asegure los socketes están PARA ARRIBA, después el estado de la Seguridad para el link virtual será fijado a PARA ARRIBA.

Los paquetes enviaron encendido un link virtual con el IPSec deben utilizar a las direcciones de origen y de destino predeterminadas. El primer direccionamiento de la área local encontrado en el intra-área-prefijo LSA del router para el área se utiliza como la dirección de origen. Guardan esta dirección de origen en la estructura de datos del área y utilizado cuando asegure los socketes se abren y los paquetes enviado sobre el link virtual. El link virtual no transición al estado de punto a punto hasta que seleccionen a una dirección de origen. También, cuando la dirección de origen o de destino cambia, el anteriores aseguran los socketes deben ser cerrados y nuevo asegure los socketes abiertos.

Este ejemplo de configuración utiliza el comando area virtual-link de definir un link virtual OSPF en el modo de configuración del router.

Nota: Cada vecino del link virtual debe incluir la área de tránsito ID y el Router ID correspondiente del vecino del link virtual para que un link virtual sea configurado correctamente. Utilice el comando exec OSPF del IP de la demostración de ver el Router ID.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Complete la estrategia y las hojas de operación (planning) de la red OSPF para su red del IPv6.

  • Habilite el Unicast Routing del IPv6.

  • Habilite el IPv6 en la interfaz.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Las configuraciones en este documento se basan en el Cisco 3700 Series Router en el software 12.4 (15)T 13 de la versión de software de Cisco IOS�.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113204-ospfv3-vlink-config-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

  • R1 del router

  • R2 del router

  • Router R3

  • Router R4

R1 del router
hostname R1
! 
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes

R2 del router
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 clock rate 64000
 !
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 virtual-link 3.3.3.3
!

Router R3
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 !

interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 !
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 virtual-link 2.2.2.2
!

Router R4
hostname R4
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:4::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
ipv6 router ospf 10
 router-id 4.4.4.4
 log-adjacency-changes
!

Verificación

Utilice estos comandos de verificar la configuración:

En el r1 del router

La salida muestra claramente que el r1 del router puede hacer ping con éxito el Loopback Address del router R4.

IPv6 del ping
R1#ping ipv6
Target IPv6 address: fe01:4::4

Ping Loopback 0 interface of R4
   	
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/72/96 ms

En el r2 del router

El comando neighbor OSPF del IPv6 de la demostración proporciona la información de vecino en a por la base de la interfaz.

muestre al vecino OSPF del IPv6
R2# show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
3.3.3.3                 0   FULL/  -                -                22        OSPFv3_VL0   

Virtual Link Between R2 & R3
       
1.1.1.1                 1   FULL/DR         00:00:35         4                 Ethernet1/0
3.3.3.3                 0   FULL/  -           00:00:31      12                Serial2/0

En el router R4

La salida muestra claramente que el router R4 puede hacer ping con éxito el loop - interfaz posterior del r1 del router.

IPv6 del ping
R4#ping ipv6
Target IPv6 address: fe01:1::1				

Ping Loopback 0 interface of R1

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/100/224 ms

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113204