Voz : Protocolo de control de gateway de medios (MGCP)

Soporte MGCP en un ejemplo de configuración del router habilitado VRF

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar el Gateway Control Protocol del mensaje (MGCP) en un router habilitado del ruteo de voz y de la expedición (VRF).

Hay dos elementos principales que usted debe entender la consideración del MGCP:

  • Puntos finales

  • Agentes de la llamada

Los puntos finales son puertos de voz uces de los en el gateway señalado. Estos puertos de voz proporcionan la Conectividad a los puertos analógicos, tales como Oficina de intercambio remoto (FXO)/Estación de intercambio remota (FXS), y los troncos digitales, tales como un T1 o E1, al PSTN. Los gatewayes pueden tener el varios puntos finales que dependen en el número de puertos que contiene.

Los agentes de la llamada son dispositivos de control externo en un sistema de voz. El Cisco CallManager es el agente de la llamada referido a este documento. En el MGCP, el agente de la llamada es el dispositivo que tiene control total del gateway. Esto es mismo un sistema eficiente pues toda la administración es realizada por el agente de la llamada. Hay configuración muy pequeña requerida en el extremo del gateway, pues configuran a todos los patrones de ruta y planes de marcación en el Cisco CallManager.

Es importante recordar que este protocolo está utilizado para los objetivos de control solamente. No se transmite ningunos datos de voz con el protocolo MGCP sí mismo. Toda la transferencia de datos de voz ocurre directamente entre el teléfono y el gateway. Este gráfico representa las relaciones de las comunicaciones MGCP:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-01.gif

Los Teléfonos IP de Cisco en este uso del ejemplo el Skinny Call Control Protocol (SCCP) de comunicar con el Cisco CallManager. Los datos de voz reales se transfieren con el Real-Time Transport Protocol (RTP) directamente entre los dos dispositivos. El MGCP es utilizado por el Cisco CallManager para controlar solamente el gateway.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Versión del Cisco IOS Software 12.4(24)T 4

  • Cisco 2800 Series Router

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

MGCP y VRF Lite

La inteligencia de ruteo VRF no existe en el protocolo MGCP.

Puesto que el MGCP no es un protocolo “que reconoce VRF”, usted no puede configurar un gateway de voz del IOS para poner el tráfico MGCP en la Voz VRF. El tráfico MGCP utilizará solamente la tabla de ruteo predeterminado del router sin importar las configuraciones de VRF.

Hay dos soluciones para soportar el MGCP en un despliegue típico VRF. Refiera a este escenario de red típico VRF:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-02.gif

Usando dos Routers usted puede establecer uno, es decir, con el gateway MGCP actuando como router básico (ningunos VRF) que proporciona al tráfico de Ethernet a un segundo router que haga la encaminamiento MPLS VRF. Usted puede entonces rutear el tráfico MGCP sobre un router VRF pues es apenas una técnica que rutea y el MGCP está inconsciente.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-03.gif

Otra solución similar es utilizar a un solo router VRF y utilizar una segunda interfaz disponible para dirigir el tráfico MGCP hacia fuera a la red de voz.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-04.gif

La conexión de la interfaz con el VLA N de la Voz en el Switching Network permite que los protocolos MGCP sean ruteados nuevamente dentro del router vía la interfaz VRF y en última instancia el CallManager.

La ruta global de las necesidades del router VRF solamente de ser dado un IP y una Static ruta que señalan al IP de la interfaz VRF o de un DHCP Address del VLA N de la Voz. Vea a estos detalles de la configuración:

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.


Información Relacionada


Document ID: 113180