IP : Protocolos de routing de IP

Ajuste la distancia administrativa para que haya selección de Route en el ejemplo de configuración del Routers del Cisco IOS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo cambiar el valor de la distancia administrativa del Routing Protocol para influenciar la selección de Route en los routeres Cisco.

La distancia administrativa es un valor que utilizan los routers para seleccionar la mejor trayectoria cuando hay dos o más rutas diferentes hacia el mismo destino desde dos protocolos de ruteo distintos. La distancia administrativa define la confiabilidad de un protocolo de ruteo. Cuanto más bajo sea el valor de la distancia administrativa, más confiable será el protocolo.

Nota: Cuando usted cambia las distancias predeterminadas, puede llevar a rutear los loopes en la red. Cambie la distancia administrativa con cautela y sólo después de usted tenga pensamiento con lo que usted quiere alcanzar.

prerrequisitos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes Utilizados

Las configuraciones en este documento se basan en el Cisco 3700 Series Router en el Cisco IOS Software Release 12.4 (15)T 13.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

Aquí el r1 y el r2 del router están conectados vía las líneas en serie paralela. El r1 y el r2 del Routers se configuran con el BGP y el OSPF. La distancia administrativa predeterminada del OSPF es 110 mientras que el del eBGP es 20. Con el comando distance, cambiamos el valor AD del BGP a 190. Antes de este comando, el r2 del router prefirió las rutas BGP sobre el OSPF puesto que hicieron los valores del valor por defecto AD configurar. Después de que el valor AD del BGP cambiara, las OSPF rutas toman la precedencia.

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-routed-protocols/113153-adjust-ad-01.gif

Configuraciones

Este documento utiliza este la configuración

Configuración del r1
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface Loopback10
 ip address 10.10.10.10 255.255.255.255
 !
!
interface Loopback20
 ip address 20.20.20.20 255.255.255.255
 !
!
interface Loopback30
 ip address 30.30.30.30 255.255.255.255
 !
!
interface Serial1/0
 ip address 100.100.100.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
interface Serial1/1
 ip address 192.168.12.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.10.10 0.0.0.0 area 0
 network 20.20.20.20 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 10.10.10.10 mask 255.255.255.255
 network 20.20.20.20 mask 255.255.255.255
 network 30.30.30.30 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 ebgp-multihop 5
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!

Configuración del r2
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
!
interface Serial1/0
 ip address 100.100.100.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
interface Serial1/1
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !

!
router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 100.100.100.2 0.0.0.0 area 0
!
router bgp 100
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 123
 neighbor 1.1.1.1 ebgp-multihop 5
 neighbor 1.1.1.1 update-source Loopback0
 distance 190 1.1.1.1 0.0.0.0 

Changed the AD value of BGP as 190!

 no auto-summary
!

Verificación

Utilice los comandos descritos en esta sección para verificar la configuración.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

En el r2 del router

Cuando no aplican al comando distance en el r2 del router

show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      10.0.0.0/32 is subnetted, 1 subnets
B        10.10.10.10 [20/0] via 1.1.1.1, 00:00:03        

 BGP Router Preffered Over OSPF

      20.0.0.0/32 is subnetted, 1 subnets
B        20.20.20.20 [20/0] via 1.1.1.1, 00:00:03
 
 BGP Router Preffered Over OSPF

      30.0.0.0/32 is subnetted, 1 subnets
B        30.30.30.30 [20/0] via 1.1.1.1, 00:00:03
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.100.100.0/24 is directly connected, Serial1/0
L        100.100.100.2/32 is directly connected, Serial1/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Serial1/1
L        192.168.12.2/32 is directly connected, Serial1/1

Cuando aplican al comando distance en el r2 del router

show ip route
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      10.0.0.0/32 is subnetted, 1 subnets
O        10.10.10.10 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
           
By increasing the AD of External BGP, OSPF takes precedence

      20.0.0.0/32 is subnetted, 1 subnets
O        20.20.20.20 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
           
By increasing the AD of External BGP, OSPF takes precedence

      30.0.0.0/32 is subnetted, 1 subnets
B        30.30.30.30 [190/0] via 1.1.1.1, 00:00:03
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.100.100.0/24 is directly connected, Serial1/0
L        100.100.100.2/32 is directly connected, Serial1/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Serial1/1
L        192.168.12.2/32 is directly connected, Serial1/1


Información Relacionada


Document ID: 113153