IP : IP versión 6 (IPv6)

Autenticación PPP CHAP/PAP sobre un ejemplo de configuración del link serial del IPv6

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para la autenticación del Challenge Handshake Authentication Protocol (CHAP)/del protocolo password authentication del Point-to-Point Protocol (PPP) (PAP) sobre un link serial del IPv6.

Cuando se habilita el PAP o la GRIETA, el router local requiere el dispositivo remoto probar su identidad antes de permitir que el tráfico de datos fluya. La autenticación PAP requiere el dispositivo remoto enviar un nombre y una contraseña, que se marca contra una entrada coincidente en la base de datos del nombre de usuario local o en la base de datos de servidor de seguridad remota. La autenticación CHAP envía un mensaje de impugnación al dispositivo remoto. El dispositivo remoto cifra el valor del desafío con un secreto compartido y vuelve el valor cifrado y su nombre al router local en un mensaje de respuesta. El router local intenta hacer juego el nombre del dispositivo remoto con un secreto asociado salvado en el nombre de usuario local o la base de datos de servidor de seguridad del telecontrol. Utiliza el secreto salvado para cifrar el desafío original y para verificarlo que los valores cifrados hacen juego.

prerrequisitos

Requisitos

Aseegurese que usted cumple estos requisitos antes de que usted intente esta configuración:

  • Entienda el proceso de autenticación PAP/CHAP

  • Entienda el IPv6 básico

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco IOS Software Release 12.4, conjunto de características anticipado de los Servicios IP

  • Cisco 3700 Series Multiservice Access Routers

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

En el ejemplo, el r1 y el r2 del Routers se configuran con la autenticación PPP. En el r1 del router, la interfaz S1/0 es IPv6 habilitado y tiene el direccionamiento 2011:2706:ABC::/64 eui-64 del IPv6 implementando EUI-64. El Identificador único extendido (EUI) permite al host automáticamente para asignarse un identificador 64-bit único de la interfaz del IPv6 sin la necesidad de la configuración manual o del DHCP. Esto es lograda en las interfaces de Ethernet refiriéndose a la dirección MAC ya única 48-bit, y cambiando formato ese valor para hacer juego la especificación EUI-64. Semejantemente, la interfaz S1/0 en el r2 del router se habilita con 2011:2706:ABC::/64 eui-64.

Configurar

El r1 y el r2 del Routers se configuran con la autenticación básica PPP/CHAP.

Diagrama de la red

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113073-ppp-chap-ipv6-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Configuración del r1
hostname R1
!
aaa new-model
!
aaa authentication ppp default local
!
username R2 password 0 cisco

interface Serial1/0
 no ip address
 encapsulation ppp
 ipv6 address 2011:2706:ABC::/64 eui-64
 ipv6 enable
 no fair-queue
 ppp authentication chap callin
!

Configuración del r2
interface Serial1/1
 no ip address
 encapsulation ppp
 ipv6 address 2011:2706:ABC::/64 eui-64
 ipv6 enable
 clock rate 64000
 ppp chap hostname R2
 ppp chap password 0 cisco

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funciona correctamente.

En el r1 del router, publique estos comandos:

  1. debug ppp negotiation

    debug ppp negotiation
    
    
    *Jun 27 08:34:56:357: Se1/0 PPP: Outbound cdp packet dropped
    *Jun 27 08:34:56:845: %SYS-5-CONFIG_|: Configured from console by console
    *Jun 27 08:34:58:357: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
    *Jun 27 08:34:58:357: Se1/0 PPP: Using default call direction
    *Jun 27 08:34:58:357: Se1/0 PPP: Treating connection as a dedicated line
    *Jun 27 08:34:58:357: Se1/0 PPP: Session handle[470002F8] Session id[29]
    *Jun 27 08:34:58:357: Se1/0 PPP: Phase is ESTABLISHING, Active Open
    *Jun 27 08:34:58:357: Se1/0 LCP: O CONFREQ [Closed] id 72 len 15
    *Jun 27 08:34:58:357: Se1/0 LCP:  AuthProto CHAP (0x0305C22305)
    *Jun 27 08:34:58:357: Se1/0 LCP:  MagicNumber 0x35B44C0F (0x050635B44C0F)
    *Jun 27 08:34:58:361: Se1/0 LCP: I CONFREQ {REQsent] id 59 len 10
    *Jun 27 08:34:58:361: Se1/0 LCP:  MagicNumber 0x1FEDF9A2 (0x05061FEDF9A2)
    *Jun 27 08:34:58:361: Se1/0 LCP: O CONFACK {REQsent] id 59 len 10
    *Jun 27 08:34:58:361: Se1/0 LCP:  MagicNumber 0x1FEDF9A2 (0x05061FEDF9A2)
    *Jun 27 08:34:58:365: Se1/0 LCP: I CONFACK {ACKsent] id 72 len 15
    *Jun 27 08:34:58:365: Se1/0 LCP:  AuthProto CHAP (0x0305C22305)
    *Jun 27 08:34:58.365: Se1/0 LCP:    MagicNumber 0x35B44C0F (0x050635B44C0F)
    *Jun 27 08:34:58.365: Se1/0 LCP: State is Open
    *Jun 27 08:34:58.365: Se1/0 PPP: Phase is AUTHENTICATING, by this end
    *Jun 27 08:34:58.365: Se1/0 CHAP: O CHALLENGE id 5 len 23 from "R1"
    *Jun 27 08:34:58.377: Se1/0 CHAP: I RESPONSE id 5 len 23 from "R2"
    *Jun 27 08:34:58.377: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
    *Jun 27 08:34:58.377: Se1/0 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is AUTHENTICATING, Authenticated User
    *Jun 27 08:34:58.381: Se1/0 CHAP: O SUCCESS id 5 len 4
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is UP
    *Jun 27 08:34:58.381: Se1/0 CDPCP: O CONFREQ [Closed] id 1 len 4
    *Jun 27 08:34:58.381: Se1/0 IPV6CP: O CONFREQ [Closed] id 1 len 14
    *Jun 27 08:34:58.381: Se1/0 IPV6CP:    Interface-Id 021B:54FF:FEA9:24B0 
        (0x010A021B54FFFEA924B0)
    *Jun 27 08:34:58.381: Se1/0 PPP: Process pending ncp packets
    *Jun 27 08:34:58.389: Se1/0 CDPCP: I CONFREQ [REQsent] id 1 len 4
    *Jun 27 08:34:58.389: Se1/0 CDPCP: O CONFACK [REQsent] id 1 len 4
    *Jun 27 08:34:58.389: Se1/0 IPV6CP: I CONFREQ [REQsent] id 1 len 14
    *Jun 27 08:34:58.389: Se1/0 IPV6CP:    Interface-Id 021F:CAFF:FE04:F918 
        (0x010A021FCAFFFE04F918)
    *Jun 27 08:34:58.389: Se1/0 IPV6CP: O CONFACK [REQsent] id 1 len 14
    *Jun 27 08:34:58.389: Se1/0 IPV6CP:    Interface-Id 021F:CAFF:FE04:F918 
        (0x010A021FCAFFFE04F918)
    *Jun 27 08:34:58.393: Se1/0 CDPCP: I CONFACK [ACKsent] id 1 len 4
    *Jun 27 08:34:58.393: Se1/0 CDPCP: State is Open
    *Jun 27 08:34:58.393: Se1/0 IPV6CP: I CONFACK [ACKsent] id 1 len 14
    *Jun 27 08:34:58.393: Se1/0 IPV6CP:    Interface-Id 021B:54FF:FEA9:24B0 
        (0x010A021B54FFFEA924B0)
    *Jun 27 08:34:58.393: Se1/0 IPV6CP: State is Open
    *Jun 27 08:34:59.381: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0,
        changed state to up
    
  2. debug ppp authentication

    *Jun 27 08:37:46.045: Se1/0 PPP: Using default call direction
    *Jun 27 08:37:46.045: Se1/0 PPP: Treating connection as a dedicated line
    *Jun 27 08:37:46.045: Se1/0 PPP: Session handle[C40002F9] Session id[30]
    *Jun 27 08:37:46.045: Se1/0 PPP: Authorization NOT required
    *Jun 27 08:37:46.053: Se1/0 CHAP: O CHALLENGE id 6 len 23 from "R1"
    *Jun 27 08:37:46.065: Se1/0 CHAP: I RESPONSE id 6 len 23 from "R2"
    *Jun 27 08:37:46.065: Se1/0 PPP: Sent CHAP LOGIN Request
    *Jun 27 08:37:46.065: Se1/0 PPP: Received LOGIN Response PASS
    *Jun 27 08:37:46.069: Se1/0 CHAP: O SUCCESS id 6 len 4
    
    

En el r2 del router, publique este comando:

  • debug ppp authentication

    debug ppp authentication 
    
    *Feb 28 05:18:39.439: Se1/1 PPP: Using default call direction
    *Feb 28 05:18:39.439: Se1/1 PPP: Treating connection as a dedicated line
    *Feb 28 05:18:39.439: Se1/1 PPP: Session handle[E300000B] Session id[35]
    *Feb 28 05:18:39.439: Se1/1 PPP: Authorization required
    *Feb 28 05:18:39.451: Se1/1 PPP: No authorization without authentication
    *Feb 28 05:18:39.455: Se1/1 CHAP: I CHALLENGE id 7 len 23 from "R1"
    *Feb 28 05:18:39.459: Se1/1 CHAP: Using hostname from interface CHAP
    *Feb 28 05:18:39.459: Se1/1 CHAP: Using password from interface CHAP
    *Feb 28 05:18:39.459: Se1/1 CHAP: O RESPONSE id 7 len 23 from "R2"
    *Feb 28 05:18:39.467: Se1/1 CHAP: I SUCCESS id 7 len 4
    

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113073