Software Cisco IOS y NX-OS : Software Cisco IOS versión 12.2 SR

Implementar el ADSL y desplegar el accesso del dial para el IPv6

5 Octubre 2011 - Documento Original
Otras Versiones: PDFpdf | Comentarios

Contenidos

Implementar el ADSL y desplegar el accesso del dial para el IPv6

Encontrar la información de la característica

Contenidos

Requisitos previos para implementar el ADSL y el accesso del dial para el IPv6

Restricciones para implementar el ADSL y desplegar el accesso del dial para el IPv6

Información sobre implementar el ADSL y desplegar el accesso del dial para el IPv6

Asignación de dirección para el IPv6

Configuración automática de dirección apátrida

Delegación del prefijo

Atributos AAA para el IPv6

Requisitos previos para usar los atributos AAA para el IPv6

Atributos de usuario del RADIO para el acceso virtual en los ambientes del IPv6

Pools del prefijo del IPv6

Cómo configurar el ADSL y desplegar el accesso del dial en el IPv6

Configurar el NAS

Consejos para la resolución de problemas

Configurar el router CE alejado

Pasos Siguientes

Configurar el DHCP para que servidor del IPv6 obtenga los prefijos de los servidores de RADIUS

Requisitos previos

Configurar el DHCP para el IPv6 AAA y las opciones del SORBO

Ejemplos de configuración para implementar el ADSL y desplegar el accesso del dial para el IPv6

Implementar el ADSL y desplegar el accesso del dial para el IPv6: Ejemplo:

Adonde ir después

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Información de la característica para implementar el ADSL y desplegar el accesso del dial para el IPv6


Implementar el ADSL y desplegar el accesso del dial para el IPv6


Primera publicación: De noviembre el 25 de 2002
Última actualización: De noviembre el 26 de 2009

Este módulo describe la implementación de los pools del prefijo y de los atributos del Remote Access Dial-In User Service del por el utilizador (RADIO) en el IPv6. También describe el despliegue del IPv6 en el Digital Subscriber Line (DSL) y los ambientes del dial-accesso. El despliegue del Asymmetric Digital Subscriber Line (ADSL) y del dial proporciona las extensiones que hacen el accesso en grande posible para los ambientes del IPv6, incluyendo los atributos de RADIUS del IPv6, la configuración apátrida del direccionamiento en los links del Point-to-Point Protocol (PPP), las Static rutas del por el utilizador, y las listas de control de acceso (ACL).

Encontrar la información de la característica

Tu versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, ver los Release Note para tu plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, ver la "información de la característica para implementar el ADSL y desplegar el accesso del dial para la sección del IPv6".

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenidos

Requisitos previos para implementar el ADSL y el accesso del dial para el IPv6

Restricciones para implementar el ADSL y desplegar el accesso del dial para el IPv6

Información sobre implementar el ADSL y desplegar el accesso del dial para el IPv6

Cómo configurar el ADSL y desplegar el accesso del dial en el IPv6

Ejemplos de configuración para implementar el ADSL y desplegar el accesso del dial para el IPv6

Adonde ir después

Referencias adicionales

Información de la característica para implementar el ADSL y desplegar el accesso del dial para el IPv6

Requisitos previos para implementar el ADSL y el accesso del dial para el IPv6

Este documento asume que eres familiar con el IPv4. Referir a las publicaciones referidas a la sección de las "referencias adicionales" para la configuración y la información sobre referencias de comandos del IPv4.

Restricciones para implementar el ADSL y desplegar el accesso del dial para el IPv6

El ADSL y el despliegue del dial está disponibles para las interfaces con la encapsulación PPP habilitada, incluyendo el PPP over ATM (PPPoA), PPP over Ethernet (PPPoE), PPP sobre el async, y PPP over ISDN.

Información sobre implementar el ADSL y desplegar el accesso del dial para el IPv6

Para implementar el ADSL y desplegar el accesso del dial para el IPv6, necesitas entender los conceptos siguientes:

Asignación de dirección para el IPv6

Atributos AAA para el IPv6

Asignación de dirección para el IPv6

Un router Cisco configurado con el IPv6 hará publicidad de sus prefijos del IPv6 en una o más interfaces, permitiendo que los clientes del IPv6 configuren automáticamente sus direccionamientos. En el IPv6, la asignación de dirección se realiza en la capa de red, en contraste con el IPv4 donde varias funciones se manejan en la capa PPP. La única función manejada en el Control Protocol del IPv6 (IPv6CP) es la negociación de un identificador único de la interfaz. Todo lo demás, incluyendo la detección del servidor DNS, se hace dentro del protocolo sí mismo del IPv6.

Contrario a la asignación de dirección del IPv4, un usuario del IPv6 será asignado un prefijo, no una sola dirección. El Proveedor de servicios de Internet (ISP) asigna típicamente un 64- o un prefijo 48-bit.

En el mundo del IPv6, los Proveedores de servicios de Internet (ISP) asignan los prefijos duraderos a los usuarios, que tiene cierto impacto en el sistema de ruteo. En los ambientes típicos del IPv4, cada servidor de acceso a la red (NAS) hace que un pool de los direccionamientos 24-bit y los usuarios consiga los direccionamientos de esto reúnen al marcar adentro. Si un usuario marca otro POP o está conectado con otro NAS en el mismo POP, se asigna un diverso direccionamiento del IPv4.

Los direccionamientos para el IPv6 son asignados por dos métodos distintos.

Configuración automática de dirección apátrida

Delegación del prefijo

Configuración automática de dirección apátrida

La asignación de los direccionamientos usando el método apátrida de la configuración automática de dirección se puede utilizar solamente para asignar los prefijos 64-bit. Asignan cada usuario un prefijo 64-bit, que se hace publicidad al usuario en un aviso del router (RA). Todos los direccionamientos se configuran automáticamente sobre la base del prefijo asignado.

Un escenario típico es asignar un prefijo 64-bit separado por el usuario; sin embargo, los usuarios pueden también ser asignados un prefijo de una agrupación de direcciones compartida. Usando los direccionamientos compartidos de los límites a solamente un direccionamiento por el usuario.

Esta solución trabaja mejor para los casos donde está un solo PC o se limita el router de borde del proveedor del cliente (CPE) a solamente una subred. Si el usuario tiene subredes múltiples, acodar 2 (L2) que interligan, las subredes del multilink o el proxy RA puede ser utilizado. El prefijo de divulgación en el RA puede venir de una autorización, autentificación, y el servidor de las estadísticas (AAA), que también proporciona el atributo del prefijo, se puede configurar manualmente, o se puede afectar un aparato de un pool del prefijo.

El atributo del Framed-Interfaz-ID AAA influencia la opción del identificador de la interfaz para los pares y, conjuntamente con el prefijo, el direccionamiento completo del IPv6 puede ser determinado.

Delegación del prefijo

La delegación del prefijo utiliza el Protocolo de configuración dinámica de host (DHCP). Cuando las peticiones del usuario un prefijo del delegator del prefijo, típicamente el NAS, el prefijo se afectan un aparato según lo descrito en la sección de la "configuración automática de dirección apátrida".

Un router de delegación del prefijo del IPv6 selecciona los prefijos del IPv6 para ser asignado a un router solicitante sobre la recepción de una petición del cliente. El router de delegación pudo seleccionar los prefijos para un router solicitante de las siguientes maneras:

Asignación estática basada en la suscripción a un ISP

Asignación dinámica de un pool de los prefijos disponibles

Selección basada en una autoridad externa tal como un servidor de RADIUS que usa el atributo Framed-IPv6-Prefix (véase la sección del "Framed-IPV6-Prefix").

Opción del servidor del SORBO del DHCP

Dos DHCP para la opción del servidor del Session Initiation Protocol (SIP) del IPv6 describen un proxy saliente local del SORBO: uno lleva una lista de Domain Name, el otro una lista de direccionamientos del IPv6. Estas dos opciones se pueden configurar en un pool de la configuración DHCPv6.

Atributos AAA para el IPv6

Los atributos específicos del proveedor (VSA) se han desarrollado para soportar el AAA para el IPv6. Cisco VSA es inacl, outacl, ruta, y prefijo.

Los pools del prefijo y los nombres del pool son configurables con el AAA.

Los atributos de RADIUS siguientes según lo descrito en el RFC 3162 se soportan para el IPv6:

Framed-Interfaz-ID

Framed-IPv6-Prefix

Login-IPv6-Host

Framed-IPv6-Route

Framed-IPv6-Pool

Estos atributos se pueden configurar en un servidor de RADIUS y descargar al Access Servers donde pueden ser aplicados para accesar las conexiones.

Los atributos AAA se describen en las secciones siguientes:

Atributos de usuario del RADIO para el acceso virtual en los ambientes del IPv6

Pools del prefijo del IPv6

Requisitos previos para usar los atributos AAA para el IPv6

Los atributos AAA para el IPv6 son obedientes con el RFC 3162 y requieren a un servidor de RADIUS capaz de soportar el RFC 3162.

Atributos de usuario del RADIO para el acceso virtual en los ambientes del IPv6

Los atributos siguientes del IPv6 para los pares del valor de atributo del RADIO (AV) se soportan para el acceso virtual:

Framed-Interfaz-ID

Framed-IPv6-Prefix

Login-IPv6-Host

Framed-IPv6-Route

Framed-IPv6-Pool

Ruta del IPv6

IPv6 ACL

IPv6 Prefix#

Pool del IPv6

Aparte de los nuevos atributos del prefijo del IPv6 y del pool del IPv6, éstos son todos Cisco existente VSA extendido para soportar el protocolo del IPv6.

Framed-Interfaz-ID

El atributo del Framed-Interfaz-ID indica el identificador de la interfaz del IPv6 que se configurará. Este atributo de usuario se utiliza durante las negociaciones IPv6CP y se puede utilizar en los paquetes access-accepts. Si la opción del interface identificador IPv6CP se ha negociado con éxito, este atributo se debe incluir en un paquete Acc-0Request como indirecta por el NAS al servidor que preferiría ese valor.

Framed-IPv6-Prefix

El atributo Framed-IPv6-Prefix realiza la misma función que Cisco VSA: Se utiliza para el acceso virtual solamente e indica un prefijo del IPv6 (y la ruta correspondiente) que se configurarán. Este atributo es un atributo de usuario y deja al usuario especificar qué prefijos a hacer publicidad en los mensajes del aviso del router de la detección de vecino. El atributo Framed-IPv6-Prefix se puede utilizar en los paquetes access-accepts y puede aparecer las épocas múltiples. El NAS creará una ruta correspondiente para el prefijo.

Para utilizar este atributo para el DHCP para la delegación del prefijo del IPv6, crear un perfil para el mismo usuario en el servidor de RADIUS. El Nombre de usuario asociado al segundo perfil tiene el sufijo el "-dhcpv6."

El atributo Framed-IPv6-Prefix en los dos perfiles se trata diferentemente. Si un NAS necesita ambos enviar un prefijo en los avisos del router (RA) y delegar un prefijo a la red de un usuario remoto, el prefijo para el RA se pone en el atributo Framed-IPv6-Prefix en el perfil regular del usuario, y el prefijo usado para la delegación del prefijo se pone en el atributo en el perfil separado del usuario.

Login-IPv6-Host

El atributo Login-IPv6-Host es un atributo de usuario que indica el sistema del IPv6 con el cual conectar al usuario cuando el atributo del Login-Servicio es incluido.

Framed-IPv6-Route

El atributo Framed-IPv6-Route realiza la misma función que Cisco VSA: Es un atributo de usuario que proporciona la información de ruteo que se configurará para el usuario en el NAS. Este atributo es un atributo de la cadena y se especifica usandoipv6 routeel comando.

Framed-IPv6-Pool

El atributo IPv6-Pool es un atributo de usuario que contiene el nombre de un pool asignado que se deba utilizar para asignar un prefijo del IPv6 para el usuario. Este pool se debe definir localmente en el router o definir en un servidor de RADIUS de quien los pools puedan ser descargados.

Ruta del IPv6

El atributo de la ruta del IPv6 permite que especifiques una Static ruta del por el utilizador. Una Static ruta es apropiada cuando el Cisco IOS Software no puede construir dinámicamente una ruta al destino. Ver la descripciónipv6 routedel comando para más información sobre las Static rutas del edificio.

El siguiente ejemplo muestra el atributo de la ruta del IPv6 usado para definir una Static ruta:

cisco-avpair = "ipv6:route#1=2001:0DB8:cc00:1::/48",
cisco-avpair = "ipv6:route#2=2001::0DB8:cc00:2::/48",

IPv6 ACL

Puedes especificar una lista de acceso completa del IPv6. El nombre único de la lista de acceso se genera automáticamente. Se quita la lista de acceso cuando su usuario termina la sesión. La lista de acceso anterior en la interfaz se reaplica.

Los atributos del inacl y del outacl te permiten a una lista de acceso existente específica configurada en el router. El siguiente ejemplo muestra ACL número 1 especificado como la lista de acceso:

cisco-avpair = "ipv6:inacl#1=permit 2001:0DB8:cc00:1::/48",
cisco-avpair = "ipv6:outacl#1=deny 2001:0DB8::/10",

IPv6 Prefix#

El atributo del prefix# del IPv6 te deja indicar qué prefijos a hacer publicidad en los mensajes del aviso del router de la detección de vecino. Cuando se utiliza el atributo del prefix#, una ruta correspondiente (marcada como Static ruta del por el utilizador) está instalada en los vectores del Routing Information Base (RIB) para el prefijo dado.

cisco-avpair = "ipv6:prefix#1=2001:0db8::/64",
cisco-avpair = "ipv6:prefix#2=2001:0db8::/64",

Pool del IPv6

Para la autenticación de RADIUS, el atributo del pool del IPv6 extiende a la agrupación de direcciones del IPv4 atribuida para soportar el protocolo del IPv6. Especifica el nombre de una agrupación local en el NAS del cual se utiliza conseguir el prefijo y siempre que el servicio se configure como PPP y siempre que el protocolo se especifica como IPv6. Observar que la agrupación de direcciones trabaja conjuntamente con la reunión local. Especifica el nombre de la agrupación local que se ha preconfigurado en el NAS.

Pools del prefijo del IPv6

La función de los pools del prefijo en el IPv6 es similar a la de las agrupaciones de direcciones en el IPv4. La diferencia principal es que el IPv6 asigna los prefijos bastante que las solas direcciones.

En cuanto al IPv4, un pool o una definición del pool puede ser configurado localmente o puede ser extraída de un servidor de AAA. La calidad de miembro que solapa entre los pools no se permite.

Un pool se configura una vez, él no puede ser cambiado. Si cambias la configuración, el pool será quitado y reconstruido. Todos los prefijos afectados un aparato previamente serán liberados.

Los pools del prefijo pueden ser definidos para afectar un aparato cada usuario un prefijo 64-bit o para compartir un solo prefijo entre varios usuarios. En un pool compartido del prefijo, cada usuario puede un direccionamiento RO del pool.

Cómo configurar el ADSL y desplegar el accesso del dial en el IPv6

Las pautas de configuración contenidas en esta sección muestran cómo configurar el ADSL y el accesso del dial en los ambientes del IPv6.

Configurando el NAS (requerido)

Configurando el router CE alejado (requerido)

Configurando el DHCP para que servidor del IPv6 obtenga los prefijos de los servidores de RADIUS (opcionales)

Configurando el DHCP para el IPv6 AAA y las opciones del SORBO (opcionales)

Configurar el NAS

El primer paso en configurar el accesso del dial es configurar el NAS. Saben a todos los grupos de dialer, listas de acceso, y rutas al NAS. Esta tarea muestra cómo configurar el NAS para implementar el ADSL y para desplegar el accesso del dial para los ambientes del IPv6.

PASOS DE PROGRESIÓN SUMARIOS

1. enable

2. configure terminal

3. hostname name

4. aaa new-model

5. aaa authentication ppp {default | list-name} method1 [method2...]

6. aaa authorization configuration default {radius | tacacs+}

7. show ipv6 route [ipv6-address | ipv6-prefix/prefix-length | protocol | interface-type interface-number]

8. virtual-profile virtual-template number

9. interface serial controller-number:timeslot

10. encapsulation encapsulation-type

11. exit

12. dialer-group group-number

13. ppp authentication {protocol1 [protocol2...]} [if-needed] [list-name | default] [callin] [one-time] [optional]

14. interface virtual-template number

15. ipv6 enable

16. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

17. radius-server host {hostname | ip-address} [test username user-name] [auth-port port-number] [ignore-auth-port] [acct-port port-number] [ignore-acct-port] [timeout seconds] [retransmit retries] [key string] [alias {hostname | ip-address}] [idle-time seconds]

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

hostname name

Example:

Router(config)# hostname cust1-53a

Especifica el nombre del host para el servidor de red.

Paso 4 

aaa new-model

Example:

Router(config)# aaa new-model

Habilita el servidor de AAA.

Paso 5 

aaa authentication ppp {default | list-name} method1 [method2...]

Example:

Router(config)# aaa authentication ppp default if-needed group radius

Especifica uno o más métodos de autenticación AAA para su uso en las interfaces seriales que están ejecutando el PPP.

Paso 6 

aaa authorization configuration default {radius tacacs+}

Example:

Router(config)# aaa authorization network default group radius

Descarga la información de la configuración del servidor de AAA.

Paso 7 

show ipv6 route [ipv6-address | ipv6-prefix/prefix-length | protocol | interface-type interface-number]

Example:

Router(config)# show ipv6 route

Muestra las rutas instaladas por los comandos anteriores.

Paso 8 

virtual-profile virtual-template number

Example:

Router(config)# virtual-profile virtual-template 1

Habilita los perfiles virtuales por la plantilla de interfaz virtual.

Paso 9 

interface serial controller-number:timeslot

Example:

Router(config)# interface Serial0:15

Especifica una interfaz serial creada en un E1 canalizado o controlador T1 canalizado (para ISDN PRI, Channel-Associated Signaling, o señalización del bit robado).

Paso 10 

encapsulation encapsulation-type

Router(config-if)# encapsulation ppp

Define el método de encapsulación utilizado por la interfaz.

Paso 11 

Vuelve al modo de configuración global.

Paso de progresión 12 

dialer-group group-number

Example:

Router(config)# dialer-group 1

Controlar el accesso configurando una interfaz para pertenecer a un grupo de marca específico.

Paso de progresión 13 

ppp authentication {protocol1 [protocol2...]} [if-needed] [list-name | default] [callin] [one-time] [optional]

Example:

Router(config)# ppp authentication chap

Habilita el Handshake Authentication Protocol del desafío (GRIETA) o el Password Authentication Protocol (PAP) o ambos y especifica la orden en la cual la GRIETA y la autenticación PAP se seleccionan en la interfaz.

Paso de progresión 14 

interface virtual-template number

Example:

Router(config)# interface virtual-template1

Crea una interfaz de plantilla virtual que pueda ser configurada y ser aplicada dinámicamente en crear las interfaces de acceso virtual.

Paso de progresión 15 

ipv6 enable

Example:

Router(config)# ipv6 enable

Habilita el IPv6 que procesa en una interfaz que no se ha configurado con un direccionamiento explícito del IPv6.

Paso de progresión 16 

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

Example:

Router(config)# dialer-list 1 protocol ipv6 permit

Define una lista del dialer del Dial-On-Demand Routing (DDR) para marcar por el protocolo o por una combinación de un protocolo y de una lista de acceso previamente definida.

Paso de progresión 17 

radius-server host {hostname | ip-address} [test username user-name] [auth-port port-number] [ignore-auth-port] [acct-port port-number] [ignore-acct-port] [timeout seconds] [retransmit retries] [key string] [alias {hostname | ip-address}] [idle-time seconds]

Example:

Router(config)# radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123

Especifica un host de servidor de RADIUS.


Consejos para la resolución de problemas

Verificar que la lista de acceso esté instalada correctamente antes de proceder con la tarea siguiente. Utilizarshow ipv6 access-listyshow ipv6 interfacelos comandos.

Configurar el router CE alejado

La tarea siguiente describe cómo configurar cada router CE alejado.

PASOS DE PROGRESIÓN SUMARIOS

1. enable

2. configure terminal

3. hostname name

4. interface bri number.subinterface-number [multipoint | point-to-point]

5. encapsulation encapsulation-type

6. ipv6 address autoconfig [default]

7. isdn switch-type switch-type

8. ppp authentication {protocol1 [protocol2...]} [if-needed] [list-name | default] [callin] [one-time]

9. ppp multilink [bap | required]

10. exit

11. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

12. ipv6 route ipv6-prefix/prefix-length {ipv6-address | interface-type interface-number [ipv6-address]} [administrative-distance] [administrative-multicast-distance | unicast | multicast] [tag tag]

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

hostname name

Example:

Router(config)# hostname cust1-36a

Especifica el nombre del host para el servidor de red.

Paso 4 

interface bri number.subinterface-number [multipoint | point-to-point]

Example:

Router(config)# interface BRI1/0

Configura una interfaz BRI y ingresa al modo de configuración de la interfaz.

Paso 5 

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp

Define el método de encapsulación utilizado por la interfaz.

Paso 6 

ipv6 address autoconfig [default]

Example:

Router(config-if)# ipv6 address autoconfig

Indica que el direccionamiento del IPv6 será generado automáticamente.

Paso 7 

isdn switch-type switch-type

Example:

Router(config-if)# isdn switch-type basic-net3

Especifica el tipo de switch de oficina central en la interfaz de ISDN.

Paso 8 

ppp authentication {protocol1 [protocol2...]} [if-needed] [list-name | default] [callin] [one-time]

Example:

Router(config-if)# ppp authentication chap optional

Habilita el Handshake Authentication Protocol del desafío (GRIETA) o el Password Authentication Protocol (PAP) o ambos y especifica la orden en la cual la GRIETA y la autenticación PAP se seleccionan en la interfaz.

Paso 9 

ppp multilink [bap | required]

Example:

Router(config-if)# ppp multilink

Habilita el Multilink PPP (MLP) en una interfaz y, habilita opcionalmente el Control Protocol de la asignación de ancho de banda (BACP) y el protocolo de la asignación de ancho de banda (BAP) para la asignación de ancho de banda dinámica.

Paso 10 

exit

Router(config-if)# exit

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

Paso 11 

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

Router(config)# dialer-list 1 protocol ipv6 permit

Define una lista del dialer del Dial-On-Demand Routing (DDR) para marcar por el protocolo o por una combinación de un protocolo y de una lista de acceso previamente definida.

Paso de progresión 12 

ipv6 route ipv6-prefix/prefix-length {ipv6-address | interface-type interface-number [ipv6-address]} [administrative-distance] [administrative-multicast-distance | unicast | multicast] [tag tag]

Example:

Router(config)# ipv6 route 2001:0db8:1/128 BRI1/0

Establece las rutas estáticas del IPv6. Utilizar un comando para cada ruta.


Pasos Siguientes

Una vez que has configurado el NAS y el router CE, configurar el RADIO para establecer las pares AV para el servicio repetido. El servicio repetido permite que los usuarios de la red remota marquen adentro al NAS sin la carga. Cuando se requiere el servicio repetido, el NAS cuelga para arriba la llamada actual y marca la parte posterior del llamante. Cuando el NAS realiza el servicio repetido, sólo la información para la conexión saliente es aplicada. El resto de los atributos del mensaje del access-accept del preauthentication se desecha.

El siguiente ejemplo muestra una configuración del perfil de RADIUS para un campus local:

campus1 Auth-Type = Local, Password = "mypassword"
                User-Service-Type = Framed-User,
                Framed-Protocol = PPP,
                cisco-avpair = "ipv6:inacl#1=permit dead::/64 any",
                cisco-avpair = "ipv6:route=dead::/64",
                cisco-avpair = "ipv6:route=cafe::/64",
                cisco-avpair = "ipv6:prefix=dead::/64 0 0 onlink autoconfig",
                cisco-avpair = "ipv6:prefix=cafe::/64 0 0 onlink autoconfig",
                cisco-avpair = "ip:route=10.0.0.0 255.0.0.0",

Las pares AV del RADIO para el IPv6 se describen en los atributos de usuario del RADIO para el acceso virtual en los ambientes del IPv6.

Configurar el DHCP para que servidor del IPv6 obtenga los prefijos de los servidores de RADIUS

La tarea siguiente describe cómo configurar el DHCP para que el servidor del IPv6 obtenga los prefijos de los servidores de RADIUS.

Requisitos previos

Antes de que realices esta tarea, debes configurar el cliente AAA y el PPP en el router.

PASOS DE PROGRESIÓN SUMARIOS

1. enable

2. configure terminal

3. interface type number

4. ipv6 nd prefix framed-ipv6-prefix

PASOS DETALLADOS


Configurar el DHCP para el IPv6 AAA y las opciones del SORBO

Esta tarea optativa permite que los usuarios habiliten el router para soportar las opciones AAA y SIP.

PASOS DE PROGRESIÓN SUMARIOS

1. enable

2. configure terminal

3. ipv6 dhcp pool poolname

4. prefix-delegation aaa [method-list method-list] [lifetime]

5. sip address ipv6-address

6. sip domain-name domain-name

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ipv6 dhcp pool poolname

Example:
Router(config)# ipv6 dhcp pool pool1

Configura un DHCP para el pool de información de la configuración del IPv6 y ingresa el DHCP para el modo de la configuración de agrupación del IPv6.

Paso 4 

prefix-delegation aaa [method-list method-list] [lifetime]

Example:
Router(config-dhcp)# prefix-delegation aaa 
method-list list1

Especifica que los prefijos deben ser adquiridos de los servidores de AAA.

Paso 5 

sip address ipv6-address

Example:

Router(config-dhcp)# sip address 2001:0DB8::2

Configura un direccionamiento del IPv6 del servidor del SORBO que se volverá en la opción de la lista de dirección del IPv6 del servidor del SORBO a los clientes.

Paso 6 

sip domain-name domain-name

Example:
Router(config-dhcp)# sip domain sip1.cisco.com

Configura un Domain Name del servidor del SORBO que se volverá en la opción de la lista del Domain Name del servidor del SORBO a los clientes.


Ejemplos de configuración para implementar el ADSL y desplegar el accesso del dial para el IPv6

Esta sección proporciona el siguiente ejemplo de configuración:

Implementar el ADSL y desplegar el accesso del dial para el IPv6: Ejemplo:

Implementar el ADSL y desplegar el accesso del dial para el IPv6: Ejemplo:

Este ejemplo muestra una configuración típica para el ADSL y el accesso del dial. Se requieren las tres configuraciones separadas siguientes:

Configuración de NAS

Configuración alejada del router CE

Configuración RADIUS

Configuración de NAS

Esta configuración para el ISP NAS muestra la configuración que accesso de los soportes del router CE alejado.

hostname cust1-53a
  aaa new-model
  aaa authentication ppp default if-needed group radius
  aaa authorization network default group radius 
  virtual-profile virtual-template 1
  interface Serial0:15
   encapsulation ppp
   dialer-group 1
   ppp authentication chap
  !
  interface Virtual-Template1
   ipv6 enable
  !
  dialer-list 1 protocol ipv6 permit
  radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123

Configuración alejada del router CE

Esta configuración para el router de borde del cliente remoto muestra las rutas de la encapsulación PPP y del IPv6 definidas.

hostname cust-36a
  interface BRI1/0
   encapsulation ppp
   ipv6 enable
   isdn switch-type basic-net3
   ppp authentication chap optional
   ppp multilink
  !
  dialer-list 1 protocol ipv6 permit
  ipv6 route 2001:0DB8:1/128 BRI1/0
  ipv6 route ::/0 2001:0db8:1

Configuración RADIUS

Esta configuración de RADIUS muestra la definición de las pares AV para establecer las Static rutas.

  campus1 Auth-Type = Local, Password = "mypassword"
                User-Service-Type = Framed-User,
                Framed-Protocol = PPP,
                cisco-avpair = "ipv6:inacl#1=permit dead::/64 any",
                cisco-avpair = "ipv6:route=library::/64",
                cisco-avpair = "ipv6:route=cafe::/64",
                cisco-avpair = "ipv6:prefix=library::/64 0 0 onlink autoconfig",
                cisco-avpair = "ipv6:prefix=cafe::/64 0 0 onlink autoconfig",
                cisco-avpair = "ip:route=10.0.0.0 255.0.0.0",

Adonde ir después

Para la información sobre implementar los Routing Protocol para el IPv6, referir al RIP que implementa para el IPv6, implementando el IS-IS para el IPv6, o el Multiprotocol BGP que implementa para el módulo del IPv6. Para la información sobre implementar la seguridad para los ambientes del IPv6, referir al IPSec que implementa en la seguridad del IPv6 y los filtros de tráfico el implementar y a los firewalls para los módulos de la seguridad del IPv6.

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con el ADSL que implementa y el accesso del dial que despliega para la característica del IPv6.

Documentos relacionados

Tema relacionado
Título del documento

Lista de la característica admitida del IPv6

"Comienzo aquí: Específicos de la versión de Cisco IOS Software para las características del IPv6," guía de configuración del IPv6 del Cisco IOS

Conectividad básica del IPv6

"Implementando la dirección y la conectividad básica del IPv6," guía de configuración del IPv6 del Cisco IOS

Comandos del IPv6: sintaxis de los comandos, modo de comando, valores por defecto, directrices de uso, y ejemplos completos

Referencia de Comandos del IPv6 del Cisco IOS

Autoridades de certificación e interoperabilidad, proxy RA

"Descripción general de seguridad," guía de configuración de la seguridad del Cisco IOS

Configuración de servidor de RADIUS

"Descripción general de seguridad," guía de configuración de la seguridad del Cisco IOS


Estándares


MIB


RFC


Asistencia Técnica


Información de la característica para implementar el ADSL y desplegar el accesso del dial para el IPv6

El cuadro 15 enumera las características en este módulo y proporciona los links a la información de la configuración específica. Solamente las características que fueron introducidas o modificadas en el Cisco IOS Release 12.2(13)T o una versión posterior aparecen en el vector.

Para la información sobre una característica en esta tecnología que no se documente aquí, ver el comienzo aquí: La versión de Cisco IOS Software especifica para el mapa de ruta de las características del IPv6.

Es posible que no todos los comandos estén disponibles en su versión de software de Cisco IOS. Para la información de versión sobre un comando específico, vea la documentación de referencia de comandos.

Utilizar el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software. Cisco Feature Navigator le permite determinar qué imágenes de Cisco IOS y Catalyst OS Software soportan una versión de software, un conjunto de funciones o una plataforma específica. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.


Observarlas listas del cuadro 15 solamente la versión de Cisco IOS Software que introdujo el soporte para una característica dada en un tren de versión del Cisco IOS Software dado. A menos que se indique lo contrario, las versiones posteriores de dicha serie de versiones de software de Cisco IOS también soportan esa función.


El cuadro 15 identifica la versión más temprana para cada tren del temprano-despliegue en el cual cada característica estaba disponible.

Información de la característica del cuadro 15 para implementar el ADSL y desplegar el accesso del dial para el IPv6 

Nombre de la función
Versiones
Información sobre la Función

Características aumentadas del IPv6 para el ADSL y el despliegue del dial

12.2(13)T
12.3
12,3(2)T
12.4
12.4(2)T

Varias características fueron aumentadas para habilitar el IPv6 para utilizar el ADSL y el despliegue del dial.

Las siguientes secciones proporcionan información sobre estas funciones:

Asignación de dirección para el IPv6

Configuración automática de dirección apátrida

Configurar el NAS

Configurar el router CE alejado

Soporte AAA para los atributos del IPv6 de Cisco VSA

12.2(13)T
12.3
12,3(2)T
12.4
12.4(2)T

Los atributos específicos del proveedor (VSA) fueron desarrollados para soportar el AAA para el IPv6.

La sección siguiente proporciona la información sobre esta característica:

Atributos AAA para el IPv6

PPPoA

12.2(13)T
12.3
12,3(2)T
12.4
12.4(2)T

El ADSL y el despliegue del dial está disponibles para las interfaces con la encapsulación PPP habilitada, incluyendo el PPPoA.

Las siguientes secciones proporcionan información sobre estas funciones:

Asignación de dirección para el IPv6

Configurar el NAS

Configurar el router CE alejado

PPPoE

12.2(13)T
12.3
12,3(2)T
12.4
12.4(2)T

El ADSL y el despliegue del dial está disponibles para las interfaces con la encapsulación PPP habilitada, incluyendo el PPPoE.

Las siguientes secciones proporcionan información sobre estas funciones:

Asignación de dirección para el IPv6

Configurar el NAS

Configurar el router CE alejado

Pools del prefijo del IPv6

12.2(13)T
12.3
12,3(2)T
12.4
12.4(2)T

La función de los pools del prefijo en el IPv6 es similar a la de las agrupaciones de direcciones en el IPv4. La diferencia principal es que el IPv6 asigna los prefijos bastante que las solas direcciones.

Las siguientes secciones proporcionan información sobre estas funciones:

Atributos AAA para el IPv6

Configuración automática de dirección apátrida

Pools del prefijo del IPv6

Configurar el NAS

Configurar el router CE alejado

Soporte AAA para los atributos de RADIUS del IPv6 del RFC 3162

‘12.3(4)T’
12.4
12.4(2)T

Los atributos AAA para el IPv6 son obedientes con el RFC 3162 y requieren a un servidor de RADIUS capaz de soportar el RFC 3162.

Las siguientes secciones proporcionan información sobre estas funciones:

Atributos AAA para el IPv6

Requisitos previos para usar los atributos AAA para el IPv6

Atributos de usuario del RADIO para el acceso virtual en los ambientes del IPv6

Configurar el DHCP para que servidor del IPv6 obtenga los prefijos de los servidores de RADIUS

Configurar el DHCP para el IPv6 AAA y las opciones del SORBO

DHCP para la delegación del prefijo del IPv6 vía el AAA

12.2(18)SXE
12.3(14)T
12.4
12.4(2)T

Las siguientes secciones proporcionan información sobre estas funciones:

Configuración automática de dirección apátrida

Delegación del prefijo

Pools del prefijo del IPv6

Requisitos previos para usar los atributos AAA para el IPv6

Configurar el DHCP para el IPv6 AAA y las opciones del SORBO

SSO - IPv6 del PPPoE

12.2(33)XNE

Esta característica se soporta en el Cisco IOS Release 12.2(33)XNE.