IP : IP versión 6

Configure la característica de la preferencia local del IPv6 BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento explica la característica Preferencia Local del Border Gateway Protocol (BGP) de IPv6. La preferencia local es una indicación para el AS sobre qué trayectoria tiene preferencia para salir del AS a fin de alcanzar una red determinada. Se prefiere un trayecto con preferencia local más alta. El valor predeterminado de preferencia es 100.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Comprensión del Routing Protocol BGP y de su operación

  • Comprensión del esquema de direccionamiento del IPv6

Componentes Utilizados

La información en este documento se prueba en estas versiones de software y hardware

  • Cisco IOS Software Release 12.4, conjunto de características anticipado de los Servicios IP

  • • Routers de acceso multiservicio Cisco de la serie 3700

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

En el ejemplo, el r1, el r2 y el R3 del router son el número del sistema autónomo 123 de la parte de BGP. El R4 es el sistema autónomo 101 de la parte de y el sistema autónomo 100 de la parte de R5.

Configuran al tres Routers (r1, r2 y R3) con OSPFv3 para la Conectividad IGP. Prefijo del IPv6 del loop - la interfaz posterior Lo 0 (1111:111:111:A::/64 eui-64, 2222:222:222:A::/64 eui-64 y 3333:333:333:A::/64 eui-64) del tres Routers se hace publicidad en el área 0 del Routing Protocol OSPFv3.

La mirada del IBGP se forma entre el r1 del Routers, el r2 y el R3 con los prefijos aprendidos del loopback. El r1 del router y el R4 están conectados sobre un link PÁLIDO (conexión en serie) y forma el peering EBGP. Semejantemente el router R3 y R5 está formando el EBGP que mira sobre el link PÁLIDO.

El router R4 y R5 inyecta los mismos prefijos del IPv6:

  1. red BC01:BC1:10:A::/64

  2. red BC02:BC1:11:A::/64

  3. red BC03:BC1:12:A::/64

Pues el dos Routers R4 y R5 inyecta los mismos prefijos del IPv6, la selección de trayecto se basa en los atributos bien conocidos BGP. En este ejemplo, se elige la preferencia local. El valor de la preferencia local BGP de 500 se fija para el prefijo BC01:BC1:10:A::/64 en el router R3 con el route-map. Esto da lugar al R3 como el punto de salida para este prefijo y r1 el punto de salida para los dos prefijos restantes.

Configurar

Las interfaces Fast Ethernet (F0/0 y F0/1) del r1, del r2 y del R3 del Routers son IPv6 habilitado con el direccionamiento del IPv6 del formato eui-64.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Nota: Habilitan a todo el Routers con la expedición de los paquetes del IPv6 usando el comando del Unicast Routing del IPv6.

R1
interface Loopback0
 no ip address
 ipv6 address 1111:111:111:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 description CONNECTED TO Rtr2
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
route-map CONNECTED permit 10
 match interface Serial0/0
!
router bgp 123
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 remote-as 101
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 next-hop-self
  neighbor AB01:CD1:123:C:C604:16FF:FE98:0 activate
 exit-address-family

R2
interface Loopback0
 no ip address
 ipv6 address 2222:222:222:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 ospf 10 area 0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
router bgp 123
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
 exit-address-family

R3
interface Loopback0
 no ip address
 ipv6 address 3333:333:333:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
router bgp 123
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 remote-as 202
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 next-hop-self
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor AB01:CD1:123:E:C605:16FF:FE98:0 activate
 exit-address-family

!
ipv6 prefix-list 10 seq 5 permit BC01:BC1:10:A::/64
!
route-map LOCAL_PREF permit 10
 match ipv6 address prefix-list 10
 set local-preference 500
!
route-map LOCAL_PREF permit 20
!
route-map CONNECTED permit 10
 match interface Serial0/0

R4
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable

router bgp 101
 bgp router-id 4.4.4.4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

R5
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable
!
router bgp 202
 bgp router-id 5.5.5.5
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

Verificación

Esta sección proporciona la información que usted puede utilizar para confirmar su configuración trabaja correctamente.

En el r1 del router

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-02.gif

  2. resumen del unicast del show bgp ipv6

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-03.gif

En el r2 del router

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-04.gif

  2. unicast del show bgp ipv6

    Nota: Cuando la preferencia local no se configura, el r2 del router (Rtr2) tiene r1 del router (Rtr1) como su salto siguiente para todos los direccionamientos aprendidos del IPv6. http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-05.gif

  3. unicast del show bgp ipv6

    Después de configurar la preferencia local 500 para el prefijo BC01:BC1:10:A::/64, el r2 tiene una diversa salida solamente para este prefijo.

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-06.gif

    Nota: El prefijo BC01:BC1:10:A::/64 toma una trayectoria de la salida del router R3 mientras que la preferencia local se fija más alta.

En el router R3

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-07.gif

  2. resumen del unicast del show bgp ipv6

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-08.gif

Troubleshooting

Utilice estos comandos para resolver problemas

  1. haga el debug de las actualizaciones del IPv6 BGP
  2. borre el IPv6 BGP {unicast | Multicast}

Información Relacionada


Document ID: 113035