IP : Protocolo de puerta de enlace fronteriza (BGP)

Comprensión del atributo BGP MED

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

El propósito de este documento es proporcionar una mejor comprensión del atributo del Multi Exit Discriminator del Border Gateway Protocol (BGP) (MED) al cruzar sobre un límite del sistema implementandolo en diversos escenarios.

El MED proporciona una forma dinámica de influenciar otra COMO de la manera de alcanzar cierta ruta cuando hay puntas de la entrada múltiple para eso COMO. El BGP sigue un procedimiento sistemático para elegir el mejor trayecto. Hay otros atributos importantes tales como ponderación, preferencia local, origina la ruta, y COMO trayectoria que se admiten para considerar antes de considerar el atributo MED. Así pues, si ninguno de estos criterios hacen juego, el atributo MED no será considerado.

Nota: Cuando el resto de los factores son iguales, el punto de salida con el MED más bajo se prefiere.

prerrequisitos

Requisitos

Cisco recomienda que usted tiene conocimiento básico del BGP.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Los escenarios discutidos en este documento utilizan estas versiones de software y hardware:

  • Escenario 1: Cisco 2600 Router en el Software Release 12.4 o Posterior del ½ del ¿Â de Cisco IOSïÂ

  • Escenario 2: Cisco 2600 Router en el Cisco IOS Software Release 12.4 o Posterior

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Caso Práctico

Escenario 1

Cuando un BGP de conversación aprende una ruta de un par, el MED de la ruta se pasa a otros pares interiores BGP (iBGP), pero no a BGP exterior (eBGP) mira.

Considere esta configuración de la red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-01.gif

Aquí, el r1 del router y el r2 del router se consideran en lo mismo COMO, por ejemplo AS#100, y el router R3 pertenece a AS#101. Para el convenio fácil, los IP Addresses en el bloque de /24 se utilizan.

Se configuran el r1 y el r2 del Routers como sigue:

Router 1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 10.10.10.10
(Config-router)#bgp log-neighbor-changes
(Config-router)#network 10.10.10.10 mask 255.255.255.255 route-map ATTACH_MED
(Config-router)#neighbor 192.1.12.2 remote-as 100
(Config-router)#no auto-summary
(Config)#access-list 10 permit 10.10.10.10
(Config)#route-map ATTACH_MED permit 10
(Config)#match ip address 10
(Config)#set metric 100

Router 2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.12.1 remote-as 100
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#no auto-summary

La configuración del router R3 se da aquí:

Router 3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)#no synchronization
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

En esta configuración, el r1 y el r2 tienen ejecutarse del iBGP. Por lo tanto, cuando una actualización ingresa COMO con cierto métrico, que métrico está utilizado para tomar las decisiones dentro del COMO. El comando show ip bgp cuando le está marcado de la demostración del r2 el valor métrico para 10.10.10.10, que se inclina vía el vecino iBGP 192.1.12.1 y tendrá un valor de MED de 100.

La salida del r2 se muestra aquí:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-02.gif

funcionamientos del eBGP entre el r2 y el R3 porque éstos están en un diferente COMO. Cuando la misma actualización pasa a un tercero COMO, por ejemplo AS#101, que las devoluciones métricas a 0. El comando show ip bgp cuando está marcado del R3 tendrá su haber quitado métrica, porque 10.10.10.10 cruza COMO boundary(101).

La salida del R3 se muestra aquí:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-03.gif

De este escenario es evidente que el atributo MED puede influenciar el tráfico entrante de los sistemas autónomos vecinos. El atributo MED no puede influenciar las decisiones de ruteo de los sistemas autónomos del más-telecontrol. Cuando un BGP de conversación aprende una ruta de un par, puede pasar el MED de la ruta a cualquier par del iBGP, pero no al eBGP mira. Como consecuencia, el MED tiene importancia solamente entre los sistemas autónomos vecinos.

Escenario 2

Si la ruta inyectada en el BGP (con la red o el comando redistribute) viene de un IGP (RIP o EIGRP o OSPF), el MED se deriva del IGP métrico y la ruta se hace publicidad a un vecino eBGP con este MED.

Este escenario utiliza esta configuración de la red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-04.gif

En esta red, el r1 se configura para ejecutarse en una red del RIP. R2 del Routers y R3 funcionamiento BGP, donde el r2 se configura con el AS100 mientras que el R3 está con COMO 101.

Se configura el r1 del router como sigue:

R1 del router
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router rip
(Config-router)#network 10.0.0.0
(Config-router)#network 192.1.12.0
(Config-router)#no auto-summary

El r2 del Routers y el R3 se configuran para el BGP, donde la redistribución se hace en el r2 para inyectar las redes del RIP a un BGP.

R2 del router
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router rip
(Config-router)# network 192.1.12.0
(Config-router)#no auto-summary
(Config-router)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#redistribute rip metric 1
 Config-router)#no auto-summary

Router R3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)# no synchronization
(Config-router)#bgp router-id 33.33.33.33
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

RIP y BGP ejecutado en el r2. Si usted marca usando el comando show ip bgp, usted puede ver que la red de 10.0.0.0 del prefijo está mostrada con un métrico de 1, que se deriva del RIP.

La salida del r2 se muestra aquí:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-05.gif

Sin embargo, en el R3 que se ejecuta en el eBGP, la red es hecha publicidad considerando el valor de MED derivado del IGP. En este caso es RIP. El prefijo 10.0.0.0 se hace publicidad con el valor de MED IGP, que es el 1. métrico RIP.

Esto puede visto en esta salida:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-06.gif

De este escenario el comportamiento del MED, en el caso de las redes que son inyectadas al router BGP vía la red o al comando redistribute, se considera claramente donde el valor de MED real se está substituyendo por el del IGP métrico. Ahora, dado que este atributo es una indirecta a los vecinos externos sobre la preferencia de trayecto en COMO. Según lo expuesto anterior, no se considera siempre si hay otros más atributos importantes para determinar la mejor ruta. Para tener el mismo efecto con un atributo más determinista, utilice el comando set as-path prepend bajo el Route Map. Si usted prepend A MEDIDA QUE las rutas de la trayectoria con certeza, él continuarán siendo consideradas por otro COMO. Para más información sobre el uso del as-path prepend, refiera al uso del conjunto-aspath prepend el comando.


Información Relacionada


Document ID: 112965