Guía de configuración de controlador de la frontera de la sesión de los Cisco 7600 Series Router
Implementar SBC Multi-VRF
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 258 KB | Inglés (28 Abril 2008) | Comentarios

Contenidos

Implementar SBC Multi-VRF

Contenido

Requisitos previos — Implementar el Multi-VRF

Información sobre implementar el Multi-VRF

Interrogación que reconoce VRF DNS

Implementar el Multi-VRF

Configurar el Multi-VRF

Configurar una interrogación que reconoce VRF DNS

Esta tarea configura una interrogación DNS para un VRF.

Asociación de una adyacencia de H.323 a un VRF

Asociación de una adyacencia del SORBO a un VRF

Configurando DBE con el VRF — Modelo distribuido solamente

Ejemplos de configuración para implementar el Multi-VRF

Configurar el Multi-VRF: Ejemplo:

Configuración de la interrogación DNS: Ejemplo:

Asociación de una adyacencia de H.323 a un VRF: Ejemplo:

Asociación de una adyacencia del SORBO a un VRF: Ejemplo:

Configurar DBE con VRF (modelo distribuido solamente): Ejemplo:


Implementar SBC Multi-VRF


El regulador de la frontera de la sesión (SBC) proporciona el soporte para multi-VRF (VPN Routing and Forwarding) en los dispositivos de la frontera del cliente (CE). Esta característica proporciona la capacidad de suprimir los controles del borde del proveedor (PE) para prevenir los loopes cuando el PE está realizando una redistribución recíproca de los paquetes.


La notaVRF se soporta solamente en el direccionamiento del direccionamiento de los media DBE y de control SBE AAA/H248; El direccionamiento de control DBE H248 no soporta el VRF.



Observepara las versiones de la versión 3.0.00 SBC de ACE y posterior, esta característica se soporta en el modelo unificado y el modelo distribuido.


Para una descripción completa de los comandos usados en este capítulo, refiera al capítulo 39, “los comandos controller de la frontera de la sesión de Cisco.” Para localizar la documentación para otros comandos que aparecen en este capítulo, utilizan el índice principal de referencia de comandos, o buscan en línea.

Historial de la característica para implementar SBC MULTI-VRF

Versión
Modificación

Versión 3.0.1 SBC de ACE

Apoyo añadido para la interrogación que reconoce VRF DNS.

Versión 3.0.00 SBC de ACE

Apoyo añadido para el modelo unificado SBC.

Las secciones siguientes fueron agregadas:

Configurar el Multi-VRF

Asociación de una adyacencia de H.323 a un VRF

Asociación de una adyacencia del SORBO a un VRF

Versión 2.0.00 SBC de ACE

Esta característica fue introducida en el Cisco 7600 Series Router.


Contenido

Este módulo contiene las secciones siguientes:

Requisitos previos — Implementar el Multi-VRF

Información sobre implementar el Multi-VRF

Implementar el Multi-VRF

Ejemplos de configuración para implementar el Multi-VRF

Requisitos previos — Implementar el Multi-VRF

Los requisitos previos siguientes se requieren implementar SBC MULTI-VRF:

En el módulo del motor del control de la aplicación (ACE), usted debe ser Usuario administrador para ingresar los comandos SBC. Para más información, vea la guía de administración del módulo del motor del control de la aplicación en: http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA2_3_0/configuration/administration/guide/admgd.html

Antes de implementar el multi-VRF, el SBC debe ser creado ya. Vea los procedimientos descritos en el capítulo 2, “los requisitos previos de la configuración de ACE para el SBC.”

Información sobre implementar el Multi-VRF

El soporte SBC para el multi-VRF en la característica de los dispositivos de la frontera del cliente (CE) (es decir, Routers de las instalaciones del cliente) proporciona la capacidad de suprimir los controles PE que son necesarios prevenir los loopes cuando el PE está realizando una redistribución recíproca de los paquetes. El Multi-VRF permite el uso de solamente un router de lograr las tareas que los routeres múltiples realizan generalmente. Se ejecuta en una red sin el requisito del MPLS y del BGP instalados.

Cuando el VRF se utiliza en un router que no sea un PE, los controles se pueden apagar para tener en cuenta la población correcta de la tabla de ruteo VRF con las rutas a los prefijos IP. El Multi-VRF es también importante porque las funciones del Red privada virtual (VPN) no se soportan totalmente en los sistemas de menor capacidad. El Multi-VRF proporciona la separación lógica de casos de la encaminamiento (y por el espacio de la dirección de la implicación) dentro de un router.

Lo que sigue resume las características del multi-VRF:

Permite que un solo router físico esté partido en los routeres virtuales múltiples, donde cada router contiene su propio conjunto de las interfaces, de la tabla de ruteo, y de la tabla de reenvío. El SBC soporta (el solapar y independiente) las tablas de ruteo múltiples (dirección) por el cliente. Los contextos del ruteo virtual se utilizan para separar los dominios de ruteo dentro de un único router.

El Multi-VRF puede ser utilizado donde se requieren los routeres múltiples pero solamente uno está disponible.

Una interfaz física puede pertenecer a los routeres virtuales múltiples con el uso de las subinterfaces (Frame Relay, atmósfera, los VLA N).

El BGP y el MPLS no se utilizan.

No se proporciona ninguna Conectividad entre los VRF (requeriría usando el BGP para la exportación interna e importar entre los VRF).

Cuando una llamada se pone entre dos puntos finales en el mismo sitio VPN, el SBC puede rutear los media directamente entre ellos, para reducir la utilización de la red.

El Multi-VRF en el SBC proporciona la optimización donde están ambos puntos finales en el mismo VPN, girando puente de los media.

Para la versión 3.0.00 SBC de ACE, por abandono, todas las adyacencias en el mismo VPN tienen puente de los media girado. Los media desvían se pueden apagar usando media-bypass-forbid el comando (este comando se implementa para las directivas CAC solamente).


Observeel nombre VRF bajo adyacencia debe hacer juego el nombre del contexto.


Interrogación que reconoce VRF DNS

Esta característica permite que el SBC pregunte el DNS por el VRF. Antes de que la versión 3.0.1 SBC de ACE, todas las interrogaciones DNS fuera realizada dentro del contexto Admin; esta característica permite que las interrogaciones DNS sean realizadas sobre una base del por-contexto.

Implementar el Multi-VRF

Implementar SBC MULTI-VRF se describe en las secciones siguientes:

Configurar el Multi-VRF

Asociación de una adyacencia del SORBO a un VRF

Configurando DBE con el VRF — Modelo distribuido solamente

Configurar el Multi-VRF

Esta tarea configura al router con el SBC que se ejecuta en el modo multi-VRF en el modo unificado del despliegue. Observe la relación entre la interfaz virtual de la interfaz y del servicio SBC (SVI), adyacencia, y media-direccionamiento del elemento de la frontera de los datos (DBE) como sea necesario.

PASOS SUMARIOS

1. configure

2. context vrf

3.afectar un aparato-interfaz

4.salida

5.par pie

6.intervalo de latido

7.cuenta del latido del corazón

8.pie-interfaz vlan

9.salida

10.grupo pie

11par

12. prioridad

13. prioridad del par

14. socio-contexto

15. en servicio

16. grupo pie

17. par

18. prioridad

19. prioridad del par

20. socio-contexto

21. en servicio

22. salida

23. salida

24. changeto

25. configuración

26. interfaz vlan

27. dirección ip

28. alias

29. IP Address de Peer

30. ningún apague

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

configure

Example:

host1/Admin# configure

host1/Admin(config)#

Ingrese el modo de la configuración de módulos ACE.

Paso 2 

context


Example:

host1/Admin(config)# context my_vrf1

Crea un contexto.

Observeel nombre VRF bajo adyacencia debe hacer juego el nombre del contexto.

El ejemplo crea un nuevo contexto my_vrf1.

Paso 3 

allocate-interface vlan

Example:

host1/Admin(config-context)# allocate-interface vlan 100

Afecta un aparato el VLAN 100 al contexto my_vrf1 para permitir que el contexto reciba el tráfico clasificado para el VLAN 100.

Paso 4 

salida

Example:

host1/Admin(config)# exit

Salga del modo del config-contexto.

Paso 5 

ft peer

Example:

host1/Admin(config)# ft peer 1

host1/Admin(config-ft-peer)#

Configura a un par pie y accede el modo de la configuración de peer pie.

Paso 6 

heartbeat interval frequency

Example:

host1/Admin(config-ft-peer)# heartbeat interval 100

Configura el intervalo de latido para la sincronización de la verificación entre los pares activos y espera pie.

Paso 7 

heartbeat count number

Example:

host1/Admin(config-ft-peer)# heartbeat count 10

Configura la cuenta del latido del corazón para la sincronización de la verificación entre los pares activos y espera pie.

Paso 8 

ft-interfac vlan vlan_id

Example:

host1/Admin(config-ft-peer)# ft-interface vlan 99

Asocia un VLA N existente pie a un par.

Paso 9 

salida

Example:

host1/Admin(config)# exit

Salga del modo del config-pie-par.

Paso 10 

ft group

Example:

host1/Admin(config)# ft group 1

host1/Admin(config-ft-group)#

Configura el group1 pie con el contexto predeterminado (Admin).

Paso 11 

peer

Example:

host1/Admin(config-ft-group)# peer 1

Asocia a un par ACE a un grupo pie.

Paso 12 

priority

Example:

host1/Admin(config-ft-group)# priority 150

Configura la prioridad del miembro activo del grupo.

Paso 13 

peer priority

Example:

host1/Admin(config-ft-group)# peer priority 50

Configura la prioridad de un grupo pie en el miembro espera remoto.

Paso 14 

socio-contexto

Example:
host1/Admin(config-ft-group)# associate-context 
my_vrf1

Asocia un contexto a un grupo pie.

Paso 15 

en servicio

Example:
host1/Admin(config-ft-group)# inservice

Pone a un grupo pie en el servicio.

Paso 16 

ft group

Example:

host1/Admin(config)# ft group 2

host1/Admin(config-ft-group)#

Configura a otro grupo pie con el contexto NON-Admin.

Paso 17 

peer

Example:

host1/Admin(config-ft-group)# peer 1

Asocia a un par ACE a un grupo pie.

Paso 18 

priority

Example:

host1/Admin(config-ft-group)# priority 150

Configura la prioridad del miembro activo del grupo.

Paso 19 

peer priority

Example:

host1/Admin(config-ft-group)# peer priority 50

Configura la prioridad de un grupo pie en el miembro espera remoto.

Paso 20 

socio-contexto

Example:
host1/Admin(config-ft-group)# associate-context 
my_vrf1

Asocia un contexto a un grupo pie.

Paso 21 

en servicio

Example:
host1/Admin(config-ft-group)# inservice

Pone a un grupo pie en el servicio.

Paso 22 

salida

Example:

host1/Admin(config-ft-group)# exit

Salga del modo del config-pie-grupo.

Paso 23 

salida

Example:

host1/Admin(config)# exit

Salga del modo de configuración.

Paso 24 

changeto

Example:

host1/Admin# changeto my_vrf1

Router/vrf1#

Movimientos a partir de un contexto en ACE a otro contexto.

Paso 25 

configure

Example:

host1/my_vrf1# configure

host1/(config)#

Ingrese al modo de configuración del contexto my_vrf1.

Paso 26 

interface vlan

Example:

host1/vrf1(config)# interface vlan 100

Crea una interfaz VLAN.

El ejemplo crea un SVI usando el VLA N del VLA N 100.The fue asignado a este contexto del contexto Admin en el paso 3.

Paso 27 

ip address

Example:

host1/vrf1(config-if)# ip address 77.101.1.2 255.255.255.0

Asigna una dirección IP a una interfaz VLAN.

Paso 28 

alias

Example:

host1/vrf1(config-if)# alias 77.101.1.100 255.255.255.0

Configura una dirección IP que flote entre el active y los módulos en espera para una interfaz VLAN.

Paso 29 

peer ip address

Example:

host1/vrf1(config-if)# peer ip address 77.101.1.3 255.255.255.0

Configura la dirección IP de un módulo en espera para la interfaz VLAN.

Paso 30 

no shutdown

Example:

host1/my_vrf1(config-if)# no shutdown

Habilita una interfaz para el uso.

Configurar una interrogación que reconoce VRF DNS

Esta tarea configura una interrogación DNS para un VRF.

PASOS SUMARIOS

1. configure

2. context vrf

3.afectar un aparato-interfaz vlan

4.salida

5.sbc-nombre sbc

6.sbe

7.sorbo dns

8.caché-curso de la vida 0-1879048

9. cache-limit 0-4294967295

10.salida

11sorbo de la adyacencia adjacency-name

12. vrf_name del vrf

13. salida

14. salida

15. salida

16. salida

17. context_name del changeto

18. configuración

19. búsqueda de dominio del IP

20. Domain Name del IP

21. ip name-server

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

configure

Example:

host1/Admin# configure

Ingrese el modo de la configuración de módulos ACE.

Paso 2 

context


Example:

host1/Admin(config)# context my_vrf1

Crea un contexto.

Observeel nombre VRF bajo adyacencia debe hacer juego el nombre del contexto.

El ejemplo crea un nuevo contexto my_vrf1.

Paso 3 

allocate-interface vlan

Example:

host1/Admin(config-context)# allocate-interface vlan 100

Afecta un aparato el VLAN 100 al contexto my_vrf1 para permitir que el contexto reciba el tráfico clasificado para el VLAN 100.

Paso 4 

exit

Example:

host1/Admin(config)# exit

Sale del modo actual.

Paso 5 

sbc sbc-name

Example:

host1/Admin(config)# sbc mySbc

Crea el servicio SBC en el SBC y ingresa en el modo de configuración SBC.

Paso 6 

sbe

Example:

host1/Admin(config-sbc)# sbe

Crea el servicio SBE en un SBC y ingresa en el modo de configuración SBC-SBE.

Paso 7 

sip dns

Example:

host1/Admin(config-sbc-sbe)# sip dns

Ingresa el modo de la Configuración de DNS SIP.

Paso 8 

cache-lifetime 0-1879048

Example:

host1/Admin(config-sbe-dns)# cache-lifetime 444

Configura el curso de la vida de cualquier entrada DNS en el caché DNS.

Paso 9 

cache-limit 0-4294967295

Example:

host1/Admin(config-sbe-dns)# cache-limit 14

Configura el número máximo de entradas que se permitan en el caché DNS.

Paso 10 

exit

Example:

host1/Admin(config-sbe-dns)# exit

Sale del modo actual.

Paso 11 

adjacency sip adjacency-name

Example:

host1/Admin(config-sbc-sbe)# vrf vpn3

Configura una adyacencia para un servicio SBC.

Paso 12 

vrf vrf_name

Example:

host1/Admin(config-sbc-sbe-adj-sip)# vrf vpn3

Configura una adyacencia del SORBO atada a un VPN específico.

Paso 13 

exit

Example:

host1/Admin(config-sbc-sbe-adj-sip)# exit

Sale del modo actual.

Paso 14 

exit

Example:

host1/Admin(config-sbc-sbe-adj)# exit

Sale del modo actual.

Paso 15 

exit

Example:

host1/Admin(config-sbe)# exit

Sale del modo actual.

Paso 16 

exit

Example:

host1/Admin(config)# exit

Sale del modo actual.

Paso 17 

changeto context_name

Example:

host1/Admin# changeto vrf120

Movimientos a partir de un contexto en ACE a otro contexto.

Paso 18 

configure

Example:

host1/Admin# configure

Ingresa el modo de la configuración de módulos ACE.

Paso 19 

ip domain-lookup

Example:

host1/Admin(config)# ip domain-lookup

Permite al módulo de ACE para realizar una búsqueda de dominio (traducción del host-a-direccionamiento) con un servidor DNS.

Paso 20 

ip domain-name

Example:

host1/Admin(config)# ip domain-name cisco.com

Configura un Domain Name predeterminado.

Paso 21 

ip name-server

Example:

host1/Admin(config)# ip name-server 192.168.12.15

Configura un servidor del nombre DNS en el módulo de ACE. Usted puede configurar un máximo de tres servidores del nombre DNS.

Asociación de una adyacencia de H.323 a un VRF

Esta tarea asocia una adyacencia de H.323 a un VPN.

PASOS SUMARIOS

1. adjacency h323 adjacency-name

2.vrf vrf_name

3.signaling-address ipv4 local_signaling_IP_address

4.signaling-port port_num

5.remote-address ipv4 remote_IP_address/prefijo

6.signaling-peer peer_addressgk del []

7.signaling-peer-port port_num

8.accountaccount_name

9. media-bypass (Optional command)

10. media-bypass-forbid

11. attach

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

adjacency h323 adjacency-name

Example:

host1/Admin(config-sbc-sbe)# adjacency h323 h323my_vrf1

host1/Admin(config-sbc-sbe-adj-h323)#

Ingresa el modo de una adyacencia SBE H.323.

Utilice el argumento del adyacencia-nombre para definir el nombre del servicio.

Paso 2 

vrf vrf_name

Example:

host1/Admin(config-sbc-sbe-adj-h323)# vrf my_vrf1

Ata una adyacencia de H.323 a un VPN específico.

Observeel nombre VRF bajo adyacencia debe hacer juego el nombre del contexto.

Paso 3 

signaling-address ipv4 local_signaling_IP_address

Example:

host1/Admin(config-sbc-sbe-adj-h323)# signaling-address ipv4 88.88.101.11

Especifica el IPv4 local que señala el direccionamiento de la adyacencia de H.323.

Paso 4 

signaling-port port_num

Example:

host1/Admin(config-sbc-sbe-adj-h323)# signaling-port 1720

Especifica el puerto local de la señalización de la adyacencia de H.323.

Paso 5 

remote-address ipv4 ipv4_IP_address/prefix

Example:

host1/Admin(config-sbc-sbe-adj-h323)# remote-address ipv4 10.10.101.4 255.255.255.255

Restringe el conjunto de los pares remotos de la señalización entrados en contacto sobre la adyacencia a ésos con el prefijo dado de la dirección IP.

Paso 6 

signaling-peer [gk] peer_address

Example:

host1/Admin(config-sbc-sbe-adj-h323)# signaling-peer gk 10.10.101.4

Especifica al par remoto de la señalización para que la adyacencia de H.323 utilice.

Paso 7 

signaling-peer-port port_num

Example:

host1/Admin(config-sbc-sbe-adj-h323)# signaling-peer-port 1720

Especifica el puerto remoto del señalización-par para que la adyacencia de H.323 utilice.

Paso 8 

account account_name

Example:

host1/Admin(config-sbc-sbe-adj-h323)# account h323-vrf1

Define la adyacencia de H.323 como perteneciendo a una cuenta en un SBE.

Paso 9 

media-bypass

Example:

host1/Admin(config-sbc-sbe-adj-h323)# media-bypass

(Opcional) configure la adyacencia para permitir que el tráfico de los media desvíe el DBE.

Este comando es opcional y trabajará solamente en una adyacencia.

Paso 10 

media-bypass-forbid

Example:

host1/Admin(config-sbc-sbe-adj-h323)# media-bypass-forbid

Configura la adyacencia de H.323 para prohibir el tráfico de los media para desviar el DBE.

El si esto no está configurado, los media trafica para las llamadas que originan y que terminan en los flujos de esta adyacencia directamente entre los puntos finales y no pasa con el DBE, mientras ambas adyacencias estén en el mismo VPN.

Paso 11 

attach

Example:

host1/Admin(config-sbc-sbe-adj-h323)# attach

Asocia la adyacencia.

Asociación de una adyacencia del SORBO a un VRF

Esta tarea asocia una adyacencia del SORBO a un VPN.

PASOS SUMARIOS

1. adjacency sip adjacency-name

2. vrf vrf_name

3. signaling-address ipv4 local_signaling_IP_address

4. signaling-port port_num

5. remote-address ipv4 local_signaling_IP_address/prefix

6. local-id host name

7.signaling-peer []gk peer_address

8. signaling-peer-port port_num

9. account account-name

10. media-bypass (optional)

11. media-bypass-forbid

12. attach

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

adjacency sip adjacency-name

Example:

host1/Admin(config-sbc-sbe)# adjacency sip sip_vrf1

host1/Admin(config-sbc-sbe-adj-sip)#

Ingresa el modo de una adyacencia SBE SIP.

Utilice el argumento del adyacencia-nombre para definir el nombre del servicio.

Paso 2 

vrf vrf_name

Example:

host1/Admin(config-sbc-sbe-adj-sip)# vrf my_vrf1

Ata una adyacencia de H.323 a un VPN específico.

Observeel nombre VRF bajo adyacencia debe hacer juego el nombre del contexto.

Paso 3 

signaling-address ipv4 ipv4_IP_address

Example:

host1/Admin(config-sbc-sbe-adj-sip)# signaling-address ipv4 88.88.88.88.101.11

Especifica el IPv4 local que señala el direccionamiento de la adyacencia del SORBO.

Paso 4 

signaling-port port_num

Example:

host1/Admin(config-sbc-sbe-adj-sip)# signaling-port 5060

Especifica el puerto local de la señalización de la adyacencia del SORBO.

Paso 5 

remote-address ipv4 remote_IP_address/prefix

Example:

host1/Admin(config-sbc-sbe-adj-sip)# remote-address ipv4 10.10.101.4 255.255.255.255

Restringe el conjunto de los pares remotos de la señalización entrados en contacto sobre la adyacencia a ésos con el prefijo dado de la dirección IP.

Paso 6 

local-id host address

Example:

host1/Admin(config-sbc-sbe-adj-sip)# local-id host 88.88.101.11

Configura el nombre local de la identidad en una adyacencia del SORBO.

Paso 7 

signaling-peer [gk] peer_address

Example:

host1/Admin(config-sbc-sbe-adj-sip)# signaling-peer 10.10.101.4

Especifica al par remoto de la señalización para que la adyacencia del SORBO utilice.

Paso 8 

signaling-peer-port port_num

Example:

host1/Admin(config-sbc-sbe-adj-sip)# signaling-peer-port 5060

Especifica el puerto remoto del señalización-par para que la adyacencia del SORBO utilice.

Paso 9 

account account_name

Example:

host1/Admin(config-sbc-sbe-adj-sip)# account sip-vrf1

Define la adyacencia del SORBO como perteneciendo a una cuenta en un SBE.

Paso 10 

media-bypass

Example:

host1/Admin(config-sbc-sbe-adj-sip)# media-bypass

(Opcional) configura la adyacencia para permitir que el tráfico de los media desvíe el DBE.

Este comando es opcional y trabaja solamente en una adyacencia.

Paso 11 

media-bypass-forbid

Example:

host1/Admin(config-sbc-sbe-adj-sip)# media-bypass-forbid

Configura la adyacencia del SORBO para prohibir el tráfico de los media para desviar el DBE.

El si esto no está configurado, los media trafica para las llamadas que originan y que terminan en los flujos de esta adyacencia directamente entre los puntos finales y no pasa con el DBE, mientras ambas adyacencias estén en el mismo VPN.

Paso 12 

attach

Example:

host1/Admin(config-sbc-sbe-adj-sip)# attach

Asocia la adyacencia.

Configurando DBE con el VRF — Modelo distribuido solamente

Esta tarea configura DBE con el VRF en el modelo distribuido.

PASOS SUMARIOS

1. configure

2.sbc sbc-nombre

3. dbe

4.vdbe global

5.inesperado-fuente-alertando

6.abcd del puerto local

7.control-address h248 ipv4A.B.C.D

8. controller h248 controller-index

9.dirección remota de la dirección remota ipv4

10.[port-num] del puerto remoto

11transport []udp | tcp

12. attach-controllers

13. vrf del A.B.C.D E.F.G.H del pool ipv4 del media-direccionamiento vrfname

14. descanso del media-descanso

15. tiempo del sobrecarga-tiempo-umbral

16. deact-MODE

17. activate

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

configure

Example:

host1/Admin# configure

Accede al modo de configuración.

Paso 2 

sbc sbc-name

Example:

host1/Admin(config)# sbc mySbc

Crea el servicio SBC en el SBC y ingresa en el modo de configuración SBC.

Paso 3 

dbe

Example:

host1/Admin(config-sbc)# dbe

Crea el servicio DBE en un SBC y ingresa en el modo de configuración SBC-DBE.

Paso 4 

vdbe [global]



Example:

host1/Admin(config-sbc-dbe)# vdbe

Ingresa en el submode de la configuración del vDBE.


Observeen la versión inicial se soporta solamente que un vDBE (el vDBE global). El nombre del vdbe no se requiere. Si está especificado, debe ser global.


Paso 5 

unexpected-source-alerting

Example:

host1/Admin(config-sbc-dbe-vdbe-global)# unexpected-source-alerting

Conjuntos que alertan para las direcciones de origen inesperadas.

La ninguna forma de este comando quita alertar para cualquier dirección de origen inesperada se reciba que.

Paso 6 

local-port {abcd}

Example:

host1/Admin(config-sbc-dbe)# local-port 5090

Configura un DBE para utilizar un puerto local específico.

Paso 7 

control-address h248 ipv4 A.B.C.D

Example:

host1/Admin(config-sbc-dbe)# control-address h248 ipv4 10.0.0.1

Configura un DBE para utilizar un direccionamiento de control específico del IPv4 H.248.

Paso 8 

controller h248 controller-index

Example:

host1/Admin(config-sbc-dbe)# controller h248 1

Identifica el regulador H.248 para el DBE y ingresa en el modo de configuración del regulador H.248.

Paso 9 

remote-address ipv4 remote-address

Example:

host1/Admin(config-sbc-dbe-vdbe-h248)# remote-address ipv4 1.1.1.1

Configura a la dirección remota del IPv4 del regulador H.248.

Paso 10 

remote-port [port-num]

Example:

host1/Admin(config-sbc-dbe-h248)# remote-port 2094

Define el puerto para conectar con en el SBE para un regulador H.248.

Paso 11 

transport udp

Example:

host1/Admin(config-sbc-dbe-h248)# transport udp

Configura un DBE para utilizar el User Datagram Protocol (UDP) para la señalización de control H.248.

Paso 12 

attach-controllers

Example:

host1/Admin(config-sbc-dbe)# attach-controllers

Configure un DBE para asociar a un regulador H.248.

Paso 13 

media-address pool ipv4 A.B.C.D E.F.G.H vrf vrfname

Example:

host1/Admin(config-sbc-dbe)# media-address pool ipv4 10.10.10.1 10.10.10.20 vrf my_vrf1

Cree un pool de los direccionamientos secuenciales de los media del IPv4 para un direccionamiento del IPv4 asociado a un caso específico VRF.

Observeel nombre VRF bajo adyacencia debe hacer juego el nombre del contexto.

Paso 14 

media-timeout timeout

Example:

host1/Admin(config-sbc-dbe)# media-timeout 10

Fija el tiempo máximo las esperas DBE después de recibir los paquetes de medios más recientes en una llamada y antes de limpiar los recursos de la llamada.

Paso 15 

overload-time-threshold time

Example:

host1/Admin(config-sbc-dbe)# overload-time-threshold 400

Configura el umbral para la detección del control de la sobrecarga del gateway de medios (MG).

Paso 16 

deact-mode normal

Example:

host1/Admin(config-sbc-dbe)# deactivation-mode normal

Especifica que el DBE de un SBC señala un cambio del servicio y termina todo invita la desactivación del servicio DBE.

Paso 17 

activate

Example:

host1/Admin(config-sbc-dbe)# activate

Inicia el servicio SBC.

Ejemplos de configuración para implementar el Multi-VRF

Esta sección proporciona los siguientes ejemplos de configuración:

Configurar el Multi-VRF: Ejemplo:

Asociación de una adyacencia de H.323 a un VRF: Ejemplo:

Asociación de una adyacencia del SORBO a un VRF: Ejemplo:

Configurar DBE con VRF (modelo distribuido solamente): Ejemplo:

Configurar el Multi-VRF: Ejemplo:

Esta configuración de muestra muestra cómo la interfaz virtual del servicio (SVI) y las adyacencias se agregan para asociar un VPN a ellos.

1.Configure la interfaz del linecard asociada al vrf my_vrf1 en el supervisor.

vrf definition my_vrf1 
rd 55:1111 
! 
address-family ipv4 
exit-address-family 
! 

2.Configure la interfaz del linecard asociada al vrf my_vrf1 en el supervisor.

interface GigabitEthernet1/3 
description ''Connected to CAT-3550-101 Fa 0/13 vlan919'' 
vrf forwarding my_vrf1 
ip address 10.122.3.3 255.255.255.0 

interface Vlan 99 
vrf forwarding my_vrf1 
ip address 99.101.1.1 255.255.255.0 
! 

3.Configure el contexto en el indicador luminoso LED amarillo de la placa muestra gravedad menor de ACE y asigne el VLA N.

context my_vrf1 
allocate-interface vlan 99 

4.Configure al grupo pie.


Notausted debe configurar el group1 pie con el contexto predeterminado (Admin) (en este caso, my_vrf1).


ft group 1
peer 1
priority 127
peer priority 126
associate-context my_vrf1
inservice

5.Configure la interfaz en el contexto my_vrf1 para el cual usted necesita utilizar el cambio al CLI para cambiar el contexto.

ACE-101-UUT1-1/Admin# changeto my_vrf1 
ACE-101-UUT1-1/my_vrf1# 

interface vlan 99 
ip address 99.101.1.2 255.255.255.0 
alias 99.101.1.100 255.255.255.0 
peer ip address 99.101.1.3 255.255.255.0 
no shutdown 

ip route 10.0.0.0 255.0.0.0 99.101.1.1 
ip route 100.0.0.0 255.0.0.0 99.101.1.1 

6.Configure el DBE.

dbe
    media-address pool ipv4 88.88.101.12  88.88.101.15 vrf my_vrf1
    activate

Configuración de la interrogación DNS: Ejemplo:

Esta configuración de muestra configura una interrogación DNS.

context vrf110
  allocate-interface vlan 110
context vrf120
  allocate-interface vlan 120

sbc mysbc
  sbe
    sip dns
      cache-lifetime 6000
      cache-limit 100
    ...
    adjacency sip sip1
      vrf vrf110
      ...
    adjacency sip sip2
      vrf vrf120
      ...

host1/Admin# changeto vrf110
ip domain-lookup
ip domain-name test.com
ip name-server 192.168.110.2

host1/Admin# changeto vrf120
ip domain-lookup
ip domain-name test1.com
ip name-server 192.168.120.2

Asociación de una adyacencia de H.323 a un VRF: Ejemplo:

Esta configuración de muestra crea una adyacencia de H.323 asociada a un VPN.

adjacency h323 h323my_vrf1
   vrf my_vrf1 
   signaling-address ipv4 88.88.101.11 
   signaling-port 1720 
   remote-address ipv4 10.10.101.4 255.255.255.255 
   signaling-peer 10.10.101.4 
   signaling-peer-port 1720 
   account h323-my_vrf1 
   attach 

Asociación de una adyacencia del SORBO a un VRF: Ejemplo:

Este ejemplo de configuración crea una adyacencia del SORBO asociada a un VPN. Observe que hay un grupo pie configurado para cada contexto.


ft interface vlan 99
  ip address 10.10.10.15 255.255.255.0
  peer ip address 10.10.10.16 255.255.255.0
  no shutdown

ft peer 1
  heartbeat interval 100
  heartbeat count 10
  ft-interface vlan 99
ft group 1
  peer 1
  priority 127
  peer priority 126
  associate-context Admin
  inservice

ip route 10.10.0.0 255.255.0.0 101.101.101.100 ip route 20.20.20.0 255.255.255.0 
101.101.101.4

context vlan100
  description vlan100
  allocate-interface vlan 100

ft group 2
  peer 1
  priority 127
  peer priority 126
  associate-context vlan100
  inservice
username admin password 5 $1$faXJEFBj$TJR1Nx7sLPTi5BZ97v08c/  role Admin domain 
default-domain username www password 5 $1$UZIiwUk7$QMVYN1JASaycabrHkhGcS/  role Admin 
domain default-domain

sbc mysbc
  sbe
    adjacency sip 7200-1
      vrf vlan100
      inherit profile preset-core
      preferred-transport udp
      redirect-mode pass-through
      authentication nonce timeout 300
      signaling-address ipv4 101.101.101.3
      signaling-port 5061
      remote-address ipv4 0.0.0.0 0.0.0.0
      signaling-peer 101.101.101.5
      signaling-peer-port 5060
      dbe-location-id 0
      account sip-core
      attach
    adjacency sip 7200-2
      vrf vlan100
      inherit profile preset-access
      preferred-transport udp
      redirect-mode pass-through
      authentication nonce timeout 300
      signaling-address ipv4 101.101.101.3
      signaling-port 5060
      remote-address ipv4 0.0.0.0 0.0.0.0
      signaling-peer 101.101.101.4
      signaling-peer-port 5060
      dbe-location-id 0
      account sip-core
      attach
    adjacency sip 7200-3
      vrf vlan100
      nat force-on
      inherit profile preset-core
      preferred-transport udp
      redirect-mode pass-through
      authentication nonce timeout 300
      signaling-address ipv4 101.101.101.3
      signaling-port 5063
      remote-address ipv4 0.0.0.0 0.0.0.0
      signaling-peer 101.101.101.5
      signaling-peer-port 5063
      dbe-location-id 0
      account sip-core
      reg-min-expiry 3000
      attach
    sip inherit profile preset-standard-non-ims

    retry-limit 3

    call-policy-set 1
      first-call-routing-table invite-table
      first-reg-routing-table start-table
      rtg-src-adjacency-table invite-table
        entry 1
          action complete
          dst-adjacency 7200-2
          match-adjacency 7200-3
        entry 2
          action complete
          dst-adjacency 7200-3
          match-adjacency 7200-2
      rtg-src-adjacency-table start-table
        entry 1
          action complete
          dst-adjacency 7200-1
          match-adjacency 7200-2
        entry 2
          action complete
          dst-adjacency 7200-2
          match-adjacency 7200-1
      complete
    active-call-policy-set 1

    network-id 2

    sip max-connections 2
    sip timer
      tcp-idle-timeout 120000
      tls-idle-timeout 3600000
      udp-response-linger-period 32000
      udp-first-retransmit-interval 500
      udp-max-retransmit-interval 4000
      invite-timeout 180

    blacklist
      global
    redirect-limit 2
    deact-mode normal
    activate

  dbe
    media-address ipv4 101.101.101.160 vrf vlan100 port-range 11000 20000 any
    location-id 0
    media-timeout 30
    deact-mode normal
    activate

newace4/Admin# changeto vlan100
newace4/vlan100# sh run
Generating configuration....

interface vlan 100
  ip address 101.101.101.1 255.255.255.0
  alias 101.101.101.3 255.255.255.0
  peer ip address 101.101.101.2 255.255.255.0
  no shutdown

ip route 0.0.0.0 0.0.0.0 101.101.101.100

Configurar DBE con VRF (modelo distribuido solamente): Ejemplo:

En este ejemplo, un contexto llamado my_vrf1 se crea y un VLA N se afecta un aparato para my_vrf1.

contexto my_vrf1
afectar un aparato-interfaz 97 vlan

Crean y se asocian a un grupo incidente-tolerante al contexto my_vrf1.

group2 pie
par 1
prioridad 127
prioridad 126 del par
socio-contexto my_vrf1
en servicio

Un SBC se configura con un direccionamiento de los media asociado al contexto my_vrf1.

sbc j
dbe
vdbe global
el inesperado-fuente-alertar
puerto local 2985
control-direccionamiento h248 ipv4 87.87.29.100
regulador h248 1
dirección remota ipv4 200.200.200.123
puerto remoto 2985
UDP del transporte
fijación-reguladores
vrf my_vrf1 del media-direccionamiento ipv4 97.97.29.100
pool ipv4 87.87.29.100 87.87.29.101 del media-direccionamiento
media-descanso 3600
sobrecarga-tiempo-umbral 100
deact-MODE normal
active

(en el contexto creado recientemente my_vrf1)

Se crea una interfaz VLAN

interfaz 97 vlan
dirección IP 97.97.29.2 255.255.255.0
alias 97.97.29.100 255.255.255.0
IP Address de Peer 97.97.29.252 255.255.255.0
ningún apague
ruta de IP 200.200.200.0 255.255.255.0 97.97.29.1
ruta de IP 20.20.29.0 255.255.255.0 97.97.29.1

La interfaz VLAN se asocia a my_vrf1 en el Supervisor Engine:

interfaz Vlan 97
reenvío de VRF my_vrf1
dirección IP 97.97.29.1 255.255.255.0