Módulos e interfaces de Cisco : Cisco Catalyst 6500 Series Multilayer Switch Feature Card

EIGRP del Catalyst 6500 sobre el ejemplo de configuración de VRF-Lite

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar el EIGRP sobre la expedición de la ruta virtual (VRF) - lite en un Cisco Catalyst 6500 Series Switch. La Static ruta se configura en el Switches y se redistribuye vía el EIGRP entre el Switches.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Conocimiento básico del EIGRP

  • Conocimiento básico de la configuración del Catalyst 6500

Componentes Utilizados

La información en este documento se basa en los Catalyst 6500 Series Switch que funcionan con la versión de software 12.2(33).SXH6.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Antecedentes

VRF-lite permite que un proveedor de servicio soporte dos o más VPN con una dirección IP que solapa usando una interfaz. VRF-lite también se llama dispositivo de la frontera del cliente CE o multi-VRF multi-VRF. En el pasado, VRF-lite fue soportado solamente con el RIP, el OSPF, y el BGP. Pero en las versiones recientes, VRF-lite también se soporta con el EIGRP. Este documento proporciona un ejemplo de un EIGRP sobre la configuración CLI de VRF-lite donde las rutas estáticas VRF se redistribuyen vía el EIGRP al otro Switches.

Configuración VRF-Lite sobre el Catalyst 6500

Éstas son las guías de consulta para configurar VRF-lite sobre el Catalyst 6500:

  • Un Switch con VRF-lite es compartido por los clientes múltiples, y todos los clientes tienen sus propias tablas de ruteo.

  • Porque los clientes utilizan diversas tablas VRF, los mismos IP Addresses pueden ser reutilizados. Los IP Addresses solapados se permiten en diversos VPN.

  • VRF-lite deja a los clientes múltiples compartir el mismo vículo físico entre el PE y el CE. Los puertos troncales con los VLAN múltiples separan los paquetes entre los clientes. Todos los clientes tienen sus propios VLA N.

  • Para el router PE, no hay diferencia entre usar VRF-lite o usar los CE múltiples.

  • Un cliente puede utilizar los VLAN múltiples mientras no solapen con los de otros clientes. Los VLA N de un cliente se asocian a una tabla de ruteo específica ID que se utilice para identificar las tablas de ruteo apropiadas salvadas en el Switch.

  • VRF-lite no afecta a la tarifa de conmutación de conjunto de bits.

Configuración de CLI

Esta sección muestra la configuración CLI:

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

EIGRP del Troubleshooting

Un problema frecuente considerado con el EIGRP es el router local no establece una relación del vecino EIGRP con los routeres de la vencidad.

Static ruta no Redistriubted al EIGRP

  1. Utilice el valor métrico predeterminado para las Static rutas en el comando redistribute static.

  2. Quite y agregue el comando redistribute static en el router; las demostraciones de la Static ruta 10.0.0.0/8 bajo topología EIGRP.


Información Relacionada


Document ID: 112245