IP : Protocolo de puerta de enlace fronteriza (BGP)

Allowas-en la característica en el ejemplo de la configuración BGP

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe un escenario donde dos Routers de sucursales está conectado vía un ISP y un Border Gateway Protocol (BGP) corriente entre ellos. El dos Routers de sucursales (r1 y r2), aunque en las ubicaciones diferentes, comparte lo mismo QUE el número. Las rutas llegan una vez de una bifurcación (r1 en este caso) a la red del proveedor de servicio (SP), ellas serán marcadas con etiqueta con el cliente COMO. Una vez que el SP la pasa al otro router de rama (r2), por abandono, las rutas serán caídas si la otra bifurcación también ejecutaba el BGP con el SP usando lo mismo QUE el número. En este escenario, publican el comando neighbor allowas-in para permitir que el BGP en el otro lado inyecte las actualizaciones. Este documento proporciona una configuración de muestra que le ayude a entender Allowas-en la característica en el BGP.

Nota: Esta característica sólo puede utilizarse para entidades pares eBGP verdaderas. Usted no puede utilizar esta característica para dos pares que sean miembros de diversa confederación sub-AS.

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

Esta sección le presenta con la información para configurar las características que este documento describe.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112236-allowas-in-bgp-config-example-1.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

Configuración en el Router_A
Router_A#interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 no switchport
 ip address 192.1.12.2 255.255.255.0
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 2.2.2.2 0.0.0.0
 network 3.3.3.3 0.0.0.0
 network 192.1.12.0
 auto-summary
!

Configuración en el r1 del router
R1#interface Loopback22
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
 network 192.1.12.0
 no auto-summary
!
router bgp 121
 no synchronization
 bgp router-id 22.22.22.22
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255 

!--- This is the advertising loopback address.

 redistribute eigrp 100 

!--- This shows the redistributing internal routes in BGP.

 neighbor 172.16.12.2 remote-as 500 

!--- This shows the EBGP connection with ISP.

 neighbor 172.16.12.2 ebgp-multihop 5
 no auto-summary
!

Este ejemplo muestra que el EIGRP se ejecuta entre el Router_A y el r1:

r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.1.12.2              Fa0/0             14 01:17:12  828  4968  0  7

Este ejemplo muestra cómo el r1 del router aprende las rutas del Router_A con el EIGRP:

r1#show ip route eigrp 100
D    1.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    2.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0

Este ejemplo muestra cómo el r1 del router establece una conexión BGP con un ISP que ejecuta el AS500 BGP:

r1#show ip bgp summary
BGP router identifier 22.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.12.2     4        500      86      76       19    0    0 00:25:13        2

Este ejemplo muestra cómo el r1 anuncia las rutas aprendido BGP:

r1#show ip bgp
BGP table version is 19, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          192.1.12.2          156160         32768 ? 
*> 2.0.0.0          192.1.12.2          156160         32768 ?
*> 3.0.0.0          192.1.12.2          156160         32768 ?
*> 10.10.12.0/24    172.16.12.2              0             0 500 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
r> 172.16.12.0/24   172.16.12.2              0             0 500 i
*> 192.1.12.0       0.0.0.0                  0         32768 ?
r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!!  
!--- This is the connectivity with Router 2 across the Internet cloud.

Configuración en el r2 del router
R2#interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
 ip address 10.10.12.1 255.255.255.0

router bgp 121
 no synchronization
 bgp router-id 33.33.33.33
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255 

!--- This is the advertising loopback address.
 
 neighbor 10.10.12.2 remote-as 500 

!--- This is the EBGP connection with ISP.

 neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary

El r2 del router no aprende ninguna rutas del r1 del router.

Éste es comportamiento natural porque el BGP intenta evitar rutear los loopes. Por ejemplo, el readvertisement de todos los prefijos que contengan los números del sistema autónomos duplicados (ASN) se inhabilita por abandono.

Las rutas EIGRP redistribuidas (1.0.0.0, 2.0.0.0, 3.0.0.0) y la ruta interno 22.22.22.22 BGP del r1 no son recibidas por el r2 mientras que están originando del mismo ASN a través de Internet. Puesto que el r2 ve sus los propio COMO número (121) en el AS-PATH, el r2 no toma esas rutas.

r2#show ip bgp
BGP table version is 20, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i

Para permitir el readvertisement de todos los prefijos que contengan los ASN duplicados, utilice el comando neighbor allowas-in en el modo de configuración del router en el r2 del router.

r2(config-router)#neighbor 10.10.12.2 allowas-in
r2#clear ip bgp*
r2#show ip bgp
BGP table version is 10, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          10.10.12.2                             0 500 121 ?
*> 2.0.0.0          10.10.12.2                             0 500 121 ?
*> 3.0.0.0          10.10.12.2                             0 500 121 ?
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 22.22.22.22/32   10.10.12.2                             0 500 121 i
*  33.33.33.33/32   10.10.12.2                             0 500 121 i
*>                  0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i
*> 192.1.12.0       10.10.12.2                             0 500 121 ?

Ahora intente hacer ping del r1 al r2:

r2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Mensaje de error

El mensaje: Ruta falsa del recv del A.B.C.D del vecino del %BGP%: COMO se recibe el mensaje de error del loop.

Esta notificación significa que la ruta BGP recibida por el router CE tiene sus los propio COMO número en COMO trayectoria y está considerada un loop del router para el router CE. Como solución alternativa, configure el router CE con allowas-en la característica como se ilustra en el ejemplo anterior.


Información Relacionada


Document ID: 112236