IP : Protocolos de routing de IP

Configuración del IPv6 de la muestra para el BGP con dos diversos proveedores de servicio (multihoming)

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Border Gateway Protocol (BGP) es uno de los protocolos clave para conseguir la redundancia de conexiones de Internet. Conectar la red a dos Proveedores de servicio de Internet (ISP) diferentes se denomina multihoming. Multihoming proporciona redundancia y optimización de red. Selecciona el ISP que ofrece el mejor trayecto a un recurso. Cuando usted ejecuta el BGP con más de un proveedor de servicio, usted corre el riesgo que su sistema se convertirá en un transitar COMO. Esto provoca que el tráfico de Internet pase por su AS y consuma potencialmente todo el ancho de banda y los recursos de la CPU del router. Este documento aborda este problema y proporciona los ejemplos de configuración apropiados.

prerrequisitos

Requisitos

Refiera a este documento antes de que usted proceda:

Ejemplo de Configuración de BGP con Dos Proveedores de Servicio Diferentes (Multihoming)

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco 2800 Series Router con el Software Release 12.4(13r)T del½ del¿Â del Cisco IOSïÂ

  • Cisco 3800 Series Router con el Cisco IOS Software Release 12.4(13r)T

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/112228/bgp2isp-01.gif

En este router de la red A conecta con dos diversos proveedores de servicio el BALNEARIO y el multihoming SP-B de la formación por donde 1010:1010::/64 y 2020:2020::/64 es hecho publicidad COMO 101 al exterior y a la red 1212:1212::/64 se recibe a partir del dos diferente COMO, COMO 202 y COMO 303.

Nota: Aquí está un link a un vídeo (disponible en la comunidad del soporte de Ciscoleavingcisco.com ) que proporciona la descripción del multihoming BGP y da el consejo sobre cómo resolver problemas los problemas comunes BGP como el peering y CPU elevada.

Multi-homing BGP: Diseño y troubleshooting - Vídeo de Webcast vivo leavingcisco.com

Configuraciones

En este documento, se utilizan estas configuraciones:

Router A
Router-A#
ipv6 unicast-routing

!---Enables the forwarding of IPv6 packets.

ipv6 cef
interface Serial3/0
 description CONNECTED TO SP-A
 ip address 192.168.10.1 255.255.255.0
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
 clock rate 64000
!
interface Serial3/1
 description CONNECTED TO SP-B
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 clock rate 64000
!
 router bgp 101
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 remote-as 202

!--- Configures SP-A as neighbor.

 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 ebgp-multihop 2
 neighbor 2303:ABCD::21B:54FF:FE54:FB10 remote-as 303

!--- Configures SP-B as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21B:54FF:FEA9:24B0 activate
  neighbor 2303:ABCD::21B:54FF:FE54:FB10 activate
  network 1010:1010::/64
  network 2020:2020::/64
 exit-address-family
!

Mantenga ProviderA
SP-A#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
!
router bgp 202
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configuers Router A as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

Mantenga ProviderB
SP-B#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 no fair-queue
!
router bgp 303
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 2303:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configures as Router A as neighbor.

 neighbor 2303:ABCD::21C:58FF:FEED:3E90 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 2303:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

  • Peering del router A con dos ISP

    Router-A#
    show bgp ipv6 unicast summary
    
    BGP router identifier 1.1.1.1, local AS number 101
    BGP table version is 6, main routing table version 6
    3 network entries using 447 bytes of memory
    4 path entries using 304 bytes of memory
    4/2 BGP path/bestpath attribute entries using 496 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 1295 total bytes of memory
    BGP activity 3/0 prefixes, 14/10 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    1202:ABCD::21B:54FF:FEA9:24B0   4   202   108     119   6    0    0 00:31:41   1
    2303:ABCD::21B:54FF:FE54:FB10   4   303   108     121   6    0    0 00:25:1    1
    
    !--- Indicates that Router A is peering with both the ISP SP-A and SP-B
    
    
  • Rutas aprendido del Router A del BALNEARIO y SP-B

    Router-A#show bgp ipv6 unicast
    BGP table version is 6, local router ID is 1.1.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   ::                       0                          32768 i
    *  1212:1212::/64   2303:ABCD::21B:54FF:FE54:FB10 0  0 303 i
    *>                              1202:ABCD::21B:54FF:FEA9:24B0 0  0 202 i
    *> 2020:2020::/64   ::                       0                         32768 i
  • En el BALNEARIO:

    SP-A#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 2.2.2.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
    *> 1212:1212::/64   ::                       0            32768              i
    *> 2020:2020::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
  • En SP-B:

    SP-B#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 3.3.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i
    *  1212:1212::/64   2303:ABCD::21C:58FF:FEED:3E90  0                 101 202 i
    *>                  ::                       0         32768 i
    *> 2020:2020::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i

Troubleshooting

Utilice el comando update del IPv6 BGP del debug para visualizar la información de debugging en las actualizaciones para ayudar a determinar el estado del peering.


Información Relacionada


Document ID: 112228