IP : IP versión 6 (IPv6)

Multiprotocol BGP para el ejemplo de configuración del IPv6

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de ejemplo del multiprotocolo BGP (Border Gateway Protocol) para IPv6. BGP es un protocolo EGP (Exterior Gateway Protocol) usado principalmente para conectar dominios de ruteo separados que contienen políticas de ruteo independientes (sistemas autónomos). El BGP es de uso general conectar con un proveedor de servicio para el acceso a Internet. El BGP se puede también utilizar dentro de un sistema autónomo, y esta variación se refiere como Internal BGP (iBGP). Multiprotocol BGP es un BGP mejorado que transporta información de enrutamiento para diversas familias de direcciones del protocolo de capa de red, como la familia de direcciones de IPv6 y para rutas de IP Multicast. Todos los comandos BGP y capacidades de política de ruteo se pueden utilizar con el multiprotocolo BGP.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

En esta topología, el R0 del Routers y el r1 forman una relación EBGP: El R0 está en el número del sistema autónomo 1 (AS1) y el r1 está en el AS2. El R0 del router está haciendo publicidad de dos redes del IPv6: 2010:AB8:2::/48 y 2010:AB8:3::/48.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/112135/ipv6-bgp-01.gif

Configuraciones

Ésta es la configuración de muestra del Multiprotocol BGP del IPv6 para el Routers mostrado en el diagrama:

R0 del router

ipv6 unicast-routing

!--- Enables forwarding of IPv6 packets.

ipv6 cef

interface Loopback10
 no ip address
 ipv6 address 2010:AB8:2::/48
 ipv6 enable
!
interface Loopback20
 no ip address
 ipv6 address 2010:AB8:3::/48
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 1
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring ""no bgp default ipv4-unicast"" only IPv4 will be 

!--- advertised

 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C601:10FF:FE58:0 remote-as 2
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C601:10FF:FE58:0 activate
  network 2010:AB8:2::/48
  network 2010:AB8:3::/48
 exit-address-family
!

R1 del router
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 2
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C600:10FF:FE58:0 remote-as 1
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C600:10FF:FE58:0 activate
 exit-address-family
!

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

show ipv6 route

Este comando visualiza el tabla de ruteo del IPv6.

R1#
show ipv6 route

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2010:AB8:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   2010:AB8:0:2:C601:10FF:FE58:0/128 [0/0]
     via ::, FastEthernet0/0
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

BGP de la show ipv6 route

Cuando usted especifica un protocolo, sólo las rutas para ese Routing Protocol particular se muestran. Esta salida de muestra es del comando show ipv6 route cuando está ingresado con la palabra clave BGP:

R1#
show ipv6 route bgp

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0

resumen del unicast del show bgp ipv6

Este comando proporciona la salida similar al comando show ip bgp summary, a menos que sea IPv6-specific.

R1#
show bgp ipv6 unicast summary

BGP router identifier 2.2.2.2, local AS number 2
BGP table version is 3, main routing table version 3
2 network entries using 304 bytes of memory
2 path entries using 152 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2010:AB8:0:2:C600:10FF:FE58:0
                4     1      15      14        3    0    0 00:11:52        2

Información Relacionada


Document ID: 112135