IP : IP versión 6 (IPv6)

Configuración de muestra para OSPFv3

31 Julio 2013 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Agosto 2010) | Comentarios


Contenido


Introducción

OSPF (Open Shortest Path First) es un protocolo de ruteo para IP. Es un Link-State Protocol, en comparación con un protocolo del vector distancia. Un Link-State Protocol toma las decisiones de ruteo basadas en los estados de los links que conectan la fuente y las máquinas de destino. El estado de un link es una descripción de esa interfaz y de la relación a sus dispositivos de interconexión de redes vecinos. La información de la interfaz incluye el prefijo del IPv6 de la interfaz, la máscara de la red, el tipo de red que está conectada con, el Routers conectado con esa red, y así sucesivamente. Esta información se propaga en el diverso tipo de los anuncios del estado del vínculo (LSA).

La versión 3 OSPF, que se describe en el RFC 2740, soporta el IPv6.

Prerrequisitos

Requisitos

Antes de que usted habilite el OSPF para el IPv6 en una interfaz, usted debe realizar el siguiente:

  • Complete la estrategia y las hojas de operación (planning) de la red OSPF para su red del IPv6. Por ejemplo, usted debe decidir si las áreas múltiples están requeridas.

  • Unicast Routing del IPv6 del permiso.

  • IPv6 del permiso en la interfaz.

  • Configure la seguridad IP (IPSec) aseguran el Application Program Interface del socket (API) en el OSPF para el IPv6 para habilitar la autenticación y el cifrado.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta Command Lookup Tool (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

/image/gif/paws/112100/ospfv3-config-guide-01.gif

Configuración

Ésta es la configuración de OSPFv3 para el Routers mostrado en el diagrama:

Router Stub
ipv6 unicast-routing
ipv6 cef
!
interface serial 0/0
 no ip address
 ipv6 enable
 ipv6 address 2001:ABAB::/64 eui-64
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 3.3.3.3
 area 2 stub
!

Router ABR1
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 speed auto
 ipv6 address 2003::1/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2002:ABAB::/64 eui-64
 ipv6 enable
 ipv6 ospf 1 area 2
!
ipv6 router ospf 1
 router-id 1.1.1.1
 area 2 stub no-summary
!

Router ASBR
ipv6 unicast-routing
ipv6 cef
!
interface FastEthernet0/0
 no ip address
 ipv6 address 2003::2/124
 ipv6 enable
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:1/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router ospf 1
 router-id 2.2.2.2
 default-metric 25
 redistribute rip EXT metric-type 1 include-connected
!
ipv6 router rip EXT
 redistribute ospf 1 match internal external 1 external 2 include-connected
!

Router externo
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address 2004:ABAB::/64 eui-64
 ipv6 enable
 ipv6 rip EXT enable
!
interface Serial0/0
 no ip address
 ipv6 address 2003::1:2/124
 ipv6 enable
 ipv6 rip EXT enable
!
ipv6 router rip EXT

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

El comando ospf database del IPv6 de la demostración muestra la base de datos del estado del link (LSDB) del router.

Stub_Router#show ipv6 ospf database

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

ADV Router      Age         Seq#            Fragment ID  Link count  Bits
1.1.1.1             885         0x80000007      0                    1           B
3.3.3.3             919         0x80000008      0                    1           None

                Inter Area Prefix Link States (Area 2)

ADV Router      Age         Seq#                Prefix
1.1.1.1             373         0x80000002          ::/0

                Link (Type-8) Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Interface
1.1.1.1             964         0x80000006      5          Se0/0
3.3.3.3             1165        0x80000006     5          Se0/0

                Intra Area Prefix Link States (Area 2)

ADV Router      Age         Seq#            Link ID    Ref-lstype  Ref-LSID
1.1.1.1             964         0x80000005      0          0x2001      0
3.3.3.3             1172        0x80000005     0          0x2001      0

La database router OSPF del IPv6 de la demostración uno mismo-origina el comando muestra a LSA de routeres donde el router origina y recibe. Los LSA de routeres no llevan ningún direccionamiento o información del prefijo.

Stub_Router#

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 2)

  Routing Bit Set on this LSA
  LS age: 753
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000007
  Checksum: 0xFCA4
  Length: 40
  Area Border Router
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 3.3.3.3


  LS age: 791
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Router Links
  Link State ID: 0
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000008
  Checksum: 0x178A
  Length: 40
  Number of Links: 1

    Link connected to: another Router (point-to-point)
      Link Metric: 64
      Local Interface ID: 5
      Neighbor Interface ID: 5
      Neighbor Router ID: 1.1.1.1

Los LSA llevan un campo de opciones que tenga estos bits:

  • V6 mordió — Indica si el router/el link debe ser utilizado en el cálculo de la encaminamiento.

  • R mordió — Éste es el “router mordido”. Indica si el terminal original es un router activo.

  • DC mordió — Indica la dirección del router del circuito de la demanda.

El link de la base de datos OSPF del IPv6 de la demostración uno mismo-origina las demostraciones del comando que conectan los LSA llevan los direccionamientos link-específicos.

Stub_Router#show ipv6 ospf database link self-originate

            OSPFv3 Router with ID (3.3.3.3) (Process ID 1)

                Link (Type-8) Link States (Area 2)

  LS age: 627
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000006
  Checksum: 0x215C
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20E:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2002:ABAB::
  Prefix Length: 64, Options: None

  LS age: 828
  Options: (V6-Bit R-bit DC-Bit)
  LS Type: Link-LSA (Interface: Serial0/0)
  Link State ID: 5 (Interface ID)
  Advertising Router: 3.3.3.3
  LS Seq Number: 80000006
  Checksum: 0xB4C2
  Length: 56
  Router Priority: 1
  Link Local Address: FE80::D20D:16FF:FE50:0
  Number of Prefixes: 1
  Prefix Address: 2001:ABAB::
  Prefix Length: 64, Options: None

Porque el router Stub pertenece a un área del Total-stub, el router ABR1 envía solamente la ruta predeterminado al router Stub.

Stub_Router#
show ipv6 route

IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OI  ::/0 [110/65]
     via FE80::D20E:16FF:FE50:0, Serial0/0
C   2001:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2001:ABAB::D20D:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
O   2002:ABAB::/64 [110/128]
     via FE80::D20E:16FF:FE50:0, Serial0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

El router ABR1 es el router del borde del área.

ABR1#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 1.1.1.1
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 2. 1 normal 1 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 5 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 2
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
          generates stub default route with cost 1
        SPF algorithm executed 6 times
        Number of LSA 7. Checksum Sum 0x042237
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

El router ABR1 recibe las rutas externo (rutas del RIP) del router ASBR.

ABR1#
show ipv6 route

IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:ABAB::/64 [110/128]
     via FE80::D20D:16FF:FE50:0, Serial0/0
C   2002:ABAB::/64 [0/0]
     via ::, Serial0/0
L   2002:ABAB::D20E:16FF:FE50:0/128 [0/0]
     via ::, Serial0/0
C   2003::/124 [0/0]
     via ::, FastEthernet0/0
L   2003::1/128 [0/0]
     via ::, FastEthernet0/0
OE1  2003::1:0/124 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
OE1  2004:ABAB::/64 [110/26]
     via FE80::D20F:BFF:FE24:0, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

El router ASBR es el Autonomous System Boundary Router para la red. Está conectado con la red del RIP a través de la interfaz del Serial0/0.

ASBR#
show ipv6 ospf

 Routing Process "ospfv3 1" with ID 2.2.2.2
 It is an autonomous system boundary router
 Redistributing External Routes (with default metric 25) from,
    rip with metric-type 1 include-connected
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 2. Checksum Sum 0x00A1E0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Reference bandwidth unit is 100 mbps
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        SPF algorithm executed 2 times
        Number of LSA 8. Checksum Sum 0x052E71
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ASBR#
show ipv6 rip

RIP process "EXT", port 521, multicast-group FF02::9, pid 156
     Administrative distance is 120. Maximum paths is 16
     Updates every 30 seconds, expire after 180
     Holddown lasts 0 seconds, garbage collect after 120
     Split horizon is on; poison reverse is off
     Default routes are not generated
     Periodic updates 69, trigger updates 6
  Interfaces:
    Serial0/0
  Redistribution:
    Redistributing protocol ospf 1 include-connected

Troubleshooting

Use esta sección para resolver problemas de configuración.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

haga el debug del IPv6

Tan pronto como OSPFv3 se habilite en el router Stub, envía los mensajes Hello Messages del tipo 1 OSPFv3 a la dirección Multicast FF02::5. Una vez que recibe los paquetes de saludo del router ABR1, negocian la relación maestro/satélite y después comienzan a enviar los paquetes del DBD.

Stub_Router#debug ipv6 ospf events

Stub_Router# debug ipv6 ospf packet
*Mar  1 00:14:20.999: OSPFv3: rcv. v:3 t:1 l:36 rid:1.1.1.1
      aid:0.0.0.2 chk:142A inst:0 from Serial0/0
*Mar  1 00:14:21.023: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:EB8A inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: rcv. v:3 t:1 l:40 rid:1.1.1.1
      aid:0.0.0.2 chk:E1C inst:0 from Serial0/0
*Mar  1 00:14:21.027: OSPFv3: 2 Way Communication to 1.1.1.1 on Serial0/0, state 2WAY
*Mar  1 00:14:21.027: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 
flag 0x7 len 28
*Mar  1 00:14:21.031: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x2402 opt 0x0011 
flag 0x7 len 28  mtu 1500 state EXSTART
*Mar  1 00:14:21.031: OSPFv3: First DBD and we are not SLAVE
*Mar  1 00:14:21.035: OSPFv3: rcv. v:3 t:2 l:88 rid:1.1.1.1
      aid:0.0.0.2 chk:5CF3 inst:0 from Serial0/0
*Mar  1 00:14:21.039: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1737 opt 0x0011 flag 
0x2 len 88  mtu 1500 state EXSTART
*Mar  1 00:14:21.039: OSPFv3: NBR Negotiation Done. We are the MASTER
*Mar  1 00:14:21.039: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x3 len 88
*Mar  1 00:14:21.043: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85B inst:0 from Serial0/0
*Mar  1 00:14:21.047: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1738 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.047: OSPFv3: Send DBD to 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x1 len 28Send LS REQ to 1.1.1.1 length 36 LSA count 3
*Mar  1 00:14:21.051: OSPFv3: rcv. v:3 t:3 l:52 rid:1.1.1.1
      aid:0.0.0.2 chk:C326 inst:0 from Serial0/0
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:2 l:28 rid:1.1.1.1
      aid:0.0.0.2 chk:F85A inst:0 from Serial0/0

Una vez que se intercambian los paquetes del DBD, el Routers envía los mensajes de la petición (REQ LS) y de la actualización de estado de link del link-state (LS UPD) de construir su LSDB. Después de los mensajes sucesivos del REQ LS y LS UPD, y cuando el estado alcanza el FULL, el Routers continúa intercambiando los paquetes de saludo.

Stub_Router#
*Mar  1 00:14:21.055: OSPFv3: rcv. v:3 t:4 l:144 rid:1.1.1.1
      aid:0.0.0.2 chk:58BC inst:0 from Serial0/0Rcv LS REQ from 1.1.1.1 on Serial0/0 length 52 
LSA count 3Send UPD to 131.88.101.156 on Serial0/0 length 128 LSA count 3
*Mar  1 00:14:21.059: OSPFv3: Rcv DBD from 1.1.1.1 on Serial0/0 seq 0x1739 opt 0x0011 flag 
0x0 len 28  mtu 1500 state EXCHANGE
*Mar  1 00:14:21.063: OSPFv3: Exchange Done with 1.1.1.1 on Serial0/0Rcv LS UPD from 
1.1.1.1 on Serial0/0 length 144 LSA count 3
*Mar  1 00:14:21.067: OSPFv3: Synchronized with 1.1.1.1 on Serial0/0, state FULL
*Mar  1 00:14:21.067: %OSPFv3-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from 
LOADING to FULL, Loading Done
*Mar  1 00:14:21.687: OSPFv3: rcv. v:3 t:4 l:60 rid:1.1.1.1
      aid:0.0.0.2 chk:66EB inst:0 from Serial0/0Rcv LS UPD from 1.1.1.1 on Serial0/0 length 60 
LSA count 1
*Mar  1 00:14:23.683: OSPFv3: rcv. v:3 t:5 l:96 rid:1.1.1.1
      aid:0.0.0.2 chk:4BB5 inst:0 from Serial0/0

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 112100