Voz y Comunicaciones unificadas : Cisco Unified Border Element

Alta disponibilidad del Cisco Unified Border Element (HA) usando el ejemplo de la configuración HSRP

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Cisco Unified Border Element (CUBE) proporciona una alta disponibilidad (HA) a través de las configuraciones de redundancia de casilla a casilla cuando se implementa en una plataforma de router Cisco Integrated Services Router Generation 2 (ISR G2). CUBIQUE la Redundancia de casilla a casilla leverages la tecnología basada en el router disponible larga del router del Hot Standby Routing Protocol (HSRP).

La tecnología del HSRP proporciona la gran disponibilidad de red ruteando el tráfico IP de los hosts en las redes sin la confianza en la Disponibilidad de cualquier único router. El HSRP se utiliza en un grupo de Routers para seleccionar un router activo y un router en espera. El HSRP monitorea ambas las interfaces interiores y exteriores – si va cualquier interfaz abajo, el dispositivo entero se considera abajo, el dispositivo en espera se convierte en active y asume el control las responsabilidades del router activo.

La Redundancia de casilla a casilla utiliza el protocolo HSRP para formar a un par activo/espera del HSRP de Routers. Los pares activos/espera comparten a la misma dirección IP virtual e intercambian continuamente los mensajes de estado. La información de la sesión del CUBO es checkpointed a través de los pares activos/espera de Routers. Esto permite al router en espera para asumir el control inmediatamente todas las responsabilidades del Procesamiento de llamadas del CUBO si va el router activo Out Of Service para planeado o los motivos no planificados.

La implementación de la Redundancia de casilla a casilla HA del CUBO soporta la preservación de los media sobre un intercambio del HSRP de las llamadas SIP-SIP, pero no se preserva ninguna señalización de llamada. Esta capacidad se soporta a partir del Software Release 15.1.2T de Cisco IOS�. La preservación de la señalización de llamada se soporta en el último Cisco IOS Software Release 15.2.3T.

Nota: Para más información, refiera a las características del protocolo independiente del Cisco Unified Border Element y ponga la guía de configuración, el Cisco IOS Release 15.2M&T.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Conocimientos básicos de cómo configurar y utilizar la voz del Cisco IOS

  • Conocimientos básicos de cómo configurar y utilizar el CUBO

  • Conocimientos básicos de cómo la Alta disponibilidad del HSRP trabaja en las Plataformas del router general

Los requisitos básicos para configurar la Redundancia de casilla a casilla del CUBO ISR G2 incluyen:

  • Dos ISR idéntico G2 equipados de la licencia del paquete de la tecnología UC (SL-29-UC-K9 o SL-39-UC-K9) instalada, de la memoria DRAM 1G, y del Cisco IOS Software Release 15.1.2T o Posterior

  • Ambo Routers debe ser establecido físicamente en el mismo LAN Ethernet.

  • La configuración del CUBO de ambo Routers es idéntica y se debe copiar manualmente a partir de un router al otro.

  • Señalan a un router el router activo del HSRP, el segundo es el recurso seguro. Hay leves diferencias en la configuración HSRP entre el Active y los routeres en espera.

  • Flujos de llamada SIP-SIP

Componentes Utilizados

La información en este documento se basa en una versión mínima de software del CUBO 8.5 (Cisco IOS Release 15.1.2T), implementada en una generación 2 (ISR G2) del router del servicio integrado de las Cisco o Series.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Antecedentes

La Redundancia de casilla a casilla requiere dos Plataformas idénticas ISR-G2: uno configurado como el Active, el otro como el recurso seguro. El HSRP se configura en las interfaces físicas para formar a un grupo del HSRP.

Si hay una falla de latido cuando va el router activo abajo, el segundo router en espera asume el control los direccionamientos del Routing IP del primer router y continúa remitiendo los mismos paquetes RTP que fueron ruteados previamente al primer router.

Las secuencias RTP de las llamadas establecidas son checkpointed entre el Active y los routeres en espera vía el protocolo HSRP. Por lo tanto las secuencias de medios de llamadas establecidas se preservan sobre la falla de HSRP del Active a los routeres en espera. Las llamadas en un estado transitorio (las llamadas que no se establecen todavía, o están en curso de modificación con una función de la transferencia o del control) a la hora de la Conmutación por falla son disconnected. También, ninguna llamadas usando los servicios del DSP tales como transcodificación no se preservan.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

La configuración HSRP del CUBO sigue un orden concreto de pasos, que incluye:

  1. Redundancia del CUBO y del CUBO del permiso

  2. HSRP del permiso

  3. Transporte de la comunicación del HSRP de la configuración

  4. HSRP de la configuración en las interfaces

  5. Configure los temporizadores HSRP

  6. Configure el temporizador de inactividad de los media

  7. Configure el SORBO que ata a la dirección HSRP

  8. Recargue al Routers

  9. Señale Softswitches asociado a la dirección virtual del HSRP del CUBO

Recargue ambo el Routers después de que se completen los pasos 1-5. Se requiere una recarga solamente cuando el HSRP se configura por primera vez en un router.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

Este diagrama muestra la topología de un par activo/espera de Routers ISR G2 usado en un despliegue del trunk del SORBO entre un administrador de las Comunicaciones unificadas de Cisco (CUCM) y un trunk del SORBO del proveedor de servicio (SP) para el acceso PSTN.

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-01.gif

Paso 1: Redundancia del CUBO y del CUBO del permiso

CUBO del permiso en ambo Routers:

voice service voip 
  mode border-element
  allow-connections sip to sip

Redundancia del CUBO del permiso y verificación de la llamada en ambo Routers:

voice service voip 
  redundancy

Paso 2: HSRP del permiso

Esquemas de redundancia del router del permiso en ambo Routers, donde:

  • esquema – esquema de seguimiento del estado de redundancia

  • espera – esquema de seguimiento (HSRP) del estado espera del permiso

  • SB – el nombre del grupo del HSRP en espera

redundancy inter-device
  scheme standby SB

Paso 3: Transporte de la comunicación del HSRP de la configuración

Configure el transporte de la comunicación del Inter-dispositivo del HSRP como sigue:

Configuración activa:

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13

Configuración espera:

ipc zone default
  association 1
   no shutdown
   protocol sctp
     local-port 5000
       local-ip 10.10.24.13
     remote-port 5000
       remote-ip 10.10.24.14

Nota: Salga del prompt “local-SCTP” para configurar los parámetros del telecontrol SCTP como sigue:

XFR-2(config)#ipc zone default
XFR-2(config-ipczone)#association 1
XFR-2(config-ipczone-assoc)#protocol sctp 
XFR-2(config-ipc-protocol-sctp)#no sh
XFR-2(config-ipczone-assoc)#protocol sctp
XFR-2(config-ipc-protocol-sctp)#local-port 5000
XFR-2(config-ipc-local-sctp)#local-ip 10.10.24.13
XFR-2(config-ipc-local-sctp)#exit
XFR-2(config-ipc-protocol-sctp)#remote-port 5000
XFR-2(config-ipc-remote-sctp)#remote-ip 10.10.24.14
XFR-2(config-ipc-remote-sctp)#end

Éstas son la explicación de los campos usados en esta configuración:

  • valor por defecto de la zona ipc – Configura el Communication Protocol del Inter-dispositivo (IPC) y ingresa al modo de configuración de la zona IPC. Utilice este comando de iniciar el link de comunicación entre el Active y los dispositivos en espera.

  • asociación 1 – Configura una asociación entre los dos dispositivos y ingresa al modo de configuración de la asociación IPC. Bajo esto, configure los detalles de la asociación tales como Transport Protocol, puerto local, IP Address local, puerto remoto y IP Address remoto. La asociación válida ID se extiende a partir de la 1 a 255. No hay asociación predeterminada ID.

  • ningún apague – Recomienza una asociación discapacitada y su Transport Protocol asociado. Para cualquier cambio a los parámetros del Transport Protocol, esta asociación debe ser apaga.

  • sctp del protocolo – Stream Control Transmission Protocol (SCTP) de las configuraciones como el Transport Protocol para esta asociación y modo de la configuración del protocolo de los permisos SCTP.

  • port_num del puerto local – Define el número del puerto local SCTP para utilizar para comunicar con el par redundante.

  • ip_addr del IP local – Define la dirección IP del router local para utilizar para comunicar con el par redundante. El IP Address local debe hacer juego el IP Address remoto en el router redundante.

  • port_num del puerto remoto – Define el número del puerto del telecontrol SCTP para utilizar para comunicar con el par redundante.

  • ip_addr del IP remoto – Define el IP Address remoto del router del par usado para comunicar con el dispositivo local. Todos los IP Address remotos deben señalar al mismo dispositivo.

Nota: El puerto local y el puerto remoto se deben fijar a 5000 en el Active y los routeres en espera.

Paso 4: HSRP de la configuración en las interfaces

Configure el transporte de la comunicación del Inter-dispositivo del HSRP como sigue:

Configuración activa

interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

Configuración espera

interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt		  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

Ésta es una explicación de los campos usados en esta configuración:

  • 0/6 – Define el número de grupo en espera.

  • keepalive – Permite al keepalive para que el HSRP monitoree los eventos arriba/abajos.

  • retardo espera – Retrasa la inicialización del HSRP hasta que la interfaz física esté para arriba.

  • IP espera x – Define la dirección IP virtual del IPv4 compartida entre el Active y los dispositivos en espera. Este comando habilita el HSRP en la interfaz.

  • x espera se apropia – Permite que el router haga el router activo cuando la prioridad es más alta que el resto del Routers HSRP-configurado en el grupo de la espera en caliente. Si usted no utiliza el comando standby preempt en la configuración para un router, ese router no hace el router activo, incluso si la prioridad es más alta que el resto del Routers.

  • prioridad espera x – Define la prioridad de la espera en caliente usada en elegir el router activo. Se extiende a partir de la 1 a 255 donde 1 denota la prioridad más baja y 255 la prioridad más alta.

    Nota: En caso de que la prioridad de reserva sea lo mismo, el dispositivo con la dirección IP más alta asume el papel del router activo.

  • nombre espera x – Define el nombre del grupo en espera que hace juego el esquema definido en el paso 2 (“SB "). Para los grupos HSRP múltiples, se utiliza el mismo nombre espera mientras que solamente un esquema espera se permite en las configuraciones.

  • decremento 10 de la pista 1 del recurso seguro 6 – Define el seguimiento de la prioridad. Para más información sobre el seguimiento de interfaz, haga clic aquí.

  • el multiplicador 3 del min_rx 500 del intervalo 500 del bfd – define la detección bidireccional de la expedición.

Para evitar las condiciones de carrera cuando un router arranca y una interfaz sube para establecer el contacto (“hola ") entre el Active y los routeres en espera, también se recomienda para configurar el siguiente:

interface GigabitEthernet0/0
  standby delay minimum 30 reload 60

Para más información sobre este comando, haga clic aquí.

Paso 5: Configure los temporizadores HSRP

Hay dos temporizadores HSRP importantes:

  • Temporizador de saludo: El intervalo entre mensajes sucesivos de saludo de HSRP desde un router dado. Este temporizador se puede configurar en los segundos o los milisegundos bajo interfaz del HSRP. El valor predeterminado es 3 segundos.

  • Temporizador del control: El intervalo entre la recepción de un mensaje de saludo y la presunción de que el router de envío ha fallado. Esta vez se puede configurar en los segundos o los milisegundos bajo interfaz del HSRP. El valor predeterminado es 8 segundos.

En las configuraciones en el paso 4, el HSRP hello y los temporizadores del control se fijan a sus valores predeterminados. Por lo tanto, no aparecen explícitamente en las configuraciones. Los valores recomendados para hola/los temporizadores del control son los valores predeterminados.

Nota: Si usted utiliza los valores no predeterminados, usted debe configurar a cada router para utilizar el mismo tiempo de saludo y para celebrar los valores del temporizador.

Los temporizadores de espera y saludo se pueden configurar bajo interfaz del HSRP usando el CLI siguiente:

Router(config-if)#standby 0 timers ?
  <1-254>  Hello interval in seconds
  msec     Specify hello interval in milliseconds

Router (config-if)#standby 0 timers 2 ?
  <3-255>  Hold time in seconds
  msec     Specify hold interval in milliseconds
Router(config-if)#standby 0 timers 2 msec 40

En la configuración previa, el temporizador de saludo se fija a 2 segundos y al temporizador del control a 40 milisegundos.

Nota: Usted puede bajar las configuraciones del temporizador para acelerar la Conmutación por falla o el derecho preferente de compra. Sin embargo, para evitar la CPU incrementada utilice y estado espera innecesario que agita, se recomienda para no fijar el temporizador de saludo en menos de 1 segundo, y el temporizador del control en menos de 4 segundos.

Paso 6: Configure el temporizador de inactividad de los media

El temporizador de inactividad de los media permite a los pares del Active/del router en espera para monitorear y para desconectar las llamadas si no se recibe ningunos paquetes del Real-Time Protocol (RTP) dentro de un periodo de tiempo configurable.

Cuando los paquetes RTP para una llamada no son recibidos por el Active/el router en espera, el temporizador de inactividad de los media del SORBO libera la sesión. Esto se utiliza para guardar contra cualquier sesión bloqueada que pudiera haber resultado de la Conmutación por falla en caso que lo haga una desconexión de la llamada normal no claro la llamada.

La misma duración para el temporizador de inactividad de los media se debe configurar en ambo Routers. El valor predeterminado es 28 segundos. Se configura este temporizador como sigue:

ip rtcp report interval 3000
gateway
  media-inactivity-criteria all
  timer receive-rtp 86400
  timer receive-rtcp 5

Paso 7: SORBO de la configuración que ata a la dirección HSRP

Configure la Mensajería del SORBO del CUBO para utilizar a la dirección virtual del HSRP en la Mensajería del SORBO.

dial-peer voice 100 voip
  description to-SIP
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1

Una vez que el HSRP se configura bajo interfaz física y han publicado el comando bind, las llamadas a la dirección IP física fallarán. Esto es porque el socket que escucha del SORBO ahora está limitado a la dirección IP virtual pero los paquetes de la señalización utilizan la dirección IP física, y por lo tanto no puede ser dirigida.

Paso 8: Recargue al Routers

Una vez que se han completado todas las configuraciones antedichas, la salida de la demostración de la Redundancia es como sigue:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
  Pending Scheme: Standby (Will not take effect until next reload)
      Pending Groupname: b2bha
  Scheme: <NOT CONFIGURED>
  Peer present: UNKNOWN
  Security: Not configured

Sobre recargar al router se habilita la configuración HSRP como sigue:

router activo

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
  Scheme: Standby
      Groupname: b2bha Group State: Active
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

router en reserva

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
  Scheme: Standby
      Groupname: b2bha Group State: Standby
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

Paso 9: Softswitches asociado punta a la dirección virtual del HSRP del CUBO

Los SBCs del proxy CUCM, IP-PBX, del SORBO o SP o los softswitches SP que rutean las llamadas PARA CUBICAR deben utilizar a la dirección virtual del HSRP en su Mensajería del SORBO. Los mensajes del SORBO a los IP Addresses físicos del CUBO no se manejan con una configuración HSRP.

Las configuraciones de muestra completas para el dóblese asociado CUBICAN la Redundancia del HSRP

Aquí están las configuraciones de muestra completas para el Routers activo y espera del CUBO. En estas configuraciones, los temporizadores del HSRP hello y del control utilizan sus valores predeterminados de 3 y 8 segundos respectivamente, y no se muestran explícitamente en la salida CLI.

Configuración del router activo

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
   standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

Configuración del router en espera

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.13
      remote-port 5000
        remote-ip 10.10.24.14
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

Configuración de muestra completa para la Redundancia Solo-asociada del HSRP del CUBO

Mientras que un CUBO del dóblese asociado es la mayoría de la configuración común, especialmente para las conexiones de tronco del SORBO SP, es también posible configurar la Redundancia de casilla a casilla del HSRP del CUBO con un despliegue solo-asociado del CUBO según lo dado en esta sección.

Configuración del router activo

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.8
     remote-port 5000
       remote-ip 1.2.175.12
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.8 255.255.0.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
 standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

Configuración del router en espera

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.12
     remote-port 5000
       remote-ip 1.2.175.8
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.12 255.255.0.0
  duplex auto
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
  standby 0 priority 50
		standby 0 preempt
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

Eliminación de las configuraciones HA

Complete estos pasos para quitar una configuración HSRP previamente ingresada de un router del CUBO:

  1. Quite la configuración de redundancia del nivel de aplicación.

    Router(config)#voice service voip 
    Router(config-voice service voip)#no redundancy
  2. Quite el esquema espera configurado bajo modo de configuración del inter-dispositivo.

    Router(config)#redundancy inter-device 
    Router(config-red-interdevice)#no scheme standby b2bha
    % Redundancy interdevice scheme change will not take effect until 
    configuration is saved and device reloaded
  3. Salve los cambios de configuración a la memoria y recargue al router.

    Router(config)#write
    Router#reload
  4. Después de que la recarga, publique este comando de marcar que se ha inhabilitado el HSRP:

    Router#show redundancy inter-device
    Redundancy inter-device state: RF_INTERDEV_STATE_INIT
      Scheme: <NOT CONFIGURED>
      Peer present: UNKNOWN
      Security: Not configured
    
  5. Inhabilite la asociación entre los dos dispositivos y quite la configuración SCTP.

    Router(config)#ipc zone default
    Router(config-ipczone)#association 1
    Router(config-ipczone-assoc)#shutdown
    Router(config-ipczone-assoc)#no protocol sctp
    Router(config-ipczone-assoc)#no association 1
    Router(config-ipczone)#exit
    Router(config)#no ipc zone default
  6. Quite la configuración HSRP de la interfaz usando las formas del no de los comandos del HSRP.

    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#no standby 0 name
    Router(config-if)#no standby 0 priority 
    Router(config-if)#no standby 0 ip
  7. Salve los cambios de configuración.

    Router(config)#write

Ofrezca las notas del uso

  • El router dos usado para un par del HSRP debe ser idéntico (asegurar el mismo funcionamiento y capacidad de llamada llanos).

  • El soporte de la configuración de la Redundancia de casilla a casilla en las llamadas SIP-SIP fluye, el transporte del SORBO puede ser UDP-UDP o UDP-TCP

  • Las direcciones virtuales del HSRP soportan solamente la dirección del IPv4.

  • La secuencia de medios de llamadas establecidas se preserva sobre una Conmutación por falla, pero la señalización no es. Por lo tanto, las llamadas preservadas no pueden ser modificadas (control/curriculum vitae, transferencia, conferencia, etc.).

  • Las llamadas que implican los servicios suplementarios tales como transcodificación, DTMF-intertrabajando, IVR, SIP-TLS, RSVP, ATURDEN, conversión RTP-SRTP, o el fax/las características del módem no se preserva en una Conmutación por falla.

  • Las secuencias de video no se preservan sobre el intercambio, aunque la secuencia de audio pueda ser preservada.

  • Soportan a los grupos HSRP múltiples por el router, pero solamente un solo grupo del HSRP por la interfaz física.

  • Los Loopback Address con el HSRP no se soportan, el comando bind del SORBO deben utilizar a la dirección IP virtual del HSRP.

  • La sincronización de la configuración entre router activo y en espera es manual, allí no es ninguna automatización. Los cambios de configuración se deben realizar manualmente a ambo Routers.

Verificación

Utilice el CLI abajo para verificar la configuración HSRP es correcto y trabajo.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Verifique al estado de redundancia

Verifique al estado de redundancia con el inter-dispositivo de la Redundancia de la demostración y muestre los comandos del estado de redundancia. Estos comandos show que la información del inter-dispositivo de la Redundancia tal como el inter-dispositivo de la Redundancia estado.

Antes de que se haga la configuración del inter-dispositivo, la salida de la demostración es como sigue:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Protocol: <NOT CONFIGURED>

XFR-2#show redundancy states
my state = 3  -NEGOTIATION 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Down      Reason: Simplex mode

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Después de que la configuración del inter-dispositivo se haga pero antes de la recarga de router, la salida de la demostración es como sigue:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
Pending Scheme: Standby (Will not take effect until next reload)
Pending Groupname: b2bha
Scheme: <NOT CONFIGURED>
Peer present: UNKNOWN
Security: Not configured

Después de la recarga de router, la salida de la demostración es como sigue mostrando el estado del “init”:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Peer present: UNKNOWN
Security: Not configured

CUBE_XFR#show redundancy states 
my state = 3  -NEGOTIATION 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (this unit is still initializing)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Durante un intercambio, por ejemplo el router activo está abajo y mientras que el router en espera está conmutando a convertirse en el Active, la salida de la demostración es como sigue:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Después del intercambio, pero antes de que el Routers haya intercambiado hola los mensajes de estado, de la salida de la demostración es como sigue:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_HSRP_STDBY_PNC
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

Después de que sea el intercambio hola de los mensajes de estado, la salida de la demostración como sigue:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
  
XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 8  -STANDBY HOT 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (peer unit not yet in terminal standby state)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0  
 
CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
        
CUBE_XFR#show redundancy states
my state = 8  -STANDBY HOT 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = cannot be initiated from this the standby unit
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

Verifique el estado del HSRP

Verifique el estado del HSRP con el comando show standby brief. Este comando muestra la salida abreviada en el HSRP incluyendo las interfaces del HSRP, los números de grupo en espera, las prioridades, Active y los IP Address en Standby así como los IP Addresses virtuales. El comando show standby da el lleno, información detallada.

Router1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active     Standby      Virtual IP
Gi0/0       0    50    Active  local      9.13.25.134  9.13.25.22

Router2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active       Standby  Virtual IP
Gi0/0       0    50    Standby 9.13.25.133  local    9.13.25.22

Verifique al estado de la llamada después de un intercambio

Utilizan al comando summary de gran disponibilidad de la Voz de la demostración de verificar:

  • La verificación de las llamadas en el router en espera después de un intercambio

  • La cuenta de la media-inactividad en el Active cuando las llamadas han terminado

  • Para marcar para saber si hay (por ejemplo, preservado) llamadas nativas y extranjeras cuando ambos tipos de llamadas están presentes

  • Para identificar la presencia de RTP escapado, HA, sesiones de SPI

Muestre la verificación de las llamadas en el router en espera después de un intercambio

En este ejemplo, 800 llamadas eran checkpointed de activo al recurso seguro después del intercambio.

CUBE_XFR#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 3100
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state STANDBY HOT
Peer current rf state ACTIVE
Voice HA Standby is not available.
System has not experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer NOT READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 0
Total number of checkpoint requested received (Standby): 971
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 800
Media Inactivity event count: 0

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
Checkpoint get buffer failure count: 0

Muestre la cuenta de la media-inactividad en el Active cuando las llamadas han terminado

En este ejemplo, 800 llamadas son borradas por el temporizador de la media-inactividad.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 4213
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state ACTIVE
Peer current rf state STANDBY HOT
Voice HA Active and Standby are in sync.
System has experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
   Checkpoint get buffer failure count: 0

Para marcar para saber si hay llamadas (preservadas) nativas y extranjeras cuando ambos están presentes

Los números de llamadas en el sistema se muestran como sigue:

  • El número total de llamadas = “número de llamadas en HA DB” + “número de las llamadas en el HA sincroniza hasta que finalice el DB”. Éste es 100 + 50 = 150 en la salida de ejemplo abajo.

  • El número total de preservado (extranjero) llama = “número de llamadas en la sesión preservada HA DB”. Éste es 70 en la salida de ejemplo abajo.

  • El número total de llamadas del natural (llamadas configuradas puesto que la Conmutación por falla y por lo tanto no preservadas sobre la Conmutación por falla) es la diferencia en los dos números anteriores. En este ejemplo, es 150 – 70 = 80.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 100
Number of calls in HA sync pending DB: 50
Number of calls in HA preserved session DB: 70

Para identificar la presencia de RTP escapado, HA, sesiones de SPI

El número total de llamadas (extranjeras) preservadas borradas por la inactividad de los media es = “total CREATE recibido en CANCELACIÓN total del recurso seguro” – “recibida en el recurso seguro” como la salida debajo de las demostraciones. Compare este número con “la cuenta de evento de la inactividad de los media” así como el número de eventos de los media abajo mostrados por la salida del comando stats del fpi del voip de la demostración.

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Verifique los atascamientos de la dirección IP del SORBO

Las visualizaciones del comando status de la demostración sorbo-UA SORBEN el estatus obligatorio.

Router1#show sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
Snapshot of SIP listen sockets : 2
            Local Address      Listen Port  Secure Listen Port
=============================  ===========  ==================
 10.10.25.14                     5060         5061
 10.10.24.14                     5060         5061
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70

Verifique el uso actual CPU

Utilizan al comando history CPU del proceso de la demostración de verificar el porcentaje de la utilización de la CPU a intervalos regulares.

Marque la utilización de la CPU antes de realizar un intercambio y proceda con una Conmutación por falla forzada solamente cuando la utilización de la CPU es menos del 70%. El comando clasificado CPU del proceso de la demostración se puede también publicar en varias ocasiones para conseguir una idea de la utilización de la CPU para un proceso determinado.

Verifique que las llamadas se estén procesando durante un intercambio

Marcando utiliza al comando statistics de la demostración sorbo-UA de verificar los descensos de la llamada durante el intercambio el número de mensajes del ADIÓS. Las llamadas en curso durante el intercambio se caen. Solamente se preservan las llamadas establecidas.

Se utiliza el comando de contabilidad de la interfaz de la demostración de verificar la confirmación del trayecto de medios durante un intercambio.

Router#show interfaces g0/0 accounting
GigabitEthernet0/0 
Protocol  Pkts In   Chars In   Pkts Out   Chars Out
Other     1         58         6          360
IP        406       178841     201        16394
ARP       569       34292      0          0
CDP       116       31672      22         7304

El IP “pkts en” y “pkts del control hacia fuera” contradice – éstos deben aumentar a una tarifa razonable. Por ejemplo, si usted está utilizando el packetization de G.711 20ms y ningún VAD, usted debe ver los contadores de paquetes aumentar en alrededor 50 cada segundo.

Forzar un failover manual para probar

La Redundancia de casilla a casilla usando el HSRP soporta un intercambio media-stateful de las llamadas que signifique que el (RTP) de los media de las llamadas está preservado, pero no la señalización. Por lo tanto, solamente las llamadas en el estado activo (trayecto de medios en el modo de conexión del “sendrecv”) se preservan mientras que las llamadas en el estado transitorio (estado, trayecto de medios inactivos no en el modo de conexión del “sendrecv”) no se preservan durante el intercambio.

Los intercambios que ocurren en los entornos reales donde hay llamadas constantes de una mezcla en el transeúnte (configuración de la llamada o siendo modificado) y el estado establecido, allí serán siempre algunas llamadas caídas durante una Conmutación por falla. El número total de llamadas interrumpidas esperadas se puede estimar por: (0.3 + control-temporizador del HSRP) * CP.

Complete el procedimiento abajo para forzar un Manual Switchover a marcar que la configuración y la operación está correctas.

Para asegurar el Forced Switchover liso, haga el siguiente:

  • Monitoree la utilización de la CPU % en los pares activos/espera. El Active tendrá una utilización de la CPU más alta como está manejando activamente las llamadas, mientras que el recurso seguro mostrará 0 utilizaciones de la CPU pues es marcha lenta hasta que ocurra un intercambio.

  • Asegúrese que un Manual Switchover esté realizado cuando es la utilización de la CPU del router activo no más el que 70%. Todos los intercambios llevan a un punto en la utilización de la CPU.

  • Utilice los comandos summary de gran disponibilidad de la Voz de la conexión y de la demostración del rtp del voip de la demostración de aseegurar las llamadas existentes haber sido synched a través de los pares del Active/del router en espera.

Un intercambio del HSRP implica antes el router activo que recarga, mientras que el router en espera asume el control y se convierte en antes el nuevo router activo que procesa las nuevas llamadas y que mantiene las secuencias de medios para las llamadas preservadas hasta que sean completas. El nuevo router activo permanecerá como el router activo hasta que ocurra otro intercambio.

Los intercambios (forzados) manuales se pueden alcanzar en de estas maneras:

  • Inicíelo por el CLI “fuerza de la Switch-actividad de la Redundancia” en el router activo.

  • Recarga del router activo

  • Reinicio duro del router activo

  • Saque la interfaz del HSRP o el cable de alimentación eléctrica del router activo.

  • Apague la interfaz del HSRP del router activo.

  • Un cambio en cualquier parámetro de la interfaz del HSRP del Active/del router en espera sin apagar la asociación bajo modo IPC lleva a una recarga de router. Por lo tanto, la interfaz debe ser apaga antes de que se realice cualquier cambio, a menos que usted esté utilizando esto como activador para forzar un intercambio.

El comando show voip rtp connections muestra el número de conexiones activas en el Active y los routeres en espera después de un intercambio.

El comando show call active voice brief no muestra ninguna salida en el router en espera después de un intercambio porque la información de señalización no es checkpointed.

Pasos para realizar y para verificar un solo intercambio

Complete estos pasos:

  1. Configure la Redundancia de casilla a casilla del HSRP según la sección de la configuración en este documento.

  2. Recargue y mantenga a ambo Routers el rommon.

  3. Inicie encima de un router. Después de que esté para arriba, publique el comando del estado de redundancia de la demostración y aseegurelo muestra mi estado como estado del Active y del par como minusválidos. Esto puede coger un rato después del inicio.

    XFR-2#show redundancy states
    my state = 13 -ACTIVE 
    peer state = 1  -DISABLED
  4. Inicio encima del segundo router. Después de que esté para arriba, publique el comando del estado de redundancia de la demostración de aseegurarlo muestra mi estado como estado Espera-caliente y del par como Active.

    CUBE_XFR#show redundancy states
    my state = 8  -STANDBY HOT 
    peer state = 13 -ACTIVE
  5. Comience una o más llamadas a través del sistema. Publique el resumen de gran disponibilidad de la Voz de la demostración y muestre que los comandos connection del rtp del voip en el Active y los routeres en espera de aseegurar las llamadas es ascendente y checkpointed.

  6. Pruebe el intercambio recargando el router activo. Si usted está utilizando un teléfono para hacer las llamadas, usted puede escuchar el teléfono para aseegurar el trayecto de medios se preserva. Si usted está utilizando el equipo de prueba, usted puede utilizar las visualizaciones del paquete para determinar si están fluyendo los media para las llamadas:

    Router#show interfaces g0/0 accounting
    GigabitEthernet0/0 
    Protocol  Pkts In   Chars In   Pkts Out   Chars Out
    Other     1         58         6          360
    IP        406       178841     201        16394
    ARP       569       34292      0          0
    CDP       116       31672      22         7304
  7. Inactividad de los media de prueba: Pare la llamada. Relance la conexión del rtp del voip de la demostración. Después del vencimiento del temporizador de la media-inactividad, no debe haber conexiones de RTP activas. Usted puede también marcar esto vía el comando summary de gran disponibilidad de la Voz de la demostración y buscarlo:

    Router#show voice high-availability summary | include media
    Media Inactivity event count: 1

    La cuenta de evento de la inactividad de los media debe mostrar 1.

Screenshots para verificar una sola llamada preservada sobre una Conmutación por falla

La visualización antes de la Conmutación por falla:

  • Router activo (#01)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-02.gif

  • Router en espera (#02)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-03.gif

Recargar el router activo (#01) para forzar una Conmutación por falla:

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-04.gif

Se preserva el router en espera (#02) asume el control como nuevo Active, la llamada (recurso seguro = nuevo Active):

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-05.gif

Previamente las recargas del router activo (#01) como el nuevo router en espera, y la llamada se preserva en el nuevo recurso seguro.

  • Nuevo router espera (#01):

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-06.gif

  • Nuevo router activo (#02):

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-07.gif

Troubleshooting

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

Estos comandos show and debug son útiles durante el troubleshooting de la Redundancia de casilla a casilla:

show redundancy state
show redundancy inter-device
show standby brief
show standby internal
show sip-ua status
show sip-ua statistics
show voice high-availability summary
show voip rtp connection | include connection
show arp
debug voip ccapi all
debug voip ccapi error
debug voip rtp session
debug voip rtcp session
debug voip rtp error
debug voip rtcp error
debug voice high-availability all
debug voice high-availability error
debug ccsip info
debug ccsip messages
debug ccsip media
debug ccsip error
debug standby terse

Nota: No gire un gran número de debugs en un sistema que lleva un volumen alto de tráfico de la llamada activa.

Nota: En cada intercambio, después de la recarga de router, los debugs se deben volver a permitir en el nuevo router en espera.

Cada router en un grupo del HSRP participa en el protocolo implementando una máquina de estado simple. Todo el Routers comienza en el estado inicial.

  1. Inicial: Éste es el estado que comienza e indica que el HSRP no se está ejecutando. Este estado se ingresa vía un cambio de configuración o cuando sube una interfaz primero.

  2. Aprenda: El router no ha determinado a la dirección IP virtual, y no todavía ha visto un mensaje de saludo autenticado del router activo. En este estado el router todavía está esperando para oír del router activo.

  3. Escuche: El router conoce a la dirección IP virtual, pero es ni el active o router en espera. Escucha los mensajes de saludo provenientes de esos routers.

  4. Hable: El router envía los mensajes de saludo periódico y está participando activamente en la elección del active y/o del router en espera. Un router no puede pasar al estado de pico salvo que tenga una dirección IP virtual.

  5. Recurso seguro: El router es un candidato a hacer el router activo siguiente y envía los mensajes de saludo periódico. Excepto las condiciones transitorias, DEBE haber a lo más un router en el grupo en el estado espera.

  6. Activo: El router está remitiendo actualmente los paquetes que se envían a la dirección IP virtual MAC/del grupo. El router envía los mensajes de saludo periódico. Además de las condiciones transitorias, DEBE haber a lo más un router en el estado activo en el grupo.

Extremidad de troubleshooting: ¿Por qué hay dos routeres activos?

Esto ocurre cuando ambo Routers no puede ver el hellos del HSRP de uno a.

  • Marque si cada router puede hacer ping el otro IP Interface Address. Si no, entonces las comunicaciones entre el Routers están abajo.

  • Utilice el comando debug standby de ver si el Routers es de envío y/o de recepción de los paquetes del HSRP hello. Si el par está enviando el hellos, pero los entonces no se están recibiendo marcan la interfaz o los comandos show controller de la demostración de ver si la interfaz está escuchando la dirección Multicast del HSRP.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 112095