Guía de Configuración de Soluciones de Calidad de Servicio de Cisco IOS, versión 12.2SR
RSVP Refresh Reduction and Reliable Messaging
21 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 245 KB | Inglés (5 Marzo 2008) | Comentarios

Contenidos

RSVP Refresh Reduction and Reliable Messaging

Contenido

Los requisitos previos para RSVP restauran la reducción y la Mensajería confiable

Las restricciones para RSVP restauran la reducción y la Mensajería confiable

La información sobre RSVP restaura la reducción y la Mensajería confiable

El diseño de la característica de RSVP restaura la reducción y la Mensajería confiable

Los tipos de mensaje en RSVP restauran la reducción y la Mensajería confiable

Mensajes confiables

Mensajes del conjunto

Mensajes de actualización sumarios

Las ventajas de RSVP restauran la reducción y la Mensajería confiable

Cómo configurar RSVP restaure la reducción y la Mensajería confiable

Habilitar RSVP en una interfaz

Habilitando RSVP restaure la reducción

Verificando RSVP restaure la reducción y la Mensajería confiable

Los ejemplos de configuración para RSVP restauran la reducción y la Mensajería confiable

Ejemplo: RSVP Refresh Reduction and Reliable Messaging

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Referencia de Comandos


RSVP Refresh Reduction and Reliable Messaging


Primera publicación: De noviembre el 25 de 2002
Última actualización: De febrero el 27 de 2009

RSVP restaura la reducción y la característica de la Mensajería confiable incluye restaura la reducción, que mejora el scalability, el tiempo de espera, y la confiabilidad del Resource Reservation Protocol (RSVP) que señala para aumentar el rendimiento de la red y la entrega de mensajes.

El historial para RSVP restaura la característica de la reducción y de la Mensajería confiable

Versión
Modificación

12.2(13)T

Esta función fue introducida.

12.0(24)S

Esta característica era integrada en el Cisco IOS Release 12.0(24)S.

12.2(14)S

Esta función se integró en Cisco IOS Release 12.2(14)S.

12.0(26)S

Dos comandos, ip rsvp signalling refresh misses y ip rsvp signalling refresh interval, fueron agregados en el Cisco IOS Release 12.0(26)S.

12.0(29)S

burst Y max-size los valores por defecto del argumento para ip rsvp signalling rate-limit el comando fueron aumentados a 8 mensajes y a 2000 bytes, respectivamente.

12.2(28)SB

Esta función se integró en Cisco IOS Release 12.2(28)SB.

12.2(18)SXF5

Esta característica era integrada en el Cisco IOS Release 12.2(18)SXF5.

12.2(33)SRB

Esta característica era integrada en el Cisco IOS Release 12.2(33)SRB.


Búsqueda de Información de Soporte de Plataformas e Imágenes de Software de Cisco IOS y Catalyst OS

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Los requisitos previos para RSVP restauran la reducción y la Mensajería confiable

Las restricciones para RSVP restauran la reducción y la Mensajería confiable

La información sobre RSVP restaura la reducción y la Mensajería confiable

Cómo configurar RSVP restaure la reducción y la Mensajería confiable

Los ejemplos de configuración para RSVP restauran la reducción y la Mensajería confiable

Referencias adicionales

Referencia de Comandos

Los requisitos previos para RSVP restauran la reducción y la Mensajería confiable

RSVP se debe configurar en dos o más Routers dentro de la red antes de que usted pueda utilizar RSVP restaure la característica de la reducción y de la Mensajería confiable.

Las restricciones para RSVP restauran la reducción y la Mensajería confiable

Los flujos del Multicast no se soportan para los mensajes confiables y el resumen restaura las características.

La información sobre RSVP restaura la reducción y la Mensajería confiable

Para configurar RSVP restaure la reducción y característica de la Mensajería confiable, usted debe entender los conceptos siguientes:

El diseño de la característica de RSVP restaura la reducción y la Mensajería confiable

Los tipos de mensaje en RSVP restauran la reducción y la Mensajería confiable

Las ventajas de RSVP restauran la reducción y la Mensajería confiable

El diseño de la característica de RSVP restaura la reducción y la Mensajería confiable

RSVP es un red-control, el protocolo del suave-estado que habilita las aplicaciones de Internet para obtener las calidades de servicio especiales (QoS) para sus flujos de datos. Como protocolo del suave-estado, RSVP requiere que el estado esté restaurado periódicamente. Si los mensajes de actualización no se transmiten durante un intervalo especificado, el estado de RSVP mide el tiempo automáticamente hacia fuera y se borra.

En una red que utilice RSVP que señala, la confiabilidad y los problemas de latencia ocurren cuando un mensaje RSVP se pierde en la transmisión. Un mensaje setup perdido de RSVP puede causar una reserva retrasada o fallada; un mensaje de actualización perdido de RSVP puede causar un retardo en la modificación de una reserva o en un descanso de la reserva. Las aplicaciones intolerantes pueden fallar como consecuencia.

Los problemas de la confiabilidad pueden también ocurrir cuando hay tráfico de mensaje de actualización excesivo de RSVP causado por un gran número de reservas en la red. Usando los mensajes de actualización sumarios puede mejorar la confiabilidad perceptiblemente reduciendo la cantidad de RSVP restauran el tráfico.


Los paquetesde RSVP de la nota consisten en las encabezados que identifican los tipos de mensaje, y el objeto coloca que contiene los atributos y las propiedades que describen cómo interpretar y actuar en el contenido.


Los tipos de mensaje en RSVP restauran la reducción y la Mensajería confiable

RSVP restaura la característica de la reducción y de la Mensajería confiable (el cuadro 1) incluye restaura la reducción, que mejora el scalability, el tiempo de espera, y la confiabilidad de RSVP que señala introduciendo las Extensiones siguientes:

Mensajes confiables (objetos MESSAGE_ID, MESSAGE_ID_ACK, y mensajes ACK)

Mensajes del conjunto (recepción y proceso solamente)

Mensajes de actualización sumarios (objetos MESSAGE_ID_LIST y MESSAGE_ID_NACK)

El cuadro 1 RSVP restaura la reducción y la Mensajería confiable

Mensajes confiables

La extensión confiable de los mensajes soporta la entrega de mensajes confiable entre los routeres de la vencidad implementando un mecanismo del acuse de recibo que consista en un objeto MESSAGE_ID y un objeto MESSAGE_ID_ACK. Los acuses de recibo se pueden transmitir en un mensaje ACK o llevar a cuestas en otros mensajes RSVP.

Cada mensaje RSVP contiene un objeto MESSAGE_ID. Si el campo del indicador de ACK_Desired se fija dentro del objeto MESSAGE_ID, el receptor transmite un objeto MESSAGE_ID_ACK al remitente para confirmar la salida.

Mensajes del conjunto

Un mensaje del conjunto consiste en varios mensajes RSVP estándar que se agrupen en un solo mensaje RSVP.

Un mensaje del conjunto debe contener por lo menos un submessage. Un submessage puede ser cualquier tipo de mensaje RSVP con excepción de otro mensaje del conjunto. Los tipos de Submessage incluyen la trayectoria, PathErr, Resv, ResvTear, ResvErr, ResvConf, y el ACK.

Los mensajes del conjunto se dirigen directamente al vecino de RSVP. La encabezado del conjunto sigue inmediatamente el encabezado IP, y no hay encabezado intermedia del transporte.

Cuando un router recibe un mensaje del conjunto que no se dirija a uno de sus IP Address locales, él adelante el mensaje.


Los mensajesdel conjunto de la nota pueden ser recibidos, pero no ser enviados.


Mensajes de actualización sumarios

Un mensaje de actualización sumario soporta la restauración del estado de RSVP sin la transmisión de los mensajes convencionales de la trayectoria y de Resv. Por lo tanto, la cantidad de información que se debe transmitir y procesar para mantener la sincronización de estado de RSVP se reduce grandemente.

Un mensaje de actualización sumario lleva un conjunto de los objetos MESSAGE_ID que identifican los estados de la trayectoria y de Resv que deben ser restaurados. Cuando un nodo de RSVP recibe un mensaje de actualización sumario, el nodo hace juego cada objeto recibido MESSAGE_ID con el estado localmente instalado de la trayectoria o de Resv. Si los objetos MESSAGE_ID hacen juego al estado local, el estado es actualizado como si un mensaje de actualización de RSVP del estándar fuera recibido. Sin embargo, si un objeto MESSAGE_ID no hace juego al estado local del receptor, el receptor notifica el remitente del mensaje de actualización sumario transmitiendo un objeto MESSAGE_ID_NACK.

Cuando un mensaje de actualización sumario se utiliza para restaurar el estado de una sesión RSVP, la transmisión de los mensajes de actualización convencionales se suprime. El resumen restaura la extensión no se puede utilizar para un mensaje de la trayectoria o de Resv que contenga los cambios a un estado previamente de divulgación. También, solamente un estado que fue hecho publicidad previamente en los mensajes de la trayectoria o de Resv que contenían los objetos MESSAGE_ID se puede restaurar usando un mensaje de actualización sumario.

Las ventajas de RSVP restauran la reducción y la Mensajería confiable

Rendimiento de la red aumentado

Restaure la reducción reduce el volumen de tráfico de la red de estado estacionario generado, el periodo de los recursos de la CPU usados, y el tiempo de respuesta, de tal modo aumentando el rendimiento de la red.

Entrega de mensajes mejorada

Los MESSAGE_ID y los objetos MESSAGE_ID_ACK se aseguran que la entrega confiable de los mensajes y del estado rápido del soporte restaure cuando ocurre un problema de red. Por ejemplo, los objetos MESSAGE_ID_ACK se utilizan para detectar las pérdidas de transmisión del link.

Cómo configurar RSVP restaure la reducción y la Mensajería confiable

Esta sección contiene los siguientes procedimientos:

Habilitando RSVP en una interfaz (requerida)

Habilitando RSVP restaure la reducción (requerida)

Verificando RSVP restaure la reducción y la Mensajería confiable (opcionales)

Habilitar RSVP en una interfaz

Realice la tarea siguiente de habilitar RSVP en una interfaz.

PASOS SUMARIOS

1. enable

2. configure terminal

3. interface type number

4.ip rsvp bandwidth [[]interface-kbps sub-pool]

5. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type number

Example:

Router(config)# interface Ethernet1

Ingresa en el modo de configuración de la interfaz.

type Y number los argumentos identifique la interfaz que se configurará.

Paso 4 

ip rsvp bandwidth [interface-kbps [sub-pool]]

Example:

Router(config-if)# ip rsvp bandwidth 7500 7500

Permisos RSVP en una interfaz.

El opcionales interface-kbps y sub-pool los argumentos especifican la cantidad de ancho de banda que se puede afectar un aparato por los flujos de RSVP o a un flujo único, respectivamente. Los valores son a partir la 1 a 10000000, y a partir la 0 a 10000000, respectivamente.

Paso 5 

end

Example:

Router(config-if)# end

Vuelve al modo EXEC privilegiado.


Habilitando RSVP restaure la reducción

Realice la tarea siguiente de habilitar RSVP restauran la reducción.

PASOS SUMARIOS

1. enable

2. configure terminal

3. ip rsvp signalling refresh reduction

4. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip rsvp signalling refresh reduction

Example:

Router(config)# ip rsvp signalling refresh reduction

Los permisos restauran la reducción.

Paso 4 

end

Example:

Router(config)# end

Vuelve al modo EXEC privilegiado.


Verificando RSVP restaure la reducción y la Mensajería confiable

Realice la tarea siguiente de verificar que RSVP restaura la reducción y está funcionando la característica de la Mensajería confiable.

PASOS SUMARIOS

1. enable

2. clear ip rsvp counters [confirm]

3. show ip rsvp

4. show ip rsvp counters [interface interface-unit | summary | neighbor]

5.show ip rsvp interface [interface-typeinterface-number] []detail

6.show ip rsvp neighbor []detail

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

clear ip rsvp counters [confirm]

Example:

Router# clear ip rsvp counters

(Opcional) borra (los conjuntos a cero) todos los contadores IP RSVP que estén siendo mantenidos por el router.

Paso 3 

show ip rsvp

Example:

Router# show ip rsvp

(Opcional) visualiza la limitación de la tarifa, la restaurar-reducción, y la información de vecino de RSVP.

Paso 4 

show ip rsvp counters [interface interface-unit | summary | neighbor]

Example:

Router# show ip rsvp counters summary

(Opcional) visualiza el número de mensajes RSVP que fueron enviados y recibidos en cada interfaz.

La palabra clave optativa summary visualiza la cantidad acumulativa de mensajes RSVP enviados y recibidos por el router sobre todas las interfaces.

Paso 5 

show ip rsvp interface [interface-type interface-number] [detail]

Example:

Router# show ip rsvp interface detail

(Opcional) visualiza la información sobre las interfaces en las cuales RSVP se habilita incluyendo el ancho de banda disponible actual del presupuesto y del máximo de la asignación.

La palabra clave optativa detail visualiza el ancho de banda y los parámetros de señalización.

Paso 6 

show ip rsvp neighbor [detail]

Example:

Router# show ip rsvp neighbor detail

(Opcional) visualiza la información del RSVP-vecino incluyendo los IP Addresses.

La palabra clave optativa detail visualiza a los vecinos actuales de RSVP y los identifica si el vecino está utilizando el IP, el User Datagram Protocol (UDP), o la encapsulación de RSVP para una interfaz especificada o todas las interfaces.

Los ejemplos de configuración para RSVP restauran la reducción y la Mensajería confiable

Esta sección proporciona el siguiente ejemplo de configuración:

Ejemplo: RSVP Refresh Reduction and Reliable Messaging

Ejemplo: RSVP Refresh Reduction and Reliable Messaging

En el siguiente ejemplo, se habilita RSVP restaura la reducción:

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface Ethernet1
Router(config-if)# ip rsvp bandwidth 7500 7500
Router(config-if)# exit
Router(config)# ip rsvp signalling refresh reduction
Router(config)# end

El siguiente ejemplo verifica que RSVP restaure la reducción esté habilitado:

Router# show running-config

Building configuration...
Current configuration : 1503 bytes

!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname Router
!
no logging buffered
logging rate-limit console 10 except errors
!
ip subnet-zero
ip cef
!
ip multicast-routing
no ip dhcp-client network-discovery
lcp max-session-starts 0
mpls traffic-eng tunnels
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 ip rsvp bandwidth 1705033 1705033
!
interface Tunnel777
 no ip address
 shutdown
!
interface Ethernet0
 ip address 192.168.0.195 255.0.0.0
 no ip mroute-cache
 media-type 10BaseT
!
interface Ethernet1
 ip address 192.168.5.2 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip pim dense-mode
 no ip mroute-cache
 media-type 10BaseT
 ip rsvp bandwidth 7500 7500
!
interface Ethernet2
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip pim dense-mode
 no ip mroute-cache
 media-type 10BaseT
 mpls traffic-eng tunnels
 ip rsvp bandwidth 7500 7500
!
interface Ethernet3
 ip address 192.168.2.2 255.255.255.0
 ip pim dense-mode
 media-type 10BaseT
 mpls traffic-eng tunnels
!
!
router eigrp 17
 network 192.168.0.0
 network 192.168.5.0
 network 192.168.12.0
 network 192.168.30.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip rsvp signalling refresh reduction
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
 transport input pad v120 telnet rlogin udptn
!
end

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con RSVP restauran la característica de la reducción y de la Mensajería confiable.

Documentos Relacionados

Tema relacionado
Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Comandos rsvp: sintaxis, modo de comando, valores por defecto, Pautas para el uso, y ejemplos del comando complete

 Referencia de Comandos de las Soluciones de Calidad de Servicio de Cisco IOS

Características de QoS incluyendo la señalización, la clasificación, y la administración de la congestión

Módulo de la descripción de la calidad de servicio”


Estándares

Estándar
Título

Ninguno


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html


RFC

RFC
Título

RFC 2205

Resource Reservation Protocol

RFC 2206

RSVP Management Information Base utilizando SMIv2

RFC 2209

RSVP — Reglas del procesamiento de mensajes de la versión 1

RFC 2210

El uso de RSVP con los Servicios integrados IETF

RFC 2211/2212

Especificación del servicio del elemento de redes de la Controlado-carga

RFC 2702

Requisitos para la ingeniería de tráfico sobre el MPLS

RFC 2749

Uso del Servicio de políticas abiertas comunes (COPS) para RSVP

RFC 2750

Control de las extensiones de RSVP para la política

RFC 2814

Administrador de ancho de banda de la subred SBM: Un protocolo para el control de admisión RSVP-basado sobre las redes de IEEE 802-style

RFC 2961

RSVP restaura las Extensiones de arriba de la reducción

RFC 2996

Formato del objeto de RSVP DCLASS


Asistencia Técnica

Descripción
Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html


Referencia de Comandos

Los siguientes comandos se introducen o se modifican en la característica o las características documentadas en este módulo. Para la información sobre estos comandos, vea la referencia del comando solutions de la Calidad de servicio de Cisco IOS en http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_book.html. Para obtener información sobre todos los comandos de Cisco IOS, utilice la Herramienta de Búsqueda de Comandos en http://tools.cisco.com/Support/CLILookup o en la Lista de Comandos Principal de Cisco IOS.

ip rsvp signalling rate-limit

show ip rsvp signalling rate-limit