Guía de Configuración de Soluciones de Calidad de Servicio de Cisco IOS, versión 12.2SR
Configurar el soporte de RSVP para el Frame Relay
21 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 319 KB | Inglés (5 Marzo 2008) | Comentarios

Contenidos

Configurar el soporte de RSVP para el Frame Relay

Encontrar la información de la característica

Contenido

Cómo configurar el soporte de RSVP para el Frame Relay

Habilitar la Encapsulación de Frame Relay en una interfaz

Configurar un circuito virtual

Habilitar el Control de tráfico de Frame Relay en una interfaz

Habilitar la interfaz de administración local mejorada

Habilitar RSVP en una interfaz

Especificar un map class del modelado de tráfico para una interfaz

Definición de un map class con el WFQ y los parámetros de modelado del tráfico

Especificar el CIR

Especificar el CIR mínimo

Habilitar el WFQ

Habilitar el FRF.12

Configurar una trayectoria

Configurar una reserva

Verificar el soporte de RSVP para el Frame Relay

Configuración de multipunto

Configuración Point-to-Point

Monitoreando y mantener el soporte de RSVP para el Frame Relay

Ejemplos de configuración para configurar el soporte de RSVP para el Frame Relay

Ejemplo: Configuración de multipunto

Ejemplo: Configuración Point-to-Point

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica


Configurar el soporte de RSVP para el Frame Relay


Este capítulo describe las tareas para configurar el soporte de RSVP para la característica de Frame Relay.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Cómo configurar el soporte de RSVP para el Frame Relay

Ejemplos de configuración para configurar el soporte de RSVP para el Frame Relay

Referencias adicionales

Cómo configurar el soporte de RSVP para el Frame Relay

Habilitando la Encapsulación de Frame Relay en una interfaz (requerida)

Configurando un circuito virtual (requerido)

Habilitando el Control de tráfico de Frame Relay en una interfaz (requerida)

Habilitando la interfaz de administración local mejorada (opcional)

Habilitando RSVP en una interfaz (requerida)

Especificando un map class del modelado de tráfico para una interfaz (requerida)

Definiendo un map class con el WFQ y los parámetros de modelado del tráfico (requeridos)

Especificando el CIR (requerido)

Especificando el CIR mínimo (opcional)

Habilitando el WFQ (requerido)

Habilitando el FRF.12 (requerido)

Configurando una trayectoria (opcional)

Configurando una reserva (opcional)

Verificando el soporte de RSVP para el Frame Relay (opcional)

Monitoreando y mantener el soporte de RSVP para el Frame Relay (opcional)

Habilitar la Encapsulación de Frame Relay en una interfaz

 
Comando
Propósito

Paso 1 

Router(config)# interface s3/0

Habilita una interfaz (por ejemplo, la interfaz serial 3/0) y ingresa el modo de la interfaz de la configuración.

Paso 2 

Router(config-if)# encapsulation frame-relay [cisco | ietf]

El Frame Relay de los permisos y especifica el método de encapsulación.

Configurar un circuito virtual

Comando
Propósito

Router(config-if)# frame-relay interface-dlci dlci

Asigna un identificador de conexión de link de datos (DLCI) a una subinterfaz especificada del Frame Relay en un router o un Access Server.


Habilitar el Control de tráfico de Frame Relay en una interfaz

Comando
Propósito

Router(config-if)# frame-relay traffic-shaping

Modelado de tráfico de los permisos y espera por VC para todos los circuitos virtuales permanentes (PVC) y los circuitos virtuales conmutados (SVC) en una interfaz de Frame Relay.


Habilitar la interfaz de administración local mejorada

Comando
Propósito

Router(config-if)# frame-relay lmi-type

Selecciona el tipo LMI.


Habilitar RSVP en una interfaz

Comando
Propósito

Router(config-if)# ip rsvp bandwidth

Permisos RSVP en una interfaz.


Especificar un map class del modelado de tráfico para una interfaz

Comando
Propósito

Router(config-if)# frame-relay class name

Asocia un map class a una interfaz o a una subinterfaz.


Definición de un map class con el WFQ y los parámetros de modelado del tráfico

Comando
Propósito

Router(config)# map-class frame-relay map-class-name

Define los parámetros para una clase especificada.


Especificar el CIR

Comando
Propósito

Router(config-map-class)# frame-relay cir {in | out} bps

Especifica el CIR entrante o saliente máximo para un VC de Frame Relay.


Especificar el CIR mínimo

Comando
Propósito

Router(config-map-class)# frame-relay mincir {in | out} bps

Especifica el CIR entrante o saliente aceptable mínimo para un VC de Frame Relay.

Observesi el mincir no se configura, después el valor del control de admisión es el CIR/2.


Habilitar el WFQ

Comando
Propósito

Router(config-map-class)# frame-relay fair-queue

Permisos WFQ en un PVC.


Habilitar el FRF.12

Comando
Propósito

Router(config-map-class)# frame-relay fragment fragment-size

Fragmentación de Frame Relay de los permisos en un PVC.


Configurar una trayectoria

Comando
Propósito

Router(config)# ip rsvp sender

Especifica los parámetros path de RSVP, incluyendo las direcciones de origen y destino, el protocolo, el destino y los puertos de origen, el direccionamiento anterior del salto, la velocidad de bits media, y los tamaños de ráfaga.


Configurar una reserva

Comando
Propósito

Router(config)# ip rsvp reservation

Especifica los parámetros del Reservación RSVP, incluyendo las direcciones de origen y destino, el protocolo, el destino y los puertos de origen, la dirección del salto siguiente, la interfaz de salto siguiente, el estilo de la reserva, el tipo de servicio, la velocidad de bits media, y los tamaños de ráfaga.


Verificar el soporte de RSVP para el Frame Relay

Configuración de multipunto

Configuración Point-to-Point

Configuración de multipunto

Para verificar el soporte de RSVP para el Frame Relay en una configuración de multipunto, realice los pasos siguientes:


Paso 1Ingrese show ip rsvp installed el comando al mostrar información sobre las interfaces y sus reservas admitidas. La salida en el siguiente ejemplo muestra que el Subinterfaz serial 3/0.1 tiene dos reservas:

Router# show ip rsvp installed

RSVP:Serial3/0
BPS    To              From            Protoc DPort  Sport  Weight Conversation
RSVP:Serial3/0.1
BPS    To              From            Protoc DPort  Sport  Weight Conversation
40K    145.20.22.212   145.10.10.211   UDP    10     10     0      24
50K    145.20.21.212   145.10.10.211   UDP    10     10     6      25

La ponderación0 de la nota se asigna Voz-como los flujos, que proceden al priority queue.


Paso 2Ingrese show ip rsvp installed detail el comando de visualizar la información adicional sobre las interfaces, las subinterfaces, DLCI PVC, y sus reservas actuales.


Observeen el producto siguiente, el primer flujo consigue una Cola reservada con una ponderación > 0, y el segundo flujo consigue el priority queue con una ponderación = 0.


Router# show ip rsvp installed detail

RSVP:Serial3/0 has the following installed reservations
RSVP:Serial3/0.1 has the following installed reservations
RSVP Reservation. Destination is 145.20.21.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 10, Source port is 10
  Reserved bandwidth:50K bits/sec, Maximum burst:1K bytes, Peak rate:50K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: RESERVED queue 25.  Weight:6
  Data given reserved service:0 packets (0M bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 68 seconds
  Long-term average bitrate (bits/sec):0M reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.22.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 10, Source port is 10
  Reserved bandwidth:40K bits/sec, Maximum burst:1K bytes, Peak rate:40K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: PRIORITY queue 24.  Weight:0
  Data given reserved service:0 packets (0M bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 707 seconds
  Long-term average bitrate (bits/sec):0M reserved, 0M best-effort

Configuración Point-to-Point

Para verificar el soporte de RSVP para el Frame Relay en una configuración Point-to-Point, realice los pasos siguientes:


Paso 1Ingrese show ip rsvp installed el comando al mostrar información sobre las interfaces y sus reservas admitidas. La salida en el siguiente ejemplo muestra que el Subinterfaz serial 3/0.1 tiene una reserva, y el Subinterfaz serial 3/0.2 tiene una reserva.

Router# show ip rsvp installed

RSVP:Serial3/0
BPS    To              From            Protoc DPort  Sport
RSVP:Serial3/0.1
BPS    To              From            Protoc DPort  Sport
50K    145.20.20.212   145.10.10.211   UDP    10     10

RSVP:Serial3/0.2
BPS    To              From            Protoc DPort  Sport
10K    145.20.21.212   145.10.10.211   UDP    11     11

La ponderación0 de la nota se asigna Voz-como los flujos, que proceden al priority queue.


Paso 2Ingrese show ip rsvp installed detail el comando de visualizar la información adicional sobre las interfaces, las subinterfaces, DLCI PVC, y sus reservas actuales.


Observeen el producto siguiente, el primer flujo con una ponderación > 0 consigue una Cola reservada y el segundo flujo con una ponderación = 0 consigue el priority queue.


Router# show ip rsvp installed detail

RSVP:Serial3/0 has the following installed reservations
RSVP:Serial3/0.1 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 10, Source port is 10
  Reserved bandwidth:50K bits/sec, Maximum burst:1K bytes, Peak rate:50K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: RESERVED queue 25.  Weight:6
  Data given reserved service:415 packets (509620 bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 862 seconds
  Long-term average bitrate (bits/sec):4724 reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 11, Source port is 11
  Reserved bandwidth:10K bits/sec, Maximum burst:1K bytes, Peak rate:10K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: PRIORITY queue 24.  Weight:0
  Data given reserved service:85 packets (104380 bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 875 seconds
  Long-term average bitrate (bits/sec):954 reserved, 0M best-effort
RSVP:Serial3/0.2 has the following installedreservations

RSVP Reservation. Destination is 145.20.21.212, Source is 145.10.10.211,

  Protocol is UDP, Destination port is 11, Source port is 11
  Reserved bandwidth:10K bits/sec, Maximum burst:1K bytes, Peak rate:10Kbits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0:PRIORITY queue 24.  Weight:0
  Data given reserved service:85 packets (104380 bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 875 seconds
  Long-term average bitrate (bits/sec):954 reserved, 0M best-effort

Monitoreando y mantener el soporte de RSVP para el Frame Relay

Comando
Propósito

Router# show ip rsvp installed

Información de las visualizaciones sobre las interfaces y sus reservas admitidas.

Router# show ip rsvp installed detail

Visualiza la información adicional sobre las interfaces, los DLCI, y sus reservas admitidas.

Router# show queueing

Visualiza todos o las Estrategias de almacenamiento en cola configuradas seleccionadas.


Ejemplos de configuración para configurar el soporte de RSVP para el Frame Relay

Ejemplo: Configuración de multipunto

Ejemplo: Configuración Point-to-Point

Ejemplo: Configuración de multipunto

El cuadro 1 muestra una configuración de la interfaz multipunto de uso general en los entornos de Frame Relay en los cuales los PVC múltiples se configuran en la misma subinterfaz en el r1 del router.

Cuadro 1 configuración de la interfaz multipunto

RSVP realiza el control de admisión basado en el mincir de DLCI 101 y de DLCI 201. El punto de congestión es no el subinterfaz 10.1.1.1/16, sino el CIR de DLCI 101 y de DLCI 201.

El siguiente ejemplo es una salida de muestra para la interfaz serial 3/0:

interface Serial3/0
 no ip address
 encapsulation frame-relay
 no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type cisco
 ip rsvp bandwidth 350 350
!
interface Serial3/0.1 multipoint
 ip address 10.1.1.1 255.255.0.0
 frame-relay interface-dlci 101
  class fr-voip
 frame-relay interface-dlci 201
  class fast-vcs
 ip rsvp bandwidth 350 350

ip rsvp pq-profile 6000 2000 ignore-peak-value
!
!
map-class frame-relay fr-voip
 frame-relay cir 800000
 frame-relay bc 8000
 frame-relay mincir 128000
 frame-relay fragment 280
 no frame-relay adaptive-shaping
 frame-relay fair-queue
!
map-class frame-relay fast-vcs
 frame-relay cir 200000
 frame-relay bc 2000
 frame-relay mincir 60000
 frame-relay fragment 280
 no frame-relay adaptive-shaping
 frame-relay fair-queue
!

Observecuando FRTS se habilita, el valor de (Bc) del committed burst del Frame Relay (en los bits) se debe configurar a un máximo del 1/100o del valor CIR (en los bits por segundo). Esta configuración se asegura de que el intervalo del token bucket FRTS (Bc/CIR) no exceda al ms 10, y de que los paquetes de voz están mantenidos puntualmente.


Ejemplo: Configuración Point-to-Point

El cuadro 2 muestra una configuración de la interfaz Point-to-Point de uso general en los entornos de Frame Relay en cuál el PVC por la subinterfaz se configura en el r1 del router.

Cuadro 2 configuración de la interfaz Point-to-Point de la muestra

Note que el ancho de banda de la interfaz del router para el r1 es T1 (1.544 Mbps), mientras que el valor CIR de DLCI 201 hacia el R3 es el kbps 256. Para los flujos de tráfico del r1 al R3 sobre DLCI 201, el punto de congestión es el CIR para DLCI 201. Como consecuencia, RSVP realiza el control de admisión basado en el mincir y reserva los recursos, incluyendo las colas de administración del tráfico y el ancho de banda, en el sistema WFQ que se ejecuta en cada DLCI.

El siguiente ejemplo es salida de muestra para la interfaz serial 3/0:

interface Serial3/0
 no ip address
 encapsulation frame-relay
no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type cisco
 ip rsvp bandwidth 500 500
!
interface Serial3/0.1 point-to-point
 ip address 10.1.1.1 255.255.0.0
 frame-relay interface-dlci 101
  class fr-voip
 ip rsvp bandwidth 350 350
!
interface Serial3/0.2 point-to-point
 ip address 10.3.1.1 255.255.0.0
 frame-relay interface-dlci 201
  class fast-vcs
 ip rsvp bandwidth 150 150

ip rsvp pq-profile 6000 2000 ignore-peak-value
!
!
map-class frame-relay fr-voip
 frame-relay cir 800000
 frame-relay bc 8000
 frame-relay mincir 128000
 frame-relay fragment 280
 no frame-relay adaptive-shaping
 frame-relay fair-queue

Observecuando FRTS se habilita, el valor de (Bc) del committed burst del Frame Relay (en los bits) se debe configurar a un máximo del 1/100o del valor CIR (en los bits por segundo). Esta configuración se asegura de que el intervalo del token bucket FRTS (Bc/CIR) no exceda al ms 10, y de que los paquetes de voz están mantenidos puntualmente.


Referencias adicionales

Documentos Relacionados

Tema relacionado
Título del documento

Comandos de Cisco IOS

El Cisco IOS domina los comandos list, todos las versiones

Comandos rsvp: sintaxis de comandos completa, modo de comandos, historial de comandos, valores predeterminados, directrices de uso y ejemplos

Referencia de Comandos de las Soluciones de Calidad de Servicio de Cisco IOS

Descripción en RSVP

Descripción General de la Señalización


Estándares

Estándar
Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html


RFC

RFC
Título

Se soportan los RFC no nuevos o modificados, y el soporte para los RFC existentes no se ha modificado.


Asistencia Técnica

Descripción
Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html