Guía de Configuración de Soluciones de Calidad de Servicio de Cisco IOS, versión 12.2SR
Configuración de la Detección Temprana Aleatoria Ponderada
21 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 216 KB | Inglés (17 Marzo 2008) | Comentarios

Contenidos

Configuración de la Detección Temprana Aleatoria Ponderada

Lista de tareas de configuración del Weighted Random Early Detection

Habilitar el WRED

Cambio de los parámetros WRED

Monitorear el WRED

Lista de tareas de configuración DWRED

Configurar el DWRED en una política de tráfico

Configurar el DWRED para utilizar los valores de la Prioridad IP en una política de tráfico

Monitoreando y mantener el DWRED

Lista de tareas de configuración del flujo basado WRED

Configurar el flujo basado WRED

Lista de tareas de configuración del DiffServ Compliant WRED

Configurar el WRED para utilizar el valor del Differentiated Services Code Point

WRED en el nivel de la interfaz

WRED en el nivel por VC

WRED en el nivel de clase

Verificar la configuración del valor DSCP

Ejemplos de configuración WRED

Ejemplo: Configuración WRED

Ejemplo: Configuración de parámetro DWRED

Ejemplo: Configuración de parámetro WRED

Ejemplos de configuración DWRED

Ejemplo: DWRED en una interfaz

Ejemplo: Modular QoS CLI

Ejemplo: Configurar el DWRED en política de tráfico

Ejemplo de configuración del flujo basado WRED

Ejemplos de configuración del DiffServ Compliant WRED

Ejemplo: WRED configurado para utilizar el valor DSCP

Ejemplo: Verificación de la configuración del valor DSCP


Configuración de la Detección Temprana Aleatoria Ponderada


Historial de la característica

Versión
Modificación

IOS de Cisco

Para obtener información sobre el soporte de funciones de Cisco IOS Software, utilice Cisco Feature Navigator.


Este módulo describe las tareas para configurar el Weighted Random Early Detection (WRED), WRED distribuido (DWRED), el flujo basado WRED, y el DiffServ Compliant WRED en un router.

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas e imágenes de Cisco IOS Software. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.


La notaWRED es útil con el tráfico adaptante tal como TCP/IP. Con el TCP, los paquetes perdidos indican la congestión, así que la fuente del paquete reducirá su velocidad de transmisión. Con otros protocolos, las fuentes del paquete pueden no responder o pueden volver a enviar los paquetes perdidos a la misma tarifa. Así, la caída de los paquetes no disminuye la congestión.

El WRED trata el tráfico no IP como precedencia 0, la precedencia más baja. Por lo tanto, el tráfico no IP es más probable ser caído que el tráfico IP.

Usted no puede configurar el WRED en la misma interfaz que el Route Switch Processor (RSP) - Asignación personalizada de colas basada, Asignación de colas de prioridad (PQ), o espera cargada de la feria (WFQ). Sin embargo, usted puede configurar el DWRED y el DWFQ en lo mismo interconecta.


El Detección temprana aleatoria (RED) es un mecanismo de prevención de congestionamiento que se aprovecha del mecanismo de control de la congestión del TCP. Aleatoriamente cayendo los paquetes antes de la congestión de los periodos de alto, el ROJO dice la fuente del paquete disminuir su velocidad de transmisión. El WRED cae los paquetes basados selectivamente en la Prioridad IP. Los routeres de borde asignan el precedences IP a los paquetes mientras que ingresan la red. (el WRED es útil en cualquier interfaz de salida donde usted espera tener congestión. Sin embargo, el WRED se utiliza generalmente en los routeres del núcleo de una red, bastante que en el borde.) el WRED utiliza este precedences para determinar cómo trata diversos tipos de tráfico.

Cuando llega un paquete, los eventos siguientes ocurren:

1. Se calculan los tamaños promedios de la cola.

2. Si la media es menos que el umbral mínimo de la cola, se hace cola el paquete de llegada.

3. Si la media está entre el umbral mínimo de la cola para ese tipo de tráfico y el umbral máximo para la interfaz, el paquete se cae o se hace cola, dependiendo de la probabilidad de caída de paquetes para ese tipo de tráfico.

4. Si los tamaños promedios de la cola son mayores que el umbral máximo, se cae el paquete.

Lista de tareas de configuración del Weighted Random Early Detection

Habilitar el WRED

Comando
Propósito

Router(config-if)# random-detect

Permisos WRED. Si usted configura este comando en una interfaz del Versatile Interface Processor (VIP), se habilita el DWRED.


Cambio de los parámetros WRED


Observelos valores de parámetro WRED predeterminado se basan en los mejores datos disponibles. Recomendamos que usted no cambia los parámetros de sus valores predeterminados a menos que usted haya determinado que sus aplicaciones se beneficiarán de los valores cambiados.

Comando
Propósito

Router(config-if)# random-detect exponential-weighting-constant exponent

Configura el factor de ponderación usado en el cálculo de la longitud de la cola promedio.

Router(config-if)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

Configura los parámetros para los paquetes con una Prioridad IP específica. El umbral mínimo para la Prioridad IP 0 corresponde a la mitad del umbral máximo para la interfaz. Relance este comando para cada precedencia. Para configurar el ROJO, bastante que el WRED, utiliza los mismos parámetros para cada precedencia.



Monitorear el WRED

Comando
Propósito

Router# show queue interface-type interface-number

Visualiza la información de encabezado de los paquetes dentro de una cola. Este comando no soporta el DWRED.

Router# show queueing interface interface-number [vc [[vpi/vci]]

Visualiza las estadísticas WRED de un virtual circuit (VC) específico en una interfaz.

Router# show queueing random-detect

Visualiza la configuración de espera para el WRED.

Router# show interfaces [type slot | port-adapter | port]

Configuración de las visualizaciones WRED en una interfaz.


Lista de tareas de configuración DWRED

Configurar el DWRED en una política de tráfico

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la política de tráfico que se creará o modificada.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase de tráfico que se creará e incluida en la política de tráfico

 

Los pasos 3, 4, y 5 son opcionales. Si usted no quiere configurar el factor de ponderación exponencial, especificar la cantidad de ancho de banda, o especificar el número de colas de administración del tráfico que se reservará, usted puede saltar estos tres pasos y continuar con el paso 6.

Paso 3 

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent

Configura el factor de ponderación exponencial usado en el cálculo de la longitud de la cola promedio.

Paso 4 

Router(config-pmap-c)# bandwidth bandwidth-kbps

Especifica la cantidad de ancho de banda, en el kbps, para ser asignado a la clase de tráfico.

Paso 5 

Router(config-pmap-c)# fair-queue [queue-limit queue-values]

Especifica el número de colas de administración del tráfico que se reservará para la clase de tráfico.

Paso 6 

Router(config-pmap-c)# queue-limit number-of-packets

Especifica la cantidad máxima de paquete que se puede hacer cola para la clase del tráfico especificado.

Configurar el DWRED para utilizar los valores de la Prioridad IP en una política de tráfico

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la política de tráfico que se creará o modificada.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase de tráfico para asociarse a la política de tráfico

Paso 3 

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent

Configura el factor de ponderación exponencial usado en el cálculo de la longitud de la cola promedio.

Paso 4 

Router(config-pmap-c)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

Configura los parámetros para los paquetes con una Prioridad IP específica. El umbral mínimo para la Prioridad IP 0 corresponde a la mitad del umbral máximo para la interfaz. Relance este comando para cada precedencia.

Monitoreando y mantener el DWRED

Comando
Propósito

Router# show policy-map

Visualiza todas las políticas de tráfico configuradas.

Router# show policy-map policy-map-name

Visualiza la política de tráfico definida por el usuario.

Router# show policy-map interface

Estadísticas de las visualizaciones y configuraciones de todas las directivas de la entrada y salida asociadas a una interfaz.

Router# show policy-map interface interface-spec

Configuración de las visualizaciones y estadísticas de las directivas de la entrada y salida asociadas a una interfaz particular.

Router# show policy-map interface interface-spec input

Configuración de las visualizaciones y estadísticas de la política de entrada asociada a una interfaz.

Router# show policy-map interface interface-spec output

Visualiza las estadísticas de configuración de la política de resultado asociada a una interfaz.

Router# show policy-map [interface [interface-spec [input | output] [class class-name]]]]

Visualiza la configuración y las estadísticas para el nombre de la clase configurado en la directiva.


Lista de tareas de configuración del flujo basado WRED

Configurar el flujo basado WRED

 
Comando
Propósito

Paso 1 

Router(config-if)# random-detect flow

Habilita el flujo basado WRED.

Paso 2 

Router(config-if)# random-detect flow average-depth-factor scaling-factor

Fija el multiplicador del umbral del flujo para el flujo basado WRED.

Paso 3 

Router(config-if)# random-detect flow count number

Fija la cuenta del flujo máximo para el flujo basado WRED.

Lista de tareas de configuración del DiffServ Compliant WRED

Configurar el WRED para utilizar el valor del Differentiated Services Code Point

WRED en el nivel de la interfaz

 
Comando
Propósito

Paso 1 

Router(config-if)# random-detect dscp-based

Indica que el WRED es utilizar el valor DSCP cuando calcula la probabilidad de caída para el paquete.

Paso 2 

Router(config-if)# random-detect dscp dscpvalue min-threshold max-threshold [mark-probability-denominator]

Especifica el mínimo y los umbrales máximos, y, opcionalmente, el denominador de la marca-probabilidad para el valor especificado DSCP.

WRED en el nivel por VC

 
Comando
Propósito

Paso 1 

Router(config)# random-detect-group group-name dscp-based

Indica que el WRED es utilizar el valor DSCP cuando calcula la probabilidad de caída para el paquete.

Paso 2 

Router(cfg-red-grp)# dscp dscpvalue min-threshold max-threshold [mark-probability-denominator]

Especifica el valor DSCP, los umbrales del mínimo y del PAQUETE MÁXIMO y, opcionalmente, el denominador de la marca-probabilidad para el valor DSCP.

Paso 3 

Router(config-atm-vc)# random-detect [attach group-name]

WRED por cada VC de los permisos o VIP-DWRED por VC.

WRED en el nivel de clase

 
Comando
Propósito

Paso 1 

Router(config-if)# class-map class-map-name

Crea un class map que se utilizará para asociar paquetes con una clase especificada.

Paso 2 

Router(config-cmap)# match match criterion

Configura los criterios de concordancia para una correspondencia de la clase.

Paso 3 

Router(config-if)# policy-map policy-map

Crea o modifica una correspondencia de políticas que se pueda asociar a una o más interfaces para especificar una política de tráfico.

Paso 4 

Router(config-pmap)# class class-map-name

Especifica las acciones de QoS para la clase predeterminada.

Paso 5 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percent}

Especifica o modifica el ancho de banda afectado un aparato para una clase que pertenece a una correspondencia de políticas.

Paso 6 

Router(config-pmap-c)# random-detect dscp-based

Indica que el WRED es utilizar el valor DSCP cuando calcula la probabilidad de caída para el paquete.

Paso 7 

Router(config-pmap-c)# random-detect dscp dscpvalue min-threshold max-threshold [mark-probability-denominator]

Especifica los umbrales del mínimo y del PAQUETE MÁXIMO y, opcionalmente, el denominador de la marca-probabilidad para el valor DSCP.

Paso 8 

Router(config-if)# service-policy output policy-map

Asocia una correspondencia de políticas a una interfaz de salida o al VC que se utilizarán como la política de tráfico para esa interfaz o el VC.

Verificar la configuración del valor DSCP

Comando
Propósito

Router# show queueing interface

Visualiza las estadísticas de espera de una interfaz o del VC.

Router# show policy-map interface

Visualiza la configuración de las clases configuradas para las políticas de tráfico en la interfaz especificada o el circuito virtual permanente (PVC).


Ejemplos de configuración WRED

Ejemplo: Configuración WRED

El siguiente ejemplo habilita el WRED con los valores de parámetro predeterminados:

interface Serial5/0
 description to qos1-75a
 ip address 200.200.14.250 255.255.255.252
 random-detect

Utilice show interfaces la salida de comando para verificar la configuración. Note que las informes enumeras “Detección temprana aleatoria (RED) de la “Estrategia de almacenamiento en cola”.”

Router# show interfaces serial 5/0

Serial5/0 is up, line protocol is up 
  Hardware is M4T
  Description: to qos1-75a
  Internet address is 200.200.14.250/30
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 237/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive not set
  Last input 00:00:15, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:05:08
  Input queue: 0/75/0 (size/max/drops); Total output drops: 1036
  Queueing strategy: random early detection(RED)
  5 minutes input rate 0 bits/sec, 2 packets/sec
  5 minutes output rate 119000 bits/sec, 126 packets/sec
     594 packets input, 37115 bytes, 0 no buffer
     Received 5 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     37525 packets output, 4428684 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Utilice show queue la salida de comando para ver el contenido actual de la cola de la interfaz. Note que hay solamente una cola única en la cual han ocurrido los paquetes de todo el precedences IP se colocan después de caer. La salida se ha truncado para mostrar solamente tres de los cinco paquetes.

Router# show queue serial 5/0 

Output queue for Serial5/0 is 5/0

Packet 1, linktype: ip, length: 118, flags: 0x288
  source: 190.1.3.4, destination: 190.1.2.2, id: 0x0001, ttl: 254,
  TOS: 128 prot: 17, source port 11111, destination port 22222
    data: 0x2B67 0x56CE 0x005E 0xE89A 0xCBA9 0x8765 0x4321 
          0x0FED 0xCBA9 0x8765 0x4321 0x0FED 0xCBA9 0x8765 

Packet 2, linktype: ip, length: 118, flags: 0x288
  source: 190.1.3.5, destination: 190.1.2.2, id: 0x0001, ttl: 254,
  TOS: 160 prot: 17, source port 11111, destination port 22222
    data: 0x2B67 0x56CE 0x005E 0xE89A 0xCBA9 0x8765 0x4321 
          0x0FED 0xCBA9 0x8765 0x4321 0x0FED 0xCBA9 0x8765 

Packet 3, linktype: ip, length: 118, flags: 0x280
  source: 190.1.3.6, destination: 190.1.2.2, id: 0x0001, ttl: 254,
  TOS: 192 prot: 17, source port 11111, destination port 22222
    data: 0x2B67 0x56CE 0x005E 0xE89A 0xCBA9 0x8765 0x4321 
          0x0FED 0xCBA9 0x8765 0x4321 0x0FED 0xCBA9 0x8765 

Utilice show queueing la salida de comando para ver las configuraciones actuales para cada uno del precedences. También note que los umbrales mínimos del valor por defecto están espaciados uniformemente entre la mitad y el umbral máximo entero. Los umbrales se especifican en términos de cuenta de paquetes.

Router# show queueing

Current random-detect configuration:
     Serial5/0
       Queueing strategy:random early detection (WRED)
       Exp-weight-constant:9 (1/512)
       Mean queue depth:28
       Class   Random       Tail    Minimum    Maximum     Mark
                 drop       drop  threshold  threshold  probability
         0        330          0         20         40     1/10
         1        267          0         22         40     1/10
         2        217          0         24         40     1/10
         3        156          0         26         40     1/10
         4         61          0         28         40     1/10
         5          6          0         31         40     1/10
         6          0          0         33         40     1/10
         7          0          0         35         40     1/10
        rsvp        0          0         37         40     1/10

Ejemplo: Configuración de parámetro DWRED

El siguiente ejemplo especifica los mismos parámetros para cada Prioridad IP. Así, todo el precedences IP recibe el mismo tratamiento. Comience habilitando el DWRED.

interface FastEthernet1/0/0
 ip address 200.200.14.250 255.255.255.252
 random-detect

Después, ingrese show queueing random-detect el comando de determinar los valores razonables para utilizar para los parámetros precedencia-específicos.

Router# show queueing random-detect

Current random-detect configuration:
  FastEthernet2/0/0
    Queueing strategy:fifo
    Packet drop strategy:VIP-based random early detection (DWRED)
    Exp-weight-constant:9 (1/512)
    Mean queue depth:0
    Queue size:0       Maximum available buffers:6308
    Output packets:5  WRED drops:0  No buffer:0

    Class   Random       Tail    Minimum    Maximum     Mark       Output
              drop       drop  threshold  threshold  probability  Packets
      0          0          0       109        218      1/10            5
      1          0          0       122        218      1/10            0
      2          0          0       135        218      1/10            0
      3          0          0       148        218      1/10            0
      4          0          0       161        218      1/10            0
      5          0          0       174        218      1/10            0
      6          0          0       187        218      1/10            0
      7          0          0       200        218      1/10            0

Complete la configuración asignando los mismos Valores de parámetro a cada precedencia. Utilice los valores obtenidos show queueing random-detect de la salida de comando para elegir los Valores de parámetro razonables.

interface FastEthernet1/0/0
 random-detect precedence 0 100 218 10
 random-detect precedence 1 100 218 10
 random-detect precedence 2 100 218 10
 random-detect precedence 3 100 218 10
 random-detect precedence 4 100 218 10
 random-detect precedence 5 100 218 10
 random-detect precedence 6 100 218 10
 random-detect precedence 7 100 218 10

Ejemplo: Configuración de parámetro WRED

El siguiente ejemplo habilita el WRED en la interfaz y especifica los parámetros para el diverso precedences IP:

interface Hssi0/0/0
 description 45Mbps to R1
 ip address 10.200.14.250 255.255.255.252
 random-detect
 random-detect precedence 0 32 256 100
 random-detect precedence 1 64 256 100
 random-detect precedence 2 96 256 100
 random-detect precedence 3 120 256 100
 random-detect precedence 4 140 256 100
 random-detect precedence 5 170 256 100
 random-detect precedence 6 290 256 100
 random-detect precedence 7 210 256 100
 random-detect precedence rsvp 230 256 100

Ejemplos de configuración DWRED

Ejemplo: DWRED en una interfaz

El siguiente ejemplo configura el DWRED en una interfaz con un factor de ponderación de 10:

Router(config)# interface hssi0/0/0
Router(config-if)# description 45mbps to R1
Router(config-if)# ip address 192.168.14.250 255.255.255.252
Router(config-if)# random-detect
Router(config-if)# random-detect exponential-weighting-constant 10

Ejemplo: Modular QoS CLI

El siguiente ejemplo habilita el DWRED usando la característica de la herencia CLI (QoS Command-Line Interface NON-modular) en la interfaz y especifica los parámetros para el diverso precedences IP:

interface Hssi0/0/0
 description 45Mbps to R1
 ip address 200.200.14.250 255.255.255.252
 random-detect
 random-detect precedence 0 32 256 100
 random-detect precedence 1 64 256 100
 random-detect precedence 2 96 256 100
 random-detect precedence 3 120 256 100
 random-detect precedence 4 140 256 100
 random-detect precedence 5 170 256 100
 random-detect precedence 6 290 256 100
 random-detect precedence 7 210 256 100
 random-detect precedence rsvp 230 256 100

El siguiente ejemplo utiliza el Modular QoS CLI para configurar una política de tráfico llamada policy10. Para la prevención de congestionamiento, se utiliza la caída de paquetes WRED, no eliminación de cola. La Prioridad IP se reajusta para los niveles 0 a 5.

policy-map policy10  
 class acl10 
 bandwidth 2000
 random-detect exponential-weighting-constant 10
 random-detect precedence 0 32 256 100
 random-detect precedence 1 64 256 100
 random-detect precedence 2 96 256 100
 random-detect precedence 3 120 256 100
 random-detect precedence 4 140 256 100
 random-detect precedence 5 170 256 100

Ejemplo: Configurar el DWRED en política de tráfico

El siguiente ejemplo configura la directiva para una clase de tráfico nombrada int10 para configurar el factor de ponderación exponencial como 12. Éste es el factor de ponderación usado para el cálculo de los tamaños promedios de la cola para la cola para la clase de tráfico int10. La caída de paquetes WRED se utiliza para la prevención de congestionamiento para la clase de tráfico int10, no eliminación de cola.

policy-map policy12  
 class int10 
 bandwidth 2000
 random-detect exponential-weighting-constant 12

Ejemplo de configuración del flujo basado WRED

El siguiente ejemplo habilita el WRED en la interfaz serial 1 y configura el flujo basado WRED. random-detect Utilizan al comando interface configuration de habilitar el WRED. Una vez que se habilita el WRED, random-detect flow se utiliza el comando de habilitar el flujo basado WRED.

Después de que se habilite el flujo basado WRED, random-detect flow average-depth-factor se utiliza el comando de fijar el factor de escala a 8 y random-detect flow count se utiliza el comando de fijar la cuenta del flujo a 16. El factor de escala se utiliza para escalar la cantidad de búfers disponible por el flujo y para determinar el número de paquetes permitidos en la cola de salida para cada flujo activo.

configure terminal
interface Serial1
 random-detect
 random-detect flow
 random-detect flow average-depth-factor 8
 random-detect flow count 16
end

La parte de siguiente el ejemplo muestra un ejemplo de archivo de configuración después de que se publiquen los comandos anteriores del flujo basado WRED:

Router# more system:running-config

Building configuration...
Current configuration:
!
version 12.0
service timestamps debug datetime msec localtime
service timestamps log uptime
no service password-encryption
service tcp-small-servers
!
no logging console
enable password lab
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no keepalive
 shutdown
!
interface Serial1
 ip address 190.1.2.1 255.255.255.0
 no ip directed-broadcast
 load-interval 30
 no keepalive
 random-detect
 random-detect flow
 random-detect flow count 16
 random-detect flow average-depth-factor 8
!
router igrp 8
 network 190.1.0.0
!
ip classless
no ip http server
!
line con 0
 transport input none
line 1 16
 transport input all
line aux 0
 transport input all
line vty 0 4
 password lab
 login
!
end

Ejemplos de configuración del DiffServ Compliant WRED

Ejemplo: WRED configurado para utilizar el valor DSCP

El siguiente ejemplo configura el WRED para utilizar el valor 8. DSCP. El umbral mínimo para el valor 8 DSCP es 24 y el umbral máximo es 40. Esta configuración fue realizada en el nivel de la interfaz.

Router(config-if)# interface seo/0
Router(config-if)# random-detect dscp-based
Router(config-if)# random-detect dscp 8 24 40

El siguiente ejemplo permite al WRED para utilizar el valor 9. DSCP. El umbral mínimo para el valor 9 DSCP es 20 y el umbral máximo es 50. Esta configuración se puede asociar al otro VCs, como sea necesario.

Router(config)# random-detect-group sanjose dscp-based
Router(cfg-red-grp)# dscp 9 20 50
Router(config-subif-vc)# random-detect attach sanjose

El siguiente ejemplo permite al WRED para utilizar el valor 8 DSCP para el c1 de la clase. El umbral mínimo para el valor 8 DSCP es 24 y el umbral máximo es 40. La línea más reciente asocia la política de tráfico a la interfaz de salida o al p1 del VC.

Router(config-if)# class-map c1
Router(config-cmap)# match access-group 101
Router(config-if)# policy-map p1
Router(config-pmap)# class c1
Router(config-pmap-c)# bandwidth 48
Router(config-pmap-c)# random-detect dscp-based
Router(config-pmap-c)# random-detect dscp 8 24 40
Router(config-if)# service-policy output p1

Ejemplo: Verificación de la configuración del valor DSCP

Cuando el WRED se ha configurado para utilizar el valor DSCP cuando calcula la probabilidad de caída de un paquete, todas las entradas de la tabla DSCP se inicializan con los valores predeterminados apropiados. El ejemplo en la sección siguiente es muestras show policy interface del comando para el WRED en el nivel de clase.

Este ejemplo visualiza las estadísticas de paquete junto con las entradas de la tabla DSCP, confirmando que el WRED se ha habilitado para utilizar el valor DSCP cuando calcula la probabilidad de caída para un paquete.

Router# show policy interface Serial6/3 

 Serial6/3 

  Service-policy output: test

    Class-map: c1 (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol ip
        0 packets, 0 bytes
        5 minute rate 0 bps
      Weighted Fair Queueing
        Output Queue: Conversation 265 
        Bandwidth 20 (%)
        Bandwidth 308 (kbps)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
         exponential weight: 9
         mean queue depth: 0

dscp     Transmitted       Random drop      Tail drop    Minimum Maximum  Mark
          pkts/bytes        pkts/bytes       pkts/bytes    thresh  thresh  prob
af11          0/0               0/0              0/0           32      40  1/10
af12          0/0               0/0              0/0           28      40  1/10
af13          0/0               0/0              0/0           24      40  1/10
af21          0/0               0/0              0/0           32      40  1/10
af22          0/0               0/0              0/0           28      40  1/10
af23          0/0               0/0              0/0           24      40  1/10
af31          0/0               0/0              0/0           32      40  1/10
af32          0/0               0/0              0/0           28      40  1/10
af33          0/0               0/0              0/0           24      40  1/10
af41          0/0               0/0              0/0           32      40  1/10
af42          0/0               0/0              0/0           28      40  1/10
af43          0/0               0/0              0/0           24      40  1/10
cs1           0/0               0/0              0/0           22      40  1/10
cs2           0/0               0/0              0/0           24      40  1/10
cs3           0/0               0/0              0/0           26      40  1/10
cs4           0/0               0/0              0/0           28      40  1/10
cs5           0/0               0/0              0/0           30      40  1/10
cs6           0/0               0/0              0/0           32      40  1/10
cs7           0/0               0/0              0/0           34      40  1/10
ef            0/0               0/0              0/0           36      40  1/10
rsvp          0/0               0/0              0/0           36      40  1/10
default       0/0               0/0              0/0           20      40  1/10