Guía de Configuración de Soluciones de Calidad de Servicio de Cisco IOS, versión 12.2SR
Low Latency Queueing (LLQ) for IPsec Encryption Engines
21 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 202 KB | Inglés (17 Marzo 2008) | Comentarios

Contenidos

Low Latency Queueing (LLQ) for IPsec Encryption Engines

Descripción general de características

Beneficios

Restricciones

Características y Tecnologías relacionadas

Documentos Relacionados

Plataformas Soportadas

Determinar el Soporte de la plataforma con el Cisco Feature Navigator

Disponibilidad de las imágenes del Cisco IOS Software

Estándares, MIB, y RFC soportados

Prerrequisitos

Tareas de Configuración

Definición de las correspondencias de la clase

Configurar la política de clase en la correspondencia de políticas

Configurar la política de clase para un priority queue

Configurar la política de clase usando un ancho de banda especificado

Configurar la directiva del clase class-default

Asociar la política de servicio

Verificar la configuración de las correspondencias de políticas y de sus clases

Monitoreo y Mantenimiento de LLQ para Motores de Encripción IPSec

Ejemplos de Configuración

Ejemplo: LLQ para los motores de la encripción de IPSec

Referencia de Comandos


Low Latency Queueing (LLQ) for IPsec Encryption Engines


Historial de la característica

Versión
Modificación

12.2(13)T

Esta función fue introducida.

12.2(14)S

Esta función se integró en Cisco IOS Release 12.2(14)S.


Este módulo de función describe el low latency queueing (LLQ) para la característica de los motores de la encripción de IPSec en el Cisco IOS Release 12.2(13)T y 12.2(14)S. Incluye las secciones siguientes:

Descripción general de características

Plataformas Soportadas

Estándares, MIB, y RFC soportados

Prerrequisitos

Tareas de Configuración

Monitoreo y Mantenimiento de LLQ para Motores de Encripción IPSec

Ejemplos de Configuración

Referencia de Comandos

Descripción general de características

El low latency queueing (LLQ) para las ayudas de los motores de la encripción de IPSec reduce la latencia del paquete introduciendo el concepto de espera antes de los motores de criptografía. Antes de esto, el motor de procesamiento crypto dio el tráfico de datos y el tráfico de voz estatus igual. Los administradores ahora señalan el tráfico de voz como prioridad. Los paquetes de datos que llegan una interfaz del router se dirigen en una cola entrante del paquete de datos para el proceso del motor de criptografía. Esta cola se llama la mejor cola de esfuerzo. Los paquetes de voz que llegan en una interfaz del router se dirigen en una cola entrante del paquete prioritario para el proceso del motor de criptografía. Esta cola se llama el priority queue. El motor de criptografía emprende el paquete que procesa en una relación de transformación favorable para los paquetes de voz. Los paquetes de voz se garantizan un ancho de banda de proceso mínimo en el motor de criptografía.

Beneficios

El low latency queueing (LLQ) para la característica de los motores de la encripción de IPSec garantiza cierto nivel de tiempo de procesamiento del motor de criptografía para el tráfico señalado prioridad.


Observeen la plataforma del Cisco 2600, a excepción del Cisco 2691 Router, la utilización de la CPU maximiza hacia fuera antes de que el motor de criptografía se congestione, así que el tiempo de espera no se mejora.


Un mejor funcionamiento de la Voz

Los paquetes de voz se pueden identificar como prioridad, permitiendo que el motor de criptografía garantice cierto porcentaje de procesar el ancho de banda. Esta característica afecta la experiencia del usuario final asegurando la Calidad de voz si el tráfico de voz se dirige sobre una red congestionada.

Tiempo de espera y jitteres mejorados

La previsibilidad es un componente crítico del rendimiento de la red. El low latency queueing (LLQ) para la característica de los motores de la encripción de IPSec entrega la previsibilidad del tráfico de la red referente al VPN. Con esta característica inhabilitada, un usuario final que empleaba un teléfono del IP sobre el VPN pudo experimentar el jitter o tiempo de espera, ambos síntomas de la latencia de red total y congestión. Con esta característica habilitada, se disipan estas características indeseables.

Restricciones

Ningún por-túnel política de calidad de servicio (QoS). Una interfaz política de calidad de servicio (QoS) representa todos los túneles.

Asuma la misma marca IP precedence/DSCP para los paquetes de voz entrantes y salientes.

Asuma que la marca IP precedence/DSCP para los paquetes de voz está hecha en la fuente.

Criterios de concordancia limitados para el tráfico de voz en la interfaz política de calidad de servicio (QoS).

Asuma que el control de admisión de llamadas está aplicado dentro de la empresa.

Ninguna verificación de errores estricta cuando el ancho de banda de la directiva global excede el ancho de banda del motor de criptografía. Solamente se visualiza una advertencia pero se permite la configuración.

Asuma que los paquetes de voz son cifrados todo o unencrypted.

Características y Tecnologías relacionadas

CBWFQ

Espera de la prioridad

Espera cargada de la feria

Documentos Relacionados

Referencia de comandos de la solución de calidad de servicio

“Configurando el módulo de espera cargado de la feria”

Plataformas Soportadas

12.2(14)S y versiones posteriores

El LLQ para la característica de los motores de la encripción de IPSec se soporta en la plataforma siguiente:

Cisco 7200 Series

12.2(13)T

El LLQ para la característica de los motores de la encripción de IPSec se soporta en todas las Plataformas usando el Cisco IOS Release 12.2(13)T o Posterior, incluyendo:

Cisco 2600 Series

Cisco 3600 Series

Cisco 7100 Series

Cisco 7200 Series

Determinar el Soporte de la plataforma con el Cisco Feature Navigator

Cisco IOS Software se suministra en conjuntos de funciones soportadas por plataformas específicas. Para conseguir información actualizada relativa al soporte de plataformas de esta función, acceda a Cisco Feature Navigator. Cisco Feature Navigator actualiza dinámicamente la lista de plataformas soportadas a medida que se añade soporte para nuevas plataformas.

Cisco Feature Navigator es una herramienta basada en web que le permite determinar rápidamente qué imágenes del software de Cisco IOS soportan un determinado conjunto de funciones y qué funciones soporta una determinada imagen de Cisco IOS. Puede buscar por función o por versión. Bajo sección de la versión, usted puede comparar las versiones de lado a lado para visualizar las características únicas a cada versión de software y las características en el campo común.

Para acceder a Cisco Feature Navigator, debe tener una cuenta en Cisco.com. Si ha olvidado o perdido la información de su cuenta, envíe un correo electrónico en blanco a cco-locksmith@cisco.com. Una comprobación automática verificará que tu dirección de correo electrónico esté registrada en Cisco.com. Si la verificación es exitosa, recibirá por email los detalles de la cuenta con una nueva contraseña aleatoria. Los usuarios cualificados pueden configurar una cuenta en Cisco.com siguiendo las instrucciones especificadas en esta URL:

http://www.cisco.com/cisco/web/LA/support/index.html

Cisco Feature Navigator se actualiza regularmente cuando se publican versiones importantes de la tecnología y el software de Cisco IOS. Para acceder a la información más actualizada, vaya a la página de inicio de Cisco Feature Navigator en la URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

Disponibilidad de las imágenes del Cisco IOS Software

El soporte de plataformas de una versión de software de Cisco IOS particular depende de la disponibilidad de las imágenes de software de dichas plataformas. Las imágenes de software para algunas plataformas se pueden diferir, demorar o cambiar sin previo aviso. Para información actualizada sobre el Soporte de la plataforma y la Disponibilidad de las imágenes del software para cada versión de Cisco IOS Software, vea los Release Note en línea o, si está soportado, el Cisco Feature Navigator.

Estándares, MIB, y RFC soportados

Estándares

Esta función no soporta estándares nuevos o modificados.

MIB

Esta función no soporta estándares nuevos o modificados.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

Si Cisco MIB Locator no soporta la información MIB que necesita, también puede obtener una lista de MIB soportadas y descargar MIB de la página de MIB de Cisco en la siguiente URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Para acceder a Cisco MIB Locator, debe tener una cuenta en Cisco.com. Si ha olvidado o perdido la información de su cuenta, envíe un correo electrónico en blanco a cco-locksmith@cisco.com. Una comprobación automática verificará que tu dirección de correo electrónico esté registrada en Cisco.com. Si la verificación es exitosa, recibirá por email los detalles de la cuenta con una nueva contraseña aleatoria. Los usuarios cualificados pueden configurar una cuenta en Cisco.com siguiendo las instrucciones especificadas en esta URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

Esta función no soporta RFCs nuevos o modificados.

Prerrequisitos

Para utilizar esta característica, usted debe ser familiar con el siguiente:

Listas de control de acceso

Administración del ancho de banda

CBWFQ

Tareas de Configuración

Definición de las correspondencias de la clase

 
Comando
Propósito

Paso 1 

Router(config)# class-map class-map-name

Especifica el nombre de la correspondencia de la clase que se creará.

Paso 2 

Router(config-cmap)# match access-group {access-group | name access-group-name}


or


Router(config-cmap)# match input-interface interface-name


or


Router(config-cmap)# match protocol protocol

Especifica el nombre del Access Control List (ACL) contra cuyo contenido los paquetes se marcan para determinar si pertenecen a la clase.


Especifica el nombre de la interfaz de entrada usada como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Especifica el nombre del protocolo usado como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Configurar la política de clase en la correspondencia de políticas

Para configurar una correspondencia de políticas y crear las políticas de clase que componen la política de servicio, comience con policy-map el comando de especificar el nombre de correspondencia de políticas. Entonces utilice uno o más de los siguientes comandos de configurar la directiva para una clase estándar o la clase predeterminada:

priority

bandwidth

queue-limit o random-detect

fair-queue (para el clase class-default solamente)

Para cada clase que usted defina, usted puede utilizar uno o más de los comandos enumerados para configurar la política de clase. Por ejemplo, usted puede ser que especifique el ancho de banda para una clase y ancho de banda y límite de cola para otra clase.

La clase predeterminada de la correspondencia de políticas (conocida comúnmente como el clase class-default) es la clase a la cual se dirige el tráfico si ese tráfico no satisface los criterios de concordancia de las otras clases definidas en la correspondencia de políticas.

Usted puede configurar las políticas de clase para tantas clases como se definen en el router, hasta el máximo de 64. Sin embargo, la cantidad total de ancho de banda afectada un aparato para todas las clases en una correspondencia de políticas no debe exceder la velocidad de información comprometida mínima (CIR) configurada para el virtual circuit (VC) menos ningún ancho de banda reservado por frame-relay voice bandwidth y frame-relay ip rtp priority los comandos. Si el CIR mínimo no se configura, el ancho de banda omite una mitad del CIR. Si todo el ancho de banda no se afecta un aparato, el ancho de banda restante se afecta un aparato proporcional entre las clases en base de su configuré el ancho de banda.

Para configurar las políticas de clase en una correspondencia de políticas, realice las tareas descritas en las secciones siguientes. La tarea en la primera sección se requiere; las tareas de las secciones restantes son opcionales.

Configurar la política de clase para un priority queue

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-cmap)# class class-name

Especifica el nombre de una clase que se creará e incluirá en la política de servicio.

Paso 3 

Router(config-pmap-c)# priority bandwidth-kbps

Crea una clase de prioridad estricta y especifica la cantidad de ancho de banda, en kbps, que se debe asignar a la clase.

Configurar la política de clase usando un ancho de banda especificado

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-cmap)# class class-name

Especifica el nombre de una clase que se creará e incluirá en la política de servicio.

Paso 3 

Router(config-pmap-c)# bandwidth bandwidth-kbps

Especifica la cantidad de ancho de banda que se asignará a la clase, en kbps, o como un porcentaje del ancho de banda disponible. El ancho de banda se debe especificar en kbps o como porcentaje sistemáticamente en todas las clases. (El ancho de banda de la cola prioritaria se debe especificar en kbps.)

Configurar la directiva del clase class-default

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-cmap)# class class-default default-class-name

Especifica la clase predeterminada para que se pueda configurar o modificar su política.

Observeel clase class-default se utiliza para clasificar el tráfico que no baja en una de las clases definidas. Aunque la clase class-default se predefine al crear el policy map, sigue siendo necesario configurarla. Si una clase predeterminada no se configura, después el tráfico que no hace juego las clases configuradas unas de los se da el tratamiento del mejor esfuerzo, así que lo significa que la red entregará el tráfico si puede, sin ninguna garantía de la confiabilidad, prevención del retardo, o la producción.

Paso 3 

Router(config-pmap-c)# bandwidth bandwidth-kbps


or


Router(config-pmap-c)# fair-queue [number-of-dynamic-queues]

Especifica la cantidad de ancho de banda, en el kbps, para ser asignado a la clase.


Especifica la Cantidad de colas dinámicas que se reservará para uso del flujo basado WFQ que se ejecuta en la clase predeterminada. La Cantidad de colas dinámicas se deriva del ancho de banda de la interfaz.

Asociar la política de servicio

 
Comando
Propósito

Paso 1 

Router(config)# interface type number

Especifica la interfaz usando el LLQ para los motores de la encripción de IPSec.

Paso 2 

Router(config-if)# service-policy output policy-map

Asocia la correlación de políticas de servicio especificada a la interfaz de salida y habilita el LLQ para los motores de la encripción de IPSec.

Verificar la configuración de las correspondencias de políticas y de sus clases

 
Comando
Propósito

Paso 1 

Router# show frame-relay pvc dlci

Estadísticas de las visualizaciones sobre el PVC y la configuración de las clases para la correspondencia de políticas en el identificador de conexión de link de datos especificado (DLCI).

Paso 2 

Router# show policy-map interface interface-name

Cuando se configura el LLQ, visualiza la configuración de las clases para todas las correspondencias de políticas.

Paso 3 

Router# show policy-map interface interface-name dlci dlci

Cuando se configura el LLQ, visualiza la configuración de las clases para la correspondencia de políticas en el DLCI especificado.

Monitoreo y Mantenimiento de LLQ para Motores de Encripción IPSec

 
Comando
Propósito

Paso 1 

Router# show crypto eng qos

Visualiza las estadísticas de espera de la calidad de servicio para el LLQ para los motores de la encripción de IPSec.

Ejemplos de Configuración

Ejemplo: LLQ para los motores de la encripción de IPSec

En el siguiente ejemplo, una cola de prioridad estricta con un ancho de banda permitido garantizado de 50 kbps es reservada para el tráfico que se envía de la dirección de origen 10.10.10.10 a la dirección destino 10.10.10.20, en el rango de los puertos 16384 a 20000 y 53000 a 56000.

Primero, los siguientes comandos configuran la lista de acceso 102 para hacer juego el tráfico de voz deseado:

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 
20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 
56000

Después, se define la Voz de la correspondencia de la clase, y se crea la correspondencia de políticas llamó policy1; una cola de prioridad estricta para la Voz de la clase es reservada, un ancho de banda de 20 kbps se configura para la clase BAR, y la clase predeterminada se configura para el WFQ. El comando service-policy entonces asocia la correspondencia de políticas al fas0/0.


Router(config)# class-map voice
Router(config-cmap)# match access-group 102
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue
Router(config)# interface fastethernet0/0
Router(config-if)# service-policy output policy1

Referencia de Comandos

Los siguientes comandos se introducen o se modifican en la característica o las características documentadas en este módulo. Para la información sobre estos comandos, vea Cisco IOS Quality of Service Solutions Command Reference en http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_book.html. Para la información sobre todos los comandos cisco ios, vaya a la herramienta de búsqueda de comandos en http://tools.cisco.com/Support/CLILookup o al Cisco IOS Master Commands List.

show crypto eng qos