Guía de Configuración de Soluciones de Calidad de Servicio de Cisco IOS, versión 12.2SR
Configuración de Weighted Fair Queueing
21 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 309 KB | Inglés (30 Enero 2008) | Comentarios

Contenidos

Configuración de Weighted Fair Queueing

Lista de tareas de configuración de espera cargada flujo basado de la feria

Configurar el WFQ

Monitorear la espera de la feria

Lista de tareas de configuración de espera cargada distribuida de la feria

Configurar el flujo basado DWFQ

Configurar el DWFQ QoS-Grupo-basado

Configurar el tipo de DWFQ basado en el servicio

Monitorear el DWFQ

Lista de tareas de configuración del Class-Based Weighted Fair Queueing

Definición de las correspondencias de la clase

Configurar la política de clase en la correspondencia de políticas

Configurar la política de clase usando la eliminación de cola

Configurar la política de clase usando la caída de paquetes WRED

Configurar la directiva del clase class-default

Asociando la política de servicio y habilitar el CBWFQ

Modificación del ancho de banda para un map class de la política existente

Modificación del límite de cola para un map class de la política existente

Borrar las correspondencias de la clase de las correspondencias de la política de servicio

Borrar las correspondencias de políticas

Verificar la configuración de las correspondencias de políticas y de sus clases

Lista de tareas de configuración distribuida del Class-Based Weighted Fair Queueing

Modificación del ancho de banda para una clase de tráfico existente

Modificación del límite de cola para una clase de tráfico existente

Monitoreando y mantener el DCBWFQ

Lista de tareas de configuración de la prioridad de IP RTP

Configurar la prioridad de IP RTP

Verificar la prioridad de IP RTP

Monitoreando y mantener la prioridad de IP RTP

Lista de tareas de configuración de la Prioridad de IP RTP en Frame Relay

Configurar la Prioridad de IP RTP en Frame Relay

Verificar la Prioridad de IP RTP en Frame Relay

Monitoreo y Mantenimiento de Frame Relay IP RTP Priority

Lista de tareas para configurar la interfaz PVC de Frame Relay

Configurar la prioridad del PVC en un map class

Habilitando el Frame Relay PIPQ y establecer los límites de cola

Asignación de un map class a un PVC

Verificar el Frame Relay PIPQ

Monitoreando y mantener el Frame Relay PIPQ

Lista de tareas de configuración del low latency queueing

Configurar el LLQ

Verificar el LLQ

Monitoreando y mantener el LLQ

Lista de tareas distribuida de la configuración de LLQ

Configurar un priority queue para una cantidad de ancho de banda disponible

Configurar un priority queue para un porcentaje del ancho de banda disponible

Configurar un límite del anillo de la transmisión en una atmósfera PVC

Configurar un límite del anillo de la transmisión en una subinterfaz ATM

Verificar el LLQ distribuido

Verificar un límite del anillo de la transmisión

Monitoreando y mantener el LLQ distribuido

Lista de tareas de configuración del Procesamiento de baja latencia de datos prioritarios en espera para Frame Relay

Definición de las correspondencias de la clase

Configurar la política de clase en la correspondencia de políticas

Configurar la política de clase para un priority queue LLQ

Configurar la política de clase usando un ancho de banda especificado y la caída de paquetes WRED

Configurar la directiva del clase class-default

Asociando la política de servicio y habilitar el LLQ para el Frame Relay

Verificar la configuración de las correspondencias de políticas y de sus clases

Monitoreando y mantener el LLQ para el Frame Relay

Configurar los tamaños de ráfaga en la lista de tareas de la configuración de LLQ

Configurar el ancho de banda LLQ

Configurar los tamaños de ráfaga LLQ

Verificar los tamaños de ráfaga LLQ

Soporte de la cola de espera por VC para la lista de tareas de configuración de los adaptadores ATM

Configurar la cola de espera por VC en un adaptador ATM

Verificar la configuración de la cola de espera por VC en un adaptador ATM

Ejemplos: Configuración del flujo basado WFQ

Ejemplos: Configuración DWFQ

Ejemplo: Flujo basado DWFQ

Ejemplo: DWFQ QoS-Grupo-basado

Ejemplo: DWFQ basado en TOS

Ejemplos: Configuración CBWFQ

Ejemplo: Configuración de asignación de la clase

Ejemplo: Creación de la directiva

Ejemplo: Conexión de la directiva a las interfaces

Ejemplo: CBWFQ usando la caída de paquetes WRED

Ejemplos: Contenido del mapa de la política de servicio de la visualización

Todas las clases para una correlación de políticas de servicio especificada

Todas las clases para todas las correspondencias de la política de servicio

Clase especificada para un mapa de la política de servicio

Todas las clases para todas las correspondencias de la política de servicio en una interfaz especificada

Ejemplos: Configuración distribuida CBWFQ

Ejemplo: Configuración de la clase de tráfico

Ejemplo: Creación de la política de tráfico

Ejemplo: Conexión de la política de tráfico a una interfaz

Ejemplos: Configuración de la prioridad de IP RTP

Ejemplo: Configuración CBWFQ

Ejemplo: Configuración de plantilla virtual

Ejemplo: Configuración del agrupamiento de links múltiples

Ejemplo: Depurar

Ejemplos: Configuración de la Prioridad de IP RTP en Frame Relay

Ejemplo: Servicio de prioridad estricta a los paquetes RTP que corresponden con

Ejemplos: Configuración de la interfaz PQ del PVC de Frame Relay

Ejemplos: Configuración de LLQ

Ejemplo: Configuración de PVC atmósfera

Ejemplo: Configuración de plantilla virtual

Ejemplo: Configuración del agrupamiento de links múltiples

Ejemplos: Configuración de LLQ distribuida

Ejemplo: Habilitar el PQ para una cantidad de ancho de banda disponible en una subinterfaz ATM

Ejemplo: Habilitar el PQ para un porcentaje del ancho de banda disponible en una subinterfaz ATM

Ejemplo: Limitación del límite del anillo de la transmisión en una interfaz ATM

Ejemplo: Limitación del límite del anillo de la transmisión en una subinterfaz atmósfera PVC

Ejemplos: LLQ para la configuración de Frame Relay

Ejemplos: Tamaños de ráfaga en configuración de LLQ

Ejemplos: Soporte de la cola de espera por VC para los adaptadores ATM


Configuración de Weighted Fair Queueing


Historial de la característica

Versión
Modificación

IOS de Cisco

Para obtener información sobre el soporte de funciones de Cisco IOS Software, utilice Cisco Feature Navigator.


Este módulo describe las tareas para configurar la espera cargada flujo basado de la feria (WFQ), WFQ distribuido (DWFQ), y el Class-Based WFQ (CBWFQ), y Class-Based WFQ distribuido (DCBWFQ) y las características relacionadas descritas en la sección siguiente, que proporcionan la prioridad estricta que hace cola (PQ) dentro del WFQ o del CBWFQ:

IP RTP Priority Queueing

Espera de la Prioridad de IP RTP en Frame Relay

Frame Relay PVC Interface Priority Queueing

Cola de tiempo de latencia bajo

Low latency queueing distribuido

Low latency queueing (LLQ) para el Frame Relay

Tamaños de ráfaga en el low latency queueing

Soporte de la cola de espera por VC para los adaptadores ATM

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Lista de tareas de configuración de espera cargada flujo basado de la feria

El WFQ proporciona la Administración de la prioridad de tráfico esa automáticamente las clases entre las secuencias del tráfico individual sin requerir que usted primero define las Listas de acceso. El WFQ puede también manejar las secuencias de datos dúplexes tales como ésos entre los pares de aplicaciones, y los datos simples fluyen por ejemplo la Voz o el vídeo. Hay dos categorías de sesiones WFQ: ancho de banda alto y ancho de banda baja. El tráfico del ancho de banda baja tiene prioridad eficaz sobre el tráfico de ancho de banda alto, y el tráfico de ancho de banda alto comparte el servicio de transmisión proporcional según los pesos asociados.

Cuando el WFQ se habilita para una interfaz, los nuevos mensajes para las secuencias del tráfico de ancho de banda alto se desechan después de que se haya resuelto el umbral congestivo configurado o predeterminado de los mensajes. Sin embargo, las conversaciones del ancho de banda baja, que incluyen las conversaciones de mensaje de control, continúan enviando a la cola los datos. Como consecuencia, la cola justa puede contener de vez en cuando más mensajes que su número del umbral configurado especifica.

Con el WFQ estándar, los paquetes son clasificados por el flujo. Los paquetes con la misma dirección IP de origen, IP Address de destino, fuente TCP o puerto del User Datagram Protocol (UDP), o TCP de destino o puerto UDP pertenecen al mismo flujo. El WFQ afecta un aparato una parte igual del ancho de banda a cada flujo. El flujo basado WFQ también se llama feria que hace cola porque todos los flujos se cargan igualmente.

El Cisco IOS Software proporciona dos formas del flujo basado WFQ:

El WFQ estándar, que se habilita por abandono en todas las interfaces seriales que se ejecuten en el 2 Mbps o abajo, y puede ejecutarse en todas las interfaces seriales de Cisco.

WFQ distribuido, que se ejecuta solamente en los Cisco 7000 Series Router con un Route Switch Processor (RSP) - el procesador de interfaz RSP7000 o los Cisco 7500 Series Router basados con un Versatile Interface Processor (VIP) - VIP2-40 basado o mayor procesador de interfaz. (Procesador de interfaz Al VIP2-50 se recomienda fuertemente cuando la línea global tarifa de los adaptadores de puerto en el VIP es mayor que el DS3. Un procesador de interfaz VIP2-50 se requiere para las tarifas OC-3.).

El flujo basado WFQ utiliza un servicio del registro de la discriminación de la secuencia de los datos del tráfico para determinar a qué flujo de tráfico pertenece un mensaje. Refiera a la tabla que acompaña la descripción fair-queue del comando (WFQ) en la referencia del comando solutions de la Calidad de servicio de Cisco IOS para los atributos de un mensaje que se utilizan para clasificar el tráfico en las secuencias de datos.

Los valores por defecto se proporcionan para el umbral de congestión después de lo cual los mensajes para las conversaciones del ancho de banda alto se caen, y para el número de colas de administración del tráfico dinámicas y reservable; sin embargo, usted puede ajustar su operación de la red cambiando estos valores por defecto. Refiera a las tablas que acompañan la descripción fair-queue del comando (WFQ) en la referencia del comando solutions de la Calidad de servicio de Cisco IOS para el número predeterminado de colas dinámicas que el WFQ y el CBWFQ utilicen cuando se habilitan en una interfaz o el VC atmósfera. Estos valores no solicitan el DWFQ.


La notaWFQ es el modo de espera predeterminado en las interfaces que se ejecutan en las velocidades del e1 (2.048 Mbps) o abajo. Se habilita por abandono para las interfaces físicas que no utilizan las encapsulaciones del link de Proceso de Acceso a link Balanceado (LAPB), X.25, o del Synchronous Data Link Control (SDLC). El WFQ no es una opción para estos protocolos. El WFQ también se habilita por abandono en las interfaces configuradas para el Multilink PPP (MLP). Sin embargo, si la Asignación personalizada de colas o el Asignación de colas de prioridad (PQ) se habilita para un link de calificación, reemplaza la espera de la feria, inhabilitandolo con eficacia. Además, el WFQ se inhabilita automáticamente si usted habilita autónomo o el Silicon Switching.


Si usted habilita el flujo basado DWFQ y después habilita el DWFQ basado en la clase (QoS-grupo basado o basado en TOS), el DWFQ basado en la clase substituirá el flujo basado DWFQ.

Si usted habilita el DWFQ basado en la clase y después quiere conmutar al flujo basado DWFQ, usted debe inhabilitar el DWFQ basado en la clase usando no fair-queue class-based el comando antes de habilitar el flujo basado DWFQ.

Si usted habilita un tipo de DWFQ basado en la clase y después habilita el otro tipo, el segundo tipo substituirá el primer.

El DWFQ se ejecuta solamente en los Cisco 7000 Series Router con un procesador de interfaz RSP basado RSP7000 o los Cisco 7500 Series Router con un VIP2-40 VIP basado o un mayor procesador de interfaz. (Procesador de interfaz Al VIP2-50 se recomienda fuertemente cuando la línea global tarifa de los adaptadores de puerto en el VIP es mayor que el DS3. Un procesador de interfaz VIP2-50 se requiere para las tarifas OC-3.)

El DWFQ se puede configurar en las interfaces pero no las subinterfaces. No se soporta en el Fast EtherChannel, túnel, u otro lógico o interfaces virtuales tales como MLP.

Para el flujo basado DWFQ, los paquetes son clasificados por el flujo. Los paquetes con la misma dirección IP de origen, IP Address de destino, fuente TCP o puerto UDP, TCP de destino o puerto UDP, y protocolo pertenecen al mismo flujo.

Para configurar el flujo basado WFQ, realice las tareas descritas en las secciones siguientes.

Configurando el WFQ (requerido)

Monitoreando la espera de la feria (opcional)

El flujo basado WFQ se soporta en la velocidad de bits inasequible (UBR), el Velocidad de bits variable (VBR), y Velocidad de bits disponible (ABR) las conexiones ATM.

Configurar el WFQ

Comando
Propósito

Router(config-if)# fair-queue [congestive-discard-threshold [dynamic-queues [reservable-queues]]]

Configura una interfaz para utilizar el WFQ.


Monitorear la espera de la feria

Comando
Propósito

Router# show interfaces [interface]

Visualiza el específico de la información estadística a una interfaz.

Router# show queue interface-type interface-number

Visualiza el contenido de los paquetes dentro de una cola para una interfaz particular o el virtual circuit (VC).

Router# show queueing fair

Visualiza el estatus de la configuración de espera justa.


Lista de tareas de configuración de espera cargada distribuida de la feria

Para configurar el DWFQ, realice una mutuamente - de las tareas exclusivas descritas en las secciones siguientes:

Configurar el flujo basado DWFQ

Configurar el DWFQ QoS-Grupo-basado

Configurar el tipo de DWFQ basado en el servicio

Monitoreando el DWFQ (opcional)

Configurar el flujo basado DWFQ

 
Comando
Propósito

Paso 1 

Router(config-if)# fair-queue

Habilita el flujo basado DWFQ.

Paso 2 

Router(config-if)# fair-queue aggregate-limit aggregate-packet

(Opcional) fija el número total de paquetes mitigados antes de que algunos paquetes puedan ser caídos. Debajo de este límite, los paquetes no serán caídos.

Notausted no debe cambiar generalmente el agregado, el individuo, o el valor límite de la clase del valor por defecto. Utilice fair-queue aggregate-limit fair-queue individual-limit, y fair-queue limit los comandos solamente si usted ha determinado que usted se beneficiaría de usar diversos valores, sobre la base de su situación determinada.

Paso 3 

Router(config-if)# fair-queue individual-limit individual-packet

(Opcional) fija los tamaños máximos de cola para las colas de administración del tráfico individuales del por-flujo durante los períodos de congestión.

Configurar el DWFQ QoS-Grupo-basado

 
Comando
Propósito

Paso 1 

Router(config-if)# fair-queue qos-group

Los permisos QoS-grupo-basaron el DWFQ.

Paso 2 

Router(config-if)# fair-queue qos-group number weight weight

Para cada grupo de QoS, especifica el porcentaje del ancho de banda que se afectará un aparato a cada clase.

Paso 3 

Router(config-if)# fair-queue aggregate-limit aggregate-packet

(Opcional) fija el número total de paquetes mitigados antes de que algunos paquetes puedan ser caídos. Debajo de este límite, los paquetes no serán caídos.

Notausted no debe cambiar generalmente el agregado, el individuo, o el valor límite de la clase del valor por defecto. Utilice fair-queue aggregate-limit fair-queue individual-limit, y fair-queue limit los comandos solamente si usted ha determinado que usted se beneficiaría de usar diversos valores, sobre la base de su situación determinada.

Paso 4 

Router(config-if)# fair-queue individual-limit individual-packet

(Opcional) fija los tamaños máximos de cola para cada cola del por-flujo durante los períodos de congestión.

Paso 5 

Router(config-if)# fair-queue qos-group number limit class-packet

(Opcional) fija los tamaños máximos de cola para una cola específica del grupo de QoS durante los períodos de congestión.

Configurar el tipo de DWFQ basado en el servicio

 
Comando
Propósito

Paso 1 

Router(config-if)# fair-queue tos

Permisos DWFQ basado en TOS

Paso 2 

Router(config-if)# fair-queue tos number weight weight

(Opcional) para cada clase TOS, especifica el porcentaje del ancho de banda que se afectará un aparato a cada clase.

Paso 3 

Router(config-if)# fair-queue aggregate-limit aggregate-packet

(Opcional) fija el número total de paquetes mitigados antes de que algunos paquetes puedan ser caídos. Debajo de este límite, los paquetes no serán caídos.

Notausted no debe cambiar generalmente el agregado, el individuo, o el valor límite de la clase del valor por defecto. Utilice fair-queue aggregate-limit fair-queue individual-limit, y fair-queue limit los comandos solamente si usted ha determinado que usted se beneficiaría de usar diversos valores, sobre la base de su situación determinada.

Paso 4 

Router(config-if)# fair-queue individual-limit individual-packet

(Opcional) fija los tamaños máximos de cola para cada cola del por-flujo durante los períodos de congestión.

Paso 5 

Router(config-if)# fair-queue tos number limit class-packet

(Opcional) fija los tamaños máximos de cola para una cola específica TOS durante los períodos de congestión.

Monitorear el DWFQ

Comando
Propósito

Router# show interfaces [interface]

Visualiza el específico de la información estadística a una interfaz.

Router# show queueing fair-queue

Visualiza el estatus de la configuración de espera justa.


Lista de tareas de configuración del Class-Based Weighted Fair Queueing

Para configurar el CBWFQ, realice las tareas descritas en las secciones siguientes.

Definiendo la clase asocia (requerido)

Configurando la política de clase en la correspondencia de políticas (requerida)

Asociando la política de servicio y habilitando el CBWFQ (requerido)

Modificando el ancho de banda para un map class de la política existente (opcional)

Modificando el límite de cola para un map class de la política existente (opcional)

Borrando las correspondencias de la clase de la política de servicio asocia (opcional)

Borrando las correspondencias de la clase de la política de servicio asocia (opcional)

Borrando las correspondencias de políticas (opcionales)

Verificando la configuración de las correspondencias de políticas y de sus clases (opcionales)

El CBWFQ se soporta en las conexiones ATM VBR y ABR. No se soporta en las conexiones UBR.

Definición de las correspondencias de la clase

 
Comando
Propósito

Paso 1 

Router(config)# class-map class-map-name

Especifica el nombre de la correspondencia de la clase que se creará.

Paso 2 

Router(config-cmap)# match access-group {access-group | name access-group-name}


o


Router(config-cmap)# match input-interface interface-name



o

Router(config-cmap)# match protocol protocol



o


Router(config-cmap)# match mpls experimental number

Especifica el nombre del Access Control List (ACL) contra cuyo contenido los paquetes se marcan para determinar si pertenecen a la clase. El CBWFQ soporta los ACL numerados y nombrados.

Especifica el nombre de la interfaz de entrada usada como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Especifica el nombre del protocolo usado como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Especifica el valor del campo EXP que se utilizará como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Observeotros criterios de concordancia puede ser utilizado al definir la clase asocia. Para los criterios de concordancia adicionales, vea “aplicando las características de QoS usando el módulo MQC”.

Configurar la política de clase en la correspondencia de políticas

Para configurar una correspondencia de políticas y crear las políticas de clase que componen la política de servicio, utilice policy-map el comando de especificar el nombre de correspondencia de políticas, después utilice uno o más de los siguientes comandos de configurar la directiva para una clase estándar o la clase predeterminada:

class

bandwidth (clase del directiva-mapa)

fair-queue (para el clase class-default solamente)

queue-limit o random-detect

Para cada clase que usted defina, usted puede utilizar uno o más de los comandos mencionados de configurar la política de clase. Por ejemplo, usted puede ser que especifique el ancho de banda para una clase y ancho de banda y límite de cola para otra clase.

La clase predeterminada de la correspondencia de políticas (conocida comúnmente como el clase class-default) es la clase a la cual se dirige el tráfico si ese tráfico no satisface los criterios de concordancia de otras clases cuya directiva se defina en la correspondencia de políticas.

Usted puede configurar las políticas de clase para tantas clases como se definen en el router, hasta el máximo de 64. Sin embargo, la cantidad total de ancho de banda afectada un aparato para toda clasifica incluido en una correspondencia de políticas no debe exceder el 75 por ciento del ancho de banda disponible en la interfaz. El otro 25 por ciento se utiliza para el tráfico del control y de la encaminamiento. (Para reemplazar la limitación del 75 por ciento, utilice max-reserved bandwidth el comando.) Si no se asigna todo el ancho de banda, la parte restante se asigna proporcionalmente entre las clases, según el ancho de banda que tienen configurado.

El clase class-default se utiliza para clasificar el tráfico que no baja en una de las clases definidas. Una vez que se clasifica un paquete, todos los mecanismos estándars que se pueden utilizar para distinguir el servicio entre las clases se aplican. El clase class-default fue predefinido cuando usted creó la correspondencia de políticas, pero usted debe configurarla. Si no se configura ninguna clase predeterminada, después por abandono el tráfico que no hace juego las clases configuradas unas de los es tratamiento clasificado y dado del flujo del mejor esfuerzo.

Para configurar las políticas de clase en una correspondencia de políticas, realice las tareas optativas descritas en las secciones siguientes. Si usted no realiza los pasos en estas secciones, se utilizan las acciones predeterminadas.

Configurando la política de clase usando la eliminación de cola (opcional)

Configurando la política de clase usando la caída de paquetes WRED (opcional)

Configurando la directiva del clase class-default (opcional)

Configurar la política de clase usando la eliminación de cola

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase que se creará e incluirá en la política de servicio.

Observepara configurar la directiva para más de una clase en la misma correspondencia de políticas, relanza el paso 2 al paso 4. Observe que porque este conjunto de comandos utiliza queue-limit el comando, la correspondencia de políticas utiliza la eliminación de cola, no caída de paquetes del Weighted Random Early Detection (WRED).

Paso 3 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percent}

Especifica la cantidad de ancho de banda, en el kbps, o el porcentaje del ancho de banda disponible, para ser asignado a la clase. La cantidad de ancho de banda configurada debe ser bastante grande también acomodar la capa 2 de arriba.

Paso 4 

Router(config-pmap-c)# queue-limit number-of-packets

Especifica la cantidad máxima de paquete que se puede hacer cola para la clase.

Configurar la política de clase usando la caída de paquetes WRED

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase que se creará e incluirá en la política de servicio.

Observepara configurar la directiva para más de una clase en la misma correspondencia de políticas, relanza el paso 2 al paso 5. Observe que este conjunto de comandos utiliza la caída de paquetes WRED, no eliminación de cola.

Paso 3 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percent}

Especifica la cantidad de ancho de banda, en el kbps, o el porcentaje del ancho de banda disponible que se asignará a la clase. La cantidad de ancho de banda configurada debe ser bastante grande también acomodar la capa 2 de arriba.

Paso 4 

Router(config-pmap-c)# random-detect

Permisos WRED. La política de clase caerá los paquetes usando el WRED en vez de la eliminación de cola.

Observesi usted configuran una clase en una correspondencia de políticas para utilizar el WRED para la caída de paquetes en vez de la eliminación de cola, usted debe asegurarse de que el WRED no esté configurado en la interfaz a la cual usted se prepone asociar esa política de servicio.

Paso 5 

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent


o


Router(config-pmap-c)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

Configura el factor de ponderación exponencial usado en el cálculo de la longitud de la cola promedio.

Parámetros WRED de las configuraciones para los paquetes con una Prioridad IP específica. Relance este comando para cada precedencia.

Configurar la directiva del clase class-default

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-default default-class-name

Especifica la clase predeterminada para que se pueda configurar o modificar su política.

Paso 3 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percent}



o


Router(config-pmap-c)# fair-queue [number-of-dynamic-queues]

Especifica la cantidad de ancho de banda, en el kbps, o el porcentaje del ancho de banda disponible que se asignará a la clase. La cantidad de ancho de banda configurada debe ser bastante grande también acomodar la capa 2 de arriba.

Especifica la Cantidad de colas dinámicas que se reservará para uso del flujo basado WFQ que se ejecuta en la clase predeterminada. La Cantidad de colas dinámicas se deriva del ancho de banda de la interfaz. Refiera a las tablas que acompañan la descripción fair-queue del comando (WFQ) en la referencia del comando solutions de la Calidad de servicio de Cisco IOS para el número predeterminado de colas dinámicas que el WFQ y el CBWFQ utilicen cuando se habilitan en una interfaz o el VC atmósfera.

Paso 4 

Router(config-pmap-c)# queue-limit number-of-packets

Especifica la cantidad máxima de paquete que la cola para la clase predeterminada puede acumular.

Para configurar una correspondencia de políticas y configurar el clase class-default para utilizar la caída de paquetes WRED, utilice el primer comando en el modo de configuración global de especificar el nombre de correspondencia de políticas, después de configurar la directiva para el uso de la clase predeterminada los siguientes comandos en el modo de configuración de clase del directiva-mapa:

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-default default-class-name

Especifica la clase predeterminada para que se pueda configurar o modificar su política.

Paso 3 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percent}



o


Router(config-pmap-c)# fair-queue [number-of-dynamic-queues]

Especifica la cantidad de ancho de banda, en el kbps, o el porcentaje del ancho de banda disponible que se asignará a la clase. La cantidad de ancho de banda configurada debe ser bastante grande también acomodar la capa 2 de arriba.

Especifica la Cantidad de colas dinámicas que se reservará para uso del flujo basado WFQ que se ejecuta en la clase predeterminada que la Cantidad de colas dinámicas se deriva del ancho de banda de la interfaz. Refiera a las tablas que acompañan la descripción fair-queue del comando (WFQ) en la referencia del comando solutions de la Calidad de servicio de Cisco IOS para el número predeterminado de colas dinámicas que el WFQ y el CBWFQ utilicen cuando se habilitan en una interfaz o el VC atmósfera.

Paso 4 

Router(config-pmap-c)# random-detect

Permisos WRED. La política de clase caerá los paquetes usando el WRED en vez de la eliminación de cola.

Paso 5 

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent


o


Router(config-pmap-c)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

Configura el factor de ponderación exponencial usado en el cálculo de la longitud de la cola promedio.

Parámetros WRED de las configuraciones para los paquetes con una Prioridad IP específica. Relance este comando para cada precedencia.

Asociando la política de servicio y habilitar el CBWFQ

Comando
Propósito

Router(config-if)# service-policy output policy-map

Los permisos CBWFQ y asocian la correlación de políticas de servicio especificada a la interfaz de salida.

La notaque configura el CBWFQ en una interfaz física es solamente posible si la interfaz está en el modo de espera predeterminado. Interfaces seriales en el e1 (2.048 Mbps) y debajo del uso WFQ por abandono — otras interfaces utilizan el (Primero en Salir FIFO) por abandono. Habilitar el CBWFQ en una interfaz física reemplaza el método de espera de la interfaz predeterminada. Habilitar el CBWFQ en un circuito virtual permanente (PVC) atmósfera no reemplaza el método de espera predeterminado.


Modificación del ancho de banda para un map class de la política existente

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la correspondencia de políticas que contiene la clase que se modificará.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase cuyo ancho de banda usted quiera modificar.

Paso 3 

Router(config-pmap-c)# bandwidth {bandwidth-kbps | percent percent}

Especifica la nueva cantidad de ancho de banda, en el kbps, o el porcentaje del ancho de banda disponible que se utilizará para configurar de nuevo la clase. La cantidad de ancho de banda configurada debe ser bastante grande también acomodar la capa 2 de arriba.

Modificación del límite de cola para un map class de la política existente

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la correspondencia de políticas que contiene la clase que se modificará.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase cuyo límite de cola usted quiera modificar.

Paso 3 

Router(config-pmap-c)# queue-limit number-of-packets

Especifica la nueva cantidad máxima de paquete que se puede hacer cola para que la clase sea configurada de nuevo. El valor por defecto y la cantidad máxima de paquete es 64.

Borrar las correspondencias de la clase de las correspondencias de la política de servicio

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la correspondencia de políticas que contiene las clases que se borrarán.

Paso 2 

Router(config-pmap)# no class class-name

Especifica el nombre de las clases que se borrarán.

Paso 3 

Router(config-pmap-c)# no class class-default

Borra la clase predeterminada.

Borrar las correspondencias de políticas

Comando
Propósito

Router(config)# no policy-map policy-map

Especifica el nombre de la correspondencia de políticas que se borrará.


Verificar la configuración de las correspondencias de políticas y de sus clases

Comando
Propósito

Router# show policy-map policy-map

Visualiza la configuración de todas las clases que compongan la correspondencia de políticas especificada.

Router# show policy-map policy-map class class-name

Visualiza la configuración de la clase especificada de la correspondencia de políticas especificada.

Router# show policy-map interface interface-name

Visualiza la configuración de todas las clases configuradas para todas las correspondencias de políticas en la interfaz especificada.

Observelos contadores visualizados después de publicar show policy-map interface el comando se ponen al día solamente si la congestión está presente en la interfaz.

Router# show queue interface-type interface-number

Visualizaciones que hacen cola la configuración y las estadísticas para una interfaz particular.


Lista de tareas de configuración distribuida del Class-Based Weighted Fair Queueing

Para configurar el DCBWFQ, realice las tareas descritas en las secciones siguientes. Aunque todas las tareas se enumeren como opcional, usted debe completar la tarea en la primera o segunda sección.

Modificando el ancho de banda para una clase de tráfico existente (opcional)

Modificando el límite de cola para una clase de tráfico existente (opcional)

Monitoreando y mantener el DCBWFQ (opcional)

El DCBWFQ se configura usando las clases de tráfico y las políticas de servicio definidas por el usario. Las clases de tráfico y las políticas de servicio se configuran usando la característica de la interfaz de línea de comando de calidad de servicio modular (CLI).

Modificación del ancho de banda para una clase de tráfico existente

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la política de tráfico que se creará o modificada.

Paso 2 

Router(config-pmap)# class class-name


Especifica el nombre de una clase de tráfico cuyo ancho de banda usted quiera modificar.

Paso 3 

Router(config-pmap-c)# bandwidth bandwidth-kbps

Especifica la cantidad de ancho de banda afectado un aparato, en el kbps, para ser reservado para la clase de tráfico en los entornos de red congestionada.

Observedespués de configurar la política de tráfico con policy-map el comando, usted debe todavía asociar la política de tráfico a una interfaz antes de que se habilite con éxito. Para la información sobre asociar una política de tráfico a una interfaz, vea “aplicando las características de QoS usando el módulo MQC”.

Modificación del límite de cola para una clase de tráfico existente

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre de la política de tráfico que se creará o modificada.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase de tráfico cuyo límite de cola usted quiera modificar.

Paso 3 

Router(config-pmap-c)# queue-limit number-of-packets

Especifica la nueva cantidad máxima de paquete que se puede hacer cola para que la clase de tráfico sea configurada de nuevo. El valor por defecto y la cantidad máxima de paquete es 64.

Observedespués de configurar la política de servicio con policy-map el comando, usted debe todavía asociar la política de tráfico a una interfaz antes de que se habilite con éxito. Para la información sobre asociar una política de tráfico a una interfaz, vea “aplicando las características de QoS usando el módulo MQC”.

Monitoreando y mantener el DCBWFQ

Comando
Propósito

Router# show policy-map

Visualiza todas las políticas de tráfico configuradas.

Router# show policy-map policy-map-name

Visualiza la política de tráfico definida por el usuario.

Router# show policy-map interface

Estadísticas de las visualizaciones y configuraciones de todas las directivas de la entrada y salida asociadas a una interfaz.

Router# show policy-map interface interface-spec

Configuración de las visualizaciones y estadísticas de las directivas de la entrada y salida asociadas a una interfaz particular.

Router# show policy-map interface interface-spec input

Configuración de las visualizaciones y estadísticas de la política de entrada asociada a una interfaz.

Router# show policy-map interface interface-spec output

Visualiza las estadísticas de configuración de la política de resultado asociada a una interfaz.

Router# show policy-map [interface [interface-spec [input | output] [class class-name]]]]

Visualiza la configuración y las estadísticas para el nombre de la clase configurado en la directiva.


Lista de tareas de configuración de la prioridad de IP RTP

Para configurar la prioridad de IP RTP, realice las tareas descritas en las secciones siguientes.

Configurando la prioridad de IP RTP (requerida)

Verificando la prioridad de IP RTP (opcional)

Verificando la prioridad de IP RTP (opcional)

Monitoreando y mantener la prioridad de IP RTP (opcional)

El Control de tráfico de Frame Relay (FRTS) y la fragmentación de Frame Relay (FRF.12 o más alto) deben ser configurados antes de que se utilice la característica de la Prioridad de IP RTP en Frame Relay.

Configurar la prioridad de IP RTP

Comando
Propósito

Router(config-if)# ip rtp priority starting-rtp-port-number port-number-range bandwidth

Reserva una cola de prioridad estricta para un conjunto de los flujos del paquete RTP que pertenecen a un rango de los puertos de destino UDP.

Observe ip rtp reserve y ip rtp priority los comandos no se pueden configurar en la misma interfaz.


Adviertaporque ip rtp priority el comando da la prioridad absoluta sobre el otro tráfico, debe ser utilizado con el cuidado. En caso de congestión, si el tráfico excede el ancho de banda configurado, entonces todo el excedente de tráfico es eliminado.

Verificar la prioridad de IP RTP

Comando
Propósito

Router# show queue interface-type interface-number

Visualizaciones que hacen cola la configuración y las estadísticas para una interfaz particular.


Monitoreando y mantener la prioridad de IP RTP

Comando
Propósito

Router# debug priority

Visualiza la salida de espera de la prioridad si los paquetes se caen del priority queue.

Router# show queue interface-type interface-number

Visualizaciones que hacen cola la configuración y las estadísticas para una interfaz particular.


Lista de tareas de configuración de la Prioridad de IP RTP en Frame Relay

Para configurar la Prioridad de IP RTP en Frame Relay, realice las tareas descritas en las secciones siguientes.

Configurando la Prioridad de IP RTP en Frame Relay (requerida)

Verificando la Prioridad de IP RTP en Frame Relay (opcional)

Monitoreando y mantener la Prioridad de IP RTP en Frame Relay (opcional)

Configurar la Prioridad de IP RTP en Frame Relay

Comando
Propósito

Router(config-map-class)# frame-relay ip rtp priority starting-rtp-port-number port-number-range bandwidth

Reserva una cola de prioridad estricta para un conjunto de los flujos del paquete RTP que pertenecen a un rango de los puertos de destino UDP.

Observeporque frame-relay ip rtp priority el comando da la prioridad absoluta sobre el otro tráfico, debe ser utilizado con el cuidado. En caso de congestión, si el tráfico excede el ancho de banda configurado, entonces todo el excedente de tráfico es eliminado.


Verificar la Prioridad de IP RTP en Frame Relay

Comando
Propósito

Router# show frame relay pvc

Muestra las estadísticas de los PVCs para las interfaces Frame Relay.

Router# show queue interface-type interface-number

Configuración y estadísticas de espera justas de las visualizaciones para una interfaz particular.

Router# show traffic-shape queue

Información de las visualizaciones sobre los elementos hechos cola en un momento determinado en el nivel del identificador de conexión de link de datos del VC (DLCI).


Monitoreo y Mantenimiento de Frame Relay IP RTP Priority

Comando
Propósito

Router# debug priority

Visualiza la salida de espera de la prioridad si los paquetes se caen del priority queue.


Lista de tareas para configurar la interfaz PVC de Frame Relay

Para configurar la característica de la prioridad de interfaz del PVC de Frame Relay, realice las tareas descritas en las secciones siguientes.

Configurando la prioridad del PVC en un map class (requerido)

Habilitando el Frame Relay PIPQ y estableciendo los límites de cola (requeridos)

Asignando un map class a un PVC (requerido)

Verificando el Frame Relay PIPQ (opcional)

Monitoreando y mantener el Frame Relay PIPQ (opcional)

Configurar la prioridad del PVC en un map class

 
Comando
Propósito

Paso 1 

Router(config)# map-class frame-relay map-class-name

Especifica una clase de correspondencia de Frame Relay.

Paso 2 

Router(config-map-class)# frame-relay interface- queue priority {high | medium | normal | low}

Asigna un nivel de prioridad del PVC a una clase de correspondencia de Frame Relay.

Habilitando el Frame Relay PIPQ y establecer los límites de cola

 
Comando
Propósito

Paso 1 

Router(config)# interface type number [name-tag]

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

Paso 2 

Router(config-if)# encapsulation frame-relay [cisco | ietf]

Habilita la encapsulación Frame Relay.

Paso 3 

Router(config-if)# frame-relay interface-queue priority [high-limit medium-limit normal-limit low-limit]

El Frame Relay PIPQ de los permisos y establece los límites del priority queue.

Asignación de un map class a un PVC

 
Comando
Propósito

Paso 1 

Router(config-if)# frame-relay interface-dlci dlci

Especifica un solo PVC en una interfaz de Frame Relay.

Paso 2 

Router(config-fr-dlci)# class map-class-name

Asocia un map class a un PVC especificado.

Verificar el Frame Relay PIPQ

Comando
Propósito

Router# show frame-relay pvc [interface interface][dlci]

Muestra las estadísticas de los PVCs para las interfaces Frame Relay.

Router# show interfaces [type number][first][last]

Visualiza la información estadística específica de una interfaz serial.

Router# show queueing [custom | fair | priority | random-detect [interface atm_subinterface [vc [[vpi/] vci]]]]

Muestra todas las estrategias de almacenamiento en cola configuradas o solamente las seleccionadas.


Monitoreando y mantener el Frame Relay PIPQ

Comando
Propósito

Router# debug priority

Visualiza la salida de espera de la prioridad si los paquetes se caen del priority queue.

Router# show frame-relay pvc [interface interface][dlci]

Muestra las estadísticas de los PVCs para las interfaces Frame Relay.

Router# show interfaces [type number][first][last]

Visualiza la información estadística específica de una interfaz serial.

Router# show queue interface-name interface-number [vc [vpi/] vci][queue-number]

Visualiza el contenido de los paquetes dentro de una cola para una interfaz particular o el VC.

Router# show queueing [custom | fair | priority | random-detect [interface atm_subinterface [vc [[vpi/] vci]]]]

Muestra todas las estrategias de almacenamiento en cola configuradas o solamente las seleccionadas.


Lista de tareas de configuración del low latency queueing

Para configurar el LLQ, realice las tareas descritas en las secciones siguientes.

Configurando el LLQ (requerido)

Verificando el LLQ (opcional)

Verificando el LLQ (opcional)

Monitoreando y mantener el LLQ (opcional)

Configurar el LLQ

Comando
Propósito

Router(config-pmap-c)# priority bandwidth

Reserva una cola de prioridad estricta para esta clase de tráfico.


Verificar el LLQ

Comando
Propósito

Router# show queue interface-type interface-number

Visualizaciones que hacen cola la configuración y las estadísticas para una interfaz particular.


Monitoreando y mantener el LLQ

Comando
Propósito

Router# debug priority

Visualiza la salida de espera de la prioridad si los paquetes se caen del priority queue.

Router# show queue interface-type interface-number

Visualizaciones que hacen cola la configuración y las estadísticas para una interfaz particular.

Router# show policy-map interface interface-name

Visualiza la configuración de todas las clases configuradas para todas las políticas de tráfico en la interfaz especificada. Visualizaciones si los paquetes y los bytes fueron desechados o caídos para la clase de prioridad en la política de tráfico asociada a la interfaz.


Lista de tareas distribuida de la configuración de LLQ

Para configurar distribuyó el LLQ, realiza las tareas descritas en las secciones siguientes.

Configurando un priority queue para una cantidad de ancho de banda disponible (requerido)

Configurando un priority queue para un porcentaje del ancho de banda disponible (requerido)

Configurando un límite del anillo de la transmisión en una atmósfera PVC (opcional)

Verificando el LLQ distribuido (opcional)

Verificando un límite del anillo de la transmisión (opcional)

Monitoreando y mantener el LLQ distribuido (opcional)

Configurar un priority queue para una cantidad de ancho de banda disponible

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-name

Especifica el nombre de la correspondencia de políticas para configurar. Ingresa en el modo de configuración del policy map.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase predefinida incluida en la política de servicio. Ingresa al modo de configuración de clase del directiva-mapa.

Paso 3 

Router(config-pmap-c)# priority kpbs [bytes]

Reserva un priority queue con una determinada cantidad de ancho de banda disponible para el tráfico CBWFQ.

Observela política de tráfico configurada en esta sección todavía no se asocia a una interfaz. Para la información sobre asociar una política de tráfico a una interfaz, vea “aplicando las características de QoS usando el módulo MQC”.

Configurar un priority queue para un porcentaje del ancho de banda disponible

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-name


Especifica el nombre de la política de tráfico para configurar. Ingresa en el modo de configuración del policy map.

Paso 2 

Router(config-pmap)# class class-name


Especifica el nombre de una clase predefinida incluida en la política de servicio. Ingresa al modo de configuración de clase del directiva-mapa.

Paso 3 

Router(config-pmap-c)# priority percent percent


Reserva un priority queue con un porcentaje especificado del ancho de banda disponible para el tráfico CBWFQ.

Observela política de tráfico configurada en esta sección todavía no se asocia a una interfaz. Para la información sobre asociar una política de tráfico a una interfaz, vea “aplicando las características de QoS usando el módulo MQC”.

Configurar un límite del anillo de la transmisión en una atmósfera PVC

 
Comando
Propósito

Paso 1 

Router(config)# interface atm interface-name

Especifica el nombre de la interfaz ATM para configurar.

Paso 2 

Router(config-if)# atm pvc vcd-number vpi-number vci-number Encapsulation-type tx-ring-limit ring-limit

Especifica la atmósfera PVC para configurar, el tipo de encapsulación, y el valor del límite del anillo de la transmisión.

Configurar un límite del anillo de la transmisión en una subinterfaz ATM

 
Comando
Propósito

Paso 1 

Router(config)# interface atm subinterface name

Especifica el nombre de la subinterfaz para configurar.

Paso 2 

Router(config-subif)# pvc pvc-name

Especifica el nombre del PVC para configurar.

Paso 3 

Router(config-if-atm-vc)# tx-ring-limit ring-limit

Especifica el valor del límite del anillo de la transmisión.

Verificar el LLQ distribuido

Comando
Propósito

Router# show interfaces [interface-type interface-number] fair-queue

Visualizaciones información y estadísticas sobre el WFQ para una interfaz VIP basada.

Router# show policy-map policy-map-name

Visualiza el contenido de una correspondencia de políticas, incluyendo la Configuración de prioridad en una correspondencia de políticas específica.


Verificar un límite del anillo de la transmisión

Comando
Propósito

Router# show atm vc vc-name

Visualiza el contenido de un VC. show atm vc La salida de comando indicará el valor del límite del anillo de la transmisión si tx-ring-limit el comando se habilita con éxito.


Monitoreando y mantener el LLQ distribuido

Comando
Propósito

Router# show interfaces [interface-type interface-number] fair-queue

Visualizaciones información y estadísticas sobre el WFQ para una interfaz VIP basada.

Router# show policy-map policy-map-name

Visualiza el contenido de una política de tráfico, incluyendo la Configuración de prioridad en una correspondencia de políticas específica.

Router# show policy interface interface-name

Visualiza la configuración de todas las clases configuradas para todas las políticas de servicio en la interfaz especificada. Visualizaciones si los paquetes y los bytes fueron desechados o caídos para la clase de prioridad en la política de servicio asociada a la interfaz.

Router# show atm vc vc-name

Visualiza el contenido de un VC. show atm vc La salida de comando indicará el valor del límite del anillo de la transmisión si tx-ring-limit el comando se habilita con éxito.


Lista de tareas de configuración del Procesamiento de baja latencia de datos prioritarios en espera para Frame Relay

Para configurar el LLQ para el Frame Relay, realice las tareas descritas en las secciones siguientes.

Definiendo la clase asocia (requerido)

Configurando la política de clase en la correspondencia de políticas (requerida)

Asociando la política de servicio y habilitando el LLQ para el Frame Relay (requerido)

Verificando la configuración de las correspondencias de políticas y de sus clases (opcionales)

Monitoreando y mantener el LLQ para el Frame Relay (opcional)

Definición de las correspondencias de la clase

 
Comando
Propósito

Paso 1 

Router(config)# class-map class-map-name

Especifica el nombre de la correspondencia de la clase que se creará.

Paso 2 

Router(config-cmap)# match access-group {access-group | name access-group-name}

o


Router(config-cmap)# match input-interface interface-name


o


Router(config-cmap)# match protocol protocol

Especifica el nombre del ACL contra cuyo contenido los paquetes se marcan para determinar si pertenecen a la clase.

Especifica el nombre de la interfaz de entrada usada como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Especifica el nombre del protocolo usado como criterio del emparejamiento contra el cual los paquetes se marquen para determinar si pertenecen a la clase.

Configurar la política de clase en la correspondencia de políticas

Para configurar una correspondencia de políticas y crear las políticas de clase que componen la política de servicio, comience con el comando policy-map de especificar el nombre de correspondencia de políticas. Entonces utilice uno o más de los siguientes comandos de configurar la directiva para una clase estándar o la clase predeterminada:

priority

bandwidth

queue-limit o random-detect

fair-queue (para el clase class-default solamente)

Para cada clase que usted defina, usted puede utilizar uno o más de los comandos enumerados para configurar la política de clase. Por ejemplo, usted puede ser que especifique el ancho de banda para una clase y ancho de banda y límite de cola para otra clase.

La clase predeterminada de la correspondencia de políticas (conocida comúnmente como el clase class-default) es la clase a la cual se dirige el tráfico si ese tráfico no satisface los criterios de concordancia de las otras clases definidas en la correspondencia de políticas.

El clase class-default se utiliza para clasificar el tráfico que no baja en una de las clases definidas. Aunque la clase class-default se predefine al crear el policy map, sigue siendo necesario configurarla. Si una clase predeterminada no se configura, después el tráfico que no hace juego las clases configuradas unas de los se da el tratamiento del mejor esfuerzo, así que lo significa que la red entregará el tráfico si puede, sin ninguna garantía de la confiabilidad, prevención del retardo, o la producción.

Usted puede configurar las políticas de clase para tantas clases como se definen en el router, hasta el máximo de 64. Sin embargo, la cantidad total de ancho de banda afectada un aparato para todas las clases en una correspondencia de políticas no debe exceder la velocidad de información comprometida mínima (CIR) configurada para el VC menos ningún ancho de banda reservado por frame-relay voice bandwidth y frame-relay ip rtp priority los comandos. Si el CIR mínimo no se configura, el ancho de banda omite una mitad del CIR. Si todo el ancho de banda no se afecta un aparato, el ancho de banda restante se afecta un aparato proporcional entre las clases en base de su configuré el ancho de banda.

Para configurar las políticas de clase en una correspondencia de políticas, realice las tareas descritas en las secciones siguientes.

Configurando la política de clase para un priority queue LLQ (requerido)

Configurando la política de clase usando un ancho de banda especificado y la caída de paquetes WRED (opcionales)

Configurando la directiva del clase class-default (opcional)

Configurar la política de clase para un priority queue LLQ

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase que se creará e incluirá en la política de servicio.

Paso 3 

Router(config-pmap-c)# priority bandwidth-kbps

Crea una clase de prioridad estricta y especifica la cantidad de ancho de banda, en kbps, que se debe asignar a la clase.

Configurar la política de clase usando un ancho de banda especificado y la caída de paquetes WRED

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-name

Especifica el nombre de una clase que se creará e incluirá en la política de servicio.

Paso 3 

Router(config-pmap-c)# bandwidth bandwidth-kbps

Especifica la cantidad de ancho de banda que se asignará a la clase, en kbps, o como un porcentaje del ancho de banda disponible. El ancho de banda se debe especificar en kbps o como porcentaje sistemáticamente en todas las clases. (El ancho de banda de la cola prioritaria se debe especificar en kbps.)

Paso 4 

Router(config-pmap-c)# random-detect

Permisos WRED.

Configurar la directiva del clase class-default

 
Comando
Propósito

Paso 1 

Router(config)# policy-map policy-map

Especifica el nombre del policy map que se creará o modificará.

Paso 2 

Router(config-pmap)# class class-default default-class-name

Especifica la clase predeterminada para que se pueda configurar o modificar su política.

Paso 3 

Router(config-pmap-c)# bandwidth bandwidth-kbps


o


Router(config-pmap-c)# fair-queue [number-of-dynamic-queues]

Especifica la cantidad de ancho de banda, en el kbps, para ser asignado a la clase.

Especifica la Cantidad de colas dinámicas que se reservará para uso del flujo basado WFQ que se ejecuta en la clase predeterminada. La Cantidad de colas dinámicas se deriva del ancho de banda de la interfaz.

Paso 4 

Router(config-pmap-c)# queue-limit number-of-packets

Especifica la cantidad máxima de paquete que la cola para la clase predeterminada puede acumular.

Asociando la política de servicio y habilitar el LLQ para el Frame Relay

Comando
Propósito

Router(config-map-class)# service-policy output policy-map

Asocia la correlación de políticas de servicio especificada a la interfaz de salida y habilita el LLQ para el Frame Relay.

Observecuando LLQ se habilita, todas las clases configuradas como parte de la correspondencia de la política de servicio están instalados en el sistema Fair Queuing.


Verificar la configuración de las correspondencias de políticas y de sus clases

Comando
Propósito

Router# show frame-relay pvc dlci

Estadísticas de las visualizaciones sobre el PVC y la configuración de las clases para la correspondencia de políticas en el DLCI especificado.

Router# show policy-map interface interface-name

Cuando se configura el FRTS, visualiza la configuración de las clases para todas las correspondencias de políticas del VC-nivel del Frame Relay.

Cuando el FRTS no se configura, visualiza la configuración de las clases para la directiva del interfaz-nivel.

Router# show policy-map interface interface-name dlci dlci

Cuando se configura el FRTS, visualiza la configuración de las clases para la correspondencia de políticas en el DLCI especificado.


Monitoreando y mantener el LLQ para el Frame Relay

Para una lista de comandos que se puedan utilizar para monitorear el LLQ para el Frame Relay, vea la sección anterior el “verificar de la configuración de las correspondencias de políticas y de sus clases.”

Configurar los tamaños de ráfaga en la lista de tareas de la configuración de LLQ

Para configurar los tamaños de ráfaga en el LLQ, realice las tareas descritas en las secciones siguientes.

Configurando el ancho de banda LLQ (requerido)

Configurando los tamaños de ráfaga LLQ (requeridos)

Verificando los tamaños de ráfaga LLQ (opcionales)

Configurar el ancho de banda LLQ

Comando
Propósito

Router(config)# priority bandwidth

Especifica la cantidad máxima de ancho de banda, en el kpbs, para el tráfico de prioridad.


Configurar los tamaños de ráfaga LLQ

Comando
Propósito

Router(config)# priority bandwidth burst

Especifica los tamaños de ráfaga en los bytes. El rango es a partir 32 a 2 millones.


Verificar los tamaños de ráfaga LLQ

Comando
Propósito

Router# show policy-map

Visualiza la configuración de todas las clases que comprenden la correlación de políticas de servicio especificada o todas las clases para toda la política existente asocian.

Router# show policy-map interface


Visualiza la configuración de las clases configuradas para el servicio limpia en la interfaz especificada o el PVC.


Soporte de la cola de espera por VC para la lista de tareas de configuración de los adaptadores ATM

Para configurar el soporte de la cola de espera por VC para los adaptadores ATM, realice las tareas descritas en las secciones siguientes.

Configurando la cola de espera por VC en un adaptador ATM (requerido)

Verificando la configuración de la cola de espera por VC en un adaptador ATM (opcional)

Configurar la cola de espera por VC en un adaptador ATM

Comando
Propósito

Router(config)# vc-hold-queue number-of-packets

Especifica el número de paquetes contenidos en la cola de espera por VC. Esto puede ser un número a partir del 5 a 1024.


Verificar la configuración de la cola de espera por VC en un adaptador ATM

Comando
Propósito

Router# show queueing interface

Visualiza las estadísticas de espera de una interfaz o del VC.


Ejemplos: Configuración del flujo basado WFQ

El siguiente ejemplo pide una cola justa con un descartar umbral congestivo de 64 mensajes, de 512 colas dinámicas, y de 18 colas de administración del tráfico de RSVP:

Router(config)# interface Serial 3/0
Router(config-if)# ip unnumbered Ethernet 0/0
Router(config-if)# fair-queue 64 512 18

Ejemplos: Configuración DWFQ

Ejemplo: Flujo basado DWFQ

El siguiente ejemplo habilita el DWFQ en la interfaz HSSI 0/0/0:

Router(config)# interface Hssi0/0/0
Router(config-if)# description 45Mbps to R2
Router(config-if)# ip address 200.200.14.250 255.255.255.252
Router(config-if)# fair-queue

Lo que sigue es salida de muestra show interfaces fair-queue del comando para esta configuración:

Router# show interfaces hssi 0/0/0 fair-queue

Hssi0/0/0 queue size 0
     packets output 35, drops 0
WFQ: global queue limit 401, local queue limit 200

Ejemplo: DWFQ QoS-Grupo-basado

Las configuraciones del siguiente ejemplo QoS-grupo-basaron el DWFQ. Las directivas del Committed Access Rate (CAR) se utilizan para asignar los paquetes con un valor de precedencia IP de 2 al group2 de QoS, y los paquetes con un valor de precedencia IP de 6 se asignan al grupo 6. de QoS.

Router(config)# interface Hssi0/0/0
Router(config-if)# ip address 188.1.3.70 255.255.255.0
Router(config-if)# rate-limit output access-group rate-limit 6 155000000 2000000 8000000 
conform-action set-qos-transmit 6 exceed-action drop
Router(config-if)# rate-limit output access-group rate-limit 2 155000000 2000000 8000000 
conform-action set-qos-transmit 2 exceed-action drop
Router(config-if)# fair-queue qos-group
Router(config-if)# fair-queue qos-group 2 weight 10
Router(config-if)# fair-queue qos-group 2 limit 27
Router(config-if)# fair-queue qos-group 6 weight 30
Router(config-if)# fair-queue qos-group 6 limit 27
!
Router(config)# access-list rate-limit 2 2
Router(config)# access-list rate-limit 6 6

La salida de muestra siguiente muestra cómo ver las estadísticas WFQ usando show interfaces fair-queue el comando:

Router# show interfaces fair-queue

 Hssi0/0/0 queue size 0
        packets output 806232, drops 1
 WFQ: aggregate queue limit 54, individual queue limit 27
    max available buffers 54
     Class 0: weight 60 limit 27 qsize 0 packets output 654 drops 0
     Class 2: weight 10 limit 27 qsize 0 packets output 402789 drops 0
     Class 6: weight 30 limit 27 qsize 0 packets output 402789 drops 1

Ejemplo: DWFQ basado en TOS

El siguiente ejemplo configura el Tipo de servicio (ToS) - DWFQ basado usando los parámetros predeterminados:

Router# configure terminal
Router(config)# interface Hssi0/0/0
Router(config-if)# fair-queue tos
Router(config-if)# end

Lo que sigue es salida show running-config del comando para la interfaz HSSI 0/0/0. Note que el router agrega automáticamente los pesos predeterminados y los límites para las clases TOS a la configuración.

interface Hssi0/0/0
 ip address 188.1.3.70 255.255.255.0
 fair-queue tos
 fair-queue tos 1 weight 20
 fair-queue tos 1 limit 27
 fair-queue tos 2 weight 30
 fair-queue tos 2 limit 27
 fair-queue tos 3 weight 40
 fair-queue tos 3 limit 27

La salida de muestra siguiente muestra cómo ver las estadísticas DWFQ usando show interfaces fair-queue el comando:

Router# show interfaces fair-queue

 Hssi0/0/0 queue size 0
        packets output 1417079, drops 2
 WFQ: aggregate queue limit 54, individual queue limit 27
    max available buffers 54
     Class 0: weight 10 limit 27 qsize 0 packets output 1150 drops 0
     Class 1: weight 20 limit 27 qsize 0 packets output 0 drops 0
     Class 2: weight 30 limit 27 qsize 0 packets output 775482 drops 1
     Class 3: weight 40 limit 27 qsize 0 packets output 0 drops 0

Ejemplos: Configuración CBWFQ

Ejemplo: Configuración de asignación de la clase

En el siguiente ejemplo, se crean los ACL 101 y 102. Después, se crean dos correspondencias de la clase y se definen sus criterios de concordancia. Para el primer map class, llamado class1, el ACL 101 numerado se utiliza como el criterio de la coincidencia. Para el segundo map class, llamado class2, el ACL 102 numerado se utiliza como el criterio de la coincidencia. Los paquetes se marcan contra el contenido de estos ACL para determinar si pertenecen a la clase.

Router(config)# access-list 101 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 
20000
Router(config# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 
56000

Router(config)# class-map class1
Router(config-cmap)# match access-group 101
Router(config-cmap)# exit

Router(config-cmap)# class-map class2
Router(config-cmap)# match access-group 102
Router(config-cmap)# exit

Ejemplo: Creación de la directiva

En el siguiente ejemplo, una correspondencia de políticas llamada policy1 se define para contener la especificación de políticas para las dos clases, class1 y class2. Los criterios de concordancia para estas clases fueron definidos en el “ejemplo anterior: Sección de la configuración de asignación de la clase”.

Para class1, la directiva especifica la petición de la asignación de ancho de banda y la cantidad máxima de paquete que la cola para esta clase puede acumular. Para class2, la directiva especifica solamente la petición de la asignación de ancho de banda, así que el límite de la cola predeterminada de 64 paquetes se asume.

Router(config)# policy-map policy1

Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 3000 
Router(config-pmap-c)# queue-limit 30
Router(config-pmap-c)# exit

Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 2000 
Router(config-pmap-c)# exit

Ejemplo: Conexión de la directiva a las interfaces

Las demostraciones del siguiente ejemplo cómo asociar una correspondencia de la política existente. Después de que usted defina una correspondencia de políticas, usted puede asociarla a una o más interfaces para especificar la política de servicio para esas interfaces. Aunque usted pueda asignar la misma correspondencia de políticas a las interfaces múltiples, cada interfaz puede tener solamente una correspondencia de políticas asociada en la entrada y una correspondencia de políticas asociada en la salida.

La correspondencia de políticas en este ejemplo fue definida en la sección anterior, “ejemplo: Creación de la directiva.”

Router(config)# interface e1/1
Router(config-if)# service output policy1 
Router(config-if)# exit

Router(config)# interface fa1/0/0
Router(config-if)# service output policy1 
Router(config-if)# exit

Ejemplo: CBWFQ usando la caída de paquetes WRED

En el siguiente ejemplo, la correspondencia de la clase llamada class1 se crea y se define para utilizar la interfaz FastEthernet 0/1 de la entrada de información como criterio del emparejamiento para determinar si los paquetes pertenecen a la clase. Después, la correspondencia de políticas policy1 se define para contener la especificación de políticas para class1, que se configura para la caída de paquetes WRED.

Router(config)# class-map class1
Router(config-cmap)# match input-interface FastEthernet0/1
!
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 1000
Router(config-pmap-c)# random-detect
!
Router(config)# interface serial0/0
Router(config-if)# service-policy output policy1
!

Ejemplos: Contenido del mapa de la política de servicio de la visualización

La demostración de los siguientes ejemplos cómo visualizar el contenido de las correspondencias de la política de servicio. Cuatro métodos se pueden utilizar para visualizar el contenido.

Visualice todas las clases que compongan una correlación de políticas de servicio especificada

Visualice todas las clases configuradas para todas las correspondencias de la política de servicio

Visualice una clase especificada de una correspondencia de la política de servicio

Visualice todas las clases configuradas para todas las correspondencias de la política de servicio en una interfaz especificada

Todas las clases para una correlación de políticas de servicio especificada

El siguiente ejemplo visualiza el contenido de la correspondencia de la política de servicio llamada pol1:

Router# show policy-map po1

Policy Map po1 
 Weighted Fair Queueing 
    Class class1
       Bandwidth 937 (kbps) Max thresh 64 (packets) 
    Class class2 
        Bandwidth 937 (kbps)  Max thresh 64 (packets)
    Class class3 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class4 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class5 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class6
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class7 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class8 
         Bandwidth 937 (kbps)  Max thresh 64 (packets)

Todas las clases para todas las correspondencias de la política de servicio

El siguiente ejemplo visualiza el contenido de todas las correspondencias de políticas en el router:

Router# show policy-map 

Policy Map poH1 
 Weighted Fair Queueing 
    Class class1 
       Bandwidth 937 (kbps) Max thresh 64 (packets) 
    Class class2 
        Bandwidth 937 (kbps)  Max thresh 64 (packets)
    Class class3 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class4 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class5 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class6 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class7 
        Bandwidth 937 (kbps)  Max thresh 64 (packets) 
    Class class8 
         Bandwidth 937 (kbps)  Max thresh 64 (packets)
Policy Map policy2
 Weighted Fair Queueing
    Class class1 
       Bandwidth 300 (kbps) Max thresh 64 (packets) 
    Class class2 
        Bandwidth 300  (kbps)  Max thresh 64 (packets)
    Class class3 
        Bandwidth 300 (kbps)  Max thresh 64 (packets) 
    Class class4 
        Bandwidth 300 (kbps)  Max thresh 64 (packets) 
    Class class5 
        Bandwidth 300 (kbps)  Max thresh 64 (packets) 
    Class class6 
        Bandwidth 300 (kbps)  Max thresh 64 (packets)  

Clase especificada para un mapa de la política de servicio

El siguiente ejemplo visualiza las configuraciones para la clase llamada class7 que pertenezca a la correspondencia de políticas llamada po1:

Router# show policy-map po1 class class7
 
Class class7 
 Bandwidth 937 (kbps) Max Thresh 64 (packets)

Todas las clases para todas las correspondencias de la política de servicio en una interfaz especificada

El siguiente ejemplo visualiza las configuraciones para las clases en la interfaz de Ethernet 2/0 de la salida. Los números mostrados entre paréntesis están para el uso con el Management Information Base (MIB).

Router# show policy-map interface e2/0

Ethernet2/0 

  Service-policy output:p1 (1057)

    Class-map:c1 (match-all) (1059/2)
      19 packets, 1140 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match:ip precedence 0  (1063)
      Weighted Fair Queueing
        Output Queue:Conversation 265 
        Bandwidth 10 (%) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map:c2 (match-all) (1067/3)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match:ip precedence 1  (1071)
      Weighted Fair Queueing
        Output Queue:Conversation 266 
        Bandwidth 10 (%) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
   Class-map:class-default (match-any) (1075/0)
      8 packets, 2620 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match:any  (1079)

Ejemplos: Configuración distribuida CBWFQ

Ejemplo: Configuración de la clase de tráfico

En el siguiente ejemplo, se crean dos clases de tráfico y se definen sus criterios de concordancia. Para la primera clase de tráfico, llamado class1, el ACL 101 numerado se utiliza como el criterio de la coincidencia. Para la segunda clase de tráfico, llamado class2, el ACL 102 numerado se utiliza como el criterio de la coincidencia. Los paquetes se marcan contra el contenido de estos ACL para determinar si pertenecen a la clase de tráfico.

Router(config)# class-map class1 
Router(config-cmap)# match access-group 101
Router(config-cmap)# exit

Router(config)# class-map class2 
Router(config-cmap)# match access-group 102
Router(config-cmap)# exit

Ejemplo: Creación de la política de tráfico

En el siguiente ejemplo, una política de tráfico llamada policy1 se define para asociar las características de QoS a las dos clases de tráfico, class1 y class2. Los criterios de concordancia para estas clases de tráfico fueron definidos en el “ejemplo anterior: Sección de la configuración de asignación de la clase”.

Para class1, las directivas de QoS incluyen el pedido de la asignación de ancho de banda y el límite de recuento del PAQUETE MÁXIMO la cola reservados para la clase de tráfico. Para class2, la directiva especifica solamente una petición de la asignación de ancho de banda, así que el límite de la cola predeterminada de 64 paquetes se asume.

Router(config)# policy-map policy1

Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 3000 
Router(config-pmap-c)# queue-limit 30
Router(config-pmap)# exit

Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 2000 
Router(config-pmap)# exit

Ejemplo: Conexión de la política de tráfico a una interfaz

Las demostraciones del siguiente ejemplo cómo asociar una política de tráfico existente a una interfaz. Después de que usted defina una política de tráfico, usted puede asociarla a una o más interfaces para especificar una política de tráfico para esas interfaces. Aunque usted pueda asignar la misma política de tráfico a las interfaces múltiples, cada interfaz puede tener solamente una política de tráfico asociada en la entrada y una correspondencia de políticas asociadas en la salida al mismo tiempo.

Router(config)# interface fe1/0/0 
Router(config-if)# service output policy1 
Router(config-if)# exit

Ejemplos: Configuración de la prioridad de IP RTP

Ejemplo: Configuración CBWFQ

El siguiente ejemplo primero define una configuración CBWFQ y en seguida reserva una cola de prioridad estricta:

! The following commands define a class map:
Router(config)# class-map class1
Router(config-cmap)# match access-group 101
Router(config-cmap)# exit

! The following commands create and attach a policy map:
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 3000
Router(config-pmap-c)# queue-limit 30
Router(config-pmap-c)# random-detect
Router(config-pmap-c)# random-detect precedence 0 32 256 100
Router(config-pmap-c)# exit
Router(config)# interface Serial1
Router(config-if)# service-policy output policy1

! The following command reserves a strict priority queue:
Router(config-if)# ip rtp priority 16384 16383 40

queue-limit Y random-detect los comandos son los comandos opcionales para las configuraciones CBWFQ. queue-limit El comando se utiliza para configurar los límites de la eliminación de cola para una cola de clases. random-detect El comando se utiliza para configurar los límites del descenso ROJO para una cola de clases, similares random-detect al comando disponible en una interfaz.

Ejemplo: Configuración de plantilla virtual

El siguiente ejemplo configura una cola de prioridad estricta en una configuración de plantilla virtual con el CBWFQ.

Router(config)# multilink virtual-template 1
Router(config)# interface virtual-template 1
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip rtp priority 16384 16383 25
Router(config-if)# service-policy output policy1
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
Router(config-if)# end

Router(config)# interface Serial0/1
Router(config-if)# bandwidth 64
Router(config-if)# ip address 1.1.1.2 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# ppp multilink
Router(config-if)# end


Observepara hacer que la interfaz de acceso virtual funciona correctamente, bandwidth el comando de configuración de clase del directiva-mapa no debe ser configurado en la plantilla virtual. Necesita ser configurada en la interfaz real, tal y como se muestra en del ejemplo.


Ejemplo: Configuración del agrupamiento de links múltiples

El siguiente ejemplo configura una cola de prioridad estricta en una configuración del agrupamiento de links múltiples con el WFQ. La ventaja a usar los agrupamientos de links múltiples es que usted puede especificar diversos parámetros de la prioridad de IP RTP en diversas interfaces.

Los siguientes comandos crean el agrupamiento de links múltiples 1, que se configura para un ancho de banda máximo de la prioridad de IP RTP de 200 kbps.

Router(config)# interface multilink 1
Router(config-if)# ip address 172.17.254.161 255.255.255.248
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip rtp priority 16384 16383 200
Router(config-if)# no ip mroute-cache
Router(config-if)# fair-queue 64 256 0
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave

Los siguientes comandos crean el agrupamiento de links múltiples 2, que se configura para un ancho de banda máximo de la prioridad de IP RTP de 100 kbps:

Router(config)# interface multilink 2
Router(config-if)# ip address 172.17.254.162 255.255.255.248
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip rtp priority 16384 16383 100
Router(config-if)# no ip mroute-cache
Router(config-if)# fair-queue 64 256 0
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave

En la parte de siguiente el ejemplo, multilink-group el comando configura la interfaz serial 2/0 para ser el agrupamiento de links múltiples 1 de la parte de:

Router(config)# interface serial 2/0
Router(config-if)# bandwidth 256
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no ip mroute-cache
Router(config-if)# no fair-queue
Router(config-if)# clockrate 256000
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1

Después, la interfaz serial 2/1 se configura para ser el agrupamiento de links múltiples 2. de la parte de.

Router(config)# interface serial 2/1
Router(config-if)# bandwidth 128
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no ip mroute-cache
Router(config-if)# no fair-queue
Router(config-if)# clockrate 128000
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 2

Ejemplo: Depurar

El siguiente ejemplo muestra la salida de muestra debug priority del comando. En este ejemplo, 64 indica la profundidad real del priority queue cuando el paquete fue caído.

Router# debug priority

*Feb 28 16:46:05.659:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.671:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.679:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.691:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.699:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.711:WFQ:dropping a packet from the priority queue 64
*Feb 28 16:46:05.719:WFQ:dropping a packet from the priority queue 64

Ejemplos: Configuración de la Prioridad de IP RTP en Frame Relay

Este “ejemplo: El servicio de prioridad estricta sección a los paquetes RTP que corresponden con” proporciona un ejemplo de configuración.

Ejemplo: Servicio de prioridad estricta a los paquetes RTP que corresponden con

El siguiente ejemplo primero configura la clase de correspondencia de Frame Relay llamada voip y en seguida aplica el map class a PVC 100 para proporcionar el servicio de prioridad estricta a los paquetes RTP que corresponden con. En este ejemplo, los paquetes RTP en PVC 100 con los puertos UDP en el rango 16384 a 32764 serán correspondidos con y servicio de prioridad estricta dado.

map-class frame-relay voip
 frame-relay cir 256000
 frame-relay bc 2560
 frame-relay be 600
 frame-relay mincir 256000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 250
 frame-relay ip rtp priority 16384 16380 210

interface Serial5/0
 ip address 10.10.10.10 255.0.0.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 load-interval 30
 clockrate 1007616
 frame-relay traffic-shaping
 frame-relay interface-dlci 100
  class voip
 frame-relay ip rtp header-compression
 frame-relay intf-type dce

Ejemplos: Configuración de la interfaz PQ del PVC de Frame Relay

Esta sección proporciona los ejemplos de configuración para el Frame Relay PIPQ.

Este ejemplo muestra que la configuración de cuatro PVC en el DLCI 100 de la interfaz serial 0. está asignada prioritario, el DLCI 200 se asigna la Prioridad media, el DLCI 300 se asigna la prioridad normal, y el DLCI 400 se asigna la prioridad baja.

Los siguientes comandos configuran las clases de correspondencia de Frame Relay con los niveles de prioridad del PVC:

Router(config)# map-class frame-relay HI
Router(config-map-class)# frame-relay interface-queue priority high
Router(config-map-class)# exit
Router(config)# map-class frame-relay MED
Router(config-map-class)# frame-relay interface-queue priority medium
Router(config-map-class)# exit
Router(config)# map-class frame-relay NORM
Router(config-map-class)# frame-relay interface-queue priority normal
Router(config-map-class)# exit
Router(config)# map-class frame-relay LOW
Router(config-map-class)# frame-relay interface-queue priority low
Router(config-map-class)# exit

Los siguientes comandos habilitan la Encapsulación de Frame Relay y el Frame Relay PIPQ en la interfaz serial 0. Los tamaños de las colas de administración del tráfico de prioridad se fijan en un máximo de 20 paquetes para la cola de alta prioridad, 40 para la cola de Prioridad media, 60 para la cola de prioridad normal, y 80 para la cola de baja prioridad.

Router(config)# interface Serial0
Router(config-if)# encapsulation frame-relay
Router(config-if)# frame-relay interface-queue priority 20 40 60 80

Los siguientes comandos asignan la prioridad a cuatro PVC asociando los DLCI a las clases configuradas de la correspondencia:

Router(config-if)# frame-relay interface-dlci 100
Router(config-fr-dlci)# class HI
Router(config-fr-dlci)# exit
Router(config-if)# frame-relay interface-dlci 200
Router(config-fr-dlci)# class MED
Router(config-fr-dlci)# exit
Router(config-if)# frame-relay interface-dlci 300
Router(config-fr-dlci)# class NORM
Router(config-fr-dlci)# exit
Router(config-if)# frame-relay interface-dlci 400
Router(config-fr-dlci)# class LOW
Router(config-fr-dlci)# exit

Ejemplos: Configuración de LLQ

Ejemplo: Configuración de PVC atmósfera

En el siguiente ejemplo, una cola de prioridad estricta con un ancho de banda permitido garantizado de 50 kbps es reservada para el tráfico que se envía de la dirección de origen 10.10.10.10 a la dirección destino 10.10.10.20, en el rango de los puertos 16384 a 20000 y 53000 a 56000.

Primero, los siguientes comandos configuran la lista de acceso 102 para hacer juego el tráfico de voz deseado:

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 
20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 
56000

Después, se define la Voz de la correspondencia de la clase, y se crea la correspondencia de políticas llamó policy1; una cola de prioridad estricta para la Voz de la clase es reservada, un ancho de banda de 20 kbps se configura para la clase BAR, y la clase predeterminada se configura para el WFQ. service-policy El comando entonces asocia la correspondencia de políticas a la interfaz 0/102 PVC en la subinterfaz atm1/0.2.

Router(config)# class-map voice
Router(config-cmap)# match access-group 102

Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue

Router(config)# interface atm1/0.2
Router(config-subif)# pvc 0/102
Router(config-subif-vc)# service-policy output policy1

Ejemplo: Configuración de plantilla virtual

El siguiente ejemplo configura una cola de prioridad estricta en una configuración de plantilla virtual con el CBWFQ. Trafique en la plantilla virtual 1 que es correspondida con por la lista de acceso 102 será dirigida a la cola de prioridad estricta.

Primero, se define la Voz de la correspondencia de la clase, y se crea la correspondencia de políticas llamó policy1. Una cola de prioridad estricta (con un ancho de banda permitido garantizado de 50 kbps) es reservada para la clase llamada Voz.

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50

Después, service-policy el comando asocia la correspondencia de políticas llamada policy1 a la plantilla virtual 1.

Router(config)# multilink virtual-template 1
Router(config)# interface virtual-template 1
Router(config-if)# ip address 172.16.1.1 255.255.255.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# service-policy output policy1
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave
Router(config-if)# end

Router(config)# interface serial 2/0
Router(config-if)# bandwidth 256
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no fair-queue
Router(config-if)# clockrate 256000
Router(config-if)# ppp multilink

Ejemplo: Configuración del agrupamiento de links múltiples

El siguiente ejemplo configura una cola de prioridad estricta en una configuración del agrupamiento de links múltiples con el CBWFQ. Trafique en la interfaz serial 2/0 que eso es correspondida con por la lista de acceso 102 será dirigida a la cola de prioridad estricta. La ventaja a usar los agrupamientos de links múltiples es que usted puede especificar diversos priority parámetros en diversas interfaces. Para especificar diversos priority parámetros, usted configuraría dos agrupamientos de links múltiples con diversos parámetros.

Primero, se define la Voz de la correspondencia de la clase, y se crea la correspondencia de políticas llamó policy1. Una cola de prioridad estricta (con un ancho de banda permitido garantizado de 50 kbps) es reservada para la clase llamada Voz.

Router(config)# class-map voice
Router(config-cmap)# match access-group 102
Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50

Los siguientes comandos crean el agrupamiento de links múltiples 1. La correspondencia de políticas llamada policy1 es asociada al conjunto por service-policy el comando.

Router(config)# interface multilink 1
Router(config-if)# ip address 172.17.254.161 255.255.255.248
Router(config-if)# no ip directed-broadcast
Router(config-if)# no ip mroute-cache
Router(config-if)# service-policy output policy1
Router(config-if)# ppp multilink
Router(config-if)# ppp multilink fragment-delay 20
Router(config-if)# ppp multilink interleave

En la parte de siguiente el ejemplo, multilink-group el comando configura la interfaz serial 2/0 para ser el agrupamiento de links múltiples 1 de la parte de, que dirige con eficacia el tráfico en la interfaz serial 2/0 que eso es correspondido con por la lista de acceso 102 a la cola de prioridad estricta:

Router(config)# interface serial 2/0
Router(config-if)# bandwidth 256
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# no fair-queue
Router(config-if)# clockrate 256000
Router(config-if)# ppp multilink
Router(config-if)# multilink-group 1

Ejemplos: Configuración de LLQ distribuida

Ejemplo: Habilitar el PQ para una cantidad de ancho de banda disponible en una subinterfaz ATM

priority El comando se puede habilitar en una subinterfaz ATM, y esa subinterfaz debe tener solamente una atmósfera habilitada PVC. Esta configuración proporciona una cantidad suficiente de soporte atmósfera PVC.

En el siguiente ejemplo, un priority queue con un ancho de banda permitido garantizado de 50 kbps es reservado para el tráfico que se envía de la dirección de origen 10.10.10.10 a la dirección destino 10.10.10.20, en el rango de los puertos 16384 a 20000 y 53000 a 56000.

Primero, los siguientes comandos configuran la lista de acceso 102 para hacer juego el tráfico de voz deseado:

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 
20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 
56000

Después, la clase de tráfico llamada Voz se define, y se crea la correspondencia de políticas llamó policy1; un priority queue para la Voz de la clase se reserva con un ancho de banda permitido garantizado de 50 kpbs y los tamaños de ráfaga permisibles de 60 bytes, un ancho de banda de 20 kbps se configura para la clase llamada barra, y la clase predeterminada se configura para las colas justas del flujo basado. service-policy El comando entonces asocia la correspondencia de políticas a la interfaz 0/102 PVC en la subinterfaz atm1/0.

Router(config)# class-map voice
Router(config-cmap)# match access-group 102

Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 50 60
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue

Router(config)# interface atm1/0
Router(config-subif)# pvc 0/102

Router(config-subif)# service-policy output policy1

Ejemplo: Habilitar el PQ para un porcentaje del ancho de banda disponible en una subinterfaz ATM

priority percent El comando se puede habilitar en una subinterfaz ATM, y esa subinterfaz debe tener solamente una atmósfera habilitada PVC. Esta configuración proporciona una cantidad suficiente de soporte atmósfera PVC.

En el siguiente ejemplo, un priority queue con un porcentaje de ancho de banda permitido garantizado del 15 por ciento es reservado para el tráfico que se envía de la dirección de origen 10.10.10.10 a la dirección destino 10.10.10.20, en el rango de los puertos 16384 a 20000 y 53000 a 56000.

Primero, los siguientes comandos configuran la lista de acceso 102 para hacer juego el tráfico de voz deseado:

Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 16384 
20000
Router(config)# access-list 102 permit udp host 10.10.10.10 host 10.10.10.20 range 53000 
56000

Después, la clase de tráfico llamada Voz se define, y se crea la correspondencia de políticas llamó policy1; un priority queue para la Voz de la clase se reserva con un porcentaje de ancho de banda permitido garantizado del 15 por ciento, un porcentaje de ancho de banda del 20 por ciento se configura para la clase llamada barra, y la clase predeterminada se configura para el flujo basado que hace cola favorablemente. service-policy El comando entonces asocia la correspondencia de políticas a la subinterfaz ATM 1/0.2.

Router(config)# class-map voice
Router(config-cmap)# match access-group 102

Router(config)# policy-map policy1
Router(config-pmap)# class voice
Router(config-pmap-c)# priority percent 15
Router(config-pmap)# class bar
Router(config-pmap-c)# bandwidth percent 20
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue

Router(config)# interface atm1/0.2
Router(config-subif)# service-policy output policy1

Ejemplo: Limitación del límite del anillo de la transmisión en una interfaz ATM

En el siguiente ejemplo, el número de partículas en el timbre de la transmisión de una interfaz ATM se limita a siete partículas:

Router(config)# interface atm 1/0/0
Router(config-if)# atm pvc 32 0 32 tx-ring-limit 7

Ejemplo: Limitación del límite del anillo de la transmisión en una subinterfaz atmósfera PVC

En el siguiente ejemplo, el número de partículas en el timbre de la transmisión de una subinterfaz atmósfera PVC se limita a diez partículas:

Router(config)# interface ATM1/0/0.1 point-to-point
Router(config-subif)# pvc 2/200
Router(config-if-atm-vc)# tx-ring-limit 10

tx-ring-limit El comando se puede aplicar a varias subinterfaces atmósfera PVC en una sola interfaz. Cada PVC individual puede configurar un límite del anillo de la transmisión.

Ejemplos: LLQ para la configuración de Frame Relay

La sección siguiente proporciona un LLQ por los ejemplos de la configuración de Frame Relay.

El siguiente ejemplo muestra cómo configurar un PVC formado a un 64K CIR con la fragmentación. La cola de modelado se configura con una clase para la Voz, dos clases de datos para el tráfico de la Prioridad IP, y una clase predeterminada para tráfico Best-Effort (mejor esfuerzo). El WRED se utiliza como la política para tirar paquetes en una de las clases de datos.

Los siguientes comandos definen las correspondencias de la clase y los criterios de concordancia para las correspondencias de la clase:

 !
 class-map voice
  match access-group 101
 !
 class-map immediate-data
  match access-group 102
 !
 class-map priority-data
  match access-group 103

 !
 access-list 101 permit udp any any range 16384 32767
 access-list 102 permit ip any any precedence immediate
 access-list 103 permit ip any any precedence priority

Los siguientes comandos crean y definen una correspondencia de políticas llamada mypolicy:

 !
 policy-map mypolicy
  class voice
   priority 16
  class immediate-data
   bandwidth 32
   random-detect
  class priority-data
   bandwidth 16
  class class-default
   fair-queue 64
   queue-limit 20

Los siguientes comandos habilitan la fragmentación de Frame Relay y asocian la correspondencia de políticas al DLCI 100:

 !
 interface Serial1/0.1 point-to-point
  frame-relay interface-dlci 100
    class fragment
 !
 map-class frame-relay fragment
  frame-relay cir 64000
  frame-relay mincir 64000
  frame-relay bc 640
  frame-relay fragment 50
  service-policy output mypolicy

Ejemplos: Tamaños de ráfaga en configuración de LLQ

El siguiente ejemplo configura el parámetro de ráfaga a 1250 bytes para la clase llamada la Voz, que tiene un ancho de banda asignado de 1000 kbps:

policy policy1
  class Voice
   priority 1000 1250

Ejemplos: Soporte de la cola de espera por VC para los adaptadores ATM

El siguiente ejemplo fija la cola de espera por VC a 55:

interface atm2/0.1
 pvc 1/101
  vc-hold-queue 55