Guía de Configuración de Bridging e IBM Networking de Cisco IOS, Versión 12.2SR
Configuración de Airline Product Set
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 332 KB | Inglés (9 Septiembre 2007) | Comentarios

Contenidos

Configuración de Airline Product Set

Descripción ALPS

Lista de tareas de configuración ALPS

Configurar los routeres remotos

Especificación de la Dirección IP de Peer Local ALPS

Especificación de la Dirección IP de Peer Remota ALPS

Especificación del Circuito ALPS

Especificación de cada ASCU

Configurar el router de centro de datos

Especificación de la Dirección de Peer Local Host ALPS

Especificación de AX.25

Especificación de EMTOX

Personalizar los mensajes de servicio

Personalizar las notificaciones de alarma

Puesta al día de un circuito

Verificar el ALPS

Monitoreo y Mantenimiento de ALPS

Ejemplos de configuración ALPS

Ejemplo de Configuración de ALPS con MATIP para ALC y UTS

Ejemplo de Configuración de ALPS para ALC y AX.25

Ejemplo de Configuración del ALPS para UTS y EMTOX


Configuración de Airline Product Set


Este capítulo describe cómo configurar el Airline Product Set (ALPS). Para una descripción completa de los comandos ALPS en este capítulo, refiera “al capítulo de los comandos Configuration del Airline Product Set” en la referencia del comando bridging and ibm networking del Cisco IOS (volumen 1 de 2). Para encontrar documentación de otros comandos que aparecen en este capítulo, utilice el índice principal de referencia de comandos, o busque en línea.

Este capítulo contiene las secciones siguientes:

Descripción ALPS

Lista de tareas de configuración ALPS

Monitoreo y Mantenimiento de ALPS

Ejemplos de configuración ALPS

Para identificar la información de la plataforma de hardware o de la imagen de software asociada con una función, utilice el Feature Navigator en Cisco.com para buscar información sobre la función o consulte las notas de versión del software para una versión específica. Para obtener más información, vea la sección "Identificación del Soporte de Plataformas para las Funciones de Cisco IOS Software" que se encuentra en la página li del capítulo "Uso de Cisco IOS Software".

Descripción ALPS

El ALPS es un mecanismo de tunelización que transporta los datos de protocolo de la línea aérea a través de una red basada en el router de Cisco TCP/IP a una unidad central. Esta característica proporciona la Conectividad entre las unidades de control determinadas del agente (ASCU) y un host de sistema central que funcione con el sistema de reserva aérea.

La característica ALPS fue liberada en tres fases. Las primeras dos fases de ALPS habilitaron la migración de la red al TCP/IP sin requerir ningunos cambios en el soporte físico o el software de los endstations (los ASCU y las unidades centrales). La fase I e II ALPS utilizó un nuevo protocolo, el Tunneling Protocol ALPS (ATP), para hacer un túnel el tráfico de protocolo de la línea aérea ([ALC] del control de la línea aérea P1024B o los datos del [UTS] del soporte de la terminal universal P1024C) a través de la red TCP/IP entre los routeres Cisco del par. Fase ALPS proporcioné al soporte para el protocolo ALC y al transporte de los datos de los ASCU a un sistema de reservas en un sistema central de IBM. Soporte proporcionado II de la fase ALPS para el protocolo UTS y el transporte de los datos de los ASCU a un sistema de reservas en un sistema del host de Unisys.

El cuadro 1 muestra una topología básica ALPS con el ALC, el UTS, el AX.25 y el intercambio del tráfico mezclado sobre los protocolos X.25 SVC (EMTOX). Tres componentes principales proporcionan el transporte de fin a fin del tráfico del protocolo airline a través de la red: el protocolo P1024B ALC o P1024C UTS, el Transport Protocol TCP basado, y el acceso AX.25/EMTOX a la unidad central.

Cuadro 1 ALPS con la arquitectura ALC y UTS

La fase III ALPS proporciona el soporte para asociar del tráfico de la línea aérea sobre el protocolo de Internet (MATIP). MATIP es un protocolo del estándar de la industria para transportar el tráfico de protocolo de la línea aérea a través de una red TCP/IP. Esta mejora habilita la salida de punta a punta de las secuencias de datos ALC y UTS entre un router Cisco y la unidad central usando el TCP/IP. El ALPS con MATIP quita (AX.25 o EMTOX) los requisitos X.25 para la comunicación con el sistema de reserva del host habilitando la comunicación TCP/IP entre el router y el sistema de reserva del host de la línea aérea.

El cuadro 2 muestra la topología básica ALPS y la arquitectura MATIP implementadas en la fase III. Tres componentes principales proporcionan el transporte de fin a fin del tráfico del protocolo airline a través de la red: el protocolo P1024B ALC o P1024C UTS, la conversión de protocolo TCP/IP basada MATIP, y el acceso TCP/IP a la unidad central.

Cuadro 2 ALPS con la arquitectura MATIP

En el Cisco IOS Release 12.1(2)T y Posterior, el ALPS soporta las adiciones y las Extensiones de los mensajes de servicio al soporte a protocolo ALPS P1024B ALC. Las adiciones incluyen las opciones personalizadas para configurar el formato, el direccionamiento, y el envío de los mensajes de servicio. El soporte ALPS ALC se amplía para ser más scalable. El soporte del debug ALPS ASCU se amplía para incluir la capacidad de la traza para el formato programable internacional de seis bits del sistema de reserva aérea (IPARS).

La característica de Cisco ALPS proporciona las siguientes ventajas:

Proporciona una solución de extremo a extremo para las líneas aéreas y los sistemas de reserva centrales.

Permite que las líneas aéreas substituyan su hardware y software existente por los routeres Cisco porque la característica ALPS se integra en el Cisco IOS Software. Para los clientes que ya utilizan routers Cisco, esta función permite consolidar el incremento y la funcionalidad de networking.

Habilita la salida de punta a punta de los datos ALC y UTS entre un router remoto o un gateway y la unidad central usando la encapsulación TCP/IP.

Elimina la tara de red para la detección de error y la lógica de la transmisión asociada al X.25 conecta.

Procesadores frontales de IBM de los reemplaces (FEP) con los procesadores de interfaz de canal (CIP).

Elimina el uso de las líneas seriales dedicadas, arrendadas, despacio ALC y UTS y emigra las redes de sistema de reserva a un paradigma moderno del establecimiento de una red. Una vez que el sistema de reserva de la unidad central se habilita para utilizar el TCP/IP, las nuevas aplicaciones se pueden escribir para PC o los equipos de red (NC).

Soporta el protocolo basado en estándares MATIP para transportar los datos a través de la red TCP/IP.

En el Cisco IOS Release 12.1(2)T y Posterior, el ALPS incluye el debug, el ALC, y las mejoras siguientes del mensaje de servicio.

Mejora del debug

Las adiciones del soporte del debug ALPS ASCU proporcionan las nuevas capacidades que le habilitan al resultado de la traza debug alps ascu del comando display en el formato IPARS.

Mejoras ALC

La stack del protocolo ALC ALPS incluye las siguientes extensiones:

Restauración automática ASCU

Aumento del rango del temporizador T1

Modificación de la lista de valor validada ASCU IA

Mejoras del mensaje de servicio

Las adiciones a los mensajes de servicio ALPS proporcionan las nuevas capacidades a las cuales habilitele:

Especifique el sita o el formato del mensaje de servicio de Apolo

Inhabilite la expedición de los mensajes de servicio para los cambios del estado del circuito ALPS

Especifique donde extraer el direccionamiento terminal para los mensajes de servicio caer-DATA

Inhabilite los mensajes de servicio específicos

Configure el texto de mensaje de servicio con una longitud creciente del carácter

En el Cisco IOS Release 12.1(3)T y Posterior, el ALPS incluye la mejora siguiente ALC.

Mejora ALC

La stack del protocolo ALC ALPS incluye las siguientes extensiones:

Soporte de Nonpolled ALC ASCU

Los soportes de característica ALPS teclean solamente el tráfico de protocolo conversacional A. La característica ALPS no soporta el tráfico del protocolo de mensajería del tráfico de protocolo del host-a-host del tipo A MATIP y del tipo B MATIP.

Los routeres remotos deben tener el chipset del Cirrus Logic CD2430 en un módulo de interfaz de serie sincrónico a conectar con el ALC o el UTS ASCU. El chipset CD2430 se soporta en las plataformas del router siguientes:

Cisco 2520, 2521, 2522, y 2523

Cisco 2600 Series

Cisco 3600 Series

Cisco 4500

Cisco 4700


Observeel Cisco4500 y las Plataformas del Cisco 4700 deben tener una alta densidad, indicador luminoso LED amarillo de la placa muestra gravedad menor de seriales de baja velocidad instalado. Dieciséis puertos de baja velocidad están disponibles para realizar las funciones del router remoto.


Los soportes de característica ALPS los estándares, el MIB y los RFC siguientes:

Estándares

Especificación del protocolo del control de comunicación P1024B, Societe Internationale de Telecommunications Aeronautiques

Especificación del protocolo del control de comunicación P1024C, Societe Internationale de Telecommunications Aeronautiques

Guía de instrumentación MATIP, Societe Internationale de Telecommunications Aeronautiques

MIB

Los soportes de característica ALPS el CISCO-ALPS-MIB y las mejoras siguientes MIB:

Extensiones al alpsIfP1024Table

Extensión al alpsAscuTable

Adición de notificaciones del Simple Network Management Protocol (SNMP) para la petición abierta abierta del error de la petición del circuito ALPS y del circuito ALPS con un rechazo parcial

Para las descripciones del MIB soportado y cómo utilizarlo, vea el Web site de Cisco MIB en el cisco.com.

RFC

RFC 2351, el asociar de la reserva aérea, el marcar, y tráfico de la Mensajería sobre el IP, mayo de 1998

Lista de tareas de configuración ALPS

Vea las secciones siguientes para las tareas de configuración para la característica ALPS. Cada tarea en la lista indica si la tarea es opcional o requerida. Las tareas en “que configuran la sección de los routeres remotos” son las únicas tareas requeridas para el ALPS con MATIP.

Para una descripción completa de los comandos ALPS en este módulo de función, refiera “al capítulo de los comandos Configuration del Airline Product Set” en la referencia del comando bridging and ibm networking del Cisco IOS (volumen 1 de 2). Para localizar la documentación de otros comandos, utilice el índice principal de referencia de comandos o busque en línea.

Configurando los routeres remotos (requeridos)

Configurando el router de centro de datos (requerido para el EMTOX y el AX.25, solamente)

Personalizando los mensajes de servicio (opcionales)

Personalizando las notificaciones de alarma (opcionales)

Poniendo al día un circuito (opcional)

Verificando el ALPS (requerido)

Vea “la sección de los ejemplos de configuración ALPS” para más información.

Configurar los routeres remotos


Observepara configurar el ALPS con MATIP, usted debe realizar solamente las tareas siguientes. Las tareas también se aplican al EMTOX y al AX.25, pero no se requieren.


Realice las tareas en las secciones siguientes de configurar la característica ALPS en los routeres remotos:

Especificación de la Dirección IP de Peer Local ALPS

Especificación de la Dirección IP de Peer Remota ALPS

Especificación del Circuito ALPS

Especificación de cada ASCU

Especificación de la Dirección IP de Peer Local ALPS

Usted debe identificar una dirección IP como peer local ALPS en el router remoto. Permiten a solamente un peer local ALPS en un router.

Para especificar la dirección IP del peer local ALPS, utilice los siguientes comandos en el modo de configuración global:

 
Comando
Propósito

Paso 1 

Router(config)# alps local-peer ipaddress [promiscuous]

Especifica una dirección IP para utilizar como el peer local ALPS en el router remoto.

Paso 2 

Router(config)# alps keepalive [interval time] [retry count]

Keepalifes TCP de los permisos para las conexiones de peer ALPS TCP.

Especificación de la Dirección IP de Peer Remota ALPS

Usted debe especificar una dirección IP del partner (peer remoto) en el router remoto. La conexión de peer puede ser permanente o dinámica (establecido a pedido). Usted puede configurar una conexión ATP para ser permanente o dinámico configurando la palabra clave optativa dynamic .


Las sesionesde la nota MATIP son dinámicas, independientemente de si dynamic la palabra clave está configurada. Para simular una conexión permanente en MATIP, configure dynamic la palabra clave con un valor del INACT-temporizador de cero.


Para especificar la dirección IP del partner para una o más conexiones de peer TCP al IP Address configurado, utilice el siguiente comando en el modo de configuración global:

Comando
Propósito

Router(config)# alps remote-peer ip-addr [protocol {atp | matip-a}] [status-interval interval] [status-retry retries] [dynamic [inact-timer] [no-circuit no-circ-timer]] [tcp-qlen [num]]

Especifica la dirección IP del partner. Si usted selecciona el protocolo ATP, usted debe configurar los routeres de centro de datos.

Especificación del Circuito ALPS

Un circuito ALPS es un trayecto de comunicación a través de una conexión TCP para uno o más ASCU. El circuito ALPS debe tener una asociación configurada con un peer remoto ALPS para establecer una conexión al host. Además, una configuración de circuito ALPS puede especificar a un diverso peer remoto como backup peer al host. Cada circuito MATIP asocia a una sola conexión TCP. Para el ATP, los circuitos ALPS se pueden multiplexar a través a una sola conexión TCP.

Para especificar un circuito ALPS, utilice los siguientes comandos que comienzan en el modo de configuración global:

 
Comando
Propósito

Paso 1 

Router(config)# alps circuit name

Especifica un circuito ALPS en el router remoto y ingresa el submode del circuito ALPS.

Paso 2 

Router(config-alps-circ)# alps primary-peer ip-addr [backup-peer ip-addr]

Especifica el par primario TCP y a un backup peer opcional para este circuito ALPS.

Paso 3 

Router(config-alps-circ)# alps local-hld loc-hld remote-hld rem-hld

Especifica el diseñador de alto nivel local (HLD) para este circuito ALPS. remote-hld La palabra clave es no corresponde para el ALPS con MATIP. La ubicación-hld es el hld del dispositivo se está substituyendo que. El REM-hld es el hld del sistema central del host.

Paso 4 

Router(config-alps-circ)# alps hostlink number {ax25 lcn | emtox x121-addr} [winout val1] [winin val2] [ops val3] [ips val4]

Especifica la información requerida establecer un circuito virtual X.25 en el CPE central.

Paso 5 

Router(config-alps-circ)# alps connection-type permanent [retry-timer]

(Opcional) especifica que este circuito debe ser establecido cuando se habilita el circuito.

Paso 6 

Router(config-alps-circ)# alps lifetime-timer timer

(Opcional) especifica cuánto tiempo los mensajes se pueden hacer cola en la cola del circuito ALPS.

Paso 7 

Router(config-alps-circ)# alps service-msg-interval seconds

(Opcional) especifica el intervalo entre la transmisión de un mensaje de servicio a un ASCU y la transmisión POR FAVOR de un mensaje del REVISAR. El mensaje del REVISAR se transmite POR FAVOR solamente a los ASCU que utilizan los circuitos con un tipo de conexión dinámica.

Paso 8 

Router(config-alps-circ)# alps service-msg-list list

(Opcional) define la lista del mensaje de servicio que se utilizará para este circuito.

Paso 9 

Router(config-alps-circ)# alps matip-close-delay time

(Opcional) especifica el intervalo entre el closing y la reapertura de la conexión de circuito MATIP.

Paso 10 

Router(config-alps-circ)# alps idle-timer timer

(Opcional) especifica (para los circuitos dinámicos) la longitud del tiempo que puede transcurrir antes de que se inhabilite un circuito ocioso.

Paso 11 

Router(config-alps-circ)# alps mpx {group | single} hdr {a1a2 | none}

(Opcional) especifica la multiplexación y la encabezado de la identificación ASCU para este circuito.

Paso 12 

Router(config-alps-circ)# alps enable-circuit

Habilita el circuito.

Especificación de cada ASCU

Usted debe configurar cada ASCU en el contexto de la configuración de la interfaz serial. Usted debe configurar la información de direccionamiento y la asociación ASCU con un ASCU. Usted puede configurar los temporizadores, los tamaños máximos del marco, los valores de reintentos, y los parámetros de la configuración optativa del modo de interrogación para cada ASCU. Los parámetros predeterminados apropiados se utilizan para los parámetros sin especificar. Una vez que usted configura el primer ASCU, usted puede configurar los ASCU adicionales usando solamente los pasos 8 a 14.

Para especificar un ASCU, utilice los siguientes comandos que comienzan en el modo de configuración global:

 
Comando
Propósito

Paso 1 

Router(config)# interface type number

Configura una interfaz y entra en el modo de configuración de interfaz.

Paso 2 

Router(config-if)# encapsulation [alc | uts]

Especifica el protocolo que se utilizará en la interfaz serial.

Paso 3 

Router(config-if)# alps t1 delay

(Opcional) especifica el retardo del descanso entre la transmisión de un mensaje de la encuesta ALC y el recibo del primer carácter del mensaje de respuesta de la encuesta.

Paso 4 

Router(config-if)# alps t2 delay

(Opcional — El ALC solamente) especifica el retardo del descanso entre el recibo del primer carácter de la respuesta a un mensaje de la encuesta y el recibo de un mensaje del ir a continuación. Se aplica al ALC, solamente.

Paso 5 

Router(config-if)# alps n1 errors

(Opcional) especifica el umbral de los errores consecutivos registrados antes de que un ASCU se declare abajo.

Paso 6 

Router(config-if)# alps n2 polls

(Opcional) especifica el número de encuestas a las cuales deba ser contestado correctamente antes de que un ASCU se declare para arriba.

Paso 7 

Router(config-if)# alps n3 value

(Opcional — El UTS solamente) especifica el número máximo de retransmisiones de un mensaje de datos no reconocido de la salida a un ASCU. Se aplica solamente al UTS.

Paso 8 

Router(config-if)# alps servlim polls

(Opcional) especifica el número de ciclos de la lista de encuesta activa para ejecutar antes de sondear el ASCU siguiente en la lista de encuesta inactiva.

Paso 9 

Router(config-if)# transmitter-delay delay

Especifica el número de caracteres de relleno agregados al final del bastidor (tiempo muerto mínimo después de transmitir un paquete).

Paso 10 

Router(config-if)# half-duplex

Especifica al modo semidúplex en una interfaz serial.

Este comando especifica si el control de flujo de hardware (Request To Send constante o conmutado [RTS]) debe ser utilizado entre un DTE y un dispositivo DCE.

Si es semidúplex se especifica para un DTE, el DTE aumenta el RTS y espera el DCE para aumentar el Clear To Send (CTS) antes de enviar.

Si es semidúplex se especifica para un DCE, el DCE espera el DTE para aumentar el RTS, después el DCE aumenta el CTS para permitir que el DTE envíe.

Si se especifica el FULL-duplex, se asume el RTS y el CTS no se monitorea.

Observeel ALPS apoya los comandos serial interface que están disponibles si especifican al modo semidúplex. Este soporte se aplica a una interfaz que se configure como el equipo circuito-terminal de los datos (DCE) y equipo de terminal de datos (DTE).


Paso 11 

Router(config-if)# alps poll-pause msec

(Opcional) especifica el intervalo mínimo, en los milisegundos, entre los lanzamientos del ciclo de sondeo.

Paso 12 

Router(config-if)# alps service-msg data-drop {msg-term | config-term}

(Opcional) especifica donde extraer el direccionamiento terminal para utilizar cuando un mensaje de servicio se envía a un ASCU como resultado de un mensaje de datos caído de una terminal.

Paso 13 

Router(config-if)# alps service-msg format {sita | apollo}

(Opcional) especifica el formato del protocolo de los mensajes de servicio enviados del router a un ASCU.

Paso 14 

Router(config-if)# alps service-msg status-change

(Opcional) especifica que los mensajes de servicio para los cambios del estado del circuito ALPS serán enviados a los ASCU en la interfaz serial.

Paso 15 

Router(config-if)# alps ascu id

Especifica una identidad física ASCU (el valor del Interchange Address ASCU para el ALC) y ingresa el submode ALPS ASCU.

Paso 16 

Router(config-alps-ascu)# alps default-circuit name

Especifica el circuito ALPS que este ASCU utiliza.

Paso 17 

Router(config-alps-ascu)# alps a1-map a1-value a2-map a2-value

Especifica la información de identificación lógica A1 y del a2 ASCU.

Paso 18 

Router(config-alps-ascu)# alps retry-option [resend | reenter]

(Opcional) especifica la opción de la recomprobación cuando un mensaje ALC con un mún carácter de control cíclico (CCC) se recibe.

Paso 19 

Router(config-alps-ascu)# alps max-msg-length value

(Opcional) especifica la longitud de mensaje de entrada máxima.

Paso 20 

Router(config-alps-ascu)# alps error-display number1 number2

(Opcional) especifica donde se visualizan los mensajes de error:

Para P1024B ALC, el argumento number1 especifica el direccionamiento terminal (TA) donde se envían estos mensajes de servicio y el argumento number2 especifica el número de línea de la pantalla donde se visualizan los mensajes de servicio.

Para P1024C UTS, el argumento number1 especifica el número de línea de la pantalla donde se visualizan los mensajes de servicio y el argumento number2 especifica el número de columna donde se visualizan los mensajes de servicio.

Paso 21 

Router(config-alps-ascu)# alps auto-reset

(Opcional) reajusta automáticamente ALC no sensible ASCU en el estado inactivo.

Paso 22 

Router(config-alps-ascu)# alps alias alias-interchange-address

(Opcional) especifica que un ALC ASCU es actuar en el modo nonpolling y especifica el Interchange Address del padre ASCU a las cuales este ASCU es aliased.

Paso 23 

Router(config-alps-ascu)# alps enable-ascu

Sondea el ASCU.

Configurar el router de centro de datos


Observeestas tareas se aplican al EMTOX y al AX.25, solamente.


Realice las tareas en las secciones siguientes de configurar la característica ALPS en el router de centro de datos:

Especificación de la Dirección de Peer Local Host ALPS

Especificación de AX.25

Especificación de EMTOX

Especificación de la Dirección de Peer Local Host ALPS

Usted debe identificar una dirección IP para utilizar como la dirección IP del peer local ALPS. Permiten a solamente un peer local del host ALPS en un router. La opción promiscua, que permite que cualquier router remoto conecte, se recomienda en el CPE central.

Para especificar el direccionamiento del peer local del host ALPS, utilice el siguiente comando en el modo de configuración global:

Comando
Propósito

Router(config)# alps local-peer ip-address [promiscuous]

Especifica la dirección IP del peer local.


Especificación de AX.25

Para habilitar el AX.25 en una interfaz X.25, el host HLD ALPS y el número del hostlink deben ser configurados y el AX.25 se debe especificar en una interfaz serial X.25. En el tiempo del Establecimiento del circuito, el router remoto adelante el host HLD, el Número del canal lógico (LCN), y el número del hostlink para el circuito virtual permanente (PVC), para ser utilizado para el grupo ASCU.

Para configurar el AX.25 en una interfaz X.25, utilice los siguientes comandos que comienzan en el modo de configuración global:

 
Comando
Propósito

Paso 1 

Router(config)# interface type number

Configura una interfaz y entra en el modo de configuración de interfaz.

Paso 2 

Router(config-if)# encapsulation x25

Especifica una interfaz serial como dispositivo X.25.

Paso 3 

Router(config-if)# alps host-hld hld host-link num {{ax25 [damp-tmr value]} | {emtox x.121 [pseudo-conv]}} [life-tmr value]

Habilita ALPS en la interfaz X.25.

Especificación de EMTOX

Para habilitar el EMTOX en una interfaz X.25, el host HLD y el número del hostlink deben ser configurados y el EMTOX se debe especificar en una interfaz serial X.25. En el tiempo del Establecimiento del circuito, el router remoto adelante el X.121 Address para ser utilizado como la dirección llamadora en la llamada X.25 y el host HLD y el número del hostlink. Si el host realiza un decir en voz alta, una correlación entre la dirección a la que se llamó X.121 y un IP Address de Peer del router remoto debe ser configurada.

Para configurar el EMTOX en una interfaz X.25, utilice los siguientes comandos que comienzan en el modo de configuración global:

 
Comando
Propósito

Paso 1 

Router(config)# interface type number

Configura una interfaz y entra en el modo de configuración de interfaz.

Paso 2 

Router(config-if)# encapsulation x25

Especifica una interfaz serial como dispositivo X.25.

Paso 3 

Router(config-if)# alps host-hld hld host-link num {{ax25 [damp-tmr value]} | {emtox x.121 [pseudo-conv]}} [life-tmr value]

Habilita ALPS en la interfaz X.25.

Paso 4 

Router(config-if)# alps translate x.121-addr ip-addr

Asocia un X.121 Address a una dirección IP en un peer remoto.

Personalizar los mensajes de servicio

Usted puede personalizar el contenido de los mensajes de servicio y de la lista del mensaje de servicio. Para especificar el número de mensaje de servicio y el contenido del mensaje, utilice el siguiente comando en el modo de configuración global:

Comando
Propósito

Router(config)# alps service-msg-list list number number msg

Especifica los números y el contenido de mensaje de servicio.



Observeel mensaje de servicio predeterminado se utiliza si no se especifica ningún número de lista del mensaje de servicio. Si usted configura un mensaje de servicio determinado en una lista, el mensaje de servicio predeterminado todavía se utiliza para el resto de los mensajes en esa lista.



Observeuna vez que alps service-msg-list number el comando se ha configurado, usted puede definir la lista del mensaje de servicio que se utilizará en el circuito configurando alps service-msg-list el comando.



Notausted puede configurar la dirección de los mensajes de servicio usando alps service-msg data-drop alps service-msg format, y alps service-msg status-change los comandos del configuración-nivel de la interfaz.


El cuadro 1 muestra las cadenas de mensaje de texto del servicio predeterminado:

Cadenas de texto predeterminadas del mensaje de servicio del cuadro 1

Número de mensaje
Evento
Cadena de texto

1

El circuito ALPS a recibir se abre.

CONEXIÓN PARA ARRIBA

2

El circuito virtual X.25 en el host se ha borrado.

DISC POR EL HOST

3

La interfaz X.25 en el host está abajo.

HOST AISLADO

4

Ninguna respuesta del router del host al intentar establecer una conexión.

PROBLEMA DE RED

5

La conexión a recibir era disconnected debido a la inactividad.

ALISTE PARA CONECTAR

6

Se congestiona la red.

CONGESTIÓN

7

La congestión de red ha borrado.

PROCEDA POR FAVOR

8

El operador de la red ha inhabilitado la trayectoria al host.

DISC POR LA RED OPERAT


Personalizar las notificaciones de alarma

Usted puede habilitar y personalizar las alarmas (mensajes de error) y el SNMP traps. Para habilitar y personalizar las alarmas para el ALPS ASCU, los circuitos, o los pares, utilizan los siguientes comandos en el modo de configuración global:

Comando
Propósito

Router(config)# alps enable-alarms ascu [interface id]

Alarmas de los permisos para el ALPS ASCU.

Router(config)# alps enable-alarms circuit [name]

Alarmas de los permisos para los circuitos ALPS.

Router(config)# alps enable-alarms peer [ip-address]

Alarmas de los permisos para los pares ALPS.

Puesta al día de un circuito

Usted puede borrar o poner al día los circuitos en la red ALPS. Si se ingresa un nombre específico, la acción de la actualización será ejecutada solamente en un circuito configurado con ese nombre; si no, la acción será realizada en todos los circuitos configurados. Si el circuito utiliza el protocolo ATP, una actualización consiste en un closing y una reapertura del circuito ALPS (la misma acción realizada al borrar el circuito). Si el circuito es un circuito MATIP, la actualización da lugar al envío de una actualización de la configuración (bajo la forma de comando Open de la sesión MATIP). Usted puede poner al día el circuito solamente en (estado abierta o de la apertura) los circuitos habilitados o activos ALPS.

Para poner al día uno o más circuitos ALPS, utilice el siguiente comando en el modo EXEC:

Comando
Propósito

Router# alps update-circuit [name]

Especifica el nombre del circuito para ponerse al día.


Verificar el ALPS

Realice las tareas en los pasos siguientes de verificar los componentes de la red ALPS:


Paso 1Verifique que la conexión entre el router y el ASCU esté para arriba sondeando el ASCU. Ingrese show alps ascu el comando y marque el campo de estado. ENCIMA DE indica que el ASCU está respondiendo a la interrogación. ABAJO indica que la conexión no está respondiendo a la interrogación.

router# show alps ascu

interface    dlc   id   a1   a2   circuit    pkt_tx  pkt_rx  state
-------------------------------------------------------------------------------------
Serial6      ALC   42   60   70   CKT_ALC_1  416     416     UP
Serial6      ALC   45   60   72   CKT_ALC_1  600     600     UP
Serial6      ALC   48   62   78   CKT_ALC_2  0       0       DOWN
Serial7      UTS   21   22   13   CKT_UTS    4830    4830    UP

Paso 2Verifique que el par entre el router y el host esté conectado. Ingrese show alps peer el comando y marque el campo de estado. ABIERTO indica que el circuito está conectado. DISCONN indica que el circuito es disconnected.

router# show alps peers

local_peer : ip_address = 192.168.25.2

ip_address     conn_id             state    pkt_t  pkt_rx
-------------------------------------------------------------------------------------
192.168.20.3   MATIP_A_CKT_UTS     OPENED   1023   1023
192.168.70.2   MATIP_A_CKT_ALC_1   OPENED   4852   4757
192.168.70.2   MATIP_A_CKT_ALC_2   OPENED   1      1
192.168.70.3   MATIP_A_CKT_ALC_1   DISCONN  0      0
192.168.70.3   MATIP_A_CKT_ALC_2   DISCONN  0      0

Paso 3Verifique que el circuito ALPS al host del par sea abierto y conectado. Ingrese show alps circuits el comando y marque el campo de estado. ABIERTO indica que el circuito está conectado. El INOP indica que el circuito es disconnected.

router# show alps circuits

name        pri_peer       curr_peer      dlc   state  pkt_tx  pkt_rx
-------------------------------------------------------------------------------------
ALC_EMTOX   192.168.45.2   192.168.45.2   ALC   OPEN   944     944
UTS_AX25    192.168.45.2   192.168.45.2   UTS   OPEN   425     425

Monitoreo y Mantenimiento de ALPS

Para monitorear el estatus de la característica ALPS, utilice los siguientes comandos en el modo EXEC:

Comando
Propósito
Router# show alps ascu [interface] [id] [detail]

Visualiza el estatus del ALPS ASCU.

Router# show alps circuits [peer ip address] [name name] 
[detail]

Visualiza el estatus de los circuitos ALPS.

Router# show alps peers [ipaddress addr] [detail]

Visualiza el estatus de los peeres remotos ALPS.

Ejemplos de configuración ALPS

Esta sección proporciona los siguientes ejemplos de configuración:

Ejemplo de Configuración de ALPS con MATIP para ALC y UTS

Ejemplo de Configuración de ALPS para ALC y AX.25

Ejemplo de Configuración del ALPS para UTS y EMTOX

Ejemplo de Configuración de ALPS con MATIP para ALC y UTS

El cuadro 3 muestra un ejemplo simple de una topología del router para el ALPS con la característica MATIP. La configuración correspondiente a esta topología sigue.

Figure la topología del 3 Router para el ALPS con el ejemplo de configuración MATIP

Configuración del router ALC/UTS

(config)# hostname alps-rcpe
(config)# alps local-peer 192.168.25.2
(config)# alps keepalive interval 45 retry 2
(config)# alps remote-peer 192.168.20.3 protocol matip-a dynamic status-interval 60
(config)# alps remote-peer 192.168.70.2 protocol matip-a dynamic 0 no-circuit 10
(config)# alps remote-peer 192.168.70.3 protocol matip-a dynamic 45
(config)# alps enable-alarms peer 192.168.70.2
(config)# alps enable-alarms ascu
!
(config)# alps circuit CKT_ALC_1
(config-alps-circ)# alps primary-peer 192.168.70.2 backup-peer 192.168.70.3
(config-alps-circ)# alps connection-type permanent
(config-alps-circ)# alps local-hld 2525
(config-alps-circ)# alps enable-circuit
!
(config)# alps circuit CKT_UTS
(config-alps-circ)# alps primary-peer 192.168.20.3
(config-alps-circ)# alps mpx single
(config-alps-circ)# alps idle-timer 90
(config-alps-circ)# alps local-hld 2527
(config-alps-circ)# alps enable-circuit
(config-alps-circ)# alps service-msg-interval 2
!
(config)# interface Loopback0
(config-if)# ip address 192.168.25.2 255.255.255.0
(config)# interface Serial0
(config-if)# ip address 210.100.50.2 255.255.255.0
(config-if)# encapsulation frame-relay IETF
(config-if)# frame-relay map ip 210.100.60.2 40
(config-if)# frame-relay map ip 210.100.70.2 50
!
(config)# interface Serial6
(config-if)# encapsulation alc
(config-if)# alps t1 6
(config-if)# alps t2 8
(config-if)# alps poll-pause 100
(config-if)# clockrate 9600
!
(config-if)# alps ascu 42
(config-alps-ascu)# alps default-circuit CKT_ALC_1
(config-alps-ascu)# alps a1-map 60 a2-map 70
(config-alps-ascu)# alps enable-ascu
!
(config-if)# alps ascu 45
(config-alps-ascu)# alps default-circuit CKT_ALC_1
(config-alps-ascu)# alps a1-map 60 a2-map 72
(config-alps-ascu)# alps enable-ascu
!
(config)# interface Serial7
(config-if)# encapsulation uts
(config-if)# alps n3 4
(config-if)# alps poll-pause 125
(config-if)# clockrate 4800
!
(config-if)# alps ascu 21
(config-alps-ascu)# alps default-circuit CKT_UTS
(config-alps-ascu)# alps a1-map 22 a2-map 13
(config-alps-ascu)# alps enable-ascu
!

Ejemplo de Configuración de ALPS para ALC y AX.25

El cuadro 4 muestra una topología del router simple para la característica ALPS con la encapsulación ALC. La configuración para esta topología sigue.

Figure la topología del 4 Router para la configuración ALPS por el ejemplo de la encapsulación ALC

Configuración de CPE remota

(config)# alps local-peer 172.22.0.90
(config)# alps keepalive interval 60
(config)# alps remote-peer 172.22.0.91 
(config)# alps remote-peer 172.22.0.92 dynamic 60
(config)# alps service-msg-list 1 number 2 TERMINAL OFF
!
(config)# alps circuit CKT1
(config-alps-circ)# alps primary-peer 172.22.0.91 backup-peer 172.22.0.92
(config-alps-circ)# alps local-hld 4B09 remote-hld 5C00
(config-alps-circ)# alps connection-type permanent 30
(config-alps-circ)# alps lifetime-timer 3
(config-alps-circ)# alps hostlink 3 ax25 120 winout 3 winin 3
(config-alps-circ)# alps service-msg-interval 3
(config-alps-circ)# alps service-msg-list 1
(config-alps-circ)# alps enable-circuit
!
(config)# alps circuit CKT2
(config-alps-circ)# alps primary-peer 172.22.0.91 backup-peer 172.22.0.92
(config-alps-circ)# alps local-hld 4C01 remote-hld 5C00
(config-alps-circ)# alps hostlink 3 ax25 1500 winout 4 winin 5
(config-alps-circ)# alps enable-circuit
!
(config)# alps circuit CKT3
(config-alps-circ)# alps primary-peer 172.22.0.91
(config-alps-circ)# alps local-hld 4B10 remote-hld 5C00
(config-alps-circ)# alps connection-type permanent 30
(config-alps-circ)# alps lifetime-timer 6
(config-alps-circ)# alps hostlink 3 ax25 905 
(config-alps-circ)# alps enable-circuit
!
(config)# interface serial 1
(config-if)# ip address 172.22.0.90 255.255.255.0
!
(config)# interface serial 2
(config-if)# encapsulation alc
(config-if)# alps t1 3
(config-if)# alps t2 6
(config-if)# alps n1 3
(config-if)# alps n2 2
(config-if)# alps servlim 20
!
(config-if)# alps ascu 51
(config-alps-ascu)# alps default-circuit CKT1
(config-alps-ascu)# alps a1-map 40 a2-map 2D
(config-alps-ascu)# alps retry-option resend
(config-alps-ascu)# alps max-msg-length 1950
(config-alps-ascu)# alps error-display 6d 78
(config-alps-ascu)# alps enable-ascu
!
(config-if)# alps ascu 44
(config-alps-ascu)# alps default-circuit CKT1
(config-alps-ascu)# alps a1-map 40 a2-map 2E
(config-alps-ascu)# alps max-msg-length 590
(config-alps-ascu)# alps error-display 6d 78
(config-alps-ascu)# alps enable-ascu
!
(config-if)# alps ascu 7E
(config-alps-ascu)# alps default-circuit CKT2
(config-alps-ascu)# alps a1-map 40 a2-map 2F
(config-alps-ascu)# alps retry-option re-send
(config-alps-ascu)# alps max-msg-length 2000
(config-alps-ascu)# alps error-display 6d 78
(config-alps-ascu)# alps enable-ascu

(config)# interface serial 3
(config-if)# encapsulation alc
(config-if)# alps t1 5
(config-if)# alps t2 6
(config-if)# alps n1 1
(config-if)# alps n2 2
(config-if)# alps servlim 20
!
(config-if)# alps ascu 4B
(config-alps-ascu)# alps default-circuit CKT3
(config-alps-ascu)# alps a1-map 63 a2-map 41
(config-alps-ascu)# alps retry-option re-send
(config-alps-ascu)# alps max-msg-length 1960
(config-alps-ascu)# alps error-display 6d 78
(config-alps-ascu)# alps enable-ascu

(config-if)# alps ascu 66 
(config-alps-ascu)# alps default-circuit CKT2 
(config-alps-ascu)# alps a1-map 71 a2-map 21
(config-alps-ascu)# alps max-msg-length 3800
(config-alps-ascu)# alps error-display 6d 78
(config-alps-ascu)# alps enable-ascu

Configuración de CPE central (principal)

Host AX.25

(config)# alps local-peer 172.22.0.91 promiscuous
(config)# interface serial 0
(config-if)# encapsulation x25 ax25
(config-if)# x25 ltc 1024
(config-if)# alps host-hld 5C00 host-link 3 ax25

Configuración de CPE central (respaldo)

Host AX.25

(config)# alps local-peer 172.22.0.92 promiscuous
(config)# interface serial 0
(config-if)# encapsulation x25 ax25
(config-if)# x25 ltc 1024
(config-if)# alps host-hld 5C00 host-link 3 ax25

Ejemplo de Configuración del ALPS para UTS y EMTOX

La configuración siguiente es un ejemplo de rutear el marco de datos P1024C UTS a través de la red entre la central y el equipo remoto.

Configuración remota del router

(config)# hostname alps-rcpe
(config)# alps local-peer 200.100.25.2
(config)# alps keepalive interval 45 retry 5
(config)# alps remote-peer 200.100.40.2
(config)# alps enable-alarms peer 200.100.40.2
(config)# alps enable-alarms ascu

(config)# alps circuit UTS_EMTOX
(config-alps-circ)# alps primary-peer 200.100.40.2
(config-alps-circ)# alps idle-timer 90
(config-alps-circ)# alps local-hld 2525 remote-hld 5050
(config-alps-circ)# alps mpx single
(config-alps-circ)# alps hostlink 6 emtox 1100 ops 512 ips 512
(config-alps-circ)# alps service-msg-interval 2
(config-alps-circ)# alps enable-circuit

(config)# interface Loopback0
(config-if)# ip address 200.100.25.2 255.255.255.0

(config)# interface Serial0
(config-if)# ip address 200.100.50.2 255.255.255.0
(config-if)# encapsulation frame-relay IETF
(config-if)# frame-relay map ip 200.100.50.3 20
(config)# interface Serial1
(config-if)# encapsulation uts
(config-if)# alps n1 5
(config-if)# alps n3 4
(config-if)# alps poll-pause 200
(config-if)# clockrate 4800
!
(config-if)# alps ascu 21
(config-alps-ascu)# alps default-circuit UTS_EMTOX
(config-alps-ascu)# alps a1-map 22 a2-map 13
(config-alps-ascu)# alps enable-ascu
!

Configuración de CPE central

(config)# hostname alps-ccpe
(config)# alps local-peer 200.100.40.2 promiscuous
(config)# alps enable-alarms circuit
!
(config)# interface Loopback0
(config-if)# ip address 200.100.40.2 255.255.255.0
!
(config)# interface Serial0
(config-if)# ip address 200.100.50.3 255.255.255.0
(config-if)# encapsulation frame-relay IETF
(config-if)# clockrate 56000
(config-if)# frame-relay map ip 200.100.50.2 20
!
(config)# interface Serial2
(config-if)# encapsulation x25 dce
(config-if)# alps host-hld 5050 host-link 6 emtox 2222
(config-if)# alps translate 110* 200.100.25.2
(config-if)# clockrate 64000