Guía de Configuración de NetFlow de Cisco IOS, Versión 12.2SR
NDE para Interfaces VRF
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 309 KB | Inglés (26 Diciembre 2006) | Comentarios

Contenidos

NDE para Interfaces VRF

Encontrar la información de la característica

Contenido

Prerrequisitos de NDE for VRF Interfaces

Restricciones de NDE para Interfaces VRF

Información sobre NDE para Interfaces VRF

Ejemplo de una Red MPLS VPN

Análisis del Tráfico que Sale de la Red MPLS VPN con NetFlow

Etiquetas Agregadas MPLS

Escrituras de la etiqueta salvadas del agregado MPLS

Más de 511 escrituras de la etiqueta salvadas del agregado MPLS

Ocupación de la Memoria Caché de NetFlow

Escrituras de la etiqueta del agregado MPLS en VPN CAM

Escrituras de la etiqueta del agregado MPLS no en VPN CAM

Escrituras de la etiqueta MPLS-específicas

Configurar la captura y la exportación del Netflow del MPLS VPN

Nombre VRF como Interfaz de Origen en la Memoria Caché de NetFlow

Cómo Configurar NDE para Interfaces VRF para una VPN MPLS

Ejemplos de Configuración para NDE for VRF Interfaces

Configuraciones para la Red de Ejemplo con una MPLS VPN: Ejemplo:

Configuración de la Función NDE for VRF Interfaces en un VRF: Ejemplo:

Adonde ir después

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Información de Función para NDE for VRF Interfaces


NDE para Interfaces VRF


Primera publicación: De febrero el 27 de 2007
Última actualización: De agosto el 09 de 2010

La Exportación de datos de NetFlow (NDE) para la característica de las interfaces VRF habilita la creación y la exportación de las entradas del caché de NetFlow del hardware para el tráfico que ingresa a un router en el salto más reciente del (MPLS) del Multi-Protocol Label Switching de un Red privada virtual (VPN) del IPv4 MPLS. El NDE para la característica de las interfaces VRF también se asegura de que los datos recogidos en el caché de NetFlow del hardware para el tráfico que se recibe en una interfaz del IPv4 configurada para una tabla de reenvío del por-sitio (VRF) contengan el específico de la información de ruteo al VRF.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea que la “información de la característica para el NDE para el VRF interconecta” la sección.

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Prerrequisitos de NDE for VRF Interfaces

Restricciones de NDE para Interfaces VRF

Información sobre NDE para Interfaces VRF

Cómo Configurar NDE para Interfaces VRF para una VPN MPLS

Ejemplos de Configuración para NDE for VRF Interfaces

Adonde ir después

Referencias adicionales

Información de Función para NDE for VRF Interfaces

Prerrequisitos de NDE for VRF Interfaces

Su router debe ser Cisco IOS Release 12.2(33)SRB o Posterior corriente para configurar el NDE para la característica de las interfaces VRF.

Restricciones de NDE para Interfaces VRF

El NDE para el VRF interconecta el tráfico del IPv4 de los soportes de característica solamente.

Cuando usted configura el NDE para el VRF interconecta la característica para un MPLS VPN, el router asigna un VLAN ID reservado al MPLS VPN. Esto limitará el número de identificaciones de VLAN disponibles para las otras funciones que usted configura en el router y que requieren las identificaciones de VLAN.

Información sobre NDE para Interfaces VRF

Antes de configurar el NDE para las interfaces característica VRF, usted debe entender los conceptos siguientes:

Ejemplo de una Red MPLS VPN

Análisis del Tráfico que Sale de la Red MPLS VPN con NetFlow

Etiquetas Agregadas MPLS

Ocupación de la Memoria Caché de NetFlow

Nombre VRF como Interfaz de Origen en la Memoria Caché de NetFlow

Ejemplo de una Red MPLS VPN

El cuadro 1 es un ejemplo de un Red privada virtual (VPN) simple MPLS. Configuran al Routers PE1 y PE2 para soportar un MPLS VPN para llevar el tráfico del cliente entre los sitios en donde localizan al Routers CE1 y CE2. El Routers PE1 y PE2 utiliza a los pares del iBGP del multi-protocol para rutear el tráfico en el MPLS VPNs. El NDE para la característica de las interfaces VRF es aplicable al Routers PE1 y PE2 en este ejemplo.

Cuadro 1 ejemplo de una red simple del MPLS VPN

Para más información sobre configurar el MPLS en los Cisco 7600 Series Router, vea el capítulo configurando el Multiprotocol Label Switching (MPLS) del PFC3BXL y del PFC3B en la guía de configuración del Cisco IOS Software de las Cisco 7600 Series.

Análisis del Tráfico que Sale de la Red MPLS VPN con NetFlow

El NDE para las interfaces VRF que las capturas de la característica trafican recibido por el router en la interfaz del MPLS VPN VRF como él sale la red MPLS. Por ejemplo, cuando usted configura el NDE para la característica de las interfaces VRF en el rojo VPN en el PE2 tal y como se muestra en del cuadro 2, y el tráfico a y desde el CE2 se asigna al rojo VRF, el tráfico se agrega al caché de NetFlow y se muestra como siendo recibido en el rojo VPN.

Cuadro 2 ejemplo de un router (PE2) que recibe el tráfico sobre una interfaz del MPLS VPN VRF

Etiquetas Agregadas MPLS

Hay dos tipos de escrituras de la etiqueta VPN MPLS:

Escrituras de la etiqueta del agregado para el tráfico en el cual una decisión de ruteo debe ser tomada

No escrituras de la etiqueta (específicas) del agregado.

Cuando usted configura un MPLS VPN en un router PE el router afecta un aparato una escritura de la etiqueta del agregado MPLS para el VPN.

Puesto que las escrituras de la etiqueta del agregado MPLS corresponden al VRF al cual un paquete pertenece, el router debe consultar la tabla de ruteo para que un VRF determine el IP Address de Next Hop correcto dentro del dominio VPN para remitir el paquete. Se requiere el IP Address de Next Hop antes de que el router pueda remitir el paquete porque los dominios VPN son capaces de soportar a los Next Hop Router múltiples. Por ejemplo, en el cuadro 2 hay dos Routers CE: CE2 y CE3. El tráfico MPLS que llegaba en el rojo VPN en el PE1 se podía destinar a los hosts asociados al CE2 o al CE3. El PE2 debe realizar otras operaciones de búsqueda para identificar el router CE correcto a las cuales el tráfico debe ser remitido. El método que el PE2 utiliza para realizar las operaciones de búsqueda del IP Address de Next Hop depende del número de escrituras de la etiqueta del agregado MPLS que el router ha salvado.

Escrituras de la etiqueta salvadas del agregado MPLS

Trafique que las aplicaciones una de las primeras 511 escrituras de la etiqueta globales MPLS son remitidas por el router basado en la entrada para la escritura de la etiqueta del MPLS VPN en la memoria de contenido direccionable VPN (CAM).

Los pasos siguientes son realizados por un router PE para remitir el tráfico MPLS que las aplicaciones una de las primeras 511 escrituras de la etiqueta globales MPLS:

1. Un paquete MPLS que lleva una escritura de la etiqueta de la agregación llega el router de la salida PE.

2. Las operaciones de búsqueda en el VPN CAM se realizan para la escritura de la etiqueta de la agregación MPLS.

3. Se quita la escritura de la etiqueta de la agregación MPLS y el VPN correspondiente ID para el paquete se identifica.

4. El índice del VPN CAM se utiliza para referirse a la tabla de ruteo del MPLS VPN.

5. Las operaciones de búsqueda se realizan para el prefijo IP de destino en el VPN VRF que fue derivado de la tabla del MPLS VPN. El resultado de búsqueda contiene el IP Address de Next Hop y el resto de la información de reescritura necesarios para remitir el paquete al router CE correcto.

Más de 511 escrituras de la etiqueta salvadas del agregado MPLS

Cuando el número de escrituras de la etiqueta del agregado MPLS en la red excede de 511, el router puede salvar no más algunas escrituras de la etiqueta del agregado MPLS en su VPN CAM. En esta situación el router consulta el MPLS FIB, pela la escritura de la etiqueta para revelar paquete IPV4 encapsulado dentro, y recircula el paquete, momento en el cual que el VRF FIB determina el salto siguiente.


Observelas primeras 511 escrituras de la etiqueta del agregado MPLS permanecen en el VPN CAM y se procesan basó en los pasos en la sección “MPLS de las escrituras de la etiqueta salvadas del agregado”.


Los pasos siguientes son realizados por un router PE para remitir el tráfico MPLS cuando la escritura de la etiqueta del agregado MPLS no está en el VPN CAM:

1. Las operaciones de búsqueda se realizan en el TCAM y la BOLA.

2. Se hace estallar la escritura de la etiqueta MPLS y el VLA N reservado asociado a la escritura de la etiqueta de la agregación MPLS se asigna al paquete.


Observecuando el número de escrituras de la etiqueta del agregado MPLS excede de 511, una interfaz VLAN reservada se asigna para cada nueva escritura de la etiqueta del agregado MPLS.


3. El VPN ID para el VLAN ID reservado se deriva del RAM del VLA N. El VPN ID se utiliza como parte de la clave de las operaciones de búsqueda para IP VRF las operaciones de búsqueda del Cisco Express Forwarding (CEF).

4. IP VRF el resultado de búsqueda CEF contiene el IP Address de Next Hop y el resto de la información de reescritura necesarios para remitir el paquete al router CE correcto.

Ocupación de la Memoria Caché de NetFlow

Cuando el NDE para la característica de las interfaces VRF se configura para un MPLS VPN, una interfaz VLAN es reservada y el Netflow se habilita en la interfaz VLAN. El método utilizó por el router para procesar el tráfico del IPv4 del MPLS VPN y poblar el caché de NetFlow depende del número de escrituras de la etiqueta del agregado MLS que el router ha salvado.

Escrituras de la etiqueta del agregado MPLS en VPN CAM

Cuando hay menos que 512 escrituras de la etiqueta globales VPN MPLS, la escritura de la etiqueta y el VPN asociado se programan en el MPLS VPN CAM, y la recirculación del paquete no se requiere. El Policy Feature Card (PFC) recibe el paquete como paquete del IP. La función del Netflow PFC considera los flujos como originados en el MPLS VPN no en la interfaz en la cual el tráfico fue recibido.

Cuando hay menos que 512 escrituras de la etiqueta globales VPN MPLS (todas las escrituras de la etiqueta del agregado MPLS se salvan en el VPN CAM), el caché de NetFlow se puebla para el tráfico MPLS que está utilizando las escrituras de la etiqueta del agregado MPLS habilitando el Netflow en la interfaz MPLS con ip flow ingress el comando. Por ejemplo, habilitar el Netflow para el tráfico que se está remitiendo sobre la base de la agregación MPLS etiqueta en el VPN CAM en el router PE2 en el cuadro 2, usted debe configurar ip flow ingress el comando en el FastEthernet0/0 de la interfaz. Esto es suficiente poblar el caché. Para hacer al router exportar los datos de NetFlow a un colector, flow hardware mpls-vpn ip el comando VRF-identificación se debe publicar en el modo de configuración global.

Escrituras de la etiqueta del agregado MPLS no en VPN CAM

Cuando el número de escrituras de la etiqueta del agregado MPLS en la red excede de 511, el VPN CAM es lleno. El tráfico debe ser recirculado si no utiliza una de las escrituras de la etiqueta del agregado MPLS salvadas en el VPN CAM. Los paquetes son procesados por el Policy Feature Card (PFC) una vez para eliminar la escritura de la etiqueta MPLS, y procesados por el PFC a la por segunda vez con el VLA N especificada como el VLA N reservado VPN que fue asignado cuando el NDE para la característica de las interfaces VRF fue habilitado. El RAM del VLA N asocia este VLA N al VPN para el uso en la encaminamiento. La función del Netflow PFC considera los flujos como originados en el VLA N reservado VRF. La entrada del Ternary Content Addressable Memory (TCAM) para la interfaz VLAN reservada proporciona la máscara del flujo al Netflow.

Los flujos para el tráfico del MPLS VPN recibido con la escritura de la etiqueta global que no está en el VPN CAM son poblados en el caché de NetFlow configurando flow hardware mpls-vpn ip el comando VRF-identificación para cada VPN VRF en el router en el modo de configuración global.

Escrituras de la etiqueta MPLS-específicas

Para el caso de la escritura de la etiqueta del nonaggregate, por definición, el router no necesita examinar el paquete del IP subyacente para determinar donde rutear el paquete. Para hacer los flujos IP poblar el caché, flow hardware mpls-vpn ip el comando configuration VRF-identificación debe ser ingresado. Esto hace el tráfico específico del flujo de la escritura de la etiqueta ser eliminada de su escritura de la etiqueta y ser recirculada al VLA N reservado VPN antes del envío a la interfaz de la salida. Esto introduce más retardo en el envío del tráfico que sea experimentado de otra manera.

Configurar la captura y la exportación del Netflow del MPLS VPN

Para asegurarse de que usted haya habilitado la captura y la exportación de los datos de NetFlow para todo el tráfico que usted quiere analizar, sin importar la escritura de la etiqueta del agregado MPLS está utilizando, usted debe configurar ip flow ingress el comando en la interfaz MPLS y configurar flow hardware mpls-vpn ip el comando VRF-identificación para cada VPN VRF en el router en el modo de configuración global.


Observelos pasos requeridos configurar la Exportación de datos de NetFlow (NDE) para los datos en el caché de NetFlow se proporcionan en “cómo configurar el NDE para las interfaces VRF para la sección de un MPLS VPN”.


Nombre VRF como Interfaz de Origen en la Memoria Caché de NetFlow

Para el tráfico recibido para un MPLS VPN en una interfaz MPLS, la interfaz de origen para el tráfico en el caché de NetFlow se enumera como el nombre VPN, no la interfaz física en la cual el tráfico fue recibido. Por ejemplo, el tráfico que es recibido en el FastEthernet0/0 en el PE2 en el cuadro 2 será visualizado en el caché de NetFlow en el router como siendo recibido sobre el rojo VPN, no FastEthernet0/0 de la interfaz.

Cómo Configurar NDE para Interfaces VRF para una VPN MPLS

Realice esta tarea de configurar el NDE para la característica de las interfaces VRF en un MPLS VPN. Esta configuración es apropiada para el router nombrado el PE1 en el cuadro 3. repetición esta tarea en el router PE2 pero recuerda cambiar las referencias de la interfaz a las interfaces apropiadas para el PE2.


Observeesta tarea no incluye los comandos de configurar el Open Shortest Path First (OSPF) y el Border Gateway Protocol (BGP) que se requieren para activar el MPLS VPN entre el Routers PE1 y PE2. Vea que los “ejemplos de configuración para el NDE para el VRF interconectan” la sección para las configuraciones completas para todos los dispositivos en la red de muestra en el cuadro 3.


Cuadro 3 red de muestra con un MPLS VPN

PASOS SUMARIOS

1. enable

2. configure terminal

3. ip vrf vrf-id

4. rd route-distinguisher

5.route-target {import | export | both} route-target-ext-community

6. interface type number

7. ip address ip-address mask

8. exit

9.mpls label protocol {ldp | tdp}

10. mpls ldp router-id type number

11. interface type number

12. ip address ip-address mask

13. mpls ip

14. ip flow ingress

15. interface type number

16. ip vrf forwarding vrf-id

17. ip address ip-address mask

18. exit

19. mls nde sender

20. mls flow ip {interface-destination-source | interface-full}

21. ip flow-export version 9

22. ip flow-export destination {ip-address | hostname} udp-port

23. flow hardware mpls-vpn ip vrf-id

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip vrf vrf-id

Example:

Router(config)# ip vrf red

Define un caso del VPN Routing and Forwarding (VRF) y ingresa el modo de la configuración de VRF.

Paso 4 

rd route-distinguisher

Example:

Router(config)# rd 200:2

Crea una encaminamiento y una tabla de reenvío para rutear/caso de reenvío (VRF) del Red privada virtual (VPN).

Paso 5 

route-target {import | export | both} route-target-ext-community

Example:

Router(config)# route-target both 200:20

Crea a una comunidad ampliada de la ruta-blanco para un VPN VRF.

Paso 6 

interface type number

Example:

Router(config)# interface loopback 0

Especifica el tipo y número de la interfaz que se desea configurar e ingresa en el modo de configuración de la interfaz.

Paso 7 

ip address ip-address mask

Example:

Router(config-if)# ip address 172.20.1.2 255.255.255.0

Configure una dirección IP en la interfaz.

Paso 8 

exit

Example:

Router(config-if)# exit

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

Paso 9 

mpls label {ldp | tdp}

Example:

Router(config)# mpls label protocol ldp

Especifica el Label Distribution Protocol MPLS.

Paso 10 

mpls ldp router-id type number

Example:

Router(config)# mpls ldp router-id loopback0

Especifica una interfaz preferida para determinar la identificación del router del Protocolo de distribución de etiquetas (LDP)

Paso 11 

interface type number

Example:

Router(config-if)# interface fastethernet1/1

Especifica el tipo y número de la interfaz que se desea configurar e ingresa en el modo de configuración de la interfaz.

Paso 12 

ip address ip-address mask

Example:

Router(config-if)# ip address 172.16.1.2 255.255.255.0

Configura una dirección IP en la interfaz.

Paso 13 

mpls ip

Example:

Router(config-if)# mpls ip

Habilita el reenvío MPLS de paquetes IPv4 a lo largo de trayectorias enrutadas normalmente para una interfaz particular.

Paso 14 

ip flow ingress

Example:

Router(config-if)# ip flow ingress

Permite al Netflow en la interfaz para capturar el tráfico que está siendo recibido por la interfaz.

Paso 15 

interface type number

Example:

Router(config)# interface GigabitEthernet5/2

Especifica el tipo y número de la interfaz que se desea configurar e ingresa en el modo de configuración de la interfaz.

Paso 16 

ip vrf forwarding vrf-id

Example:

Router(config-if)# ip vrf forwarding red

Asocia un VRF de VPN a una interfaz o subinterfaz.

Paso 17 

ip address ip-address mask

Example:

Router(config-if)# ip address 10.1.0.1 255.255.255.0

Configure una dirección IP en la interfaz.

Paso 18 

exit

Example:

Router(config-if)# exit

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

Paso 19 

mls nde sender

Example:

Router(config)# mls nde sender

Netflow de los permisos en el PFC.

Paso 20 

mls flow ip {interface-destination-source | interface-full}

Example:

Router(config)# mls flow ip interface-destination-source

Especifica la máscara del flujo del Netflow para el tráfico IP.

Paso 21 

ip flow-export version 9

Example:

Router(config)# ip flow-export version 9

Exportación de datos de NetFlow de las configuraciones para utilizar el formato de la exportación de la versión 9.

Paso 22 

ip flow-export destination {ip-address | hostname} udp-port

Example:

Router(config)# ip flow-export destination 172.16.2.6 99

Configura la dirección IP o el nombre de host del puesto de trabajo al cual usted quiere enviar la información de NetFlow y el número del puerto UDP en el cual el puesto de trabajo está estando atenta esta entrada.

Paso 23 

flow hardware mpls-vpn ip vrf-id

Example:

Router(config)# flow hardware mpls-vpn ip red

Habilita el NDE para la característica de las interfaces VRF para el VRF.

Ejemplos

El producto siguiente show mls nde del comando visualiza la configuración y las estadísticas NDE.

PE1# show mls nde
 Netflow Data Export enabled 
 Exporting flows to  172.16.2.6 (99)
 Exporting flows from 172.16.1.2 (51203)
 Version: 9
 Layer2 flow creation is disabled
 Layer2 flow export is disabled
 Include Filter not configured 
 Exclude Filter not configured 
 Total Netflow Data Export Packets are:
    4 packets, 0 no packets, 19 records
 Total Netflow Data Export Send Errors:
        IPWRITE_NO_FIB = 0
        IPWRITE_ADJ_FAILED = 0
        IPWRITE_PROCESS = 0
        IPWRITE_ENQUEUE_FAILED = 0
        IPWRITE_IPC_FAILED = 0
        IPWRITE_OUTPUT_FAILED = 0
        IPWRITE_MTU_FAILED = 0
        IPWRITE_ENCAPFIX_FAILED = 0
 Netflow Aggregation Disabled 

PE1#

El producto siguiente show mls netflow ip module del comando visualiza las entradas del Netflow en el PFC. La primera fila de la salida muestra el tráfico en el rojo VPN.


El módulo5 de la nota es el supervisor activo 720 en este Cisco 7600 Series Router.


Router# show mls netflow ip module 5

Displaying Netflow entries in module 5
DstIP           SrcIP           Prot:SrcPort:DstPort  Src i/f          :AdjPtr
-----------------------------------------------------------------------------
Pkts         Bytes         Age   LastSeen  Attributes
---------------------------------------------------
10.1.1.1        10.2.0.2        0   :0      :0        vpn:red          :0x0     
504          398020        1     23:20:48   L3 - Dynamic
224.0.0.5       172.16.1.1      89  :0      :0        Fa1/1            :0x0     
1            84            7     23:20:42   L2 - Dynamic
0.0.0.0         0.0.0.0         0   :0      :0        --               :0x0     
2238         1582910       33    23:20:48   L3 - Dynamic
224.0.0.2       172.16.1.1      udp :646    :646      Fa1/1            :0x0     
5            310           21    23:20:46   L2 - Dynamic
172.16.2.6      172.16.1.2      0   :0      :0        Fa1/1            :0x0     
1            140           22    23:20:27   L2 - Dynamic

Router#

El producto siguiente show ip cache flow del comando visualiza los datos en el caché de NetFlow. La línea más reciente de datos en la salida muestra que la interfaz de origen para este tráfico es rojo VPN.

PE1# show ip cache flow

-------------------------------------------------------------------------------
MSFC:
IP packet size distribution (3139 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .685 .309 .000 .000 .000 .000 .003 .000 .000 .000 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 278544 bytes
  2 active, 4094 inactive, 56 added
  20904 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33992 bytes
  0 active, 1024 inactive, 4 added, 4 added to flow
  0 alloc failures, 0 force free
  1 chunk, 2 chunks added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-BGP             10      0.0         1    49      0.0       0.0      15.3
TCP-other            6      0.0         2    49      0.0       4.5      15.5
UDP-other           28      0.0        74    63      0.1     320.5      12.7
IP-other             6      0.0       153    80      0.0    1488.3       1.7
Total:              50      0.0        60    68      0.2     358.6      12.2

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Fa1/1         172.16.1.1      Null          224.0.0.2       11 0286 0286    74 
Fa1/1         172.16.1.1      Null          224.0.0.5       59 0000 0000    33 

-------------------------------------------------------------------------------
PFC:

Displaying Hardware entries in Module 5
 SrcIf            SrcIPaddress          DstIPaddress      Pr       SrcP      Dss
 Fa1/1            172.20.1.2            172.20.1.3        0        0         0  
 Fa1/1            172.20.1.3            172.20.1.2        0        0         0  
 Fa1/1            172.16.1.2            172.16.2.6        0        0         0  
 Fa1/1            172.16.1.1            224.0.0.2         udp      646       64 
 --               0.0.0.0               0.0.0.0           0        0         0  
 vpn:red          10.2.0.2              10.1.1.1          0        0         0  
.
.
.
PE1#

Ejemplos de Configuración para NDE for VRF Interfaces

El ejemplo de configuración siguiente muestra cómo configurar una topología de red simple con el NDE para la característica de las interfaces VRF configurada en dos Routers PE.

Esta sección contiene las configuraciones del siguiente ejemplo:

Configuraciones para la Red de Ejemplo con una MPLS VPN: Ejemplo:

Configuración de la Función NDE for VRF Interfaces en un VRF: Ejemplo:

Configuraciones para la Red de Ejemplo con una MPLS VPN: Ejemplo:

Esta sección contiene las configuraciones para todos los dispositivos en el cuadro 3. El NDE para la característica de las interfaces VRF se configura en el Routers PE1 y PE2.

CE1

!
hostname CE1
!
ip cef
!
interface Loopback0
 no shutdown
 ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no shutdown
 ip address 10.1.0.2 255.255.255.0
!
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.1.0.1
!
end

PE1

!
hostname PE1
!
ip cef distributed
!
mls nde sender
mls flow ip interface-destination-source
ip flow-export destination 172.16.2.6 99
ip flow-export version 9
!
ip vrf red
 rd 200:2
 route-target export 200:20
 route-target import 200:20
!
flow hardware mpls-vpn ip red
!
multilink bundle-name authenticated
mpls label protocol ldp
!
interface Loopback0
 ip address 172.20.1.2 255.255.255.255
!
interface gigabitEthernet5/2
 no shutdown
 ip vrf forwarding red
 ip address 10.1.0.1 255.255.255.0
!
interface FastEthernet1/1
 no shutdown
 interface FastEthernet1/1
 ip address 172.16.1.2 255.255.255.0
 ip flow ingress
 mpls ip
!
router ospf 100
 router-id 172.20.1.2
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 172.20.1.2 0.0.0.0 area 0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 172.0.0.0 mask 255.0.0.0
 neighbor as200 peer-group
 neighbor as200 remote-as 200
 neighbor as200 description as200
 neighbor as200 update-source Loopback0
 neighbor as200 route-reflector-client
 neighbor 172.20.1.4 remote-as 200
 neighbor 172.20.1.4 description iBGP with r4
 neighbor 172.20.1.4 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 172.20.1.4 activate
 neighbor 172.20.1.4 send-community both
 exit-address-family
 !
 address-family ipv4 vrf red
 no synchronization
 network 10.1.0.0 mask 255.255.255.0
 network 10.1.1.1 mask 255.255.255.255
 exit-address-family
!
ip route 172.0.0.0 255.0.0.0 Null0
ip route vrf red 10.1.1.1 255.255.255.255 10.1.0.2
!
mpls ldp router-id Loopback0
!
end

P1

!
hostname P1
!
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
 no shutdown
 ip address 172.20.1.3 255.255.255.255
!
interface FastEthernet0/0
 no shutdown
 ip address 172.16.2.1 255.255.255.0
 mpls ip
!
interface FastEthernet0/1
 no shutdown
 ip address 172.16.1.1 255.255.255.0
 mpls ip
!
router ospf 100
 router-id 172.20.1.3
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 172.20.1.3 0.0.0.0 area 0
!
mpls ldp router-id Loopback0
!
end

PE2

!
hostname PE2
!
ip cef distributed
!
mls nde sender
mls flow ip interface-destination-source
ip flow-export destination 172.16.2.6 99
ip flow-export version 9
!
ip vrf red
 rd 200:2
 route-target export 200:20
 route-target import 200:20
!
flow hardware mpls-vpn ip red
!
multilink bundle-name authenticated
mpls label protocol ldp
!
interface Loopback0
 no shutdown
 ip address 172.20.1.4 255.255.255.255
!
interface FastEthernet0/0
 no shutdown
 ip address 172.16.2.2 255.255.255.0
 mpls ip
 ip flow ingress
!
interface FastEthernet0/1
 no shutdown
 ip vrf forwarding red
 ip address 10.2.0.1 255.255.255.0
!
router ospf 100
 router-id 172.20.1.4
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 172.20.1.4 0.0.0.0 area 0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 172.0.0.0 mask 255.0.0.0
 neighbor as200 peer-group
 neighbor as200 remote-as 200
 neighbor as200 description as200
 neighbor as200 update-source Loopback0
 neighbor as200 route-reflector-client
 neighbor 172.20.1.2 remote-as 200
 neighbor 172.20.1.2 description iBGP with r2
 neighbor 172.20.1.2 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 172.20.1.2 activate
 neighbor 172.20.1.2 send-community both
 exit-address-family
 !
 address-family ipv4 vrf red
 no synchronization
 network 10.2.0.0 mask 255.255.255.0
 network 10.2.2.2 mask 255.255.255.255
 exit-address-family
!
ip route 172.0.0.0 255.0.0.0 Null0
ip route vrf red 10.2.2.2 255.255.255.255 10.2.0.2
!
mpls ldp router-id Loopback0
!
end

CE2

!
hostname CE2
!
ip cef
!
interface Loopback0
 no shutdown
 ip address 10.2.2.2 255.255.255.255
!
interface FastEthernet0/1
 no shutdown
 ip address 10.2.0.2 255.255.255.0
!
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.2.0.1
!
end

Configuración de la Función NDE for VRF Interfaces en un VRF: Ejemplo:

Este ejemplo de configuración muestra cómo configurar el NDE para la característica de las interfaces VRF para un VRF. Cuando usted habilita el Netflow en la interfaz GigabitEthernet2/3 con ip flow ingress el comando, el caché de NetFlow contendrá la información para el tráfico para el vpn1 VPN.

PE1

!
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
mls flow ip interface-full
!
interface GigabitEthernet2/3
 ip vrf forwarding vpn1
 ip address 10.0.0.1 255.0.0.0
 ip flow ingress
!
interface GigabitEthernet2/7
 ip vrf forwarding vpn1
 ip address 172.16.20.1 255.255.255.0
!
ip flow-export version 9
ip flow-export destination 192.168.10.2 20000
end

Adonde ir después

Vea el Netflow que configura y el capítulo NDE de la guía de configuración del Cisco IOS Software de las Cisco 7600 Series, para más información sobre configurar las características del Netflow en los Cisco 7600 Series Router.

Vea capítulo del Multiprotocol Label Switching (MPLS) del modo del PFC3BXL que configura y del PFC3B de la guía de configuración del Cisco IOS Software de las Cisco 7600 Series, para más información sobre configurar las características MPLS en los Cisco 7600 Series Router.

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con el NDE para la característica de las interfaces VRF.

Documentos Relacionados

Tema relacionado
Título del documento

El Netflow ordena, sintaxis del comando complete, modo de comando, los valores por defecto, comando history, las Pautas para el uso, y los ejemplos.

Referencia de comandos del Cisco IOS NetFlow

Información para configurar el Netflow, el MPLS, y las otras funciones en los Cisco 7600 Series Router.

Guía de configuración del Cisco IOS Software de las Cisco 7600 Series


Estándares

Estándar
Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html


RFC

RFC
Título

Esta función no soporta RFCs nuevos o modificados, y el soporte de los RFCs existentes no ha sido modificado por ella.


Asistencia Técnica

Descripción
Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com. Si dispone de un contrato de servicios válido pero no tiene asignados un ID de usuario ni una contraseña, puede registrarse en Cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html


Información de Función para NDE for VRF Interfaces

La Tabla 1 muestra el historial de versiones de esta función.

Puede que no estén disponibles todos los comandos en su versión de software de Cisco IOS. Para la información de versión sobre un comando específico, vea la documentación de referencia de comandos.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software. Cisco Feature Navigator le permite determinar qué imágenes de Cisco IOS y Catalyst OS Software soportan una versión de software, un conjunto de funciones o una plataforma específica. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.


Observelas listas del cuadro 1 solamente la versión de Cisco IOS Software que introdujo el soporte para una característica dada en un tren de versión del Cisco IOS Software dado. A menos que se indique lo contrario, las versiones posteriores de dicha serie de versiones de software de Cisco IOS también soportan esa función.


Información de la característica del cuadro 1 para el NDE para las interfaces VRF 

Nombre de la función
Versiones
Información sobre la Función

NDE para Interfaces VRF

12.2(33)SRB
15.0(1)S

El soporte NDE para el VRF interconecta los permisos de las características que capturan y que exportan la información de flujo del Netflow de las interfaces VRF.

En 12.2(33)SRB, esta característica fue introducida en los Cisco 7600 Series Router.

Las secciones siguientes proporcionan información acerca de esta función:

Información sobre NDE para Interfaces VRF

Cómo Configurar NDE para Interfaces VRF para una VPN MPLS

Los siguientes comandos fueron introducidos o modificados por esta característica: flow hardware mpls-vpn ip show ip cache flow show ip cache flow aggregation show mls netflow ip.