Guía de Configuración de Multiprotocol Label Switching de Cisco IOS, Release 12.2SR
Load Sharing MPLS VPN Traffic
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 394 KB | Inglés (12 Febrero 2008) | Comentarios

Contenidos

Load Sharing MPLS VPN Traffic

Encontrar la información de la característica

Contenido

Prerrequisitos de Load Sharing MPLS VPN Traffic

Restricciones de Load Sharing MPLS VPN Traffic

Información sobre Load Sharing MPLS VPN Traffic

Descripción de la carga a compartir usando las opciones del trayecto múltiple de BGP

Carga a Compartir de Trayectoria Múltiple de BGP Interno

BGP Multipath for eBGP and iBGP

Carga a Compartir de Trayectoria Múltiple de eBGP

Uso Compartido de la Carga Usando el Peering de Loopback Directamente Conectado

Cómo Configurar la Distribución de Carga

Configuración de Carga a Compartir Multitrayectoria para eBGP e iBGP

Verificar la carga a compartir del trayecto múltiple de BGP para el eBGP y el iBGP

Configuración de la Carga a Compartir de Trayectoria Múltiple del eBGP con MPLS VPN Inter-AS

Configurar la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador en el Routers CSC-PE

Configurar la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador en el Routers CSC-CE

Configuración de Peering de Loopback Directamente Conectado para MPLS VPN Inter-AS que usan ASBRs para Intercambiar Direcciones VPN-IPv4

Configurar las direcciones de la interfaz loopback para ASBR conectados directamente

Configuración de Rutas Estáticas /32 al Loopback del Vecino eBGP

Configuración del Reenvío en la Conexión de Interfaces Loopback

Configuración de una Sesión eBGP entre los Loopbacks

Verificación de que esa Carga a Compartir Ocurre entre Loopbacks

Configurando el peering directamente conectado del loopback para el MPLS VPN Inter-COMO usando los ASBR para intercambiar las rutas y las escrituras de la etiqueta del IPv4

Configurar las direcciones de la interfaz loopback para ASBR conectados directamente

Configuración de Rutas Estáticas /32 al Loopback del Vecino eBGP

Configuración del Reenvío en la Conexión de Interfaces Loopback

Configuración de una Sesión eBGP entre los Loopbacks

Verificación de que esa Carga a Compartir Ocurre entre Loopbacks

Configurar el peering directamente conectado del loopback en el portador del MPLS VPN que soporta el portador

Configurar a las direcciones del Loopback Interface en el Routers CSC-PE

Configurar a las direcciones del Loopback Interface para el Routers CSC-CE

Configurar las Static rutas de /32 al loopback del vecino eBGP en el router CSC-PE

Configurar las Static rutas de /32 al loopback del vecino eBGP en el router CSC-CE

Configurando la expedición en las interfaces CSC-PE que conectan con el loopback CSC-CE

Configurando la expedición en las interfaces CSC-CE que conectan con el loopback CSC-PE

Configurar a una sesión eBGP entre el router CSC-PE y el loopback CSC-CE

Configurar a una sesión eBGP entre el router CSC-CE y el loopback CSC-PE

Verificación de que esa Carga a Compartir Ocurre entre Loopbacks

Ejemplos de Configuración de Load Sharing MPLS VPN Traffic

Configuración de un Router para Seleccionar las Trayectorias eBGP o iBGP como Trayectorias Múltiples: Ejemplo:

Configuración de una Ruta Estática /32 desde un ASBR a la Dirección de Loopback de otro ASBR: Ejemplos

Configuración del Reenvío BGP/MPLS en las Interfaces que Conectan con ASBRs: Ejemplo:

Configuración de las Sesiones de VPNv4 en un ASBR: Ejemplo:

Verificación de VPN NLRI para una Red Especificada: Ejemplo:

Referencias adicionales

Documentos Relacionados

Estándares

MIB

RFC

Asistencia Técnica

Información sobre la Función Load Sharing MPLS VPN Traffic


Load Sharing MPLS VPN Traffic


Primera publicación: 2 de mayo de 2005
Última actualización: De febrero el 18 de 2009

La carga a compartir distribuye el tráfico para no sobrecargar ningún router individual. En una red de Red privada virtual (VPN) del Multiprotocol Label Switching (MPLS), usted puede alcanzar la carga a compartir con los métodos siguientes:

Opciones del trayecto múltiple de BGP

Peering directamente conectado del loopback

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea “información de la característica para la sección del tráfico del MPLS VPN de la carga a compartir”.

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Contenido

Prerrequisitos de Load Sharing MPLS VPN Traffic

Restricciones de Load Sharing MPLS VPN Traffic

Información sobre Load Sharing MPLS VPN Traffic

Cómo Configurar la Distribución de Carga

Ejemplos de Configuración de Load Sharing MPLS VPN Traffic

Referencias adicionales

Referencia de comandos, página 50

Información sobre la Función Load Sharing MPLS VPN Traffic

Prerrequisitos de Load Sharing MPLS VPN Traffic

Antes de configurar la carga a compartir, asegúrese de que su red del MPLS VPN (portador incluyendo del MPLS VPN que soporta el portador o el sistema interautonomous) es configurada y de trabajo correctamente. Vea que “relacionó la sección de los documentos” para las referencias relacionadas con el MPLS VPNs.

Restricciones de Load Sharing MPLS VPN Traffic

Configurar el trayecto múltiple de BGP para el eBGP y el iBGP está solamente para la capa básica 3 VPN MPLS. El portador del MPLS VPN Inter-COMO y del MPLS VPN que soporta el portador no soporta esta configuración de trayectoria múltiple.

Con las trayectorias múltiples del iBGP instaladas en una tabla de ruteo, un reflector de ruta hace publicidad de solamente uno de las trayectorias (un salto siguiente). Si un router está detrás de un reflector de ruta, no hacen publicidad todo el Routers que está conectado con los sitios multihomed a menos que los VRF separados con diversos RD se configuren para cada VRF.

Cada entrada de tabla de IP Routing para un prefijo BGP que tenga trayectorias múltiples del iBGP utiliza la memoria adicional. Recomendamos no usar esta función en un router con una cantidad baja de memoria disponible, especialmente cuando el router transporta una tabla de ruteo de Internet completa.

el eBGP de varios trayectos no se soporta en el MPLS VPN Inter-COMO con los ASBR que intercambian las rutas del VPNv4.

La carga a compartir usando el peering directamente conectado del loopback no aplica al CSC las redes que utilizan el LDP y un IGP para distribuir las rutas y las escrituras de la etiqueta MPLS.

Cuando usted configura las Static rutas en un entorno MPLS o del MPLS VPN, algunas variaciones del ip route y ip route vrf de los comandos no se soportan. Estas variaciones de los comandos no se soportan en las versiones del Cisco IOS que soportan el (TFIB) de los Tag Forwarding Information Bases, específicamente los Cisco IOS Release 12.nT, 12.nM, y 12.0S. La TFIB no puede resolver los prefijos si la ruta recurrente sobre la que viajan los prefijos desaparece y después reaparece. Sin embargo, las variaciones del comando se soportan en las versiones del Cisco IOS que soportan la infraestructura de la expedición MPLS (MFI), Cisco IOS Release 12.2(25)S y Posterior liberan específicamente. Utilice las siguientes pautas al configurar rutas estáticas.

Rutas Estáticas Soportadas en un Entorno MPLS

Se soporta ip route el siguiente comando cuando usted configura las Static rutas en un entorno MPLS:

ip route destination-prefix mask interface next-hop-address

Se soportan ip route los siguientes comandos cuando usted configura las Static rutas en un entorno MPLS y configura la carga a compartir con las rutas no recurrentes estáticas y una interfaz de salida específica:

ip route máscara del prefijo de destino interface1 next-hop1
de la ruta de IP de la máscara del prefijo de destino interface2 next-hop2

Static rutas sin apoyo en un entorno MPLS que utiliza el TFIB

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno MPLS:

ip route destination-prefix mask next-hop-address

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno del MPLS VPN y habilita la carga a compartir donde el salto siguiente se puede alcanzar a través de dos trayectorias:

ip route destination-prefix mask next-hop-address

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno del MPLS VPN y habilita la carga a compartir donde el destino se puede alcanzar a través de dos saltos siguientes:

ip route máscara del prefijo de destinonext-hop1
de la ruta de IP de la máscara del prefijo de destino next-hop2

Utilice interface y next-hop los argumentos al especificar las Static rutas.

Rutas Estáticas Soportadas en un Entorno VPN MPLS

Se soportan ip route vrf los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente y la interfaz se asocian al mismo caso del ruteo virtual y de la expedición (VRF):

ip route vrfnext-hop-address de la máscara del prefijo de destino del vrf-name

ip route vrfnext-hop-address de la interfaz de la máscara del prefijo de destino del vrf-name

ip route vrfmáscara del prefijo de destino del vrf-name interface1 next-hop1
ip route vrf vrf-name destination-prefix mask interface2 next-hop2

Se soportan ip route vrf los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente está en la tabla global en la nube MPLS en la tabla de Global Routing. Por ejemplo, se soportan estos comandos cuando el salto siguiente está señalando al gateway de Internet.

ip route vrfnext-hop-address de la máscara del prefijo de destino del vrf-name global

ip route vrfnext-hop-address de la interfaz de la máscara del prefijo de destino del vrf-name
(Se soporta este comando cuando el salto siguiente y la interfaz están en la base.)

Se soportan ip route los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN y habilita la carga a compartir con las rutas no recurrentes estáticas y las interfaces de salida específicas:

ip route máscara del prefijo de destinointerface1 next-hop1
de la ruta de IP de la máscara del prefijo de destino interface2 next-hop2

Static rutas sin apoyo en un entorno del MPLS VPN que utiliza el TFIB

El siguiente comando ip route no se soporta cuando usted configura las Static rutas en un entorno del MPLS VPN, el salto siguiente está en la tabla global en la nube MPLS dentro de la base, y usted habilita la carga a compartir donde el salto siguiente se puede alcanzar a través de dos trayectorias:

ip route vrf destination-prefix mask next-hop-address global

Los siguientes comandos ip route no se soportan cuando usted configura las Static rutas en un entorno del MPLS VPN, el salto siguiente están en la tabla global en la nube MPLS dentro de la base, y usted habilita la carga a compartir donde el destino se puede alcanzar a través de dos saltos siguientes:

ip route vrf destination-prefix mask next-hop1 global
ip route vrf destination-prefix mask next-hop2 global

Los siguientes comandos ip route vrf no se soportan cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente y la interfaz están en el mismo VRF:

ip route vrf máscara del prefijo de destino del vrf-namenext-hop1
del
vrf de la ruta de IP de la máscara del prefijo de destino del vrf-name next-hop2

Rutas Estáticas Soportadas en un Entorno de MPLS VPN donde el Siguiente Salto Reside en la Tabla Global del Router CE

Se soporta ip route vrf el siguiente comando cuando usted configura las Static rutas en un entorno del MPLS VPN, y el salto siguiente está en la tabla global en el lado de la frontera del cliente (CE). Por ejemplo, el siguiente comando se soporta cuando el prefijo de destino es la dirección de loopback del router CE, como en los casos del eBGP multisalto.

ip route vrf vrf-name destination-prefix mask interface next-hop-address

Se soportan ip route los siguientes comandos cuando usted configura las Static rutas en un entorno del MPLS VPN, el salto siguiente están en la tabla global en el lado CE, y usted habilita la carga a compartir con las rutas no recurrentes estáticas y las interfaces de salida específicas:

ip route máscara del prefijo de destinointerface1 nexthop1
de la ruta de IP de la máscara del prefijo de destino interface2 nexthop2

Información sobre Load Sharing MPLS VPN Traffic

Antes de configurar las características de la carga a compartir, usted debe entender los conceptos siguientes:

Descripción de la carga a compartir usando las opciones del trayecto múltiple de BGP

Uso Compartido de la Carga Usando el Peering de Loopback Directamente Conectado

Descripción de la carga a compartir usando las opciones del trayecto múltiple de BGP

Una variedad de opciones de trayectoria múltiple del Border Gateway Protocol (BGP) existen ese permiso usted para configurar la carga a compartir en su MPLS VPN que utilice el BGP.

Para cargar el tráfico de la parte en el nivel de la ruta múltiple iBGP, se recomienda que usted configura el BGP que etiqueta usando neighbor send-label el comando en el modo de configuración del router. Cuando usted configura la característica de la ruta múltiple iBGP, el siguiente mensaje se visualiza como recordatorio para utilizar las funciones vecinas del comando de la enviar-escritura de la etiqueta:

WARNING: Using iBGP multipath feature with LDP or TE based LSPs towards the BGP nexthop, 
paths taken by forwarding may not be as expected. Please consider configuring BGP labeling 
(RFC 3107) for proper forwarding behavior.

Las secciones siguientes describen algunas opciones del trayecto múltiple de BGP:

Carga a Compartir de Trayectoria Múltiple de BGP Interno

BGP Multipath for eBGP and iBGP

Carga a Compartir de Trayectoria Múltiple de eBGP

Carga a Compartir de Trayectoria Múltiple de BGP Interno

Cuando un router de BGP-discurso sin la política local configurada recibe la información de alcance de la capa de Red múltiple (NLRI) del Internal BGP (iBGP) para el mismo destino, el router elige una trayectoria del iBGP como el mejor trayecto. A continuación se instala la mejor trayectoria en la tabla de ruteo IP del router. La característica de la ruta múltiple iBGP permite al router de BGP-discurso para seleccionar las trayectorias múltiples del iBGP como los mejores trayectos a un destino. Los mejores trayectos entonces están instalados en la tabla de IP Routing del router. Para habilitar la carga a compartir de la ruta múltiple iBGP, usted publica maximum-paths ibgp el comando en el modo de configuración del router. Para más información sobre la carga a compartir de la ruta múltiple iBGP, vea configurar el BGP.

BGP Multipath for eBGP and iBGP

La carga a compartir del trayecto múltiple de BGP para ambo eBGP y iBGP en una característica del MPLS VPN permite los sistemas autónomos multihomed y al Routers del borde del proveedor (PE) que se configurarán para distribuir el tráfico a través de las trayectorias del BGP externo (eBGP) y del iBGP.

El BGP instala hasta el número máximo de trayectorias permitidas (configurado usando maximum-paths el comando). El BGP utiliza el algoritmo del mejor trayecto para seleccionar uno de trayectoria múltiple como el mejor trayecto, inserta el mejor trayecto en el Routing Information Base (RIB), y hace publicidad del mejor trayecto a los peeres BGP. Otros multipaths se pueden insertar en el RIB, pero solamente una trayectoria se selecciona como el mejor trayecto.

El Cisco Express Forwarding utiliza los mutlipaths para realizar el Equilibrio de carga sobre una base por paquete o de la por-fuente o de los pares del destino. Para habilitar la característica de la carga a compartir, configure al router con el MPLS VPNs que contienen los casos del VPN Routing and Forwarding (los VRF) ese eBGP de la importación y las trayectorias del iBGP. Usted puede configurar el número de multipaths por separado para cada VRF.


Observeesta característica actúa dentro de los parámetros de la configuración del política de ruteo saliente existente.


eBGP y carga a compartir de la ruta múltiple iBGP en una red MPLS usando el BGP

El cuadro 1 muestra una red del proveedor de servicios MPLS usando el BGP que conecta dos redes remotas con el PE1 y el PE2, que ambas se configuran para la mirada del iBGP del unicast del VPNv4. La red 2 es una red con varias conexiones que está conectada con el PE1 y el PE2. La red 2 también tiene los servicios del extranet VPN configurados con la red 1. Las redes 1 y 2 están configuradas para el peering eBGP con los routers PE.

Figura 1

Una red MPLS del proveedor de servicio usando el BGP

Usted puede configurar el PE1 para poder seleccionar iBGP y las trayectorias del eBGP como multipaths e importado en el VRF del Cisco Express Forwarding de la red 1. utilice los mutlipaths para realizar el Equilibrio de carga. Se distribuye el tráfico como sigue:

El tráfico IP que se envía de la red 2 al PE1 y al PE2 se envía a través de las trayectorias del eBGP como tráfico IP.

El tráfico IP que se envía del PE1 al PE2 se envía a través de la trayectoria del iBGP como tráfico MPLS.

El tráfico MPLS que se envía a través de una trayectoria del eBGP se envía como tráfico IP.

Cualquier prefijo que se haga publicidad de la red 2 será recibido por el PE1 con el Route Distinguisher (RD) 21 y RD22.

El anuncio con RD21 es adentro llevados paquetes IP.

El anuncio con RD22 es adentro llevados paquetes MPLS.

Ambas trayectorias se pueden seleccionar como multipaths para VRF1 e insertar en el RIB VRF1.

eBGP y carga a compartir de la ruta múltiple iBGP con los reflectores de ruta

El cuadro 2 muestra una topología que contenga tres Routers PE y un reflector de ruta, configurada todo para la mirada del iBGP. El PE2 y PE3 cada uno hacen publicidad de una trayectoria del eBGP de la preferencia del igual al PE1. Por abandono, el reflector de ruta elige solamente una trayectoria y hace publicidad del PE1.

Figura 2

Topología con un reflector de ruta

Para todas las trayectorias iguales de la preferencia al PE1 que se hará publicidad a través del reflector de ruta, usted debe configurar cada VRF con un diverso RD. Los prefijos recibidos por el reflector de ruta se reconocen diferentemente y se hacen publicidad al PE1.

Carga a Compartir de Trayectoria Múltiple de eBGP

Cuando un router aprende dos trayectorias idénticas del eBGP para un prefijo de un sistema autónomo vecino, elige la trayectoria con la ruta más baja ID como el mejor trayecto. Este mejor trayecto está instalado en la tabla de IP Routing. Usted puede habilitar el eBGP de varios trayectos, que instala los trayectos múltiples en la tabla de IP Routing cuando las trayectorias del eBGP son doctas de un sistema autónomo vecino, en vez del mejor trayecto de la cosecha una.

Durante el packet switching, dependiendo del Switching Mode, por paquete o la distribución de carga por destino se realiza entre los trayectos múltiples. maximum-paths El comando router configuration controla el número de trayectorias permitidas. Por abandono, el BGP instala solamente una trayectoria a la tabla de IP Routing.

Uso Compartido de la Carga Usando el Peering de Loopback Directamente Conectado

Usted utiliza esta característica con el portador del MPLS VPN Inter-COMO y del MPLS VPN que soporta las redes del portador (CSC) para cargar el tráfico de la parte entre el Routers conmutado escritura de la etiqueta adyacente (LSR) que es conectado por los links múltiples. Los LSR podrían ser pares de los Autonomous System Boundary Router (ASBR) o un CSC-PE y un CSC-CE.

La utilización de peering de loopback conectado directamente permite el balanceo de carga en el nivel IGP, por lo que no es necesaria más de una sesión de BGP entre los LSR. No se necesita otro mecanismo de distribución de etiquetas entre los LSRs adyacentes más que BGP.

El peering directamente conectado del loopback habilita la carga a compartir del tráfico como sigue:

Establecen a una sesión de BGP, usando los Loopback Address de los LSR.

El MPLS se habilita en los puentes de conexión.

Las Static rutas múltiples al Loopback Address del LSR adyacente permiten la carga a compartir IGP.

La etiqueta saliente al Loopback Address del LSR adyacente es una escritura de la etiqueta nula implícita y es deducida por el LSR.

Porque la carga a compartir IGP se habilita en el Loopback Address del LSR adyacente, cualquier tráfico destinó a un prefijo que es docto sobre la sesión de BGP (y los recurses sobre el loopback) es carga compartida.

Cómo Configurar la Distribución de Carga

Esta sección contiene los siguientes procedimientos:

Configurando la carga a compartir del trayecto múltiple de BGP para el eBGP y el iBGP (requeridos)

Verificando la carga a compartir del trayecto múltiple de BGP para el eBGP y el iBGP (opcionales)

Configurando la carga a compartir del eBGP de varios trayectos con el MPLS VPN Inter-COMO (requerido)

Configurando la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador en el Routers CSC-PE (requerido)

Configurar la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador en el Routers CSC-CE

Configurando el peering directamente conectado del loopback para el MPLS VPN Inter-COMO usando los ASBR para intercambiar los direccionamientos del VPN-IPv4 (requeridos)

Configurando el peering directamente conectado del loopback para el MPLS VPN Inter-COMO usando los ASBR para intercambiar las rutas y las escrituras de la etiqueta del IPv4 (requeridas)

Configurando el peering directamente conectado del loopback en el portador del MPLS VPN que soporta el portador (requerido)

Configuración de Carga a Compartir Multitrayectoria para eBGP e iBGP

Para configurar el iBGP y las rutas del eBGP para la distribución de carga de trayecto múltiple, realice la tarea siguiente.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4.address-family ipv4 [multicast | unicast | vrf vrf-name]

5. maximum-paths eibgp number-of-paths

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:

Router(config)# router bgp 1

Ingresa al modo de configuración del router y configura al router para funcionar con un proceso de ruteo BGP.

Paso 4 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf vrf1

Ingresa en el modo de configuración de la familia de direcciones para configurar sesiones de ruteo, como sesiones BGP que utilizan prefijos de dirección IPv4 estándar.

Observepara esta tarea que usted debe crear el VRF y especificar vrf la palabra clave.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifican el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 5 

maximum-paths eibgp number-of-paths

Example:

Router(config-router-af)# maximum-paths eibgp 6

Configura el número de trayectorias paralelas de iBGP y eBGP que se pueden instalar en una tabla de ruteo.

Verificar la carga a compartir del trayecto múltiple de BGP para el eBGP y el iBGP

Para verificar la configuración del iBGP y las rutas del eBGP para la distribución de carga de trayecto múltiple, realice esta tarea.

PASOS SUMARIOS

1. enable

2.show ip bgp vpnv4 {all | rd route-distinguisher | []vrf-namedel []del []rib-failuredel []ip-prefix/lengthlonger-prefixesdel []del [[]network-addressmaskdel []longer-prefixesdel [[]del []cidr-onlydel []community del []community-listdel []dampened-pathsdel []filter-listdel []flap-statistics] inconsistent-asdel [[]neighbors del [[]paths linedel []del vrfpeer-group}quote-regexp]regexp]summary]labels

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

(Opcional) Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

show ip bgp vpnv4 {all | rd route-distinguisher | vrf vrf-name} [rib-failure] [ip-prefix/length [longer-prefixes]] [network-address [mask] [longer-prefixes]] [cidr-only] [community] [community-list] [dampened-paths] [filter-list] [flap-statistics] [inconsistent-as] [neighbors] [paths [line]] [peer-group] [quote-regexp] [regexp] [summary] [labels]

Example:

Router# show ip bgp vpnv4 all

Atributos de visualizaciones y multipaths para una red específica en un MPLS VPN.

Ingrese una o más palabras claves o argumentos.

Configuración de la Carga a Compartir de Trayectoria Múltiple del eBGP con MPLS VPN Inter-AS

Realice esta tarea en los ASBR de configurar el eBGP de varios trayectos para los sistemas interautonomous del MPLS VPN con los ASBR que intercambian las rutas del IPv4 y las escrituras de la etiqueta MPLS.

PASOS SUMARIOS

1. enable

2. configure terminal

3.router bgp as-number

4.neighbor {ip-address | peer-group-name} remote-as as-number

5.address-family ipv4 [multicast | unicast | vrf vrf-name]

6. maximum paths number-paths

7.neighbor {ip-address | peer-group-name} activate

8. neighbor ip-address send-label

9. exit-address-family

10. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:

Router(config)# router bgp 100

Configura un proceso de ruteo BGP y cambia el router al modo de configuración del router.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante. Los números válidos son del 0 al 65535. Los números privados del sistema autónomo que se pueden utilizar en redes internas van del 64512 al 65535.

Paso 4 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router)# neighbor 10.0.0.1 remote-as 200

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

as-number El argumento especifica el sistema autónomo al cual el vecino pertenece.

Paso 5 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4

Ingresa en el modo de configuración de la familia de direcciones para configurar sesiones de ruteo, como sesiones BGP que utilizan prefijos de dirección IPv4 estándar.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifican el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 6 

maximum-paths number-paths

Example:

Router(config-router-af)# maximum-paths 2

(Opcional) Controla el número máximo de rutas paralelas que puede soportar un protocolo de IP Routing.

number-paths El argumento especifica el número máximo de rutas paralelo que un IP Routing Protocol instala en una tabla de ruteo.

Paso 7 

neighbor {ip-address | peer-group-name} activate

Example:

Router(config-router-af)# neighbor 10.0.0.1 activate

Habilita el intercambio de información con un router vecino.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 8 

neighbor ip-address send-label

Example:

Router(config-router-af)# neighbor 10.0.0.1 send-label

Permite a un router BGP enviar etiquetas MPLS con rutas BGP a un router BGP vecino.

ip-address El argumento especifica la dirección IP del router de la vencidad.

Paso 9 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 10 

end

Example:

Router(config-router-af)# end

(Opcional) Sale al modo EXEC privilegiado.

Configurar la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador en el Routers CSC-PE

Realice esta tarea de configurar la carga a compartir del eBGP de varios trayectos en el Routers CSC-PE que distribuye las rutas BGP con las escrituras de la etiqueta MPLS.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4.address-family ipv4 [multicast | unicast | vrf vrf-name]

5. maximum paths number-paths

6.neighbor {ip-address | peer-group-name} remote-as as-number

7.neighbor {ip-address | peer-group-name} activate

8. neighbor ip-address as-override

9. neighbor ip-address send-label

10. exit-address-family

11. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:
Router(config)# router bgp 100

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante. Los números válidos son del 0 al 65535. Los números privados del sistema autónomo que se pueden utilizar en redes internas van del 64512 al 65535.

Paso 4 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf vpn1

Especifica el tipo de la familia de direcciones IPv4 e ingresa en el modo de configuración de familia de direcciones.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifican el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 5 

maximum-paths number-paths

Example:

Router(config-router-af)# maximum-paths 2

(Opcional) Controla el número máximo de rutas paralelas que puede soportar un protocolo de IP Routing.

En el router CSC-PE, este comando se habilita en el modo de configuración de la familia del direccionamiento.

number-paths El argumento especifica el número máximo de rutas paralelo que un IP Routing Protocol instala en una tabla de ruteo.

Paso 6 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router-af)# neighbor 10.0.0.1 remote-as 200

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

as-number El argumento especifica el sistema autónomo al cual el vecino pertenece.

Paso 7 

neighbor {ip-address | peer-group-name} activate

Example:

Router(config-router-af)# neighbor 10.0.0.1 activate

Habilita el intercambio de información con un router BGP vecino.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 8 

neighbor ip-address as-override

Example:

Router(config-router-af)# neighbor 10.0.0.1 as-override

Configura un router PE para invalidar el número del sistema autónomo (ASN) de un sitio sustituyéndolo por el ASN de un proveedor.

ip-address El argumento especifica la dirección IP del router que debe ser reemplazado con el ASN proporcionado.

Paso 9 

neighbor ip-address send-label

Example:

Router(config-router-af)# neighbor 10.0.0.1 send-label

Permite a un router BGP enviar etiquetas MPLS con rutas BGP a un router BGP vecino.

ip-address El argumento especifica la dirección IP del router de la vencidad.

Paso 10 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 11 

end

Example:

Router(config-router)# end

(Opcional) Sale al modo EXEC privilegiado.

Configurar la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador en el Routers CSC-CE

Realice esta tarea de configurar la carga a compartir del eBGP de varios trayectos en el Routers CSC-CE.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. maximum paths number-paths

5.address-family ipv4 [multicast | unicast | vrf vrf-name]

6. redistribute protocol

7.neighbor{ip-address | peer-group-name} remote-as as-number

8.neighbor {ip-address | peer-group-name} activate

9.neighborip-address enviar-escritura de la etiqueta

10. exit-address-family

11. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number
Example:
Router(config)# router bgp 200

Configura un proceso de ruteo BGP e ingresa en el modo de configuración del router.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante. Los números válidos son del 0 al 65535. Los números privados del sistema autónomo que se pueden utilizar en redes internas van del 64512 al 65535.

Paso 4 

maximum-paths number-paths

Example:
Router(config-router)# maximum-paths 2

(Opcional) Controla el número máximo de rutas paralelas que puede soportar un protocolo de IP Routing.

En el Routers CSC-CE, este comando se publica en el modo de configuración del router.

number-paths El argumento especifica el número máximo de rutas paralelo que un IP Routing Protocol instala en una tabla de ruteo.

Paso 5 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4

Especifica el tipo de la familia de direcciones IPv4 e ingresa en el modo de configuración de familia de direcciones.

multicast La palabra clave especifica los prefijos de la dirección Multicast del IPv4.

unicast La palabra clave especifica los prefijos de la dirección de Unicast del IPv4.

vrf vrf-name La palabra clave y el argumento especifican el nombre del VRF para asociarse a los comandos configuration mode subsiguientes de la familia del direccionamiento del IPv4.

Paso 6 

redistribute protocol

Example:

Router(config-router-af)# redistribute static

Redistribuye las rutas desde un dominio de ruteo a otro dominio de ruteo.

protocol El argumento especifica el protocolo de la fuente del cual se están redistribuyendo las rutas. Puede ser una de las siguientes palabras clave: bgp connected egp igrp isis mobile ospf, rip, y static []ip.

static La palabra claveip del []redistribuye las Static rutas IP.

Observela palabra clave optativa ip se utiliza cuando usted redistribuye las Static rutas en el Intermediate System-to-Intermediate System (IS-IS).

connected La palabra clave refiere a las rutas que se establecen automáticamente cuando el IP se habilita en una interfaz.

– Para los Routing Protocol tales como Open Shortest Path First (OSPF) y IS-IS, estas rutas se redistribuyen como externo al sistema autónomo.

Paso 7 

neighbor {ip-address | peer-group-name} 
remote-as as-number
Example:
Router(config-router-af)# neighbor 10.0.0.2 
remote-as 100

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

as-number El argumento especifica el sistema autónomo al cual el vecino pertenece.

Paso 8 

neighbor {ip-address | peer-group-name} 
activate
Example:
Router(config-router-af)# neighbor 10.0.0.2 
activate

Habilita el intercambio de información con un router BGP vecino.

ip-address El argumento especifica la dirección IP del vecino.

peer-group-name El argumento especifica el nombre de un grupo de peer de BGP.

Paso 9 

neighbor ip-address send-label
Example:
Router(config-router-af)# neighbor 10.0.0.2 
send-label

Permite a un router BGP enviar etiquetas MPLS con rutas BGP a un router BGP vecino.

ip-address El argumento especifica la dirección IP del router de la vencidad.

Paso 10 

exit-address-family
Example:
Router(config-router-af)# exit-address-family

Sale del modo de configuración de familia de direcciones.

Paso 11 

end
Example:
Router(config-router)# end

(Opcional) Sale al modo EXEC privilegiado.

Configuración de Peering de Loopback Directamente Conectado para MPLS VPN Inter-AS que usan ASBRs para Intercambiar Direcciones VPN-IPv4

Esta sección describe las tareas siguientes que usted necesita hacer para configurar el peering de las interfaces del loopback de los ASBR directamente conectados:

Configurando a las direcciones del Loopback Interface para los ASBR directamente conectados (requeridos)

Configurando las Static rutas de /32 al loopback del vecino eBGP (requerido)

Configurando la expedición en la conexión del loopback interconecta (requerido)

Configurando a una sesión eBGP entre los loopback (requeridos)

Verificar esa carga a compartir ocurre entre los loopback (opcionales)

El cuadro 3 muestra el Loopback Configuration para conectado directamente ASBR1 y ASBR2. Esta configuración se utiliza como ejemplo en las tareas siguientes.

Cuadro 3 Loopback Interface Configuration para conectado directamente ASBR1 y ASBR2

Configurar las direcciones de la interfaz loopback para ASBR conectados directamente

Realice esta tarea de configurar a las direcciones del Loopback Interface para los ASBR directamente conectados.


Los Loopback Addressde la nota necesitan ser configurados para cada ASBR directamente conectado. Es decir, configure un Loopback Address para ASBR1 y por ASBR2 adentro el ejemplo mostrado en el cuadro 3.


PASOS SUMARIOS

1. enable

2. configure terminal

3. interface loopback interface-number

4.ip address ip-address mask []secondary

5. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface loopback interface-number

Example:

Router(config)# interface loopback 0

Configura una interfaz virtual de software solamente que emula una interfaz que siempre está activada ascendente e ingresa en el modo de configuración de interfaz.

interface-number El argumento es el número del Loopback Interface que usted quiere crear o configurar. No hay límite para el número de interfaces Loopback que se pueden crear.

Paso 4 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Fija una dirección IP primaria o secundaria para una interfaz.

ip-address El argumento es la dirección IP.

mask El argumento es la máscara para la subred IP asociada.

secondary La palabra clave especifica que la dirección configurada es una driección IP secundaria. Si se omite esta palabra clave, la dirección configurada es la dirección IP primaria.

Paso 5 

end

Example:

Router(config-if)# end

Sale al modo EXEC privilegiado.

Configuración de Rutas Estáticas /32 al Loopback del Vecino eBGP

Realice esta tarea para configurar las rutas estáticas /32 al loopback del vecino eBGP.


Nota queusted necesita configurar las Static rutas de /32 en cada uno de los ASBR directamente conectados.


PASOS SUMARIOS

1. enable

2. configure terminal

3.ip route prefix mask {ip-address | interface-type interface-number []ip-address}
[]distancedel []namedel []permanentdel []tag tag

4. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [permanent] [tag tag]

Example:

Router(config)# ip route 10.20.20.20 255.255.255.255 Ethernet 1/0 172.16.0.1

Establece las rutas estáticas.

prefix El argumento es el prefijo de la ruta de IP para el destino.

mask El argumento es la máscara del prefijo para el destino.

ip-address El argumento es la dirección IP del salto siguiente que usted puede utilizar para alcanzar la red específicada.

interface-type Y interface-number los argumentos son el tipo y el Número de interfaz de interfaz de la red.

distance El argumento es una distancia administrativa.

name El argumento aplica un nombre a la ruta especificado.

permanent La palabra clave especifica que la ruta no debe ser quitada, incluso si la interfaz apaga.

tag tag La palabra clave y el argumento nombran un valor de la etiqueta que se pueda utilizar como valor de la “coincidencia” para la redistribución que controla con el uso de los mapa del ruta.

Paso 4 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configuración del Reenvío en la Conexión de Interfaces Loopback

Realice esta tarea para configurar el reenvío en las interfaces Loopback de conexión.

Esta tarea es necesaria para las sesiones entre loopbacks. En “configurando las Static rutas de /32 la tarea al loopback del vecino eBGP”, los Ethernetes 1/0 y el Ethernet0/0 son las interfaces de conexión.

PASOS SUMARIOS

1. enable

2. configure terminal

3.interface type slot/port

4. mpls bgp forwarding

5. exit

6.Relance los pasos 3 y 4 para otra interfaz de conexión (Ethernet0/0).

7. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type slot/port

Example:

Router(config)# interface ethernet 1/0

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

type El argumento es el tipo de interfaz que se configurará.

slot El argumento es el número de slot. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

/port El argumento es el número del puerto. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

Paso 4 

mpls bgp forwarding

Example:

Router(config-if)# mpls bgp forwarding

Configura BGP para habilitar el reenvío MPLS en las interfaces de conexión.

Paso 5 

exit

Example:

Router(config-if)# exit

Sale al modo de configuración global.

Paso 6 

Repita los pasos 3 y 4 para otra interfaz de conexión (Ethernet0/0).

Paso 7 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configuración de una Sesión eBGP entre los Loopbacks

Realice esta tarea de configurar a una sesión eBGP entre los loopback.


Nota queusted necesita configurar a una sesión eBGP entre los loopback en cada ASBR directamente conectado.


PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default route-target filter

5.neighbor {ip-address | peer-group-name} remote-as as-number

6.neighbor {ip-address | peer-group-name} disable-connected-check

7.neighbor {ip-address | ipv6-address | peer-group-name} update-source
interface-type interface-number

8.address-family vpnv4 []unicast

9.neighbor {ip-address | peer-group-name | ipv6-address} activate

10.neighbor {ip-address | peer-group-name} send-community [both | standard | extended]

11. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:
Router(config)# router bgp 200

Configura el proceso de ruteo de BGP.

as-number Indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante.

Paso 4 

no bgp default route-target filter

Example:

Router(config)# no bgp default route-target filter

La ruta-blanco de las neutralizaciones BGP que filtra, y ingresa al modo de configuración del router.

Todas las rutas VPN-IPv4 BGP recibidas son aceptadas por el router.

Paso 5 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router)# neighbor 10.20.20.20 remote-as 100

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

as-number El argumento es el sistema autónomo al cual el vecino pertenece.

Paso 6 

neighbor {ip-address | peer-group-name} disable-connected-check

Example:

Router(config-router)# neighbor 10.20.20.20 disable-connected-check

Permite el peering entre loopbacks.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

Paso 7 

neighbor {ip-address | ipv6-address | peer-group-name} update-source interface-type interface-number

Example:

Router(config-router)# neighbor 10.20.20.20 update-source Loopback 0

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

ip-address El argumento es el direccionamiento del IPv4 del vecino de BGP-discurso.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Este argumento debe utilizar el formato documentado en RFC 2373, donde la dirección se especifica en formato hexadecimal con valores de 16 bits entre signos de dos puntos.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

interface-type El argumento es el tipo de interfaz.

interface-number El argumento es el Número de interfaz.

Paso 8 

address-family vpnv4 [unicast]

Example:

Router(config-router)# address-family vpnv4

Ingresa al modo de configuración de familia de direcciones para configurar Routing Protocols como BGP, Routing Information Protocol (RIP) y el ruteo estático.

unicast La palabra clave especifica los prefijos del unicast.

Paso 9 

neighbor {ip-address | peer-group-name | ipv6-address} activate

Example:

Router(config-router-af)# neighbor 10.20.20.20 activate

Habilita el intercambio de información con un vecino BGP.

ip-address El argumento es la dirección IP del router de la vencidad.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Observeeste argumento debe estar en la forma documentada en RFC 2373, donde el direccionamiento se especifica en el hexadecimal usando los valores de 16 bits entre los dos puntos.

Paso 10 

neighbor {ip-address | peer-group-name} send-community [both | standard | extended]

Example:

Router(config-router-af)# neighbor 10.20.20.20 send-community extended

Especifica que se debe enviar un atributo de comunidades a un vecino BGP.

ip-address El argumento es la dirección IP del router de la vencidad.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

both La palabra clave especifica que enviarán el estándar y las comunidades ampliadas.

standard La palabra clave especifica que solamente enviarán las comunidades estándar.

extended La palabra clave especifica que solamente enviarán las comunidades ampliadas.

Paso 11 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Verificación de que esa Carga a Compartir Ocurre entre Loopbacks

Realice esta tarea de verificar que la carga a compartir ocurre entre los loopback. Usted necesita asegurarse de que la entrada de las Bases de información de reenvío de etiquetas (LFIB) MPLS para la ruta vecina enumere los trayectos disponibles y las interfaces.

PASOS SUMARIOS

1. enable

2.show mpls forwarding-table [network {mask | length} | labels label []- label | interface interface | next-hop address | lsp-tunnel []tunnel-iddel []del []vrf vrf-name]detail

3. disable

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

(Opcional) Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

show mpls forwarding-table [network {mask | length} | labels label [-label] | interface interface | next-hop address | lsp-tunnel [tunnel-id]] [vrf vrf-name] [detail]

Example:

Router# show mpls forwarding-table

Muestra el contenido de LFIB de MPLS.

Ingrese una palabra clave optativa o un argumento si está deseado.

Paso 3 

disable

Example:

Router# disable

Sale al modo EXEC de usuario.

Configurando el peering directamente conectado del loopback para el MPLS VPN Inter-COMO usando los ASBR para intercambiar las rutas y las escrituras de la etiqueta del IPv4

Las secciones siguientes describen cómo configurar el peering de las interfaces del loopback de los ASBR directamente conectados para alcanzar la carga a compartir en una red del sistema interautonomous:

Configurando a las direcciones del Loopback Interface para los ASBR directamente conectados (requeridos)

Configurando las Static rutas de /32 al loopback del vecino eBGP (requerido)

Configurando la expedición en la conexión del loopback interconecta (requerido)

Configurando a una sesión eBGP entre los loopback (requeridos)

Verificar esa carga a compartir ocurre entre los loopback (opcionales)

El cuadro 4 muestra el Loopback Configuration para conectado directamente ASBR1 y ASBR2. Esta configuración se utiliza como ejemplo en las tareas siguientes.

Cuadro 4 Loopback Interface Configuration para conectado directamente ASBR1 y ASBR2

Configurar las direcciones de la interfaz loopback para ASBR conectados directamente

Realice esta tarea de configurar a las direcciones del Loopback Interface.


Los Loopback Addressde la nota necesitan ser configurados para cada ASBR directamente conectado. Es decir, configure un Loopback Address para ASBR1 y para ASBR2 según lo en el ejemplo mostrado en el cuadro 4.


PASOS SUMARIOS

1. enable

2. configure terminal

3. interface loopback interface-number

4.ip address ip-address mask []secondary

5. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface loopback interface-number

Example:

Router(config)# interface loopback 0

Configura una interfaz virtual de software solamente que emula una interfaz que siempre está activada ascendente e ingresa en el modo de configuración de interfaz.

interface-number El argumento es el número del Loopback Interface que usted quiere crear o configurar. No hay límite para el número de interfaces Loopback que se pueden crear.

Paso 4 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Fija una dirección IP primaria o secundaria para una interfaz.

ip-address El argumento es la dirección IP.

mask El argumento es la máscara para la subred IP asociada.

secondary La palabra clave especifica que la dirección configurada es una driección IP secundaria. Si se omite esta palabra clave, la dirección configurada es la dirección IP primaria.

Paso 5 

end

Example:

Router(config-if)# end

Sale al modo EXEC privilegiado.

Configuración de Rutas Estáticas /32 al Loopback del Vecino eBGP

Realice esta tarea para configurar las rutas estáticas /32 al loopback del vecino eBGP.


Nota queusted necesita configurar las Static rutas de /32 en cada uno de los ASBR directamente conectados.


PASOS SUMARIOS

1. enable

2. configure terminal

3.ip route prefix mask {ip-address | interface-type interface-number []ip-address}
[]distancedel []namedel []permanentdel []tag tag

4. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [permanent] [tag tag]

Example:

Router(config)# ip route 10.20.20.20 255.255.255.255 Ethernet 1/0 172.16.0.1

Establece las rutas estáticas.

prefix El argumento es el prefijo de la ruta de IP para el destino.

mask El argumento es la máscara del prefijo para el destino.

ip-address El argumento es la dirección IP del salto siguiente que usted puede utilizar para alcanzar la red específicada.

interface-type Y interface-number los argumentos son el tipo y el Número de interfaz de interfaz de la red.

distance El argumento es una distancia administrativa.

name El argumento aplica un nombre a la ruta especificado.

permanent La palabra clave especifica que la ruta no debe ser quitada, incluso si la interfaz apaga.

tag tag La palabra clave y el argumento nombran un valor de la etiqueta que se pueda utilizar como valor de la “coincidencia” para la redistribución que controla con el uso de los mapa del ruta.

Paso 4 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configuración del Reenvío en la Conexión de Interfaces Loopback

Realice esta tarea para configurar el reenvío en las interfaces Loopback de conexión.

Esta tarea es necesaria para las sesiones entre loopbacks. En “configurando las Static rutas de /32 la tarea al loopback del vecino eBGP”, Ethernet1/0 y el Ethernet0/0 son las interfaces de conexión.

PASOS SUMARIOS

1. enable

2. configure terminal

3.interface type slot/port

4. mpls bgp forwarding

5. exit

6.Relance los pasos 3 y 4 para otra interfaz de conexión (el Ethernet0/0)

7. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type slot/port

Example:

Router(config)# interface ethernet 1/0

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

type El argumento es el tipo de interfaz que se configurará.

slot El argumento es el número de slot. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

/port El argumento es el número del puerto. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

Paso 4 

mpls bgp forwarding

Example:

Router(config-if)# mpls bgp forwarding

Configura BGP para habilitar el reenvío MPLS en las interfaces de conexión.

Paso 5 

exit

Example:

Router(config-if)# exit

Sale al modo de configuración global.

Paso 6 

Repita los pasos 3 y 4 para otra interfaz de conexión (Ethernet0/0).

Paso 7 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configuración de una Sesión eBGP entre los Loopbacks

Realice las tareas siguientes de configurar a una sesión eBGP entre los loopback.


Nota queusted necesita configurar a una sesión eBGP entre los loopback en cada ASBR directamente conectado.


PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5.neighbor {ip-address | peer-group-name} remote-as as-number

6.neighbor {ip-address | peer-group-name} disable-connected-check

7.neighbor {ip-address | ipv6-address | peer-group-name} update-source
interface-type interface-number

8.address-family ipv4 []unicast vrf vrf-name

9.neighbor {ip-address | peer-group-name | ipv6-address} activate

10.neighbor {ip-address | peer-group-name} send-community [both | standard | extended]

11. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:
Router(config)# router bgp 200

Configura el proceso de ruteo BGP, y ingresa al modo de configuración del router.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante.

Paso 4 

bgp log-neighbor-changes

Example:

Router(config-router)# bgp log-neighbor-changes

Habilita el registro de reinicios del vecino BGP.

Paso 5 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router)# neighbor 10.20.20.20 remote-as 100

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

as-number El argumento es el número del sistema autónomo al cual el vecino pertenece.

Paso 6 

neighbor {ip-address | peer-group-name} disable-connected-check

Example:

Router(config-router)# neighbor 10.20.20.20 disable-connected-check

Permite el peering entre loopbacks.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

Paso 7 

neighbor {ip-address | ipv6-address | peer-group-name} update-source interface-type interface-number

Example:

Router(config-router)# neighbor 10.20.20.20 update-source Loopback 0

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

ip-address El argumento es el direccionamiento del IPv4 del vecino de BGP-discurso.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Observeeste argumento debe estar en la forma documentada en RFC 2373, donde el direccionamiento se especifica en el hexadecimal usando los valores de 16 bits entre los dos puntos.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

interface-type El argumento es el tipo de interfaz.

interface-number El argumento es el Número de interfaz.

Paso 8 

address-family ipv4 [unicast] vrf vrf-name

Example:

Router(config-router)# address-family ipv4

Ingresa al modo de configuración de familia de direcciones para configurar Routing Protocols como BGP, Routing Information Protocol (RIP) y el ruteo estático.

unicast La palabra clave especifica los prefijos del unicast.

vrf vrf-name La palabra clave y el argumento especifican el nombre de un VPN Routing/Forwarding Instance (VRF) para asociarse a los comandos del submode.

Paso 9 

neighbor {ip-address | peer-group-name | ipv6-address} activate

Example:

Router(config-router-af)# neighbor 10.20.20.20 activate

Habilita el intercambio de información con un vecino BGP.

ip-address El argumento es la dirección IP del router de la vencidad.

peer-group-name El argumento es el nombre del grupo de peer de BGP.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Observeeste argumento debe estar en la forma documentada en RFC 2373, donde el direccionamiento se especifica en el hexadecimal usando los valores de 16 bits entre los dos puntos.

Paso 10 

neighbor {ip-address | peer-group-name} send-community [both | standard | extended]

Example:

Router(config-router-af)# neighbor 10.20.20.20 send-community extended

Especifica que se debe enviar un atributo de comunidades a un vecino BGP.

ip-address El argumento es la dirección IP del router de la vencidad.

peer-group-name El argumento es el nombre del grupo de peer de BGP.

both La palabra clave especifica que enviarán el estándar y las comunidades ampliadas.

standard La palabra clave especifica que solamente enviarán las comunidades estándar.

extended La palabra clave especifica que solamente enviarán las comunidades ampliadas.

Paso 11 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Verificación de que esa Carga a Compartir Ocurre entre Loopbacks

Para verificar que la carga a compartir pueda ocurrir entre los loopback, asegúrese de que la entrada MPLS LFIB para la ruta vecina enumere los trayectos disponibles y las interfaces.

PASOS SUMARIOS

1. enable

2.show mpls forwarding-table [network {mask | length} | labels label []-label | interface interface | next-hop address | lsp-tunnel []tunnel-iddel []del []vrf vrf-name]detail

3. disable

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

show mpls forwarding-table [network {mask | length} | labels label [-label] | interface interface | next-hop address | lsp-tunnel [tunnel-id]] [vrf vrf-name] [detail]

Example:

Router# show mpls forwarding-table

Muestra el contenido de LFIB de MPLS.

Ingrese una palabra clave o un argumento, si está deseado.

Paso 3 

disable

Example:

Router# disable

Sale al modo EXEC de usuario.

Configurar el peering directamente conectado del loopback en el portador del MPLS VPN que soporta el portador

Las secciones siguientes explican cómo cargar el tráfico del CSC de la balanza por las interfaces de mirada del loopback del Routers directamente conectado CSC-PE y CSC-CE:

Configurando a las direcciones del Loopback Interface en el Routers CSC-PE (requerido)

Configurando a las direcciones del Loopback Interface para el Routers CSC-CE (requerido)

Configurando las Static rutas de /32 al loopback del vecino eBGP en el router CSC-PE (requerido)

Configurando las Static rutas de /32 al loopback del vecino eBGP en el router CSC-CE (requerido)

Configurando la expedición en las interfaces CSC-PE que conectan con el loopback CSC-CE (requerido)

Configurando la expedición en las interfaces CSC-CE que conectan con el loopback CSC-PE (requerido)

Configurando a una sesión eBGP entre el router CSC-PE y el loopback CSC-CE (requeridos)

Configurando a una sesión eBGP entre el router CSC-CE y el loopback CSC-PE (requeridos)

Verificar esa carga a compartir ocurre entre los loopback (opcionales)

El cuadro 5 muestra el Loopback Configuration para el Routers directamente conectado CSC-PE y CSC-CE. Esta configuración se utiliza como ejemplo en las tareas siguientes.

Cuadro 5 Loopback Interface Configuration para el Routers directamente conectado CSC-PE y CSC-CE

Configurar a las direcciones del Loopback Interface en el Routers CSC-PE

Realice esta tarea de configurar a las direcciones del Loopback Interface en el router CSC-PE.


La configuraciónde la nota de una dirección del Loopback Interface en el router CSC-PE requiere habilitar de un VRF. El Loopback Interface del router CSC-CE no requiere la a que habilita del VRF.


PASOS SUMARIOS

1. enable

2. configure terminal

3.interface loopback interface-number

4. ip vrf forwarding vrf-name

5.ip address ip-address mask []secondary

6. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface loopback interface-number

Example:

Router(config)# interface loopback 0

Configura una interfaz virtual software solamente que emule a una interfaz que esté siempre para arriba, y ingrese al modo de configuración de la interfaz.

interface-number El argumento es el número del Loopback Interface que usted quiere crear o configurar. No hay límite para el número de interfaces Loopback que se pueden crear.

Paso 4 

ip vrf forwarding vrf-name

Example:

Router(config-if)# ip vrf forwarding vpn1

Asocia un VRF a la interfaz o subinterfaz especificada.

vrf-name El argumento es el nombre asignado a un VRF.

Paso 5 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.20.20.20 255.255.255.255

Fija una dirección IP primaria o secundaria para una interfaz.

ip-address El argumento es la dirección IP.

mask El argumento es la máscara para la subred IP asociada.

secondary La palabra clave especifica que la dirección configurada es una driección IP secundaria. Si se omite esta palabra clave, la dirección configurada es la dirección IP primaria.

Paso 6 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configurar a las direcciones del Loopback Interface para el Routers CSC-CE

Realice esta tarea de configurar a las direcciones del Loopback Interface para el Routers CSC-CE.

PASOS SUMARIOS

1. enable

2. configure terminal

3. interface loopback interface-number

4.ip address ip-address mask []secondary

5. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface loopback interface-number

Example:

Router(config)# interface loopback 0

Configura una interfaz virtual software solamente que emule a una interfaz que esté siempre para arriba.

interface-number El argumento es el número del Loopback Interface que usted quiere crear o configurar. No hay límite para el número de interfaces Loopback que se pueden crear.

Paso 4 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.10.10.10 255.255.255.255

Fija una dirección IP primaria o secundaria para una interfaz.

ip-address El argumento es la dirección IP.

mask El argumento es la máscara para la subred IP asociada.

secondary La palabra clave especifica que la dirección configurada es una driección IP secundaria. Si se omite esta palabra clave, la dirección configurada es la dirección IP primaria.

Paso 5 

end

Example:

Router(config-if)# end

Sale al modo EXEC privilegiado.

Configurar las Static rutas de /32 al loopback del vecino eBGP en el router CSC-PE

Realice la tarea siguiente de configurar las Static rutas de /32 al loopback del vecino eBGP en el router CSC-PE.

PASOS SUMARIOS

1. enable

2. configure terminal

3.ip route vrf vrf-name prefix mask {ip-address | interface-type interface-number []ip-address}
[]globaldel []distancedel []namedel []permanentdel []tag tag

4. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip route vrf vrf-name prefix mask {ip-address | interface-type interface-number [ip-address]} [global] [distance] [name] [permanent] [tag tag]

Example:

Router(config)# ip route vrf vpn1 10.10.10.10 255.255.255.255 Ethernet 1/0 172.16.0.2

Establece las Static rutas para un VRF.

vrf-name El argumento es el nombre del VRF para la Static ruta.

prefix El argumento es el prefijo de la ruta de IP para el destino.

mask El argumento es la máscara del prefijo para el destino.

ip-address El argumento es la dirección IP del salto siguiente que usted puede utilizar para alcanzar la red de destino.

interface-type Y interface-number los argumentos son el tipo y el Número de interfaz de interfaz de la red.

global La palabra clave especifica que la dirección del salto siguiente dada está en la tabla de ruteo del nonVRF.

distance El argumento es una distancia administrativa.

name El argumento aplica un nombre a la ruta especificado.

permanent La palabra clave especifica que la ruta no debe ser quitada, incluso si la interfaz apaga.

tag tag La palabra clave y el argumento nombran un valor de la etiqueta que se pueda utilizar como valor de la “coincidencia” para la redistribución que controla vía los mapa del ruta.

Paso 4 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configurar las Static rutas de /32 al loopback del vecino eBGP en el router CSC-CE

Realice la tarea siguiente de configurar las Static rutas de /32 al loopback del vecino eBGP para el router CSC-CE.

PASOS SUMARIOS

1. enable

2. configure terminal

3.ip route prefix mask {ip-address | interface-type interface-number []ip-address}
[]distancedel []namedel []permanentdel []tag tag

4. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [permanent] [tag tag]

Example:

Router(config)# ip route 10.20.20.20 255.255.255.255 Ethernet 1/0 172.16.0.1

Establece las rutas estáticas.

prefix El argumento es el prefijo de la ruta de IP para el destino.

mask El argumento es la máscara del prefijo para el destino.

ip-address El argumento es la dirección IP del salto siguiente que usted puede utilizar para alcanzar la red de destino.

interface-type Y interface-number los argumentos son el tipo y el Número de interfaz de interfaz de la red.

distance El argumento es una distancia administrativa.

name El argumento aplica un nombre a la ruta especificado.

permanent La palabra clave especifica que la ruta no debe ser quitada, incluso si la interfaz apaga.

tag tag La palabra clave y el argumento nombran un valor de la etiqueta que se pueda utilizar como valor de la “coincidencia” para la redistribución que controla vía los mapa del ruta.

Paso 4 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configurando la expedición en las interfaces CSC-PE que conectan con el loopback CSC-CE

Realice esta tarea de configurar la expedición en las interfaces CSC-PE que conectan con el loopback CSC-CE.

PASOS SUMARIOS

1. enable

2. configure terminal

3.interface type slot/port

4. ip vrf forwarding vrf-name

5.ip address ip-address mask []secondary

6. mpls bgp forwarding

7. exit

8.Relance los pasos 3 a 6 para otra interfaz de conexión (Ethernet0/0).

9. end

PASOS DETALLADOS — CSC-PE

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type slot/port

Example:

Router(config)# interface ethernet 1/0

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

type El argumento es el tipo de interfaz que se configurará.

slot El argumento es el número de slot. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

/port El argumento es el número del puerto. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

Paso 4 

ip vrf forwarding vrf-name

Example:

Router(config-if)# ip vrf forwarding vpn1

Asocia un VRF a una interfaz o subinterfaz.

vrf-name El argumento es el nombre asignado a un VRF.

Paso 5 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 172.16.0.1 255.255.255.255

Fija una dirección IP primaria o secundaria para una interfaz.

ip-address El argumento es la dirección IP.

mask El argumento es la máscara para la subred IP asociada.

secondary La palabra clave especifica que la dirección configurada es una driección IP secundaria. Si se omite esta palabra clave, la dirección configurada es la dirección IP primaria.

Paso 6 

mpls bgp forwarding

Example:

Router(config-if)# mpls bgp forwarding

Configura BGP para habilitar el reenvío MPLS en las interfaces de conexión.

Paso 7 

exit

Example:

Router(config-if)# exit

Sale al modo de configuración global.

Paso 8 

Relance los pasos 3 a 6 para otra interfaz de conexión (Ethernet0/0).

Paso 9 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configurando la expedición en las interfaces CSC-CE que conectan con el loopback CSC-PE

Realice esta tarea de configurar la expedición en las interfaces CSC-CE que conectan con el loopback CSC-PE.

PASOS SUMARIOS

1. enable

2. configure terminal

3.interface type slot/port

4. mpls bgp forwarding

5. exit

6.Relance los pasos 3 y 4 para otra interfaz de conexión (Ethernet0/0).

7. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

interface type slot/port

Example:

Router(config)# interface ethernet 1/0

Configura un tipo de interfaz e ingresa en el modo de configuración de la interfaz.

type El argumento es el tipo de interfaz que se configurará.

slot El argumento es el número de slot. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

/port El argumento es el número del puerto. Refiérase al manual de hardware pertinente para obtener información sobre el slot y el puerto.

Paso 4 

mpls bgp forwarding

Example:

Router(config-if)# mpls bgp forwarding

Configura BGP para habilitar el reenvío MPLS en las interfaces de conexión.

Paso 5 

exit

Example:

Router(config-if)# exit

Sale al modo de configuración global.

Paso 6 

Repita los pasos 3 y 4 para otra interfaz de conexión (Ethernet0/0).

Paso 7 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configurar a una sesión eBGP entre el router CSC-PE y el loopback CSC-CE

Realice esta tarea de configurar a una sesión eBGP entre el router CSC-PE y el loopback CSC-CE.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5.neighbor {ip-address | peer-group-name} remote-as as-number

6.neighbor {ip-address | peer-group-name} disable-connected-check

7.neighbor {ip-address | ipv6-address | peer-group-name} update-source
interface-type interface-number

8.address-family ipv4 []unicast vrf vrf-name

9. ip vrf forwarding vrf-name

10.neighbor {ip-address | peer-group-name | ipv6-address} activate

11neighbor ip-address enviar-escritura de la etiqueta

12. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:
Router(config)# router bgp 200

Configura el proceso de ruteo de BGP.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante.

Paso 4 

bgp log-neighbor-changes

Example:

Router(config-router)# bgp log-neighbor-changes

Habilita el registro de reinicios del vecino BGP.

Paso 5 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router)# neighbor 10.10.10.10 remote-as 100

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

as-number El argumento es el sistema autónomo al cual el vecino pertenece.

Paso 6 

neighbor {ip-address | peer-group-name} disable-connected-check

Example:

Router(config-router)# neighbor 10.10.10.10 disable-connected-check

Permite el peering entre loopbacks.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

Paso 7 

neighbor {ip-address | ipv6-address | peer-group-name} update-source interface-type interface-number

Example:

Router(config-router)# neighbor 10.10.10.10 update-source Loopback 0

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

ip-address El argumento es el direccionamiento del IPv4 del vecino de BGP-discurso.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Este argumento debe utilizar el formato documentado en RFC 2373, donde la dirección se especifica en formato hexadecimal con valores de 16 bits entre signos de dos puntos.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

interface-type El argumento es el tipo de interfaz.

interface-number El argumento es el Número de interfaz.

Paso 8 

address-family ipv4 [unicast] vrf vrf-name

Example:

Router(config-router)# address-family ipv4 vrf vpn1

Ingresa al modo de configuración de familia de direcciones para configurar Routing Protocols como BGP, Routing Information Protocol (RIP) y el ruteo estático.

ipv4 La palabra clave configura las sesiones que llevan los prefijos de dirección estándar del IPv4.

unicast La palabra clave especifica los prefijos del unicast.

vrf vrf-name La palabra clave y el argumento especifican el nombre de un VRF para asociarse a los comandos del submode.

Paso 9 

ip vrf forwarding vrf-name

Example:

Router(config-router-af)# ip vrf forwarding vpn1

Asocia un VRF a una interfaz o subinterfaz.

vrf-name El argumento es el nombre asignado a un VRF.

Paso 10 

neighbor {ip-address | peer-group-name | ipv6-address} activate

Example:

Router(config-router-af)# neighbor 10.10.10.10 activate

Habilita el intercambio de información con un vecino BGP.

ip-address El argumento es la dirección IP del router de la vencidad.

peer-group-name El argumento es el nombre del grupo de peer de BGP.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Observeeste argumento debe estar en la forma documentada en RFC 2373, donde el direccionamiento se especifica en el hexadecimal usando los valores de 16 bits entre los dos puntos.

Paso 11 

neighbor ip-address send-label

Example:

Router(config-router-af)# neighbor 10.10.10.10 send-label

Permite a un router BGP enviar etiquetas MPLS con rutas BGP a un router BGP vecino.

ip-address El argumento es la dirección IP del router de la vencidad.

Paso 12 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Configurar a una sesión eBGP entre el router CSC-CE y el loopback CSC-PE

Realice esta tarea de configurar a una sesión eBGP entre el router CSC-CE y el loopback CSC-PE.

PASOS SUMARIOS

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5.neighbor {ip-address | peer-group-name} remote-as as-number

6.neighbor {ip-address | peer-group-name} disable-connected-check

7.neighbor {ip-address | ipv6-address | peer-group-name} update-source
interface-type interface-number

8.address-family ipv4 []unicastdel []vrf vrf-name

9.neighbor {ip-address | peer-group-name | ipv6-address} activate

10.neighbor ip-address enviar-escritura de la etiqueta

11. end

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

configure terminal

Example:

Router# configure terminal

Ingresa en el modo de configuración global.

Paso 3 

router bgp as-number

Example:
Router(config)# router bgp 200

Configura el proceso de ruteo de BGP.

as-number El argumento indica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante.

Paso 4 

bgp log-neighbor-changes

Example:

Router(config-router)# bgp log-neighbor-changes

Habilita el registro de reinicios del vecino BGP.

Paso 5 

neighbor {ip-address | peer-group-name} remote-as as-number

Example:

Router(config-router)# neighbor 10.20.20.20 remote-as 100

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

as-number El argumento es el sistema autónomo al cual el vecino pertenece.

Paso 6 

neighbor {ip-address | peer-group-name} disable-connected-check

Example:

Router(config-router)# neighbor 10.20.20.20 disable-connected-check

Permite el peering entre loopbacks.

ip-address El argumento es la dirección IP del vecino.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

Paso 7 

neighbor {ip-address | ipv6-address | peer-group-name} update-source interface-type interface-number

Example:

Router(config-router)# neighbor 10.20.20.20 update-source Loopback 0

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

ip-address El argumento es el direccionamiento del IPv4 del vecino de BGP-discurso.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Este argumento debe utilizar el formato documentado en RFC 2373, donde la dirección se especifica en formato hexadecimal con valores de 16 bits entre signos de dos puntos.

peer-group-name El argumento es el nombre de un grupo de peer de BGP.

interface-type El argumento es el tipo de interfaz.

interface-number El argumento es el Número de interfaz.

Paso 8 

address-family ipv4 [unicast] [vrf vrf-name]

Example:

Router(config-router)# address-family ipv4

Ingresa al modo de configuración de la familia del direccionamiento para configurar los Routing Protocol tales como BGP, RIP, y Static Routing.

ipv4 La palabra clave configura las sesiones que llevan los prefijos de dirección estándar del IPv4.

unicast La palabra clave especifica los prefijos del unicast.

vrf vrf-name La palabra clave y el argumento especifican el nombre de un VRF para asociarse a los comandos del submode.

Paso 9 

neighbor {ip-address | peer-group-name | ipv6-address} activate

Example:

Router(config-router-af)# neighbor 10.20.20.20 activate

Habilita el intercambio de información con un vecino BGP.

ip-address El argumento es la dirección IP del router de la vencidad.

peer-group-name El argumento es el nombre del grupo de peer de BGP.

ipv6-address El argumento es el direccionamiento del IPv6 del vecino de BGP-discurso.

Observeeste argumento debe estar en la forma documentada en RFC 2373, donde el direccionamiento se especifica en el hexadecimal usando los valores de 16 bits entre los dos puntos.

Paso 10 

neighbor ip-address send-label

Example:

Router(config-router-af)# neighbor 10.20.20.20 send-label

Permite a un router BGP enviar etiquetas MPLS con rutas BGP a un router BGP vecino.

ip-address El argumento es la dirección IP del router de la vencidad.

Paso 11 

end

Example:

Router(config)# end

Sale al modo EXEC privilegiado.

Verificación de que esa Carga a Compartir Ocurre entre Loopbacks

Para verificar que la carga a compartir ocurra entre los loopback, asegúrese de que la entrada MPLS LFIB para la ruta vecina enumere los trayectos disponibles y las interfaces.

PASOS SUMARIOS

1. enable

2.show mpls forwarding-table []vrf vrf-name[{network {mask | length} | labels label []- label | interface interface | next-hop address | lsp-tunnel []tunnel-iddel []}]detail

3. disable

PASOS DETALLADOS

 
Comando o acción
Propósito

Paso 1 

enable

Example:

Router> enable

Habilita el modo EXEC privilegiado.

Ingrese su contraseña si se le pide que lo haga.

Paso 2 

show mpls forwarding-table [vrf vrf-name] [{network {mask | length} | labels label [- label] | interface interface | next-hop address | lsp-tunnel [tunnel-id]}] [detail]

Example:

Router# show mpls forwarding-table

Muestra el contenido de LFIB de MPLS.

Paso 3 

disable

Example:

Router# disable

Sale al modo EXEC de usuario.

Ejemplos de Configuración de Load Sharing MPLS VPN Traffic

Esta sección contiene los ejemplos de configuración siguientes para el tráfico del MPLS VPN de la carga a compartir:

Configuración de un Router para Seleccionar las Trayectorias eBGP o iBGP como Trayectorias Múltiples: Ejemplo:

Configuración de una Ruta Estática /32 desde un ASBR a la Dirección de Loopback de otro ASBR: Ejemplos

Configuración del Reenvío BGP/MPLS en las Interfaces que Conectan con ASBRs: Ejemplo:

Configuración de las Sesiones de VPNv4 en un ASBR: Ejemplo:

Verificación de VPN NLRI para una Red Especificada: Ejemplo:

Configuración de un Router para Seleccionar las Trayectorias eBGP o iBGP como Trayectorias Múltiples: Ejemplo:

El siguiente ejemplo configura a un router en el modo de configuración de la familia del direccionamiento para seleccionar seis eBGP o trayectorias del iBGP como multipaths:

Router(config)# router bgp 100
Router(config-router)# address-family ipv4 vrf try
Router(config-router-af)# maximum-paths eibgp 6
Router(config-router-af)# end

Configuración de una Ruta Estática /32 desde un ASBR a la Dirección de Loopback de otro ASBR: Ejemplos

El siguiente ejemplo configura una Static ruta de /32 de ASBR1 al Loopback Address de ASBR2:

Router# configure terminal
Router(config)# ip route 10.20.20.20 255.255.255 e1/0 168.192.0.1
Router(config)# ip route 10.20.20.20 255.255.255 e0/0 168.192.2.1

El siguiente ejemplo configura una Static ruta de /32 de ASBR2 al Loopback Address de ASBR1:

Router# configure terminal
Router(config)# ip route vrf vpn1 10.10.10.10 255.255.255 e1/0 168.192.0.2
Router(config)# ip route vrf vpn1 10.10.10.10 255.255.255 e0/0 168.192.2.2

Configuración del Reenvío BGP/MPLS en las Interfaces que Conectan con ASBRs: Ejemplo:

El siguiente ejemplo configura la expedición BGP/MPLS en las interfaces que conectan ASBR2 con ASBR1:

Router# configure terminal
Router(config)# interface ethernet 1/0
Router(config-if)# ip vrf forwarding vpn1
Router(config-if)# ip address 168.192.0.1 255.255.255.255
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit
Router(config)# interface ethernet 0/0
Router(config-if)# ip vrf forwarding vpn1
Router(config-if)# ip address 168.192.2.1 255.255.255.255
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit

Configuración de las Sesiones de VPNv4 en un ASBR: Ejemplo:

El siguiente ejemplo configura las sesiones del VPNv4 encendido ASBR2:

Router# configure terminal
Router(config)# router bgp 200
Router(config-router)# bgp log-neighbor-changes
Router(config-router)# neighbor 10.10.10.10 remote-as 100
Router(config-router)# neighbor 10.10.10.10 disable-connected-check
Router(config-router)# neighbor 10.10.10.10 update-source Loopback0
!
Router(config-router)# address-family vpnv4
Router(config-router-af)# neighbor 10.10.10.10 activate
Router(config-router-af)# neighbor 10.10.10.10 send-community extended
Router(config-router-af)# end

Verificación de VPN NLRI para una Red Especificada: Ejemplo:

Si usted ingresa all la palabra clave con show ip bgp vpnv4 el comando, la salida visualiza la información sobre toda la información de alcance de la capa de red VPN (NLRI) para una red específicada:

Router# show ip bgp vpnv4 all 10.22.22.0
BGP routing table entry for 10:1:22.22.22.0/24, version 19
Paths:(5 available, best #5)
Multipath: eiBGP
  Advertised to non peer-group peers:
  10.0.0.2 10.0.0.3 10.0.0.4 10.0.0.5
  22
    10.0.0.2 (metric 20) from 10.0.0.4 (10.0.0.4)
      Origin IGP, metric 0, localpref 100, valid, internal, multipath
      Extended Community:0x0:0:0 RT:100:1 0x0:0:0
      Originator:10.0.0.2, Cluster list:10.0.0.4
  22
    10.0.0.2 (metric 20) from 10.0.0.5 (10.0.0.5)
      Origin IGP, metric 0, localpref 100, valid, internal, multipath
      Extended Community:0x0:0:0 RT:100:1 0x0:0:0
      Originator:10.0.0.2, Cluster list:10.0.0.5
  22
    10.0.0.2 (metric 20) from 10.0.0.2 (10.0.0.2)
      Origin IGP, metric 0, localpref 100, valid, internal, multipath
      Extended Community:RT:100:1 0x0:0:0
  22
    10.0.0.2 (metric 20) from 10.0.0.3 (10.0.0.3)
      Origin IGP, metric 0, localpref 100, valid, internal, multipath
      Extended Community:0x0:0:0 RT:100:1 0x0:0:0
      Originator:10.0.0.2, Cluster list:10.0.0.3
  22
    10.1.1.12 from 10.1.1.12 (10.22.22.12)
      Origin IGP, metric 0, localpref 100, valid, external, multipath, best
      Extended Community:RT:100:1

Referencias adicionales

Las secciones siguientes proporcionan referencias relacionadas con MPLS VPNs.

Documentos Relacionados


Estándares

Estándar
Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.


MIB

MIB
Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html


RFC

RFC
Título

RFC 1164

Aplicación de Border Gateway Protocol en Internet

RFC 1171

Un protocolo Protocolo de la puerta de enlace marginal (BGP) 4

RFC 1700

Números Asignados

RFC 1966

Reflexión de Ruta BGP: Una alternativa al IBGP de la interconexión total

RFC 2283

Extensiones Multiprotocolo para BGP-4

RFC 2373

Arquitectura de direccionamiento del IP versión 6

RFC 2547

BGP/MPLS VPN

RFC 2842

Anuncio de Capacidades con BGP-4

RFC 2858

Extensiones Multiprotocolo para BGP-4

RFC 3107

Cómo Incluir la Información de Etiquetas en BGP-4


Asistencia Técnica

Descripción
Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html


Información sobre la Función Load Sharing MPLS VPN Traffic

La Tabla 1 muestra el historial de versiones de esta función.

Puede que no estén disponibles todos los comandos en su versión de software de Cisco IOS. Para la información de versión sobre un comando específico, vea la documentación de referencia de comandos.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software. Cisco Feature Navigator le permite determinar qué imágenes de Cisco IOS y Catalyst OS Software soportan una versión de software, un conjunto de funciones o una plataforma específica. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.


Observelas listas del cuadro 1 solamente la versión de Cisco IOS Software que introdujo el soporte para una característica dada en un tren de versión del Cisco IOS Software dado. A menos que se indique lo contrario, las versiones posteriores de dicha serie de versiones de software de Cisco IOS también soportan esa función.


Información de la característica del cuadro 1 para el tráfico del MPLS VPN de la carga a compartir 

Nombre de la función
Versiones
Información de la Configuración de la Función

MPLS VPN — Soporte del Equilibrio de carga para Inter-COMO y CSC VPN

12.0(29)S
12.4(20)T

Esta característica permite que las redes del CSC del MPLS VPN Inter-COMO y del MPLS VPN carguen el tráfico de la parte entre los LSR adyacentes que son conectados por los links múltiples. Los LSR pueden ser pares de ASBR o un CSC-PE y un CSC-CE. La utilización de peering de loopback conectado directamente permite el balanceo de carga en el nivel IGP, por lo que no es necesaria más de una sesión de BGP entre los LSR. No se necesita otro mecanismo de distribución de etiquetas entre los LSRs adyacentes más que BGP.

Las secciones siguientes proporcionan información acerca de esta función:

Uso Compartido de la Carga Usando el Peering de Loopback Directamente Conectado

Configuración de Peering de Loopback Directamente Conectado para MPLS VPN Inter-AS que usan ASBRs para Intercambiar Direcciones VPN-IPv4

Carga a compartir del trayecto múltiple de BGP para el eBGP y el iBGP en un MPLS VPN

12.2(4)T
12.2(14)S
12.0(24)S

Esta característica permite los sistemas autónomos multihomed y al Routers PE que se configurarán para distribuir el tráfico a través de las trayectorias del BGP externo (eBGP) y del Internal BGP (iBGP).

Las secciones siguientes proporcionan información acerca de esta función:

BGP Multipath for eBGP and iBGP

Configuración de Carga a Compartir Multitrayectoria para eBGP e iBGP

iBGP Multipath Load Sharing

12.2(2)T
12.2(14)S

Esta característica permite al Router parlante BGP para seleccionar las trayectorias múltiples del iBGP como los mejores trayectos a un destino.

La sección siguiente proporciona la información sobre esta característica:

Carga a Compartir de Trayectoria Múltiple de BGP Interno

eBGP de varios trayectos

12.0(27)S

Esta característica instala los trayectos múltiples en la tabla de IP Routing cuando las trayectorias del eBGP son doctas de un sistema vecino, en vez del mejor trayecto de la cosecha una.

Las secciones siguientes proporcionan información acerca de esta función:

Carga a Compartir de Trayectoria Múltiple de eBGP

Configuración de la Carga a Compartir de Trayectoria Múltiple del eBGP con MPLS VPN Inter-AS

Configurar la carga a compartir del eBGP de varios trayectos con el portador del MPLS VPN que soporta el portador, página 11